Created using
htm2chm 3.0

Download it NOW!


Untitled Document

CISCO Internetworking Technology Overview

Cisco 25xx

Операционная система маршрутизаторов CISCO

Решения Cisco IOS для сетей Novell Netware

Cisco IOS Конфигурирование функций Network Address Translation

Проектирование кампусных сетей

Построение кампусных ATM сетей

Протокол CGMP: Применение IP Multicast

Цифровая сеть передачи данных с интеграцией услуг

Проектирование высокопроизводительных корпоративных сетей


InfoCity

Операционная система маршрутизаторов CISCO

  • Наборы возможностей (feature set) для версии 11.1 (12)

    Я рассматриваю только младшие серии (Cisco 2500, AS5100), про ATM ни слова, про ИБМ протоколы тоже)(потребности в памяти даны для Cisco 2500 - исполнение из флэша)(RMON alarm and events реализованы даже для наборов, в которых нет RMON):

    1. igs-i-l(4 FLASH, 4 DRAM): IP
    2. igs-im-l(4 FLASH, 4 DRAM): IP/RMON
    3. igs-ir-l(8/4): IP/IBM Base
    4. igs-imr-l(8/4): IP/IBM/RMON
    5. igs-in-l(8/4): IP/IPX
    6. igs-imn-l(8/4): IP/IPX/RMON
    7. igs-inr-l(8/4): IP/IPX/IBM Base
    8. igs-imnr-l(8/4): IP/IPX/IBM/RMON
    9. igs-ainr-l(8/8): IP/IPX/IBM/APPN
    10. igs-d-l(8/4): Desktop (с этого уровня начинается AppleTalk, DECnet IV)
    11. igs-dr-l(8/4): Desktop/IBM Base
    12. igs-j-l(8/6): Enterprise (с этого уровня начинается ES-IS и IS-IS, DECnet V, Apoolo domain, VINES, ISO, XNS керберос для login, трансляция протоколов, Xremote)
    13. igs-jm-l(8/6): Enterprise/RMON
    14. igs-aj-l(16/8): Enterprise/APPN
    15. CFRAD(4/4) (Cisco Frame Relay Access Device)
    16. igs-p-l(4/4): Remote Access Server (нет всяких IBМовских и прочих нестандарных вещей, зато есть все, что необходимо для нормальной работы, нет RMONа,ISDN, OSPF, EGP, моста, зато есть трансляция протоколов, TN3270, Xremote, PAD, LAT, NETBEUI через PPP, автоконфигурация модемов)
    17. igs-g-l(4/2): ISDN
    18. LAN FRAD(4/4)
    19. OSPF LAN FRAD(4/4)

    Ошибки версии 11.1 (только те, которые мне интересны)

    11.1(12)

    • если разрешен учет соединения, но не разрешен учет exec, то при 2-ом соединении пользователя Cisco перегружается.
    • не подерживается interrupt-level IP fragmentation
    • DHCP proxy-client не обрабатывает DHCP пакеты от сервера с DHCP-опцией равной нулю
    • RADIUS CLASS аттрибут разрушается, что не позволяет использовать MERIT сервер
    • aaa accounting system start-stop tacacs+ не всегда передает сообщение "system restarted" (не успевает устояться таблица маршрутизации) - используйте: ip host-routing
    • show accounting может вызвать перезагрузку
    • проблема при отсутсвии связи с RADIUS сервером (не предлагает ввести enable password)
    • проблемы с шифровкой длинных (больше 11 символов) паролей администратора - может обрезаться до 11 символов
    • snmp-server trap-source работает неверно
    • pool manager ихогда пожирает память I/O
    • грох по команде no boot system flash (введите полное имя файла)
    • включение сжатия STAC на async линии может подвесить Cisco
    • нельзя использовать ping с пакетом 2048 байт
    • отключение 10Base2 кабеля не опускает интерфейс
    • тунель не работает, если bandwidth больше 2048
    • icmp redirect не посылается, если входной пакет типа ECHO-REPLY
    • BGP с расширенным ACL и default-originate route-map грохается
    • при некоторых усливиях статический маршрут со следующим узлом, достижимым через статический маршрут, не заносится в таблицу
    • не работает trace на собственный ip-адрес
    • не работает сжатие заголовков TCP на выходных линиях PPP
    • надежный PPP-режим не работает на асинхронных линиях
    • сжатие заголовков TCP не совместимо с multilink TCP, а предупреждения об этом не делается

    11.1(11)

    • exec-timeout вырубает даже активный telnet (либо вернитесь к 11.1(10), либо поставьте 0)
    • BGP и OSPF работают нестабильно
    • ip igmp query-interval 0 подвешивает систему
    • низкоскоростные sync/async порты неспособны обрабатывать пакеты размером больше 1500 (поставьте на обоих концах MTU меньше 1498)

    11.1(10)

    • reset script модема не выполняется, если PPP-сессия завершилась нормально
    • tacacs+ вызывает пожирание памяти (начиная с версиии 11.0(10)
    • иногда бывает Bus Error
    • иногда telnet замирает на 20 секунд, нажмите любую клавишу
    • show ip bgp iconsistence-as иногда перезагружает киску
    • расширенный ACL иногда пропускает фрагменты, если включена журнализация
    • по no shutdown для group async киска иногда перезагружается
    • если есть PPP, то иногда происходит Bus error

    более старые модификации я не рассматриваю, но количество их впечатляет Наборы возможностей (feature set) для версии 11.0(16)(у меня есть только 11.0(14))

    Рассматривается только Cisco 2500 (все очень похоже на 11.1, потребности в памяти даны для Cisco 2500 - исполнение из флэша) :

    1. IP(4 MB Flash/2 DRAM)
    2. IP/IBM Base(8/4)
    3. IP/IPX(4/4)
    4. IP/IPX/IBM Base(8/4)
    5. IP/IPX/IBM APPN(8/8)
    6. Desktop(8/4)
    7. Desktop/IBM Base(8/4)
    8. Enterprise(8/6)
    9. Enterprise/APPN(8/8)
    10. CFRAD(4/2)
    11. ISDN(4/2)
    12. LAN FRAD(8/4)
    13. Remote Access Server(4/4)

    Ошибки версии 11.0(только те, которые мне интересны)

    11.0(16):

    • service password-encription обрезает пароли до 11 символов
    • если serial установлен в loopback аппаратным сигналом, то чтобы вывести его из этого состояния, надо выдать команду no loopback

    11.0(14):

    • Cisco 2511 иногда перезагружается со словами sched-3-pagezero: low memory
    • включение TACACS+ приводит к пожиранию памяти (появилось в версии 11.0(10)
    • иногда бывает bus error
    • OSPF иногда приводит к краху
    • расширенный ACL иногда пропускает фрагменты, если включена журнализация
    • если есть PPP, то иногда происходит Bus error
    • иногда подвисает async контроллер вместе с 4 модемами

    11.0(13):

    • когда пингуешь синхронный DDR с установленным сжатием HDLC, маршрутизатор сбрасывается
    • перезагружай каждые 3 недели, если используется SPX
    • не-TCP обратное соединение может вызвать грох маршрутизатора (началось с 11.0(11.1)

    11.0(12):

    • пакеты к TACAS+ могут быть задержаны на 9 секунд, если DNS не сконфигурирован на маршрутизаторе (либо сделайте no ip domain-lookup, либо добавьте IP адрес TACACS+ сервера к локальной таблице хостов)
    • если задача заняла меньше времени, чем потребовалось чтобы достучаться до TACACS+, то stop-запись теряется
    • если alias расширится в строку длиннее 256, то киска грохнется

    11.0(11) и ранее:

    • service compress-config может подвешивать
    • использование DNS для поиска alias грохает киску
    • не надо говорить ip address на подключенный к PPP интерфейс
    • PAP не работает с TACACS+
    • на Cisco 2511 иногда сразу 4 порта меняют DSR при одном событии
    • encapsulation ppp (или async mode dedicated) приводит к паузе неопределенной длины, если выдана для группы
    • при тяжелой загрузке Cisco 2509-2511 могут зависнуть или bus error
    • иногда после copy tftp running отваливается аппаратная синхронизация
    • если использовать autoselect в комбинации с TACACS+, то таблица маршрутов будет содержать таблицу маршрутов для IP-адреса по умолчанию, даже если TACACS+ поменял этот адрес
    • расширенный ACL с использованием конечных UDP адресов, работает неверно
    Наборы возможностей (feature set) для версии 11.2 (7a)(у меня есть только 11.2(05))

    Для версии 11.2 параллельно ведутся 3 ветки: 11.2 (наиболее стабильная, только исправления ошибок), 11.2 P (исправление ошибок и новое оборудование), 11.2 F (исправление ошибок, новое оборудование и межплатформенная совместимость).

    Требования к памяти (для версии 11.2 Cisco 2500):

    • Enterprise и выше: 8MB flash, 6MB DRAM
    • все, что ниже: 8MB flash, 4MB DRAM. Я рассматриваю только младшие серии (Cisco 1000, 1600, 2500, 4000, AS5100, AS5200), про ATM ни слова, про ИБМ протоколы тоже.

    Имена файлов см. в http://www.cisco.com/univercd/data/doc/software/11_2/relnotes/rn112.htm

    Image Name Mapping from Release 11.1 to Release 11.2
    Image Name in Release 11.1 or Earlier Image Name in Release 11.2
    Cisco 1005
    c1005-bnxy-mz
            c1005-bny-mz
    c1005-bxy-mz
            c1005-by-mz
    c1005-nxy-mz
            c1005-ny-mz
    c1005-xy-mz
            c1005-y-mz
    c1005-xy2-mz
            c1005-y2-mz
    Cisco 2500 Series
    IP/IPX/IBM/APPN
    igs-ainr-l
            c2500-ainr-l
    Enterprise/APPN
    igs-aj-l
            c2500-ajs-l
    igs-c-l
            c2500-c-l
    Desktop
    igs-d-l
            c2500-d-l
    Desktop/IBM Base
    igs-dr-l
            c2500-ds-l
    igs-f-l
            c2500-f-l
    igs-fin-l
            c2500-fin-l
    ISDN
    igs-g-l
            c2500-g-l
    IP
    igs-i-l
            c2500-i-l
    IP/RMON
    igs-im-l
            c2500-is-l
    IP/IPX/RMON
    igs-imn-l
            c2500-ds-l
    IP/IPX/IBM/RMON
    igs-imnr-l
            c2500-ds-l
    IP/IBM/RMON
    igs-imr-l
            c2500-is-l
    IP/IPX
    igs-in-l
            c2500-d-l
    IP/IBM Base
    igs-ir-l
            c2500-is-l
    IP/IPX/IBM base
    igs-inr-l
            c2500-ds-l
    Enterprise/RMON
    igs-jm-l
            c2500-js-l
    Enterprise
    igs-j-l
            c2500-j-l
    Cisco AS5200
    as5200-iz-l
            c5200-is-l
    as5200-dz-l
            c5200-ds-l
    as5200-jmz-l
            c5200-js-l
    Cisco 4000 Series
    xx-ainr-mz
            c4000-ainr-mz
    xx-aj-mz
            c4000-ajs-mz
    xx-d-mz
            c4000-d-mz
    xx-dr-mz
            c4000-ds-mz
    xx-i-mz
            c4000-is-mz
    xx-in-mz
            c4000-d-mz
    xx-inr-mz
            c4000-ds-mz
    xx-ir-mz
            c4000-is-mz
    xx-j-mz
            c4000-j-mz
    Cisco 4500 Series
    c4500-aj-mz
            c4500-ajs-mz
    c4500-dr-mz
            c4500-ds-mz
    c4500-ir-mz
            c4500-is-mz
    c4500-in-mz
            c4500-d-mz
    c4500-inr-mz
            c4500-ds-mz
    Cisco 7000 Series
    gs7-aj-mz
            c7000-aj-mz
    gs7-ajv-mz
            c7000-ajv-mz
    gs7-jv-mz
            c7000-jv-mz
    gs7-j-mz
            c7000-j-mz
    Cisco 7200 Series
    c7200-aj-mz
            c7200-ajs-mz
    c7200-dr-mz
            c7200-ds-mz
    c7200-j-mz
            c7200-js-mz
    Cisco 7500 Series and Cisco 7000 with RSP7000
    rsp-aj-mz
            rsp-ajsv-mz
    rsp-j-mz
            rsp-jsv-mz
    rsp-ajv-mz
            rsp-ajsv-mz
    rsp-jv-mz
            rsp-jsv-mz

    Каждый набор может иметь 4 модификации: базовая, расширенная (PLUS), шифровка 40 бит, шифровка 56 бит (не на каждой платформе возможны определенные пакеты и их модификации):

    1. c2500-i- IP: параллельная маршрутизация и мост, GRE, совмещенная маршрутизация и мост (начиная с 11.2), IP, LAN extention host, multiring, прозрачные и переводные мосты, VLAN (ISL и IEEE 802.10 - только Cisco 4500 и с версии 11.2 и модификация Plus), Combinet Packet Protocol (CPP - с версии 11.2), Dialer Profiles (с версии 11.2), Frame Relay, Frame Relay Traffic shaping (с 11.2), полумост/полумаршрутизатор (с 11.2), HDLC, PPP, SMDS, switched 56, X.25, полоса пропускания по запросу, настраиваемые приоритеты очередей, dial backup, dial-on-demand, сжатие заголовка, соединения и payroll(?), snapshot routing, weighted fair queuing, BGP, BGP4 (с 11.2), EGP, IGRP, enhanced IGRP, оптимизация EIGRP (с 11.2), поименнованные IP ACL (с 11.2), трансляция сетевых адресов (с 11.2 и Plus), NHRP, маршрутизация по запросу (с 11.2), OSPF, OSPF Not-So-Stubby-Areas (с 11.2), OSPF on demand circuit (RFC 1793 - с 11.2), PIM (protocol independent multicast), policy based routing, RIP, RIP2 (с 11.1), generic traffic shaping (с 11.2), Random Early Detection (RED - с 11.2), resource reservation protocol (RSVP - с 11.2), AutoInstall, автоматическая конфигурация модемов (с 11.1), HTTP-сервер (с 11.2), RMON events and alarms (с 11.1), полный RMON (только 2500, с 11.2 и Plus), SNMP, telnet, списки доступа, расширенные списки доступа, Lock and Key (с 11.2), MAC security for hubs (с 11.2), MD5 routing authentication, шифровка на сетевом уровне (только модификация encrypt), RADIUS (с 11.1), TACACS+, asynchronous master interfaces, PPP, SLIP, CPPP, CSLIP, DHCP, IP pooling, rlogin, telnet, X.25 PAD
    2. c2500- IP/IPX(этот набор отсутствует для 11.2): добавлено IPX, IPXWAN 2.0, ISDN, IPX RIP, NLSP, IPXCP
    3. c2500- Desktop(IP/IPX/AppleTalk/DEC): добавлено AppleTalk 1 и 2, DECnet IV, Virtual Private Dial-UP network (с 11.2), AURP, RTMP, SMRP, ARAP 1.0/2.0, ATCP, MacIP
    4. c2500- Enterpise: добавлено Apollo Domain, Banyan Vines, DECnet V, OSI, XNS, Frame Relay SVC (с 11.2), multichassis multilink PPP (MPP - с 11.2), ES-IS, IS-IS, SRTP, Kerberos login (с 11.1), поддержка клиентов Kerberos V (с 11.2), трансляция протоколов (LAT, telnet, PPP, rlogin, X.25, TN3270), IPX и ARAP на виртуальных асинхронных интерфейсах, NASI (с 11.1), NetBEUI поверх PPP (с 11.1), LAT, TN3270, Xremote
    5. c2500- Enterprise and APPN
    6. c2500- IP/IPX/IBM and APPN
    7. c2500- Desktop/IBM and APPN

    Для Cisco 1000 и 1600 (только 11.1 и 11.2):

    1. IP
    2. IP/IPX
    3. IP/Apple Talk
    4. IP/IPX/Apple Talk

    Для Cisco 1005:

    1. IP/OSPF/PIM
    2. IP/Async
    3. IP/IPX/Async

    Для Cisco 2500 и AS5100 дополнительно:

    1. c2500- CFRAD
    2. c2500- LAN FRAD
    3. c2500- ISDN
    4. c2500-p- Remote Access Server (2509-2512 и AS5100): AppleTalk 1 и 2 (с 11.2), DECnet IV (только 11.0), GRE, совмещенная маршрутизация и мост (начиная с 11.2), IP, multiring, IPX, source-route bridging (с 11.2), прозрачный мост (с 11.2), прозрачные и переводные мосты, CPP (с 11.2), dialer profiles (с 11.2), Frame Relay, Frame Relay Traffic shaping (с 11.2), полумост/полумаршрутизатор (с 11.2), HDLC, IPXWAN 2.0, multichassis multilink PPP (MPP - с 11.2), PPP, switched 56, Virtual Private Dial-UP network (с 11.2), X.25, полоса пропускания по запросу, настраиваемые приоритеты очередей, dial backup, dial-on-demand, сжатие заголовка, соединения и payroll(?), snapshot routing, weighted fair queuing, BGP (только 11.0), BGP4 нет совсем, EGP (только 11.0), EIGRP, оптимизация EIGRP (с 11.2), IGRP, NHRP (только 11.0), маршрутизация по запросу (с 11.2), OSPF (только 11.0), PIM, policy based routing, RIP, RIP2 (с 11.1), AURP, IPX RIP, RTMP, generic traffic shaping (с 11.2), utoInstall, автоматическая конфигурация модемов (с 11.1), HTTP-сервер (с 11.2), RMON events and alarms (с 11.1), SNMP, telnet, писки доступа, расширенные списки доступа, Lock and Key (с 11.1), MD5 routing authentication, RADIUS (с 11.1), TACACS+, трансляция протоколов (LAT, telnet, PPP, rlogin, X.25, TN3270), ARAP 1.0/2.0, asynchronous master interfaces, PPP, SLIP, CPPP, CSLIP, ATCP, DHCP, IP pooling, IPX и ARAP на виртуальных асинхронных интерфейсах, IPXCP, MacIP, NASI (с 11.1), NetBEUI поверх PPP (с 11.1), login, telnet, X.25 PAD, LAT, TN3270, Xremote

    Ошибки в версии 11.2 (только те, которые меня задевают).

    11.2(7):

    • иногда перезагрузка по show accounting
    • в chat-script неверно запоминаются cntrl-символы
    • если ip identd и установлен tacacs+, то перезагрузка, если:
      1. используется внешний DNS
      2. TACACS+ сервер упал
      3. пользователь зашел через enable
      4. выдал telnet
    • при форматировании флэша типов A6, A7, AA он не распознается (Intel 28F004S5/08S5/16S5)
    • при удалении ip default-network не удаляется запись о gateway
    • Cisco 2511 через неделю работы может сказать, что нет памяти

    11.2(6):

    • не стоит делать copy tftp flash между двумя кисками
    • если dialer dtr, то киска не поднимает сигнал DTR
    • асинхронный контроллер иногда зависает
    • на низкоскоростных портах обязательно ставить MTU меньше 1498
    • неправильный LCP NAK пакет грохает киску

    11.2(5):

    • telnet может подвисать на 20 секунд
    • расширенный ACL иногда пропускает фрагменты, если задана журнализация

    11.2(4) и ниже:

    • при включении TACACS+ понемногу исчезает память (начиная с 11.0(10)
    • нельзя очистить telnet-сессию с непустым входным буфером
    • иногда группа из 4 последовательных портов зависает
    • пожирание памяти через 29 часов работы
    • быстро завершившиеся задачи не попадают в журнал учета tacacs+
    • обратные соединения не-TCP могут грохнуть киску
    • пакеты к TACAS+ могут быть задержаны на 9 секунд, если DNS не сконфигурирован на маршрутизаторе (либо сделайте no ip domain-lookup, либо добавьте IP адрес TACACS+ сервера к локальной таблице хостов)

    Отличия в версиях (X.25, DECnet, AppleTalk, VINES , IBM , ATM не описаны)

    Новое в версии 11.0 (начиная с 11.0(11) только исправляются ошибки):

    • улучшение в работе с пулом IP-адресов - 11.0(3)
    • Multilink PPP для PPP
    • одновременное использование Flash разных производителей - 11.0(3) - нужен загрузчик 10.2(7a)
    • PPP callback - 11.0(3)
    • куча нового в начальной версии не описана

    Новое в версии 11.1 (начиная с 11.1(6) только исправляются ошибки):

    • NHRP для IPX
    • быстрая установка для статических маршрутов (для backup);
    • быстро-переключаемое GRE (generic routing encapsulation);
    • RIPv2 (подмаски, аутентикация, multicast, внешние метки маршрута);
    • передача информации из EIGRP в NLSP (IPX);
    • input access list для IPX;
    • per host route balancing для IPX;
    • NLSP aggregation (IPX);
    • инкапсуляция IPX в FDDI;
    • сжатие заголовков для IPX (30 байт);
    • маршрутизация VLAN;
    • асинхронный ISDN (V.120);
    • NetBEUI через PPP (NBFCP);
    • автоконфигурация модемов;
    • NASI - dial-out сервис для IPX-сетей;
    • ident (RFC 1413);
    • RADIUS;
    • Locks and keys - с 11.1(1) - динамическая генерация ACL в зависимости от имени пользователя.

    Новое в версии 11.2:

    • маршрутизация по запросу (ODR) - меньше нагрузка, на "глухом" маршрутизаторе не надо конфигурировать протокол маршрутизации;
    • OSPF on demand (RFC 1793) - позволяет использовать OSPF через ISDN, X.25 SVC и модемные линии;
    • OSPF Not-So-Stubby-Areas (NSSA) - позволяет "тупиковым" маршрутизаторам импортировать внешнюю таблицу маршрутов частично (например, только default);
    • BGP4 soft configuration - позволяет конфигурировать BGP4 без сброса кеша;
    • BGP4 multipath support - балансировка загрузки между многими exterior BGP;
    • BGP4 prefix filtering with inbound route maps - позволяет задать уровень агрегирования внешних таблиц маршрутизации;
    • Network Address Translation (NAT) - позволяет подсоединять хосты и подсети с локальными IP адресами к Internet;
    • поименованные IP ACL;
    • integrated routing and bridging (IRB) - позволяет продолжить VLAN через интерфейсы (IP, IPX, AppleTalk, только прозрачные мосты, не для X.25 и ISDN, не для Cisco 7000, не может работать параллельно с concurrent routing and bridging);
    • показать SAP по имени (IPX);
    • журнализация нарушений IPX ACL;
    • имена протоколов и портов в IPX ACL;
    • конфигурация с помощью HTTP сервера (11.1(5));
    • ClickStart - быстрая конфигурация Cisco 1000;
    • RSVP (протокол резервирования ресурсов) - realtime multimedia приложения;
    • RED (Random Early Detection) - помогает избегать перегрузок сети (сообщает приложениям TCP, чтобы работали помедленнее);
    • generic traffic shaping - помогает избежать перегрузок сети (на уровне 2), приостанавливая ответные пакеты;
    • router authetication;
    • шифровка на сетевом уровне;
    • оптимизация EIGRP;
    • Frame Relay SVC;
    • traffic shaping over Frame Relay;
    • NetFlow switching (только Cisco 7000 и 7500 с Route Switche Processor) - ускоряет применение ACL и сбор статистики;
    • MMP (multichassis multilink PPP) - распараллеливание PPP между каналами с разных кисок (внутри одной было и раньше);
    • TACACS+ single connection (одно TCP соединение на все);
    • SENDAUTH в TACACS+ (увеличение безопасности);
    • VPDN - Virtual Private DialUp Network - по имени PPP организуется туннель до домашней сети пользователя, независимо от физ. природы соединения и безопасный;
    • Dialer profiles;
    • CPP - собственный протокол Combinet - сжатие и распределение нагрузки по нескольким ISDN;
    • полумост/полумаршрутизатор для CPP и PPP - позволяет подсоединять дешевые мосты к ядру сети.

    Покупка IOS

    Заказывать надо продукт с номером, заканчивающимся на знак равенства.

    IOS можно заказать в трех формах:

    1. DOS дискетта (EPROM, Flash);
    2. CD-ROM
    3. загрузка с TFTP сервера (только для устройств с флэш-памятью).

    Номер продукта определяется так:

    • начинается на SF и НЕ кончается на знак равенства - первоначальная загрузка на фабрике
    • начинается на SF и зканчивается на знак равенства - upgrade для Cisco 1003, 1004, 1005 для загрузки во Flash
    • начинается на CD и заканчивается на знак равенства - upgrade для устройства, которое пока содержит пакет (feature set) только IP;
    • начинается на SW и НЕ заканчивается на знак равенства - для загрузки в новую систему;
    • начинается на SW и заканчивается на знак равенства - upgrade для системы, поставленной ранее на ROM или дискетте;
    • начинается на FR - лицензия на использование;
    • начинается на SWR и заканчвается на знак равенства - запасной софт, поставляемый на ROM для Cisco 7000.

    Поставка осуществляется в виде пакетов возможностей (feature packs) - CD-ROM с одним или несколькими образами IOS и инсталляционной программой для MS Windows 95, инструкция по установке (в т.ч. использование TFTP вместо инсталляционной программы), лицензия, CD-ROM с документацией.

    Текущее состояние

    На наших маршрутизаторах стоит IOS версии 11.1 (12) на внутренних и 11.2(5) на внешней, хотя уже выпущена 11.2(7a) 18-jul-97 - на внутренних не хватает флэша под версию 11.2.

    приступаем к работе

    Вынимаем железку, подключаем терминал (или PC с TELEMATE) к консольному порту (или вспомогательный порт ранее сконфигурированной киски и заходим обратным телнетом), все нужные нам кабели (синхронный, Ethernet, модемы), включаем питание и начинаем конфигурирование. При первом включении IOS пытается скачать конфигурацию из глобальной сети - можно подождать несколько минут, чтобы дать ей понять, что на том конце ничего нет, или временно отсоединить синхронный кабель. Потерпев неудачу, IOS предлагает выполнить команду setup - соглашайтесь! В этом случае IOS задает вам несколько вопросов и самостоятельно конфигурируется.

    Конфигурирование осуществляется следующими способами:

    1. командный интерфейс:
      telnet имя-киски
      имя-киски>
      • с терминала: conf term
      • NVRAM: conf memory
      • из сети: conf network
    2. через WWW (начиная с версии 11.0(6), 11.1(5), не все возможности): ip http server
    3. ClickStart (стандартные конфигурации).

    Общие сведения о командном языке:

    1. help - в любой момент можно ввести "?" - киска в ответ выдаст список команд или операндов;
    2. любое ключевое слово или имя можно сокращать до минимально возможного;
    3. если терминал нормально настроен, то можно редактировать командную строку как в emacs или bash.
    4. почти каждую команду можно предварять словом no.

    Уровни привилегий: предусмотрено 16 уровней привилегий - от 0 до 15. Если не производить дополнительной настройки, то уровень 0 - это уровень пользователя: доступны только "безопасные" команды. Уровень 15 - это уровень супервизора: доступны все команды. Переходим с уровня на уровень по команде:
    епable     [номер уровня]
    Любую команду можно перевести на уровень, отличный от стандартного; любому пользователю можно назначить определенный уровень, устанавливаемый при входе на киску этого пользователя; таким образом права пользователей можно тонко настраивать (только help-ом при этом тяжело пользоваться :(

    Режимы командного языка:

    1. Режим пользователя
    2. Привилегированный режим:
      1. верхний уровень
      2. режим глобальной конфигурации
        1. собственно верхний уровень конфигурирования
        2. конфигурирование интерфейса
          1. конфигурирование интерфейса
          2. конфигурирование подинтерфейса (serial в режиме Frame Relay)
        3. конфигурирование контроллера (T1)
        4. конфигурирование хаба (cisco 2500 - ethernet)
        5. конфигурирование списка карт (ATM и FrameRelay)
        6. конфигурирование класса карт (Quality of Service over Switched Virtual Circuit - ATM, FrameRelay или dialer)
        7. конфигурирование линий
        8. конфигурирование маршрутизатора (bgp, egp, igrp, eigrp, is-is, iso-igrp, mobile, OSPF, RIP, static)
        9. конфигурирование IPX-маршрутизатора
        10. конфигурирование карт маршрутизатора
        11. конфигурирование ключевых цепочек с его подрежимами (RIP authentication)
        12. конфигурирование генератора отчетов о времени ответа
        13. конфигурирование БД LANE (ATM)
        14. режим команд APPN с его подрежимами (advance peer-to-peer Networking - второе поколение SNA)
        15. режим команд присоединения канала IBM с его подрежимами (Cisco 7000 с CIP)
        16. режим команд сервера TN3270
        17. конфигурирование списков доступа (для именованых IP ACL)
        18. режим шестнадцатеричного ввода (задание публичного ключа для шифровки)
        19. конфигурирование карт шифровки
      3. ROM монитор (нажать break в первые 60 секунд загрузки, тоже есть help).

    Редактирование командной строки

    Комментарии начинаются с восклицательного знака, но в NVRAM не сохраняются.

    Задать размер истории команд: terminal history size размер

    Предыдущая/следующая команда: Ctrl-P/Ctrl-N или sстрелка вверх/вниз

    Включить/выключить редактирование:
    [no] terminal editing

    символ вперед/назад: Ctrl-F/Ctrl-B или стрелка вперед/назад

    в начало/конец строки: Ctrl-A/Ctrl-E

    на слово вперед/назад: Esc F/Esc B

    развертывание команды: Tab или Ctrl-I

    вспомнить из буфера/вспомнить следующий: Ctrl-Y/Esc Y

    удалить символ слева от курсора/под курсором: Delete/Ctrl-D

    удалить все символы до начала строки/конца строки: Ctrl-U/Ctrl-K

    удалить слово слева от курсора/справа от курсора: Ctrl-W/Esc D

    перерисовать строку: Ctrl-L/Ctrl-R

    поменять символы местами: Ctrl-T

    экранирование символа: Ctrl-V или Esc Q Работа с флэш-памятью (в ней лежит и из нее выполняется IOS) и NVRAM (конфигурация)

    На киске работает ТРИ программы: ROM монитор (это загрузчик и отладчик - тупой до безобразия - попадаем в него если соответствующим образом установлен регистр конфигурации или нажал BREAK во время загрузки и это не запрещено); система в ROM (урезанная и очень старая система IOS - 9.1 - если не удалось найти более подходящую во флэш или по сети или ручная загрузка из ROM монитора) и система во флэш - версия, которуя сам поставил.

    В руководстве делается предупреждение, что на Sun'е сервер TFTP должен быть настроен так, чтобы генерировать и проверять контрольные суммы UDP (я ничего не делал). Везде вместо TFTP можно использовать rcp, но мне лениво следить за безопасностью в этом случае.

    Посмотреть, что там лежит: show flash all

    System flash directory:
File  Length   Name/status
        addr      fcksum  ccksum
  1   3243752  igs-i-l.110-1
        0x40      0xB5C4  0xB5C4
[3243816 bytes used, 950488 available, 4194304 total]
4096K bytes of processor board System flash (Read ONLY)

   Chip    Bank    Code      Size      Name
    1      1       89A2      1024KB    INTEL 28F008SA
    2      1       89A2      1024KB    INTEL 28F008SA
    3      1       89A2      1024KB    INTEL 28F008SA
    4      1       89A2      1024KB    INTEL 28F008SA
Executing current image from System flash

    Иметь два файла во флэш можно только, если имеется два банка памяти (у меня нет) и выполнить специальную процедуру (IOS надо настроить адреса - выполняется-то она из флэша!). Буква l в имени файла как раз и означает, что адреса можно настроить.

    Посмотреть, сколько раз туда чего записывали: show flash err (по-моему, ерунду показывает).

    Копировать из флэш на tftp: copy flash tftp, после чего спросят имя сервера, исходное имя файла и результатирующее имя файла (файл должен существовать с правами 666).

    Копировать конфигурацию на tftp: copy startup-config/running-config tftp

    Загрузить конфигурацию с tftp: copy tftp startup-config/running-config (по-моему, если грузить текущую конфигурацию, то происходит не копирование, а слияние).

    Копировать из tftp во флэш (если достаточно памяти!!!): copy tftp flash

    Понятное дело, что если IOS выполняется из флэш, то грузить новое содержимое флэша во время работы IOS не стоит, надо загрузиться из ROM (либо нажав Break при загрузке, либо выдав no boot system flash).

    Черта-с два! На самом деле все не так как в книжке. Надо выдать copy tftp flash прямо из IOS (ибо в bootstrap такой команды нет вовсе), будет запущен flash load helper, который задает все необходимые вопросы, затем перезапускает киску из ROМа, стирает флэш, копирует файл с tftp (заходить только с консоли - иначе ничего не увидишь, и об ошибках не узнаешь ;). После этого надо сохранить конфигурацию (copy run start). А все-таки интересно, как выбираться из ситуации, если что-то получилось не так. Кстати, рекомендуется сохранить конфигурацию куда-нибудь на tftp перед изменением флэша. p.s. все-таки можно было бы сделать и загрузившись из ROM (только не ROM монитор, а ROM IOS), если задать в регистре конфигурации младшие 4 бита равными 0-0-0-1.

    Копирование текущей конфигурации в загрузочную: copy run start

    Копирование загрузочной конфигурации в текущую: copy start run

    Посмотреть состояние: show version

    Проверить контрольную сумму: verify flash

    Сжатие конфигурационного файла работает только на Cisco 3xxx и Cisco 7xxx.

    Повторно выполнить конфигурационный файл: configure memory

    Очистить конфигурацию: erase startup

    Посмотреть текущую/загрузочную конфигурацию: show run/start

    В NVRAM записываются только параметры, отличные от параметров по умолчанию.

    Регистр конфигурации: 16 бит. Меняется командой: config-register. Младшие 4 бита (3,2,1, и 0) образуют поле загрузки:

    • 0-0-0-0 загрузить ROM-монитор вместо IOS
    • 0-0-0-1 загрузить boot ROM
    • если между 0-0-1-0 и 1-1-1-1 то грузить то, что задано командой boot system (если ничего не задано, то грузить файл с сетевого сервера с именем определяемым по умолчанию: имя формаируется исходя из значения регистра). Можно задать несколько команд boot system. Только не надо задавать имя файла в boot system flash (все равно он ровно один, а то после прошивки новой версии IOS загрузчик будет упрямо искать старый файл).

    Файл конфигурации сети (по умолчанию имя файла: network-config):
    boot network [tftp] имя-файла [ip-адрес]
    service config

    Файл конфигурации хоста (по умолчанию имя файла: network-config):
    boot host [tftp] имя-файла [ip-адрес]
    service config

    Перезагрузка:

    • просто перезагрузка
      reload
    • перезагрузка в определенное время:
      reload at hh:mm [month day] [reason]
    • перезагрузка через определенное время:
      reload in [hh:]mm [reason]
    • отмена отложенной перезагрузки:
      reload cancel

    Автоматизированное конфигурирование

    ClickStart: конфигурирование Cisco 1003, 1004 и 1005 через WWW (однопортовые ISDN, Frame Relay и асинхронные маршрутизаторы).

    AutoInstall: включаешь новый маршрутизатор, он ишет сконфигурированный ранее маршрутизатор (Ethernet, FDDI, HDLC, Frame Relay) - требуется такое количество предварительной подготовки, что легче все сделать вручную (если только не надо установить сотню кисок).

    Setup: интерактивная установка параметров. Требует подключения консольного терминала (я использую AUX порт соседней киски).

    Еще бывает sreamline setup (если установлен RXBOOT ROM) и возникают непреодолимые проблемы: задает минимум вопросов необходимых, чтобы найти загрузочный образ и файл с конфигурацией.

    Сервисы

    Часы (сбрасываются даже при перезагрузке на 1 марта 1993 года) хранятся в формате UTC (Coordinated Universal Time) - то же самое, что и GMT. Используются протоколы NTP (прием и передача - включен по умолчанию - при перезагрузке и при выключении на пару минут время сохраняется), SNTP на кисках серии 1000 (только прием - выключен по умолчанию).

    • посмотреть
      show clock [detail]
    • установить вручную
      clock set hh:mm:ss день месяц год
    • аутентификация NTP:
      • ntp authenticate - включить
      • ntp authentication-key number md value - задать значение ключа
      • ntp trusted-key номер-ключа - знающий этот ключ может синхронизовать нас
    • определить соседей:
      ntp peer ip-address [version номер] [key номер-ключа][source интерфейс] [prefer]
    • определить сервер:
      ntp server ip-address [version номер] [key номер-ключа][source интерфейс] [prefer]
    • широковещательная рассылка
      ntp broadcast [version версия]
    • получать широковещательную рассылку
      ntp broadcast client
    • установить предполагаемое значение задержки при широковещательной рассылке
      ntp broadcastdelay микросекунд
    • управление доступом (номер ACL задается базовой командой access-list)(по умолчанию все разрешено, даже синхронизация с незнакомыми системами! - сделать)
      ntp access-group query-only/serve-only/serve/peer номер-ACL
    • запретить NTP сервис на определенном интерфейсе
      ntp disable
    • если киска имеет несколько IP-адресов то можно определить исходный IP-адрес в NTP-пакетах
      ntp source интерфейс
    • определить киску как властный источник времени, даже если она не синхронизована с внешним миром
      ntp master [слой]
    • задать размер аппаратного тика (теоретически 250 Гц) в единицах 2^-32
      ntp clock-period единиц
    • максимальное число соседей NTP-протокола (сделать!)
      ntp max-associations число
    • посмотреть статус
      show ntp status
    • посмотреть список соседей
      show ntp associations [detail]
    • откуда SNTP будет запрашивать NTP пакеты
      sntp server адрес [version версия]
    • SNTP будет брать NTP пакеты из широковещательных потоков
      sntp broadcast client
    • посмотреть сосотояние SNTP (Cisco 100x)
      show sntp
    • задать часовой пояс - почему только целое число часов?
      clock timezone имя(MSK) смещение(3)
    • задать летнее время (по правилам) (last Sun Mar 2:00 last Sun Sep 2:00)
      clock summer-time имя(MSD) recurring first/last/номер-недели-начала день-недели месяц hh:mm first/last/номер-недели-окончания день-недели месяц hh:mm [смещение-в-минутах]
    • задать летнее время непосредственно
      clock summer-time имя месяц-начала день год hh:mm месяц-окончания день год hh:mm [смещение-в-минутах]
    • на Cisco 4500 и Cisco 7000 есть батареечный календарь

    Запустить TFTP сервер на киске:

    • предоставлять содержимое флэша (там лежит не обязательно IOS):
      tftp-server flash имя-файла [alias синоним] [acl]
    • предоставлять содержимое ROМа (можно одновременно с флэш):
      tftp-server rom имя-файла [alias синоним] [acl]

    Запустить RARP сервер на киске (чтобы это реально использовать необходимо выполнить кучу дополнительных условий - обеспечить broadcast UDP - ip forward-protocol udp 111, заполнить таблицу АRP MAC-адресами клиентов, ip helper-adress адрес-настоящего-сервера - говорят, что проблемы возникли из-за недоделанности rpc.bootparamd в SunOS - судя по нашему принтеру так оно и есть):
    cat(config-if)>ip rarp-server ip-адрес-настоящего-сервера

    rcp и rsh сервис:

    • задание базы данных пользователей (не знаю что за засада, но мне и локальное и внешенее имя пришлось задать свое):
      ip rcmd remote-host local-username ip-address/host remote-username [enable [level]]
    • запуск rcp сервера (а для чего его можно приспособить?):
      ip rcmd rcp-enable
    • запуск rsh сервера (надо избавиться от expect при сборе статистики)
      ip rcmd rsh-enable

    HTTP-сервер (при входе в качестве имени надо говорить имя киски, а пароля - пароль супервизора) - пользы от этого никакой:
    ip http server
    ip http port 80

    Общее управление

    prompt строка - изменение стандартного приглашения
    hostname имя - имя маршрутизатора
    alias уровень-EXEC имя-синоним текст-команды - создание сокращений-синонимов команд
    show aliases [уровень-EXEC] - посмотреть список синонимов
    load-interval секунд - длина интервала вычисления средней загрузки

    Интерфейсы

    общие команды для всех интерфейсов

    description строка-текста
    hold-queue длина in/out - задание размера буфера
    bandwidth kilobits - используется, например, для настройки параметров TCP
    delay десятые-милисекунды - информация для некоторых протоколов маршрутизации (или десятки микросекунд)
    keepalive секунд - как часто посылать пкаеты для проверки живучести линии (интерфейс считается упавшим если в течении 3 интервалов не пришло ответа)
    mtu байт

    последовательный асинхронный

    async: 8 штук на Cisco 2509, 16 штук на Cisco 2511, еще можно использовать AUX порт, но ОЧЕНЬ не советую (дефективная аппаратная реализация: скорость 38400, все на программном уровне - в том числе и синхронизация).

    Саму физическую линию надо конфигурировать отдельно с помощью команды line.

    Вход в режим конфигурации интерфейса:
    interface async номер-порта

    Инкапсуляция: поддерживаются два метода инкапсуляции - SLIP и PPP. О SLIP мы забудем сразу же.

    Режим: интерактивный или жестко настроенный (dedicated): в последнем случае не запускается EXEC, так что нельзя поменять адрес и другие параметры:
    async mode interactive/dedicated

    Разрешить протоколы динамической маршрутизации:
    async dynamic routing

    Групповая конфигурация (столько предупреждений об ошибках, что лучше и не трогать)

    1. определение группы:
      interface group-async unit-number
      общие команды
      member номер индивидуальная-команда
      group-range low-number high-number - тут же начинается построение конфигурации

    хаб (2505, 2507, 2516)

    hub ethernet number port
    no shutdown
    auto-polarity
    link-test
    source-address [MAC-address]     - пропускать только пакеты от этого MAC-адреса

    loopback (позволяет удержать BGP-сессию, даже если другие интерфейсы упадут)

    interface loopback number

    null (позволяет маршрутизировать все ненужное в /dev/null)

    interface null 0

    синхронный последовательный интерфейс (serial)

    interface serial номер
    encapsulation atm-dxi/hdlc/frame-relay/ppp/sdlc-primary/sdlc-secondary/smds/stun/x25 - по умолчанию HDLC (есть обнаружение ошибок, но нет повтора неверно переданных данных)
    compress stac - если загрузка CPU превышает 65%, то выключить
    pulse-time секунд - какую паузу сделать при пропадании несущей

    тунель (инкапсуляция пакетов одного протокола внутри пакетов другого)

    Для чего это надо:

    1. многопротокольная локальная сеть через однопротокольный бэкбон
    2. для обхода протоколов ограничивающих число промежуточных узлов
    3. виртуальные частные сети через WAN

    Компоненты:

    1. протокол-пассажир
    2. протокол-носитель
    3. протокол инкапсуляции (обычно GRE, остальные в исключительных случаях)

    Предупреждения:

    1. большая загрузка CPU
    2. возможное нарушение безопасности
    3. увеличение времени задержки
    4. множественные тунели могут забить канал информацией о маршрутах
    5. протокол маршрутизации может предпочесть тунель как якобы самый короткий маршрут
    6. появление рекурсивных маршрутов

    interface tunnel номер
    тут должно быть описано каким протоколам позволено туннелироваться
    tunnel source ip-address-или-интерфейс
    tunnel destination ip-address-или-интерфейс
    tunnel mode aurp/cayman/dvmrp/eon/gre ip/nos - определяет протокол инкапсуляции
    tunnel checksum - все плохие пакеты будут выкидываться (некоторые протоколы требуют этого)
    tunnel key номер - должны быть одинаковы на обоих концах (слабая защита)
    tunnel sequence-datagramms - отбрасывать пакеты, пришедшие не в том порядке (некоторые протоколы требуют этого)

    управление и мониторинг

    show async status
    show interface async номер
    show compress
    show controller имя-контроллера
    show interface accounting
    show interface тип номер
    clear counters тип номер
    show protocols
    show version
    clear interface тип номер
    clear line номер
    shutdown
    no shutdown
    down-when-looped - считать интерфейс упавшим, если на нем включен loopback (необходимо для backup)

    динамическое выделение IP-адресов из локального пула и удержание их за пользователями

    ip address-pool local
    ip local pool default начальный-ip-адрес конечный-ip-адрес
    interface Group-Async1
    ip unnumbered Ethernet0
    ip tcp header-compression passive
    encapsulation ppp
    bandwidth 112
    delay 20000
    keepalive 10
    async mode interactive
    no cdp enable
    здесь я еще говорил: peer default ip address pool, но она куда-то делась (по-умолчанию небось)
    group-range 1 16

    если чей-то адрес надо задать явно, то скажи:
    member номер peer default ip address IP-адрес

    в версии 11.0(1) не работала, в версии 11.1(12) вроде работает

    конфигурирование в качестве простого терминального сервера

    Пример конфигурации с коментариями.

    service tcp-small-servers # позволяет киске отвечать на всякие мелкие запросы типа echo, chargen и т.д.
    hostname cat2511-wb # имя киски, выдается в приглашении и ,наверное, где-то еще
    сlock timezone MSK 3 # временная зона
    сlock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00 # летнее время
    епable secret <шифрованный пароль> # зашифрованный пароль суперпользователя
    епable password <нешифрованный пароль> # не используется, если есть шифрованный
    ip subnet-zero # не разбирался
    ip tcp synwait-time 120 # зачем это
    ip tcp path-mtu-discovery # автоматическая настройка на размер MTU
    ip accounting-threshold 256 # не разбирался
    ip accounting-list 194.84.39.0 0.0.0.255 # не разбирался
    interface Ethernet0 # начинаем конфигурировать порт Ethernet
    ip address 194.84.39.24 255.255.255.224 # IP адрес и маска ethernet-порта (основной адрес киски)
    ip address 194.87.163.24 255.255.255.224 secondary # если у нас два блока IP-адресов (что у нас было в момент перехода от одного ISP к другому
    ехit # выход из конфигурирования Ethernet
    interface Serial0 # начинаем конфигурировать синхронный последовательный порт
    пo ip address # нет у нас его
    shutdown # -//-
    ехit # выход из конфигурирования порта
    interface Serial1 # начинаем конфигурировать синхронный последовательный порт
    пo ip address # нет у нас его
    shutdown # -//-
    ехit # выход из конфигурирования порта
    ip domain-name deol.ru. # имя нашего домена
    ip name-server 194.84.39.28 # адрес DNS-сервера (может быть до 6 штук)
    ip route 0.0.0.0 0.0.0.0 194.84.39.26 # маршрут по умолчанию (все, что не на наших портах, передаем на более "умную" киску
    snmp-server community public RO # разрешаем SNMP управление (только чтение)
    line con 0 # начинаем конфигурирование консольного порта
    ехec-timeout 0 0 # отключаем тайм-аут
    ехit # выход из конфигурирования порта
    line 1 16 # начинаем конфигурацию асинхронных последовательных портов
    ехec-timeout 0 0 # отключаем тайм-аут
    мodem InOut # отрабатывать модемные сигналы
    аиtocommand telnet 194.84.39.28 # при входе на линию, киска насильно выдает команду telnet..., что не позволяет пользователю делать что-либо еще (если, конечно, не знаешь как из этого выйти)
    transport input none # не позволяет звонить с наших модемов (зайдя на линию обратным телнетом)
    transport preferred none # на всякий случай
    еscape-character NONE # не позволяет выйти из telnet'а
    stopbits 1
    rxspeed 115200 # скорость между модемом и киской
    txspeed 115200 # скорость между киской и модемом
    flowcontrol hardware
    ехit # выход из конфигурирования порта
    line aux 0 # конфигурирование вспомогательного асинхронного последовательного порта
    transport input all # может быть сюда будет подключена консоль другой киски
    ехit # выход из конфигурирования порта
    line vty 0 4 # конфигирирование виртуальных терминалов (на них мы попадаем, когда заходим телнетом на киску)
    ехec-timeout 0 0 # отключаем тайм-аут
    рassword <пароль> # пароль линии; к сожалению, не шифрованный
    login # киска будет спрашивать пароль при заходе на эту линию (в данном случае телнетом)
    ехit # выход из конфигурирования порта

    конфигурирование внешнего сервера доступа (tacacs+)

    Сервер доступа (tacacs+) - это программа, которая крутится на UNIX-компьютере и отвечает на запросы киски типа: есть ли такой пользователь, какие у него права и ведет журнал посещений. Как конфигурировать сервер смотри отдельную главу, а киска конфигурируется так:
    аaa new-model # будем использовать tacacs+, а не старые варианты
    аaa authentication login default tacacs+ enable # по-умолчанию проверяем каждый вход на линию с помощью tacacs+ сервера, а если он не отзывается, то спрашиваем пароль суперпользователя
    аaa authentication ppp default if-needed none # при включении PPP, производим проверку пользователя, если не проверяли его раньше (может это уже можно выключить?)
    аaa authorization exec tacacs+ if-authenticated # проверяем права на запуск EXEC (shell так у киски называется) с помощью сервера tacacs+, а если его нет, то даем разрешение, если личность пользователя удостоверена - только благодаря этой строчке tacacs+ сервер возвращает автокоманду (в нашем случае telnet или ppp)
    аaa authorization commands 1 tacacs+ if-authenticated # проверяем права на исполнение команд уровня 1 (непривилегированных) с помощью сервера tacacs+, а если его нет, то даем разрешение, если личность пользователя удостоверена
    аaa authorization commands 15 tacacs+ if-authenticated # проверяем права на исполнение команд уровня 15
    (привилегированных) с помощью сервера tacacs+, а если его нет, то даем разрешение, если личность пользователя удостоверена
    aaa authorization network tacacs+ if-authenticated # проверка прав, если кто-то лезет к нам по сети с помощью сервера tacacs+, а если его нет, то даем разрешение, если личность пользователя удостоверена
    аaa accounting network stop-only tacacs+ # посылаем учетную запись tacacs+ серверу в случае окончания сетевого события (завершение PPP-сеанса, например)
    аaa accounting connection stop-only tacacs+ # посылаем учетную запись tacacs+ серверу в случае окончания telnet-сеанса
    аaa accounting system stop-only tacacs+ # посылаем учетную запись tacacs+ серверу в случае окончания системного события (например, перезагрузки)
    еще должна работать команда: aaa authentication local-override (если конечно перед ней завести пользователя на киске username admin privilege 15 password <пароль>), которая позволяет использовать локальную базу пользователей, но такие пользователи получаются абсолютно бесправными (даже EXEC не могут запустить :( Отлично! Я использую это для запрета входа пользователя bbs на киску с быстрыми модемами, не разбираясь с tacacs+ сервером.
    tacacs-server host 194.84.39.28 # адрес компьютера, на котором работает tacacs+ сервер
    tacacs-server host 194.84.39.27 # адрес компьютера, на котором работает запасной tacacs+ сервер (в реальности он не работает, но при необходимости можно запустить)
    tacacs-server key <пароль> # ключ, с помощью которого шифруются сообщения между киской и tacacs+ сервером

    Ссылки:
    • словарь терминов
    • словарь терминов Cisco
    • матрица версий
    • безопасность
    • локальная документация на IOS 11.0 на CD-ROM
    • IOS 11.0 на CD-ROM на www.cisco.com
      • Release Notes для маршрутизатора
      • Release Notes для сервера доступа
      • список ошибок
      • загрузка
    • IOS 11.1 на CD-ROM на www.cisco.com
      • Release Notes (здесь же список основных ошибок - меня интересует только 11.1(11) и более поздние
      • список ошибок
      • документация
      • вспомогательная документация
      • загрузка
    • IOS 11.2 на CD-ROM на www.cisco.com
      • Release Notes для основной ветки
      • анонс версии
      • документация
      • конфигурирование для ленивых
      • ошибки
      • загрузка
    • информация об IOS на сервере Cisco
    • новости о софте
    • общее описание продукта - отличия в наборах возможностей и версиях
    • различие в наборах возможностей для различных моделей и требования к ресурсам (память/флэш) для версий 11.1 и 11.2
    • информация об IOS для знающих пароль
      • IOS 11.0
      • IOS 11.1
      • IOS 11.2


InfoCity

Cisco 25xx

* Cisco 2511 и uucp *

Aleksey Kuksenko wrote: > Подскажите, что сказать Cisco 2511/IOS 11.0 - IP only, чтобы UUCP > нормально работал через нее? > Telnet uuhost и rlogin uuhost - login нормальный, дальше кроме INIT-пакетов > ничего не проходит- NAK-NAK-NAK,

Известные грабли, сделай на линиях conf t line 1 16 escape-character NONE exec-character-bits 8 special-character-bits 8 ^z > И еще - extended tacacs не может autocommand на Cisco выполнить, а кто > нибудь может? А еще лучше скрипт... Может tacacs+, но это наверное из специалиство тебе кто-нибудь объяснит...

Та же проблемма была решена добавлением в system некоторого числа буковок. Может сделано и криво - но работает. Имея несколько удаленных кафедр института, которым надо почту забирать я им ставлю UUPC (6.18, но это не принципиально) с подправленным system.pat. После инсталляции UUPC - все окей. А вот и system.pat из нового дистрибутива ( надеюсь, что я никоим образом не ущемляю авторские права Андрея Чернова, но как-то надо выходить из положения) 200 gGt N g(%L_GWSIZE%,%L_GPSIZE%)/g(%R_GWSIZE%,%R_GPSIZE%) "" \W20\c name--name--name \p\p\L sword:-\L-sword:-\L-sword:-\L-sword: \p\P ->-> \crlogin\smail\r ogin--ogin--ogin \p\p\L sword:-\L-sword:-\L-sword: \p\P Вообщем просто поменял ogin на name и добавил: ->-> \crlogin\smail\r ogin--ogin--ogin \p\p\L sword:-\L-sword:-\L-sword: \p\P ^^^^ mail рекомендуется поменять либо на IP address либо на hostname почтовой машины ( uuhost ). Итог работы: Username:uutest Password:lalala cisco>rlogin mail login:uutest password:lalala Shere=sut

Boris

сделай так: conf term line ? telnet transparent

W tacacs+ wse prosto, example: tac_plus.conf: user = pupkin { service = exec { autocmd = "ppp pupkin.nowhere.ru" } login = cleartext qq-pupkin } ili chutx poslozhnee: tac_plus.conf: group = users { before authorization "/root/bin/authuser $user $port" } user = pupkin { member = users login = cleartext qq-pupkin } /root/bin/authuser: #! /bin/sh user=`echo "$1" | tr A-Z a-z` port=`echo "$2" | sed -e s/tty//` if [ "$port" -lt 10 ]; then port=0$port fi if [ ]; then exit 1; fi echo "autocmd*ppp host$port.nowhere.ru" exit 2;

* Дополнителльная память для Cisco *

Date: 30 Jul 1997 21:10:25 GMT ura@nau.antar.bryansk.ru (Yury V. Chernykh) Vladimir N. Degtyarev (vnd@sequoia.nsk.su) : > Имеется CiscoPro 2511. В ней стоит 2Mb. При попытке поставить туда : > симм 16Mb с 8 корпусами 70ns OK не загорается. : Раз у Вас 8 микросхем на SIMM-е, то память, скорее всего без четности ! : На стандартный цисковский 2MB SIMM не обращайте внимания. На нем стоят : хитрые микросхемы с встроенным битом четности. : По крайней мере обычный SIMM с четностью 16MB (4M*36, 70ns, FastPage) : на 12-ти микросхемах (8 4-разрядных и 4 1-разрядных) нормально работает : в CISCO 2509. : Когда я пытался добавить мозгов своей киске, то буквально обобрал все : компутерные фирмы города на симы(на попробовать)... Максимум, что : добился - некоторые 16Mb симы разпознавались как 1Mb ;-) : Все симы неЕDO-шные, и по заявлениям продавцов - : с наичестнейшим парити. И переделывать симы пробовали... В конце концов на это дело плюнули, заказали в Штатах кингстоновские 16Mb и 8Mb FLASH для Cisco 25xx, через пару недель все приехало, встало, как родное и пашеть... Причем получилось ненамного дороже, нежели бегать с высунутым языком и отыскивать левые симы... И гораздо дешевле европейского прайс-листа...

Cisco 2509 & reversive telnet

Date: 29 Nov 1997 From: Yura Pismerov VVA> Как заставить работать subj. conf t lin ttyX transport input telnet (или all) После этого можно на эту линию делать telnet (2000+номер линии) 4000 6000 Это разные режимы telnet.

Как на Cisco дернуть DTR при отвале клиента

Все юзера используют ppp. Как заставить Cisco Контролировать по ppp удаленный конец соединения и при отваливании его разрывать линию ? keepalive & pulse-time.


Проектирование кампусных ATM сетей

Построение кампусных ATM сетей

Введение

Возможность коммутируемого взаимодействия сетей становится важным элементом в кампусных сетях. В этой области лидирующее положение занимают продукты и технологии Cisco Systems. Cisco предлагает технологии построения как коммутируемых LAN, так и ATM с соответствующими решениями по виртуальным сетям (VLAN), возможными для каждой технологии. Решения VLAN включают такие методы мультиплексирования, как LAN Emulation (LANE) в сетях ATM, Inter-Switch Link (ISL) в сетях Fast Ethernet, и 802.10 в сетях Fiber Distributed Data Interface (FDDI). При разработке архитектуры кампусной сети, базирующейся на VLAN, возникает необходимость выбора между ISL в Fast Ethernet и LANE в ATM. Сделать этот выбор часто бывает затруднительно, особенно при отсутствии у потребителя представления о том, какое решение лучше и полнее удовлетворит все его требования. Настоящий документ предназначен для понимания сетевых решений на основе ATM.

Масштабируемая полоса пропускания, гарантии качества сервиса (QoS) и управление трафиком - все это ключевые факторы, указывающие на необходимость применения технологии АТМ для удовлетворения потребностей сегодняшних развивающихся корпоративных сетей. Для того чтобы успешно выполнить проектирование АТМ-сети и обеспечить ее работоспособность, требуется глубокое понимание того, как работают ее основные компоненты.

LANE - ключевая технология, обеспечивающая плавный перенос наследия существующей сети к АТМ, успешно применяется в рабочих группах и кампусных сетях. Используя технологию LANE, потребители могут выполнять существующие приложения, разработанные для локальных сетей, а также применять широковещательные LAN-протоколы в сети ATM. PNNI очень важен для масштабирования ATM-сети и его реализация от Cisco позволяет успешно строить сети, состоящие из более чем 90 ATM-коммутаторов.

Настоящий документ по проектированию и внедрению ATM-сетей содержит полезную информацию для построения масштабируемых сетей LANE. Детально обсуждается оборудование Cisco и реализация в нем упомянутых выше стандартов, а также принципы, по которым следует использовать это оборудование при построении сети. Там, где это возможно, разъясняется конфигурация, и приводятся примеры. В частях 2-6 исследуются вопросы проектирования и масштабирования для LANE в рабочих группах и кампусных сетях. В части 7 обсуждаются некоторые детали конфигураций при построении сетей LANE с использованием оборудования Cisco. Часть 8 посвящена обсуждению схем надежности LANE с применением протоколов Simple Server Redundancy Protocol (SSRP) и Hot Standby Routing Protocol (HSRP).

Содержание

Переход к коммутации

Преимущества LANE с PNNI:

Решение VLAN — мобильность, широковещательное управление и защита

Масштабирование полосы пропускания - PNNI в противовес Spanning Tree

Фактор MPOA — разрешение вопроса о размещении сервера

Обеспечение класса услуг в кампусных сетях

Логическая модель кампусной сети

Проектирование сети рабочей группы

Плоская коммутируемая сеть

Каким образом здесь применяются VLAN?

Ограничения в адресации: практические вопросы

Распространение широковещательного трафика

Масштабирование сети рабочей группы

Расположение сервера - множественный доступ

Маршрутизация взаимодействующих подсетей

Масштабирование кампусной сети

Кампусная архитектура, основанная на маршрутизаторах

Распределенная кампусная магистраль уровня 2

PNNI: управление шириной полосы пропускания, распределение трафика и
резервирование путей для сетей LANE

Масштабирование ELAN: проблемы протокола Spanning-Tree

Полоса пропускания BUS

Расположение служб LANE

Планирование количества SVC

Конфигурация Cisco LANE

Сети Cisco LANE

Реализация LANE от Cisco

Пример конфигурации сети LANE

Автоматическое назначение адресов в Cisco LANE

Конфигурация LightStream 1010

Конфигурация Catalyst 5000 (службы LANE)

Конфигурация клиента LANE

Конфигурация Cisco LANE с применением ATM-адресов, назначаемых пользователем

Резервирование LANE

Проблемы в сети LANE 1.0

Способность к быстрому восстановлению в сетях LANE 1.0

Резервирование LECS

Резервирование LES/BUS

Основные принципы использования SSRP

Типы проектов

Правила конфигурации

Замечания по взаимодействию

Работа SSRP с общепризнанными адресами LECS

Работа SSRP в разделенной сети

HSRP по LANE

Пример конфигурации HSRP и SSRP

Карта dual PHY ATM для Catalyst 5000

Какие существуют проблемы?

Конфигурирование клиентов LANE на карте dual PHY LANE

Конфигурирование служб LANE на карте dual PHY LANE

Заключение

Приложение 1. Функционирование сети LANE

Компоненты LANE

Функционирование ELAN

Регистрация ATM-адреса

Обнаружение LECS

Контактирование с LECS

Присоединение к LES

Обнаружение BUS

Присоединение BUS

Взаимодействие LEC-to-LEC

Proxy LEC

Используемая литература

Переход к коммутации

Необходимость увеличения полосы пропускания, более легкого администрирования и уменьшения стоимости накладных расходов побуждает потребителей к переходу на коммутируемые сети. Требования, предъявляемые пользователями к этим сетям, являются общими для большинства и могут быть классифицированы следующим образом:

  • Увеличение сетевой полосы пропускания. Основным фактором, побуждающим увеличивать полосу пропускания в кампусных сетях, является рост числа пользователей и приложений. Новые приложения требуют более мощных серверов и настольных компьютеров, что, в свою очередь, вызывает необходимость увеличения пропускной способности сети. Более того, разделение информации и ее быстрая передача в нужных направлениях становится настоятельной потребностью в корпорациях. Эти требования выдвигают технологии и приложения Intranet, которые все чаще используются в корпоративных сетях. Таким образом, возрастает и необходимость увеличения сетевой полосы пропускания.
  • Расположение сервера. Несмотря на то что распределенная архитектура, предполагающая размещение серверов в максимальной близости к группам пользователей, была очень популярной концепцией, высокая стоимость накладных расходов побудила проектировщиков сетей пересмотреть этот вопрос и использовать централизованное расположение серверов. Это означает, что практически весь трафик клиент/сервер проходит по транкам или магистрали, что, в свою очередь, является существенным преимуществом при построении масштабируемой сети и имеет большое влияние при ее проектировании.
  • Добавления, перемещения и изменения. Группы пользователей растут и реорганизуются. Одно из основных и наиболее важных требований потребителей - с наименьшими накладными расходами произвести возможные добавления, изменения или перемещения. С точки зрения функционирования сети эти требования затрагивают сетевые адреса и вопросы управления, поэтому необходимо спроектировать сетевую архитектуру таким образом, чтобы эти изменения проводились максимально легко.
  • Защита. Несмотря на то, что необходимость защищенности кампусной сети значительно ниже, чем территориально-распределенной сети (WAN), потребность в защите определенного типа данных (информации о паролях, например) от неавторизованных пользователей все же существует. Другим примером может служить настоятельная необходимость в формировании группы пользователей, имеющей доступ к секретной информации.

Для удовлетворения этих требований существует много различных решений - от ATM с LANE до простой коммутацией пакетов в таких технологиях, как коммутируемый Ethernet, Fast Ethernet и FDDI. В последующих частях обсуждается решение ATM с LANE и PNNI в контексте модели кампусной сети. Там, где это возможно, решение сравнивается с решениями на основе коммутации пакетов.

Преимущества LANE c PNNI

LANE версии 1.0 определяет стандарты для межсетевого взаимодействия сетей Ethernet и Token Ring с устройствами ATM. Такими устройствами могут быть конечные станции (например, серверы ATM), пограничные устройства, являющиеся мостами от существующих LAN к магистрали ATM (например, коммутаторы Catalyst 5000) и маршрутизаторы ATM для маршрутизации между эмулируемыми LAN (ELAN).

LANE определяется как инкапсуляция Media Access Control (MAC), обеспечивающая поддержку большого количества протоколов уровня 3. Конечным результатом является то, что все устройства, присоединенные к ELAN, оказываются на одном сегменте. Таким образом, IP, IPX, Apple Talk и другие протоколы будут иметь похожие характеристики производительности по сравнению с традиционной средой.

Рисунок 1 иллюстрирует сеть LANE и показывает необходимые компоненты для применения в такой сети.

image1.gif (14967 bytes)

Рис. 1. Компоненты сети ATM, выполняющей LANE

Решение VLAN — мобильность, широковещательное управление и защита

VLAN предоставляют возможность логически разделить сеть на несколько групп по признаку функциональной принадлежности пользователей. Например, все пользователи отдела маркетинга могут являться частью одной логической рабочей группы со схожими требованиями и предоставляемыми им услугами. Такая возможность существенно упрощает процесс изменений и перемещений, другими словами, обеспечивает мобильность. Решение VLAN, основанное на привязке к порту, предоставляет также возможность не допускать появления широковещательного трафика от других виртуальных сетей не только из соображений безопасности, но и для лучшего масштабирования. Проектирование области распространения (домена) широковещательного трафика обсуждается в части 5.1.3.

Такие пограничные устройства, как Catalyst 5000, позволяют пользователю локальной сети перейти к магистрали ATM, при этом эмулировать не одну, а несколько ELAN на одном и том же физическом интерфейсе. Это влечет за собой возможность мультиплексировать в магистраль ATM трафик от нескольких LAN-сегментов или доменов.

Другие архитектуры VLAN основаны на технологиях мультиплексирования пакетов, таких как ISL для использования по Fast Ethernet и 802.10 по FDDI.

VLAN, построенные при помощи ISL, 802.10, или LANE, являются, по существу, логическими областями распространения широковещательного трафика, в противовес попыткам физического ограничения. Таким образом, свойства масштабируемости VLAN, построенных при использовании различных технологий мультиплексирования, очень похожи. Размеры VLAN или ELAN зависят от границ областей распространения широковещательного трафика и практически не отличаются при использовании их для построения виртуальных сетей различных мультиплексирующих технологий.

Масштабирование полосы пропускания - PNNI в противовес Spanning Tree

Основным отличием между сетями VLAN, построенными на базе ISL и 802.10, и сетями LANE является ядро или магистраль.

В то время как технология мультиплексирования пакетов использует в ядре сети пакетные коммутаторы, LANE использует коммутаторы ATM. Масштабируемость сетей на базе пакетных коммутаторов ограничена протоколом Spanning Tree Protocol (STP). Ядро ATM базируется на протоколе PNNI, который является протоколом маршрутизации и передачи сигнализации и в контексте семиуровневой модели OSI может рассматриваться как протокол маршрутизации уровня 2. Протокол PNNI походит на протокол Open Shortest Path First (OSPF), за исключением того, что PNNI поддерживает возможности, предоставляемые QoS. Другими словами, он может формировать топологии для различных классов трафика (постоянная скорость передачи [CBR], переменная скорость передачи [VBR] и т.д.) и маршрутов соединений [VC] в сетях, построенных на базе классов трафика.

Использование PNNI в ядре сети позволяет установить VC по нескольким маршрутам и соединениям, что влечет за собой повышение надежности и распределение нагрузки в магистрали. Время восстановления такой сети после сбоев намного меньше, чем в случае традиционной сети, построенной на базе протокола Spanning Tree. Детали обсуждаются в части, посвященной масштабированию кампусных сетей.

В сетях LANE в качестве пограничных устройств присутствуют пакетные коммутаторы, и проблему масштабируемости протокола Spanning Tree все равно необходимо учитывать. Однако здесь ограничение больше относится к масштабируемости VLAN, чем к магистрали.

Фактор MPOA — разрешение вопроса о размещении сервера

В текущих сетевых архитектурах коммутируемых VLAN маршрутизация выполняется традиционным путем, по которому весь внутренний трафик VLAN проходит процесс маршрутизации (обычно маршрутизатором). Единственное отличие от не-VLAN архитектуры состоит в том, что маршрутизатор понимает такие VLAN-мультиплексирующие технологии, как ISL и LANE, и несколько VLAN могут пользоваться одним физическим интерфейсом. Из-за ограниченной полосы пропускания, доступной традиционным маршрутизаторам, стандартная рекомендация при проектировании сети - это правило 80:20. То есть, 80 процентов отдается локальному трафику и 20 процентов - маршрутизатору для внутреннего трафика VLAN. В применении к приложениям клиент/сервер это означает, что для оптимальной производительности сервер должен находиться на том же сегменте, что и клиент. До появления концепции VLAN требовалось размещать серверы там же, где располагались клиенты. VLAN позволили физически централизовать серверы, исключив необходимость промежуточных маршрутов благодаря присутствию серверов и клиентов в одной и той же VLAN. Несмотря на то что такое распределение открывает возможности централизованного управления серверами, оно не решает вопроса масштабируемости. Другими словами, VLAN продолжают быть ограниченными в размерах и для серверов, доступ к которым необходим большим группам приложений (как, например, Web, электронная почта и т.д.).

Можно организовать множественный доступ (multihoming) к серверам для различных VLAN, но и это не решит проблемы масштабируемости для крупных сетей. Поэтому пока рекомендации по проектированию состоят в расположении серверов с одним промежуточным маршрутом от клиентов, до тех пор пока такое решение минимизирует сложность конфигурации сервера и предоставляет равные права доступа для всех пользователей в сети.

ATM Forum работает над новым стандартом, известным как Multiprotocol Over ATM (MPOA), который обеспечит возможность коммутировать внутренний трафик VLAN по магистрали ATM, не задействуя при этом маршрутизатор. Такая техника так называемая сквозная маршрутизация обеспечивает более высокую производительность по сравнению с традиционной маршрутизацией и является подходящей технологией для серверов Web и других услуг, доступ к которым требуется большим группам пользователей.

MPOA продолжит использование LANE в качестве стандарта для внутренних VLAN. Поэтому реализация сетей LANE является предпосылкой к MPOA; и LANE вместе с маршрутизаторами ATM будет использоваться для обеспечения маршрутизации до тех пор, пока MPOA станет стандартизованным и достаточно устойчивым для применения его в реальных сетях.

Обеспечение класса услуг в кампусных сетях

При обсуждении преимуществ ATM часто возникает вопрос о возможности поддержки классов сервиса (CoS). Текущее положение дел с ограниченными возможностями конечных станций и некоторыми ограничениями в существующих на сегодняшний день стандартах не позволяет реализовать такую возможность в кампусной сети. В качестве примера можно привести стандарт LANE 1.0, который поддерживает только неопределенную скорость передачи (UBR) и, следовательно, не может воспользоваться теми возможностями поддержки CoS, которые предоставляются ATM коммутаторами и PNNI-протоколом.

Однако несмотря на это потребители все-таки желают иметь возможность реализовать гарантии CoS, не обновляя при этом программное обеспечение на их конечных станциях или серверах. Cisco решает эту проблему путем включения специализированных схем моделирования трафика в коммутаторах ATM. Теперь конечные станции могут продолжать существовать на текущей технологии LANE и пользоваться преимуществами гарантий CoS.

Логическая модель кампусной сети

image2.gif (5442 bytes)

Рис. 2 Кампусная сеть - логическая модель

Кампусная сеть может быть представлена в виде нескольких рабочих групп, логически разделенных в соответствии с административными требованиями. В корпорациях эти рабочие группы могут быть организованы в такие функциональные единицы, как отдел маркетинга, инженерный отдел, финансовый, а также по географическому положению (расположение на этаже и т.д.). Каждая функциональная единица или рабочая группа имеет уникальные приложения и услуги, которые предоставляются их собственными серверами. Таким образом, каждый отдел представляет собой конечный набор пользователей с конкретными требованиями к файл-серверам. Необходим очень быстрый сетевой доступ к этим локальным серверам и отсутствие узких мест, поскольку любые проблемы с доступом к услугам, предоставляемым данными серверами, неблагоприятно сказываются на ежедневном функционировании указанных рабочих групп.

В дополнение к этому имеются также корпоративные серверы, которые являются общими для всех рабочих групп с вытекающими отсюда требованиями равного доступа. Если рабочие группы полностью независимы друг от друга и не нуждаются во взаимодействии между собой, они могут быть поделены на отдельные логические части сети, не взаимодействующие друг с другом. Однако такой сценарий является редкостью, так как в большинстве корпораций всегда необходимо некоторое взаимодействие между рабочими группами. Кроме того, некоторые корпорации требуют определенной защищенности для пересекающихся (взаимодействующих) рабочих групп. Примером такого требования может служить необходимость разрешения доступа к электронной почте и услугам, предоставляемым серверами Web и одновременного запрещения доступа к любым данным на этих серверах.

Такая модель для трафика внутри рабочих групп предполагает использование коммуникаций как третьего, так и второго уровня, в отличие от коммуникаций между группами, где используется третий уровень. Логическим обоснованием этой модели является необходимость высокой скорости трафика внутри рабочих групп, которая обеспечивается коммутаторами второго уровня. Потребность в третьем уровне внутри рабочих групп возникает в том случае, когда рабочая группа слишком велика. Надежность и защищенность лучше реализуются при иерархической схеме адресации, которая обычно используется на третьем уровне, чем при работающей на втором уровне плоской, построенной на MAC-адресах схеме. На рис. 2 показано логическое разделение кампусной сети с использованием маршрутизаторов. Маршрутизаторы могут быть соединены физически (как на рис. 2), либо могут быть соединены по принципу “routers on a stick” (так называемые однорукие маршрутизаторы).

Пользователи внутри рабочих групп не обязаны находиться в одном месте в смысле их географического расположения в пределах кампусной сети. При перемещении с одного места на другое внутри кампуса они сохраняют за собой все права доступа к серверам и услугам, что и у всей рабочей группы, к которой они продолжают принадлежать.

Такая модель является иерархической, так как несколько рабочих групп взаимодействуют, используя маршрутизаторы, а базовая функциональная единица, которой является сеть рабочей группы, повторяется несколько раз. Масштабируемость таких рабочих групп обсуждается в следующей части. В обсуждаемом варианте кампуса сети рабочих групп разделены маршрутизаторами.

Проектирование сети рабочей группы

Сеть рабочей группы состоит из множества компьютеров, имеющих общий сервер с располагающимися на нем данными, разделяемыми всеми пользователями. Взаимодействия внутри рабочей группы в большинстве своем построены по принципу клиент/сервер с небольшим количеством взаимодействий клиент/клиент и сервер/сервер. Несмотря на то что мы попытаемся быть объективными ко всем этим режимам, наибольший акцент будет сделан все-таки на взаимоотношения клиент/сервер.

Плоская коммутируемая сеть

Простейший подход к реализации сети рабочей группы состоит в использовании для всей рабочей группы одной области распространения широковещательных сообщений или VLAN. Такая сеть состоит из нескольких коммутаторов, разделяемых одним Spanning Tree доменом, как показано на рис. 3.

image3.gif (12193 bytes)

Рис. 3. Плоская сеть рабочей группы

Каким образом здесь применяются VLAN?

Плоская сеть имеет превосходные мобильные характеристики до тех пор, пока каждый пользователь принадлежит к одному домену (области распространения широковещательного трафика). До тех пор пока порт, к которому подключен пользователь, принадлежит данному домену, доступ к рабочей группе остается таким же, вне зависимости от физического расположения пользователя. Проблема возникает при необходимости расширения широковещательного домена к новому месту пользователя. Установка нового коммутатора для удовлетворения потребностей единственного пользователя является экономически необоснованной. Наиболее оптимальным вариантом можно считать использование архитектуры коммутируемой VLAN с мультиплексирующей технологией.

Плоская коммутируемая сеть имеет ограничения по масштабированию, которые обсуждаются в следующей части.

Ограничения в адресации: практические вопросы

Большинство IP-сетей представляют собой либо сети класса B с маской подсети класса C (восьмибитовой), либо несколько сетей класса С. Из этого следует ограничение в 254 конечные станции на одну подсеть. Затем подсеть размечается в домен широковещательного трафика, и маска подсети становится ограничением для расширения домена. Несмотря на то что возможны конфигурации, в которых несколько подсетей реализованы в одном домене, для эффективной работы такой конфигурации администратор сети должен добавлять маршруты к другим сетям в домене для каждой конечной станции. Очевидно, что это чрезвычайно трудоемкий процесс для администратора сети. Наиболее гибкое решение - использование одной подсети на домен и применение маршрутизации для обеспечения взаимодействия подсетей.

Например, смещение границы маски подсети на два бита влево даст в результате 1024 конечные станции, но значительно уменьшит количество подсетей (до 64). Более того, не все рабочие группы должны быть одинакового размера и 1024 станции на одну подсеть - это слишком много для большинства рабочих групп. Конечно, для варьирования размеров рабочих групп можно применить стратегию маски подсети переменной длины (VLSM), но такой вариант будет слишком трудоемким для администратора и, кроме того, потребует смены протоколов маршрутизации Routing Information Protocol (RIP) или Interior Gateway Routing Protocol (IGRP) на Enhanced IGRP или OSPF. Такие преобразования выглядят все-таки чрезмерными для простой возможности увеличения количества пользователей в одном домене, особенно если есть иные варианты решения. Практическая же сторона проблемы заключается в том, что любые изменения в стратегии организации адресного пространства затрагивают все конечные станции, маска подсети которых подвергается изменениям. Это задача, которую проще изложить, чем разрешить.

Для сетей Internetwork Packet Exchange (IPX) и AppleTalk вопросы ограничения адресного пространства не так актуальны, поскольку в них используется преимущество динамической адресации. Тем не менее сети IPX и AppleTalk имеют более интенсивный широковещательный трафик, представляющий намного более серьезную проблему в масштабировании области его распространения.

Распространение широковещательного трафика

Термин "домен широковещательного трафика" происходит от того факта, что и широковещательный и мультивещательный трафики (RIP, SAP и т.д.) проходят по всей области распространения. Такие широковещательные пакеты должны быть обработаны всеми конечными станциями. В случае если пакет станции не нужен, он отбрасывается. Такой процесс сильно загружает CPU. Отсюда следует важность минимизации распространения широковещательного трафика на ELAN. Следовательно, размер ELAN реально зависит от степени распространения широковещательного трафика и от возможностей конечных станций этот трафик обрабатывать. В свою очередь, распространение широковещательного трафика зависит от протоколов и типов приложений, работающих в сети. Исследования обнаруживают верхние пределы размеров ELAN; они приведены в табл. 1.

В дополнение к вышеприведенным существуют и другие проблемы, касающиеся масштабирования, такие, например, как протокол Spanning Tree, который также играет роль в определении размеров области распространения широковещательного трафика. Эта важная тема обсуждается в части, посвященной масштабированию кампусной сети.

Таблица 1. Масштабирование коллизионных областей: максимальное количество конечных узлов в одной коллизионной области

Тип протокола | Максимальное количество конечных узлов
IP | 500 (практически применяется 254 при использовании подсетей класса C)
IPX | 300
AppleTalk | 200
Смешанная сеть | 200
Масштабирование сети рабочей группы

Проблемы с адресацией и ограничением распространения широковещательного трафика могут быть разрешены путем распределения сети рабочей группы по нескольким доменам. Такая процедура может быть выполнена посредством реализации отдельных ELAN или VLAN для каждой подсети, однако это представляет некоторые проблемы для сетевого администратора.

Расположение сервера - множественный доступ

В плоской модели сети для рабочей группы сервер и пользователи, имеющие к нему доступ, могут располагаться с нулевым количеством промежуточных маршрутов, что обеспечивает их взаимодействие по второму уровню. Когда требуется протянуть сеть рабочей группы по нескольким доменам, оптимальным является расположение сервера с одним промежуточным маршрутом по отношению к пользователям. Это может быть достигнуто путем организации серверов с множественным к ним доступом (multihoming) в каждом из используемых рабочей группой доменов. Множественный доступ к серверу может быть организован логически или физически. Физический способ требует наличия в сервере одной сетевой интерфейсной карты (NIC) для каждой подсети, частью которой необходимо быть серверу. Такой подход может быть полезен в случае, когда имеется небольшое (от 1 до 4) количество подсетей и каждой из них требуется одна NIC. Логический же способ организации множественного доступа предполагает, что сервер может иметь одну NIC, но участвовать в нескольких подсетях. Такая концепция очень напоминает организацию маршрутизаторов по принципу “router on stick”, где один физический интерфейс состоит из нескольких подинтерфейсов.

image4.gif (9293 bytes)

Рис. 4. Сравнение физического и логического способа организации множественного доступа к серверам

Требование к NIC при организации логического множественного доступа к серверу состоит в необходимости распознавания картой мультиплексирующей технологии VLAN, используемой на магистрали. Следовательно, в случае ATM NIC должна понимать LANE, а в случае ISL - соответственно ISL. В смысле поддержки различными платформами для LANE намного больше опций, чем для ISL. В табл. 2 приведен частичный список платформ, поддерживающих LANE и ISL.

Таблица 2. Однонаправленная производительность

Маршрутизатор | Cisco 7500 c процессором AIP | Cisco 7000 с процессором AIP | Cisco 4700 | Cisco 7500 с модулем ATM Lite PA | Cisco 7200 с модулем ATM Lite PA
Режим коммутации
Оптимальная | 47,5 kpps | - | - | 74 kpps | 76,2 kpps
Flow | 47,5 kpps | 45,8 kpps | - | 74 kpps | 71,9 kpps
Fast | 47.5 kpps | 13,4 kpps | 34 kpps | 76,1 kpps | 76,3 kpps
Process | 2,7 kpps | 1,1 kpps | 4,5 kpps | 2,9 kpps | 4,7 kpps

image5.gif (10254 bytes)

Рис. 5. Однонаправленная пропускная способность LANE

Несмотря на то, что в маркетинговой информации по различным NIC содержатся данные о том, что они могут мультиплексировать от 8 до 256 ELAN или VLAN, на самом деле более реалистичные числа - от 4 до 162. На самом деле этого более чем достаточно для рабочей группы. Точное количество зависит от NIC, типа сервера и приложений, выполняемых на нем. Хотя вопросы масштабируемости серверов и NIC сами по себе лежат за рамками настоящего документа, укажем некоторые моменты, на которые следует обратить внимание при проектировании серверов с множественным доступом:

  • Память сервера и NIC. Возможности NIC заключаются зависят от того, какое количество имеющейся на карте памяти доступно для хранения пакетов. Большинство NIC имеет достаточно памяти для хранения поступающих на карту пакетов максимального размера, которые затем немедленно копируются (DMA) в основную память. Некоторые NIC имеют дополнительную память для хранения нескольких пакетов перед их копированием в основную память. Количество запросов DMA прямо пропорционально количеству прерываний, отправленных к CPU, что, в свою очередь, вызывает излишнюю загрузку CPU. Следовательно, имея немного больше памяти на карте, скажем для двух или трех пакетов, которые все одновременно будут скопированы в основную память, возможно вдвое или втрое сократить количество прерываний, понижая тем самым нагрузку на CPU. CPU же может использоваться для других важных функций, таких как операции ввода/вывода и т.д.
  • CPU и тип системы. Очевидно, что процессор и тип системы оказывают влияние на обработку ввода/вывода. Например, сервер SPARC от SUN выполняет такую обработку гораздо лучше, чем сервер PCI Pentium.
  • Количество коммутируемых виртуальных каналов (SVC). NIC может поддерживать только ограниченное количество SVC. В маркетинговой информации сообщается о поддержке от 1024 до 2048 виртуальных канальных соединений (VCC). Более реалистичным представляется число 512. Это не обязательное правило, однако очень важно быть уверенным в том, что вы не выйдете за рамки емкости SVC на NIC.

Маршрутизация взаимодействующих подсетей

Исходя из того что для реализации сети рабочей группы необходимо использовать несколько подсетей, важно спроектировать достаточное значение производительности маршрутизации для согласования требований к полосе пропускания для трафика между подсетями. Как упоминалось ранее, в этом случае трафик клиент/сервер может быть оптимизирован предоставлением локального доступа к серверам (назначением их имеющими множественный доступ для нескольких ELAN), в то время как трафик клиент/клиент будет проходить через маршрутизатор. Значение трафика клиент/клиент переменно и зависит от количества применяемых в рабочей группе равноправных приложений (peer/peer). Значение производительности маршрутизации может быть определено при сравнении различных маршрутизаторов, представленных в соответствующей таблице.

Таблица 3. Двунаправленная производительность маршрутизации

Маршрутизатор | Cisco 7500 c процессором AIP | Cisco 7000 с процессором AIP | Cisco 4700 | Cisco 7500 с модулем ATM Lite PA | Cisco 7200 с модулем ATM Lite PA
Режим коммутации
Оптимальная | 47,6 kpps | - | - | 81,6 kpps | 76,0 kpps
Flow | 47,1 kpps | 45,8 kpps | - | 81,6 kpps | 76,4 kpps
Fast | 47,6 kpps | 14,0 kpps | 34,4 kpps | 82,0 kpps | 76,4 kpps
Process | 3,0 kpps | 1,1 kpps | 4,6 kpps | 3,0 kpps | 4,9 kpps
image6.gif (9979 bytes)

Рис. 6. Двунаправленная пропускная способность LANE

Масштабирование кампусной сети

Кампусная сеть состоит из нескольких сетей рабочих групп, взаимодействующих между собой при помощи маршрутизаторов. Хотя такое определение и звучит несколько функционально, в нем заключены важные моменты для реализации и развития кампусной сети. Архитектура сети реально зависит от предъявляемых к ней требований. В следующих частях этого документа исследуются некоторые из этих требований и, сообразуясь с ними, будет построена кампусная сеть LANE.

Сеть LANE, как показано на рис. 1, состоит не только из LAN Emulation Clients (LEC) и LANE-услуг, но также из коммутаторов ATM, возможно использующих PNNI, пограничных устройств, выполняющих Spanning Tree Protocol и т.д. Отсюда следует, что расширение LANE-сети должно быть всесторонне исследовано в совокупности с другими компонентами, которые являются частью сети LANE, но не подчиняются стандарту LANE.

Кампусная архитектура, основанная на маршрутизаторах

По правилам этой архитектуры рабочие группы в кампусной сети разделены маршрутизаторами логически и физически. Серверы имеют множественный доступ для соответствующих подсетей рабочей группы и могут быть либо централизованными, либо распределенными. Такая архитектура очень похожа на ранние сети с разделяемой технологией. Ключевое отличие состоит в резком увеличении ширины полосы пропускания, предоставляемой при использовании коммутации LAN и ATM.
Такая сеть проиллюстрирована на рис. 7.
Несмотря на то что на рисунке приведен только один коммутатор ATM для каждой рабочей группы, их может быть несколько. Главное же в том, что эти маршрутизаторы не соединены друг с другом. Поэтому и сама сеть состоит из нескольких коммутируемых областей, логически и физически отделенных друг от друга.

image7.gif (20435 bytes)

Рис. 7. Архитектура традиционной кампусной сети

Такая сеть имеет хорошие возможности для масштабируемости, поскольку каждая сеть рабочей группы является автономной единицей. Разделение, достигнутое при помощи маршрутизаторов, превращает ее в маршрутизируемую сеть и, следовательно, она приобретает те же возможности масштабируемости и гибкости, что и традиционная сеть. Преимуществом такой сети является ее простота, что очень важно для разрешения возникающих проблем. Тем не менее такая сеть имеет некоторые проблемы и недостатки, присущие простой маршрутизируемой сети:

  • Стоимость. Поскольку рабочие группы физически отделены друг от друга, появляется столько же магистралей, сколько и рабочих групп. Следовательно, если несколько рабочих групп расположены в конкретном здании, там же должна быть положена магистраль каждой из этих рабочих групп. Если рабочие группы географически ограничены пределами одного задания, такой вариант не будет стоить очень дорого. Однако если рабочие группы разнесены по всему кампусу по нескольким зданиям, вопрос о стоимости такого решения обязательно возникнет.
  • Мобильность. Этот вопрос очень тесно связан с вопросом о стоимости. Если пользователю необходимо расположиться в здании, в котором нет рабочей группы, возникает вопрос продления магистрали к этому зданию. Поэтому переезд вызывает не только физическое перемещение рабочей станции пользователя, но и добавление коммутаторов, а также, возможно, и прокладку волоконно-оптического кабеля для размещения рабочей группы в новом помещении. Эти проблемы могут быть решены путем использования для географически распределенного кампуса архитектуры VLAN, обсуждаемой в следующей части.
  • Централизация серверов. Доступ к серверам, которые должны быть доступны для всех рабочих групп, осуществляется через маршрутизаторы. Примерами таких серверов могут быть Web-серверы, серверы электронной почты и т.д. В зависимости от интенсивности трафика и возможностей его обработки маршрутизатором такой сценарий может вызвать проблемы.

Распределенная кампусная магистраль Уровня 2

Эта архитектура решает проблемы стоимости и мобильности пользователей, которые имелись в предыдущих архитектурах кампусных сетей. Такая магистраль, по существу, предоставляет путь Уровня 2 между любыми двумя точками в сети. Таким образом, любая VLAN рабочей группы может находиться в любом месте кампусной сети, обеспечивая легкость и маневренность в управлении при всех добавлениях, перемещениях и изменениях, необходимых пользователям.

image8.gif (22640 bytes)

Рис. 8. VLAN распределенной кампусной сети

Масштабируемость такой магистрали определяется технологиями, которые используются при ее построении. Магистраль ATM, так же как и магистраль, основанную на коммутации пакетов, можно построить различными способами, где каждое решение может предоставлять различные возможности масштабирования.

В архитектуре, о которой мы говорим, обычно применяются пограничные устройства и коммутация ATM в ядре системы. Ядро ATM использует PNNI как протокол маршрутизации уровня 2, предоставляющий больше возможностей для масштабирования сети, чем использование магистрали с коммутацией пакетов, чья масштабируемость ограничена протоколом Spanning Tree.

В последующих частях детально обсуждаются преимущества использования протокола PNNI в качестве протокола маршрутизации уровня 2.

PNNI: управление шириной полосы пропускания, распределение трафика и резервирование путей для сетей LANE

PNNI - это протокол маршрутизации ATM, служащий для маршрутизации соединений и реализуемый в коммутаторах ATM. Большинство сетей LANE состоит из нескольких коммутаторов ATM и обычно применяет протокол PNNI. Несмотря на то что PNNI является очень "продвинутым" протоколом и поддерживает маршрутизацию, основанную на QoS, этот исключительный аспект PNNI здесь не обсуждается. Однако хотелось отметить, что для масштабирования сетей LANE могут быть использованы ннекоторые полезные свойства LightStreame 1010, связанные с PNNI. Эта часть рассматривает вопрос о субъектах PNNI, связанных с LANE, но не затрагивает сложности и проблемы маршрутизации PNNI.

Применение PNNI на LightStream 1010 предоставляет следующие возможности:

  • Распределение нагрузки при выполнении запросов на установку соединения по нескольким маршрутам между двумя конечными станциями.
  • Распределение нагрузки по нескольким параллельным каналам.
  • Обеспечение резервирования каналов и путей с быстрой сходимостью.
  • Обеспечение высокой производительности при установке соединений по нескольким промежуточным маршрутам путем использования свойства фоновой маршрутизации.

image9.gif (9582 bytes)

Рис. 9. Распределение нагрузки по нескольким путям и нескольким параллельным каналам

Распределение нагрузки при процедурах установки соединений, как показано на рис. 9, включено по умолчанию на LightStream 1010. Фоновая маршрутизация по умолчанию не поддерживается. В общем, фоновая маршрутизация может рассматриваться как маршрутизация с использованием путей из числа предварительно вычисленных и находящихся в базе данных. В процессе фоновой маршрутизации вычисляются все возможные маршруты ко всем возможным пунктам назначения по всем категориям услуг (CBR, VBR-реального-времени [RT], VBR-не-реального-времени [NRT], ABR, UBR). Когда требуется установить соединение от точки А к точке В, PNNI просто берет уже вычисленный маршрут из таблицы маршрутов вместо вычисления его по требованию. Такой подход облегчает нагрузку на CPU и обеспечивает более высокую скорость обработки процедур установки соединений. Фоновая маршрутизация может быть очень полезной для применения в сетях с устоявшимися по отношению к QoS топологиями, а, соответственно менее полезной в сетях с часто меняющейся топологией (как, например, у поставщиков услуг Internet). Кампусные сети LANE могут использовать это свойство очень эффективно по причине того, что все SVC в сети принадлежат к категориям UBR или ABR.

Для того чтобы включить это свойство, следует использовать следующую команду:

atm router pnni

background-routes

Текущая реализация протокола PNNI на LightStream 1010 не поддерживает иерархии, поэтому ожидаемая масштабируемость составляет от 100 до 200 узлов (коммутаторов ATM), в зависимости от взаимных соединений. Данная версия хорошо подходит для тех сетей, в которых работает от 90 коммутаторов. PNNI с иерархией теоретически поддерживает неограниченное количество узлов. В настоящее время данные по практическому ограничению отсутствуют.

Масштабирование ELAN: проблемы протокола Spanning Tree

Протокол Spanning Tree реализован в коммутаторах/мостах уровня 2 (например, Catalyst 5000) для того, чтобы препятствовать образованию временных петель маршрутизации в сетях с резервными каналами, поэтому он часто используется как механизм для обеспечения резервирования. Поскольку LEC, по существу, бриджует трафик Ethernet/Token Ring по магистрали ATM, блоки данных протокола Spanning Tree bridge (BPDU) передаются по всей ELAN. Для процесса Spanning Tree на пограничных коммутаторах уровня 2 сеть ATM выглядит как разделяемая сеть Ethernet/Token Ring. На рис. 10 это показано в сравнении с коммутируемой сетью, полностью построенной на коммутации пакетов.

Как видно из рисунка, топология Spanning Tree (STP) сети, основанной на LANE, в значительной степени проще, чем топология чисто коммутируемой сети, применяющей STP. Как бы то ни было, время сходимости, которое может быть главной проблемой в крупных коммутируемых пакетных сетях, продолжает являться проблемой и в сетях LANE. Несмотря на это, преимущество использования LANE с PNNI состоит в том, что сама по себе масштабируемость области Уровня 2 предпочтительнее, чем масштабируемость ELAN.

Экспериментальным путем установлено, что время сходимости лежит в интервале от 35 до 40 секунд (установки таймера приняты по умолчанию). Следует обратить внимание на то, что Spanning Tree требует повторного выполнения процесса сходимости в случае сбоев на пограничных коммутаторах или внутри сети ATM.

image10.gif (13437 bytes)

Рис. 10. Топологии Spanning Tree для сети LANE и сети с коммутацией пакетов

Рекомендуется оставить значение таймеров Spanning Tree, установленные по умолчанию, так как они хорошо подходят большинству сетей.

Тем не менее при необходимости несколько уменьшить (или увеличить) время сходимости можно использовать параметр задержки пересылки (forward delay). Этот параметр контролирует количество времени, на которое коммутатор переводит порт в режимы "прослушивания" и "изучения" STP в процессе перехода порта в состояние блокирования или выхода из этого состояния. Значение по умолчанию, установленное для этого параметра, составляет 15 секунд, что в результате дает приблизительно от 35 до 45 секунд на восстановление. На Catalyst 5000 минимальное значение этого параметра составляет четыре секунды, что уменьшает время на восстановление после ошибок до величины около 15-20 секунд. Время, необходимое клиенту LANE для повторной регистрации, обычно лежит в интервале от 0 до 5 секунд. Время сходимости зависит от типа сетевой конфигурации и количества ELAN, которые требуется восстановить.

Команда для регулирования параметра задержки пересылки на Catalyst 5000:

C5000(enable)> set spantree fwddelay 4 <vlan id>

Полоса пропускания BUS

В любой ELAN BUS занимается пересылкой всего широковещательного, мультивещательного и нераспознанного однонаправленного трафика. Следовательно, потенциальные возможности обработки пакетов BUS должны обеспечивать обслуживание всего трафика в ELAN. Кроме того, должно быть предусмотрено поведение BUS в случае широковещательных "штормов", во время которых могут быть существенно уменьшены возможности оборудования/программного обеспечения, реализующего функции BUS.

Так как в сети может быть несколько ELAN, производительность и скорость обработки у BUS должны быть выше, чем объем совокупного широковещательного сетевого трафика.

На рис. 11 показана производительность BUS на каждом устройстве Cisco, реализующем функции BUS.

image11.gif (12062 bytes)

Рис. 11. Производительность BUS

Как видно из рисунка, платформа Catalyst 5000 обеспечивает лучшую производительность BUS с одновременным минимальным использованием CPU. Все другие устройства, за исключением Catalyst 3000, сильно загружают CPU. Происходит это потому, что модуль LANE для Catalyst 5000 и 3000 оптимизирован для BUS, и все пакеты, предназначенные для BUS, обрабатываются на аппаратном уровне. Все другие платформы для трафика BUS используют CPU. Поэтому, реализуя BUS на данных платформах, следует иметь в виду степень загруженности CPU.

Как правило, возникает вопрос о преимуществах варианта реализации BUS (или служб LANE) на коммутаторе ATM в противовес пограничному устройству, такому, как Catalyst 5000 или маршрутизатор. Оборудование само по себе (то есть коммутатор ATM или пограничное устройство) не имеет прямого отношения к этому обсуждению, важно только, оптимизировано ли это оборудование для реализации на нем служб LANE. Большинство коммутаторов ATM, включая LightStream 1010, не имеет специализированного оборудования для служб LANE. Следовательно, реализация служб LANE на этих коммутаторах означает излишнюю нагрузку на CPU не только для PNNI, передачи служебной информации, Interim Local Management Interface (ILMI), и т.д., но также и для служб LANE. Поэтому реализация служб LANE на любых платформах, которые не поддерживают их аппаратно, ставит сеть в зависимость от таких процессов, как широковещательные "штормы" и т.п. Чтобы избежать такого рода проблем, Cisco рекомендует в качестве платформы для реализации служб LANE использовать Catalyst 5000.

Расположение служб LANE

Расположение служб LANE влияет на производительность сети в целом. В предыдущей части речь шла о вопросах, возникающих при выборе аппаратной платформы для работы служб LANE. В этой части обсуждаются вопросы централизованного и распределенного расположения служб LANE.

Централизованное расположение служб LANE делает удобным управление сетью LANE благодаря тому, что все службы LANE являются общими для всех ELAN и находятся на одном устройстве. Тем не менее такой подход не очень желателен с точки зрения отказоустойчивости. Кроме того, при восстановлении после сбоя все управляющие SVC для LANE будут установлены к одному ATM UNI-порту, увеличивая время восстановления сети. Таким образом, полная централизация не рекомендуется.

Распределение служб LANE по нескольким устройствам применяется для снижения воздействий на сеть, вызванных сбоями. Такой способ обеспечивает также увеличение сигнальной ширины полосы пропускания для служб LANE благодаря распределению по нескольким UNI-портам. Тем не менее распределение служб LANE по всей сети вызывает сложности в управлении и не очень желательно с точки зрения комплексного решения возникающих проблем.

Таким образом, рекомендуемой стратегией в крупных сетях является сочетание централизованного и распределенного подхода к размещению служб LANE. Для этого службы LANE устанвливаются на нескольких коммутаторах Catalyst 5000, специально для этого выделенных.

Планирование количества SVC

При масштабировании сети АТМ ключевой является проблема емкости SVC. Сеть ATM, состоящая из n пограничных устройств, для обеспечения полного взаимодействия требует общее количество SVC, вычисляемое по формуле: n*(n-1)/2. Это крайний случай, имеющий место только тогда, когда каждое устройство обменивается информацией с другим устройством одновременно. К счастью, в реальных сетях такие случаи происходят редко, взаимодействия разграничены во времени и SVC устанавливаются и разрываются по требованию. Тем не менее сетям LANE для корректного функционирования требуется минимальное количество SVC, а вычисление этого количества дает представление о том, сколько SVC имеется в распоряжении для установки по требованию Data_Direct SVC.

При вычислении количества SVC важно учитывать и суммировать не только SVC, необходимые сети, но и SVC, требующиеся каждому пограничному устройству. Например, на рис. 12 показано десять пограничных устройств, присоединенных к коммутатору ATM, и все они взаимодействуют на одной ELAN.

image12.gif (18737 bytes)

Рис. 12. Требования SVC для одной ELAN

Для служб LANE необходимо минимум 22 SVC. Каждому пограничному устройству (LEC) необходимо 4 SVC для того, чтобы быть частью ELAN. В наихудшем случае в сети ATM должно быть 67 SVC. Если этот пример модифицировать до 10 ELAN, требования к количеству SVC возрастут в десять раз, и, таким образом, для функционирования всей ATM-сети в худшем случае понадобится 670 SVC.

Расчет количества SVC в сети производиться следующим образом:

Исходные данные:

  • Примем m за общее количество ELAN в сети.
  • Примем n за общее количество пограничных устройств в сети. Кроме того, примем за данность, что службы LANE расположены на отдельных пограничных устройствах и что на этих устройствах нет LEC. Также примем, что все пограничные устройства обслуживают все ELAN.
  • Тогда количество SVC, необходимое для каждого пограничного устройства, рассчитывается по формуле: 4m + m*(n-1)
  • Количество SVC, необходимое для служб LANE, рассчитывается по формуле: m*(2n+2)
  • Общее количество однонаправленных (unicast) SVC, необходимых в сети ATM, рассчитывается по формуле: m* n*(n-1)/2 + m*2n = m*n*(n+3)/2
  • Общее количество мультивещательных (multicast) SVC, необходимых в сети ATM, равно 2m

Количественные данные о необходимых в ATM-сети SVC дают представление о том, сколько SVC необходимо для всей сети с несколькими ATM-коммутаторами. Кроме того, этот пример следует рассматривать c точки зрения определения минимального, а не максимального количества SVC. Другими словами, этот пример может служить руководством для понимания того, какое количество SVC необходимо для управления LANE и какое количество доступно для Data_Direct SVC.

Эти формулы не применимы для линии Catalyst 3000 из-за различий в способах, по которым модули ATM в этих коммутаторах назначают SVC.

Конфигурация Cisco LANE

Сети Cisco LANE

Сети LANE от Cisco характеризуют следующие особенности:

  • Один активный LECS поддерживает все ELAN в одном административном домене LANE.
  • В каждой ELAN имеется одна пара LES/BUS и некоторое количество LEC.
  • Функциональности LES и BUS должны быть определены на одном и том же подинтерфейсе; они не могут быть разделены.
  • На одном подинтерфейсе может быть только одна пара LES/BUS.
  • В одной ELAN может быть только одна активная пара LES/BUS.
  • LECS и LES/BUS могут быть маршрутизаторами/мостами/рабочими станциями.
  • На одном подинтерфейсе может быть только один LEC. Если LEC и пара LES/BUS разделяют подинтерфейс, они работают (по определению) в одной и той же ELAN.
  • При определении VLAN на Catalyst 5000 каждый VLAN должен быть назначен отдельной ELAN.

Реализация LANE от Cisco

Функциональности LECS, LEC, LES, и BUS могут быть реализованы при помощи различного оборудования Cisco; полный список приводится в табл. 4.

Таблица 4. Функциональности LANE по продуктам

Устройство | Компоненты LANE, поддерживаемые устройством | Версия программного обеспечения
Catalyst 5000 | LECS, LES, BUS, LEC | ATM module software 2.0 или выше
Catalyst 3000 | LECS, LES, BUS, LEC | Только для LEC Software Version 1.2 Для LECS, LES, BUS Software Version 2.1
Cisco 7000 | LECS, LES, BUS, LEC | Cisco IOS Release 11.0 или выше
Cisco 75xx, 4xxx | LECS, LES, BUS, LEC | Cisco IOS Release 11.0 или выше
LightStream 1010 | LECS, LES, BUS, LEC | LightStream 1010 Software Version 11.2

Эти функции определены на физических ATM-интерфейсах и подинтерфейсах. Подинтерфейсы, которые могут быть определены как логические, являются частью физического интерфейса, такого как OC-3. Интерфейсы ATM на маршрутизаторах Cisco и модули ATM на Catalyst 5000 могут быть логически поделены на 255 подинтерфейсов. Несмотря на использование той же операционной системы (Cisco IOS) в Catalyst 3000, концепция подинтерфейсов не применяется.

Пример конфигурации сети LANE

image13.gif (12677 bytes)

Рис. 13. Пример сети LANE с ассоциированными компонентами

Сетевые требования для построения сети LANE заключаются в поддержке двух VLAN (ELAN) и наличия возможности маршрутизации между VLAN. Также необходимо определиться, где будут работать службы LANE. В приведенном примере они работают на Catalyst 5000.

Автоматическое назначение адресов в Cisco LANE

Каждый компонент LANE, именуемый LECS, LES, BUS и LEC, требует адрес ATM для обеспечения возможности уникальной идентификации его конечной станцией. Так как широко применяется автоматическое назначение адресов, важно понимание этого процесса. Структура адреса ATM показана на рис. 14.

image14.gif (3170 bytes)

Рис. 14. Структура адреса ATM

Маршрутизаторы Cisco Catalyst 5000 имеют уже предварительно сконфигурированные MAC-адреса, которые используются в качестве идентификатора конечной системы (ESI) и являются частью 20-байтного адреса ATM. Такие MAC-адреса программируются на внутренней шине шасси и благодаря этому защищены от смены плат, Route Switch Processor (RSP) (для Catalyst 7500) и супервизоров (для Catalyst 5000). Эти адреса можно увидеть, используя команду show lane default при отключенном восходящем канале ATM.

Как видно, каждый компонент LANE имеет уникальную часть ESI. На одном модуле может быть сконфигурирован только один LECS и, следовательно, значение байта селектора для LECS ? 0x00. Байт селектора для оставшихся компонентов используется при идентификации различных подинтерфейсов. Так как на одном подинтерфейсе может быть только одна ELAN, этот селектор уникально идентифицирует ELAN, сконфигурированный на этом подинтерфейсе. Этот факт может быть очень полезным при возникновении каких-либо проблем, так как подинтерфейсы являются только внутренним представлением Cisco, и ничего не значат для внешних ATM-анализаторов.

Как только модуль ATM устанавливается в коммутатор ATM, он получает от него 13-байтный префикс, используя ILMI. Для того чтобы сделать это, на модуле ATM должно быть сконфигурировано постоянное виртуальное соединение (PVC) для ILMI (идентификатор виртуального пути/идентификатор виртуального канала [VPI/VCI]—0/16). Также необходимо соединение PVC для сигналинга (VPI/VCI—0/5).

Эта процедура должна быть выполнена на модулях ATM Catalyst 5000 во время их предварительного конфигурирования.

После завершения конфигурации команда show lane default покажет 19-байтный ATM-адрес. Значение байта селектора используется, когда LES/BUS и LEC конфигурируются для различных ELAN.

Основные шаги конфигурации включают:

  • Идентификацию оборудования, на котором будет работать LECS, и получение его автоматического адреса путем использования show lane default.
  • Идентификацию оборудования и подинтерфейсов, на которых будут работать пары LES/BUS для различных ELAN. Основываясь на номерах подинтерфейсов, необходимо получить ATM-адреса каждого LES, используя show lane default. Шестнадцатеричное значение номера подинтерфейса становится байтом селектора. Подинтерфейс 1 представляет селектор 01, подинтерфейс 2 - 02, и подинтерфейс 010 - 0A.
  • Конфигурацию коммутатора (коммутаторов) с ATM-адресом LECS.
  • Конфигурацию базы данных LECS с наименованиями ELAN и назначение ATM-адресов их LES. Запуск LECS.
  • Запуск пары LES/BUS на различных подинтерфейсах.
  • Запуск LEC на всех пограничных устройствах и создание ассоциаций ELAN/VLAN там, где это необходимо. Решение об использовании Virtual Trunking Protocol (VTP) принимается на этом же этапе.

В этом примере все службы LANE сконфигурированы на одном Catalyst 5000.

Конфигурация LightStream 1010

Каждый LEC для получения LECS ATM адреса запрашивает коммутатор ATM через интерфейс ILMI. Для обеспечения получения положительного ответа от коммутатора на нем должен быть сконфигурирован ATM-адрес LECS. Пример команды, назначающей адрес ATM для LECS на LightStream 1010:

Следует обратить внимание на то, что используемый адрес получен по команде show lane default от Catalyst 5000, исполняющего LECS. С этого момента коммутатор способен предоставлять клиентам адрес LECS, указывающий на Catalyst 5000.

Конфигурация Catalyst 5000 (службы LANE)

  • Конфигурация LECS. База данных LECS идентифицирует два сервера LANE, финансовый и маркетинговый, и их ATM-адреса. ATM-адреса для этих LES снова получаются в результате использования команды show lane default на Catalyst 5000. 19-байтный адрес для LES добавляется к номеру подинтерфейса (в шестнадцатеричном виде) и этот 20-байтный адрес используется для определения наименования ELAN и соответствия ей ATM-адреса LES. В нашем примере подинтерфейсы 1 и 2 используются для ELAN финансов и маркетинга соответственно. Эти LES-адреса являются теми адресами, которые LECS дает клиентам, пытающимся присоединиться к данной ELAN.

После того как определена база данных LECS, на Catalyst 5000 необходимо сконфигурировать основной (primary) интерфейс для исполнения LECS. Этот шаг выполняется командой lane config example, где example - база данных. Команда lane config auto-config-atm-address запускает LECS на Catalyst 5000.

Дополнительные детали конфигурации базы данных LECS:

  • Конфигурация имен ELAN на LEC. В этой конфигурации все LEC должны быть сконфигурированы с наименованием ELAN, которое может быть включено в их запрос Configure_Requests. Самая простая форма базы данных LECS должна содержать только список наименований ELAN и соответствующие им ATM адреса. В такой конфигурации все LEC, запрашивающие присоединение к данной ELAN, возвращаются к соответствующему ATM-адресу LES. Этот процесс показан на рис. 25. LEC, который не знает, к какой ELAN присоединиться, будет подключен к ELAN по умолчанию, если таковая сконфигурирована в базе данных LECS.
  • Конфигурация принадлежности LEC к ELAN в базе данных LECS. В нашей конфигурации вся информация централизована в базе данных LECS. Сами по себе LEC могут просто обратиться к LECS для выяснения вопроса о том, к какой ELAN они предполагают присоединиться. И хотя такая конфигурация немного сложнее, она обеспечивает лучший контроль над всеми ELAN и удобна в тех случаях, когда важен вопрос защиты. LEC идентифицируются своими собственными адресами ATM или MAC. Дополнительно имеется возможность использовать шаблоны префиксов адресов ATM, что очень удобно при создании отношений LEC и ELAN. Конфигурация показана в табл. 4.
  • Смешанная конфигурация. Возможна также конфигурация с использованием комбинации этих методов.

Таблица 5. Конфигурация базы данных LECS

Конфигурация 1 LEC-to-ELAN Соответствие на уровне LEC | Lane database test-1 Name finance les-atm-address 47.0091.8100.0000.0800.200c.1001.01 Name marketing les-atm-address 47.0091.8100.0000.0800.200c.1001.02 Default-name finance
Конфигурация 2 LEC-to-ELAN Соответствие в базе данных LECS | Lane database test-2 Name finance les-atm-address 47.0091.8100.0000.0800.200c.1001.01 Name marketing les-atm-address 47.0091.8100.0000.0800.200c.1001.02 Client-atm-address 47.0091.8100.0000.08 … name finance Client-atm-address 47.0091.8100.0000.08 … name marketing Mac-address 00c0.0000.0100.0100 name finance Mac-address 00c0.1111.2222 name marketing
  • Конфигурация LES/BUS. Подинтерфейс 0.1 должен быть сконфигурирован для предоставления услуг LES/BUS финансовой ELAN, а подинтерфейс 0.2 ? для ELAN маркетинга. Команда запуска LES/BUS для данной ELAN ? lane server-bus ethernet <ELAN name>. После выполнения команды подинтерфейс обслуживает ELAN, но фактически не имеет в ней клиентов.

С этого момента компоненты служб LANE готовы к функционированию и остается только зарегистрировать LEC на всех устройствах. Конфигурация LEC производится отдельно для каждого устройства.

Конфигурация клиента LANE

  • Конфигурация LEC на маршрутизаторе. Подинтерфейсы маршрутизатора, действующие как LEC, управляют маршрутизацией между VLAN. Для каждого нуждающегося в маршрутизации подинтерфейса должен быть сконфигурирован LEC. Командой lane client ethernet <elan name> запускается клиентское программное обеспечение. Если не указывать наименование ELAN, LECS либо обнаружит наименование в своей базе данных, либо назначит ELAN по умолчанию.
  • Конфигурация LEC на Catalyst 5000. С этого момента ISL VLAN-домен на Catalyst 5000 соответствует ATM ELAN-домену, и должен существовать некий путь, который осуществит отображение VLAN в ELAN. Решение следующее:

Команда lane client ethernet имеет дополнительное поле, позволяющее администратору назначить определенный VLAN для ATM ELAN. Такое присваивание должно быть выполнено для каждой VLAN в Catalyst 5000, которой требуется взаимодействие с ATM-доменом LANE. Таким путем осуществляется бриджинг через VLAN и ELAN.

  • Конфигурация LEC на Catalyst 5000 с VTP. Протокол VTP был создан для разрешения административных сложностей при создании соответствий ISL VLAN и 802.10 VLAN LANE-базирующимся ELAN. Используя VTP, можно создать для VLAN единственный идентификатор, и коммутатор автоматически установит соответствие номеров различных VLAN их наименованиям. ISL и 802.10 имеют числовую схему для идентификации VLAN, следовательно, VTP создаст таблицу соответствия номеров VLAN их наименованиям. С другой стороны, LANE уже использует наименования ELAN для идентификации VLAN, следовательно, наименование VLAN продолжает быть наименованием ELAN. Пример такого соответствия приведен в таблице 6.

Таблица 6. Пример VTP — соответствие ELAN, ISL и 802.10

Имя VLAN VTP | Имя ELAN LANE | Идентификатор ISL VLAN | Идентификатор 802.10 VLAN (SAID)
Finance | Finance | 1 | 100001
Marketing | Marketing | 2 | 100002

С точки зрения ATM-модуля Catalyst 5000, VTP может быть полезен для устранения конфигурационной сложности, так как он позволяет автоматически создавать LEC, в каком бы месте ни образовывалась новая VLAN/ELAN. Требованием для успешного функционирования VTP является наличие пары LES/BUS у всех ELAN. Если LES/BUS для данной ELAN не сконфигурирован, то и LEC для этой ELAN никогда не появятся. По умолчанию VTP выключен на ATM-модуле Catalyst 5000 и его следует включать глобальной командой "vtp enable".

ПРЕДУПРЕЖДЕНИЕ. Решение о применении VTP в сети LANE должно приниматься очень осторожно, так как для крупных сетей это может принести больше вреда, чем пользы. Некоторые аспекты включают:

  • Расходование SVC. Вопросы масштабируемости, связанные с расходованием SVC, обсуждаются далее в документе. VTP регистрирует все ELAN на всех коммутаторах, вне зависимости от того, нужны они или нет. Таким образом, может произойти чрезмерное расходование SVC для ATM-сети, превышающее допустимое количество.
  • Конфигурация LEC на Catalyst 3000. Как уже упоминалось ранее, Catalyst 3000 имеет отличную от Catalyst 5000 схему конфигурации. Здесь регистрация LEC происходит в две стадии: сначала необходимо изменить наименование VLAN, каким бы ни было наименование ELAN; затем нужно зарегистрировать LEC.

Конфигурация Cisco LANE с применением ATM-адресов, назначаемых пользователем

Назначение ATM-адресов пользователем требует определенного планирования и осторожного администрирования, но имеет некоторые преимущества. Единожды назначенные различным компонентам LANE, они оказываются защищенными при замене плат, супервизора или RSP.

Вопросы реального администрирования ATM-адресов лежат за рамками этого документа. Всю информацию можно получить из документации Форума ATM.

Пример конфигурации приведен в табл. 7.

Таблица 7. Конфигурация LANE с использованием ATM-адресов, назначаемых пользователем

Адреса компонентов LANE, предопределенные пользователем | LECS: 47.009188880000000000000000.00000000001.01 LES: 47.009188880000000000000000.00000000002.** BUS: 47.009188880000000000000000.00000000003.** LEC: 47.009188880000000000000000.00000000004.**
Простая конфигурация сервисов и клиентов LANE | Lane database example Name elan1 server-atm-address 47.009188880000000000000000.00000000002.01 Name elan2 server-atm-address 47.009188880000000000000000.00000000002.02 ! interface atm0 atm preferred phy A atm pvc 1 0 5 qsaal atm pvc 2 0 16 ilmi lane config config-atm-address 47.009188880000000000000000.00000000001.00 lane config database example ! interface atm0.1 multipoint lane client-atm-address 47.009188880000000000000000.00000000004.01 lane server-atm-address 47.009188880000000000000000.00000000002.01 lane bus-atm-address 47.0091888800 lane server-bus ethernet elan1 lane client ethernet 1 elan1 ! interface atm0.1 multipoint lane client-atm-address 47.009188880000000000000000.00000000004.02 lane server-atm-address 47.009188880000000000000000.00000000002.02 lane bus-atm-address 47.009188880000000000000000. 00000000003.02 lane server-bus ethernet elan2 lane client ethernet 2 elan2
Резервирование LANE

Работа Форума ATM над LANE дала потребителям начальный импульс для перевода рабочих групп и кампусных сетей на ATM. Применяя LANE, пользователи могут продолжать работать с уже существующими приложениями, ориентированными на функционирование в среде LAN, а также c широковещательными LAN-протоколами, но уже по ATM. LANE Version 1.0 определяет стандарты для межсетевого взаимодействия существующих сетей Ethernet и AppleTalk с устройствами ATM. Такие устройства включают конечные станции (например, ATM-серверы), пограничные устройства, обеспечивающие мосты от существующих LAN к магистрали ATM (например, Catalyst 5000) и маршрутизаторы ATM, обеспечивающие маршрутизацию между ELAN.

При всех преимуществах LANE 1.0 она имеет существенныйнедостаток: она не определяет механизмов для построения избыточности и отказоустойчивости в LANE. Более того, нерешенными остаются проблемы резервирования маршрутизаторов, путей и соединений. Понимание этих проблем и вытекающих отсюда требований потребителей для их решения позволило Cisco добавить некоторые механизмы, способствующие построению отказоустойчивых сетей ATM. Настоящий документ содержит разъяснения различных механизмов, а также основополагающие правила проектирования и вопросы, подлежащие согласованию при реализации сетей LANE.

Эта часть начинается с обсуждения протокола Simple Server Redundancy Protocol (SSRP), который был разработан для обеспечения резервирования служб услуг. Несмотря на то что многие производители имеют реализуют службы услуг LANE различных видов, все они нарушают спецификации LANE 1.0 и, следовательно, не могут взаимодействовать с реализациями других производителей. Протокол SSRP точно следует спецификации LANE 1.0 и, значит, обеспечивает взаимодействие с реализациями LEC других производителей, что является очень важным моментом в построении взаимодействующей сети ATM. За обсуждением протокола SSRP следует описание протокола Hot Standby Router Protocol over LANE, который предоставляет механизм для обеспечения резервирования маршрутизаторов. В завершение обсуждается протокол Spanning Tree и некоторые другие возможности оборудования, которые могут быть использованы для построения резервирования путей и соединений на пограничных устройствах. Такие вопросы, как обеспечение резервирования, или избыточности сети, полностью обеспечиваются например, протоколом PNNI, и эта тема не обсуждается в настоящем документе.

Проблемы в сети LANE 1.0

Основной проблемой в сети LANE 1.0 является то, что в определенный момент времени для LEC может быть доступен только один набор из компонентов служб LANE. Это определяется следующими ограничениями:

- только один LECS поддерживает все ELAN;

- на одну ELAN приходится только одна пара LES/BUS.

Сбой в любом из этих компонентов служб вызывает нарушение работоспособности сети:

- Сбой LECS. Воздействует на все ELAN, так как обеспечивает контроль доступа для всех ELAN. Несмотря на то что все существующие ELAN продолжают работать нормально (мы говорим о Cisco LEC), ни один новый LEC не сможет присоединиться ни к одной из ELAN, находящейся под управлением сбойного LECS. Также ни один LEC, желающий выполнить повторное соединение или поменять членство в группе на другую ELAN, не сможет этого сделать, так как LECS будет не в состоянии проверить LEC, пытающийся присоединиться к ELAN.

- Сбой LES/BUS. Пара LES/BUS нужна для управления работой ELAN. LES предоставляет услугу LE_ARP для перевода MAC-адресов в адреса ATM, а BUS обеспечивает обслуживание широковещательного и неопознанного трафика этой ELAN. Таким образом, возникновение сбоя в работе LES или BUS немедленно прекращает нормальное функционирование ELAN. Правда, сбой LES/BUS воздействует только на ELAN, обслуживаемую этой парой.

Ясно, что наличие этих проблем может оказаться решающим фактором при выборе сети ATM, основанной на применении LANE, особенно для тех сетей, в которых требуются отказоустойчивость и способность к быстрому восстановлению.

Кроме того, наличие общей отказоустойчивости окружения LANE зависит от принципа расположения сервисных компонентов LANE внутри сети ATM. Этот вопрос обсуждался здесь ранее.

Способность к быстрому восстановлению в сетях LANE 1.0

Повышение способности к быстрому восстановлению сетей, построенных на LANE, по существу, заключается в повышении отказоустойчивости в таких сервисных компонентах LANE, как LECS, LES и BUS. Необходимая отказоустойчивость обеспечивается протоколом SSRP через комбинацию служб LANE по принципу "основной/резервный".

Для обеспечения резервирования LECS один основной LECS дублируется несколькими резервными LECS. Резервирование LES/BUS осуществляется похожим образом и одна основная пара дублируется несколькими резервными. Заметим, что функции LES/BUS в реализациях Cisco всегда объединены и эта пара управляется как один элемент.

Резервирование LECS

По спецификации LANE 1.0 первым шагом для LEC во время инициализации является установка соединения с LECS для получения LES-адресов ATM той ELAN, к которой он желает присоединиться. Для обеспечения возможности LEC присоединится к LECS задействовано несколько механизмов. Первый механизм, который осуществляет LEC - это запрос к обслуживающему его коммутатору ATM для получения LECS-адресов. Процесс обнаружения адресов совершается при использовании протокола ILMI на VPI, VCI-0,16.

image15.gif (14982 bytes)

Рис. 15. Конфигурация нескольких LECS и инициализация LEC с использованием обнаружения адресов LECS

Адреса LECS конфигурируются в коммутаторе ATM. Для LightStream 1010 команда конфигурации для добавления LECS выглядит следующим образом:

atm-lecs-address <LECS NSAP address> <index>

При использовании SSRP в коммутаторе ATM конфигурируется несколько адресов LECS, как показано на рис. 15. LEC, который запрашивает от коммутатора ATM адрес LECS, получает в ответ полную таблицу адресов LECS. LEC должен попытаться присоединиться к первому по порядку LECS-адресу. Если соединения не происходит, LEC пытается присоединиться к следующему по порядку и так далее до тех пор, пока соединение с LECS не будет установлено.

В то время как LEC всегда пытается установить соединение с наивысшим по порядку доступным LECS, SSRP гарантирует, что есть только один основной, отвечающий запросу, пришедшему от LEC. Назначение основного LECS и расположение остальных в режим резервирования является основной задачей SSRP. Ниже описан механизм, используемый SSRP для установки основного LECS. После инициализации LECS получает от коммутатора таблицу адресов LECS, аналогично тому, как это происходит с LEC (см. рис. 15). Затем LECS пытается установить соединение со всеми LECS, следующими после него по списку в полученной им таблице. Если LECS имеет соединение (VCC), идущее от LECS, чей порядковый номер выше, чем его собственный, он устанавливается в режим резервирования. LECS с самым высшим порядковым номером не имеет соединений с другими LECS, находящимися выше него (их просто нет при такой схеме) и, следовательно, принимает роль основного.

Процедура, описывающая, каким образом резервный принимает на себя обеспечение работоспособности в случае "падения" основного, может быть объяснена с использованием следующего примера. На рис. 16 показана сеть LANE с четырьмя сконфигурированными LECS. Все коммутаторы ATM в сети сконфигурированы с одинаковыми адресными таблицами LECS. После инициализации А получает таблицу адресов LECS от коммутатора, к которому он присоединен и обнаруживает, что в списке ниже его имеется три LECS; теперь он пытается установить (и устанавливает) соединения с LECS B, C, и D. B, в свою очередь, соединяется с C и D, и C соединяется с D. Таким образом, происходит понижательная установка VCC, и поскольку А не имеет сверху никаких VCC, он и становится основным. Во время нормальной работы сети А отвечает на все запросы, а резервные B, C, и D не отвечают ни на какие. Если по каким-либо причинам основной (А) "падает" (например, сбой на линии, сбой оборудования и т.д.), тогда B теряет свой VCC от А и так же поступают остальные. С этого момента уже B не имеет ни одного VCC сверху и, таким образом, становится самым первым доступным LECS в сети. Теперь B является основным. C и D продолжают иметь соединения с LECS, имеющие более высокие порядковые номера, чем их собственные, и поэтому они так и остаются в режиме резервирования, как показано на рис. 16.

image16.gif (15247 bytes)

Рис. 16 (a) Нормальная работа четырех LECS (b) Работа после сбоя в основном LECS

Резервирование LES/BUS

Часть протокола SSRP, отвечающая за резервирование LES/BUS, поддерживает конфигурацию нескольких пар LES/BUS, которые работают в стиле основной/резервный. Тем не менее здесь используется механизм, отличный от используемого для резервирования LECS. Несколько пар LES/BUS для данной ELAN сначала конфигурируются в базе данных LECS, как показано на рис. 17. Внутри этой базы данных для каждой пары LES/BUS назначается приоритет. После инициализации каждая пара LES/BUS открывает VCC с основным LECS, используя механизм обнаружения LECS адресов, описанный выше. Пара LES/BUS с высшим приоритетом, имеющая открытый VCC к LECS, назначается основным LECS как основная LES/BUS.

image17.gif (11976 bytes)

Рис. 17. (a) Физический вид резервной конфигурации LES/BUS (b) Логический вид с базой данных LECS

При нормальных условиях работы все приведенные в примере пары LES/BUS B, C, и D имеют открытые VCC к основному LECS. Так как B имеет высший приоритет в соответствии с базой данных LECS, все запросы на присоединение, поступающие от LEC обрабатываются B. Если B теряет связь с сетью, то и его VCC к LECS разрываются. Все LEC, которые были частью данной ELAN, инициализируются повторно, так как активная пара LES/BUS для этой ELAN недоступна. LEC повторно отправляют к LECS свои запросы на присоединение. LECS, в свою очередь, перенаправляет эти запросы к следующей паре LES/BUS в порядке приоритета - в этом случае к C.

Таким образом, все LEC теперь присоединились к той же самой ELAN; активной парой для этой ELAN стала бывшая резервная пара LES/BUS. Этот процесс приведен на рис. 18.

Как совершенно ясно из описания этого процесса, применение SSRP вызывает потребление ресурсов только на уровне нескольких VC. Никакие другие накладные расходы не вызываются.

Для конфигурирования протокола SSRP в сети следует обращаться к руководству по конфигурированию Cisco IOS.

Основные принципы использования SSRP

Типы проектов

Теоретически количество LECS, конфигурируемых при помощи SSRP, не ограничено. Однако рекомендуемое число - два (один основной плюс второй в режиме резервирования) или три (один основной и плюс два в режиме резервирования). Большее количество следует применять только после очень тщательного обсуждения, так как резервирование добавляет сложности и очень обременительно при управлении и разрешении проблем, возникающих в сети.

Правила конфигурации

Для поддержки схемы резервирования LECS необходимо точно выполнять следующие правила конфигурации. Ошибки в выполнении этих правил приведут к некорректной работе SSRP и соответственно к некорректному функционированию сети в целом.

1.Каждый LECS должен содержать одинаковую базу данных ELAN. Поэтому сетевой администратор обязан обеспечивать это соответствие.

2. Адреса LECS в адресной таблице LECS должны быть сконфигурированы в одном и том же порядке на каждом коммутаторе ATM в сети.

3. При условии применения SSRP с общепризнанными адресами НЕ следует располагать два LECS на одном и том же коммутаторе ATM. Работать такая конфигурация не будет, так как только один LECS может зарегистрировать общепризнанный адрес на коммутаторе (через ILMI), зато вызовет проблемы во время инициализации.

image18.gif (10499 bytes)

Рис. 18. (a) LEC VCC с основным LES/BUS (b) Новый LEC VCC с резервным LES/BUS

Замечания по взаимодействию

SSRP может применяться для независимых LEC других производителей при условии, что они поддерживают механизм обнаружения адреса LECS через ILMI и обрабатывают соответствующим образом несколько адресов LECS, отправленных коммутатором ATM. Другими словами, LEC должен уметь пройти через присоединение к списку адресов LECS, возвращаемых коммутатором ATM. Первый LECS, который отвечает на конфигурационный запрос, является ведущим (master). Большинство производителей адаптеров, включая Olicom, Interphase, Adaptec и Efficient, выпускают SSRP-совместимые версии своих LEC, которые удовлетворяют этим условиям.

Работа SSRP с общепризнанными адресами LECS

SSRP работает также с общепризнанными адресами LECS (47.0079….), определенными в спецификации LANE 1.0. Cisco LECS умеет "слушать" несколько адресов ATM одновременно. Следовательно, он "слышит" и общепризнанный адрес в дополнение к автоматически сконфигурированному адресу (который можно увидеть по команде show lane). LECS регистрирует общепризнанный адрес на коммутаторе ATM таким образом, что коммутатор сможет выделять маршруты к общепризнанным адресам точно так же, как и маршруты любых запросов на установку соединения к любому корректному адресу. Однако в сети находятся несколько LECS, и если каждый из них зарегистрирует общепризнанный адрес ATM на коммутаторах, к которым они присоединены, запросы на установки соединений будут направлены к различным местам сети.

Таким образом, при работе с SSRP необходимо конфигурировать "автоматически конфигурируемый адрес" таким образом, чтобы сначала имело место определение ведущего (master), а затем уже ведущий зарегистрировал бы общепризнанный адрес на коммутаторе ATM. Тогда, в случае сбоя ведущего, общепризнанный адрес переместится вместе с ведущим LECS. PNNI на LightStream 1010 предложит новый маршрут для общепризнанного адреса после соответствующих изменений при назначении ведущим другого LECS. Следовательно, LEC других производителей, которые используют только общепризнанные адреса, тоже могут взаимодействовать с SSRP. SSRP это всего лишь схема резервирования, которая может использоваться практически с любым LEC.

Подводя итог, приведем перечень действий, необходимых для применения SSRP с общепризнанными адресами:

1. Сконфигурировать LECS способным "слушать" автоматически сконфигурированные адреса, которые должны быть запрограммированы в коммутаторе ATM для механизма обнаружения адресов LECS.

2. Сконфигурировать каждый LECS способным "слушать" общепризнанные адреса, используя команду lane config fixed-config-atm-address. После использования процедуры резервирования LECS с целью определения ведущего LECS последний регистрирует общепринятый адрес на ATM-коммутаторе, к которому он присоединен.

Предостережение. При использовании SSRP с общепринятыми адресами целесообразно располагать каждый LECS на отдельном коммутаторе из-за возможного дублирования адресов регистрации в процессе восстановления после сбоев, которое не позволяется ILMI.

Работа SSRP в разделенной сети

В случае разделения сети, когда из-за сбоя коммутатора или канала связи формируются две отдельные области ATM, каждая из них будет иметь свой собственный набор служб LANE, поэтому протокол SSRP следует конфигурировать с учетом, такой возможности. Иллюстрация к процессу приведена на рис. 19.

image19.gif (18722 bytes)

Рис. 19. Функционирование SSRP в разделенной на части сети

Для конфигурирования SSRP с учетом возможности разделения сети следует соблюдать следующие правила:

1. Конфигурировать каждую часть со своими собственными службами LANE, которые могут стать активными во время разделения сети. Например, если две кампусных сети должны взаимодействовать через общегородскую сеть (Metropolitan-area Network (MAN)) и в обеих сетях предполагается иметь одинаковые ELAN, каждый кампус следует конфигурировать со своими собственными службами LANE.

2. Особенно внимательно следует относиться к маршрутизации при разделении сети в том случае, если ELAN организована по сети уровня 3 (например, IP-подсеть, IPX-сеть и т.д.) и имеется два маршрута к одной и той же подсети (предполагаем, что в сети есть резервные маршрутизаторы). Если нет резервных маршрутизаторов, одна из этих частей эффективно изолирована от остальной сети; внутренний трафик ELAN продолжает вести себя должным образом.

HSRP по LANE

HSRP является протоколом, предназначенным для защиты сети от сбоев маршрутизаторов. Протокол работает между двумя маршрутизаторами, один из которых назначается в качестве основного интерфейса (или подинтерфейса) для данной подсети, в то время как второй функционирует в режиме "горячей" замены.

Два маршрутизатора, обменивающиеся протоколом HSRP, разделяют и считают общими IP- и MAC-адреса, принятые по умолчанию. Эти IP-адреса используются в качестве шлюза всеми IP-станциями для обеспечения взаимодействия между конечными станциями, находящимися за пределами их непосредственной подсети. Таким образом, когда происходит сбой основного маршрутизатора, резервный принимает на себя как адреса шлюза, так и MAC-адреса, что позволяет конечным станциям подсети продолжать взаимодействовать с конечными станциями, находящимися за пределами их подсети.

Так как HSRP представляет собой механизм уровня 2 и нуждается в сети, построенной на MAC адресах, имеется возможность выполнять восстановления в стиле HSRP по LANE. При этом используются такие же механизмы, как и для любого интерфейса Ethernet, которые могут быть сконфигурированы на уровне подинтерфейса.

На рис. 20 конечная IP-станция в данной подсети (которая размечена в ELAN) сконфигурирована с адресом по умолчанию маршрутизатора, который является тем же самым, что и "разделяемый" адрес HSRP. Каждый из маршрутизаторов имеет свой собственный адрес IP, который используется для обмена "приветственными" сообщениями с другими маршрутизаторами. Каждый маршрутизатор ? это LEC в данной ELAN. Между маршрутизаторами A и B устанавливается прямое SVC-соединение для обмена приветственными сообщениями.

Если основной маршрутизатор (A) "падает", резервный маршрутизатор (B) выжидает время, отведенное для трех "приветственных" сообщений, перед тем как взять на себя функцию нового владельца HSRP IP- и MAC-адресов. Когда MAC-адрес переходит к маршрутизатору B, все LEC должны выполнить повторное распределение MAC/ATM-адресов и обновить их кэши LE-ARP.

image20.gif (17473 bytes)

Рис. 20. HSRP по LANE (Под)интерфейсам

Пример конфигурации HSRP и SSRP

В этой части представлен пример конфигурации сети LANE, которая включает SSRP и HSRP (рис. 21).

Два коммутатора Catalyst 5000 (1 и 2) работают как основной и резервный для служб LANE. Для координации основного и резервного используется протокол SSRP. Маршрутизаторы 7507-1 и 7507-2 используют HSRP. 7507-1 является основным для 1-й и 2-й ELAN и резервным для 3-й и 4-й. 7507-2 является основным для 3-й и 4-й ELAN и резервным для 1-й и 2-й ELAN.

image21.gif (15723 bytes)

Рис. 21. Пример сети LANE, исполняющей SSRP и HSRP

Таблица 8. Конфигурация SSRP

Catalyst 5000-1 (Основной)

Lane database lecsdb

Name elan1 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.01

Name elan1 server-atm-address 47.009181000000006170599301.00400BE6A041.01

Name elan2 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.02

Name elan2 server-atm-address 47.009181000000006170599301.00400BE6A041.02

Name elan3 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.03

Name elan3 server-atm-address 47.009181000000006170599301.00400BE6A041.03

Name elan4 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.04

Name elan4 server-atm-address 47.009181000000006170599301.00400BE6A041.04

!

interface ATM0

mtu 1500

no ip address

atm pvc 1 0 5 qsaal

atm pvc 1 0 16 ilmi

lane config auto-config-atm-address

lane config database lecscdb

!

interface ATM0.1 multipoint

lane server-bus ethernet elan1

!

interface ATM0.2 multipoint

lane server-bus ethernet elan2

!

interface ATM0.3 multipoint

lane server-bus ethernet elan3

!

interface ATM0.4 multipoint

lane server-bus ethernet elan4

Catalyst 5000-2 (резервный)

Lane database lecsdb

Name elan1 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.01

Name elan1 server-atm-address 47.009181000000006170599301.00400BE6A041.01

Name elan2 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.02

Name elan2 server-atm-address 47.009181000000006170599301.00400BE6A041.02

Name elan3 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.03

Name elan3 server-atm-address 47.009181000000006170599301.00400BE6A041.03

Name elan4 server-atm-address 47.00918100000000613E5C0901.00400BE69C31.04

Name elan4 server-atm-address 47.009181000000006170599301.00400BE6A041.04

!

interface ATM0

mtu 1500

no ip address

atm pvc 1 0 5 qsaal

atm pvc 1 0 16 ilmi

lane config auto-config-atm-address

lane config database lecscdb

!

interface ATM0.1 multipoint

lane server-bus ethernet elan1

!

interface ATM0.2 multipoint

lane server-bus ethernet elan2

!

interface ATM0.3 multipoint

lane server-bus ethernet elan3

!

interface ATM0.4 multipoint

lane server-bus ethernet elan4

Таблица 9. Конфигурация HSRP

Cisco 7507-1 | Cisco 7507-2
Primary – ELAN 1, 2 Backup – ELAN 3, 4 ! interface ATM5/0 mtu 1500 no ip address ip route-cache optimum atm pvc 1 0 5 qsaal atm pvc 1 0 16 ilmi ! interface ATM5/0.1 multipoint ip address 137.80.110.3 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 11 standby 1 priority 101 standby 1 preempt standby 1 ip 137.80.110.1 bridge-group 1 ! interface ATM5/0.2 multipoint ip address 137.80.111.3 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 12 standby 2 priority 101 standby 2 preempt standby 2 ip 137.80.111.1 bridge-group 1 ! interface ATM5/0.3 multipoint ip address 137.80.112.3 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 13 standby 3 priority 101 standby 3 preempt standby 3 ip 137.80.112.1 bridge-group 1 ! interface ATM5/0.4 multipoint ip address 137.80.113.3 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 14 standby 4 preempt standby 4 ip 137.80.113.1 bridge-group 1 | Primary – ELAN 3, 4 Backup – ELAN 1, 2 ! interface ATM5/0 mtu 1500 no ip address ip route-cache optimum atm pvc 1 0 5 qsaal atm pvc 1 0 16 ilmi ! interface ATM5/0.1 multipoint ip address 137.80.110.2 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 11 standby 1 preempt standby 1 ip 137.80.110.1 bridge-group 1 ! interface ATM5/0.2 multipoint ip address 137.80.111.2 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 12 standby 2 priority 101 standby 2 preempt standby 2 ip 137.80.111.1 bridge-group 1 ! interface ATM5/0.3 multipoint ip address 137.80.112.2 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 13 standby 3 priority 101 standby 3 preempt standby 3 ip 137.80.112.1 bridge-group 1 ! interface ATM5/0.4 multipoint ip address 137.80.113.2 255.255.255.0 no ip redirects lane client ethernet elan1 ipx network 14 standby 1 priority 101 standby 4 preempt standby 4 ip 137.80.113.1 bridge-group 1

Таблица 10. Конфигурация LS1010 и пример конфигурации LEC

LS1010-1, LS1010-2, LS1010-3, LS1010-4

!

atm lecs-address-default 47.0091.8100.0000.0061.3e5c.0901.0040.0be6.9c33.00

atm lecs-address-default 47.0091.8100.0000.0061.7059.9301.0040.0be6.a043.00

Пример конфигурации LEC

!

interface ATM0

mtu 1500

no ip address

supervisor-engine-ip <ip-address>

atm pvc 1 0 5 qsaal

atm pvc 1 0 16 ilmi

!

interface ATM0.1 multipoint

no ip address

lane client ethernet elan1

!

interface ATM0.2 multipoint

no ip address

lane client ethernet elan2

!

interface ATM0.3 multipoint

no ip address

lane client ethernet elan3

!

interface ATM0.4 multipoint

no ip address

lane client ethernet elan4

Карта dual PHY ATM для Catalyst 5000

С точки зрения физической топологии сети имеет место другой аспект для обеспечения резервирования. Хорошим решением является добавление двойного PHY-порта для обеспечения резервирования на модуле LANE коммутатора Catalyst 5000. Двойное PHY-резервирование представляет собой только аппаратный уровень и применяется в случаях, когда происходит отказ основного канала к коммутатору ATM.

Если карта используется только для LANE-клиента (или клиентов), нет отличий в конфигурации по сравнению с одним PHY. Однако в случае использования модуля для предоставления служб LANE (LECS, LES/BUS) необходимо принять во внимание некоторые основные правила.

Какие существуют проблемы?

Как уже обсуждалось в части 7.3.1, 13-байтный префикс адреса ATM для компонентов LANE на Catalyst 5000 получается от коммутатора ATM по ILMI. В конфигурации с одним используемым восходящим каналом проблем нет, так как имеет место только один префикс адреса ATM. В случае же с двойной PHY LANE-картой имеют место два восходящих канала, и Catalyst 5000 дважды и в одинаковой степени может использоваться различными LS1010, как показано на рис. 22. Каждый LS1010 имеет свой префикс ATM-адреса и, следовательно, Catalyst 5000 получит определенный 13-байтный префикс в зависимости от того, какой канал (PHY-A или PHY-B) активен. Пример приведен в табл. 11.

image22.gif (8404 bytes)

Рис. 22. dual PHY ATM

Таблица 11. Пример адресации по умолчанию с использованием модуля dual PHY

Результаты команды “show lane default” при активном соединении через PHY-A

Interface ATM0:

LANE Client: 47.00918100000000605C71F401.00603E9EFC30.**

LANE Server: 47.00918100000000605C71F401.00603E9EFC31.**

LANE Bus: 47.00918100000000605C71F401.00603E9EFC32.**

LANE Config Server: 47.00918100000000605C71F401.00603E9EFC33.00

Note: ** is the subinterface number byte in hex

Результаты команды “show lane default” при активном соединении через PHY-B

Interface ATM0:

LANE Client: 47.00918100000000603E5C4701.00603E9EFC30.**

LANE Server: 47.00918100000000603E5C4701.00603E9EFC31.**

LANE Bus: 47.00918100000000603E5C4701.00603E9EFC32.**

LANE Config Server: 47.00918100000000603E5C4701.00603E9EFC33.00

Note: ** is the subinterface number byte in hex

Эти несколько адресов необходимо корректно сконфигурировать в базе данных LANE и адресной таблице LECS LS1010. На рис. 22 ATM-адреса LECS коммутатора C5000-1 - A.1 и B.1, где A и B являются 13-байтными префиксами ATM-адреса для LS1010-1 и LS1010-2 соответственно. Для C5000-2 LECS ATM-адреса - A.2 и B.2.

Конфигурирование клиентов LANE на карте Dual-PHY LANE

ATM-адреса клиентов LANE обычно никогда не конфигурируются в базе данных LANE, и, следовательно, LECS не интересуется ATM-адресами присоединившихся LEC. Тем не менее при необходимости в защите информации и вытекающей отсюда потребности конфигурировать ATM-адреса LEC для обеспечения возможности присоединиться к определенной ELAN становится важным сконфигурировать в базе данных LANE оба ATM-адреса, ассоциирующихся с LEC на Catalyst 5000.

Конфигурирование служб LANE на карте dual PHY LANE

Использование адресации по умолчанию: ATM-адреса LECS и LES используются для конфигурирования таблицы LECS на LS1010 и базы данных LANE соответственно. В связи с тем что для карты dual PHY LANE существует несколько адресов, порядок, в котором они отображаются в таблице LECS и базе данных LANE, становится очень важным.

В примере, показанном на рис. 22, ATM-адреса LECS для C5000-1 - A.1 и B.1; они же для C5000-2 - A.2 и B2. Эти адреса должны быть помещены в адресную таблицу LECS LS1010. Ниже приведено два варианта того, как это можно сделать:

  • LECS-последовательность — A.1, A.2, B.1, B.2: (РЕКОМЕНДУЕТСЯ) Такая последовательность определяет, что после "падения" основного LECS (A.1), резервным LECS, который примет на себя функционирование в качестве основного, станет A.2. Другими словами, основной переместится с C5000-1 на C5000-2. Так как C5000-2 уже работает, весь процесс занимает минимум времени. Такой последовательностью обеспечивается также минимальное количество переключений "основной/резервный" между LECS. В следующем примере показано, каким образом это количество может быть увеличено из-за применения нерекомендуемой последовательности LECS.
  • LECS последовательность — A.1, B.1, A.2, B.2. Такая последовательность определяет, что резервным LECS является резервный PHY на том же самом Catalyst 5000, то есть B.1. После сбоя основного LECS (A.1) следующим доступным LECS для принятия на себя функций основного станет A.2. Это произойдет из-за запаздывания по времени "поднятия" второго резервного порта (B.1) по сравнению с A.2. Однако, как только B.1. "поднимется" и станет активным, он возьмет на себя функции основного от A.2. Клиентам LANE, которые уже начали использовать A.2, придется инициализироваться повторно, так как статус сети изменился. Ясно, что появляется один дополнительный и совершенно не нужный шаг в сценарии восстановления по сравнению с приведенной выше схемой назначения последовательности. Одновременно с увеличением количества переключений "основной/резервный" между LECS увеличивается и время на восстановление после сбоя. Таким образом, эта схема не рекомендуется.

Пример конфигурации приведен ниже.

Таблица 12. Пример конфигурации служб LANE с использованием адресации по умолчанию и модуля dual PHY LANE

Таблица LECS – LS1010

!

atm lecs-address-default 47.0091.8100.0000.0060.5C71.F401.0060.3E9E.FC33.00 /*A.1*/

atm lecs-address-default 47.0091.8100.0000.0060.5C71.F401.0040.0BE6.9C33.00 /*B.1*/

atm lecs-address-default 47.0091.8100.0000.0060.3E5C.4701.0060.3E9E.FC33.00 /*A.2*/

atm lecs-address-default 47.0091.8100.0000.0060.3E5C.4701.0040.0BE6.9C33.00 /*B.2*/

!

Конфигурация базы данных LANE

!

lane database lecsdb

name elan1 server-atm-address 47.00918100000000605C71F401.00603E9EFC31.00 /*A.1*/

name elan1 server-atm-address 47.00918100000000605C71F401.00400BE69C31.00 /*B.1*/

name elan1 server-atm-address 47.00918100000000603E5C4701.00603E9EFC31.00 /*A.2*/

name elan1 server-atm-address 47.00918100000000603E5C4701.00400BE69C31.00 /*B.2*/

!

Заключение

Схема проектирования сети с резервированием, обсуждаемая здесь, дает полное представление о наиболее существенных недостатках в спецификации Форума ATM для LANE, а также охватывает некоторые вопросы резервирования оборудования в сетях LANE. Построение отказоустойчивых и способных к быстрому восстановлению работоспособности сетей LANE возможно при использовании:

  • Протокола Simple Server Replication Protocol (SSRP) для резервирования служб LANE, который работает с LEC Cisco и других производителей.
  • Протокола Hot Standby Router Protocol (HSRP) по LANE, который обеспечивает резервирование маршрутизаторов.
  • Карты dual PHY LANE на Catalyst 5000 или ATM портов для нескольких восходящих каналов Catalyst 3000.
  • Протокола Spanning Tree на Ethernet/ATM-коммутаторах.

Приложение 1. Функционирование сети LANE

Эта часть предоставляет детальное рассмотрение различных частей LANE и предназначена для сетевых инженеров, которые сталкиваются со сложностями при разрешении проблем, возникающих в сети LANE.

Компоненты LANE

Компоненты LANE включают следующее:

  • LAN Emulation Client (LEC) — рабочие станции и серверы, коммутаторы Catalyst или маршрутизаторы Cisco, которые поддерживают LANE. LEC эмулирует интерфейс для существующих сетей к протоколам высокого уровня. Выполняет пересылку данных, разрешение адресов, регистрацию MAC-адресов в LES и взаимодействие с другими LEC через ATM VCC.
  • LAN Emulation Configuration Server (LECS). LECS содержит базу данных всех эмулируемых ELAN и ATM-адреса LES, которые управляют этими ELAN. Он принимает запросы от LEC и отправляет ему список всех эмулируемых сетей и их параметров, включая информацию об ATM-адресах LES, обслуживающих соответствующие ELAN/VLAN. База данных определяется и управляется сетевым администратором.

Таблица 13. Пример базы данных LECS

Имя ELAN | Адреса LES
Finance | 47.0091.8100.0000.0800.200c.1001.01
Marketing | 47.0091.8100.0000.0800.200c.1001.02
  • LAN Emulation Server (LES). LES обеспечивает автоматическое построение транзитных адресных таблиц и является центральной точкой управления для всех LEC. Каждый LEC выполняет прямое виртуальное соединение (Control_Direct VCC) к LES и сообщает ему свои MAC- и ATM-адреса. Для всех LEC LES устанавливает виртуальное соединение VCC “один-ко-многим” (point-to-multipoint), называемое Control_Distribute VCC и предназначенное только для пересылки служебной информации. Каждый новый LEC, присоединившийся к ELAN, добавляется к мультивещательному соединению.

image23.gif (20196 bytes)

Рис. 23. (a) Соединения LES A-1(b) Соединения BUS

  • Broadcast and unknown server (BUS). Сервер BUS организует доставку кадров с широковещательными и мультивещательными адресами, а также кадров, ATM-адрес пограничного коммутатора которых неизвестен клиенту LEC, всем узлам эмулируемой сети. Сервер BUS имеет отдельный ATM-адрес, который сообщается сервером LES клиенту LEC при его присоединении к эмулируемой сети. Клиент LEC должен после этого установить с сервером BUS прямое виртуальное соединение Multicast_Send VCC, по которому он будет пересылать кадры с широковещательными или неизвестными адресами. Сервер BUS добавляет каждого нового клиента LEC к мультивещательному соединению Multicast_Forward VCC. Это соединение используется сервером BUS для одновременной рассылки широковещательных кадров и кадров с неизвестными адресами всем пограничным коммутаторам эмулируемой сети.

LANE определена на уровне адаптации ATM (AAL5), не позволяющем перемешивать ячейки разных кадров в виртуальном канале. Проблемой, заключающейся в дифференциации ячеек ATM различных отправителей при мультиплексировании по виртуальному каналу, занимается BUS. Подразумевается, что ячейки прибывают в последовательности; по прибытии ячейки, содержащей "конец сообщения" (EOM), необходимо просто собрать все уже прибывшие ячейки. BUS должен принять последовательность ячеек по каждому виртуальному соединению Multicast_Send VCC и собрать их в кадры. После того как кадр принят полностью, формируется запрос на отправку его по виртуальному соединению Multicast_Forward VCC. Такой способ гарантирует упорядоченную отправку ячеек, относящихся к определенному кадру, не чередующуюся с ячейками, относящимися к другим кадрам.

Этот процесс, называемый "сериализацией", показан на рис. 24.

image24.gif (13316 bytes)

Рис. 24. Разбиение пакетов в Protocol Data Units и сериализация в BUS

Функционирование ELAN

ELAN обеспечивает коммуникации уровня 2 между всеми пользователями этой сети. В одной и той же ATM-сети может работать одна или несколько ELAN. Тем не менее каждая ELAN независима от других, и пользователи отдельных ELAN не могут взаимодействовать друг с другом напрямую.

Взаимодействие между ELAN возможно только при помощи маршрутизаторов или мостов.

Так как ELAN предоставляет коммуникации уровня 2, она может быть выделена в область распространения широковещательного трафика или широковещательный домен. VLAN тоже могут рассматриваться как широковещательные домены, что делает возможным отображение ELAN в VLAN на коммутаторах уровня 2 с различными технологиями мультиплексирования, такими как ISL или 802.10.

ELAN управляется одной парой LES/BUS. ELAN состоят из нескольких однотипных LEC типа Ethernet или AppleTalk, но не обоих типов одновременно.

Каждый LEC данной ELAN должен выполнить определенную последовательность действий, которые описываются в следующем разделе.

Регистрация ATM-адреса

Первым шагом для LEC является регистрация его ESI на ATM-коммутаторе, к которому он присоединен, и получение от него 13-байтного префикса ATM-адреса. Эта процедура известна под названием "address registration" и обеспечивается интерфейсом ILMI. После завершения фазы регистрации адреса LEC "узнает" свой полный ATM-адрес, который впоследствии используется под названием "Calling Party address" в служебных запросах. Коммутатору ATM тоже известен ATM-адрес LEC, что позволяет ему корректно доставлять сообщения, предназначенные для LEC.

Обнаружение LECS

Для того чтобы LEC мог получить доступ к данной ELAN, он должен сначала найти LECS. В частности, должен быть известен ATM-адрес LES, обслуживающего требуемую ELAN. Обнаружить ATM-адрес LECS можно тремя способами:

  • Запросить коммутатор ATM через ILMI. Сетевой администратор отвечает за конфигурирование коммутатора ATM, содержащего базу данных с адресами LECS. LEC может контактировать с LECS по UNI.
  • Искать фиксированные или общепризнанные ATM-адреса LECS, которые определены Форумом ATM, обращаясь к ним напрямую.
  • Доступ по PVC 0/17, “общепризнанный PVC”. Эта опция используется редко и не включена в качестве опции в LEC Cisco.

Контактирование с LECS

LEC создает служебный пакет с ATM-адресом LECS. Устанавливает прямое соединение Configure_Direct VCC и выполняет запрос LE_CONFIGURE_REQUEST. LEC либо знает, к какой ELAN он желает присоединиться, и включает эту информацию в свой запрос, либо просто запрашивает LECS о ELAN, содержащихся в базе данных LECS. LEC также включает в свой запрос такую информацию, как свой собственный MAC-адрес, тип ELAN (Ethernet или Token Ring) и т.д.

Если удовлетворяющие LEC варианты будут обнаружены, он получит ответ LE_CONFIGURE_RESPONSE, содержащий ATM-адрес LES, обслуживающего требуемую ELAN.

image25.gif (12517 bytes)

Рис. 25. Инициализация LEC — Обнаружение адреса LECS и процедура запроса

Присоединение к LES

После того как LEC обнаружит ATM-адрес требуемого LES, он разрывает соединение с LECS, создает служебный пакет с ATM-адресом LES и устанавливает прямое виртуальное соединение Control_Direct VCC. После успешной установки этого соединения LEC отправляет LE_JOIN_REQUEST. Этот запрос содержит как ATM-адрес LEC, так и MAC-адрес, которые требуется зарегистрировать в ELAN.

Эта информация контролируется таким образом, что регистрация двух LEC с одинаковыми адресами ATM или MAC невозможна.

После принятия запроса LE_JOIN_REQUEST Cisco LES по своему собственному открытому соединению с LECS проверяет его, таким образом подтверждая принадлежность клиента к группе. После успешной проверки LES добавляет LEC к своему мультивещательному соединению “один-к-многим” Control_Distribute VCC. И, наконец, LES отправляет для LEC благоприятный ответ LE_JOIN_RESPONSE, содержащий идентификатор клиента LANE (LECID), являющийся уникальным для каждого нового клиента. Этот идентификатор используется LEC для отделения собственного широковещательного трафика, поступающего от BUS.

Обнаружение BUS

Теперь, когда LEC успешно присоединился к LES, его первостепенной задачей является обнаружение ATM-адреса BUS и присоединение к широковещательной группе. LEC создает запрос LE_ARP_REQUEST с MAC-адресом 0xFFFFFFFF. Этот специальный пакет отправляется по Control_Direct VCC к LES. LES понимает, что LEC ищет BUS, формирует LE_ARP_RESPONSE с ATM-адресом BUS и отправляет этот ответ по Control_Distribute VCC.

Присоединение BUS

После обнаружения ATM-адреса BUS следующими действиями LEC будет создание служебного пакета с эти адресом и установка Multicast_Send VCC. Затем BUS добавляет LEC к мультивещательному соединению Multicast_ Forward VCC.

С этого момента LEC является членом ELAN. Полностью процесс показан на рис. 26.

Взаимодействие LEC-to-LEC

Ценность LANE обнаруживается и при работе с однонаправленным (unicast) трафиком между LEC. Для понимания того, каким образом организована такая взаимосвязь между двумя LEC, допустим, что две конечные IP-станции, A и B, нуждаются в общении друг с другом. Для упрощения предположим, что эти станции напрямую присоединены к ATM и являются частью одной и той же "Ethernet" ELAN. Если станции A необходимо связаться со станцией B, она должна выполнить следующие действия:

  • Получить IP-адрес B из Domain Name System (DNS) или из другой схемы разрешения адресов.
  • Выполнить запрос IP ARP о MAC-адресе B. Этот широковещательный пакет и будет отправлен по Multicast_Send VCC. Затем BUS перешлет этот пакет по Multicast_Forward VCC всем LEC в данной ELAN.

image26.gif (20958 bytes)

Рис. 26. Инициализация LEC: присоединение LES и соединение с BUS

  • B получает этот распространенный IP ARP, распознает в нем свой собственный IP- адрес и отправляет его к A в виде однонаправленного пакета. LEC на B, которому надо передать этот пакет, понимает, что ему надо установить прямое соединение Data_Direct VCC с A, но ему необходимо знать для этого ATM-адрес A. Для получения этого адреса B выполняет запрос LE_ARP_REQUEST к LES по Control_Direct VCC. LE_ARP_REQUEST содержит MAC-адрес A. LES пересылает этот запрос по Control_Distribute VCC, чтобы все LEC-станции могли его услышать. Одновременно с этим однонаправленный пакет (IP ARP-ответ) отправляется к BUS для того, чтобы быть разосланным всем конечным станциям. Такая "лавинообразная маршрутизация", не являющаяся оптимальным путем для распространения однонаправленного трафика, используется только в период выполнения процедуры LE-ARP.

В рамках ограничения такого "неправильного" использования пути передачи применяется ограничение скорости, установленное в 10 пакетов в секунду (для LANE). Однонаправленные пакеты используют BUS до тех пор, пока не завершится LE_ARP.

  • A получает LE_ARP_REQUEST и распознает свой собственный MAC-адрес в запросе. Затем формирует ответ LE_ARP_RESPONSE и отправляет его к LES, который пересылает его по Control_Distribute VCC для того, чтобы все LEC смогли узнать новую привязку адресов "MAC к ATM". LEC на станции B, соответственно, узнает об этом тоже.
  • Теперь B может использовать UNI для обращения к ATM-адресу A по сигнальному PVC 0,5.
  • Во время ожидания завершения работы LE_ARP и установки Data_Direct VCC, LEC пересылает "нераспознанные" однонаправленные пакеты по пути BUS. Когда соединение Data_Direct VCC становится доступным, если LEC немедленно переключается на новый маршрут, возникает риск получения неупорядоченных пакетов. Такая вероятность велика из-за того, что путь BUS медленнее, чем новый “оптимальный” путь. Пакеты, отправленные по пути BUS, до пункта назначения доберутся позже, чем отправленные по оптимальному пути. Стандарт LANE для защиты от таких ситуаций предоставляет протокол, известный под названием “flush protocol”. Под управлением этого протокола происходит следующее. После того, как становится доступным соединение Data_Direct VCC, LEC генерирует “flush”-пакет и отправляет его к BUS по Multicast_Send. LEC пункта назначения (A) получает этот запрос и отвечает, отправляя этот пакет обратно по Control Path (LES). Когда отправляющий LEC (B) получает свой собственный пакет “flush” по Control_Distribute VCC, он узнает, что все предварительно отправленные однонаправленные пакеты должны быть уже пересланными. И теперь можно без риска начать использовать Data_Direct VCC. Большинство однонаправленного трафика в сети LANE передается по этим Data_Direct VCC.

Proxy LEC

Когда LEC реализуется на конечной станции, он должен представить только один MAC-адрес в ELAN. Он будет отвечать на любой запрос LE_ARP_REQUESTS, отправленный по этому MAC адресу. Однако в случае реализации LEC на коммутаторе/мосте такое устройство должно представлять (или быть proxy) несколько MAC-адресов, так как к нему подключено несколько конечных Ethernet-станций; то есть устройство должно отвечать на многочисленные запросы LE_ARP_REQUESTS. Такие LEC называются proxy LEC, и реализуются на коммутаторах уровня 2, например Catalyst 5000, 3000 и т.д. На маршрутизаторах реализуются простые LEC, за исключением случаев, когда на подинтерфейсе маршрутизатора конфигурируется бриджинг.

Используемая литература

  1. ATM Internetworking—White Paper—Anthony Alles.
  2. The Next-Generation ATM Switch: From Testbeds to Production Networks—White Paper—Anthony Alles http://wwwin.cisco.com/Mkt/cmc/cc/cisco/mkt/switch/ls1010/ngatm_wp.htm

3. Designing ATM networks using the Catalyst 3000 ATM module—Implementation Guide—Marcus Phipps— http://wbu-pme/mphipps/3katm-ig.htm.

4. VLAN Technologies Handbook—Design Guide—Merwyn Andrade.


Проектирование кампусных сетей

Copyright (C) Cisco Systems, Inc., (С) PLUS Communications, 1998

Проектирование кампусных

сетей

Введение

Данный материал представляет собой переработанное руководство по проектированию крупных кампусных сетей фирмы Cisco Systems. В решениях, заложенных в основу настоящего руководства, использовано существующее на данный момент оборудование, программное обеспечение и технологии, разработанные фирмой Cisco Systems.

Ниже приводятся описания специализированных примеров и приемов проектирования, основанных на конкретном пакете требований заказчиков. Рассматриваются две базовые модели построения крупных корпоративных сетей:

  • коммутируемая сеть Ethernet с ядром, основанным на применении технологии Fast Ethernet.
  • коммутируемая сеть Ethernet с ядром, основанным на применении технологии ATM (Asynchronous Transfer Mode).

Методология, представленная в настоящем руководстве, отражает традиционный и практический подходы к проектированию систем такого класса, однако изложенные здесь принципы и пути реализации проекта не являются единственно правильным решением проблемы. Фактически руководство можно рассматривать как свод общих рекомендаций по проектированию, основанных на собственных аппаратных и программных разработках фирмы Cisco Systems. Многие технические решения явились прямым следствием ранних наработок инженеров и разработчиков компании. Так, например, сетевая операционная система Cisco IOS™, под управлением которой работают все устройства фирмы, содержит в себе полный набор средств, позволяющих осуществлять функции конфигурирования аппаратуры, оптимизации сетевого трафика, обеспечения защиты данных от несанкционированного доступа и т.д.

Итак, перейдем к обсуждению проектных решений.

Содержание

Существующая сетевая система

Требования заказчика

Методы проектирования

Сеть, основанная на Ethernet

Уровень доступа

Адресация IP и разбиение на подсети (структура VLAN)

Уровень распределения

Масштабирование полосы пропускания

Назначение серверов рабочих групп

Принципы организации уровня ядра сети

Ядро сети с использованием выделенных маршрутизаторов

Обеспечение увеличения полосы пропускания на уровне ядра

Соединения внутри ядра системы

Ядро системы с применением аппаратуры маршрутизации, встроенной

в коммутаторы уровня распределения

Корпоративные серверы

Поддержка мультикастинга IP

Поддержка других технологий и подключение к внешним сетям

Итоги рассмотрения проекта сети на основе Fast Ethernet

Анализ отказоустойчивости

Общие комментарии

Сеть, основанная на ATM

Уровень доступа и структура VLAN

Соединения уровня доступа с уровнем распределения

Анализ отказоустойчивости

Масштабирование полосы пропускания между уровнями доступа

и распределения

Серверы рабочих групп

Ядро на основе ATM

Масштабирование ядра системы

Маршрутизация Inter-ELAN

Подключение к внешним сетям

Расчет количества виртуальных подключений LANE

Анализ отказоустойчивости

Переход к сетям ATM, использующим MPOA

Общие замечания

Преимущества проекта на Fast Ethernet

Преимущества проекта на ATM

Существующая сетевая система

Существующая сетевая система заказчика переживает трудные дни. Будучи основанной на использовании традиционной технологии shared Ethernet (разделяемая сеть Ethernet), эта система уже не в состоянии обрабатывать все возрастающие объемы данных. Рост объема передаваемых по сети данных связан с появлением приложений, работающих с данными мультимедиа, а также с развитием технологий обработки и представления данных. В качестве примеров таких технологий можно привести приложения клиент/сервер, позволяющие производить обработку данных большим числом конечных пользователей.

В основе существующей сетевой системы находятся такие устройства, как сетевые концентраторы (повторители), составляющие сильно загруженное ядро системы, и маршрутизаторы, обеспечивающие соединения отдельных сегментов сети.

Характеристики сети, взятой нами для примера, следующие:

  • Количество рабочих мест – 6000, из которых большинство оборудовано компьютерами, совместимыми с IBM PC, 95% всех сетевых соединений работают по технологии Ethernet, 5% составляет Token Ring.
  • Используемые сетевые протоколы – IP, IPX, ограниченное количество станций используют AppleTalk, некоторые станции и сегменты – NetBIOS.
  • В сети имеется несколько больших корпоративных серверов, а также достаточно большое количество серверов рабочих групп.
  • Вся сеть имеет IP-адрес 10.0.0.0 (см. RFC-1918).
  • Ядро системы составляют концентраторы (повторители) и маршрутизаторы AGS+/Cisco 7000 series.
  • В сети наблюдается высокая загруженность активного сетевого оборудования, сетевых соединений, начиная от серверных сегментов и заканчивая пользовательскими подсетями.

Текущее распределение трафика невозможно отследить, однако считается, что основной его объем создают приложения клиент/сервер с небольшим добавлением трафика, возникающего при обращении к серверам и службам WWW.

Требования заказчика

Известно, что для того чтобы повысить эффективность работы конечных пользователей сети, серверы должны иметь высокоскоростные подключения к ядру (центральному коммутатору) сетевой системы. Для удовлетворения возрастающих требований приложений к пропускной способности сетевых систем необходим некоторый запас быстродействия, который обеспечил бы нормальное функционирование системы в течение нескольких лет. В связи с этим заказчики предъявляют к проектируемым сетям следующие обязательные требования:

  • Наличие коммутируемых портов Ethernet на каждом рабочем месте сети.
  • Функционирование серверов под управлением ОС Microsoft Windows NT, использующих в качестве основного протокол IP.
  • Функционирование корпоративных серверов вспомогательного назначения (электронная почта, обработка сообщений, WWW), а также высокопроизводительных серверов рабочих групп, интенсивно использующих полосу пропускания, и мультимедиа-серверов для осуществления мультикастинговой трансляции по протоколу IP.
  • Поддержка принципов “plug-and-play” при добавлении, перемещении и изменении конфигурации узлов сети (рабочих станций, групп, серверов и т.п.).
  • Отсутствие так называемых единичных точек сбоя в системе (single point of failure), при котором выход из строя любого компонента активного сетевого оборудования приводит к отключению не более чем 100 рабочих станций сети;
  • Возможность проведения контрольных измерений нагрузки на сетевые соединения и оборудование, а также управления потоками данных с целью оптимизации работы сети.
  • Возможность увеличения полосы пропускания некоторых участков сети при использовании имеющегося оборудования.
  • Возможность подключения системы к внешним сетям, в том числе к таким, которые используют другие технологии передачи данных (другие реализации ЛВС, глобальные сети, Интернет).
  • Возможность эффективного роста сетевой системы при минимальном вложении средств в оборудование и каналы связи.

Методы проектирования

Процесс проектирования сетевой системы основывается на функциональных строительных блоках, которые не могут быть строго классифицированы по своей иерархической принадлежности, однако обеспечивают сходные процедуры по управлению и поиску и устранению возможных неисправностей. Такой подход обеспечивает разработку системы, которая будет иметь при эксплуатации единое управление, систему контроля и устранения неисправностей и узких мест в сетевых магистралях.

Для простоты картины мы не будем привязываться к конкретным монтажным помещениям и их физическому расположению. Примем как данное, что каждое здание заказчика имеет похожие кабельные системы и аппаратные помещения, обеспечивающие установку и работу всего необходимого оборудования. Однако на практике часто бывает так, что физические ограничения имеют место, и, более того, оказывают непосредственное влияние на выбор того или иного типа оборудования. И тем не менее предположим, что:

  • При наличии на предприятии заказчика 6000 сотрудников имеется необходимость предоставления сетевой системой 8000 конечных пользовательских портов. Это связано с тем, что некоторые рабочие места должны быть оборудованы более чем одной розеткой для подключения к системе, и, кроме того, есть различные учебные и конференц-залы и т.п.
  • Каждый кабельный узел обеспечивает в среднем по 100 кабельных линий, выполненных из кабеля с витыми парами 5-й категории (UTP5), сходящихся к этому узлу.
  • Оптоволоконные кабельные линии связывают каждый кабельный узел с промежуточным аппаратным помещением.

Сеть, основанная на Ethernet

Разработку проекта мы будем рассматривать начиная с кабельных узлов, обеспечивающих физическое подключение рабочих мест пользователей, и заканчивая ядром системы. Для этого разобьем систему на три иерархических уровня: уровень доступа, уровень распределения и уровень ядра системы.

Уровень доступа

Для обеспечения 8000 пользовательских портов (по 100 портов на каждый кабельный узел) необходимо установить 80 коммутаторов Ethernet (см. рис. 1).

image1.gif (5460 bytes)

Рис. 1. Подключение конечных узлов

Для этой цели мы выбираем две модели коммутаторов Cisco Systems - Catalyst 5000 или Catalyst 5500. Выбор той или иной модели коммутатора в каждом конкретном случае зависит от числа и типа пользовательских портов, подключенных к данному кабельному узлу. Зная о возможном скором переходе на высокоскоростные сетевые соединения, многие заказчики выбирают в качестве основных порты с разными скоростями передачи – 10 и 100 Мбит/с (Ethernet и Fast Ethernet). В качестве коммутатора для уровня доступа рекомендуется использовать именно модель Catalyst 5500 (или 550х), способную резервировать коммутирующий процессор (Supervisor Engine Module), что позволит значительно повысить отказоустойчивость системы уже на уровне доступа.

Адресация IP и разбиение на подсети (структура VLAN)

Для достижения основной цели -- сделать адресацию IP настолько простой, насколько это возможно, - необходимо минимизировать затраты на добавление, перемещение и модификацию узлов сети при эксплуатации. В еще сравнительно недавнем прошлом каждая рабочая станция сети имела статические значения “IP address”, “address mask” и “default gateway”. Всякий раз, когда пользователь или компьютер менял свое местоположение внутри предприятия заказчика, сетевому администратору приходилось вручную на рабочей станции менять значения этих параметров.

В настоящее же время общение сотрудников компаний происходит между удаленными офисами и зданиями, многие работают дома, имея подключение к корпоративной сети через обычные телефонные каналы или через каналы цифровой сети ISDN (Integrated Services Digital Network). При такой организации работы администрирование всех рабочих станций становится практически невозможным.

В связи с этим был разработан протокол DHCP (Dynamic Host Configuration Protocol), позволяющий удаленным пользователям подключаться к любому месту сети, использующей этот протокол, и получать соответствующие значения параметров настройки IP-адреса автоматически, без вмешательства администратора системы. Таким образом, пользователи получили возможность свободно перемещаться как внутри здания предприятия, так и между удаленными офисами, и даже работать дома. Все, что им нужно - это подключиться к системе. Данная схема в настоящее время используется многими крупными корпорациями (в том числе и Cisco Systems). Следует отметить, что такая возможность появилась уже несколько лет назад в сетях AppleTalk, объединявших компьютеры Apple Macintosh.

Благодаря протоколу DHCP решается проблема с добавлениями, перемещениями и удалениями узлов сети. Заказчики теперь не испытывают трудностей при разработке и модернизации собственных сетей, связанных со схемой IP-адресации.

Теперь перед нами возникает следующий вопрос - какого размера должны быть подсети IP? До недавнего времени общепринятыми средними размерами подсетей были большие, затем все чаще стали применять подсети небольшого размера. Это было связано с появлением в составе локальных корпоративных сетей таких устройств, как маршрутизаторы, ранее применявшихся только для связи с глобальными сетями и для управления потоками данных в самих глобальных сетях. С появлением в составе ЛВС коммутаторов размеры подсетей вновь стали увеличиваться для обеспечения работы новых приложений, связанных с организацией видеоконференций, использующих принцип IP-мультикастинга.

В настоящее время нет какого-то одного ответа на вопрос о размерах подсетей. Единственным критерием выбора того или иного способа разделения сети на подсети можно считать требования заказчиков и приложений, работающих на предприятиях.

Для упрощения будем считать, что сеть 10.0.0.0 разбита на подсети, имеющие адресную маску 255.255.255.0. Такая конфигурация подсетей позволяет иметь в каждой из них по 254 активных узла. Кроме того, отметим, что с этого момента мы будем пользоваться термином “VLAN” (Virtual LAN - виртуальная ЛВС) по отношению к подсетям. Позднее, при использовании протокола DHCP, это количество может быть уменьшено с целью разделения VLAN на более мелкие подсети, однако в настоящем руководстве эта проблема не рассматривается.

В связи с тем, что в нашем примере мы используем не более 100 узлов на одну VLAN, 154 адреса из каждой подсети всегда будут оставаться свободными (незанятыми). Однако решение этого вопроса не является целью настоящего руководства.

Расположение VLAN между коммутаторами уровня доступа показано на рис. 2.

image2.gif (5847 bytes)

Рис. 2. Распределение VLAN по коммутационным узлам

Половина всех портов в одном из коммутаторов будет принадлежать, например, VLAN#2, а другая половина – VLAN#3. Все VLAN будут распределяться также между остальными коммутаторами уровня доступа. Таким образом, мы имеем 80 VLAN. Так как каждая VLAN соответствует одной подсети IP, то сеть 10.0.0.0 получается разделенной на 80 подсетей.

Как будет показано ниже, такое решение по организации VLAN позволит масштабировать соединения устройств уровня доступа с устройствами следующего уровня нашей модели – уровня распределения. Кроме того, членство каждого коммутатора в двух VLAN обеспечит дополнительную степень отказоустойчивости и облегчит сопровождение каждого коммутатора и VLAN. Напомним, что принадлежность стоящих рядом рабочих станций к одной VLAN не имеет основополагающего значения. Главной целью является обеспечение надежного и эффективного подключения пользователя к ресурсам сети. Каким образом происходит коммутация на втором и третьем уровне модели OSI, будет объяснено дальше по ходу обсуждения проекта.

Уровень распределения

Каждый коммутатор Catalyst 5000 уровня доступа имеет по две восходящие связи Fast Ethernet ISL. Для повышения степени надежности системы каждая из этих связей подключается к разным коммутаторам Catalyst 5000, образующим уровень распределения в нашей модели (см. рис. 3).

image3.gif (15066 bytes)

Рис. 3. Уровень распределения

Каждый из 14 коммутаторов Catalyst 5000, образующих уровень распределения, имеет по 12 восходящих портов Fast Ethernet. Наша модель сети состоит из семи функциональных строительных блоков, имеющих сходную структуру и состав оборудования. Каждый из этих блоков обеспечивает работу 12 VLAN и состоит из 12 коммутаторов уровня доступа и двух коммутаторов уровня распределения. Далее по ходу обсуждения проекта, мы рассмотрим, каким образом происходит взаимодействие VLAN внутри блока и как блоки взаимодействуют между собой.

Необходимо отметить, что в большинстве случаев из-за физических ограничений, таких как размеры зданий, корпусов, аппаратных помещений и пр., размер функциональных блоков может быть различным. Однако на общей модели сети это никак не отражается.

image4.gif (10040 bytes)

Рис. 4. Уровень распределения (детали)

На рис. 4 уровень распределения показан более подробно; здесь отражены разные пути передачи трафика в зависимости от его принадлежности той или иной VLAN, основанные на использовании протокола Spanning Tree.

Рациональное распределение функций основного коммутатора (root) для каждой VLAN позволит наилучшим образом использовать обе связи, обеспечивающие физическое соединение уровней доступа и распределения. Также правильное конфигурирование избыточности повышает отказоустойчивость соединений уровней доступа и распределения – при обрыве одной из связей трафик обеих VLAN будет автоматически переключен на альтернативный путь передачи. На рис. 4 показано состояние всех линий связи при нормальном функционировании всех кабельных соединений. При помощи настроек параметров протокола Spanning Tree также можно обеспечить балансирование нагрузки между параллельными путями.

Для того чтобы установить левый нижний коммутатор в качестве основного для VLAN#2, необходимо при конфигурации коммутатора задать команду

Switch>set spantree priority 500 2,

где 500 – это значение приоритета, а 2 соответствует VLAN#2.

На другом коммутаторе уровня распределения надо задать команду

Switch>set spantree 1000 2,

где 1000 – приоритет, больший, чем 500, но меньший, чем значение по умолчанию (32768). Таким образом, второй коммутатор станет основным в том случае, если выйдет из строя первый или случится обрыв линии связи между первым коммутатором и уровнем доступа.

Протокол ISL (Inter-Switch Link) используется для передачи трафика двух VLAN по одному магистральному соединению между коммутаторами уровней доступа и распределения.

image5.gif (10509 bytes)

Рис. 5. Анализ избыточности по протоколу Spanning Tree

Для того чтобы убедиться, как эта схема будет работать на практике, рассмотрим случай, при котором соединение между левыми коммутаторами в обоих уровнях было удалено или оборвано (см. рис. 5). В такой ситуации вторая связь с уровнем распределения становиться путем передачи трафика VLAN#2 и VLAN#3.

Масштабирование полосы пропускания

Достаточно важным аспектом на начальном этапе проектирования является оценка инструментальных средств, позволяющих контролировать и изменять поведение сети в реальных условиях при передаче больших объемов пользовательского трафика. Одним из основополагающих мест в сети, где необходимость управления трафиком велика, являются соединения между уровнем доступа и уровнем распределения. Один из подходов к масштабированию соединений этого уровня сети показан на рис. 6.

image6.gif (11072 bytes)

Рис. 6. Масштабирование производительности соединений

В связи с тем, что ранее мы уже разработали для сети гибкую схему распределения VLAN и их соответствия подсетям, в данном примере мы просто организуем новую VLAN (VLAN#100 в данном случае), которая позволит передавать большее количество трафика при взаимодействии двух уровней сети. Фактически исследование трафика на этапе взаимодействия двух уровней может привести к необходимости дополнительного физического соединения между коммутаторами и создания на его основе выделенного соединения для группы пользователей, требующих более широкой полосы пропускания. Этот случай как раз и показан на рис. 6.

На практике создать такое соединение не сложно: используя протокол DHCP можно легко и безболезненно присвоить новые адреса клиентам VLAN#100. При этом обслуживающему персоналу даже не потребуется изменеять в конфигурацию конечных пользовательских рабочих станций.

Другим способом увеличения полосы пропускания соединений уровней доступа и распределения является применение технологии Fast EtherChannel. Применение этой технологии показано на рис. 7.

image7.gif (11392 bytes)

Рис. 7. Масштабирование производительности соединений с применением Fast EtherChannel

Объединение двух или четырех параллельных соединений Fast Ethernet позволяет существенно увеличить производительность соединений между коммутаторами в пределах одной VLAN. При взаимодействии двух узлов сети технология Fast EtherChannel предотвращает передачу пакетов по разным физическим каналам путем закрепления адресов источника и приемника пакетов за одной линией связи. В случае ее отключения или выхода из строя весь трафик автоматически переключается на параллельное соединение.

Назначение серверов рабочих групп

В корпоративных сетях все сетевые приложения выполняются на серверах. В связи с этим одним из важнейших факторов, способствующих правильному распределению потоков данных в сети, является определение местоположения того или иного сервера в сетевой иерархии.

В настоящем руководстве серверы рабочих групп рассматриваются как специализированные вычислительные мощности, призванные обслуживать определенную часть пользователей. Примером применения сервера рабочей группы можно считать сервер электронных сообщений, обеспечивающий передачу информации внутри группы, а также файловый сервер и сервер печати, предоставляющий пользователям группы сервисы хранения файлов и групповой печати. Обычно при такой организации появляется возможность предотвращения передачи всего трафика группы в корпоративную сеть, что существенно снижает нагрузку на основные магистрали.

Для этих целей необходимо создать прямое физическое соединение второго уровня модели OSI сервера рабочей группы с соответствующим коммутатором уровня распределения. На рис. 8 показано прямое подключение серверов к коммутаторам уровня распределения при использовании технологии Fast Ethernet.

image8.gif (7684 bytes)

Рис. 8. Расположение серверов рабочих групп

При использовании сетевых адаптеров, поддерживающих функции ISL, имеется возможность включить один сервер сразу в несколько VLAN. Такое подключение серверов обеспечивает прямое соединение второго уровня с любым местом рассматриваемого строительного блока сети (для VLAN#2 – VLAN#13), показанного на рис. 8. Как правило, на практике нет необходимости предоставлять один сервер только одной рабочей группе. Это связано с тем, что современные серверы по своим аппаратным ресурсам в состоянии обеспечить качественное обслуживание сразу нескольких групп. Такой подход к проблеме организации серверов рабочих групп позволяет снизить затраты на их установку и сопровождение.

Другим решением организации взаимодействия сервера рабочих групп сразу с несколькими VLAN можно считать конфигурирование сетевого адаптера сервера на принадлежность нескольким подсетям. Количество подсетей, поддерживаемое сетевыми адаптерами разных производителей, не ограничивается каким-либо стандартом и зависит от конкретной модели адаптера (особенно в случае с множественными эмулированными сетями (ELAN) при использовании технологии LANE). Следовательно, при выборе какого-то конечного решения по применению данного подхода необходимо обратить внимание на документацию к сетевому адаптеру. На практике конфигурирование сетевого адаптера на принадлежность нескольким VLAN эквивалентно наличию нескольких обычных адаптеров в сервере. На основе этого в применяемых решениях используют от 6 до 10 различных VLAN на одном сетевом интерфейсе.

Принципы организации уровня ядра сети

На рис. 9 показана текущая (по мере обсуждения в настоящем руководстве) конфигурация нашей сети.

image9.gif (11188 bytes)

Рис. 9. Уровни доступа и распределения

Все 14 коммутаторов уровня распределения образуют семь функциональных строительных блоков сети. В каждом блоке имеются все возможности и реализованы все функции для обеспечения взаимодействия всех узлов и VLAN внутри блока. Уровень ядра должен предоставлять три типа функций по объединению имеющихся блоков в единую сетевую систему:

  • Взаимодействие VLAN за пределами строительных блоков сети (Inter-VLAN communication).
  • Взаимодействие оборудования из разных строительных блоков, необходимое для определения оптимальных маршрутов следования потоков данных в разных направлениях.
  • Обеспечение связи всех конечных узлов сети с корпоративными серверами и внешними сетями (частные глобальные сети и Интернет).

Для обеспечения всех этих функций ядром системы мы рассмотрим два подхода к построению самого ядра:

  • Ядро с использованием выделенных маршрутизаторов.
  • Ядро с использованием аппаратуры маршрутизации, встроенной в коммутаторы уровня распределения.

Оба подхода обеспечивают достижение поставленных задач, выбор того или иного решения в каждом конкретном случае зависит от требований заказчика, типа используемого оборудования и от особенностей аппаратных и кабельных помещений.

Ядро сети с использованием выделенных маршрутизаторов

Наиболее приемлемое решение для достижения поставленных задач при использовании выделенных маршрутизаторов показано на рис. 10. В нашем проекте для создания ядра корпоративной сетевой системы используются четыре маршрутизатора Cisco 7500 с шестью или восемью портовыми адаптерами Fast Ethernet.

image10.gif (18455 bytes)

Рис. 10. Ядро системы с отдельно стоящими маршрутизаторами

Более подробно принципы связи между ядром системы и уровнями распределения и доступа показаны на рис. 11.

image11.gif (10304 bytes)

Рис. 11. Резервирование Inter-VLAN маршрутизации

Для обеспечения избыточности в оборудовании и коммуникациях между уровнями ядра и распределения имеются два пути следования потоков данных. Чтобы эти пути одновременно использовались для передачи трафика, необходимо ввести некоторые соглашения. Разделим условно все VLAN в каждом из строительных блоков на четные и нечетные. Для первого строительного блока, который, как описано выше, необходим для передачи трафика четных VLAN, левый маршрутизатор используется в качестве основного для трафика VLAN#2 - VLAN#12.

При использовании маршрутизатора с протоколом HSRP (Hot Standby Router Protocol) необходимо обратить внимание на назначение его (маршрутизатора) интерфейсов в качестве основных и резервных. В сущности, вся маршрутизация Inter-VLAN для подсетей 2–13 в первом функциональном блоке осуществляется левым маршрутизатором, а маршрутизация подсетей 14–25 - правым. Применение HSRP позволяет маршрутизаторам уровня ядра резервировать друг друга, что дает возможность снизить количество единиц оборудования в системе и соответственно избежать дополнительных расходов.

В заключение добавим, что эффективность маршрутизации IP может быть увеличена за счет использования дополнительных функций распределенной коммутации, встроенных в программное обеспечение маршрутизаторов Cisco 7500 (начиная с Cisco IOS 11.2.(7)F). При использовании этих функций вся маршрутизация IP выполняется одним модулем Cisco 7500 -VIP 2 (Versatile Interface Processor), что обеспечивает снижение нагрузки на центральную шину маршрутизатора и существенно увеличивает его производительность. В нашем проекте мы будем использовать 14 таких модулей для обеспечения всех функций распределенной коммутации.

Обеспечение увеличения полосы пропускания на уровне ядра

Как и на уровне распределения, рассмотрим два способа увеличения полосы пропускания соединений на уровне ядра (см. рис. 12).

image12.gif (7602 bytes)

Рис. 12. Масштабирование соединений с маршрутизаторами

Наиболее простым решением является разбиение одной VLAN на более мелкие подсети и группы и передача их трафика по разным физическим соединениям. Это решение показано на рис. 12 в части передачи трафиков четных VLAN#2 – VLAN#12. Эта группа подсетей разбивается на две (VLAN#2 – VLAN#6 и VLAN#8 – VLAN#12), и суммарный трафик передается по двум независимым физическим соединениям. Второй способ увеличения полосы пропускания соединений на уровне ядра - применение технологии Fast EtherChannel является более простым, по сравнению с первым, так как не требует разбиения групп VLAN на подгруппы. Однако применение технологии Fast EtherChannel требует наличия ее поддержки и маршрутизатором уровня ядра, и коммутатором уровня распределения.

Соединения внутри ядра системы

В предыдущих разделах руководства мы рассматривали наш проект как две большие составляющие единой сетевой системы. Теперь настало время обсудить, каким образом происходит взаимодействие этих частей.

Взаимодействие отдельных частей уровня ядра системы показано на рис. 13.

image13.gif (9899 bytes)

Рис. 13. Ядро системы (детали)

Рассмотрим, какие функции выполняют соединения между различными аппаратными компонентами ядра системы. Между маршрутизаторами и коммутаторами Catalyst на уровне ядра организованы две подсети. Наличие протокола ISL в этих подсетях не обязательно; физические соединения для них выполняются на обычных интерфейсах Fast Ethernet. В частности, VLAN#100 предназначена для передачи трафика левому коммутатору Catalyst, а VLAN#101 - правому. Для передачи трафика между двумя частями сети имеется два возможных маршрута. Каким именно образом будет проходить трафик, определяется используемым протоколом маршрутизации. Чтобы обеспечить наиболее быстрое переключение передачи данных на резервный канал, рекомендуется использовать протокол с минимальным временем сходимости. В IP-сетях обычно применяют протоколы OSPF (Open Shortest Path First) или EIGRP (Enhanced Interior Gateway Routing Protocol).

Показанные на рис. 13 корпоративные серверы подключаются к коммутаторам уровня ядра по линиям Fast Ethernet и принадлежат одной VLAN. Серверы, как и рабочие станции, нуждаются в настроенных параметрах IP address, address mask и default gateway. Это необходимо для обеспечения связи на третьем уровне модели OSI для обеспечения функций взаимодействия серверов с остальными участниками сетевой системы. Применение протокола DHCP в этом случае невозможно, поэтому мы рассматриваем два возможных пути решения проблемы: статическая конфигурация серверов и использование протоколов ARP (Address Resolution Protocol) и ICMP (Internet Control Message Protocol), обеспечивающих поддержку корректных таблиц маршрутизации.

Более подробно на функциях корпоративных серверов и проблемах, связанных с их подключением, мы остановимся позднее, а пока рассмотрим альтернативный вариант построения ядра системы.

Ядро системы с применением аппаратуры маршрутизации, встроенной в коммутаторы уровня распределения

Как альтернативный путь построения ядра сетевой системы мы рассмотрим вариант с использованием в качестве ядра аппаратуры коммутации третьего уровня модели OSI, встроенной в коммутаторы уровня распределения. Такая аппаратура доступна в качестве модулей расширения к коммутаторам Catalyst 5xxx и называется RSM (Route Switch Module). Использование модулей RSM в каждом из 14 коммутаторов Catalyst 5000 уровня распределения позволит избежать необходимости установки 14 маршрутизаторов Cisco 7500 с модулями VIP 2 (см. рис. 14).

image14.gif (13696 bytes)

Рис. 14. Уровень ядра с использованием модулей Route Switch Module (RSM)

Объединение коммутации второго и третьего уровня в одном устройстве позволяет осуществлять передачу до 2 миллионов пакетов в секунду. Более подробно работа оборудования показана на рис. 15.

image15.gif (11058 bytes)

Рис. 15. Резервирование ядра на основе RSM

Модули RSM имеют внутренние интерфейсы с внутренней шиной коммутаторов, по одному интерфейсу на каждую VLAN. Например, левый коммутатор с модулем RSM имеет внутренние интерфейсы для VLAN#2–VLAN#13 и функционирует как основной HSRP-маршрутизатор для четных VLAN, а правый коммутатор с модулем RSM также имеет внутренние интерфейсы для VLAN#2–VLAN#13, но функционирует как основной HSRP-маршрутизатор для нечетных VLAN. Каждый из коммутаторов в паре выполняет функции резервного маршрутизатора для своего соседа.

Так же как и в случае с выделенными маршрутизаторами, внутренние соединения аппаратуры ядра системы выполнены с применением коммутаторов Catalyst (см. рис. 16).

image16.gif (18274 bytes)

Рис. 16. Схема соединений ядра на основе RSM

Корпоративные серверы

Корпоративными обычно называют серверы, обеспечивающие выполнение приложений масштаба организации заказчика. Такие серверы поддерживают большое число одновременно подключенных пользователей и имеют возможность обрабатывать большое число пользовательских транзакций за единицу времени. Примерами таких серверов могут служить серверы электронной почты, серверы WWW, серверы мультикастовой трансляции, серверы DHCP и DNS (Domain Name System) и т.д. В процессе эксплуатации серверы могут наращиваться, и их статус в системе может изменяться, например сервер рабочей группы может “дорасти” до корпоративного сервера.

Поддержка мультикастинга IP

Приложения, работающие по принципу многоцелевой рассылки данных (мультикастинга), такие как Microsoft NetShow и Precept IP/TV, требуют от сетевой системы возможности такой рассылки в реальном времени. И такая возможность обеспечивается за счет поддержки протокола IGMP (Internet Group Management Protocol) на рабочих станциях и протокола CGMP (Cisco Group Management Protocol) на коммутаторах и маршрутизаторах. Как это все происходит, показано на рис. 17. (На рисунке показаны выделенные маршрутизаторы, однако такая структура в равной степени относится и к варианту с использованием модулей RSM).

image17.gif (19349 bytes)

Рис. 17. Поддержка IP-multicasting

Для правильного функционирования приложений многоцелевой рассылки данных необходимо, чтобы протокол CGMP был запущен на устройствах уровней распределения и доступа, обеспечивая оптимальную передачу пакетов. В данном случае коммутаторы Catalyst распространяют мультикастовый трафик только на выходные порты, принадлежащие группе рассылки.

Поддержка других технологий и подключение к внешним сетям

Как уже отмечалось в самом начале данного руководства, требования заказчика заключаются в необходимости подключения создаваемой сети к внешним сетям, а также в обеспечении функционирования внутри сетевой системы участков, созданных по другим технологиям организации локальных сетей. Так, в нашей сети необходимо обеспечить функционирование протоколов IPX, NetBIOS и AppleTalk, а также подключить к общим ресурсам рабочие группы, использующие технологию Token Ring. Кроме того, такой подход позволит создавать новые рабочие группы без необходимости применения какой-то определенной модели их (групп) организации. Для большей наглядности проблема показана на рис. 18 в виде ядра с выделенными маршрутизаторами.

image18.gif (21937 bytes)

Рис. 18. Соединения с внешними сетями с другой топологией

Уровень ядра поддерживает следующие типы подключений:

  • Доступ в Интернет через маршрутизатор (или через маршрутизаторы, если требуется резервирование) с обеспечением функций трансляции адресов и обеспечения безопасности (firewall).
  • Подключения к глобальным сетям через маршрутизатор уровня ядра включая постоянное подключение, доступ по коммутируемым каналам тональной частоты и по цифровым каналам ISDN.
  • Подключение к сетям, выполненным по другим технологиям передачи данных (Token Ring, AppleTalk) через маршрутизаторы уровня ядра. Необходимо отметить, что при использовании других технологий передачи рабочая группа, например Token Ring, должна быть организована в соответствии со стандартом и иметь возможность подключения к нашей системе.

Для обеспечения работы протокола Token Ring NetBIOS в новой сети Ethernet необходимо обеспечить прозрачную трансляцию (бриджинг) пакетов из Token Ring в Ethernet и наоборот. Эта трансляция выполняется на уровне распределения при помощи либо выделенного маршрутизатора Cisco 4000 или коммутатора Catalyst 1800 через транспортную сеть FDDI (Fiber Distributed Data Interface).

Итоги рассмотрения проекта сети на основе Fast Ethernet

Итак, подведем итоги. Мы имеем две базовые модели построения коммутируемой сети на базе технологии Fast Ethernet. Выбор подходящего варианта построения зависит от конкретных требований заказчиков и многого другого. На рис. 19 показан проект сети с использованием выделенных коммутаторов Cisco 7500, обеспечивающей функции масштабирования на уровне ядра системы.

image19.gif (23185 bytes)

Рис. 19. Окончательная топология сети с использованием выделенных маршрутизаторов

Проект сети с использованием модулей RSM показан на рис. 20.

image20.gif (20697 bytes)

Рис. 20. Окончательная топология сети с использованием модулей RSM

Анализ отказоустойчивости

Теперь рассмотрим поведение системы при возникновении различного рода сбоев и неполадок. Это необходимо для того, чтобы предотвратить возможную потерю данных при авариях и сократить время простоя системы при локализации и устранении неисправностей.

Напомним, что начальные условия проектирования предусматривали, что при выходе из строя любого компонента активного сетевого оборудования или линии связи должно произойти отключение не более чем 100 конечных пользовательских рабочих мест. Следует отметить, что отключение конечных пользователей произойдет только в случае сбоя на уровне доступа (как это и происходит в сетях shared Ethernet/Fast Ethernet).

Рассмотрим проблему на примере. Имеется взаимодействие между рабочими станциями, входящими соответственно к VLAN#2 и VLAN#5. На рис. 21 показан нормальный путь следования трафика между взаимодействующими станциями на основе информации, ранее описанной в настоящем руководстве. Для более детального и понятного рассмотрения ситуации показан вариант с выделенными маршрутизаторами.

image21.gif (20327 bytes)

Рис. 21. Анализ отказоустойчивости (с использованием выделенных маршрутизаторов)

На рис. 22 показан маршрут следования трафика при сбое основного маршрутизатора для соответствующих VLAN.

image22.gif (22007 bytes)

Рис. 22. Анализ отказоустойчивости (с использованием выделенных маршрутизаторов).
Сбой основного маршрутизатора уровня ядра для маршрутизации VLAN#2 – VLAN#5

В данном случае механизм HSRP автоматически определит сбой в основном маршрутизаторе и переключит передачу трафика на резервный маршрутизатор с использованием резервных линий связи.

В следующем примере (см. рис. 23) рассматривается ситуация, когда выходит из строя коммутатор уровня распределения.

image23.gif (23019 bytes)

Рис. 23. Анализ отказоустойчивости (с использованием выделенных маршрутизаторов).
Сбой одного из коммутаторов уровня распределения для маршрутизации VLAN#2 – VLAN#5

В данном случае сбой ликвидируется при помощи протокола Spanning Tree, функционирующего на соединениях уровней доступа и распределения, и протокола HSRP, функционирующего между маршрутизаторами уровня ядра. На рис. 23 показан один из возможных путей, который маршрутизаторы могут выбрать в качестве основного при выходе из строя коммутатора уровня распределения. Использование параметров конфигурации портов маршрутизаторов (в частности, административная стоимость интерфейсов) позволяет настроить автоматическое перераспределение маршрутов и нагрузки на маршрутизаторы оптимальным образом. Следует отметить, что при использовании модулей RSM эти процессы будут выполняться значительно быстрее за счет использования внутренних шин коммутаторов.

Общие комментарии

Проекты сетей, которые рассматриваются в этой части руководства, значительно упрощены для облегчения понимания самого механизма проектирования больших масштабируемых сетей. Рассмотренные нами функциональные логические блоки, состав оборудования и его назначение могут изменяться в каждом конкретном случае. Это зависит не только от потребностей заказчика, но и от объемов финансирования, физических и прочих ограничений и т.п.

Разбиение крупной сети на более мелкие функциональные блоки и участки делает процесс установки и эксплуатации значительно проще. Упрощаются также и задачи по подключению к работающим системам новых рабочих групп, зданий и удаленных офисов - все это не вызовет глобальных изменений в логической структуре сети.

Окончательный выбор варианта проекта (выделенные маршрутизаторы или модули RSM) зависит от типа используемого оборудования и других факторов, которые учитываются в каждом конкретном случае.

Сеть, основанная на ATM

Проекты сетей на основе Ethernet и ATM на уровне доступа похожи друг на друга, поэтому мы не будем еще раз останавливаться на описании этого уровня. Однако вопросы, касающиеся АТМ, будут рассматриваться подробно.

Уровень доступа и структура VLAN

Уровень доступа, как уже было сказано, построен точно так же, как и в проекте на основе Fast Ethernet. Сеть на уровне доступа состоит из 80 коммутаторов Catalyst 5000, по 100 пользователей на каждом коммутаторе. На уровне доступа конфигурируется 80 VLAN, по два коммутатора на каждую VLAN (см. рис. 24).

image24.gif (5847 bytes)

Рис. 24. Уровень доступа и распределение VLAN

Соединения уровня доступа с уровнем распределения

Каждый коммутатор уровня доступа имеет соединение с коммутатором уровня распределения LightStream 1010 по оптической линии связи ATM OC-3 (155 Мбит/с). Структура соединений показана на рис. 25.

Модуль OC3 ATM в коммутаторе Catalyst 5000 имеет два физических подуровня (PHY), которые обеспечивают подключение одного коммутатора уровня доступа к двум коммутаторам уровня распределения.

image25.gif (16137 bytes)

Рис. 25. Схема соединений уровня распределения АТМ

В нашем случае каждый из восьми коммутаторов LightStream 1010 использует 20 интерфейсов OC-3 ATM (максимальное число таких интерфейсов для коммутатора LightStream 1010 - 32). Позднее, когда потребуется соединить эти коммутаторы с другими устройствами, можно воспользоваться незанятыми интерфейсами.

Рассмотрим такую конфигурацию более подробно (см. рис. 26) и обсудим расположение компонентов технологии LANE.

image26.gif (7420 bytes)

Рис. 26. Уровень распределения (детали) с применением компонентов LEC

На каждом коммутаторе Catalyst 5000 на интерфейсе ATM необходимо создать LEC (LAN Emulation Client) для каждой из VLAN, присутствующих на интерфейсах Ethernet. В нашем случае, например, первый и второй коммутаторы Catalyst 5000 на уровне доступа должны иметь сконфигурированные LEC только для VLAN#2 и VLAN#3. Линии связи от интерфейсов ATM будут подключены к разным коммутаторам ATM. При возникновении неисправности в основной линии связи произойдет автоматическое переключение передачи данных на резервную линию. При этом резервная линия автоматически становится основной без дополнительных изменений в конфигурации LEC.

Необходимо отметить, что в случаях, если коммутаторы ATM связаны между собой дополнительными линиями связи (о чем мы расскажем позже), следует избегать возникновения петель. Зачастую происходит так, что при эксплуатации сетевые администраторы отключают протокол Spanning Tree на коммутаторах с модулями ATM, при этом образуются кольцевые маршруты, что приводит к снижению скорости передачи и ставит под вопрос саму передачу данных по сети. Само собой разумеется, что если на коммутаторах выключен протокол Spanning Tree, то администратор сети должен быть абсолютно уверен в том, что кольцевые соединения второго уровня отсутствуют на всех участках сетевой системы, за исключением тех мест, где этого не позволяет топология (например, рабочие группы Token Ring).

Технология LANE, а точнее ее функционирование, строится на таких компонентах, как LECS (LAN Emulation Configuration Server), LES (LAN Emulation Server), BUS (Broadcast and Unknown Server). Каждый из этих компонентов должен присутствовать в сети. Проблему конфигурирования LECS мы рассмотрим позднее, а вот конфигурация LES/BUS показана на рис. 27.

image27.gif (9631 bytes)

Рис. 27. Распределение сервисов LANE

Наилучшим местом для расположения серверов LES/BUS являются модули ATM LANE, установленные в коммутаторы Catalyst 5000 уровня доступа. Каждый модуль ATM LANE является основным сервером LES/BUS для одной ELAN (Emulated LAN) и резервным для другой. При этом мы будем рассматривать пары коммутаторов, в которых один коммутатор является резервным для другого (см. рис. 28). Протокол SSRP (Simple Server Redundancy Protocol) используется для обеспечения резервирования компонентов LANE и организации взаимодействия между коммутаторами в паре.

Анализ отказоустойчивости

При возникновении сбоя в соединении между уровнями доступа и распределения будут запущены два механизма восстановления связи (см. рис. 28).

image28.gif (8922 bytes)

Рис. 28. Анализ отказоустойчивости

Во-первых, два физических подуровня интерфейса ATM LANE на коммутаторах Catalyst 5000 автоматически определят сбойную линию связи и произведут переключение трафика на резервную линию. Так как сервисы LANE сконфигурированы для этого интерфейса, то протокол SSRP обеспечит автоматическое перемещение всех этих сервисов на второй коммутатор Catalyst.

В случае выхода из строя самого коммутатора LightStream 1010 на уровне распределения интерфейсы dual PHY произведут физическое переключение, однако, без предварительной конфигурации LEC на коммутаторах Catalyst, на другом коммутаторе уровня распределения восстановление связи не произойдет. В связи с этим при проектировании сети необходимо распределить резервирование всех компонентов LANE по имеющемуся оборудованию. Также отметим, что коммутаторы LightStream могут служить резервными серверами LANE и для других пар коммутаторов Catalyst (не показано на рис. 28).

Масштабирование полосы пропускания между уровнями доступа и распределения

Масштабирование (увеличение) полосы пропускания между уровнями доступа и распределения можно производить двумя способами. Первый из них показан на рис. 29. При добавлении дополнительной физической линии связи можно сконфигурировать клиента LEC таким образом, чтобы две линии связи использовались как единый канал для обеспечения передачи трафика VLAN#2 и VLAN#3. Другим решением является использование линий ATM с пропускной способностью 622 Мбит/с.

image29.gif (8107 bytes)

Рис. 29. Масштабирование пропускной способности соединений

Серверы рабочих групп

Назначение и местоположение серверов рабочих групп аналогичны рассмотренным проектам сети на основе Fast Ethernet (см. рис. 30).

image30.gif (11787 bytes)

Рис. 30. Серверы рабочих групп

Большинство сетевых адаптеров ATM поддерживают возможность конфигурации, при которой адаптер становится членом сразу нескольких ELAN. Смысл использования этой возможности адаптеров заключается в создании соединений второго уровня между серверами и клиентами, необходимых для повышения пропускной способности и эффективности сетевого взаимодействия. Так же как и в случае с Fast Ethernet, адаптеры обеспечивают одновременное подключение серверов к 6-10 ELAN.

Некоторые сетевые администраторы не хотят включать серверы по технологии ATM. В этом случае можно подключать серверы рабочих групп по технологии Fast Ethernet. Для того чтобы обеспечить такую возможность, необходимо вместо коммутаторов LightStream 1010 устанавливать на уровне распределения коммутаторы Catalyst 5500, объединяющие в себе все возможности Catalyst 5xxx и LightStream 1010. В этом случае серверы могут быть подключены линиями Fast Ethernet (также обеспечивается поддержка ISL) и быть доступны по сети через линии ATM OC-3 или OC-12 (622 Мбит/с) при использовании соответствующих интерфейсных модулей в коммутаторах.

Ядро на основе ATM

Уровень распределения нашей сети построен на восьми коммутаторах LightStream 1010. Теперь необходимо объединить все это оборудование в единую отказоустойчивую сетевую систему. Для этого мы будем использовать избыточные соединения OC-12, как показано на рис. 31.

image31.gif (17238 bytes)

Рис. 31. Схема ядра на основе АТМ

Каждый коммутатор ATM уровня распределения имеет две связи OC-12 с каждым из двух коммутаторов уровня ядра. Каждый из этих двух коммутаторов имеет две связи OC-12 с двумя другими коммутаторами в пределах ядра системы, которые образуют собственно ядро системы, обладающее отказоустойчивостью и работающее по протоколу маршрутизации PNNI (Private Network-Network Interface). Этот протокол обеспечивает автоматическое восстановление соединения за счет резервных линий связи при выходе из строя основных магистралей сети.

Масштабирование ядра системы

Как показано на рис. 32, полоса пропускания на уровне ядра может быть увеличена за счет добавления дополнительных линий связи в тех местах, где это необходимо. Протокол PNNI автоматически определит наилучший маршрут следования потоков данных и обеспечит балансирование нагрузки между параллельными линиями связи.

image32.gif (13488 bytes)

Рис. 32. Масштабирование ядра на основе АТМ

Маршрутизация Inter-ELAN

На данном этапе проектирования наша сеть не обеспечивает взаимодействия между различными VLAN. Для решения этой проблемы нам необходимы маршрутизаторы, которые поддерживают функции взаимодействия между ELAN в составе сети ATM. На рис. 33 показаны четыре маршрутизатора Cisco 7500, которые обеспечивают все необходимые функции.

image33.gif (20991 bytes)

Рис. 33. Маршрутизация Inter-ELAN

При определении размеров маршрутизации Inter-ELAN необходимо обратить внимание на два параметра:

  • Общая полоса пропускания, необходимая для передачи маршрутов Inter-ELAN.
  • Общая пропускная способность, измеряемая в пакетах в секунду, необходимая для передачи трафика между ELAN.

Для имеющейся на данном этапе проектирования сетевой системы мы рассмотрим четыре магистральных соединения ATM OC-3 со следующими характеристиками (указаны значения, полученные при измерениях количества передач пакетов в обоих направлениях):

  • Маршрутизатор Cisco 7500 series с модулем AIP (ATM Interface Processor) ? 55 тысяч пакетов в секунду.
  • Маршрутизатор Cisco 7500 series с модулем VIP (Versatile Interface Processor) ? от 80 до 85 тысяч пакетов в секунду.

На рис. 35 показано, каким образом происходит распределение ELAN по маршрутизаторам и как разделяются нагрузки между устройствами. Однако сначала мы рассмотрим, как ELAN расположены в сети на уровне распределения.

В левой части сети (см. рис. 34) каждая ELAN закреплена за определенным коммутатором уровня распределения. Правая часть сети (не показана на рисунке) использует ту же схему распределения ELAN.

image34.gif (13372 bytes)

Рис. 34. Ядро на основе АТМ (детали)

Мы специально используем такой подробный уровень детализации в обсуждении проектных решений - это в дальнейшем поможет лучше понять, какой из маршрутизаторов, подключенных к ядру системы, должен обеспечивать работу той или иной ELAN и являться для нее основным маршрутизатором HSRP по умолчанию (Primary HSRP Default Gateway), и сделать правильный выбор.

При конфигурировании маршрутизации Inter-ELAN необходимо убедиться, что каждый из маршрутизаторов (см. рис. 35) подключен к каждой из 80 ELAN. Каждый из маршрутизаторов выбирается в качестве основного HSRP-маршрутизатора по умолчанию для группы из 20 ELAN. Эти группы составляются таким образом, чтобы от коммутаторов уровня распределения (см. рис. 34) до соответствующих маршрутизаторов был наиболее короткий путь.

image35.gif (9254 bytes)

Рис. 35. Маршрутизация Inter-ELAN (детали)

При использовании четырех маршрутизаторов для управления 80 VLAN нагрузка на каждый маршрутизатор будет достаточно большой. Кроме того, каждый маршрутизатор будет обрабатывать информацию не только о VLAN, так или иначе к нему относящихся, но и информацию о маршрутах соседей. Для оптимизации такой ситуации маршрутизаторы ставятся в пассивный режим по отношению ко всем ELAN, кроме тех, которые он обязан обслуживать.

Необходимо добавить, что здесь также располагается компонент LECS технологии LANE, о которой мы упоминали ранее. Каждый из маршрутизаторов выполняет функции сервера LECS, а благодаря использованию протокола SSRP только один из них является основным.

Подключение к внешним сетям

Оглядываясь назад на процесс проектирования сети, можно сказать, что проект сетевой системы, представленной в этом разделе руководства, обеспечивает такие же возможности по подключению внешних сетей, что и проект, основанный на технологии Fast Ethernet (см. рис. 36).

Как видно из диаграммы, некоторые маршрутизаторы, осуществляющие маршрутизацию Inter-ELAN, сконфигурированы таким образом, чтобы заниматься еще и маршрутизацией в глобальные сети. В данном случае такая конфигурация достаточно удобна, однако прежде чем конфигурировать маршрутизатор для выполнения обеих функций, необходимо как следует рассмотреть вопросы, касающиеся полосы пропускания маршрутизатора, его быстродействия, загрузки процессора и нагрузки на интерфейсные порты.

Корпоративные серверы могут быть подключены по интерфейсам ATM или LAN к маршрутизаторам или коммутаторам уровня ядра системы.

Расчет количества виртуальных подключений LANE

При построении сетей ATM не самой плохой идеей является предварительный расчет количества возможных коммутируемых виртуальных соединений (Switched Virtual Circuit, SVC), которое может понадобиться для нормальной работы сети. SVC используются для создания логической связи между компонентами активного сетевого оборудования в системе.

Рассмотрим порядок проведения расчетов.

Для каждой ELAN конфигурируются следующие компоненты LEC:

  • 2 клиента LEC на коммутаторах Catalyst 5000;
  • 4 клиента LEC на маршрутизаторах Cisco 7500;
  • 4 (предположительно) клиента LEC на серверах рабочих групп.

Максимальное число виртуальных канальных соединений (Virtual Channel Connection, VCC) определяется формулой (10*9)/2, т.е. равно 45. Сверху на VCC накладываются 20 SVC типа “точка-точка” и 2 SVC типа “точка-много точек”.

Так как общее количество VLAN - 80, то общее количество SVC определяется следующим образом:

  • общее количество SVC типа “точка-точка” равно 80*(45+20) = 5200
  • общее количество SVC типа “точка-много точек” равно 80*2 = 160
  • общее количество SVC на один маршрутизатор равно 80 + 80 + (80*9) = 880.

image36.gif (22938 bytes)

Рис. 36. Окончательная схема ядра на основе АТМ

Максимальное число SVC, поддерживаемое одним коммутатором LightStream 1010, - 32 000, поэтому наши 5200 SVC на 12 коммутаторов очень хорошо вписываются в это число. Количество SVC на каждый маршрутизатор также посчитано, так как именно маршрутизаторы являются теми точками сети, где происходит объединение большого количества ELAN. Модуль AIP обеспечивает поддержку не более 2048 SVC, что также подходит для данного случая.

Для обеспечения контроля над числом соединений SVC на этапе эксплуатации сетевой системы при проектировании необходимо учесть следующие рекомендации:

  • Необходимо вести строгий контроль за членством пользователей в определенных VLAN. Если для одной VLAN продолжать создавать LEC на каждом коммутаторе, то число возникающих при этом соединений SVC очень скоро выйдет из-под контроля. Это связано с тем, что количество SVC, открываемых при создании LEC, в 4 раза превосходит количество самих LEC для каждой VLAN. Если же необходимость в создании LEC на каждом коммутаторе все-таки есть, то нужно рассмотреть вопрос о переходе на протокол MPOA (Multiprotocol Over ATM). Более подробно об этом мы скажем чуть позже.
  • Необходимо убедиться в том, что протокол VTP (VLAN Trunking Protocol) запущен на всех коммутаторах Catalyst в прозрачном режиме. Такой подход гарантирует, что количество LEC не будет расти катастрофически, что приведет к уменьшению общего количества SVC.
  • При необходимости, в целях уменьшения общего числа SVC, можно уменьшить размеры VLAN и тем самым увеличить количество ELAN, что приведет к снижению числа LEC на одну VLAN (для сети, которую мы рассматриваем в данной статье, это не нужно).

Анализ отказоустойчивости

Теперь рассмотрим, как будет вести себя оборудование при различных сбоях в работе сетевой аппаратуры и линий связи.

Нормальное функционирование сети при взаимодействии между клиентами VLAN#2 и VLAN#5 показано на рис. 37.

image37.gif (24555 bytes)

Рис. 37. Анализ отказоустойчивости

Трафик от клиента VLAN#2 передается через соединение SVC маршрутизатору по умолчанию (основному маршрутизатору), а затем маршрутизатор перенаправляет его по другому SVC коммутатору Catalyst, обслуживающему VLAN#5.

При сбое в работе одного из коммутаторов ATM на уровне ядра происходит перераспределение маршрутов и создание новых SVC, как показано на рис. 38.

В связи с тем, что основной HSRP-маршрутизатор для этого маршрута оказался отключенным от сети, протокол HSRP перенаправит потоки данных следующему маршрутизатору. Новое соединение SVC необходимо для создания логического пути следования трафика через коммутаторы ядра. Восстановление соединений ATM осуществляется протоколом PNNI.

image38.gif (25176 bytes)

Рис. 38. Сбой коммутатора АТМ на уровне ядра

Вернемся к рис. 37. При сбое одного из коммутаторов ATM на уровне распределения происходит перенаправление потоков данных, показанное на рис. 39.

image39.gif (25573 bytes)

Рис. 39. Сбой коммутатора АТМ на уровне распределения

Интерфейс dual PHY на коммутаторе Catalyst, обслуживающем VLAN#5, так же как и протокол PNNI на коммутаторах LightStream, автоматически перенаправит потоки данных по наиболее короткому из имеющихся маршрутов. В этом случае для правильного функционирования протокола SSRP необходимо сконфигурировать резервные серверы LES/BUS для ELAN#5 на соседних с коммутатором Catalyst устройствах.

Переход к сетям ATM, использующим MPOA

Технология MPOA основывается на использовании технологии LANE для обеспечения взаимодействия между ELAN. ATM-интерфейсы коммутаторов Catalyst могут выступать в качестве клиентов MPOA (MPC), а маршрутизаторы Cisco 7500 - в качестве серверов MPOA (MPS).

При использовании MPOA взаимодействие между различными VLAN происходит, как показано на рис. 40.

image40.gif (23935 bytes)

Рис. 40. Применение маршрутизации MPOA

Общие замечания

Мы рассмотрели два альтернативных подхода к организации корпоративных сетей, основанных на современном сетевом оборудовании. Один из этих подходов предоставляет порты коммутируемого Ethernet на каждое рабочее место и использует в качестве технологии ядра системы Fast Ethernet. Другой подход основан на применении для построения ядра системы технологии ATM.

Оба рассмотренных проекта позволяют достичь целей, поставленных заказчиком при проектировании.

Преимущества проекта на Fast Ethernet

  • Простая технология.
  • Высокая плотность портов при сравнительно небольшой стоимости.
  • Простое подключение серверов по технологии Fast Ethernet.
  • Возможность миграции на технологии Fast EtherChannel и Gigabit Ethernet.

Преимущества проекта на ATM

  • Быстрое восстановление функционирования ядра системы при возможных сбоях.
  • Поддержка передачи разнородного трафика (голос, видео) на уровне ядра системы.
  • Поддержка линий связи со скоростью передачи 622 Мбит/с
  • Поддержка стандартов LANE и MPOA.

Оба проекта независимо от применяемых технологий обеспечивают наращиваемость, гибкость и единое управление сетевым оборудованием. Это достигается благодаря разделению сетевой системы на функциональные блоки и объединения коммутации пакетов второго и третьего уровня в одном оборудовании.

Plus Networking Academy

Россия, Москва, 1-й Хвостов переулок 11А
Tel: +7 (095) 238-3711, -3777, -3977, -5343
+7 (095) 777-0-111, 777-0-222
Fax: +7 (095) 238-3989
E-mail: info@pluscom.ru

© 1996-2000 Plus Communications


Проектирование кампусных сетей

Данный материал представляет собой переработанное руководство по проектированию крупных кампусных сетей фирмы Cisco Systems. В решениях, заложенных в основу настоящего руководства, использовано существующее на данный момент оборудование, программное обеспечение и технологии, разработанные фирмой Cisco Systems.

Ниже приводятся описания специализированных примеров и приемов проектирования, основанных на конкретном пакете требований заказчиков. Рассматриваются две базовые модели построения крупных корпоративных сетей:

  • коммутируемая сеть Ethernet с ядром, основанным на применении технологии Fast Ethernet.
  • коммутируемая сеть Ethernet с ядром, основанным на применении технологии ATM (Asynchronous Transfer Mode).

Методология, представленная в настоящем руководстве, отражает традиционный и практический подходы к проектированию систем такого класса, однако изложенные здесь принципы и пути реализации проекта не являются единственно правильным решением проблемы. Фактически руководство можно рассматривать как свод общих рекомендаций по проектированию, основанных на собственных аппаратных и программных разработках фирмы Cisco Systems. Многие технические решения явились прямым следствием ранних наработок инженеров и разработчиков компании. Так, например, сетевая операционная система Cisco IOS™, под управлением которой работают все устройства фирмы, содержит в себе полный набор средств, позволяющих осуществлять функции конфигурирования аппаратуры, оптимизации сетевого трафика, обеспечения защиты данных от несанкционированного доступа и т.д.

Итак, перейдем к обсуждению проектных решений.

Содержание

Существующая сетевая система

Требования заказчика

Методы проектирования

Сеть, основанная на Ethernet

Уровень доступа

Адресация IP и разбиение на подсети (структура VLAN)

Уровень распределения

Масштабирование полосы пропускания

Назначение серверов рабочих групп

Принципы организации уровня ядра сети

Ядро сети с использованием выделенных маршрутизаторов

Обеспечение увеличения полосы пропускания на уровне ядра

Соединения внутри ядра системы

Ядро системы с применением аппаратуры маршрутизации, встроенной

в коммутаторы уровня распределения

Корпоративные серверы

Поддержка мультикастинга IP

Поддержка других технологий и подключение к внешним сетям

Итоги рассмотрения проекта сети на основе Fast Ethernet

Анализ отказоустойчивости

Общие комментарии

Сеть, основанная на ATM

Уровень доступа и структура VLAN

Соединения уровня доступа с уровнем распределения

Анализ отказоустойчивости

Масштабирование полосы пропускания между уровнями доступа

и распределения

Серверы рабочих групп

Ядро на основе ATM

Масштабирование ядра системы

Маршрутизация Inter-ELAN

Подключение к внешним сетям

Расчет количества виртуальных подключений LANE

Анализ отказоустойчивости

Переход к сетям ATM, использующим MPOA

Общие замечания

Преимущества проекта на Fast Ethernet

Преимущества проекта на ATM

Существующая сетевая система

Существующая сетевая система заказчика переживает трудные дни. Будучи основанной на использовании традиционной технологии shared Ethernet (разделяемая сеть Ethernet), эта система уже не в состоянии обрабатывать все возрастающие объемы данных. Рост объема передаваемых по сети данных связан с появлением приложений, работающих с данными мультимедиа, а также с развитием технологий обработки и представления данных. В качестве примеров таких технологий можно привести приложения клиент/сервер, позволяющие производить обработку данных большим числом конечных пользователей.

В основе существующей сетевой системы находятся такие устройства, как сетевые концентраторы (повторители), составляющие сильно загруженное ядро системы, и маршрутизаторы, обеспечивающие соединения отдельных сегментов сети.

Характеристики сети, взятой нами для примера, следующие:

  • Количество рабочих мест – 6000, из которых большинство оборудовано компьютерами, совместимыми с IBM PC, 95% всех сетевых соединений работают по технологии Ethernet, 5% составляет Token Ring.
  • Используемые сетевые протоколы – IP, IPX, ограниченное количество станций используют AppleTalk, некоторые станции и сегменты – NetBIOS.
  • В сети имеется несколько больших корпоративных серверов, а также достаточно большое количество серверов рабочих групп.
  • Вся сеть имеет IP-адрес 10.0.0.0 (см. RFC-1918).
  • Ядро системы составляют концентраторы (повторители) и маршрутизаторы AGS+/Cisco 7000 series.
  • В сети наблюдается высокая загруженность активного сетевого оборудования, сетевых соединений, начиная от серверных сегментов и заканчивая пользовательскими подсетями.

Текущее распределение трафика невозможно отследить, однако считается, что основной его объем создают приложения клиент/сервер с небольшим добавлением трафика, возникающего при обращении к серверам и службам WWW.

Требования заказчика

Известно, что для того чтобы повысить эффективность работы конечных пользователей сети, серверы должны иметь высокоскоростные подключения к ядру (центральному коммутатору) сетевой системы. Для удовлетворения возрастающих требований приложений к пропускной способности сетевых систем необходим некоторый запас быстродействия, который обеспечил бы нормальное функционирование системы в течение нескольких лет. В связи с этим заказчики предъявляют к проектируемым сетям следующие обязательные требования:

  • Наличие коммутируемых портов Ethernet на каждом рабочем месте сети.
  • Функционирование серверов под управлением ОС Microsoft Windows NT, использующих в качестве основного протокол IP.
  • Функционирование корпоративных серверов вспомогательного назначения (электронная почта, обработка сообщений, WWW), а также высокопроизводительных серверов рабочих групп, интенсивно использующих полосу пропускания, и мультимедиа-серверов для осуществления мультикастинговой трансляции по протоколу IP.
  • Поддержка принципов “plug-and-play” при добавлении, перемещении и изменении конфигурации узлов сети (рабочих станций, групп, серверов и т.п.).
  • Отсутствие так называемых единичных точек сбоя в системе (single point of failure), при котором выход из строя любого компонента активного сетевого оборудования приводит к отключению не более чем 100 рабочих станций сети;
  • Возможность проведения контрольных измерений нагрузки на сетевые соединения и оборудование, а также управления потоками данных с целью оптимизации работы сети.
  • Возможность увеличения полосы пропускания некоторых участков сети при использовании имеющегося оборудования.
  • Возможность подключения системы к внешним сетям, в том числе к таким, которые используют другие технологии передачи данных (другие реализации ЛВС, глобальные сети, Интернет).
  • Возможность эффективного роста сетевой системы при минимальном вложении средств в оборудование и каналы связи.

Методы проектирования

Процесс проектирования сетевой системы основывается на функциональных строительных блоках, которые не могут быть строго классифицированы по своей иерархической принадлежности, однако обеспечивают сходные процедуры по управлению и поиску и устранению возможных неисправностей. Такой подход обеспечивает разработку системы, которая будет иметь при эксплуатации единое управление, систему контроля и устранения неисправностей и узких мест в сетевых магистралях.

Для простоты картины мы не будем привязываться к конкретным монтажным помещениям и их физическому расположению. Примем как данное, что каждое здание заказчика имеет похожие кабельные системы и аппаратные помещения, обеспечивающие установку и работу всего необходимого оборудования. Однако на практике часто бывает так, что физические ограничения имеют место, и, более того, оказывают непосредственное влияние на выбор того или иного типа оборудования. И тем не менее предположим, что:

  • При наличии на предприятии заказчика 6000 сотрудников имеется необходимость предоставления сетевой системой 8000 конечных пользовательских портов. Это связано с тем, что некоторые рабочие места должны быть оборудованы более чем одной розеткой для подключения к системе, и, кроме того, есть различные учебные и конференц-залы и т.п.
  • Каждый кабельный узел обеспечивает в среднем по 100 кабельных линий, выполненных из кабеля с витыми парами 5-й категории (UTP5), сходящихся к этому узлу.
  • Оптоволоконные кабельные линии связывают каждый кабельный узел с промежуточным аппаратным помещением.

Сеть, основанная на Ethernet

Разработку проекта мы будем рассматривать начиная с кабельных узлов, обеспечивающих физическое подключение рабочих мест пользователей, и заканчивая ядром системы. Для этого разобьем систему на три иерархических уровня: уровень доступа, уровень распределения и уровень ядра системы.

Уровень доступа

Для обеспечения 8000 пользовательских портов (по 100 портов на каждый кабельный узел) необходимо установить 80 коммутаторов Ethernet (см. рис. 1).

image1.gif (5460 bytes)

Рис. 1. Подключение конечных узлов

Для этой цели мы выбираем две модели коммутаторов Cisco Systems - Catalyst 5000 или Catalyst 5500. Выбор той или иной модели коммутатора в каждом конкретном случае зависит от числа и типа пользовательских портов, подключенных к данному кабельному узлу. Зная о возможном скором переходе на высокоскоростные сетевые соединения, многие заказчики выбирают в качестве основных порты с разными скоростями передачи – 10 и 100 Мбит/с (Ethernet и Fast Ethernet). В качестве коммутатора для уровня доступа рекомендуется использовать именно модель Catalyst 5500 (или 550х), способную резервировать коммутирующий процессор (Supervisor Engine Module), что позволит значительно повысить отказоустойчивость системы уже на уровне доступа.

Адресация IP и разбиение на подсети (структура VLAN)

Для достижения основной цели -- сделать адресацию IP настолько простой, насколько это возможно, - необходимо минимизировать затраты на добавление, перемещение и модификацию узлов сети при эксплуатации. В еще сравнительно недавнем прошлом каждая рабочая станция сети имела статические значения “IP address”, “address mask” и “default gateway”. Всякий раз, когда пользователь или компьютер менял свое местоположение внутри предприятия заказчика, сетевому администратору приходилось вручную на рабочей станции менять значения этих параметров.

В настоящее же время общение сотрудников компаний происходит между удаленными офисами и зданиями, многие работают дома, имея подключение к корпоративной сети через обычные телефонные каналы или через каналы цифровой сети ISDN (Integrated Services Digital Network). При такой организации работы администрирование всех рабочих станций становится практически невозможным.

В связи с этим был разработан протокол DHCP (Dynamic Host Configuration Protocol), позволяющий удаленным пользователям подключаться к любому месту сети, использующей этот протокол, и получать соответствующие значения параметров настройки IP-адреса автоматически, без вмешательства администратора системы. Таким образом, пользователи получили возможность свободно перемещаться как внутри здания предприятия, так и между удаленными офисами, и даже работать дома. Все, что им нужно - это подключиться к системе. Данная схема в настоящее время используется многими крупными корпорациями (в том числе и Cisco Systems). Следует отметить, что такая возможность появилась уже несколько лет назад в сетях AppleTalk, объединявших компьютеры Apple Macintosh.

Благодаря протоколу DHCP решается проблема с добавлениями, перемещениями и удалениями узлов сети. Заказчики теперь не испытывают трудностей при разработке и модернизации собственных сетей, связанных со схемой IP-адресации.

Теперь перед нами возникает следующий вопрос - какого размера должны быть подсети IP? До недавнего времени общепринятыми средними размерами подсетей были большие, затем все чаще стали применять подсети небольшого размера. Это было связано с появлением в составе локальных корпоративных сетей таких устройств, как маршрутизаторы, ранее применявшихся только для связи с глобальными сетями и для управления потоками данных в самих глобальных сетях. С появлением в составе ЛВС коммутаторов размеры подсетей вновь стали увеличиваться для обеспечения работы новых приложений, связанных с организацией видеоконференций, использующих принцип IP-мультикастинга.

В настоящее время нет какого-то одного ответа на вопрос о размерах подсетей. Единственным критерием выбора того или иного способа разделения сети на подсети можно считать требования заказчиков и приложений, работающих на предприятиях.

Для упрощения будем считать, что сеть 10.0.0.0 разбита на подсети, имеющие адресную маску 255.255.255.0. Такая конфигурация подсетей позволяет иметь в каждой из них по 254 активных узла. Кроме того, отметим, что с этого момента мы будем пользоваться термином “VLAN” (Virtual LAN - виртуальная ЛВС) по отношению к подсетям. Позднее, при использовании протокола DHCP, это количество может быть уменьшено с целью разделения VLAN на более мелкие подсети, однако в настоящем руководстве эта проблема не рассматривается.

В связи с тем, что в нашем примере мы используем не более 100 узлов на одну VLAN, 154 адреса из каждой подсети всегда будут оставаться свободными (незанятыми). Однако решение этого вопроса не является целью настоящего руководства.

Расположение VLAN между коммутаторами уровня доступа показано на рис. 2.

image2.gif (5847 bytes)

Рис. 2. Распределение VLAN по коммутационным узлам

Половина всех портов в одном из коммутаторов будет принадлежать, например, VLAN#2, а другая половина – VLAN#3. Все VLAN будут распределяться также между остальными коммутаторами уровня доступа. Таким образом, мы имеем 80 VLAN. Так как каждая VLAN соответствует одной подсети IP, то сеть 10.0.0.0 получается разделенной на 80 подсетей.

Как будет показано ниже, такое решение по организации VLAN позволит масштабировать соединения устройств уровня доступа с устройствами следующего уровня нашей модели – уровня распределения. Кроме того, членство каждого коммутатора в двух VLAN обеспечит дополнительную степень отказоустойчивости и облегчит сопровождение каждого коммутатора и VLAN. Напомним, что принадлежность стоящих рядом рабочих станций к одной VLAN не имеет основополагающего значения. Главной целью является обеспечение надежного и эффективного подключения пользователя к ресурсам сети. Каким образом происходит коммутация на втором и третьем уровне модели OSI, будет объяснено дальше по ходу обсуждения проекта.

Уровень распределения

Каждый коммутатор Catalyst 5000 уровня доступа имеет по две восходящие связи Fast Ethernet ISL. Для повышения степени надежности системы каждая из этих связей подключается к разным коммутаторам Catalyst 5000, образующим уровень распределения в нашей модели (см. рис. 3).

image3.gif (15066 bytes)

Рис. 3. Уровень распределения

Каждый из 14 коммутаторов Catalyst 5000, образующих уровень распределения, имеет по 12 восходящих портов Fast Ethernet. Наша модель сети состоит из семи функциональных строительных блоков, имеющих сходную структуру и состав оборудования. Каждый из этих блоков обеспечивает работу 12 VLAN и состоит из 12 коммутаторов уровня доступа и двух коммутаторов уровня распределения. Далее по ходу обсуждения проекта, мы рассмотрим, каким образом происходит взаимодействие VLAN внутри блока и как блоки взаимодействуют между собой.

Необходимо отметить, что в большинстве случаев из-за физических ограничений, таких как размеры зданий, корпусов, аппаратных помещений и пр., размер функциональных блоков может быть различным. Однако на общей модели сети это никак не отражается.

image4.gif (10040 bytes)

Рис. 4. Уровень распределения (детали)

На рис. 4 уровень распределения показан более подробно; здесь отражены разные пути передачи трафика в зависимости от его принадлежности той или иной VLAN, основанные на использовании протокола Spanning Tree.

Рациональное распределение функций основного коммутатора (root) для каждой VLAN позволит наилучшим образом использовать обе связи, обеспечивающие физическое соединение уровней доступа и распределения. Также правильное конфигурирование избыточности повышает отказоустойчивость соединений уровней доступа и распределения – при обрыве одной из связей трафик обеих VLAN будет автоматически переключен на альтернативный путь передачи. На рис. 4 показано состояние всех линий связи при нормальном функционировании всех кабельных соединений. При помощи настроек параметров протокола Spanning Tree также можно обеспечить балансирование нагрузки между параллельными путями.

Для того чтобы установить левый нижний коммутатор в качестве основного для VLAN#2, необходимо при конфигурации коммутатора задать команду

Switch>set spantree priority 500 2,

где 500 – это значение приоритета, а 2 соответствует VLAN#2.

На другом коммутаторе уровня распределения надо задать команду

Switch>set spantree 1000 2,

где 1000 – приоритет, больший, чем 500, но меньший, чем значение по умолчанию (32768). Таким образом, второй коммутатор станет основным в том случае, если выйдет из строя первый или случится обрыв линии связи между первым коммутатором и уровнем доступа.

Протокол ISL (Inter-Switch Link) используется для передачи трафика двух VLAN по одному магистральному соединению между коммутаторами уровней доступа и распределения.

image5.gif (10509 bytes)

Рис. 5. Анализ избыточности по протоколу Spanning Tree

Для того чтобы убедиться, как эта схема будет работать на практике, рассмотрим случай, при котором соединение между левыми коммутаторами в обоих уровнях было удалено или оборвано (см. рис. 5). В такой ситуации вторая связь с уровнем распределения становиться путем передачи трафика VLAN#2 и VLAN#3.

Масштабирование полосы пропускания

Достаточно важным аспектом на начальном этапе проектирования является оценка инструментальных средств, позволяющих контролировать и изменять поведение сети в реальных условиях при передаче больших объемов пользовательского трафика. Одним из основополагающих мест в сети, где необходимость управления трафиком велика, являются соединения между уровнем доступа и уровнем распределения. Один из подходов к масштабированию соединений этого уровня сети показан на рис. 6.

image6.gif (11072 bytes)

Рис. 6. Масштабирование производительности соединений

В связи с тем, что ранее мы уже разработали для сети гибкую схему распределения VLAN и их соответствия подсетям, в данном примере мы просто организуем новую VLAN (VLAN#100 в данном случае), которая позволит передавать большее количество трафика при взаимодействии двух уровней сети. Фактически исследование трафика на этапе взаимодействия двух уровней может привести к необходимости дополнительного физического соединения между коммутаторами и создания на его основе выделенного соединения для группы пользователей, требующих более широкой полосы пропускания. Этот случай как раз и показан на рис. 6.

На практике создать такое соединение не сложно: используя протокол DHCP можно легко и безболезненно присвоить новые адреса клиентам VLAN#100. При этом обслуживающему персоналу даже не потребуется изменеять в конфигурацию конечных пользовательских рабочих станций.

Другим способом увеличения полосы пропускания соединений уровней доступа и распределения является применение технологии Fast EtherChannel. Применение этой технологии показано на рис. 7.

image7.gif (11392 bytes)

Рис. 7. Масштабирование производительности соединений с применением Fast EtherChannel

Объединение двух или четырех параллельных соединений Fast Ethernet позволяет существенно увеличить производительность соединений между коммутаторами в пределах одной VLAN. При взаимодействии двух узлов сети технология Fast EtherChannel предотвращает передачу пакетов по разным физическим каналам путем закрепления адресов источника и приемника пакетов за одной линией связи. В случае ее отключения или выхода из строя весь трафик автоматически переключается на параллельное соединение.

Назначение серверов рабочих групп

В корпоративных сетях все сетевые приложения выполняются на серверах. В связи с этим одним из важнейших факторов, способствующих правильному распределению потоков данных в сети, является определение местоположения того или иного сервера в сетевой иерархии.

В настоящем руководстве серверы рабочих групп рассматриваются как специализированные вычислительные мощности, призванные обслуживать определенную часть пользователей. Примером применения сервера рабочей группы можно считать сервер электронных сообщений, обеспечивающий передачу информации внутри группы, а также файловый сервер и сервер печати, предоставляющий пользователям группы сервисы хранения файлов и групповой печати. Обычно при такой организации появляется возможность предотвращения передачи всего трафика группы в корпоративную сеть, что существенно снижает нагрузку на основные магистрали.

Для этих целей необходимо создать прямое физическое соединение второго уровня модели OSI сервера рабочей группы с соответствующим коммутатором уровня распределения. На рис. 8 показано прямое подключение серверов к коммутаторам уровня распределения при использовании технологии Fast Ethernet.

image8.gif (7684 bytes)

Рис. 8. Расположение серверов рабочих групп

При использовании сетевых адаптеров, поддерживающих функции ISL, имеется возможность включить один сервер сразу в несколько VLAN. Такое подключение серверов обеспечивает прямое соединение второго уровня с любым местом рассматриваемого строительного блока сети (для VLAN#2 – VLAN#13), показанного на рис. 8. Как правило, на практике нет необходимости предоставлять один сервер только одной рабочей группе. Это связано с тем, что современные серверы по своим аппаратным ресурсам в состоянии обеспечить качественное обслуживание сразу нескольких групп. Такой подход к проблеме организации серверов рабочих групп позволяет снизить затраты на их установку и сопровождение.

Другим решением организации взаимодействия сервера рабочих групп сразу с несколькими VLAN можно считать конфигурирование сетевого адаптера сервера на принадлежность нескольким подсетям. Количество подсетей, поддерживаемое сетевыми адаптерами разных производителей, не ограничивается каким-либо стандартом и зависит от конкретной модели адаптера (особенно в случае с множественными эмулированными сетями (ELAN) при использовании технологии LANE). Следовательно, при выборе какого-то конечного решения по применению данного подхода необходимо обратить внимание на документацию к сетевому адаптеру. На практике конфигурирование сетевого адаптера на принадлежность нескольким VLAN эквивалентно наличию нескольких обычных адаптеров в сервере. На основе этого в применяемых решениях используют от 6 до 10 различных VLAN на одном сетевом интерфейсе.

Принципы организации уровня ядра сети

На рис. 9 показана текущая (по мере обсуждения в настоящем руководстве) конфигурация нашей сети.

image9.gif (11188 bytes)

Рис. 9. Уровни доступа и распределения

Все 14 коммутаторов уровня распределения образуют семь функциональных строительных блоков сети. В каждом блоке имеются все возможности и реализованы все функции для обеспечения взаимодействия всех узлов и VLAN внутри блока. Уровень ядра должен предоставлять три типа функций по объединению имеющихся блоков в единую сетевую систему:

  • Взаимодействие VLAN за пределами строительных блоков сети (Inter-VLAN communication).
  • Взаимодействие оборудования из разных строительных блоков, необходимое для определения оптимальных маршрутов следования потоков данных в разных направлениях.
  • Обеспечение связи всех конечных узлов сети с корпоративными серверами и внешними сетями (частные глобальные сети и Интернет).

Для обеспечения всех этих функций ядром системы мы рассмотрим два подхода к построению самого ядра:

  • Ядро с использованием выделенных маршрутизаторов.
  • Ядро с использованием аппаратуры маршрутизации, встроенной в коммутаторы уровня распределения.

Оба подхода обеспечивают достижение поставленных задач, выбор того или иного решения в каждом конкретном случае зависит от требований заказчика, типа используемого оборудования и от особенностей аппаратных и кабельных помещений.

Ядро сети с использованием выделенных маршрутизаторов

Наиболее приемлемое решение для достижения поставленных задач при использовании выделенных маршрутизаторов показано на рис. 10. В нашем проекте для создания ядра корпоративной сетевой системы используются четыре маршрутизатора Cisco 7500 с шестью или восемью портовыми адаптерами Fast Ethernet.

image10.gif (18455 bytes)

Рис. 10. Ядро системы с отдельно стоящими маршрутизаторами

Более подробно принципы связи между ядром системы и уровнями распределения и доступа показаны на рис. 11.

image11.gif (10304 bytes)

Рис. 11. Резервирование Inter-VLAN маршрутизации

Для обеспечения избыточности в оборудовании и коммуникациях между уровнями ядра и распределения имеются два пути следования потоков данных. Чтобы эти пути одновременно использовались для передачи трафика, необходимо ввести некоторые соглашения. Разделим условно все VLAN в каждом из строительных блоков на четные и нечетные. Для первого строительного блока, который, как описано выше, необходим для передачи трафика четных VLAN, левый маршрутизатор используется в качестве основного для трафика VLAN#2 - VLAN#12.

При использовании маршрутизатора с протоколом HSRP (Hot Standby Router Protocol) необходимо обратить внимание на назначение его (маршрутизатора) интерфейсов в качестве основных и резервных. В сущности, вся маршрутизация Inter-VLAN для подсетей 2–13 в первом функциональном блоке осуществляется левым маршрутизатором, а маршрутизация подсетей 14–25 - правым. Применение HSRP позволяет маршрутизаторам уровня ядра резервировать друг друга, что дает возможность снизить количество единиц оборудования в системе и соответственно избежать дополнительных расходов.

В заключение добавим, что эффективность маршрутизации IP может быть увеличена за счет использования дополнительных функций распределенной коммутации, встроенных в программное обеспечение маршрутизаторов Cisco 7500 (начиная с Cisco IOS 11.2.(7)F). При использовании этих функций вся маршрутизация IP выполняется одним модулем Cisco 7500 -VIP 2 (Versatile Interface Processor), что обеспечивает снижение нагрузки на центральную шину маршрутизатора и существенно увеличивает его производительность. В нашем проекте мы будем использовать 14 таких модулей для обеспечения всех функций распределенной коммутации.

Обеспечение увеличения полосы пропускания на уровне ядра

Как и на уровне распределения, рассмотрим два способа увеличения полосы пропускания соединений на уровне ядра (см. рис. 12).

image12.gif (7602 bytes)

Рис. 12. Масштабирование соединений с маршрутизаторами

Наиболее простым решением является разбиение одной VLAN на более мелкие подсети и группы и передача их трафика по разным физическим соединениям. Это решение показано на рис. 12 в части передачи трафиков четных VLAN#2 – VLAN#12. Эта группа подсетей разбивается на две (VLAN#2 – VLAN#6 и VLAN#8 – VLAN#12), и суммарный трафик передается по двум независимым физическим соединениям. Второй способ увеличения полосы пропускания соединений на уровне ядра - применение технологии Fast EtherChannel является более простым, по сравнению с первым, так как не требует разбиения групп VLAN на подгруппы. Однако применение технологии Fast EtherChannel требует наличия ее поддержки и маршрутизатором уровня ядра, и коммутатором уровня распределения.

Соединения внутри ядра системы

В предыдущих разделах руководства мы рассматривали наш проект как две большие составляющие единой сетевой системы. Теперь настало время обсудить, каким образом происходит взаимодействие этих частей.

Взаимодействие отдельных частей уровня ядра системы показано на рис. 13.

image13.gif (9899 bytes)

Рис. 13. Ядро системы (детали)

Рассмотрим, какие функции выполняют соединения между различными аппаратными компонентами ядра системы. Между маршрутизаторами и коммутаторами Catalyst на уровне ядра организованы две подсети. Наличие протокола ISL в этих подсетях не обязательно; физические соединения для них выполняются на обычных интерфейсах Fast Ethernet. В частности, VLAN#100 предназначена для передачи трафика левому коммутатору Catalyst, а VLAN#101 - правому. Для передачи трафика между двумя частями сети имеется два возможных маршрута. Каким именно образом будет проходить трафик, определяется используемым протоколом маршрутизации. Чтобы обеспечить наиболее быстрое переключение передачи данных на резервный канал, рекомендуется использовать протокол с минимальным временем сходимости. В IP-сетях обычно применяют протоколы OSPF (Open Shortest Path First) или EIGRP (Enhanced Interior Gateway Routing Protocol).

Показанные на рис. 13 корпоративные серверы подключаются к коммутаторам уровня ядра по линиям Fast Ethernet и принадлежат одной VLAN. Серверы, как и рабочие станции, нуждаются в настроенных параметрах IP address, address mask и default gateway. Это необходимо для обеспечения связи на третьем уровне модели OSI для обеспечения функций взаимодействия серверов с остальными участниками сетевой системы. Применение протокола DHCP в этом случае невозможно, поэтому мы рассматриваем два возможных пути решения проблемы: статическая конфигурация серверов и использование протоколов ARP (Address Resolution Protocol) и ICMP (Internet Control Message Protocol), обеспечивающих поддержку корректных таблиц маршрутизации.

Более подробно на функциях корпоративных серверов и проблемах, связанных с их подключением, мы остановимся позднее, а пока рассмотрим альтернативный вариант построения ядра системы.

Ядро системы с применением аппаратуры маршрутизации, встроенной в коммутаторы уровня распределения

Как альтернативный путь построения ядра сетевой системы мы рассмотрим вариант с использованием в качестве ядра аппаратуры коммутации третьего уровня модели OSI, встроенной в коммутаторы уровня распределения. Такая аппаратура доступна в качестве модулей расширения к коммутаторам Catalyst 5xxx и называется RSM (Route Switch Module). Использование модулей RSM в каждом из 14 коммутаторов Catalyst 5000 уровня распределения позволит избежать необходимости установки 14 маршрутизаторов Cisco 7500 с модулями VIP 2 (см. рис. 14).

image14.gif (13696 bytes)

Рис. 14. Уровень ядра с использованием модулей Route Switch Module (RSM)

Объединение коммутации второго и третьего уровня в одном устройстве позволяет осуществлять передачу до 2 миллионов пакетов в секунду. Более подробно работа оборудования показана на рис. 15.

image15.gif (11058 bytes)

Рис. 15. Резервирование ядра на основе RSM

Модули RSM имеют внутренние интерфейсы с внутренней шиной коммутаторов, по одному интерфейсу на каждую VLAN. Например, левый коммутатор с модулем RSM имеет внутренние интерфейсы для VLAN#2–VLAN#13 и функционирует как основной HSRP-маршрутизатор для четных VLAN, а правый коммутатор с модулем RSM также имеет внутренние интерфейсы для VLAN#2–VLAN#13, но функционирует как основной HSRP-маршрутизатор для нечетных VLAN. Каждый из коммутаторов в паре выполняет функции резервного маршрутизатора для своего соседа.

Так же как и в случае с выделенными маршрутизаторами, внутренние соединения аппаратуры ядра системы выполнены с применением коммутаторов Catalyst (см. рис. 16).

image16.gif (18274 bytes)

Рис. 16. Схема соединений ядра на основе RSM

Корпоративные серверы

Корпоративными обычно называют серверы, обеспечивающие выполнение приложений масштаба организации заказчика. Такие серверы поддерживают большое число одновременно подключенных пользователей и имеют возможность обрабатывать большое число пользовательских транзакций за единицу времени. Примерами таких серверов могут служить серверы электронной почты, серверы WWW, серверы мультикастовой трансляции, серверы DHCP и DNS (Domain Name System) и т.д. В процессе эксплуатации серверы могут наращиваться, и их статус в системе может изменяться, например сервер рабочей группы может “дорасти” до корпоративного сервера.

Поддержка мультикастинга IP

Приложения, работающие по принципу многоцелевой рассылки данных (мультикастинга), такие как Microsoft NetShow и Precept IP/TV, требуют от сетевой системы возможности такой рассылки в реальном времени. И такая возможность обеспечивается за счет поддержки протокола IGMP (Internet Group Management Protocol) на рабочих станциях и протокола CGMP (Cisco Group Management Protocol) на коммутаторах и маршрутизаторах. Как это все происходит, показано на рис. 17. (На рисунке показаны выделенные маршрутизаторы, однако такая структура в равной степени относится и к варианту с использованием модулей RSM).

image17.gif (19349 bytes)

Рис. 17. Поддержка IP-multicasting

Для правильного функционирования приложений многоцелевой рассылки данных необходимо, чтобы протокол CGMP был запущен на устройствах уровней распределения и доступа, обеспечивая оптимальную передачу пакетов. В данном случае коммутаторы Catalyst распространяют мультикастовый трафик только на выходные порты, принадлежащие группе рассылки.

Поддержка других технологий и подключение к внешним сетям

Как уже отмечалось в самом начале данного руководства, требования заказчика заключаются в необходимости подключения создаваемой сети к внешним сетям, а также в обеспечении функционирования внутри сетевой системы участков, созданных по другим технологиям организации локальных сетей. Так, в нашей сети необходимо обеспечить функционирование протоколов IPX, NetBIOS и AppleTalk, а также подключить к общим ресурсам рабочие группы, использующие технологию Token Ring. Кроме того, такой подход позволит создавать новые рабочие группы без необходимости применения какой-то определенной модели их (групп) организации. Для большей наглядности проблема показана на рис. 18 в виде ядра с выделенными маршрутизаторами.

image18.gif (21937 bytes)

Рис. 18. Соединения с внешними сетями с другой топологией

Уровень ядра поддерживает следующие типы подключений:

  • Доступ в Интернет через маршрутизатор (или через маршрутизаторы, если требуется резервирование) с обеспечением функций трансляции адресов и обеспечения безопасности (firewall).
  • Подключения к глобальным сетям через маршрутизатор уровня ядра включая постоянное подключение, доступ по коммутируемым каналам тональной частоты и по цифровым каналам ISDN.
  • Подключение к сетям, выполненным по другим технологиям передачи данных (Token Ring, AppleTalk) через маршрутизаторы уровня ядра. Необходимо отметить, что при использовании других технологий передачи рабочая группа, например Token Ring, должна быть организована в соответствии со стандартом и иметь возможность подключения к нашей системе.

Для обеспечения работы протокола Token Ring NetBIOS в новой сети Ethernet необходимо обеспечить прозрачную трансляцию (бриджинг) пакетов из Token Ring в Ethernet и наоборот. Эта трансляция выполняется на уровне распределения при помощи либо выделенного маршрутизатора Cisco 4000 или коммутатора Catalyst 1800 через транспортную сеть FDDI (Fiber Distributed Data Interface).

Итоги рассмотрения проекта сети на основе Fast Ethernet

Итак, подведем итоги. Мы имеем две базовые модели построения коммутируемой сети на базе технологии Fast Ethernet. Выбор подходящего варианта построения зависит от конкретных требований заказчиков и многого другого. На рис. 19 показан проект сети с использованием выделенных коммутаторов Cisco 7500, обеспечивающей функции масштабирования на уровне ядра системы.

image19.gif (23185 bytes)

Рис. 19. Окончательная топология сети с использованием выделенных маршрутизаторов

Проект сети с использованием модулей RSM показан на рис. 20.

image20.gif (20697 bytes)

Рис. 20. Окончательная топология сети с использованием модулей RSM

Анализ отказоустойчивости

Теперь рассмотрим поведение системы при возникновении различного рода сбоев и неполадок. Это необходимо для того, чтобы предотвратить возможную потерю данных при авариях и сократить время простоя системы при локализации и устранении неисправностей.

Напомним, что начальные условия проектирования предусматривали, что при выходе из строя любого компонента активного сетевого оборудования или линии связи должно произойти отключение не более чем 100 конечных пользовательских рабочих мест. Следует отметить, что отключение конечных пользователей произойдет только в случае сбоя на уровне доступа (как это и происходит в сетях shared Ethernet/Fast Ethernet).

Рассмотрим проблему на примере. Имеется взаимодействие между рабочими станциями, входящими соответственно к VLAN#2 и VLAN#5. На рис. 21 показан нормальный путь следования трафика между взаимодействующими станциями на основе информации, ранее описанной в настоящем руководстве. Для более детального и понятного рассмотрения ситуации показан вариант с выделенными маршрутизаторами.

image21.gif (20327 bytes)

Рис. 21. Анализ отказоустойчивости (с использованием выделенных маршрутизаторов)

На рис. 22 показан маршрут следования трафика при сбое основного маршрутизатора для соответствующих VLAN.

image22.gif (22007 bytes)

Рис. 22. Анализ отказоустойчивости (с использованием выделенных маршрутизаторов).
Сбой основного маршрутизатора уровня ядра для маршрутизации VLAN#2 – VLAN#5

В данном случае механизм HSRP автоматически определит сбой в основном маршрутизаторе и переключит передачу трафика на резервный маршрутизатор с использованием резервных линий связи.

В следующем примере (см. рис. 23) рассматривается ситуация, когда выходит из строя коммутатор уровня распределения.

image23.gif (23019 bytes)

Рис. 23. Анализ отказоустойчивости (с использованием выделенных маршрутизаторов).
Сбой одного из коммутаторов уровня распределения для маршрутизации VLAN#2 – VLAN#5

В данном случае сбой ликвидируется при помощи протокола Spanning Tree, функционирующего на соединениях уровней доступа и распределения, и протокола HSRP, функционирующего между маршрутизаторами уровня ядра. На рис. 23 показан один из возможных путей, который маршрутизаторы могут выбрать в качестве основного при выходе из строя коммутатора уровня распределения. Использование параметров конфигурации портов маршрутизаторов (в частности, административная стоимость интерфейсов) позволяет настроить автоматическое перераспределение маршрутов и нагрузки на маршрутизаторы оптимальным образом. Следует отметить, что при использовании модулей RSM эти процессы будут выполняться значительно быстрее за счет использования внутренних шин коммутаторов.

Общие комментарии

Проекты сетей, которые рассматриваются в этой части руководства, значительно упрощены для облегчения понимания самого механизма проектирования больших масштабируемых сетей. Рассмотренные нами функциональные логические блоки, состав оборудования и его назначение могут изменяться в каждом конкретном случае. Это зависит не только от потребностей заказчика, но и от объемов финансирования, физических и прочих ограничений и т.п.

Разбиение крупной сети на более мелкие функциональные блоки и участки делает процесс установки и эксплуатации значительно проще. Упрощаются также и задачи по подключению к работающим системам новых рабочих групп, зданий и удаленных офисов - все это не вызовет глобальных изменений в логической структуре сети.

Окончательный выбор варианта проекта (выделенные маршрутизаторы или модули RSM) зависит от типа используемого оборудования и других факторов, которые учитываются в каждом конкретном случае.

Сеть, основанная на ATM

Проекты сетей на основе Ethernet и ATM на уровне доступа похожи друг на друга, поэтому мы не будем еще раз останавливаться на описании этого уровня. Однако вопросы, касающиеся АТМ, будут рассматриваться подробно.

Уровень доступа и структура VLAN

Уровень доступа, как уже было сказано, построен точно так же, как и в проекте на основе Fast Ethernet. Сеть на уровне доступа состоит из 80 коммутаторов Catalyst 5000, по 100 пользователей на каждом коммутаторе. На уровне доступа конфигурируется 80 VLAN, по два коммутатора на каждую VLAN (см. рис. 24).

image24.gif (5847 bytes)

Рис. 24. Уровень доступа и распределение VLAN

Соединения уровня доступа с уровнем распределения

Каждый коммутатор уровня доступа имеет соединение с коммутатором уровня распределения LightStream 1010 по оптической линии связи ATM OC-3 (155 Мбит/с). Структура соединений показана на рис. 25.

Модуль OC3 ATM в коммутаторе Catalyst 5000 имеет два физических подуровня (PHY), которые обеспечивают подключение одного коммутатора уровня доступа к двум коммутаторам уровня распределения.

image25.gif (16137 bytes)

Рис. 25. Схема соединений уровня распределения АТМ

В нашем случае каждый из восьми коммутаторов LightStream 1010 использует 20 интерфейсов OC-3 ATM (максимальное число таких интерфейсов для коммутатора LightStream 1010 - 32). Позднее, когда потребуется соединить эти коммутаторы с другими устройствами, можно воспользоваться незанятыми интерфейсами.

Рассмотрим такую конфигурацию более подробно (см. рис. 26) и обсудим расположение компонентов технологии LANE.

image26.gif (7420 bytes)

Рис. 26. Уровень распределения (детали) с применением компонентов LEC

На каждом коммутаторе Catalyst 5000 на интерфейсе ATM необходимо создать LEC (LAN Emulation Client) для каждой из VLAN, присутствующих на интерфейсах Ethernet. В нашем случае, например, первый и второй коммутаторы Catalyst 5000 на уровне доступа должны иметь сконфигурированные LEC только для VLAN#2 и VLAN#3. Линии связи от интерфейсов ATM будут подключены к разным коммутаторам ATM. При возникновении неисправности в основной линии связи произойдет автоматическое переключение передачи данных на резервную линию. При этом резервная линия автоматически становится основной без дополнительных изменений в конфигурации LEC.

Необходимо отметить, что в случаях, если коммутаторы ATM связаны между собой дополнительными линиями связи (о чем мы расскажем позже), следует избегать возникновения петель. Зачастую происходит так, что при эксплуатации сетевые администраторы отключают протокол Spanning Tree на коммутаторах с модулями ATM, при этом образуются кольцевые маршруты, что приводит к снижению скорости передачи и ставит под вопрос саму передачу данных по сети. Само собой разумеется, что если на коммутаторах выключен протокол Spanning Tree, то администратор сети должен быть абсолютно уверен в том, что кольцевые соединения второго уровня отсутствуют на всех участках сетевой системы, за исключением тех мест, где этого не позволяет топология (например, рабочие группы Token Ring).

Технология LANE, а точнее ее функционирование, строится на таких компонентах, как LECS (LAN Emulation Configuration Server), LES (LAN Emulation Server), BUS (Broadcast and Unknown Server). Каждый из этих компонентов должен присутствовать в сети. Проблему конфигурирования LECS мы рассмотрим позднее, а вот конфигурация LES/BUS показана на рис. 27.

image27.gif (9631 bytes)

Рис. 27. Распределение сервисов LANE

Наилучшим местом для расположения серверов LES/BUS являются модули ATM LANE, установленные в коммутаторы Catalyst 5000 уровня доступа. Каждый модуль ATM LANE является основным сервером LES/BUS для одной ELAN (Emulated LAN) и резервным для другой. При этом мы будем рассматривать пары коммутаторов, в которых один коммутатор является резервным для другого (см. рис. 28). Протокол SSRP (Simple Server Redundancy Protocol) используется для обеспечения резервирования компонентов LANE и организации взаимодействия между коммутаторами в паре.

Анализ отказоустойчивости

При возникновении сбоя в соединении между уровнями доступа и распределения будут запущены два механизма восстановления связи (см. рис. 28).

image28.gif (8922 bytes)

Рис. 28. Анализ отказоустойчивости

Во-первых, два физических подуровня интерфейса ATM LANE на коммутаторах Catalyst 5000 автоматически определят сбойную линию связи и произведут переключение трафика на резервную линию. Так как сервисы LANE сконфигурированы для этого интерфейса, то протокол SSRP обеспечит автоматическое перемещение всех этих сервисов на второй коммутатор Catalyst.

В случае выхода из строя самого коммутатора LightStream 1010 на уровне распределения интерфейсы dual PHY произведут физическое переключение, однако, без предварительной конфигурации LEC на коммутаторах Catalyst, на другом коммутаторе уровня распределения восстановление связи не произойдет. В связи с этим при проектировании сети необходимо распределить резервирование всех компонентов LANE по имеющемуся оборудованию. Также отметим, что коммутаторы LightStream могут служить резервными серверами LANE и для других пар коммутаторов Catalyst (не показано на рис. 28).

Масштабирование полосы пропускания между уровнями доступа и распределения

Масштабирование (увеличение) полосы пропускания между уровнями доступа и распределения можно производить двумя способами. Первый из них показан на рис. 29. При добавлении дополнительной физической линии связи можно сконфигурировать клиента LEC таким образом, чтобы две линии связи использовались как единый канал для обеспечения передачи трафика VLAN#2 и VLAN#3. Другим решением является использование линий ATM с пропускной способностью 622 Мбит/с.

image29.gif (8107 bytes)

Рис. 29. Масштабирование пропускной способности соединений

Серверы рабочих групп

Назначение и местоположение серверов рабочих групп аналогичны рассмотренным проектам сети на основе Fast Ethernet (см. рис. 30).

image30.gif (11787 bytes)

Рис. 30. Серверы рабочих групп

Большинство сетевых адаптеров ATM поддерживают возможность конфигурации, при которой адаптер становится членом сразу нескольких ELAN. Смысл использования этой возможности адаптеров заключается в создании соединений второго уровня между серверами и клиентами, необходимых для повышения пропускной способности и эффективности сетевого взаимодействия. Так же как и в случае с Fast Ethernet, адаптеры обеспечивают одновременное подключение серверов к 6-10 ELAN.

Некоторые сетевые администраторы не хотят включать серверы по технологии ATM. В этом случае можно подключать серверы рабочих групп по технологии Fast Ethernet. Для того чтобы обеспечить такую возможность, необходимо вместо коммутаторов LightStream 1010 устанавливать на уровне распределения коммутаторы Catalyst 5500, объединяющие в себе все возможности Catalyst 5xxx и LightStream 1010. В этом случае серверы могут быть подключены линиями Fast Ethernet (также обеспечивается поддержка ISL) и быть доступны по сети через линии ATM OC-3 или OC-12 (622 Мбит/с) при использовании соответствующих интерфейсных модулей в коммутаторах.

Ядро на основе ATM

Уровень распределения нашей сети построен на восьми коммутаторах LightStream 1010. Теперь необходимо объединить все это оборудование в единую отказоустойчивую сетевую систему. Для этого мы будем использовать избыточные соединения OC-12, как показано на рис. 31.

image31.gif (17238 bytes)

Рис. 31. Схема ядра на основе АТМ

Каждый коммутатор ATM уровня распределения имеет две связи OC-12 с каждым из двух коммутаторов уровня ядра. Каждый из этих двух коммутаторов имеет две связи OC-12 с двумя другими коммутаторами в пределах ядра системы, которые образуют собственно ядро системы, обладающее отказоустойчивостью и работающее по протоколу маршрутизации PNNI (Private Network-Network Interface). Этот протокол обеспечивает автоматическое восстановление соединения за счет резервных линий связи при выходе из строя основных магистралей сети.

Масштабирование ядра системы

Как показано на рис. 32, полоса пропускания на уровне ядра может быть увеличена за счет добавления дополнительных линий связи в тех местах, где это необходимо. Протокол PNNI автоматически определит наилучший маршрут следования потоков данных и обеспечит балансирование нагрузки между параллельными линиями связи.

image32.gif (13488 bytes)

Рис. 32. Масштабирование ядра на основе АТМ

Маршрутизация Inter-ELAN

На данном этапе проектирования наша сеть не обеспечивает взаимодействия между различными VLAN. Для решения этой проблемы нам необходимы маршрутизаторы, которые поддерживают функции взаимодействия между ELAN в составе сети ATM. На рис. 33 показаны четыре маршрутизатора Cisco 7500, которые обеспечивают все необходимые функции.

image33.gif (20991 bytes)

Рис. 33. Маршрутизация Inter-ELAN

При определении размеров маршрутизации Inter-ELAN необходимо обратить внимание на два параметра:

  • Общая полоса пропускания, необходимая для передачи маршрутов Inter-ELAN.
  • Общая пропускная способность, измеряемая в пакетах в секунду, необходимая для передачи трафика между ELAN.

Для имеющейся на данном этапе проектирования сетевой системы мы рассмотрим четыре магистральных соединения ATM OC-3 со следующими характеристиками (указаны значения, полученные при измерениях количества передач пакетов в обоих направлениях):

  • Маршрутизатор Cisco 7500 series с модулем AIP (ATM Interface Processor) ? 55 тысяч пакетов в секунду.
  • Маршрутизатор Cisco 7500 series с модулем VIP (Versatile Interface Processor) ? от 80 до 85 тысяч пакетов в секунду.

На рис. 35 показано, каким образом происходит распределение ELAN по маршрутизаторам и как разделяются нагрузки между устройствами. Однако сначала мы рассмотрим, как ELAN расположены в сети на уровне распределения.

В левой части сети (см. рис. 34) каждая ELAN закреплена за определенным коммутатором уровня распределения. Правая часть сети (не показана на рисунке) использует ту же схему распределения ELAN.

image34.gif (13372 bytes)

Рис. 34. Ядро на основе АТМ (детали)

Мы специально используем такой подробный уровень детализации в обсуждении проектных решений - это в дальнейшем поможет лучше понять, какой из маршрутизаторов, подключенных к ядру системы, должен обеспечивать работу той или иной ELAN и являться для нее основным маршрутизатором HSRP по умолчанию (Primary HSRP Default Gateway), и сделать правильный выбор.

При конфигурировании маршрутизации Inter-ELAN необходимо убедиться, что каждый из маршрутизаторов (см. рис. 35) подключен к каждой из 80 ELAN. Каждый из маршрутизаторов выбирается в качестве основного HSRP-маршрутизатора по умолчанию для группы из 20 ELAN. Эти группы составляются таким образом, чтобы от коммутаторов уровня распределения (см. рис. 34) до соответствующих маршрутизаторов был наиболее короткий путь.

image35.gif (9254 bytes)

Рис. 35. Маршрутизация Inter-ELAN (детали)

При использовании четырех маршрутизаторов для управления 80 VLAN нагрузка на каждый маршрутизатор будет достаточно большой. Кроме того, каждый маршрутизатор будет обрабатывать информацию не только о VLAN, так или иначе к нему относящихся, но и информацию о маршрутах соседей. Для оптимизации такой ситуации маршрутизаторы ставятся в пассивный режим по отношению ко всем ELAN, кроме тех, которые он обязан обслуживать.

Необходимо добавить, что здесь также располагается компонент LECS технологии LANE, о которой мы упоминали ранее. Каждый из маршрутизаторов выполняет функции сервера LECS, а благодаря использованию протокола SSRP только один из них является основным.

Подключение к внешним сетям

Оглядываясь назад на процесс проектирования сети, можно сказать, что проект сетевой системы, представленной в этом разделе руководства, обеспечивает такие же возможности по подключению внешних сетей, что и проект, основанный на технологии Fast Ethernet (см. рис. 36).

Как видно из диаграммы, некоторые маршрутизаторы, осуществляющие маршрутизацию Inter-ELAN, сконфигурированы таким образом, чтобы заниматься еще и маршрутизацией в глобальные сети. В данном случае такая конфигурация достаточно удобна, однако прежде чем конфигурировать маршрутизатор для выполнения обеих функций, необходимо как следует рассмотреть вопросы, касающиеся полосы пропускания маршрутизатора, его быстродействия, загрузки процессора и нагрузки на интерфейсные порты.

Корпоративные серверы могут быть подключены по интерфейсам ATM или LAN к маршрутизаторам или коммутаторам уровня ядра системы.

Расчет количества виртуальных подключений LANE

При построении сетей ATM не самой плохой идеей является предварительный расчет количества возможных коммутируемых виртуальных соединений (Switched Virtual Circuit, SVC), которое может понадобиться для нормальной работы сети. SVC используются для создания логической связи между компонентами активного сетевого оборудования в системе.

Рассмотрим порядок проведения расчетов.

Для каждой ELAN конфигурируются следующие компоненты LEC:

  • 2 клиента LEC на коммутаторах Catalyst 5000;
  • 4 клиента LEC на маршрутизаторах Cisco 7500;
  • 4 (предположительно) клиента LEC на серверах рабочих групп.

Максимальное число виртуальных канальных соединений (Virtual Channel Connection, VCC) определяется формулой (10*9)/2, т.е. равно 45. Сверху на VCC накладываются 20 SVC типа “точка-точка” и 2 SVC типа “точка-много точек”.

Так как общее количество VLAN - 80, то общее количество SVC определяется следующим образом:

  • общее количество SVC типа “точка-точка” равно 80*(45+20) = 5200
  • общее количество SVC типа “точка-много точек” равно 80*2 = 160
  • общее количество SVC на один маршрутизатор равно 80 + 80 + (80*9) = 880.

image36.gif (22938 bytes)

Рис. 36. Окончательная схема ядра на основе АТМ

Максимальное число SVC, поддерживаемое одним коммутатором LightStream 1010, - 32 000, поэтому наши 5200 SVC на 12 коммутаторов очень хорошо вписываются в это число. Количество SVC на каждый маршрутизатор также посчитано, так как именно маршрутизаторы являются теми точками сети, где происходит объединение большого количества ELAN. Модуль AIP обеспечивает поддержку не более 2048 SVC, что также подходит для данного случая.

Для обеспечения контроля над числом соединений SVC на этапе эксплуатации сетевой системы при проектировании необходимо учесть следующие рекомендации:

  • Необходимо вести строгий контроль за членством пользователей в определенных VLAN. Если для одной VLAN продолжать создавать LEC на каждом коммутаторе, то число возникающих при этом соединений SVC очень скоро выйдет из-под контроля. Это связано с тем, что количество SVC, открываемых при создании LEC, в 4 раза превосходит количество самих LEC для каждой VLAN. Если же необходимость в создании LEC на каждом коммутаторе все-таки есть, то нужно рассмотреть вопрос о переходе на протокол MPOA (Multiprotocol Over ATM). Более подробно об этом мы скажем чуть позже.
  • Необходимо убедиться в том, что протокол VTP (VLAN Trunking Protocol) запущен на всех коммутаторах Catalyst в прозрачном режиме. Такой подход гарантирует, что количество LEC не будет расти катастрофически, что приведет к уменьшению общего количества SVC.
  • При необходимости, в целях уменьшения общего числа SVC, можно уменьшить размеры VLAN и тем самым увеличить количество ELAN, что приведет к снижению числа LEC на одну VLAN (для сети, которую мы рассматриваем в данной статье, это не нужно).

Анализ отказоустойчивости

Теперь рассмотрим, как будет вести себя оборудование при различных сбоях в работе сетевой аппаратуры и линий связи.

Нормальное функционирование сети при взаимодействии между клиентами VLAN#2 и VLAN#5 показано на рис. 37.

image37.gif (24555 bytes)

Рис. 37. Анализ отказоустойчивости

Трафик от клиента VLAN#2 передается через соединение SVC маршрутизатору по умолчанию (основному маршрутизатору), а затем маршрутизатор перенаправляет его по другому SVC коммутатору Catalyst, обслуживающему VLAN#5.

При сбое в работе одного из коммутаторов ATM на уровне ядра происходит перераспределение маршрутов и создание новых SVC, как показано на рис. 38.

В связи с тем, что основной HSRP-маршрутизатор для этого маршрута оказался отключенным от сети, протокол HSRP перенаправит потоки данных следующему маршрутизатору. Новое соединение SVC необходимо для создания логического пути следования трафика через коммутаторы ядра. Восстановление соединений ATM осуществляется протоколом PNNI.

image38.gif (25176 bytes)

Рис. 38. Сбой коммутатора АТМ на уровне ядра

Вернемся к рис. 37. При сбое одного из коммутаторов ATM на уровне распределения происходит перенаправление потоков данных, показанное на рис. 39.

image39.gif (25573 bytes)

Рис. 39. Сбой коммутатора АТМ на уровне распределения

Интерфейс dual PHY на коммутаторе Catalyst, обслуживающем VLAN#5, так же как и протокол PNNI на коммутаторах LightStream, автоматически перенаправит потоки данных по наиболее короткому из имеющихся маршрутов. В этом случае для правильного функционирования протокола SSRP необходимо сконфигурировать резервные серверы LES/BUS для ELAN#5 на соседних с коммутатором Catalyst устройствах.

Переход к сетям ATM, использующим MPOA

Технология MPOA основывается на использовании технологии LANE для обеспечения взаимодействия между ELAN. ATM-интерфейсы коммутаторов Catalyst могут выступать в качестве клиентов MPOA (MPC), а маршрутизаторы Cisco 7500 - в качестве серверов MPOA (MPS).

При использовании MPOA взаимодействие между различными VLAN происходит, как показано на рис. 40.

image40.gif (23935 bytes)

Рис. 40. Применение маршрутизации MPOA

Общие замечания

Мы рассмотрели два альтернативных подхода к организации корпоративных сетей, основанных на современном сетевом оборудовании. Один из этих подходов предоставляет порты коммутируемого Ethernet на каждое рабочее место и использует в качестве технологии ядра системы Fast Ethernet. Другой подход основан на применении для построения ядра системы технологии ATM.

Оба рассмотренных проекта позволяют достичь целей, поставленных заказчиком при проектировании.

Преимущества проекта на Fast Ethernet

  • Простая технология.
  • Высокая плотность портов при сравнительно небольшой стоимости.
  • Простое подключение серверов по технологии Fast Ethernet.
  • Возможность миграции на технологии Fast EtherChannel и Gigabit Ethernet.

Преимущества проекта на ATM

  • Быстрое восстановление функционирования ядра системы при возможных сбоях.
  • Поддержка передачи разнородного трафика (голос, видео) на уровне ядра системы.
  • Поддержка линий связи со скоростью передачи 622 Мбит/с
  • Поддержка стандартов LANE и MPOA.

Оба проекта независимо от применяемых технологий обеспечивают наращиваемость, гибкость и единое управление сетевым оборудованием. Это достигается благодаря разделению сетевой системы на функциональные блоки и объединения коммутации пакетов второго и третьего уровня в одном оборудовании.


Протокол CGMP

Протокол CGMP: Применение IP Multicast в сетях с коммутацией уровня 2

Введение

Коммутация уровня 2 и приложения IP Multicast становятся все более популярными. Их все чаще можно встретить в кампусных сетях. Коммутация уровня 2 позволяет создавать соединения между конечными пользователями и серверами, характеризующиеся масштабируемой пропускной способностью. Рассылка IP Multicast обеспечивает эффективный, многонаправленный транспорт уровня 3, доставляющий конечным абонентам трафики данных, голоса и видео. Прикладные программы, такие как, например, Cisco IP/TV и MBONE VIC и VAT, опираются на технологии IP Multicast для доставки мультимедийного трафика группам устройств, объединенных по принципу определенных IP-адресов.

Хотя обе технологии предоставляют значительные преимущества, их комбинирование в условиях единой сетевой системы может оказать неблаготворное влияние. Основной идеей, заложенной в основу коммутации уровня 2, является использование в качестве единицы данных пакета канального уровня (его еще называют уровнем MAC [Media Access Control]). Такой подход абсолютно неэффективен при передаче трафика IP Multicast. При возникновении потока IP Multicast в сети с коммутацией уровня 2 на всех портах коммутатора появляются широковещательные пакеты уровня 2, что приводит к возникновению широковещательных “штормов” и, как следствие, к снижению скорости передачи всего остального трафика. В этом случае вся эффективность использования обеих технологий сводится к нулю.

Компания Cisco Systems, являясь одним из лидеров сетевой индустрии в области технологий коммутации уровня 2 и IP Multicast, разработала решение, позволяющее эффективно использовать обе эти технологии в корпоративных сетях. Одним из результатов этой деятельности явилась разработка протокола CGMP – Cisco Group Multicast Protocol – динамического протокола, в основе которого лежит многолетний опыт Cisco в создании сетей IP Multicast, основанных на использовании маршрутизаторов. Этот протокол обеспечивает возможность добавления всех средств и методов, необходимых для организации рассылки IP Multicast, в семейство высокоскоростных коммутаторов Catalyst. Несмотря на то, что этот протокол в основном служит для передачи IP Multicast в сетях с коммутацией уровня 2, он основан на протоколе IP. Протокол CGMP работает на основе другого протокола передачи трафика Multicast на уровне 3. Это протокол SMRP (Simple Multicast Routing Protocol), обеспечивающий эффективную передачу трафика через коммутирующую матрицу устройств Catalyst.

Настоящая статья содержит информацию о том, какие шаги необходимо предпринять для внедрения технологий IP Multicast (и протокола CGMP) на уровнях 2 и 3. Статья состоит из следующих разделов:

  • Пример для сети с коммутацией уровня 2: Краткое обсуждение вопросов, касающихся сетей с коммутацией уровня 2;
  • Пример сети с IP Multicast: Обзор основных положений использования технологий Multicast на уровнях 2 и3;
  • IP Multicasting: Углубленное обсуждение наиболее важных компонентов технологии IP Multicast в сетях на основе оборудования Cisco Systems;
  • Протокол CGMP: Решение по применению технологии IP Multicast и других многоадресных протоколов уровня 3 в сетях с коммутацией уровня 2.
  • Заключение

Содержание

Пример сети с коммутацией уровня 2

Пример сети Multicast

Пакеты Unicast

Пакеты Broadcast

Пакеты Multicast

IP Multicasting

Групповая адресация IP Multicast

Протокол IGMP

Маршрутизация Multicast

Протокол DVMRP (RFC-1075)

Протокол MOSPF(Multicast Extensions to OSPF, RFC-1584)

Протокол PIM

Протокол CGMP

Заключение

Пример сети с коммутацией уровня 2
image1.gif (1630 bytes)

Рис. 1. Адрес узла назначения уровня 2

Процесс коммутации уровня 2 заключается в том, что производится обработка входящего фрейма с одного интерфейса и его передача другому интерфейсу. Интерфейс, которому передается фрейм, определяется на основе MAC-адреса узла назначения, указанный в заголовке фрейма.

Коммутатор уровня 2 просматривает таблицу коммутации (см. табл. 1) для определения того, к какому его порту подключен узел назначения, указанный в текущем фрейме.

Табл. 1. Таблица коммутации уровня 2

MAC-адрес узла назначения | Порт назначения
00-00-0с-06-41-7с | 3/3
00-00-0с-02-b9-01 | 3/3
00-80-24-07-8c-60 | 3/2

Если в текущей таблице коммутации нет информации о нахождении узла назначения фрейма, то этот фрейм рассылается по всем портам коммутатора; таким образом устанавливается корректное значение записи таблицы. Когда приходит ответ от узла, принявшего фрейм, коммутатор соответствующим образом корректирует таблицу коммутации.

Когда посланный фрейм содержит в поле адреса назначения широковещательный или многоцелевой адрес, то коммутатор уровня 2 распространяет его по всем интерфейсам. На рис. 2 показан процесс, происходящий тогда, когда коммутатор уровня 2 получает трафик multicast.

image2.gif (7339 bytes)

Рис. 2. Процесс обработки фреймов Broadcast и Multicast коммутатором уровня 2

Пример сети Multicast

Технологии Multicast используются в современных сетях в разных целях. Такие протоколы, как, например EIGRP (Enhanced Interior Gateway Routing Protocol) и OSPF (Open Shortest Path First), используют пакеты multicast для рассылки маршрутных обновлений между соседними маршрутизаторами. Более важной сферой применения технологий Multicast является организация групповой обработки данных прикладными программами. Одним из наилучших примеров такой обработки является использование рассылки данных мультимедиа, когда видео и аудиоданные распространяются по мере подключения пользователей к группам рассылки.

Для применения технологий Multicast необходимо понимание трех основных типов пакетов, служащих для передачи данных по сети: Unicast (одноцелевые), Multicast (групповые) и Broadcast (широковещательные) пакеты.

Пакеты Unicast

image3.gif (2376 bytes)

Рис. 3. Передача пакетов Unicast

В сетях, имеющих дизайн, основанный на применении технологий передачи Unicast, приложения рассылают по одной копии каждого пакета каждому клиенту на основе его (клиента) адреса Unicast. Такой тип передачи данных между приложениями и клиентами имеет серьезные ограничения, особенно проявляющиеся при многочисленных рабочих группах пользователей. Это связано с тем, что рассылка одной и той же информации требует достаточно большого времени, в особенности при использовании разделяемой полосы пропускания сети (см. рис. 3).

Пакеты Broadcast
image4.gif (2433 bytes)

Рис. 4. Передача пакетов Broadcast

При использовании пакетов Broadcast приложения рассылают по одной копии каждого пакета на так называемый адрес Broadcast, который означает, что данный пакет должен обрабатываться каждым узлом сети. Такое техническое решение является более простым, нежели организация рассылки на основе Unicast, особенно при внедрении приложений, осуществляющих групповую рассылку. Однако, при использовании этого подхода сетевое оборудование, такое как устройства уровня 3, должно либо не передавать такие пакеты за пределы подсетей уровня 3, либо передавать их по всем имеющимся подсетям.

На практике рассылка таких пакетов по всем подсетям является малоэффективной, так как лишь небольшая группа клиентов нуждается в подобной рассылке (см. рис. 4).

Пакеты Multicast
image5.gif (2374 bytes)

Рис. 5. Передача пакетов Multicast

При таком дизайне приложения рассылают по одной копии каждого пакета на групповой адрес, причем именно клиент определяет, надо ли ему обрабатывать пакеты с таким адресом. Использование технологий Multicast обеспечивает возможность контролирования объема передаваемого трафика, а также ограничивать объем вычислений, производимых активным сетевым оборудованием и конечными узлами сети, что позволяет исключить избыточность трафика (см. рис.5).

Для понимания преимуществ использования технологий Multicast рассмотрим работу видео-сервера, использующего данные в формате MPEG. Воспроизведение одного видеопотока MPEG требует полосы пропускания примерно в 1,5 Мбит/с. В условиях сети Unicast видео-сервер рассылает трафик со скоростью, определяемой по формуле 1,5 Мбит/с * n, где n – это общее число клиентов рассылки. Таким образом получаем, что при использовании сети с пропускной способностью 10 Мбит/с рассылка 6 или 7 потоков одновременно полностью исчерпывает пропускную способность сети. При использовании же технологий Multicast серверу достаточно рассылать всего 1 копию видеопотока на 1 адрес Multicast, причем независимо от числа активных клиентов, принимающих этот поток. Получается, что при использовании Multicast серверу достаточно свободной полосы пропускания в 1,5 Мбит/с, что обеспечивает возможность утилизации оставшейся пропускной способности для иных целей.

Технологии передачи Multicast могут применяться как на уровне 2, так и на уровне 3. Например, сети Ethernet и FDDI (Fiber Distributed Data Interface) поддерживают все 3 типа пакетов. Индивидуальный компьютер может получать пакеты на адрес Unicast, несколько адресов Multicast и на адрес Broadcast. Сети Token Ring также поддерживают концепции Multicast, правда, они используют для этого несколько иные механизмы. Сети Token Ring имеют функциональные адреса, которые можно использовать для идентификации групп рассылки.

Если общее число приложений, используемых в одной локальной сети, ограничено, то применение технологий Multicast на уровне 2 может оказаться весьма эффективным. Однако, применение в одной локальной сети большого числа приложений, использующих Multicast, не ограничено и не оказывает существенного влияния на каждое приложение в отдельности.

При внедрении приложения Multicast в кампусную сеть, содержащую несколько типов сред и систем передачи данных, таких как Ethernet, Token Ring, FDDI, ATM (Asynchronous Transfer Mode), Frame Relay, SMDS (Switched Multimegabit Data Service) и других сетевых технологий, наилучшим вариантом применения Multicast является его внедрение на уровне 3, если, конечно, трафик такого типа не предназначен только для одного сетевого сегмента.

Для поддержки Multicast на сетевом уровне необходимо определить несколько параметров:

  • Адресация – Необходимо иметь адрес сетевого уровня, отвечающий за соединения между серверами и группами рассылки, причем группы рассылки могут состоять как из одного, так и из большого числа пользователей. Кроме того, необходимо обеспечить механизм установления соответствия между этим адресом и адресами уровня 2, которые используются при работе Multicast на канальном уровне.
  • Динамическая регистрация – Необходимо обеспечить механизм регистрации компьютера, подключенного к сети, в определенных группах рассылки. Без такого механизма невозможно определить, по каким именно подсетям необходимо передавать трафик для каждой группы рассылки.
  • Маршрутизация Multicast – Сеть должна обеспечивать построение деревьев распределения пакетов, которые позволят источникам рассылки отправлять пакеты всем узлам-приемникам. Основной задачей деревьев распределения пакетов является обеспечение нахождения каждого пакета в определенной подсети только один раз (например, если внутри офисной сети имеется несколько получателей пакетов Multicast, то на всю офисную сеть должна приходить только одна копия каждого пакета).

IP Multicasting

Организация IETF (Internet Engineering Task Force) разработала ряд стандартов, соответствующих пунктам, перечисленным в предыдущем разделе.

  • Адресация – Адресное пространство IP разделяется на четыре части: Class A, Class B, Class C и Class D. Для трафика Unicast отводятся Class А, В и С. Class D резервируется для трафика Multicast. Адреса из диапазона Class D распределяются динамически.
  • Динамическая регистрация – Документ RFC-1112 определяет протокол IGMP (Internet Group Management Protocol), который обеспечивает возможность конечного узла сети информировать всю сеть о подключении этого узла к определенной группе рассылки.
  • Маршрутизация Multicast – Для обеспечения маршрутизации Multicast был разработан целый ряд стандартов:
  • RFC-1075, определяющий протокол DVMPR (Distance Vector Multicast Routing Protocol)
  • RFC-1584, определяющий протокол MOSPF (Multicast OSPF) – расширение протокола OSPF (Open Shortest Path First), поддерживающее IP Multicast
  • Два предварительных описания стандартов, представленных Cisco Systems, определяющих протокол PIM (Protocol Independent Multicast) – протокол, который может использоваться совместно с любым стандартным протоколом маршрутизации IP Unicast.

Групповая адресация IP Multicast

На рис. 6 показан формат адреса IP Multicast Class D.

Рис. 6. Формат адреса Class D

В отличие от адресов Class A, B и С младшие 28 бит адреса Class D не имеют определенной структуры. Адрес группы Multicast является двоичной комбинацией значения 1110 в старших 4 битах адреса и идентификатора группы, обычно обозначаемого в десятичной форме в диапазоне от 224.0.0.0 до 239.255.255.255.

В связи с тем, что значение старшего октета начинается с двоичной комбинации 1110, то значение 224 является базовым адресом.
Конечные узлы, обеспечивающие прием пакетов, имеющих определенный адрес IP Multicast, называются группой узлов. Группа узлов может охватывать несколько подсетей. Участие узлов в группе определяется динамически – узлы могут подключаться к группе и отключаться от нее. Более подробно о процессе регистрации в сети IP Multicast рассказывается в разделе, посвященном протоколу IGMP.

Некоторые адреса групп соответствуют определенному типу узлов. Это определено в соответствующем документе IANA (Internet Assigned Numbers Authority). Эти группы называются постоянными группами узлов, аналогично тому, как распределяются номера портов TCP и UDP. В таблице 2 показаны некоторые такие группы.

Табл. 2. Зарегистрированные адреса Class D

Адрес Class D | Назначение
224.0.0.1 | Все узлы в данной подсети
224.0.0.2 | Все маршрутизаторы в данной подсети
224.0.0.4 | Все маршрутизаторы DVMRP
224.0.0.5 | Все маршрутизаторы MOSPF
224.0.0.9 | Протокол RIPv2 (Routing Information Protocol Version 2)
224.0.1.1 | Протокол NTP (Network Time Protocol)
224.0.1.2 | SGI Dogfight
224.0.1.7 | Audio news
224.0.1.11 | IETF audio
224.0.1.12 | IETF video

Кроме резервирования адресов Class D IANA владеет блоком адресов Ethernet, начинающихся с шестнадцатеричной комбинации 00:00:5e. Эта комбинация представляет собой старшие 24 бита адреса Ethernet, что означает, что весь блок адресов включает в себя диапазон с 00:00:5e:00:00:00 по 00:00:5e:ff:ff:ff. Половина адресов этого блока резервируется для передачи пакетов Multicast. Первый байт каждого адреса Ethernet должен содержать комбинацию 01, которая и определяет данный пакет, как пакет Multicast. Таким образом, для передачи IP Multicast используются адреса в диапазоне от 01:00:5e:00:00:00 до 01:00:5e:7f:ff:ff.

Такое резервирование адресов позволяет использовать 23 бита адреса Ethernet для идентификации группы рассылки IP Multicast. Таким образом, младшие 23 бита адреса IP Multicast полностью соответствуют 23 битам адреса Ethernet (см. рис. 7).

Рис. 7. Соответствие адресов Multicast для уровней 2 и 3

Старшие 5 бит адреса Multicast игнорируются и не являются уникальными. Таким образом, каждому адресу Ethernet можно назначить до 23 идентификаторов групп Multicast.

Необходимо отметить, что в связи с тем, что такое соответствие адресов не является уникальным, то драйверы устройств или модули IP должны обеспечивать фильтрацию. Это нужно для того, чтобы интерфейсные карты могли получать только те фреймы Multicast, которые им действительно нужны.

Работа IP Multicast в пределах одной физической сети достаточно проста. При оправке пакета в сеть в поле адреса назначения указывается адрес IP Multicast, драйвер сетевой платы преобразует его в адрес Ethernet Multicast и отправляет в сеть. Для обеспечения приема уровень IP на конечном узле должен проинформировать связной уровень о том, что следует принимать и обрабатывать пакеты, адресованные группе Multicast, а драйвер сетевого адаптера должен обеспечивать этот прием. Этот процесс сопровождается подключением конечного узла к группе рассылки.

При получении дейтаграммы Multicast конечным узлом сети узел должен выполнить все необходимые операции по обработке пакета, предписанные данной группе рассылки. Этот сценарий несколько отличается от обработки UDP, так как в последнем случае входящая дейтаграмма UDP обрабатывается одной операцией. В случае же с Multicast возможно выполнение нескольких операций на данном конечном узле в составе группы рассылки.

Сложности начинаются при применении технологий Multicast за пределами одно локальной сети. При использовании уровня 2 MAC-адреса назначения Multicast обрабатываются так же, как и адреса Broadcast, т.е. пакеты распространяются по всем портам сетевых устройств уровня 2. Все коммутаторы, получая на один из портов поток пакетов Multicast, распространяют его по всем своим интерфейсам, и т.д. Результатом такой обработки является то, что в большинстве случаев пакеты попадают в такие подсети и сетевые сегменты, в которых нет ни одного участника группы рассылки. К счастью, маршрутизаторы на уровне 3 могут разрешить эту проблему, блокируя передачу любых фреймов Broadcast и Multicast уровня 2. Однако, до тех пор, пока маршрутизаторы не будут соответствующим образом передавать пакеты Multicast, для передачи (или не передачи) таких пакетов придется пользоваться отдельным протоколом. Эти функции выполняются протоколом IGMP, который сообщает маршрутизатору о том, что, например, некоторый узел на некоторой подсети, подключенной к данному маршрутизатору, “хочет” присоединиться к данной группе рассылки.

Протокол IGMP

Как и любая другая часть уровня IP, протокол IGMP использует для передачи данных дейтаграммы протокола IP. В отличие от других протоколов этого семейства, IGMP имеет фиксированный размер поля данных внутри дейтаграммы IP (см. рис. 8).

Рис. 8. Дейтаграмма IP с сообщением
протокола IGMP

Сообщения протокола IGMP обозначаются в поле идентификатора протокола дейтаграммы IP значением 2. Формат сообщения IGMP внутри дейтаграммы IP показан на рис. 9.

Протокол IGMP реализован в двух версиях – Type 1 и Type 2. Сообщения Type 1 являются запросами, рассылаемыми маршрутизаторами Multicast, а сообщения Type 2 являются ответами на эти запросы,посылаемыми конечными узлами сети. Групповой адрес – это ничто иное, как адрес IP Class D. При запросах групповой адрес имеет значение 0, а при ответах это поле содержит адрес группы рассылки.

Рис. 9. Формат сообщения IGMP

Фундаментальной функцией технологий Multicast является концепция обеспечения подключения некоего данного порта (интерфейса) на некотором конечном узле сети к группе рассылки. Участие данного интерфейса в группе рассылки является динамическим (таким образом, с течением времени имеют место процессы подключения и отключения клиентов от групп рассылки). Благодаря этому конечные узлы сети могут динамически подключаться к группам рассылки по мере загрузки на этих узлах определенных прикладных программ.

Сообщения IGMP используются маршрутизаторами Multicast для отслеживания текущего состояния групп рассылки (а именно, членство в той или иной группе того или иного конечного узла сети). Отслеживание затрагивает все сети, к которым у данного маршрутизатора имеются физические подключения. При этом необходимо упомянуть о соблюдении следующих правил:

  1. Конечный узел сети посылает пакет IGMP типа report для обеспечения запуска процесса подключения к группе рассылки. Если на данном конечном узле выполняются сразу несколько процессов подключения к одной и той же группе, то посылается только один пакет IGMP. Причем этот пакет посылается только на тот интерфейс, который имеет соединение с сервером рассылки.
  2. Узел не посылает никаких дополнительных пакетов при отключении от группы рассылки, даже если последним покидает группу. Каждый конечный узел “знает” о том, что в данной группе нет ни одного участника, поэтому при получении следующего запроса ему не за чем информировать группу.
  3. Маршрутизатор Multicast через определенные временные интервалы посылает в сеть запросы IGMP. Эти запросы позволяют определить текущее состояние групп рассылки. Маршрутизатор должен отправить по одному запросу на каждый интерфейс. Адрес группы в запросе равен 0 до тех пор, пока маршрутизатор не обнаружит хотя бы одного работающего клиента из любой активной группы рассылки.
  4. Узел посылает ответный пакет IGMP для каждой группы рассылки до тех пор, пока имеется хотя бы один клиент данной группы.

Использование системы запросов и ответов позволяет маршрутизатору Multicast обеспечивать актуальное состояние таблицы, содержащей информацию о том, на каком из интерфейсов находятся один или более узлов сети, принадлежащих данной группе рассылки. Если маршрутизатор получает дейтаграмму Multicast (использующую адрес Multicast уровня 2), предназначенную для дальнейшей пересылки, то он пересылает эту дейтаграмму только на те интерфейсы, к которым подключены подсети, содержащие клиентов данной группы рассылки. На рис. 10 показано простое взаимодействие устройств по протоколу IGMP.
image10.gif (4951 bytes)

Рис. 10. Запросы и ответы IGMP

Как видно из рисунка, значение поля TTL (Time to Live) запросов и ответов устанавливается в 1, в отличие от нормального значения TTL в заголовке обычного пакета IP. Дейтаграмма Multicast с начальным значением TTL равным 0 ограничена по распространению в пределах того же узла. По умолчанию дейтаграммы Multicast имеют в поле TTL значение 1, что ограничивает их распространение в

пределах одной подсети. Дейтаграммы с большим значением TTL могут обрабатываться и передаваться маршрутизаторами Multicast.
Увеличивая значение TTL, приложения могут расширять круг поиска определенных серверов. Первая дейтаграмма Multicast в потоке всегда имеет значение TTL равное 1. Если на эту дейтаграмму не приходит ответа от сервера, то посылается следующая дейтаграмма с полем TTL равным 2. Затем 3 и т.д. Таким образом, приложение обнаруживает далеко стоящий сервер, причем попутно определяется количество промежуточных маршрутизаторов на пути от клиента до сервера (Number of Hops).

Специальный диапазон адресов от 224.0.0.0 до 224.0.0.255 предназначен для тех приложений, трафик которых никогда не выходит за пределы одного промежуточного маршрутизатора. Маршрутизатор Multicast никогда не обрабатывает пакеты с такими адресами, несмотря на значение поля TTL.

Маршрутизация Multicast

Одним из необходимых требований для передачи трафика Multicast через маршрутизируемые сети является наличие маршрутного протокола Multicast. В настоящее время известны 3 таких протокола – DVMRP, MOSPF и PIM. Назначение каждого из них заключается в нахождении внутри сети маршрута для следования трафика Multicast и обеспечение доставки этого трафика каждому заинтересованному участнику сети.

Протокол DVMRP (RFC-1075)

Протокол DVMRP использует алгоритм, известный как Reverse Path Forwarding. Маршрутизатор, получая пакет, распространяет его по всем известным ему путям, кроме того, откуда этот пакет был получен. Такое действие позволяет потокам данных достигать всех имеющихся локальных сегментов (иногда и по несколько раз). Если маршрутизатор подключен к некоторому количеству локальных сегментов, в которых нет ни одного участника групп рассылки, то он (маршрутизатор) отправляет обратное сообщение, содержащее информацию об этом. На основе этого сообщения соответствующим образом корректируется текущее состояние дерева распределения. Это обеспечивает предотвращение передачи трафика тем подсетям, которые в таком трафике не нуждаются.

Протокол DVMRP периодически генерирует распространение пробных пакетов, назначением которых является определение новых узлов сети, подключающихся к группам рассылки. Между временем, необходимым станции для подключения к группе рассылки и получение станцией первых пакетов потока данных, и частотой посылки пробных пакетов существует прямая зависимость.

Для определения того, какой интерфейс является источником потока данных Multicast, и предотвращения распространения трафика в обратном направлении, протокол DVMRP использует свой собственный маршрутный протокол типа Unicast. Этот протокол в достаточно большой степени похож на протокол RIP; он основывается на числе промежуточных узлов при определении метрики маршрута. В результате трафик Multicast не всегда следует тем же маршрутом, что и трафик Unicast.

Протокол DVMRP вызывает серьезные проблемы при наращивании сети, связанные с необходимостью периодического опроса клиентов групп рассылки. Эти ограничения усиливаются тем фактом, что протокол не обеспечивает механизма отключения станций. В результате DVMRP обычно использует механизмы туннелирования контрольной информации, что может вызывать непредвиденные задержки в сети.

Протокол DVMRP применяется для организации MBONE (Multicast backbone across the public Internet), обеспечивая реализацию туннелей между устройствами, работающими с этим протоколом. Такие вещи, как MBONE, повсеместно используются для обеспечения настольной конференц-связи между компьютерами и их группами, установленными на значительном расстоянии друг от друга и соединенными публичными каналами связи. В недалеком будущем планируется отход MBONE от применения DVMRP; вместо него планируется использование протокола PIM в связи с тем, что PIM имеет лучшие параметры эффективности. Преимуществам протокола PIM перед DVMRP посвящена часть раздела с описанием PIM.

Протокол MOSPF(Multicast Extensions to OSPF, RFC-1584)

Протокол MOSPF определен, как расширение маршрутного протокола Unicast OSPF. В основе работы протокола OSPF находится концепция того, что каждый маршрутизатор сети “знает” обо всех имеющихся сетевых соединениях. Каждый маршрутизатор OSPF вычисляет маршруты от себя до всех возможных узлов и подсетей.

Работа протокола MOSPF основана на том, что к маршрутным обновлениям OSPF добавляется информация Multicast. Маршрутизатор MOSPF в процессе работы накапливает информацию о группах Multicast, которые в настоящий момент активны в сети.

Протокол MOSPF обеспечивает построение дерева распределения для каждой пары “источник – группа рассылки” и вычисляет пути для передачи трафика от активных источников к группам. Текущее состояние дерева имеется на каждом маршрутизаторе, что обеспечивает перерасчет маршрутов при изменении текущего состояния соединений или при устаревании имеющейся информации. В связи с тем, что все эти действия производятся только в случае каких-либо изменений, то в зависимости от размеров сети и распределения групп рассылки это может оказывать негативное влияние на производительность обработки Multicast.

Естественно, что протокол MOSPF работает только в тех сетях, которые используют протокол OSPF.

Протокол MOSPF является наилучшим решением для таких сетевых систем, в которых имеется небольшое число пар “источник – группа рассылки”, активных в данных момент времени. Менее хорошо этот протокол будет работать в сетевых системах с большим количеством активных источников или в системах, имеющих нестабильные линии связи.

Протокол PIM

В отличие от MOSPF, работающего только с протоколом OSPF, протокол PIM работает с любым из известных маршрутных протоколов. Также, в отличие от DVMRP, имеющего по определению проблемы с масштабируемостью, протокол PIM предоставляет два различных типа схем распределения многоадресного трафика, обеспечивающих масштабирование маршрутизации Multicast: режимы Dense Mode и Sparse Mode.

Режим Dense Mode PIM чаще всего используется в следующих случаях:

  • Отправители и получатели информации находятся в непосредственной близости друг от друга

  • Имеется небольшое количество отправителей и большое количество получателей рассылки

  • Имеется большой объем трафика Multicast

  • Плотность потоков данных Multicast находится постоянно примерно на одном уровне.

Режим Dense Mode использует, так же как и DVMRP, механизм Reverse Path Forwarding. Основным отличием между DVMRP и Dense Mode PIM является тот факт, что PIM работает независимо от того, какой маршрутный протокол Unicast используется на данном соединении. Другими словами, протокол PIM не требует наличия в сети какого-либо определенного протокола Unicast.

image11.gif (13168 bytes)

Рис. 11. Работа протокола Dense Mode PIM

В режиме Dense Mode протокол PIM распространяет запросы и ответы на подключение или отключение от групп рассылки сразу обо всей подсети, основываясь на информации о составе групп Multicast. В частности, при использовании телевизионного вещания в условиях локальной сети этот режим достаточно эффективен в связи с тем, что он обеспечивает быстрое распространение информации о подключениях и отключениях клиентов от групп рассылки во всех подсетях. Распространение информации о подсетях также эффективно благодаря тому, что требуется небольшое количество трафика для рассылки такого объема информации. Программное обеспечение Cisco IOS (Cisco Internetwork Operating System) обеспечивает поддержку протокола Dense Mode PIM.

image12.gif (9002 bytes)

Рис. 12. Работа протокола Sparse Mode PIM

Режим Sparse Mode PIM обычно применяется в следующих случаях:

  • При наличии небольшого количества получателей рассылки в каждой группе

  • Источники и получатели рассылки соединены между собой каналами WAN

  • Трафик характеризуется непостоянной плотностью

На рис. 12 показано функционирование Sparse Mode PIM. Этот режим оптимизирован для таких ситуаций, при которых большое количество многонаправленных потоков данных и каждый поток Multicast связаны с небольшим количеством локальных сетевых сегментов внутри общей сети. При таком типе групп рассылки механизм Reverse Path Forwarding неэффективно использует полосу пропускания сети. Механизм, используемый Sparse Mode PIM, называется Rendezvous Point (точка встречи). Когда источник отправляет данные, то сперва он отправляет их на точку встречи, и если получатель подключается к группе рассылки, то ему необходимо зарегистрироваться в этой точке. При передаче трафика по маршруту “Источник – точка встречи – получатель” маршрутизаторы автоматически оптимизируют путь следования трафика, исключая тем самым лишние промежуточные узлы. Режим Sparse Mode PIM предполагает, что ни один узел не начинает рассылку пакетов Multicast без предварительного запроса клиента. Программное обеспечение Cisco IOS осуществляет поддержку этого режима протокола PIM.

Информация о том, как конфигурировать маршрутизацию IP Multicast на устройствах Cisco Systems содержится на CD-ROM Cisco Connection Documentation.

Протокол CGMP

Очевидно, что благодаря адресной схеме Class D, протоколам IGMP и PIM есть возможность создания хорошего механизма распределения трафика IP Multicast в маршрутизируемых сетях на основе оборудования Cisco Systems, однако, этот механизм основывается на распределенных адресах уровня 3, что создает определенные проблемы при использовании коммутации уровня 2. Дело в том, что в коммутационных таблицах коммутаторов для этого типа трафика не создается никаких записей, что приводит к тому, что поток Multicast плотностью 1,5 Мбит/с просто передается на все порты коммутатора. Такая ситуация не лучшим образом сказывается на эффективности работы всей сети.

При достаточно большом количестве устройств уровня 3 в одной сети присутствует сравнительно большой набор механизмов управления трафиком IP Multicast. Например, простое запрещение передачи этого трафика через один из интерфейсов маршрутизатора помогает решить проблему предотвращения передачи этого трафика в подсети, не проявляющие к нему интерес. Другим решением может быть установка определенного значения поля TTL на некоторых интерфейсах маршрутизатора.

Однако с другой стороны, прохождение трафика IP Multicast через коммутаторы уровня 2 неизбежно, особенно в условиях кампусной сети (см. рис.13).

image13.gif (9781 bytes)

Рис. 13. Прохождение трафика IP Multicast через коммутаторы уровня 2

Как мы рассматривали ранее, трафик IP Multicast ставится в соответствие адресам Multicast уровня 2, что приводит к тому, что он передается на все порты коммутатора.

Рассмотрим на рис. 13 видеосервер A и видеоклиента B. Видеоклиент требует просмотра видеопрограммы, транслируемой видеосервером с использованием 1,5 Мбит/с потока. Процесс подключения клиента к группе рассылки начинается с посылки запроса видеосерверу на подключение по протоколу IGMP. Ближайший к клиенту маршрутизатор получает этот запрос и, используя протокол PIM, добавляет клиентский сегмент в дерево распределения PIM. На этом этапе трафик IP Multicast начинает передаваться клиенту. Коммутатор получает входящий трафик и просматривает MAC-адрес узла назначения. В связи с тем, что этот MAC-адрес соответствует адресу Multicast, и в таблице коммутации, естественно, такого адреса нет, то весь 1,5 Мбит/с поток передается всем портам коммутатора.

Cisco Systems представляет решение, позволяющее устранить возникающую неэффективность. Это решение заключается в том, что в программное обеспечение Cisco IOS, под управлением которого работают коммутаторы, добавляются “интеллектуальные” функции, позволяющие управлять трафиком Multicast уровня 2. Эти функции осуществляются протоколом CGMP (Cisco Group Management Protocol).

Как видно из названия протокола, CGMP является разработкой Cisco Systems и позволяет коммутаторам Cisco Catalyst получать информацию о составе групп рассылки от маршрутизаторов Cisco. Это обеспечивает возможность управления трафиком Multicast на уровне 2. В результате сеть, построенная на основе такого оборудования и использующая CGMP, обеспечивает доставку трафика Multicast только на те порты коммутаторов Catalyst, к которым подключены участники рассылки. На остальные порты данная рассылка не распространяется до тех пор, пока от них не придет запрос клиента на подключение к группе рассылки.

Самым важным преимуществом использования CGMP является то, что этот протокол позволяет максимально использовать производительность уровня 2. В отличие от других решений этот подход позволяет передавать информацию уровня 3 на уровень конечных портов, т.е. CGMP может управлять коммутацией уровня 2. И как результат такого использования протокола можно отметить, например, тот факт, что коммутатор Catalyst 5000 может обрабатывать пакеты Multicast со скоростью в 1 миллион пакетов в секунду.

Рисунки с 14 по 16 показывают работу протокола CGMP между маршрутизатором Cisco 7505 и коммутатором Catalyst 5000. Преимущества протокола CGMP рассматриваются на примере видеопотока плотностью 1,5 Мбит/с.

image14.gif (5183 bytes)

Рис. 14. Трафик IP Multicast в сети с протоколом CGMP: IGMP Join Message

Как и прежде, процесс подключения клиента к группе рассылки начинается с посылки клиентом запроса на подключение по протоколу IGMP.

image15.gif (5866 bytes)

Рис. 15. Трафик IP Multicast в сети с протоколом CGMP: CGMP Join Message

Однако, в данном случае ближайший от клиента маршрутизатор, получив запрос IGMP на подключение, запоминает MAC-адрес узла-отправителя запроса (читай – клиента рассылки) и возвращает коммутатору Catalyst 5000 запрос на подключение к группе, но уже по протоколу CGMP. Коммутатор Catalyst 5000 использует этот пакет CGMP для создания динамической записи в таблице коммутации, которая соответствует номеру порта, к которому подключен клиент. В данном примере видеопоток плотностью 1,5 Мбит/с будет доставлен только тем портам коммутатора, которые присутствуют в таблице коммутации. Все остальные порты этот трафик получать не будут.

image16.gif (1932 bytes)

Рис. 16. Трафик IP Multicast в сети с протоколом CGMP: распространение трафика после подключения по CGMP

Несмотря на то, что данный пример иллюстрирует работу всего одного коммутатора, протокол CGMP обеспечивает аналогичную работу при каскадировании коммутаторов. На рис. 17 показан как раз такой случай, когда несколько коммутаторов Catalyst 5000 подключены последовательно к одному интерфейсу маршрутизатора.

image17.gif (3261 bytes)

Рис. 17. Сеть с каскадированием коммутаторов

Без применения протокола CGMP трафик Multicast распространяется на всю коммутирующую матрицу уровня 2. Исходящий маршрутизатор предотвращает попадание трафика Multicast в ядро кампусной сети, однако он не в состоянии управлять коммутирующими матрицами на уровне 2. При использовании CGMP трафик Multicast является полностью управляемым, причем не только на уровне непосредственно подключенного коммутатора, но и на всех нижестоящих коммутаторах. Выполнение этих функций возможно благодаря тому, что протокол CGMP использует известный адрес Multicast уровня 2, который обрабатывается всеми коммутаторами Catalyst. На рис. 18 показана работа протокола CGMP в сети с каскадированием коммутаторов уровня 2.

image18.gif (10842 bytes)

Рис. 18. Протокол CGMP в сети с каскадированием коммутаторов уровня 2

Заключение

Как стало понятно при рассмотрении в настоящей статье, технологии IP Multicasting и коммутация уровня 2 являются перспективными технологиями, предоставляющими масштабируемую коммутируемую среду, обеспечивающую взаимодействие клиентов и серверов. Слабым местом коммутации уровня 2 является поддержка трафика Multicast. Без применения специальных дополнительных механизмов, повышающих эффективность передачи трафика Multicast, коммутатор уровня 2 доставляет этот трафик всем своим портам. Cisco Systems решает эту проблему, предлагая использование в корпоративных сетях протокола CGMP, являющимся одним из наиболее передовых решений, которое уже достаточно широко и успешно применяется в корпоративных сетях с целью повышения производительности коммутации уровня 2 и поддержки трафика IP Multicast. Именно это решение позволяет этим технологиям сосуществовать в рамках одной сети, удовлетворяя при этом все требования пользователей этих сетей.


Глава 1. Введение в объединенные сети.

  • Введение
  • Эталонная модель OSI
    • Иерархическая связь
    • Форматы информации
    • Проблемы совместимости
    • Уровни OSI
  • Важнейшие термины и концепции
    • Адресация
    • Блоки данных (фрэймы), пакеты и сообщения
  • Основные организации.

Введение.

В данной главе дается раз'яснение основных концепций об'единения сетей. Представленная здесь основополагающая информация поможет читателю понять тот технический материал, из которого составлена большая часть данной публикации. В главу включены разделы, касающиеся эталонной модели OSI, важные термины и концепции, а также перечень основных организаций по стандартизации сетей.

Эталонная модель OSI.

Перемещение информации между компьютерами различных схем является чрезвычайно сложной задачей. В начале 1980 гг. Международная Организация по Стандартизации (ISO) признала необходимость в создания модели сети, которая могла бы помочь поставщикам создавать реализации взаимодействующих сетей. Эту потребность удовлетворяет эталонная модель "Взаимодействие Открытых Систем" (OSI), выпущенная в 1984 г.

Эталонная модель OSI быстро стала основной архитектурной моделью для передачи межкомпьютерных сообщений. Несмотря на то, что были разработаны другие архитектурные модели (в основном патентованные), большинство поставщиков сетей, когда им необходимо предоставить обучающую информацию пользователям поставляемых ими изделий, ссылаются на них как на изделия для сети, соответствующей эталонной модели OSI. И действительно, эта модель является самым лучшим средством, имеющемся в распоряжении тех, кто надеется изучить технологию сетей.

Иерарахическая связь.

Эталонная модель OSI делит проблему перемещения информации между компьютерами через среду сети на семь менее крупных, и следовательно, более легко разрешимых проблем. Каждая из этих семи проблем выбрана потому, что она относительно автономна, и следовательно, ее легче решить без чрезмерной опоры на внешнюю информацию.

Каждая из семи областей проблемы решалась с помощью одного из уровней модели. Большинство устройств сети реализует все семь уровней. Однако в режиме потока информации некоторые реализации сети пропускают один или более уровней. Два самых низших уровня OSI реализуются аппаратным и программным обеспечением; остальные пять высших уровней, как правило, реализуются программным обеспечением.

Справочная модель OSI описывает, каким образом информация проделывает путь через среду сети (например, провода) от одной прикладной программы (например, программы обработки крупноформатных таблиц) до другой прикладной программы, находящейся в другом компьютере. Т.к.информация, которая должна быть отослана, проходит вниз через уровни системы, по мере этого продвижения она становится все меньше похожей на человеческий язык и все больше похожей на ту информацию, которую понимают компьютеры, а именно "единицы" и "нули".

В качесте примера связи типа OSI предположим, что Система А на Рис. 1-1 имеет информацию для отправки в Систему В. Прикладная программа Системы А сообщается с Уровнем 7 Системы А (верхний уровень), который сообщается с Уровнем 6 Системы А, который в свою очередь сообщается с Уровнем 5 Системы А, и т.д. до Уровня 1 Системы А. Задача Уровня 1 - отдавать (а также забирать) информацию в физическую среду сети. После того, как информация проходит через физическую среду сети и поглащается Системой В, она поднимается через слои Системы В в обратном порядке (сначала Уровень 1 , затем Уровень 2 и т.д.), пока она наконец не достигнет прикладную программу Системы В.

Хотя каждый из уровней Системы А может сообщаться со смежными уровнями этой системы, их главной задачей является сообщение с соответствующими уровнями Системы В. Т.е. главной задачей Уровня 1 Системы А является связь с Уровнем 1 Системы В; Уровень 2 Системы А сообщается с Уровнем 2 Системы В и т.д. Это необходимо потому, что каждый уровень Системы имеет свои определенные задачи, которые он должен выполнять. Чтобы выполнить эти задачи, он должен сообщаться с соответствующим уровнем в другой системе.

Уровневая модель OSI исключает прямую связь между соответствующими уровнями других систем. Следовательно, каждый уровень Системы А должен полагаться на услуги, предоставляемые ему смежными уровнями Системы А, чтобы помочь осуществить связь с соответствующим ему уровнем Системы В. Взаимоотношения между смежными уровнями отдельной системы показаны на Рис.1-2.

Предположим, что Уровень 4 Системы А должен связаться с Уровнем 4 Системы В. Чтобы выполнить эту задачу, Уровень 4 Системы А должен воспользоваться услугами Уровня 3 Системы А. Уровень 4 называется "пользователем услуг", а Уровень 3 - "источником услуг". Услуги Уровня 3 обеспечиваются Уровню 4 в "точке доступа к услугам" (SAP), которая представляет собой просто местоположение, в котором Уровень 4 может запросить услуги Уровня 3. Как видно из рисунка, Уровень 3 может предоставлять свои услуги множеству об'ектов Уровня 4.

Форматы информации.

Каким образом Уровень 4 Системы В узнает о том, что необходимо Уровню 4 Системы А? Специфичные запросы Уровня А запоминаются как управляющая информация, которая передается между соответствующими уровнями в блоке, называемом заголовком; заголовок предшествуют фактической прикладной информации. Например, предположим, что Система А хочет отправить в Систему В следующий текст (называемый "данные" или "информация"):

The small grey cat ran up the wall to try to catch the red bird.

Этот текст передается из прикладной программы Системы А в верхний уровень этой системы. Прикладной уровень Системы А должен передать определенную информацию в прикладной уровень Системы В, поэтому он помещает управляющую информацию (в форме кодированного заголовка) перед фактическим текстом, который должен быть передан. Этот информационный блок передается в Уровень 6 Системы А, который может предварить его своей собственной управляющей информацией. Размеры сообщения увеличиваются по мере того, как оно проходит вниз через уровни до тех пор, пока не достигнет сети, где оригинальный текст и вся связанная с ним управляющая информация перемещаются к Системе В, где они поглащаются Уровнем 1 Системы В. Уровень 1 Системы В отделяет заголовок уровня 1 и прочитывает его, после чего он знает, как обрабатывать данный информационный блок. Слегка уменьшенный в размерах информационный блок передается в Уровень 2, который отделяет заголовок Уровня 2, анализирует его, чтобы узнать о действиях, которые он должен выполнить, и т.д. Когда информационный блок наконец доходит до прикладной программы Системы В, он должен содержать только оригинальный текст.

Концепция заголовка и собственно данных относительна и зависит от перспективы того уровня, который в данный момент анализирует информационный блок. Например, в Уровне 3 информационный блок состоит из заголовка Уровня 3 и следующими за ним данными. Однако данные Уровня 3 могут содержать заголовки Уровней 4, 5, 6 и 7. Кроме того, заголовок Уровня 3 является просто данными для Уровня 2. Эта концепция иллюстрируется на Рис. 1-3. И наконец, не все уровни нуждаются в присоединении заголовков. Некоторые уровни просто выполняют трансформацию фактических данных, которые они получают, чтобы сделать их более или менее читаемыми для смежных с ними уровней.

Проблемы совместимости.

Эталонная модель OSI не является реализацией сети. Она только определяет функции каждого уровня. В этом отношении она напоминает план для постройки корабля. Точно также, как для выполнения фактической работы по плану могут быть заключены контракты с любым количеством кораблестроительных компаний, любое число поставщиков сети могут построить протокол реализации по спецификации протокола. И если этот план не будет предельно понятным, корабли, построенные различными компаниями, пользующимися одним и тем же планом, пусть незначительно, но будут отличаться друг от друга. Примером самого незначительного отличия могут быть гвозди, забитые в разных местах.

Чем об'ясняется разница в реализациях одного и того же плана корабля (или спецификации протокола)? Частично эта разница вызвана неспособностью любой спецификации учесть все возможные детали реализации. Кроме того, разные люди, реализующие один и тот же проект, всегда интерпретируют его немного по-разному. И наконец, неизбежные ошибки реализации приводят к тому, что изделия разных реализаций отличаются исполнением. Этим об'ясняется то, что реализация протокола Х одной компании не всегда взаимодействует с реализацией этого протокола, осуществленной другой компанией.

Уровни OSI.

После того, как стали понятными основные особенности принципа деления на уровни модели OSI, можно приступить к обсуждению каждого отдельного уровня и его функций. Каждый уровень имеет заранее заданный набор функций, которые он должен выполнить для того, чтобы связь могла состояться.

Прикладной уровень
Прикладной уровень - это самый близкий к пользователю уровень OSI. Он отличается от других уровней тем, что не обеспечивает услуг ни одному из других уровней OSI; однако он обеспечивает ими прикладные процессы, лежащие за пределами масштаба модели OSI. Примерами таких прикладных процессов могут служить программы обработки крупномасштабных таблиц, программы обработки слов, программы банковских терминалов и т.д.

Прикладной уровень идентифицирует и устанавливает наличие предполагаемых партнеров для связи, синхронизирует совместно работающие прикладные программы, а также устанавливает соглашение по процедурам устранения ошибок и управления целостностью информации. Прикладной уровень также определяет, имеется ли в наличии достаточно ресурсов для предполагаемой связи.

Представительный уровень
Представительный уровень отвечает за то, чтобы информация, посылаемая из прикладного уровня одной системы, была читаемой для прикладного уровня другой системы. При необходимости представительный уровень осуществляет трансляцию между множеством форматов представления информации путем использования общего формата представления информации.

Представительный уровень занят не только форматом и представлением фактических данных пользователя, но также структурами данных, которые используют программы. Поэтому кроме трансформации формата фактических данных (если она необходима), представительный уровень согласует синтаксис передачи данных для прикладного уровня.

Сеансовый уровень
Как указывает его название, сеансовый уровень устанавливает, управляет и завершает сеансы взаимодействия между прикладными задачами. Сеансы состоят из диалога между двумя или более об'ектами представления (как вы помните, сеансовый уровень обеспечивает своими услугами представительный уровень). Сеансовый уровень синхронизирует диалог между об'ектами представительного уровня и управляет обменом информации между ними. В дополнение к основной регуляции диалогов (сеансов) сеансовый уровень предоставляет средства для отправки информации, класса услуг и уведомления в исключительных ситуациях о проблемах сеансового, представительного и прикладного уровней.
Транспортный уровень
Граница между сеансовым и транспортным уровнями может быть представлена как граница между протоколами прикладного уровня и протоколами низших уровней. В то время как прикладной, представительный и сеансовый уровни заняты прикладными вопросами, четыре низших уровня решают проблемы транспортировки данных.

Транспортный уровень пытается обеспечить услуги по транспортировке данных, которые избавляют высшие слои от необходимости вникать в ее детали. В частности, заботой транспортного уровня является решение таких вопросов, как выполнение надежной транспортировки данных через об'единенную сеть. Предоставляя надежные услуги, транспортный уровень обеспечивает механизмы для установки, поддержания и упорядоченного завершения действия виртуальных каналов, систем обнаружения и устранения неисправностей транспортировки и управления информационным потоком (с целью предотвращения переполнения системы данными из другой системы).

Сетевой уровень
Сетевой уровень - это комплексный уровень, который обеспечивает возможность соединения и выбор маршрута между двумя конечными системами, подключенными к разным "подсетям", которые могут находиться в разных географических пунктах. В данном случае "подсеть" - это по сути независимый сетевой кабель (иногда называемый сегментом).

Т.к. две конечные системы, желающие организовать связь, может разделять значительное географическое расстояние и множество подсетей, сетевой уровень является доменом маршрутизации. Протоколы маршрутизации выбирают оптимальные маршруты через последовательность соединенных между собой подсетей. Традиционные протоколы сетевого уровня передают информацию вдоль этих маршрутов.

Канальный уровень
Канальный уровень (формально называемый информационно-канальным уровнем) обеспечивает надежный транзит данных через физический канал. Выполняя эту задачу, канальный уровень решает вопросы физической адресации (в противоположность сетевой или логической адресации), топологии сети, линейной дисциплины (каким образом конечной системе использовать сетевой канал), уведомления о неисправностях, упорядоченной доставки блоков данных и управления потоком информации.
Физический уровень
Физический уровень определяет электротехнические, механические, процедурные и функциональные характеристики активации, поддержания и дезактивации физического канала между конечными системами. Спецификации физического уровня определяют такие характеристики, как уровни напряжений, синхронизацию изменения напряжений, скорость передачи физической информации, максимальные расстояния передачи информации, физические соединители и другие аналогичные характеристики.

Важнейшие термины и концепции.

Наука об об'единении сетей, как и другие науки, имеет свою собственную терминологию и научную базу. К сожалению, ввиду того, что наука об об'единении сетей очень молода, пока что не достигнуто единое соглашение о значении концепций и терминов об'единенных сетей. По мере дальнейшего совершенствования индустрии об'единенных сетей определение и использование терминов будут более четкими.

Адресация

Существенным компонентом любой системы сети является оперделение местонахождения компьютерных систем. Существуют различные схемы адресации, используемые для этой цели, которые зависят от используемого семейства протоколов. Другими словами, адресация AppleTalk отличается от адресации TCP/IP, которая в свою очередь отличается от адресации OSI, и т.д.

Двумя важными типами адресов являются адреса канального уровня и адреса сетевого уровня. Адреса канального уровня (называемые также физическими или аппаратными адресами), как правило, уникальны для каждого сетевого соединения. У большинства локальных сетей (LAN) адреса канального уровня размещены в схеме интерфейса; они назначаются той организацией, которая определяет стандарт протокола, представленный этим интерфейсом. Т.к. большинство компьютерных систем имеют одно физическое сетевое соединение, они имеют только один адрес канального уровня. Роутеры и другие системы, соединенные с множеством физических сетей, могут иметь множество адресов канального уровня. В соответствии с названием, адреса канального уровня существуют на Уровне 2 эталонной модели ISO.

Aдреса сетевого уровня (называемые также виртуальными или логическими адресами) существуют на Уровне 3 эталонной модели OSI. В отличие от адресов канального уровня, которые обычно существуют в пределах плоского адресного пространства, адреса сетевого уровня обычно иерархические. Другими словми, они похожи на почтовые адреса, которые описывают местонахождение человека, указывая страну, штат, почтовый индекс, город, улицу, адрес на этой улице и наконец, имя. Хорошим примером одноуровневой адресации является номерная система социальной безопасности США, в соответствии с которой каждый человек имеет один уникальный номер, присвоенный ему службой безопасности.

Иерархические адреса делают сортировку адресов и повторный вызов более легкими путем исключения крупных блоков логически схожих адресов в процессе последовательности операций сравнения. Например, можно исключить все другие страны, если в адресе указана страна "Ирландия". Легкость сортировки и повторного вызова являются причиной того, что роутеры используют адреса сетевого уровня в качестве базиса маршрутизации.

Адреса сетевого уровня различаются в зависимости от используемого семейства протоколов, однако они, как правило, используют соответствующие логические разделы для нахождения компьютерных систем в об'единенной сети. Некоторые из этих логических разделов базируются на физических характеристиках сети (таких, как сегмент сети, в котором находится какая-нибудь система); другие логические разделы базируются на группировках, не имеющих физического базиса (например, "зона" AppleTalk).

Блоки данных, пакеты и сообщения

После того, как по адресам установили местоположение компьютерных систем, может быть произведен обмен информацией между двумя или более системами. В литературе по об'единенным сетям наблюдается непоследовательность в наименовании логически сгруппированных блоков информации, которая перемещается между компьютерными системами. "блок данных", "пакет", "блок данных протокола", "PDU", "сегмент", "сообщение" - используются все эти и другие термины, в зависимости от прихоти тех, кто пишет спецификации протоколов.

В настоящей работе термин "блок данных" (frame) обозначает блок информации, источником и пунктом назначения которого являются об'екты канального уровня. Термин "пакет" (packet) обозначает блок информации, у которого источник и пункт назначения - об'екты сетевого уровня. И наконец, термин "сообщение" (message) oбoзначает информационный блок, у которого об'екты источника и места назначения находятся выше сетевого уровня. Термин "сообщение" используется также для обозначения отдельных информационных блоков низших уровней, которые имеют специальное, хорошо сформулированное назначение.

Основные организации, занимающиеся стандартизацией объединенных сетей

Без услуг нескольких основных организаций по стандартизации, в области об'единенных сетей было бы значительно больше хаоса, чем его имеется в настоящее время. Организации по стандартизации обеспечивают форум для дискуссий, помогают превратить результаты дискуссий в официальные спецификации, а также распространяют эти спецификации после завершения процесса стандартизации.

Большинство организаций по стандартизации выполняют специфичные процессы, чтобы превратить идеи в официальные стандарты. И хотя у различных организаций эти процессы немного отличаются, они схожи в том, что проходят через несколько раундов организации идей, обсуждения этих идей, разработки проектов стандартов, голосования по всем или некоторым аспектам этих стандартов и наконец, официального выпуска завершенных стандартов.


Глава 2. Основы маршрутизации.

  • Библиографическая справка
  • Компоненты маршрутизации
    • Определение маршрута
    • Коммутация
  • Алгоритмы маршрутизации
    • Цели разработки алгоритмов маршрутизации
    • Типы алгоритмов
    • Показатели алгоритмов (метрики)

Библиографическая справка.

В общедоступном значении слова маршрутизация означает передвижение информации от источника к пункту назначения через об'единенную сеть. При этом, как правило, на пути встречается по крайней мере один узел. Маршрутизация часто противопоставляется об'единению сетей с помощью моста, которое, в популярном понимании этого способа, выполняет точно такие же функции. Основное различие между ними заключается в том, что об'единение с помощью моста имеет место на Уровне 2 эталонной модели ISO, в то время как маршрутизация встречается на Уровне 3. Этой разницей об'ясняется то, что маршрутизация и об'единение по мостовой схеме используют различную информацию в процессе ее перемещения от источника к месту назначения. Результатом этого является то, что маршрутизация и об'единение с помощью моста выполняют свои задачи разными способами; фактически, имеется несколько различных видов маршрутизации и об'единения с помощью мостов. Дополнительная информация об об'единении сетей с помощью мостов приведена в Главе 3 "Основы Об'единения сетей с помощью мостов".

Тема маршрутизации освещалась в научной литературе о компьютерах более 2-х десятилетий, однако с коммерческой точки зрения маршрутизация приобрела популярность только в 1970 гг. В течение этого периода сети были довольно простыми, гомогенными окружениями. Крупномасштабное об'единение сетей стало популярно только в последнее время.

Компоненты маршрутизации

Маршрутизация включает в себя два основных компонента: определение оптимальных трактов маршрутизации и транспортировка информационых групп (обычно называемых пакетами) через об'единенную сеть. В настоящей работе последний из этих двух компонентов называется коммутацией. Коммутация относительно проста. С другой стороны, определение маршрута может быть очень сложным процессом.

Определение маршрута

Определение маршрута может базироваться на различных показателях (величинах, результирующих из алгоритмических вычислений по отдельной переменной - например, длина маршрута) или комбинациях показателей. Программные реализации алгоритмов маршрутизации высчитывают показатели маршрута для определения оптимальных маршрутов к пункту назначения.

Для облегчения процесса определения маршрута, алгоритмы маршрутизации инициализируют и поддерживают таблицы маршрутизации, в которых содержится маршрутная информация. Маршрутная информация изменяется в зависимости от используемого алгоритма маршрутизации.

Алгоритмы маршрутизации заполняют маршрутные таблицы неким множеством информации. Ассоциации "Пункт назначения/следующая пересылка" сообщают роутеру, что определенный пункт назначения может быть оптимально достигнут путем отправки пакета в определенный роутер, представляющий "следующую пересылку" на пути к конечному пункту назначения. При приеме поступающего пакета роутер проверяет адрес пункта назначения и пытается ассоциировать этот адрес со следующей пересылкой. На рис. 2-1 приведен пример маршрутной таблицы "место назначения/следующая пересылка".

To reach network: | Send to:
27 | Node A
57 | Node B
17 | Node C
24 | Node A
52 | Node A
16 | Node B
26 | Node A
. . . | . . .

Figure 2-1 Destination/Next Hop Routing Table

В маршрутных таблицах может содержаться также и другая информация. "Показатели" обеспечивают информацию о желательности какого-либо канала или тракта. Роутеры сравнивают показатели, чтобы определить оптамальные маршруты. Показатели отличаются друг oт друга в зависимости от использованной схемы алгоритма маршрутизации. Далее в этой главе будет представлен и описан ряд общих показателей.

Роутеры сообщаются друг с другом (и поддерживают свои маршрутные таблицы) путем передачи различных сообщений. Одним из видов таких сообщений является сообщение об "обновлении маршрутизации". Обновления маршрутизации обычно включают всю маршрутную таблицу или ее часть. Анализируя информацию об обновлении маршрутизации, поступающую ото всех роутеров, любой из них может построить детальную картину топологии сети. Другим примером сообщений, которыми обмениваются роутеры, является "об'явление о состоянии канала". Об'явление о состоянии канала информирует другие роутеры о состоянии кааналов отправителя. Канальная информация также может быть использована для построения полной картины топологии сети. После того, как топология сети становится понятной, роутеры могут определить оптимальные маршруты к пунктам назначения.

Коммутация

Алгоритмы коммутации сравнительно просты и в основном одинаковы для большинства протоколов маршрутизации. В большинстве случаев главная вычислительная машина определяет необходимость отправки пакета в другую главную вычислительную машину. Получив определенным способом адрес роутера, главная вычислительная машина-источник отправляет пакет, адресованный специально в физический адрес роутера (уровень МАС), однако с адресом протокола (сетевой уровень) главной вычислительной машины пункта назначения.

После проверки адреса протокола пункта назначения пакета роутер определяет, знает он или нет, как передать этот пакет к следующему роутеру. Во втором случае (когда роутер не знает, как переслать пакет) пакет, как правило, игнорируется. В первом случае роутер отсылает пакет к следующей роутеру путем замены физического адреса пункта назначения на физический адрес следующего роутера и последующей передачи пакета.

Следующая пересылка может быть или не быть главной вычислительной машиной окончательного пункта назначения. Если нет,то следующей пересылкой, как правило, является другой роутер, который выполняет такой же процесс принятия решения о коммутации. По мере того, как пакет продвигается через об'единенную сеть, его физический адрес меняется, однако адрес протокола остается неизменным. Этот процесс иллюстрируется на Рис. 2-2.

В изложенном выше описании рассмотрена коммутация между источником и системой конечного пункта назначения. Международная Организация по Стандартизации (ISO) разработала иерархическую терминологию, которая может быть полезной при описании этого процесса. Если пользоваться этой терминологией, то устройства сети, не обладающие способностью пересылать пакеты между подсетями, называются конечными системами (ЕS), в то время как устройства сети, имеющие такую способность, называются промежуточными системами (IS). Промежуточные системы далее подразделяются на системы, которые могут сообщаться в пределах "доменов мааршрутизации" ("внутридоменные" IS), и системы, которые могут сообщаться как в пределах домена маршрутизации, так и с другими доменами маршрутизации ("междоменные IS"). Обычно считается, что "домен маршрутизации" - это часть об'единенной сети, находящейся под общим административным управлением и регулируемой пределенным набором административных руководящих принципов. Домены маршрутизации называются также "автономными системами" (AS). Для опрелеленных протоколов домены маршрутизации могут быть дополнительно подразделены на "участки маршрутизации", однако для коммутации как внутри участков, так и между ними также используются внутридоменные протоколы маршрутизации.

Алгоритмы маршрутизации

Алгоритмы маршрутизации можно дифференцировать, основываясь на нескольких ключевых характеристиках. Во-первых, на работу результирующего протокола маршрутизации влияют конкретные задачи, которые решает разработчик алгоритма. Во-вторых, существуют различные типы алгоритмов маршрутизации, и каждый из них по-разному влияет на сеть и ресурсы маршрутизации. И наконец, алгоритмы маршрутизации используют разнообразные показатели, которые влияют на расчет оптимальных маршрутов. В следующих разделах анализируются эти атрибуты алгоритмов маршрутизации.

Цели разработки алгоритмов маршрутизации

При разработке алгоритмов маршрутизации часто преследуют одну или несколько из перечисленных ниже целей:

  1. Оптимальность
  2. Простота и низкие непроизводительные затраты
  3. Живучесть и стабильность
  4. Быстрая сходимость
  5. Гибкость

Оптимальность

Оптимальность, вероятно, является самой общей целью разработки. Она характеризует способность алгоритма маршрутизации выбирать "наилучший" маршрут. Наилучший маршрут зависит от показателей и от "веса" этих показателей, используемых при проведении расчета. Например, алгоритм маршрутизации мог бы использовать несколько пересылок с определенной задержкой, но при расчете "вес" задержки может быть им оценен как очень значительный. Естественно, что протоколы маршрутизации дожны строгo определять свои алгоритмы расчета показателей.

Простота и низкие непроизводительные затраты

Алгоритмы маршрутизации разрабатываются как можно более простыми. Другими словами, алгоритм маршрутизации должен эффективно обеспечивать свои функциональные возможности, с мимимальными затратами программного обеспечения и коэффициентом использования. Особенно важна эффективность в том случае, когда программа, реализующая алгоритм маршрутизации, должна работать в компьютере с ограниченными физическими ресурсами.

Живучесть и стабильность

Алгоритмы маршрутизации должны обладать живучестью. Другими словми, они должны четко функционировать в случае неординарных или непредвиденных обстоятельств, таких как отказы аппаратуры, условия высокой нагрузки и некорректные реализации. Т.к. роутеры расположены в узловых точках сети, их отказ может вызвать значительные проблемы.
Часто наилучшими алгоритмами маршрутизации оказываются те, которые выдержали испытание временем и доказали свою надежность в различных условиях работы сети.

Быстрая сходимость

Алгоритмы маршрутизации должны быстро сходиться. Сходимость - это процесс соглашения между всеми роутерами по оптимальным маршрутам. Когда какое-нибудь событие в сети приводит к тому, что маршруты или отвергаются, или ставновятся доступными, роутеры рассылают сообщения об обновлении маршрутизации. Сообщения об обновлении маршрутизации пронизывают сети, стимулируя пересчет оптимальных маршрутов и, в конечном итоге, вынуждая все роутеры придти к соглашению по этим маршрутам. Алгоритмы мааршрутизации, которые сходятся медленно, могут привести к образованию петель маршрутизации или выходам из строя сети.

На Рис. 2-3 изображена петля маршрутизации. В данном случае, в момент времени t1 к роутеру 1 прибывает пакет. Роутер 1 уже был обновлен и поэтому он знает, что оптимальный маршрут к пункту назначения требует, чтобы следующей остановкой был роутер 2. Поэтому роутер 1 пересылает пакет в роутер 2. Роутер 2 еще не был обновлен, поэтому он полагает, что следующей оптимальной пересылкой должен быть роутер 1.
Поэтому роутер 2 пересылает пакет обратно в роутер 1. Пакет будет продолжать скакать взад и вперед между двумя роутерами до тех пор, пока роутер 2 не получит корректировку маршрутизации, или пока число коммутаций данного пакета не превысит допустимого максимального числа.

Гибкость

Алгоритмы маршрутизации должны быть также гибкими. Другими словами, алгоритмы маршрутизации должны быстро и точно адаптироваться к разнообразным обстоятельствам в сети. Например, предположим, что сегмент сети отвергнут. Многие алгоритмы маршрутизации, после того как они узнают об этой проблеме, быстро выбирают следующий наилучший путь для всех маршрутов, которые обычно используют этот сегмент. Алгоритмы маршрутизации могут быть запрограммированы таким образом, чтобы они могли адаптироваться к изменениям полосы пропускания сети, размеров очереди к роутеру, величины задержки сети и других переменных.

Типы алгоритмов

Алгоритмы маршрутизации могут быть классифицированы по типам. Например, алгоритмы могут быть:

  1. Статическими или динамическими
  2. Одномаршрутными или многомаршрутными
  3. Одноуровневыми или иерархическими
  4. С интеллектом в главной вычислительной машине или в роутере
  5. Внутридоменными и междоменными
  6. Алгоритмами состояния канала или вектора расстояний

Статические или динамические алгоритмы

Статические алгоритмы маршрутизации вообще вряд ли являются алгоритмами. Распределение статических таблиц маршрутизации устанавливется администратором сети до начала маршрутизации. Оно не меняется, если только администратор сети не изменит его. Алгоритмы, использующие статические маршруты, просты для разработки и хорошо работают в окружениях, где трафик сети относительно предсказуем, а схема сети относительно проста.

Т.к. статические системы маршрутизации не могут реагировать на изменения в сети, они, как правило, считаются непригодными для современных крупных, постоянно изменяющихся сетей. Большинство доминирующих алгоритмов маршрутизации 1990гг. - динамические.

Динамические алгоритмы маршрутизации подстраиваются к изменяющимся обстоятельствам сети в масштабе реального времени. Они выполняют это путем анализа поступающих сообщений об обновлении маршрутизации. Если в сообщении указывается, что имело место изменение сети, программы маршрутизации пересчитывают маршруты и рассылают новые сообщения о корректировке маршрутизации. Такие сообщения пронизывают сеть, стимулируя роутеры заново прогонять свои алгоритмы и соответствующим образом изменять таблицы маршрутизации. Динамические алгоритмы маршрутизации могут дополнять статические маршруты там, где это уместно. Например, можно разработать "роутер последнего обращения" (т.е. роутер, в который отсылаются все неотправленные по определенному маршруту пакеты). Такой роутер выполняет роль хранилища неотправленных пакетов, гарантируя, что все сообщения будут хотя бы определенным образом обработаны.

Одномаршрутные или многомаршрутные алгоритмы

Некоторые сложные протоколы маршрутизации обеспечивают множество маршрутов к одному и тому же пункту назначения. Такие многомаршрутные алгоритмы делают возможной мультиплексную передачу трафика по многочисленным линиям; одномаршрутные алгоритмы не могут делать этого. Преимущества многомаршрутных алгоритмов очевидны - они могут обеспечить заначительно большую пропускную способность и надежность.

Одноуровневые или иерархические алгоритмы

Некоторые алгоритмы маршрутизации оперируют в плоском пространстве, в то время как другие используют иерархиии маршрутизации. В одноуровневой системе маршрутизации все роутеры равны по отношению друг к другу. В иерархической системе маршрутизации некоторые роутеры формируют то, что составляет основу (backbone - базу) маршрутизации. Пакеты из небазовых роутеров перемещаются к базовыи роутерам и пропускаются через них до тех пор, пока не достигнут общей области пункта назначения. Начиная с этого момента, они перемещаются от последнего базового роутера через один или несколько небазовых роутеров до конечного пункта назначения.

Системы маршрутизации часто устанавливают логические группы узлов, называемых доменами, или автономными системами (AS), или областями. В иерархических системах одни роутеры какого-либо домена могут сообщаться с роутерами других доменов, в то время как другие роутеры этого домена могут поддерживать связь с роутеры только в пределах своего домена. В очень крупных сетях могут существовать дополнительные иерархические уровни. Роутеры наивысшего иерархического уровня образуют базу маршрутизации.

Основным преимуществом иерархической маршрутизации является то, что она имитирует организацию большинства компаний и следовательно, очень хорошо поддерживает их схемы трафика. Большая часть сетевой связи имеет место в пределах групп небольших компаний (доменов). Внутридоменным роутерам необходимо знать только о других роутерах в пределах своего домена, поэтому их алгоритмы маршрутизации могут быть упрощенными. Соответственно может быть уменьшен и трафик обновления маршрутизации, зависящий от используемого алгоритма маршрутизации.

Алгоритмы с игнтеллектом в главной вычислительной машине или в роутере

Некоторые алгоритмы маршрутизации предполагают, что конечный узел источника определяет весь маршрут. Обычно это называют маршрутизацией от источника. В системах маршрутизации от источника роутеры действуют просто как устойства хранения и пересылки пакета, без всякий раздумий отсылая его к следующей остановке.

Другие алгоритмы предполагают, что главные вычислительные машины ничего не знают о маршрутах. При использовании этих алгоритмов роутеры определяют маршрут через об'единенную сеть, базируясь на своих собственных расчетах. В первой системе, рассмотренной выше, интеллект маршрутизации находится в главной вычислительной машине. В системе, рассмотренной во втором случае, интеллектом маршрутизации наделены роутеры.

Компромисс между маршрутизацией с интеллектом в главной вычислительной машине и маршрутизацией с интеллектом в роутере достигается путем сопоставления оптимальности маршрута с непроизводительными затратами трафика. Системы с интеллектом в главной вычислительной машине чаще выбирают наилучшие маршруты, т.к. они, как правило, находят все возможные маршруты к пункту назначения, прежде чем пакет будет действительно отослан. Затем они выбирают наилучший мааршрут, основываясь на определении оптимальности данной конкретной системы. Однако акт определения всех маршрутов часто требует значительного трафика поиска и большого об'ема времени.

Внутридоменные или междоменные алгоритмы

Некоторые алгоритмы маршрутизации действуют только в пределах доменов; другие - как в пределах доменов, так и между ними. Природа этих двух типов алгоритмов различная. Поэтому понятно, что оптимальный алгоритм внутридоменной маршрутизации не обязательно будет оптимальным алгоритмом междоменной маршрутизации.

Алгоритмы состояния канала или вектора расстояния

Алгоритмы состояния канала (известные также как алгоритмы "первоочередности наикратчайшего маршрута") направляют потоки маршрутной информации во все узлы об'единенной сети. Однако каждый роутер посылает только ту часть маршрутной таблицы, которая описывает состояние его собственных каналов. Алгоритмы вектора расстояния ( известные также как алгоритмы Бэлмана-Форда) требуют от каждогo роутера посылки всей или части своей маршрутной таблицы, но только своим соседям. Алгоритмы состояния каналов фактически направляют небольшие корректировки по всем направлениям, в то время как алгоритмы вектора расстояний отсылают более крупные корректировки только в соседние роутеры.

Отличаясь более быстрой сходимостью, алгоритмы состояния каналов несколько меньше склонны к образованию петель маршрутизации, чем алгоритмы вектора расстояния. С другой стороны, алгоритмы состояния канала характеризуются более сложными расчетами в сравнении с алгоритмами вектора расстояний, требуя большей процессорной мощности и памяти, чем алгоритмы вектора расстояний. Вследствие этого, реализация и поддержка алгоритмов состояния канала может быть более дорогостоящей. Несмотря на их различия, оба типа алгоритмов хорошо функционируют при самых различных обстоятельствах.

Показатели алгоритмов (метрики)

Маршрутные таблицы содержат информацию, которую используют программы коммутации для выбора наилучшего маршрута. Чем характеризуется построение маршрутных таблиц? Какова особенность природы информации, которую они содержат? В данном разделе, посвященном показателям алгоритмов, сделана попытка ответить на вопрос о том, каким образом алгоритм определяет предпочтительность одного маршрута по сравнению с другими.

В алгоритмах маршрутизации используется много различных показателей. Сложные алгоритмы маршрутизации при выборе маршрута могут базироваться на множестве показателей, комбинируя их таким образом, что в результате получается один отдельный (гибридный) показатель. Ниже перечислены показатели, которые используются в алгоритмах маршрутизации:

  1. Длина маршрута
  2. Надежность
  3. Задержка
  4. Ширина полосы пропускания
  5. Нагрузка
  6. Стоимость связи

Длина маршрута

Длина маршрута является наиболее общим показателем маршрутизации. Некоторые протоколы маршрутизации позволяют администраторам сети назначать произвольные цены на каждый канал сети. В этом случае длиной тракта является сумма расходов, связанных с каждым каналом, который был траверсирован. Другие протоколы маршрутизации определяют "количество пересылок", т.е. показатель, характеризующий число проходов, которые пакет должен совершить на пути от источника до пункта назначения через изделия об'единения сетей (такие как роутеры).

Надежность

Надежность, в контексте алгоритмов маршрутизации, относится к надежности каждого канала сети (обычно описываемой в терминах соотношения бит/ошибка). Некоторые каналы сети могут отказывать чаще, чем другие. Отказы одних каналов сети могут быть устранены легче или быстрее, чем отказы других каналов. При назначении оценок надежности могут быть приняты в расчет любые факторы надежности. Оценки надежности обычно назначаются каналам сети администраторами сети. Как правило, это произвольные цифровые величины.

Задержка

Под задержкой маршрутизации обычно понимают отрезок времени, необходимый для передвижения пакета от источника до пункта назначения через об'единенную сеть. Задержка зависит от многих факторов, включая полосу пропускания промежуточных каналов сети, очереди в порт каждого роутера на пути передвижения пакета, перегруженность сети на всех промежуточных каналах сети и физическое расстояние, на которое необходимо переместить пакет. Т.к. здесь имеет место конгломерация нескольких важных переменных, задержка является наиболее общим и полезным показателем.

Полоса пропускания

Полоса пропускания относится к имеющейся мощности трафика какого-либо канала. При прочих равных показателях, канал Ethernet 10 Mbps предпочтителен любой арендованной линии с полосой пропускания 64 Кбайт/сек. Хотя полоса пропускания является оценкой максимально достижимой пропускной способности канала, маршруты, проходящие через каналы с большей полосой пропускания, не обязательно будут лучше маршрутов, проходящих через менее быстродействующие каналы.


Глава 3. Основы объединения сетей с помощью мостов.

  • Сравнение устройств для объединения сетей
  • Основы технологии объединения сетей
  • Типы мостов

Биографическая справка

Серийное изготовление мостов началось в начале 1980гг. В то время, когда они появились, мосты о'единяли гомогенные сети, делая возможным прохождение пакетов между ними. В последнее время об'единение различных сетей с помощью мостов также было определено и стандартизировано.

На первый план выдвинулись несколько видов об'единений с помощью мостов. В окружениях Ethernet в основном встречается "transparent bridging" (прозрачное соединение). В окружениях Token Ring в первую очередь используется "Source-route bridging"(соединение маршрут- источник). "Translational bridging" (трансляционное соединение) обеспечивает трансляцию между форматами и принципами передачи различных типов сред (обычно Ethernet и Token Ring). "Source-route transparent bridging" (прозрачное соединение маршрут-источник) об'единяет алгоритмы прозрачного соединения и соединения маршрут- источник, что позволяет передавать сообщения в смешанных окружениях Ethernet/Token Ring.

Уменьшающиеся цены на роутеры и введение во многие из них возможности соединять по мостовой схеме, сделанное в последнее время, значительно сократило долю рынка чистых мостов. Те мосты, которые уцелели, обладают такими характеристиками, как сложные схемы фильтрации, псевдоинтеллектуальный выбор маршрута и высокая производительность. В то время как в конце 1980гг шли бурные дебаты о преимуществах соединения с помощью мостов в сравнении с роутерами, в настоящее время большинство пришло к выводу, что часто оба устройства необходимы в любой полной схеме об'единения сетей.

Сравнение устройств для объединения сетей

Устройства об'единения сетей обеспечивают связь между сегментами локальных сетей (LAN). Существуют 4 основных типа устройств об'единения сетей: повторители, мосты, роутеры и межсетевые интерфейсы. Эти устройства в самом общем виде могут быть дифференцированы тем уровнем "Межсоединений Открытых Систем" (OSI), на котором они устанавливают соединение между LAN. Повторители соединяют LAN на Уровне 1 OSI; мосты соединяют LAN на Уровне 2; роутеры соединяют LAN на Уровне 3; межсетевые интерфейсы соединяют LAN на Уровнях 4-7. Каждое устройство обеспечивает функциональные возможности, соответствующие своему уровню, а также использует функциональные возможности всех более низких уровней. Эта положение иллюстрируется графически на Рис. 3-1.

Основы технологии объединения сетей

Уровень, на котором находит применение об'единение с помощью мостов (называемый канальным уровнем), контролирует поток информации, обрабатывает ошибки передачи, обеспечивает физическую (в отличие от логической) адресацию и управляет доступом к физической среде. Мосты обеспечивают выполнение этих функций путем поддержки различных протоколов канального уровня, которые предписывают определенный поток информации, обработку ошибок, адресацию и алгоритмы доступа к носителю. В качестве примеров популярных протоколов канального уровня можно назвать Ethernet, Token Ring и FDDI.

Мосты - несложные устройства. Они анализируют поступающие фреймы, принимают решение о их продвижении, базируясь на информации, содержащейся в фрейме, и пересылает их к месту назначения. В некоторых случаях (например, при об'единении "источник-маршрут") весь путь к месту назначения содержится в каждом фрейме. В других случаях (например, прозрачное об'единение) фреймы продвигаются к месту назначения отдельными пересылками, по одной за раз. Дополнительная информация по соединению источник-маршрут и прозрачному соединению приведена соответственно в главе 30 "Соединение по мостовой схeмe Источник-Маршрут" и главе 29 "Прозрачное об'единение с помощью мостов".

Основным преимуществом об'единения с помощью мостов является прозрачность протоколов верхних уровней. Т.к. мосты оперируют на канальном уровне, от них не требуется проверки информации высших уровней. Это означает, что они могут быстро продвигать трафик, представляющий любой протокол сетевого уровня. Обычным делом для моста является продвижение Apple Talk, DECnet, TCP/IP, XNS и другого трафика между двумя и более сетями.

Мосты способны фильтровать фреймы, базирующиеся на любых полях Уровня 2. Например, мост можно запрограммировать так, чтобы он отвергал (т.е. не пропускал) все фреймы, посылаемые из определенной сети. Т.к. в информацию канального уровня часто включается ссылка на протокол высшего уровня, мосты обычно фильтруют по этому параметру. Кроме того, мосты могут быть полезны, когда они имеют дело с необязательной информацией пакетов широкой рассылки.

Разделяя крупные сети на автономные блоки, мосты обеспечивают ряд преимуществ. Во-первых, поскольку пересылается лишь некоторый процент трафика, мосты уменьшают трафик, проходящий через устройства всех соединенных сегментов. Во-вторых, мосты действуют как непреодолимая преграда для некоторых потенциально опасных для сети неисправностей. В-третьих, мосты позволяют осуществлять связь между большим числом устройств, чем ее можно было бы обеспечить на любой LAN, подсоединенной к мосту, если бы она была независима. В-четвертых, мосты увеличивают эффективную длину LAN, позволяя подключать еще не подсоединенные отдаленные станции.

Типы мостов

Мосты можно сгруппировать в категории, базирующиеся на различных характеристиках изделий. В соответствии с одной из популярных схем классификации мосты бывают локальные и дистанционные. Локальные мосты обеспечивают прямое соединение множества сегментов LAN, находящихся на одной территории. Дистанционные мосты соединяют множество сегментов LAN на различных территориях, обычно через телекоммуникационные линии. Эти две конфигурации представлены на Рис. 3-2.

Дистанционное мостовое соединение представляет ряд уникальных трудностей об'единения сетей. Одна из них - разница между скоростями LAN и WAN (глобальная сеть). Хотя в последнее время в географически рассредоточенных об'единенных сетях появилось несколько технологий быстродействующих WAN, скорости LAN часто на порядок выше скоростей WAN. Большая разница скоростей LAN и WAN иногда не позволяет пользователям прогoнять через WAN применения LAN, чуствительные к задержкам.

Дистанционные мосты не могут увеличить скорость WAN, однако они могут компенсировать несоответствия в скоростях путем использования достаточных буферных мощностей. Если какое-либо устройство LAN, способной передавать со скоростью 3 Mb/сек, намерено связаться с одним из устройств отдаленной LAN, то локальный мост должен регулировать поток информации, передаваемой со скоростью 3Mb/сек, чтобы не переполнить последовательный канал, который пропускает 64 Kb/сек. Это достигается путем накопления поступающей информации в расположенных на плате буферах и посылки ее через последовательный канал со скоростью, которую он может обеспечить. Это осуществимо только для коротких пакетов информации, которые не переполняют буферные мощности моста.

IEEE (Институт инженеров по электротехнике и радиоэлектронике) поделил канальный уровень OSI на два отдельных подуровня: подуровень MAC (Управление доступом к носителю) и подуровень LLC (Управление логическим каналом). МАС разрешает и оркестрирует доступ к носителю (Например, конфликтные ситуации, эстафетная передача и др.), в то время как подуровень LLC занят кадрированием, управлением потоком информации, управлением неисправностями и адресацией подуровня МАС.

Некоторые мосты являются мостами подуровня МАС. Эти устройства образуют мост между гомогенными сетями (например, IEEE 802.3 и IEEE 802.3). Другие мосты могут осуществлять трансляцию между различными протоколами канального уровня (например, IEEE 802.3 и IEEE 802.5). Базовый механизм такой трансляции показан на Рис. 3-3.

На Рис. 3-3 главная вычислительная машина IEEE 802.3 (Главная вычислительная машина А) формулирует пакет, содержащий прикладную информацию, и герметизирует этот пакет в совместимый с IEEE 802.3 фрейм для передачи через среду IEEE 802.3 в мост. Внутри моста фрейм освобождается от заголовка IEEE 802.3 в подуровне МАС канального уровня и затем передается выше в подуровень LLC для дальнейшей обработки. После обработки пакет снова передается вниз в реализацию IEEE 802.5, которая герметизирует пакет в заголовок IEEE 802.5 для передачи через сеть IEEE 802.5 в главную вычислительную машину IEEE 802.5 (Главная вычислительная машина В).

Трансляция, осуществляемая мостом между различными типами сетей, никогда не бывает безупречной, т.к. всегда имеется вероятность, что одна сеть поддержит определенный фрейм, который не поддерживается другой сетью. Эту ситуацию можно считать примерно аналогичной проблеме, с которой сталкивается эскимос, пытающийся перевести на английский некоторые слова из тех 50 слов, которые обозначают "снег". Более подробно многие из вопросов трансляции через мосты обсуждаются в Главе 31 "Об'единение различных сред с помощью мостов".


Глава 4. Основы управления сетями.

  • Архитектура управления сети
  • Модель управления сети ISO
    • Управление эффективностью
    • Управление конфигурацией
    • Управление учетом использования ресурсов
    • Управление неисправностями
    • Управление защитой данных

Библиографическая справка

Начало 1980гг. ознаменовалось резким ростом в области применения сетей. Как только компании поняли, что сетевая технология обеспечивает им сокращение расходов и повышение производительности, они начали устанавливать новые и расширять уже существующие сети почти с такой же скоростью, с какой появлялись новые технологии сетей и изделия для них. К середине 1980гг. стали очевидными проблемы, число которых все более увеличивалось, связанные с этим ростом, особенно у тех компаний, которые применили много разных (и несовместимых) технологий сети.

Основными проблемами, связанными с увеличением сетей, являются каждодневное управление работой сети и стратегическое планирование роста сети. Характерным является то, что каждая новая технология сети требует свою собственную группу экспертов для ее работы и поддержки. В начале 1980гг. стратегическое планирование роста этих сетей превратилось в какой-то кошмар. Одни только требования к числу персонала для управления крупными гетерогенными сетями привели многие организации на грань кризиса. Насущной необходимостью стало автоматизированное управление сетями (включая то, что обычно называется "планированием возможностей сети"), интегрированное по всем различным окружениям.

В настоящей главе описываются технические характеристики, общие для большинства архитектур и протоколов управления сетями. В ней также представлены 5 функциональных областей управления , определенных Международной Оврганизацией по Стандартизации (ISO).

Архитектура управления сети

Большинство архитектур управления сети используют одну и ту же базовую структуру и набор взаимоотношений. Конечные станции (managed devices - управляемые устройства), такие как компьютерные системы и другие сетевые устройства, прогoняют программные средства, позволяющие им посылать сигналы тревоги, когда они распознают проблемы. Проблемы распознаются, когда превышен один или более порогов, заданных пользователем. Management entities (управляющие об'екты) запрограммированы таким образом, что после получения этих сигналов тревоги они реагируют выполнением одного, нескольких или группы действий, включающих:

  1. Уведомление оператора
  2. Регистрацию события
  3. Отключение системы
  4. Автоматические попытки исправления системы

Управляющие об'екты могут также опросить конечные станции, чтобы проверить некоторые переменные. Опрос может быть автоматическим или его может инициировать пользователь. На эти запросы в управляемых устройствах отвечают "агенты". Агенты - это программные модули, которые накапливают информацию об управляемом устройстве, в котором они расположены, хранят эту информацию в "базе данных управления" и предоставляют ее (проактивно или реактивно) в управляющие об'екты, находящиеся в пределах "систем управления сети" (NMSs), через протокол управления сети. В число известных протоколов управления сети входят "the Simple Network Management Protocol (SPMP)" (Протокол Управления Простой Сети) и "Common Management Information Protocol (CMIP)" (Протокол Информации Общего Управления). "Management proxies" (Уполномоченные управления) - это об'екты, которые обеспечивают информацию управления от имени других об'ектов. Типичная архитектура управления сети показана на рис. 4-1.

Модель управления сети ISO

ISO внесла большой вклад в стандартизацию сетей. Модель управления сети этой организации является основным средством для понимания главных функций систем управления сети. Эта модель состоит из 5 концептуальных областей:

  1. Управление эффективностью
  2. Управление конфигурацией
  3. Управление учетом использования ресурсов
  4. Управление неисправностями
  5. Управление защитой данных

Управление эффективностью

Цель управления эффективностью - измерение и обеспечение различных аспектов эффективности сети для того, чтобы межсетевая эффективность могла поддерживаться на приемлемом уровне. Примерами переменных эффективности, которые могли бы быть обеспечены, являются пропускная способность сети, время реакции пользователей и коэффициент использования линии.

Управление эффективностью включает несколько этапов:

  1. Сбор информации об эффективности по тем переменным, которые предствляют интерес для администраторов сети.
  2. Анализ информации для определения нормальных (базовая строка) уровней.
  3. Определение соответствующих порогoв эффективности для каждой важной переменной таким образом, что превышение этих порогов указывает на наличие проблемы в сети, достойной внимания.

Управляемые об'екты постоянно контролируют переменные эффективности. При превышении порога эффективности вырабатывается и посылается в NMS сигнал тревоги.

Каждый из описанных выше этапов является частью процесса установки реактивной системы. Если эффективность становится неприемлемой вследствие превышения установленного пользователем порога, система реагирует посылкой сообщения. Управление эффективностью позволяет также использовать проактивные методы. Например, при проектировании воздействия роста сети на показатели ее эффективности может быть использован имитатор сети. Такие имитаторы могут эффективно предупреждать администраторов о надвигающихся проблемах для того, чтобы можно было принять контрактивные меры.

Управление конфигурацией

Цель управления конфигурацией - контролирование информации о сете- вой и системной конфигурации для того, чтобы можно было отслеживать и управлять воздействием на работу сети различных версий аппаратных и программных элементов. Т.к. все аппаратные и программные элементы имеют эксплуатационные отклонения, погрешности, или то и другое вместе, которые могут влиять на работу сети, такая информация важна для поддержания гладкой работы сети.

Каждое устройство сети располагает разнообразной информацией о версиях, ассоциируемых с ним. Например, АРМ проектировщика может иметь следующую конфигурацию:

  • Операционная система, Version 3.2
  • Интерфейс Ethernet, Version 5.4
  • Программное обеспечение TCP/IP, Version 2.0
  • Программное обеспечение NetWare, Version 4.1
  • Программное обеспечение NFS, Version 5.1
  • Контроллер последовательных сообщений, Version 1.1
  • Программное обеспечение Х.25, Version 1.0
  • Прoграммное обеспечение SNMP, Version 3.1

Чтобы обеспечить легкий доступ, подсистемы управления конфигурацией хранят эту информацию в базе данных. Когда возникает какая-нибудь проблема, в этой базе данных может быть проведен поиск ключей, которые могли бы помочь решить эту проблему.

Управление учетом использования ресурсов

Цель управления учетом использования ресурсов - измерение параметров использования сети, чтобы можно было соответствующим образом регулировать ее использование индивидуальными или групповыми пользователями. Такое регулирование минимизирует число проблем в сети (т.к. ресурсы сети могут быть поделены исходя из возможностей источника) и максимизировать равнодоступность к сети для всех пользователей.

Как и для случая управления эффективностью, первым шагом к соответствующему управлению учетом использования ресурсов является измерение коэффициента использования всех важных сетевых ресурсов. Анализ результатов дает возможность понять текущую картину использования. В этой точке могут быть установлены доли пользования. Для достижения оптимальной практики получения доступа может потребоваться определенная коррекция. Начиная с этого момента, последующие измерения использования ресурсов могут выдавать информацию о выставленных счетах, наряду с информацией, использованной для оценки наличия равнодоступности и оптимального каоэффициента использования источника.

Управление неисправностями

Цель управления неисправностями - выявить, зафиксировать, уведомить пользователей и (в пределах возможного) автоматически устранить проблемы в сети с тем, чтобы эффективно поддерживать работу сети. Т.к. неисправности могут привести к простоям или недопустимой деградации сети, управление несправностями, по всей вероятности, является наиболее широко используемым элементом модели управления сети ISO.

Управление неисправностями включает в себя несколько шагов:

  1. Определение симптомов проблемы.
  2. Изолирование проблемы.
  3. Устранение проблемы.
  4. Проверка устранения неисправности на всех важных подсистемах.
  5. Регистрация обнаружения проблемы и ее решения.

Управление защитой данных

Цель управления защитой данных - контроль доступа к сетевым ресурсам в соответствии с местными руководящими принципами, чтобы сделать невозможными саботаж сети и доступ к чувствительной информации лицам, не имеющим соответствующего разрешения. Например, одна из подсистем управления защитой данных может контролировать регистрацию пользователей ресурса сети, отказывая в доступе тем, кто вводит коды доступа, не соответствующие установленным.

Подсистемы управления защитой данных работают путем разделения источников на санкционированные и несанкционированные области. Для некоторых пользователей доступ к любому источнику сети является несоответствующим. Такими пользователями, как правило, являются не члены компании. Для других пользователей сети (внутренних) несоответствующим является доступ к информации, исходящей из какого- либо отдельного отдела. Например, доступ к файлам о людских ресурсах является несоответствующим для любых пользователей, не принадлежащих к отделу управления людскими ресурсами (исключением может быть администраторский персонал).

Подсистемы управления защитой данных выполняют следующие функции:

  • Идентифицируют чувствительные ресурсы сети (включая системы, файлы и другие об'екты)
  • Определяют отображения в виде карт между чувствительными источниками сети и набором пользователей
  • Контролируют точки доступа к чувствительным ресурсам сети
  • Регистрируют несоответствующий доступ к чувствительным ресурсам сети.


Глава 5. Ethernet/IEEE 802.3

  • Основы технологии
  • СравнениеEthernet и IEEE 802.3
  • Физические соединения
  • Форматы блоков

Основы технологии

Ethernet был разработан Исследовательским центром в Пало Альто (PARC) корпорации Xerox в 1970-м году. Ethernet стал основой для спецификации IEEE 802.3, которая появилась 1980-м году. После недолгих споров компании Digital Equipment Corporation, Intel Corporation и Xerox Corporation совместно разработали и приняли спецификацию (Version 2.0), которая была частично совместима с 802.3. На сегодняшний день Ethernet и IEEE 802.3 являются наиболее распространенными протоколами локальных вычислительных сетей (ЛВС). Сегодня термин Ethernet чаще всего используется для описания всех ЛВС работающих по принципу множественный доступ с обнаружением несущей (carrier sense multiple access/collision detection (CSMA/CD)), которые соотвествуют Ethernet, включая IEEE 802.3.

Когда Ethernet был разработан, он должен был заполнить нишу между глобальными сетями, низкоскоростными сетями и специализированными сетями компьтерных центров, которые работали на высокой скрости, но очень органиченном расстоянии. Ethernet хорошо подходит для приложений где локальные коммуникации должны выдерживать высокие нагрузки при высоких скоростях в пиках.

Сравнение Ethernet и IEEE 802.3

Ethernet and IEEE 802.3 specify similar technologies. Both are CSMA/CD LANs. Stations on a CSMA/CD LAN can access the network at any time. Before sending data, CSMA/CD stations "listen" to the network to see if it is already in use. If it is, the station wishing to transmit waits. If the network is not in use, the station transmits. A collision occurs when two stations listen for network traffic, "hear" none, and transmit simultaneously. In this case, both transmissions are damaged, and the stations must retransmit at some later time. Backoffalgorithms determine when the colliding stations retransmit. CSMA/CD stations can detect collisions, so they know when they must retransmit.

Both Ethernet and IEEE 802.3 LANs are broadcast networks. In other words, all stations see all frames, regardless of whether they represent an intended destination. Each station must examine received frames to determine if the station is a destination. If so, the frame is passed to a higher protocol layer for appropriate processing.

Differences between Ethernet and IEEE 802.3 LANs are subtle. Ethernet provides services corresponding to Layers 1 and 2 of the OSI reference model, while IEEE 802.3 specifies the physical layer (Layer 1) and the channel-access portion of the link layer (Layer 2), but does not define a logical link control protocol. Both Ethernet and IEEE 802.3 are implemented in hardware. Typically, the physical manifestation of these protocols is either an interface card in a host computer or circuitry on a primary circuit board within a host computer.

Физическое подключение

IEEE 802.3 specifies several different physical layers, whereas Ethernet defines only one. Each IEEE 802.3 physical layer protocol has a name that summarizes its characteristics. The coded components of an IEEE 802.3 physical-layer name are shown in Figure 5-1.

Figure 5-1 : IEEE 802.3 Physical-Layer Name Components

A summary of Ethernet Version 2 and IEEE 802.3 characteristics appears in Table 5-1.
Характеристики | Ethernet | IEEE 802.3
 |  | 10Base5 | 10Base2 | 1Base5 | 10BaseT | 10Broad36
Скорость, Mbps | 10 | 10 | 10 | 1 | 10 | 10
Метод передачи | Baseband | Baseband | Baseband | Baseband | Baseband | Broadband
Макс. длина сегмента, м | 500 | 500 | 185 | 250 | 100 | 1800
Среда передачи | 50-Ом коаксиал (толстый) | 50-Ом коаксиал (толстый) | 50-Ом коаксиал (тонкий) | неэкр. витая пара | неэкр. витая пара | 75-ohm coax
Топология | Шина | Шина | Шина | Звезда | Звезда | Шина

Table 5-1 Ethernet Version 2 and IEEE 802.3 Physical Characteristics

Ethernet is most similar to IEEE 802.3 10Base5. Both of these protocols specify a bus topology network with a connecting cable between the end stations and the actual network medium. In the case of Ethernet, that cable is called a transceiver cable. The transceiver cable connects to a transceiver device attached to the physical network medium. The IEEE 802.3 configuration is much the same, except that the connecting cable is referred to as an attachment unit interface (AUI), and the transceiver is called a medium attachment unit (MAU). In both cases, the connecting cable attaches to an interface board (or interface circuitry) within the end station.

Форматы блоков

Ethernet and IEEE 802.3 frame formats are shown in Figure 5-2.

Both Ethernet and IEEE 802.3 frames begin with an alternating pattern of ones and zeros called a preamble. The preamble tells receiving stations that a frame is coming.

The byte before the destination address in both an Ethernet and a IEEE 802.3 frame is a start-of-frame (SOF) delimiter. This byte ends with two consecutive one bits, which serve to synchronize the frame reception portions of all stations on the LAN.

Immediately following the preamble in both Ethernet and IEEE 802.3 LANs are the destination and source addressfields. Both Ethernet and IEEE 802.3 addresses are 6 bytes long. Addresses are contained in hardware on the Ethernet and IEEE 802.3 interface cards. The first 3 bytes of the addresses are specified by the IEEE on a vendor-dependent basis, while the last 3 bytes are specified by the Ethernet or IEEE 802.3 vendor. The source address is always a unicast (single node) address, while the destination address may be unicast, multicast (group), or broadcast (all nodes).

In Ethernet frames, the 2-byte field following the source address is a type field. This field specifies the upper-layer protocol to receive the data after Ethernet processing is complete.

In IEEE 802.3 frames, the 2-byte field following the source address is a length field, which indicates the number of bytes of data that follow this field and precede the frame check sequence (FCS) field.

Following the type/length field is the actual datacontained in the frame. After physical-layer and link-layer processing is complete, this data will eventually be sent to an upper-layer protocol. In the case of Ethernet, the upper-layer protocol is identified in the type field. In the case of IEEE 802.3, the upper-layer protocol must be defined within the data portion of the frame, if at all. If data in the frame is insufficient to fill the frame to its minimum 64-byte size, padding bytes are inserted to ensure at least a 64-byte frame.

After the data field is a 4-byte FCS field containing a cyclic redundancy check (CRC) value. The CRC is created by the sending device and recalculated by the receiving device to check for damage that might have occurred to the frame in transit.


Глава 6. Token Ring и IEEE 802.5.

  • Сравнение Token Ring и IEEE 802.5
  • Передача маркера
  • Физические соединения
  • Система приоритетов
  • Механизмы управления неисправостями
  • Формат блока данных

Библиографическая справка

Сеть Token Ring первоначально была разработана компанией IBM в 1970 гг. Она попрежнему является основной технологией IBM для локальных сетей (LAN) , уступая по популярности среди технологий LAN только Ethernet/IEEE 802.3. Спецификация IEEE 802.5 почти идентична и полностью совместима с сетью Token Ring IBM. Спецификация IEEE 802.5 была фактически создана по образцу Token Ring IBM, и она продолжает отслеживать ее разработку. Термин "Token Ring" oбычно применяется как при ссылке на сеть Token Ring IBM, так и на сеть IEEE 802.5.

Сравнение Token Ring и IEEE 802.5

Сети Token Ring и IEEE 802.5 в основном почти совместимы, хотя их спецификации имеют относительно небольшие различия. Сеть Token Ring IBM оговаривает звездообразное соединение, причем все конечные устройства подключаются к устройству, называемому "устройством доступа к многостанционной сети" (MSAU), в то время как IEEE 802.5 не оговаривает топологию сети (хотя виртуально все реализации IEEE 802.5 также базируются на звездообразной сети). Имеются и другие отличия, в том числе тип носителя (IEEE 802.5 не оговаривает тип носителя, в то время как сети Toke Ring IBM используют витую пару) и размер поля маршрутной информации (смотри далее в этой главе обсуждение характеристик полей маршрутной информации). На Рис. 6-1 представлены обобщенные характеристики сетей Token Ring и IЕЕЕ 802.5.

 | IBM Token Ring Network | IEEE 802.5
Data rates | 4.16 Mbps | 4.16 Mbps
Station/segment | 260 (S.T.P.) 72 (U.T.P.) | 250
Topology | Star | Not specified
Media | Twisted pair | Not specified
Signaling | Baseband | Baseband
Access method | Token passing | Token passing
Encoding | Differential Manchester | Differential Manchester

Figure 6-1 IBM Token Ring Network/IEEE 802.5 Comparison

Передача маркера

Token Ring и IEEE 802.5 являются главными примерами сетей с передачей маркера. Сети с передачей маркера перемещают вдоль сети небольшой блок данных, называемый маркером. Владение этим маркером гарантирует право передачи. Если узел, принимающий маркер, не имеет информации для отправки, он просто переправляет маркер к следующей конечной станции. Каждая станция может удерживать маркер в течение определенного максимального времени.

Если у станции, владеющей маркером, имеется информации для передачи, она захватывает маркер, изменяет у него один бит (в результате чего маркер превращается в последовательность "начало блока данных"), дополняет информацией, которую он хочет передать и, наконец, отсылает эту информацию к следующей станции кольцевой сети. Когда информационный блок циркулирует по кольцу, маркер в сети отсутствует (если только кольцо не обеспечивает "раннего освобождения маркера" - early token release), поэтому другие станции, желающие передать информацию, вынуждены ожидать. Следовательно, в сетях Token Ring не может быть коллизий. Если обеспечивается раннее высвобождение маркера, то новый маркер может быть выпущен после завершения передачи блока данных.

Информационный блок циркулирует по кольцу, пока не достигнет предполагаемой станции назначения, которая копирует информацию для дальнейшей обработки. Информационный блок продолжает циркулировать по кольцу; он окончательно удаляется после достижения станции, отославшей этот блок. Станция отправки может проверить вернувшийся блок, чтобы убедиться, что он был просмотрен и затем скопирован станцией назначения.

В отличие от сетей CSMA/CD (например, Ethernet) сети с передачей маркера являются детерминистическими сетями. Это означает, что можно вычислить максимальное время, которое пройдет,прежде чем любая конечная станция сможет передавать. Эта характеристика, а также некоторые характеристики надежности, которые будут рассмотрены дальше, делают сеть Token Ring идеальной для применений, где задержка должна быть предсказуема и важна устойчивость функционирования сети. Примерами таких применений является среда автоматизированных станций на заводах.

Физические соединения

Станции сети IBM Token Ring напрямую подключаются к MSAU, которые могут быть об'единены с помощью кабелей, образуя одну большую кольцевую сеть (смотри Рис. 6-2). Кабели- перемычки соединяют MSAU со смежными MSAU. Кабели-лепестки подключают MSAU к станциям. В составе МSAU имеются шунтирующие реле для исключения станций из кольца.

Система приоритетов

Сети Тоkеn Ring используют сложную систему приоритетов, которая позволяет некоторым станциям с высоким приоритетом, назначенным пользователем, более часто пользоваться сетью. Блоки данных Token Ring содержат два поля, которые управляют приоритетом: поле приоритетов и поле резервирования.

Только станции с приоритетом, который равен или выше величины приоритета, содержащейся в маркере, могут завладеть им. После того, как маркер захвачен и изменен( в результате чего он превратился в информационный блок), только станции, приоритет которых выше приоритета передающей станции, могут зарезервировать маркер для следующего прохода по сети. При генерации следующего маркера в него включается более высокий приоритет данной резервирующей станции. Станции, которые повышают уровень приоритета маркера, должны восстановить предыдущий уровень приоритета после завершения передачи.

Механизмы управления неисправостями

Сети Token Ring используют несколько механизмов обнаружения и компенсации неисправностей в сети. Например, одна станция в сети Token Ring выбирается "активным монитором" (active monitor). Эта станция, которой в принципе может быть любая станция сети, действует как централизованный источник синхронизирующей информации для других станций кольца и выполняет разнообразразные функции для поддержания кольца. Одной из таких функций является удаление из кольца постоянно циркулирующих блоков данных. Если устройство, отправившее блок данных, отказало, то этот блок может постоянно циркулировать по кольцу. Это может помешать другим станциям передавать собственные блоки данных и фактически блокирует сеть. Активный монитор может выявлять и удалять такие блоки и генерировать новый маркер.

Звездообразная топология сети IBM Token Ring также способствует повышению общей надежности сети. Т.к. вся информация сети Token Ring просматривется активными MSAU, эти устройства можно запрограммировать так, чтобы они проверяли наличие проблем и при необходимости выборочно удаляли станции из кольца.

Алгоритм Token Ring, называемый "сигнализирующим" (beaconing), выявляет и пытается устранить некоторые неисправности сети. Если какая-нибудь станция обнаружит серьезную проблему в сети (например такую, как обрыв кабеля), она высылает сигнальный блок данных. Сигнальный блок данных указывает домен неисправности, в который входят станция, сообщающая о неисправности, ее ближайший активный сосед, находящийся выше по течению потока информации (NAUN), и все, что находится между ними. Сигнализация инициализирует процесс, называемый "автореконфигурацией" (autoreconfiguration), в ходе которого узлы, расположенные в пределах отказавшего домена, автоматически выполняют диагностику, пытаясь реконфигурировать сеть вокруг отказавшей зоны. В физическом плане MSAU может выполнить это с помощью электрической реконфигурации.

Формат блока данных

Сети Token Ring определяют два типа блока данных: блоки маркеров и блоки данных/блоки команд. Оба формата представлены на Рис.6-3.

  • Маркеры Длина маркера - три байта; он состоит из
    ограничителя начала
    Ограничитель начала служит для предупреждения каждой станции о прибытии маркера (или блока данных/блока команд). В этом поле имеются сигналы, которые отличают этот байт от остальной части блока путем нарушения схемы кодирования, использованной в других частях блока.
    байта управления доступом
    Байт управления доступом содержит поля приоритета и резервирования, а также бит маркера (используемый для дифференциации маркера и блока данных/блока команд) и бит монитора (используемый активным монитором, чтобы определить, циркулирует какой-либо блок в кольце непрерывно или нет).
    ограничителя конца
    И наконец, разделитель конца сигнализирует о конце маркера или блока данных/ блока команд. В нем также имеются биты для индикации поврежденного блока,а также блока, являющегося последним в логической последовательности.
  • Блок данных и блок команд
    Блок данных и блок команд могут иметь разные размеры в зависимости от размеров информационного поля. Блоки данных переносят информацию для протоколов высших уровней; блоки команд содержат управляющую информацию, в них отсутствует информация для протоколов высших уровней.
    В блоке данных/ блоке команд за байтом управления доступом следует байт управления блоком данных. Байт управления блоком данных указывает, что содержит блок - данные или управляющую информацию. В управляющих блоках этот байт определяет тип управляющей информации.
    За байтом управления блоком следуют два адресных поля, которые идентифицируют станции пункта назначения и источника. Для IEEE 802.5 длина адресов равна 6 байтам.
    За адресными полями идет поле данных. Длина этого поля ограничена временем удержания маркера кольца, которое определяет максимальное время, в течение которого станция может удерживать маркер.
    За полем данных идет поле последовательности проверки блока (FCS). Станция-источник заполняет это поле вычисленной величиной, зависящей от содержания блока данных. Станция назначения повторно вычисляет эту величину, чтобы определить, не был ли блок поврежден при прохождении. Если это так, то блок отбрасывается.
    Также, как и маркер, блок данных/ блок команд заканчивается ограничителем конца.


Глава 7. FDDI.

  • Основы технологии
  • Технические условия FDDI
  • Физические соединения
  • Типы трафика
  • Особенности отказоустойчивости
  • Формат блока данных

Библиографическая справка

Стандарт на "Волоконно-оптический интерфейс по распределенным данным" (FDDI) был выпущен ANSI X3Т9.5 (комитет по разработке стандартов) в середине 1980 гг. В этот период быстродействующие АРМ проектировщика уже начинали требовать максимального напряжения возможностей существующих локальных сетей (LAN) (в oсновном Ethernet и Token Ring). Возникла необходимость в новой LAN, которая могла бы легко поддерживать эти АРМ и их новые прикладные распределенные системы. Одновременно все большее значение уделяется проблеме надежности сети, т.к. администраторы систем начали переносить критические по назначению прикладные задачи из больших компьютеров в сети. FDDI была создана для того, чтобы удовлетворить эти потребности.

После завершения работы над FDDI, ANSI представила его на рассмотрение в ISO. ISO разработала международный вариант FDDI, который полностью совместим с вариантом стандарта, разработанным ANSI.

Хотя реализации FDDI сегодня не столь распространены, как Ethernet или Token Ring, FDDI приобрела значительное число своих последователей, которое увеличивается по мере уменьшения стоимости интерфейса FDDI. FDDI часто используется как основа технологий, а также как средство для соединения быстродействующих компьютеров, находящихся в локальной области.

Основы технологии

Стандарт FDDI определяет 100 Mb/сек. LAN с двойным кольцом и передачей маркера, которая использует в качестве среды передачи волоконно-оптический кабель. Он определяет физический уровень и часть канального уровня, которая отвечает за доступ к носителю; поэтому его взаимоотношения с эталонной моделью OSI примерно аналогичны тем, которые характеризуют IEEE 802.3 и IЕЕЕ 802.5.

Хотя она работает на более высоких скоростях, FDDI во многом похожа на Token Ring. Oбe сети имеют одинаковые характеристики, включая топологию (кольцевая сеть), технику доступа к носителю (передача маркера), характеристики надежности (например, сигнализация-beaconing), и др. За дополнительной информацией по Token Ring и связанными с ней технологиями обращайтесь к Главе 6 "Token Ring/IEEE 802.5".

Одной из наиболее важных характеристик FDDI является то, что она использует световод в качестве передающей среды. Световод обеспечивает ряд преимуществ по сравнению с традиционной медной проводкой, включая защиту данных (оптоволокно не излучает электрические сигналы, которые можно перехватывать), надежность (оптоволокно устойчиво к электрическим помехам) и скорость (потенциальная пропускная способность световода намного выше, чем у медного кабеля).

FDDI устанавливает два типа используемoгo оптического волокна: одномодовое (иногда называемое мономодовым) и многомодовое. Моды можно представить в виде пучков лучей света, входящего в оптическое волокно под определенным углом. Одномодовое волокно позволяет распространяться через оптическое волокно только одному моду света, в то время как многомодовое волокно позволяет распространяться по оптическому волокну множеству мод света. Т.к. множество мод света, распространяющихся по оптическому кабелю, могут проходить различные расстояния (в зависимости от угла входа), и, следовательно, достигать пункт назначения в разное время (явление, называемое модальной дисперсией), одномодовый световод способен обеспечивать большую полосу пропускания и прогoн кабеля на большие расстояния, чем многомодовые световоды. Благодаря этим характеристикам одномодовые световоды часто используются в качестве основы университетских сетей, в то время как многомодовый световод часто используется для соединения рабочих групп. В многомодовом световоде в качестве генераторов света используются диоды, излучающие свет (LED), в то время как в одномодовом световоде обычно применяются лазеры.

Технические условия FDDI

FDDI определяется 4-мя независимыми техническими условиями (смотри Рис. 7-1 "Стандарты FDDI"):

Media Access Control (MAC) (Управление доступом к носителю)
определяет способ доступа к носителю, включая формат пакета, обработку маркера, адресацию, алгоритм CRC (проверка избыточности цикла) и механизмы устранения ошибок.
Physical Layer Protocol (PHY) (Протокол физического уровня)
определяет процедуры кодирования/декодирования информации, требования к синхронизации, формированию кадров и другие функции.
Station Management (SMT) (Управление станциями)
определяет конфигурацию станций FDDI, конфигурацию кольцевой сети и особенности управления кольцевой сетью, включая вставку и исключение станций, инициализацию, изоляцию и устранение неисправностей, составление графика и набор статистики.

Физические соединения

FDDI устанавливает применение двойных кольцевых сетей. Трафик по этим кольцам движется в противоположных направлениях. В физическом выражении кольцо состоит из двух или более двухточечных соединений между смежными станциями. Одно из двух колец FDDI называется первичным кольцом, другое-вторичным кольцом. Первичное кольцо используется для передачи данных, в то время как вторичное кольцо обычно является дублирующим.

"Станции Класса В" или "станции, подключаемые к одному кольцу" (SAS) подсоединены к одной кольцевой сети; "станции класса А" или "станции, подключаемые к двум кольцам" (DAS) подсоединены к обеим кольцевым сетям. SAS подключены к первичному кольцу через "концентратор", который обеспечивает связи для множества SAS. Koнцентратор отвечает за то, чтобы отказ или отключение питания в любой из SAS не прерывали кольцо. Это особенно необходимо, когда к кольцу подключен РС или аналогичные устройства, у которых питание часто включается и выключается.

На Рис. 7-2 "Узлы FDDI: DAS, SAS и концентратор" представлена типичная конфигурация FDDI, включающая как DAS, так и SAS.

Каждая DAS FDDI имеет два порта, обозначенных А и В. Эти порты подключают станцию к двойному кольцу FDDI. Следовательно, как это показано на Рис. 7-3 "Порты DAS FDDI", каждый порт обеспечивает соединение как с первичным, так и со вторичным кольцом.

Типы трафика

FDDI поддерживает распределение полосы пропускания сети в масштабе реального времени, что является идеальным для ряда различных типов прикладных задач. FDDI обеспечивает эту поддержку путем обозначения двух типов трафика: синхронного и асинхронного. Синхронный трафик может потреблять часть общей полосы пропускания сети FDDI, равную 100 Mb/сек; остальную часть может потреблять асинхронный трафик. Синхронная полоса пропускания выделяется тем станциям, которым необходима постоянная возможность передачи. Например, наличие такой возможности помогает при передаче голоса и видеоинформации. Другие станции используют остальную часть полосы пропускания асинхронно. Спецификация SMT для сети FDDI определяет схему распределенных заявок на выделение полосы пропускания FDDI.

Распределение асинхронной полосы пропускания производится с использованием восьмиуровневой схемы приоритетов. Каждой станции присваивается определенный уровень приоритета пользования асинхронной полосой пропускания. FDDI также разрешает длительные диалоги, когда станции могут временно использовать всю асинхронную полосу пропускания. Механизм приоритетов FDDI может фактически блокировать станции, которые не могут пользоваться синхронной полосой пропускания и имеют слишком низкий приоритет пользования асинхронной полосой пропускания.

Особенности отказоустойчивости

FDDI характеризуется рядом особенностей отказоустойчивости. Основной особенностью отказоустойчивости является наличие двойной кольцевой сети. Если какая-нибудь станция, подключенная к двойной кольцевой сети, отказывает, или у нее отключается питание, или если поврежден кабель, то двойная кольцевая сеть автоматически "свертывается" ("подгибается" внутрь) в одно кольцо, как показано на Рис.7-4 "Конфигурация восстановления кольца при отказе станции". При отказе Станции 3, изображенной на рисунке, двойное кольцо автоматически свертывается в Станциях 2 и 4, образуя одинарное кольцо. Хотя Станция 3 больше не подключена к кольцу, сеть продолжает работать для оставшихся станций.

На Рис. 7-5 "Конфигурация восстановления сети при отказе кабеля" показано, как FDDI компенсирует отказ в проводке. Станции 3 и 4 свертывают кольцо внутрь себя при отказе проводки между этими станциями.

По мере увеличения размеров сетей FDDI растет вероятность увеличения числа отказов кольцевой сети. Если имеют место два отказа кольцевой сети, то кольцо будет свернуто в обоих случаях, что приводит к фактическому сегментированию кольца на два отдельных кольца, которые не могут сообщаться друг с другом. Последующие отказы вызовут дополнительную сегментацию кольца.

Для предотвращения сегментации кольца могут быть использованы оптические шунтирующие переключатели, которые исключают отказавшие станции из кольца. На Рис. 7-6 показано "Использование оптического шунтирующего переключателя".

Устройства, критичные к отказам, такие как роутеры или главные универсальные вычислительные машины, могут использовать другую технику повышения отказоустойчивости, называемую "двойным подключением" (dual homing), для того, чтобы обеспечить дополнительную избыточность и повысить гарантию работоспособности. При двойном подключении критичное к отказам устройство подсоединяется к двум концентраторам. Одна пара каналов концентраторов считается активным каналом; другую пару называют пассивным каналом. Пассивный канал находится в режиме поддержки до тех пор, пока не будет установлено, что основной канал (или концентратор, к которому он подключен) отказал. Если это происходит,то пассивный канал автоматически активируется.

Формат блока данных

Форматы блока данных FDDI (представлены на Рис. 7-7) аналогичны форматам Token Ring.

preamble
Заголовок подготавливает каждую станцию для приема прибывающего блока данных.
start delimiter
Ограничитель начала указывает на начало блока данных. Он содержит сигнальные структуры, которые отличают его от остальной части блока данных.
frame control
Поле управления блоком данных указывает на размер адресных полей, на вид данных, содержащихся в блоке (синхронная или асинхронная информация), и на другую управляющую информацию.
destination address
Также, как у Ethernet и Token Ring, размер адресов равен 6 байтам. Поле адреса назначения может содержать односоставный (единственный), многосоставный (групповой) или широковещательный (все станции) адрес, в то время как адрес источника идентифицирует только одну станцию, отправившую блок данных.
data
Информационное поле содержит либо информацию, предназначенную для протокола высшего уровня, либо управляющую информацию.
frame check sequence
Также, как у Token Ring и Ethernet, поле проверочной последовательности блока данных (FCS) заполняется величиной "проверки избыточности цикла" (CRC), зависящей от содержания блока данных, которую вычисляет станция- источник. Станция пункта назначения пересчитывает эту величину, чтобы определить наличие возможного повреждения блока данных при транзите. Если повреждение имеется, то блок данных отбрасывается.
end delimiter
Ограничитель конца содержит неинформационные символы, которые означают конец блока данных.
frame status
Поле состояния блока данных позволяет станции источника определять, не появилась ли ошибка, и был ли блок данных признан и скопирован принимающей станцией.


Глава 8. UltraNet.

  • Основы технологии
  • Компоненты UltraNet
  • Концентратор (hub) UltraNet
  • Программное обеспечение главной вычислительной машины UltraNet
  • Управляющий сети UltraNet
  • Сетевые процессоры
  • Адаптеры каналов связи

Библиографическая справка

Система сети UltraNet, или просто UltraNet, состоит из семейства высокоскоростных программ для об'единенных сетей и аппаратных изделий, способных обеспечить совокупную пропускную способность в один гигабайт в секунду (Gb/сек). UltraNet производится и реализуется на рынке компанией Ultra Network Technologies. UltraNet oбычно используется для соединения высокоскоростных компьютерных систем, таких как суперкомпьютеры, минисуперкомпьютеры, универсальные вычислительные машины, устройства обслуживания и АРМ. UltraNet может быть сама соединена с другой сетью (например, Ethernet и Token Ring) через роутеры, которые выполняют функции межсетевого интерфейса.

Основы технологии

UltraNet обеспечивает услуги, соответствующие четырем низшим уровням эталонной модели OSI. На Рис. 8-1 показаны взаимоотношения между этими уровнями и реализацией UltraNet. В дополнение к перечисленным протоколам UltraNet также обеспечиваетSimple Network Management Protocol (SNMP)(Протокол Управления Простой Сетью) и Routing Information Protocol (RIP) (Протокол маршрутной информации). Дополнительная информация по этим протоколам дается соответственно в Главе 23 "RIP" и Главе 32 "SNMP".

UltraNet использует топологию звездообразной сети с концентратором сети (Hub) в центральной точке звезды. Другими компонентами системы UltraNet являются программное обеспечение для главной вычислительной машины, сетевые процессоры, канальные адаптеры, инструментальные средства управления сети и изделия для об'единения сетей, такие как роутеры и мосты. Сетевые процессоры соединяют главные вычислительные машины с системой UltraNet и обеспечивают виртуальную цепь и услуги дейтаграмм. Главные вычислительные машины, непосредственно подключенные к системе UltraNet, могут быть удалены друг от друга на расстояние до 30 км. Этот предел может быть расширен подключением к глобальной сети (WAN), например, путем использования каналов связи Т3.

Компоненты UltraNet

Сеть UltraNet состоит из различных компонентов, в том числе концентраторов, программного обеспечения для главных вычислительных машин, управляющих сети, сетеых процессоров и канальных адаптеров. Описание этих системных элементов дается в следующих разделах.

Концентратор (hub) UltraNet

Концентратор в UltraNet является центральной точкой связи для главных вычислительных машин сети UltraNet. Он содержит высоко- скоростную внутреннюю параллельную шину (UltraBus), об'единяющую все процессоры в пределах этого концентратора. UltraBus отвечает за коммутируемую информацию в сети UltraNet. Концентраторы UltraNet обеспечивают быстрое согласование, управление перегрузкой каналов связи и прямое подключение каналов.

Программное обеспечение главной вычислительной машины UltraNet

Программное обеспечение главной вычислительной машины UltraNet состоит из:

  • Библиотек программирования, позволяющих пропускать через UltraNet программы клиентов Transmission Control Protocol/Internet Protocol (TCP/IP) (Протокол управления передачей/ Протокол Internet) и графические прикладные программы.
  • Драйверов устройств сетевых процессоров, которые обеспечивают интерфейс между процессами пользователя и сетевым процессором UltraNet через адаптер процессора.
  • Поддержки системы программных гнезд, базирующейся на библиотеках программ, UNIX Berkeley Standard Distribution (BSD). Эта поддержка обеспечивается в форме совокупности библиотечных функций языка С, которая заменяет стандартные обращения к системе программных гнезд, чтобы обеспечить совместимость с существующими прикладными задачами, базирующимися на программных гнездах.
  • Обслуживающие конфигурационные программы, которые дают возможность пользователю определять сетевые процессоры, имеющиеся в системе UltraNet, маршруты между концентраторами UltraNet и сетевыми процессорами, а также адреса UltraNet.
  • Диагностические обслуживающие программы, которые позволяют пользователям проверять систему UltraNet для обнаружения возможных проблем. Эти обслуживающие программы могут запускаться компьютером Ultra Network Manager (Управляющий сети UltraNet), а также главной вычислительной машиной.

Управляющий сети UltraNet

Управляющий сети UltraNet обеспечивает инструментальные средства, которые помогают инициализировать и управлять UltraNet. Физическим выражением управляющего является базирующийся на Intel 80386 РС, работающий в операционных системах DOS и Windows, который подключает к концентратору UltraNet через шину управления сети (NMB). NMB представляет собой независимую 1 Mg/сек LAN, базирующуюся на спецификации StarLAN (1Base5). Управляющий UltraNet заменяет информацию управления, пользуясь протоколом SNMP.

Сетевые процессоры

Сетеые процессоры UltraNet обеспечивают связи между концентраторами UltraNet и главными вычислительными машинами. Имеются сетевые процессоры, которые поддерживают каналы High-Perfomance Parallel Interface (HIPPI)(Высокопроизводительный параллельный интерфейс), HSX (обеспечивается Cray), ВМС (обеспечивается IBM) и LSC (обеспечивается Cray), а также шины VMEbus, SBus, HP/EISA bus и IBM Micro Channel bus. Сетевые процессоры могут находиться либо в главной вычислительной машине, либо в концентраторе UltraNet.

Сетевой процессор, размещаемый в концентраторе, состоит из платы процессора обработки протоколов, платы персонального модуля и платы пульта ручного управления. Плата процессора обработки протоколов выполняет команды сетевых протоколов; на ней имеются буферы FIFO для выполнения буферизации пакетов и согласования скоростей. Плата персонального модуля управляет обменом информации между процессором обработки протоколов и различными средами сети, каналами главной управляющей машины или специализированной аппаратурой. Плата пульта ручного управления управляет устройством ввода/вывода (I/O) информации между сетевым процессором и главной вычислительной машиной, монитором графического дисплея или другим концентратором.

UltraNet также обеспечивает систему графического изображения с высокой разрешающей способностью, которая принимает информацию в пикселях из главной вычислительной машины UltraNet и отображает ее на мониторе, подключенном к адаптеру. Это устройство называется сетевым процессором кадрового буфера.

Большинство задач обработки сетевых протоколов выполняются сетевыми процессорами UltraNet. Сетевые процессоры могут принимать реализации TCP/IP и связанных с ним протоколов, а также модифицированные пакеты протоколов OSI, чтобы осуществлять связь между главными вычислительными машинами.

Адаптеры каналов связи

Адаптеры каналов связи соединяют и передают информацию между двумя концентраторами UltraNet или между концентратором UltraNet и роутерами Cisco Systems AGS+. Имея в своем составе контроллеры каналов связи, от одного до четырех мультиплексоров каналов связи и одну плату пульта ручного управления для каждого мультиплексора каналов связи, адаптеры каналов связи располагают полностью дублированной частной шиной, мощность полосы пропускания которой равна 1 Гигабит/сек.

На основе регурярно действующего принципа адаптеры каналов связи определяют те адаптеры и концентраторы, к которым они непосредственно подключаются. Адаптеры каналов связи рассылают ту или иную маршрутную информацию в другие адаптеры каналов, чтобы осуществлять динамичное построение и поддержание базы данных маршрутизации, содержащей информацию о наилучшем маршруте до всех главных вычислительных машин в пределах сети.


Глава 9. HSSI.

  • Основы технологии

Библиографическая справка

Бесспорной тенденцией развития сетей является увеличение скорости связи. В последнее время с появлением интерфейса Fiber Distributed Data Interface (FDDI) (Волоконно-оптический интерфейс по распределенным данным) локальные сети переместились в диапазон скоростей до 100 Mb/сек. Прикладные программы для локальных сетей, стимулирующие это увеличение скоростей, включают передачу изображений, видеосигналов и современные прикладные задачи передачи распределенной информации (клиент-устройство обслуживания). Более быстродействующие компьютерные платформы будут продолжать стимулировать увеличение скоростей в окружениях локальных сетей по мере того, как они будут делать возможными новые высокоскоростные прикладные задачи.

Уже разработаны линии глобальных сетей (WAN) с более высокой пропускной способностью, чтобы соответствовать постоянно растущим скоростям LAN и сделать возможным увеличение протяженности канала универсальной вычислительной машины через глобальные сети. Технологии WAN, такие как Frame Relay(Реле блока данных), Switched Multimegabit Data Service (SMDS) (Обслуживание переключаемых мультимегабитовых информационных каналов), Synchronous Optical Network (Sonet) (Синхронная оптическая сеть) и Broadband Integrated Services Digital Network (Broadband ISDN, или просто BISDN) (Широкополосная цифровая сеть с интегрированными услугами), использовали преимущества новых цифровых и волоконно-оптических технологий для того, чтобы обеспечить WAN иную роль, чем роль узкого бутылочного горлышка в сквозной передаче через большие географические пространства. Дополнительная информация по Frame Relay и SMDS приведена соответственно в Главе 14 "Frame Relay" и Главе 15 "SMDS".

С достижением более высоких скоростей в окружениях как локальных, так и глобальных сетей, насущной необходимостью стал интерфейс data terminal equipment (DTE)/data circuit-terminating equipment (DCE) (Интерфейс "терминальное оборудование/оборудование завершения работы информационной цепи"), который мог бы соединить эти два различных мира и не стать при этом узким бутылочным горлышком. Стандарты классических интерфейсов DTE/DCE, таких как RS-232 и V.35, не способны обеспечить скорости Т3 или аналогичные им скорости. К концу 1980 гг. стало очевидно, что необходим новый протокол DTE/DCE.

High-Speed Serial Interface (HSSI)(Высокоскоростной последовательный интерфейс) является интерфейсом DTE/DCE, разработанным компаниями Cisco Systems и T3Plus Networking, чтобы удовлетворить перечисленные выше потребности. Спецификация HSSI доступна для любой организации, которая хочет реализовать HSSI. Пока что распределено свыше 150 копий этой спецификации, и десятки компаний либо уже реализовали одно из технических решений HSSI, либо находятся в стадии реализации. Менее чем за 3 года HSSI стала настоящим промышленным стандартом.

В настоящее время HSSI находится в стадии процесса официальной стандартизации в комитете Ассоциации электронной промышленности (EIA/TIATR30.2) Американскогo национальногo институтa стандартизации (ANSI). Недавно он был передан в организации "Международный Консультативный Комитет по Телеграфии и Телефонии" (CCITT) и "Международная Организация по Стандартизации" (ISO); ожидается, что он будет стандартизирован обеими организациями.

Основы технологии

HSSI определяет как электрический, так и и физический интерфейсы DTE/DCE. Следовательно, он соответствует физическому уровню эталонной модели OSI. Технические характеристики HSSI обобщены на Рис. 9-1.

Max. signal rate | 52 Mbps
Max. cable length | 50 feet
Connector pins | 50
Interface | DTE-DCE
Electrical technology | Differential ECL
Typical power consumption | 610 mW
Topology | Point-to-point
Cable type | Shielded twisted pair

Figure 9-1 HSSI Technical Characteristics

Максимальная скорость передачи сигнала HSSI равна 52 Mb/сек. На этой скорости HSSI может оперировать скоростями Т3 (45 Mb/сек) большинства современных быстродействующих технологий WAN, скоростями Office Channel(OC)-1 (52 Mb/сек) иерархии синхронной цифровой сети (SDN), а также может легко обеспечить высокоскоростное соединение между локальными сетями, такими, как Token Ring и Ethernet.

Применение дифференциальных логических схем с эмиттерным повторителем (ЕCL) позволяет HSSI добиться высоких скоростей передачи информации и низких уровней помех. ECL использовалась в интерфейсах Cray в течение нескольких лет; эта схема определена стандартом сообщений High-Perfomance Parallel Interface (HIPPI), разработанным ANSI, для связей LAN с суперкомпьютерами. ECL-это имеющаяся в готовом виде технология, которая позволяет превосходно восстанавливать синхронизацию приемника, результатом чего является достаточный запас надежности по синхронизации.

Гибкость синхронизации и протокола обмена информацией HSSI делает возможным выделение полосы пропускания пользователю (или поставщику). DCE управляет синхронизацией путем изменения ее скорости или путем стирания импульсов синхронизации. Таким образом DCE может распределять полосу пропускания между прикладными задачами. Например, PВX может потребовать одну величину полосы пропускания, роутер другую величину, а расширитель канала-третью. Распределение полосы пропускания является ключом для того, чтобы сделать Т3 и другие услуги широкой полосы (broadband) доступными и популярными.

HSSI использует субминиатюрный, одобренный FCC 50-контактный соединитель, размеры которого меньше, чем у его аналога V.35. Чтобы уменьшить потребность в адаптерах для соединения двух вилок или двух розеток, соединители кабеля HSSI определены как вилки. Кабель HSSI использует такое же число контактов и проводов, как кабель интерфейса Small Computer Systems Interface 2 (SCSI-2), однако технические требования HSSI на электрические сигналы более жесткие.

Для любого из высших уровней диагностического ввода, HSSI обеспечивает четыре проверки петлевого контроля. Эти тесты показаны на Рис. 9-2 "четыре теста петлевого контроля HSSI". Первый тест обеспечивает контроль кабеля локальной сети, т.к. сигнал закольцовывается, как только он доходит до порта DTE. Сигнал второго теста доходит до линейного порта локального DСE. Сигнал трeтьего теста доходит до линейного порта отдаленной DCE. И наконец, четвертый тест представляет собой инициируемую DCE проверку устройством DTE порта DCE.

HSSI предполагает, что DCE и DТЕ обладают одинаковым интеллектом. Протокол управления упрощен, т.к. требуется всего два управляющих сигнала (DTE available - "DTE доступен" и DCE available - "DCE доступен"). Оба сигнала должны быть утверждены до того, как информационная цепь станет действующей. Ожидается, что DTE и DCE будут в состоянии управлять теми сетями, которые находятся за их интерфейсами. Уменьшение числа управляющих сигналов улучшает надежность цепи за счет уменьшения числа цепей, которые могут отказать.


Глава 10. PPP.

  • Компоненты PPP
  • Основные принципы работы
  • Требования, определяемые физическим уровнем
  • Канальный уровень PPP
  • Протокол управления канала связи PPP (LCP)

Библиографическая справка

В конце 1980 гг. Internet (крупная международная сеть, соединяющая множество иссследовательских организаций, университетoв и коммерческих концернов) начала испытывать резкий рост числа главных вычислительных машин, обеспечивающих TCP/IP. Преобладающая часть этих главных вычислительных машин была подсоединена к локальным сетям (LAN) различных типов, причем наиболее популярной была Ethernet. Большая часть других главных вычислительных машин.соединялись через глобальные сети (WAN), такие как общедоступные сети передачи данных (PDN) типа Х.25. Сравнительно небольшое число главных вычислительных машин были подключены к каналам связи с непосредственным (двухточечным) соединением (т.е. к последовательным каналами связи). Однако каналы связи с непосредственным соединением принадлежат к числу старейших методов передачи информации, и почти каждая главная вычислительная машина поддерживает непосредственные соединения. Например, асинхронные интерфейсы RS-232-С встречаются фактически повсюду.

Одной из причин малого числа каналов связи IP с непосредственным соединением было отсутствие стандартного протокола формирования пакета данных Internet. Протокол Point-to-Point Protocol (PPP)(Протокол канала связи с непосредственным соединением) предназначался для решения этой проблемы. Помимо решения проблемы формирования стандартных пакетов данных Internet IP в каналах с непосредственным соединением, РРР также должен был решить другие проблемы, в том числе присвоение и управление адресами IP, асинхронное (старт/стоп) и синхронное бит-ориентированное формирование пакета данных, мультиплексирование протокола сети, конфигурация канала связи, проверка качества канала связи, обнаружение ошибок и согласование варианта для таких способностей, как согласование адреса сетевого уровня и согласование компрессии информации. РРР решает эти вопросы путем обеспечения расширяемого Протокола Управления Каналом (Link Control Protocol) (LCP) и семейства Протоколов Управления Сетью (Network Control Protocols) (NCP), которые позволяют согласовывать факультативные параметры конфигурации и различные возможности. Сегодня PPP, помимо IP, обеспечивает также и другие протоколы, в том числе IPX и DECnet.

Компоненты PPP

РРР обеспечивает метод передачи дейтаграмм через последовательные каналы связи с непосредственным соединением. Он содержит три основных компонента:

  • Метод формирования дейтаграмм для передачи по последовательным каналам. РРР использует протокол High-level Data Link Control (HDLC) (Протокол управления каналом передачи данных высокого уровня) в качестве базиса для формирования дейтаграмм при прохождении через каналы с непосредственным соединением. Дополнительная информация по HDLC дается в Главе 12 "SDLC и его производные".
  • Расширяемый протокол LCP для организации, выбора конфигурации и проверки соединения канала передачи данных.
  • Семейство протоколов NCP для организации и выбора конфигурации различных протоколов сетевого уровня. РРР предназначена для обеспечения одновременного пользования множеством протоколов сетевого уровня.

Основные принципы работы

Для того, чтобы организовать связь через канал связи с непосредственным соединением, инициирующий РРР сначала отправляет пакеты LCР для выбора конфигурации и (факультативно) проверки канала передачи данных. После того, как канал установлен и пакетом LCР проведенo необходимое согласование факультативных средств, инициирующий РРР отправляет пакеты NCP, чтобы выбрать и определить конфигурацию одного или более протоколов сетевого уровня. Как только конфигурация каждого выбранного протокола оперделена, дейтаграммы из каждого протокола сетевого уровня могут быть отправлены через данный канал. Канал сохраняет свою конфигурацию для связи до тех пор, пока явно выраженные пакеты LCP или NCP не закроют этот канал, или пока не произойдет какое-нибудь внешнее событие (например, истечет срок бездействия таймера или вмешается какой-нибудь пользователь).

Требования, определяемые физическим уровнем

РРР может работать через любой интерфейс DTE/DCE (например, EIA RS-232-C, EIA RS-422, EIA RS-423 и CCITT V.35). Единственным абсолютным требованием, которое пред'являет РРР, является требование обеспечения дублированных схем (либо специально назначенных, либо переключаемых), которые могут работать как в синхронном, так и в асинхронном последовательном по битам режиме, прозрачном для блоков данных канального уровня РРР. РРР не пред'являет каких-либо ограничений, касающихся скорости передачи информации, кроме тех, которые определяются конкретным примененным интерфейсом DTE/DCE.

Канальный уровень PPP

РРР использует принципы, терминологию и структуру блока данных процедур HDLC (ISO 3309-1979) Международной Организации по Стандартизации (ISO), модифицированных стандартом ISO 3309-1984/PDAD1 "Addendum 1:Start/stop Trasmission" (Приложение 1: Стартстопная передача"). ISO 3309-1979 определяет структуру блока данных HLDC для применения в синхронных окружениях. ISO 3309-1984/PDAD1 определяет предложенные для стандарта ISO 3309-1979 модификации, которые позволяют его использование в асинхронных окружениях. Процедуры управления РРР используют дефиниции и кодирование управляющих полей, стандартизированных ISO 4335-1979 и ISO 4335-1979/Addendum 1-1979.

Нa Рис. 10-1 приведен формат блока данных РРР.

flag
Длина последовательности "флаг" равна одному байту; она указывает на начало или конец блока данных. Эта последовательность состоит из бинарной последовательности 01111110.
address
Длина поля "адрес" равна 1 байту; оно содержит бинарную последовательность 11111111, представляющую собой стандартный широковещательный адрес. РРР не присваивает индивидуальных адресов станциям.
control
Поле "управление" составляет 1 байт и содержит бинарную последовательность 00000011, которая требует от пользователя передачи информации непоследовательным кадром. Предусмотрены услуги без установления соединения канала связи, аналогичные услугам LLC Type 1. Подробную информацию о типах LLC и блоков данных смотри в Главе 12 "SDLC и его производные".
protocol
Длина поля "протокол" равна 2 байтам; его значение идентифицирует протокол, заключенный в информационном поле блока данных. Большинство современных значений поля протокола определены в последнем выпуске Assigned Numbers Request for Comments (RFC).
data
Длина поля "данные" - от нуля и больше; оно содержит дейтаграмму для ротокола, заданного в поле протокола. Конец информационного поля определяется локализацией замыкающей последовательности "флаг" и предоставлением двух байтов полю FCS. Максимальная длина умолчания информационного поля равна 1500 байтам. В соответствии с априорным соглашением, разрешающие реализации РРР могут использовать другие значения максимальной длины информационного поля.
frame check sequence
Поле проверочной последовательности блока данных (FCS) обычно составляет 16 бит (два байта). В соответствии с априорным соглашением, разрешающие реализации РРР могут использовать 32-х битовое (четырехбайтовое) поле FCS, чтобы улучшить процесс выявления ошибок.

Link Control Protocol (LCP) может согласовывать модификации стандартной структуры блока данных РРР. Однако модифицированные блоки данных всегда будут четко различимы от стандартных блоков данных.

Протокол управления канала связи PPP (LCP)

LCP обеспечивает метод организации, выбора конфигурации, поддержания и окончания работы канала с непосредственным соединением. Процесс LCD проходит через 4 четко различаемые фазы:

  • Организация канала и согласование его конфигурации. Прежде чем может быть произведен обмен каких-либо дейтаграмм сетевого уровня (например, IP), LCP сначала должен открыть связь и согласовать параметры конфигурации. Эта фаза завершается после того, как пакет подтверждения конфигурации будет отправлен и принят.
  • Определение качества канала связи. LCP обеспечивает факультативную фазу определения качества канала, которая следует за фазой организации канала и согласования его конфигурации. В этой фазе проверяется канал, чтобы определить, является ли качество канала достаточным для вызова протоколов сетевого уровня. Эта фаза является полностью факультативной. LСP может задержать передачу информации протоколов сетевого уровня до завершения этой фазы.
  • Согласование конфигурации протоколов сетевого уровня. После того, как LСP завершит фазу определения качества канала связи, конфигурация сетевых протоколов может быть по отдельности выбрана соответствующими NCP, и они могут быть в любой момент вызваны и освобождены для последующего использования. Если LCP закрывает данный канал, он информирует об этом протоколы сетевого уровня, чтобы они могли принять соответствующие меры.
  • Прекращение действия канала. LCP может в любой момент закрыть канал. Этро обычно делается по запросу пользователя (человека), но может произойти и из-за какого-нибудь физического события, такого, как потеря носителя или истечение периода бездействия таймера.

Существует три класса пакетов LCP:

  • Пакеты для организации канала связи. Используются для организации и выбора конфигурации канала.
  • Пакеты для завершения действия канала. Используются для завершения действия канала связи.
  • Пакеты для поддержания работоспособности канала. Используются для поддержания и отладки канала.

Эти пакеты используются для достижения работоспособности каждой из фаз LCP.


Глава 11. ISDN.

  • Компоненты ISDN
  • Услуги ISDN
  • Уровень 1
  • Уровень 2
  • Уровень 3

Библиографическая справка

Название сети Integrated Services Digital Network (ISDN) (Цифровая сеть с интегрированными услугами) относится к набору цифровых услуг, которые становятся доступными для конечных пользователей. ISDN предполагает оцифровывание телефонной сети для того, чтобы голос, информация, текст, графические изображения, музыка, видеосигналы и другие материальные источники могли быть переданы коанечныму пользователю по имеющимся телефонным проводам и получены им из одного терминала конечного пользователя. Сторонники ISDN рисуют картину сети мирового масштаба, во многом похожую на сегодняшнюю телефонную сеть, за тем исключеним, что в ней используется передача цирфрового сигнала и появляются новые разнообразные услуги.

ISDN является попыткой стандартизировать абонентские услуги, интерфейсы пользователь/сеть и сетевые и межсетевые возможности. Стандартизация абонентских услуг является попыткой гарантировать уровень совместимости в международном масштабе. Стандартизация интерфейса пользователь/сеть стимулирует разработку и сбыт на рынке этих интерфейсов изготовителями, являющимися третьей участвующей стороной. Стандартизация сетевых и межсетевых возможностей помогает в достижении цели возможного об'единения в мировом масштабе путем обеспечения легкости связи сетей ISDN друг с другом.

Применения ISDN включают быстродействующие системы обработки изображений (такие, как факсимиле Group 1V), дополнительные телефонные линии в домах для обслуживания индустрии дистанционного доступа, высокоскоростную передачу файлов и проведение видео конференций. Передача голоса несомненно станет популярной прикладной программой для ISDN.

Многие коммерческие сети связи начинают предлагать ISDN по ценам ниже тарифных. В Северной Америке коммерческие сети связи с коммутатором локальных сетей (Local-exchange carrier) (LEC) начинают обеспечивать услуги ISDN в качестве альтернативы соединениям Т1, которые в настоящее время выполняюут большую часть услуг "глобальной телефонной службы" (WATS) (wide-area telephone service).

Компоненты ISDN

В число компонентов ISDN входят терминалы, терминальные адаптеры (ТА), устройства завершения работы сети, оборудование завершения работы линии и оборудование завершения коммутации. Имеется два типа терминалов ISDN. Специализированные терминалы ISDN называются "терминальным оборудованием типа 1" (terminal equipment type 1) (TE1). Терминалы, разрабатывавшиеся не для ISDN, такие, как DTE, которые появились раньше стандартов ISDN, называются "терминальным оборудованием типа 2" (terminal equipment type 2) (TE2). Терминалы ТЕ1 подключают к сети ISDN через цифровую линию связи из четырех скрученных пар проводов. Терминалы ТЕ2 подключают к сети ISDN через терминальный адаптер. Teрминальный адаптер (ТА) ISDN может быть либо автономным устройством, либо платой внутри ТЕ2. Если ТЕ2 реализован как автономное устройств, то он подключает к ТА через стандартный интерфейс физического уровня (например, EIA232, V.24 или V.35).

Следующей точкой соединения в сети ISDN, расположенной за пределами устройств ТЕ1 и ТЕ2, является NT1 или NT2. Это устройства завершения работы сети, которые подключают четырехпроводной абонентский монтаж к традиционному контуру двухпроводной локальной сети. В Северной Америке NT1 является устройством "оборудования посылок заказчика" (customer premises equipment) (CPE). В большинстве других частей света NT1 является частью сети, обеспечиваемой коммерческими сетями связи. NT2 является более сложным устройством, которое обычно применяется в "частных цифровых телефонных станциях с выходом в общую сеть" (PBX), и выполняет функции протоколов Уровней 2 и 3 и услуги по концентрации данных. Существует также устройство NT1/2; это отдельное устройство, которое сочетает функции NT1 и NT2.

В ISDN задано определенное число контрольных точек. Эти контрольные точки определяют логические интерфейсы между функциональными группировками, такими, как ТА и NТ1. Контрольными точками ISDN являются точки "R" (контрольная точка между неспециализированным оборудованием ISDN и ТА), "S" (контрольная точка между терминалами пользователя и NT2), "Т" (контрольная точка между устройствами NT1 и NT2) и "U" (контрольная точка между устройствами NT1 и оборудованием завершения работы линии в коммерческих сетях связи). Контрольная точка "U" имеет отношение только к Северной Америке, где функция NT1 не обеспечивается коммерческими сетями связи.

На Рис. 11-1 показан "Образец конфигурации ISDN". Нa рисунке изображены три устройства, подключенные к коммутатору ISDN , находящемуся на центральной станции. Два из этих устройства совместимы с ISDN, поэтому их можно подключить к устройствам NT2 через контрольную точку "S". Третье устройство (стандартный, не специализированный для ISDN тeлефон) подключается к ТА через контрольную точку "R". Любое из этих устройств может быть также подключено к устройству NT1/2, которое заменяет оба устройства- NТ1 и NT2. Аналогичные станции пользователей (не показанные на рисунке) подключены к самому правому переключателю ISDN.

Услуги ISDN

Услуги "Интерфейса базовой скорости" (Basic Rate Interface) (BRI), обеспечиваемые ISDN, предлагают два В-канала и один D-канал (2B+D). Обслуживание В-каналом BRI осуществляется со скоростью 64 Kb/сек; оно предназначено для переноса управляющей информации и информации сигнализации, хотя при определенных обстоятельствах может поддерживать передачу информации пользователя. Протокол обмена сигналами D-канала включает Уровни 1-3 эталонной модели OSI. BRI обеспечивает также управление разметкой и другие непроизводительные операции, при этом общая скорость передачи битов доходит до 192 Kb/сек. Спецификацией физического уровня BRI является ССIТТ 1.430.

Услуги "Интерфейса первичной скорости" ISDN (Primary Rate Interface) (PRI)предлагают 23 В-канала и один D-канал в Северной Америке и Японии, обеспечивающие общую скорость передачи битов 1.544 Mb/сек (канал-D PRI работает на скорости 64 Kb/сек). PRI ISDN в Европе, Австралии и других частях света обеспечивает 30 В-каналов и один 64 Kb/сек D-канал и общую скорость интерфейса 2.048 Mb/сек. Спецификацией физического уровня PRI является CCITT 1.431.

Уровень 1

Форматы блока данных физическoго уровня (Уровень 1) ISDN различаются в зависимости от того, является блок данных отправляемым за пределы терминала (из терминала в сеть) или входящим в пределы терминала (из сети в терминал). Оба вида блока данных физического уровня показаны на Рис. 11-2 "Форматы блоков данных физического уровня ISDN". Длина блоков данных равна 48 битам, из которых 36 бит представляют информацию. Биты "F" обеспечивают синхронизацию. Биты "L" регулируют среднее значение бита. Биты "Е" используются для решения конфликтной ситуации, когда несколько терминалов на какой- нибудь пассивной шине претендуют на один канал. Бит "А"" активирует усройства. Биты "S" ещe не получили назначения. Биты "В1", "В2" и "D" предназначены для данных пользователя.

Физически к одной цепи может быть подключено множество устройств пользователей ISDN. Для такой конфигурации столкновения могут быть результатом одновременной передачи двух терминалов. Поэтому ISDN предусматривает средства для определения конфликтов в канале связи. При получении устройством NT бита D из ТЕ оно отражает этот бит эхо-сигналом обратно в соседнюю позицию Е-бита. ТЕ ожидает, что соседний Е бит должен быть тем же самым, что и бит D, который он передал в последней передаче.

Терминалы не могут передавать в D-канал до тех пор, пока они не распознают специфичное число единиц (указывающих на "отсутствие сигнала"), соответствующее заранее установленному приоритету. Если устройство ТЕ обнаруживает какой-либо бит в канале с эхо-сигналом (Е), отличающимся от его битов D, oнo должно немедленно прекратить передачу. Этот простой прием является гарантией того, что одновременно только один терминал может передавать свои D-сообщения. После успешной передачи D-сообщения приоритет этого терминала становится более низким, что обеспечивается путем пред'явления ему требования до передачи детектировать большее число последовательных единиц. Приоретет у терминалов может не повыситься до тех пор, пока все другие устройства на этой линии не получат возможность отправить D-сообщение. Телефонные связи имеют более высокий приоритет, чем все другие службы, а информация обмена сигналами имеет более высокий приоритет, чем несигнализирующая информация.

Уровень 2

Уровнем 2 протокола обмена сигналами ISDN является Link Access Procedure, D channel (Процедура доступа к каналу связи, D-канал), известная также как LAРD. LAPD аналогична "Управлению каналом передачи данных высокого уровня" (HDLC) и "Процедуре доступа к каналу связи, сбалансированной" (LAPB) (смотри Главу 12 "SDLC и его производные" и Главу 13 "Х.25", где дается более подробная информация об этих протоколах). Как видно из раскрытия его акронима, LAPD используется в D-канале для того, чтобы обеспечить поток и соответствующий прием управляющей и сигнализирующей информации. Формат блока данных LAPD (смотри Рис. 11-3) очень похож на формат HDLC; также, как НDLC, LAPD использует блок данных супервизора, информационный и и непронумерованный блоки данных. Протокол LAPD формально определен в CCITT Q.920 и SSITT Q.921.

Поля "флаг" (flag) и "управление" (control) LAPD идентичны этим полям у HDLC. Длина поля "адрес" LAPD может составлять один или два байта. Если в первом байте задан бит расширенного адреса (ЕА), то адрес состоит из одного байта; если он не задан, то адрес состоит из двух байтов. Первый байт адресного поля содержит servise access point identifier (SAPI)(идентификатор точки доступа к услугам), который идентифицирует главный вход, в котором услуги LAPD обеспечиваются Уровню 3. Бит C/R указывает, содержит ли блок данных команду или ответный сигнал. Поле "идентификатора конечной точки терминала" (terminal end-point identifier) (TEI) указывает, является ли терминал единственным или их много. Этот идентификатор является единственным из перечисленных выше, который указывает на широковещание.

Уровень 3

Для передачи сигналов ISDN используются две спецификации Уровня 3: CCITT 1.450 (известная также как CCITT Q.930) и CCITT 1.451 (известная также как SSITT Q.931). Вместе оба этих протокола обеспечивают соединения пользователь-пользователь, соединения с коммутацией каналов и с коммутацией пакетов. В них определены разнообразные сообщения по организации и завершению обращения, информационные и смешанные сообщения, в том числе SETUP (УСТАНОВКА), CONNECT (ПОДКЛЮЧАТЬ), RELEASE (ОТКЛЮЧЕНИЕ), USER INFORMATION (ИНФОРМАЦИЯ ПОЛЬЗОВАТЕЛЯ), CANCEL (ОТМЕНА), STATUS (СОСТОЯНИЕ) и DISCONNECT (РАЗ'ЕДИНЯТЬ). Эти сообщения функционально схожи с сообщениями, которые обеспечивает протокол Х.25 (более подробно смотри в Главе 13 "Х.25"). На рис.11-4, взятом из спецификации CCITT 1.451, показаны типичные стадии обращения с коммутацией каналов ISDN.


Глава 12. SDLC и его производные.

  • Основы технологии
  • Форматы блока данных
  • Производные протоколы
    • HDLC
    • LAPB
    • IEEE802.2

Библиографическая справка

IBM разработала протокол Synchronous Data-Link Control (SDLC) (Управление синхронным каналом передачи данных) в середине 1970 гг. для применения в окружениях Systems Network Architecture (SNA) (Архитектура системных сетей). SDLC был первым из протоколов канального уровня нового важного направления, базирующегося на синхронном бит-ориентированном режиме работы. По сравнению с синхронным, ориентированным по символам (например, Bisynk фирмы IBM) и синхронным, с организацией счета байтов (например, Digital Data Communications Message Protocol - Протокол Сообщений Цифровой Связи) протоколами, бит-ориентированные синхронные протоколы являются более эффективными и гибкими, и очень часто более быстродействующими.

После разработки SDLC компания IBM представила его на рассмотрение в различные комитеты по стандартам. Международная Организация по Стандартизации (ISO) модифицировала SDLC с целью разработки протокола HDLC (Управление каналом связи высокого уровня). Впоследствии Международный консультативный комитет по телеграфии и телефонии (CCITT) модифицировал HDLC с целью создания "Процедуры доступа к каналу" (LAP), а затем "Процедуры доступа к каналу, сбалансированной" (LAPB). Институт инженеров по электротехнике и радиоэлектронике (IEEE) модифицировал HDLC , чтобы разработать IEEE 802.2. Kaждый из этих протоколов играет важную роль в своей области. SDLC остается основным протоколом канального уровня SNA для каналов глобальных сетей.

Основы технологии

SDLC поддерживает разнообразные типы соединений и топологий. Он может применяться в сетях с двухточечными (непосредственными) и многоточечными связями, со связанным и несвязанным носителем, с полностью и наполовину дублированными средствами передачи, с коммутацией цепей и коммутацией пакетов.

SDLC идентифицирует два типа сетевых узлов:

Первичный
Управляет работой других станций (называемых вторичными). Первичный узел опрашивает вторичные в заранее заданном порядке. После этого вторичные узлы могут передавать, если у них имеются исходящие данные. Первичный узел также устанавливает каналы и завершает их работу, и управляет каналом во время его функционирования.
Вторичные
Управляются первичным узлом. Вторичные узлы могут только отсылать информацию в первичный узел, но не могут делать этого без получения разрешения от первичного узла.

Первичные и вторичные узды SDLC могут быть соединены в соответствии со следующими четырьмя основными конфигурациями:

Point-to-point (двухточечная).
Предполагает только два узла: один первичный и один вторичный.
Multipoint (многоточечная).
Включает в себя один первичный и множество вторичных узлов.
Loop (контур).
Подразумевает топологию контура, когда первичный узел соединяется с первым и последним вторичными узлами. Промежуточные вторичные узлы, отвечая на запросы первичного узла, передают сообщения друг через друга.
Hub go-ahead (готовый вперед).
Предполагает наличие входного и выходного каналов. Первичный узел использует выходной канал для связи со вторичными узлами. Вторичные узлы используют входной канал для связи в первичным. Входной канал соединяется с первичным узлом через каждый вторичный по схеме гирляндной цепи.

Форматы блока данных

Формат блока данных SDLC представлен на Рис. 12-1.

Как видно из рисунка, блоки данных SDLC ограничены уникальной структурой "флага" (flag). Поле "адрес" (address) всегда содержит адрес вторичного узла, задействованного в текущей связи. Т.к. первичный узел является либо источником связи, либо пунктом назначения, нет необходимости включать его адрес - он заранее известен всем вторичным узлам.

"Управляющее" (control) поле использует три разных формата в зависимости от использованного типа блока данных SDLC. Описание трех типов блока данных SDLC дается ниже в следующем перечне:

Информационные блоки данных (Information (I) frames).
Эти блоки данных содержат информацию высших уровней и определенную управляющую информацию (необходимую для работы с полным дублированием). Номера последовательностей отправки и приема и бит "опроса последнего" (P/F) выполняют функции управления потоком информации и неисправностями. Номер последовательности отправки (send sequence number) относится к номеру блока данных, который должен быть отправлен следующим. Номер последовательности приема (receive sequence number) обеспечивает номер блока данных, который должен быть принят следующим. При полностью дублированном диалоге как отправитель, так и получатель хранят номера последовательностей отправки и приема. Первичный узел использует бит P/F, чтобы сообщить вторичному узлу, требует он от него немедленно ответного сигнала или нет. Вторичный узел использует этот бит для того, чтобы сообщить первичному, является текущий блок данных последним или нет в текущей ответной реакции данного вторичного узла.
Блоки данных супервизора (Supervisory (S) frames).
Эти блоки данных обеспечивают управляющую информацию. У них нет информационного поля. Блоки данных супервизора запрашивают и приостанавливают передачу, сообщают о состоянии и подтверждают прием блоков данных "I".
Непронумерованные блоки банных (Unnumbered (U) frames).
Как видно из названия, эти блоки данных неупорядочены. Они могут иметь информационное поле. Блоки данных "U" используются для управляющих целей. Например, они могут определять одно- или двубайтовое поле управления, инициализировать вторичные узлы и выполнять другие аналогичные функции.

Последовательность проверки блока данных (frame check sequence) (FCS) предшествует ограничителю завершающего флага. FCS обычно является остатком расчета "проверки при помощи циклического избыточного кода" (cyclic redundency check) (CRC). Расчет CRC выполняется повторно получателем. Если результат отличается от значения, содержащегося в блоке данных отправителя, считается, что имеет место ошибка.

Типичная конфигурация сети, базирующейся на SDLC, представлена на Рис. 12-2. Как показано на рисунке, контроллер организации связи IBM (раньше называвшийся групповым контроллером) на отдаленном пункте подключен к "немым" терминалам и к сети Token Ring. На местном вычислительном центре главная вычислительная машина IBM подключена (через оборудование подключения каналов) к фронтальному процессору (FEP), который может также иметь связи с местными локальными сетями Token Ring и стержнем SNA. Оба пункта соединены с помощью арендуемой, базирующейся на SDLC, 56-Kb/сек линии.

Производные протоколы

Несмотря на то, что в HDLC не вoшли несколько характеристик, используемых в SDLC, он повсеместно считается некой суперразновидностью SDLC, совместимой с ним. LAP считается подразновидностью HDLC. LAPB был разработан, чтобы обеспечить продолжение совместимости с HDLC, который был изменен в начале 1980 гг. IEEE 802.2 является модификацией HDLC для окружений LAN.

HDLC

Формат блока данных HDLC такой же, как у SDLC; поля HDLC обеспечивают те же функциональные возможности, что и соответствующие поля SDLC. Кроме того, также, как и SDLC, HDLC обеспечивает синхронный режим работы с полным дублированием.

HDLC имеет несколько незначительных отличий от SDLC. Во-первых, HDLC имеет вариант для 32-х битовых контрольных сумм. Во-вторых, в отличие от SDLC, HDLC не обеспечивает конфигурации "loop" и "hub go-ahead". Главным различием между HDLC и SDLC является то, что SDLC обеспечивает только один режим передачи, в то время как HDLC обеспечивает три. HDLC обеспечивает следующие три режима передачи:

Режим нормальной ответной реакции (NRM)
SDLC также использует этот режим. В этом режиме вторичные узлы не могут иметь связи с первичным узлом до тех пор, пока первичный узел не даст разрешения.
Режим асинхронной ответной реакции (ARM)
Этот режим передачи позволяет вторичным узлам инициировать связь с первичным узлом без получения разрешения.
Асинхронный сбалансированный режим (ABM)
В режиме АВМ появляется "комбинированный" узел, который, в зависимости от ситуации, может действовать как первичный или как вторичный узел. Все связи режима АВМ имеют место между множеством комбинированных узлов. В окружениях АВМ любая комбинированная станция может инициировать передачу данных без получения разрешения от каких-либо других станций.

LAPB

LAPB является наиболее популярным протоколом благодаря тому, что он входит в комплект протоколов Х.25. Формат и типы блока данных, а также функции поля у LAPB те же самые, что у SDLC и HDLC. Однако в отличие от любого из этих двух протоколов, LAPB обеспечивает только один режим передачи ABM, поэтому он подходит только для комбинированных станций. Кроме того, цепи LAPB могут быть организованы либо терминальным оборудованием (DTE), либо оборудованием завершения действия информационной цепи (DCE). Станция, инициирующая обращение, определяется как первичная, в то время как реагирующая станция считается вторичной. И наконец, использование протоколом LAPB бита P/F несколько отличается от его использования другими протоколами. Подробности смотри в Главе 13 "Х.25".

IEEE802.2

IEEE 802.2 часто называют Logical Link Control (LLC) (Управление логическим каналом связи). Он чрезвычайно популярен в окружениях LAN, где он взаимодействует с такими протоколами, как IEEE 802.3, IEEE 802.4 и IEEE 802.5.

IEEE 802.2 предлагает три типа услуг. Тип 1 обеспечивает услуги без установления соединения и подтверждения о приеме. Тип 2 обеспечивает услуги с установлением соединения. Тип 3 обеспечивает услуги без установления соединения с подтверждением о приеме.

Являясь обслуживанием без установления соединения и подтверждения о приеме, Тип 1 LLC не подтверждает передачу данных. Т.к. большое число протоколов верхнего уровня, таких как Transmissin Control Protocol/ Internet Protocol (ТCP/IP), обеспечивают надежную передачу информации, которая может компенсировать недостаточную надежность протоколов низших уровней, Тип 1 является широко используемой услугой.

Обслуживание Типа 2 LLC (часто называемое LLC2) организует виртуальные цепи между отправителем и получателем и, следовательно, является обслуживанием с установлением соединения. LLC2 подтверждает получение информации; оно используется в системах связи IBM.

Обеспечивая передачу данных с подтверждением, обслуживание Типа 3 LLC не организует виртуальных цепей. Являясь компромиссом между двумя другими услугами LLC, Тип 3 LLC бывает полезным в окружениях фабричных автоматизированных систем, где обнаружение ошибок очень важно, однако область памяти контекста (для виртуальных цепей) чрезвычайно ограничена.

Конечные станции могут обеспечить множество типов услуг LLC. Устройство Класса 1 обеспечивает только услуги Типа 1. Устройство Класса II обеспечивает как услуги Типа 1, так и услуги Типа 2. Устройства Класса III обеспечивает услуги Типа 1 и Типа 3, в то время как устройства Класса IV обеспечивают все три типа услуг.

Процессы высших уровней используют услуги IEEE 802.2 через "точки доступа к услугам" (SAP). Заголовок IEEE 802.2 начинается с поля "точки доступа к услугам пункта назначения" (DSAP), которое идентифицирует принимающий процесс высшего уровня. Другими словами, после того, как реализация IEEE 802.2 принимающего узла завершит свою обработку, процесс высшего уровня, идентифицированный в поле DSAP, принимает оставшиеся данные. За адресом DSAP следует адрес "точки доступа к услугам источника" (SSAP), который идентифицирует передающий процесс высшего уровня.


Глава 13. X25.

  • Основы технологии
  • Формат блока данных
    • Уровень 3
    • Уровень 2
    • Уровень 1

Библиографическая справка

В середине-конце 1970 гг. потребовался определенный набор протоколов, чтобы обеспечить пользователям связность глобальной сети с общедоступными сетями передачи данных (PDN). Сети PDN, такие как TELENET и TYMNET, добились замечательного успеха, однако было ясно, что стандартизация протоколов еще больше увеличит число абонентов PDN за счет возросшей совместимости оборудования и более низких цен. Результатом последующих усилий по разработке в этом направлении была группа протоколов, самым популярным из которых является Х.25.

Протокол Х.25 (официально называемый CCITT Recommendation X.25 - "Рекомендация "Х.25 CCITT) был разработан компаниями общественных линий связи (в основном телефонными компаниями), а не каким-то отдельным коммерческим предприятием. Поэтому спецификация разработана так, чтобы обеспечить хорошую работоспособность независимо от типа системы пользователя или изготовителя. Пользователи заключают контракты с общедоступными сетями передачи данных, чтобы пользоваться их сетями с коммутацией пакетов (PSN), и им пред'является счет в зависимости от времени пользования PDN. Предлагаемые услуги (и взимаемая плата) регулируются Федеральной Комиссией по Связи (FCC).

Oдним из уникальных свойств Х.25 является его международный характер. Х.25 и связанными с ним протоколами управляет одно из агентств Организации Об'единненых Наций, называемое "Международный Союз по Телекоммуникациям (ITU). Комитет ITU, ответственный за передачу голоса и данных, называется Международным консультативным комитетом по телеграфии и телефонии (CCITT). Членами CCITT являются FCC, Европейские PTT, общедоступные сети передачи данных и множество компаний, занимающихся компьютерами и передачей данных. То, что Х.25 стал стандартом подлинно глобального значения, является прямым следствием присущих ему свойств.

Основы технологии

Х.25 определяет характеристики телефонной сети для передачи данных. Чтобы начать связь, один компьютер обращается к другому с запросом о сеансе связи. Вызванный компьютер может принять или отклонить связь. Если вызов принят, то обе системы могут начать передачу информации с полным дублированием. Любая сторoнa может в любой момент прекратить связь.

Спецификация Х.25 определяет двухточечное взаимодействие между терминальным оборудованием (DTE) и оборудованием завершения действия информационной цепи (DCE). Устройства DTE (терминалы и главные вычислительные машины в аппаратуре пользователя) подключаются к устройствам DCE (модемы, коммутаторы пакетов и другие порты в сеть PDN, обычно расположенные в аппаратуре этой сети), которые соединяются с "коммутаторами переключения пакетов" (packet switching exchange) (PSE или просто switches) и другими DCE внутри PSN и, наконец, к другому устройству DTE. Взаимоотношения между об'ектами сети Х.25 показаны на Рис. 13-1.

DTE может быть терминалом, который не полностью реализует все функциональные возможности Х.25. Такие DTE подключаются к DCE через трансляционное устройство, называемое пакетный ассемблер/дизассемблер - packet assembler/disassembler - (РAD). Действие интерфейса терминал/PAD, услуги, предлагаемые PAD и взаимодействие между PAD и главной вычислительной машиной определены соответственно CCITT Recommendations X.28, X3 и Х.29.

Спецификация Х.25 составляет схемы Уровней 1-3 эталонной модели OSI. Уровень 3 Х.25 описывает форматы пакетов и процедуры обмена пакетами между равноправными об'ектами Уровня 3. Уровень 2 Х.25 реализован Протоколом Link Access Procedure, Balanced (LAPB). LAPB определяет кадрирование пакетов для звена DTE/DCE. Уровень 1 Х.25 определяет электрические и механические процедуры активации и дезактивации физической среды, соединяющей данные DTE и DCE. Это взаимоотношение представлено на Рис. 13-2. Необходимо отметить, что на Уровни 2 и 3 также ссылаются как на стандарты ISO - ISO 7776 (LAPB) и ISO 8208 (пакетный уровень Х.25).

Сквозная передача между устройствами DTE выполняется через двунаправленную связь, называемую виртуальной цепью. Виртуальные цепи позволяют осуществлять связь между различными элементами сети через любое число промежуточных узлов без назначения частей физической среды, что является характерным для физических цепей. Виртуальные цепи могут быть либо перманентными, либо коммутируемыми (временно). Перманентные виртуальные цепи обычно называют PVC; переключаемые виртуальные цепи- SVC. PVC обычно применяются для наиболее часто используемых передач данных, в то время как SVC применяются для спорадических передач данных. Уровень 3 Х.25 отвечает за сквозную передачу, включающую как PVC, так и SVC.

После того, как виртуальная цепь организована, DTE отсылает пакет на другой конец связи путем отправки его в DCE, используя соответствующую виртуальную цепь. DCE просматривает номер виртуальной цепи для определения маршрута этого пакета через сеть Х.25. Протокол Уровня 3 Х.25 осуществляет мультиплексную передачу между всеми DTE, которые обслуживает устройство DCE, расположенное в сети со стороны пункта назначения, в результате чего пакет доставлен к DTE пункта назначения.

Формат блока данных

Блок данных Х.25 состоит из последовательности полей, показанной на Рис. 13-3. Поля Х.25 Уровня 3 образуют пакет Х.25; они состоят из заголовка и данных пользователя. Поля Х.25 Уровня 2 (LAPB) включают в себя поле управления уровнем блока данных и поле адресации, встроенный пакет Уровня 2 и проверочную последовательность блока данных (FCS).

Уровень 3

Заголовок Х.25 Уровня 3 образован из "идентификатора универсального формата" - general format identifier - (GFI), "идентификатора логического канала"- logical channel identifier - (LCI) и "идентификатора типа пакета"- packet type identifier - (PTI). GFI представляет собой 4-х битовое поле, которое указывает на универсальный формат заголовка пакета. LCI представляет собой 12-битовое поле, которое идентифицирует виртуальную цепь. Поле LCI является логически значимым в интерфейсе DTE/DCE. Другими словами, для организации виртуальной цепи PDN соединяет два логических канала, каждый из которых имеет независимый LCI, двумя интерфейсами DTE/DCE. Поле PTI идентифицирует один из 17 типов пакетов Х.25.

Поля адресации в пакетах установления обращения обеспечивают адреса DTE источника и пункта назначения. Они используются для организации виртуальных цепей, включающих передачу Х.25. Recommendation Х.121 CCITT определяет форматы адресов источника и пункта назначения. Адреса Х.121 (называемые также International Data Numbers, или IDN) имеют разную длину, которая может доходить до 14 десятичных знака. Четвертый байт в пакете организации обращения определяет длину адресов DTE источника и назначения. Первые четыре цифры IDN называются "код идентификации сети" - data network identification code - (DNIC). DNIC поделен на две части; первая часть (3 цифры) определяет страну, где находится PSN, вторая часть определяет саму PSN. Остальные цифры называются "номером национального терминала" - national terminal number - (NTN); они используются для идентификации определенного DTE в сети PSN. Формат адреса Х.121 представлен на Рис. 13-4.

Поля адресации, образующие адрес Х.121, необходимы только при использовании SVC, да и то только на время установления обращения. После того, как вызов организован, PSN использует поле LCI заголовка пакета данных для назначения конкретной виртуальную цепь отдаленному DTE.

Х.25 Уровня 3 использует три рабочих процедуры организации виртуальной цепи:

  • Установления обращения
  • Передача данных
  • Раз'единение вызова

Выполнение этих процедур зависит от использованного типа виртуальной цепи. Для PVC Уровень 3 Х.25 всегда находится в режиме передачи данных, т.к. цепь организована перманентно. Если применена SVC, то используются все три процедуры.

Процедура передачи данных зависит от пакетов DATA. Х.25 Уровня 3 сегментирует и подвегает операции "обратный ассеблер" сообщения пользователя, если длина их превышает максимальный размер пакета для данной цепи. Каждому пакету DATA присваивается номер последовательности, поэтому можнo управлять неисправностями и потоком информации через интерфейс DTE/DCE.

Уровень 2

Уровень 2 реализован протоколом LAPB. LAPB позволяет обеим сторонам (DTE и DCE) инициировать связь друг с другом. В процессе передачи информации LAPB контролирует, чтобы блоки данных поступали к приемному устройству в правильной последовательности и без ошибок.

Также, как и аналогичные протоколы канального уровня, LAPB использует три типа форматов блоков данных:

Информационный блок данных ( Information (I) frame ) .
Эти блоки данных содержат информацию высших уровней и определенную управляющую информацию (необходимую для работы с полным дублированием). Номера последовательности отправки и приема и бит опроса конечного (P/F) осуществляют управление информационным потоком и устранением неисправностей. Номер последовательности отправки относится к номеру текущего блока данных. Номер последовательности приема фиксирует номер блока данных, который должен быть принят следующим. В диалоге с полным дублированием как отправитель, так и получатель хранят номера последовательности отправки и приема; она используется для обнаружения и устранения ошибок.
Блоки данных супервизора ( Supervisory (S) frames ) .
Эти блоки данных обеспечивают управляющую информацию. У них нет информационного поля. Блоки данных S запрашивают и приостанавливают передачу, сообщают о состоянии канала и подтверждают прием блоков данных типа I.
Непронумерованные блоки данных ( Unnumbered (U) frames ).
Как видно из названия, эти блоки данных непоследовательны. Они используются для управляющих целей. Например, они могут инициировать связи , используя стандартную или расширяемую организацию окон (modulo 8 versus 128), раз'единять канал, сообщать об ошибках в протоколе, и выполнять другие аналогичные функции.

Блок данных LAPB представлен на Рис. 13-5.

Поле flag ограничивает блок данных LAPB. Чтобы предотвратить появление структуры флага в пределах внутренней части блока данных, используется вставка битов.

Поле address указывает, что содержит блок данных-команду или ответный сигнал. Поле controlобеспечивает дальнейшую квалификацию блоков данных и блоков команд, а также указывает формат блока данных (U, I или S)), функции блока данных (например, receiver ready - "получатель готов", или disconnect- "отключение") и номер последовательности отправки/ приема.

Поле data содержит данные высших уровней. Его размер и формат меняются в зависимости от типа пакета Уровня 3. Максимальная длина этого поля устанавливается соглашением между администратором PSN и абонентом во время оформления абонентства.

Поле FCS обеспечивает целостность передаваемых данных.

Уровень 1

Уровень 1 Х.25 использует протокол физического уровня Х.21 bis, который примерно эквивалентен RS-232-С. Протокол X.21 bis является производным от CCITT Recommendations V24 и V25, которые соответственно идентифицируют цепи межобмена и характеристики электрических сигналов интерфейса DTE/DCE. X.21 bis обеспечивает двухточечные связи, скорости до 19.2 Кб/сек и синхронную передачу с полным дублированием через четырех-проводной носитель. Максимальное расстояние между DTE и DCE -15 метров.


Глава 14. Frame Relay.

  • Основы технологии
  • Дополнения LMI
  • Форматы блока данных
  • Формат сообщений LMI
    • Глобальная адресация
    • Групповая адресация (multicusting)
  • Реализация сети

Библиографическая справка

Frame Relay первоначально замышлялся как протокол для использования в интерфейсах ISDN, и исходные предложения, представленные в CCITT в 1984 г., преследовали эту цель. Была также предпринята работа над Frame Relay в аккредитованном ANSI комитете по стандартам T1S1 в США.

Крупное событие в истории Frame Relay произошло в 1990 г., когда Cisco Systems, StrataCom, Northern Telecom и Digital Equipment Corporation образовали консорциум, чтобы сосредоточить усилия на разработке технологии Frame Relay и ускорить появление изделий Frame Relay, обеспечивающих взаимодействие сетей. Консорциум разработал спецификацию, отвечающую требованиям базового протокола Frame Relay, рассмотренного в T1S1 и CCITT; однако он расширил ее, включив характеристики, обеспечивающие дополнительные возможности для комплексных окружений межсетевого об'единения. Эти дополнения к Frame Relay называют обобщенно local management interface(LMI) (интерфейс управления локальной сетью).

Основы технологии

Frame Relay обеспечивает возможность передачи данных с коммутацией пакетов через интерфейс между устройствами пользователя (например, маршрутизаторами, мостами, главными вычислительными машинами) и оборудованием сети (например, переключающими узлами). Устройства пользователя часто называют терминальным оборудованием (DTE), в то время как сетевое оборудование, которое обеспечивает согласование с DTE, часто называют устройством завершения работы информационной цепи (DCE). Сеть, обеспечивающая интерфейс Frame Relay, может быть либо общедоступная сеть передачи данных и использованием несущей, либо сеть с оборудованием, находящимся в частном владении, которая обслуживает отдельное предприятие.

В роли сетевого интерфейса, Frame Relay является таким же типом протокола, что и Х.25 (смотри Главу 13 "Х.25"). Однако Frame Relay значительно отличается от Х.25 по своим функциональным возможностям и по формату. В частности, Frame Relay является протоколом для линии с большим потоком информации, обеспечивая более высокую производительность и эффективность.

В роли интерфейса между оборудованием пользователя и сети, Frame Relay обеспечивает средства для мультиплексирования большого числа логических информационных диалогов (называемых виртуальными цепями) через один физический канал передачи, которое выполняется с помощью статистики. Это отличает его от систем, использующих только технику временного мультиплексирования (TDM) для поддержания множества информационных потоков. Статистическое мультиплексирование Frame Relay обеспечивает более гибкое и эффективное использование доступной полосы пропускания. Оно может использоваться без применения техники TDM или как дополнительное средство для каналов, уже снабженных системами TDM.

Другой важной характеристикой Frame Relay является то, что она использует новейшие достижения технологии передачи глобальных сетей. Более ранние протоколы WAN, такие как Х.25, были разработаны в то время, когда преобладали аналоговые системы передачи данных и медные носители. Эти каналы передачи данных значительно менее надежны, чем доступные сегодня каналы с волоконно-оптическим носителем и цифровой передачей данных. В таких каналах передачи данных протоколы канального уровня могут предшествовать требующим значительных временных затрат алгоритмам исправления ошибок, оставляя это для выполнения на более высоких уровнях протокола. Следовательно, возможны большие производительность и эффективность без ущерба для целостности информации. Именно эта цель преследовалась при разработке Frame Relay. Он включает в себя алгоритм проверки при помощи циклического избыточного кода (CRC) для обнаружения испорченных битов (из-за чего данные могут быть отвергнуты), но в нем отсутствуют какие-либо механизмы для корректирования испорченных данных средствами протокола (например, путем повторной их передачи на данном уровне протокола).

Другим различием между Frame Relay и Х.25 является отсутствие явно выраженного управления потоком для каждой виртуальной цепи. В настоящее время, когда большинство протоколов высших уровней эффективно выполняют свои собственные алгоритмы управления потоком, необходимость в этой функциональной возможности на канальном уровне уменьшилась. Таким образом, Frame Relay не включает явно выраженных процедур управления потоком, которые являются избыточными для этих процедур в высших уровнях. Вместо этого предусмотрены очень простые механизмы уведомления о перегрузках, позволяющие сети информировать какое-либо устройство пользователя о том, что ресурсы сети находятся близко к состоянию перегрузки. Такое уведомление может предупредить протоколы высших уровней о том, что может понадобиться управление потоком.

Стандарты Current Frame Relay адресованы перманентным виртуальным цепям (PVC), определение конфигурации которых и управление осуществляется административным путем в сети Frame Relay. Был также предложен и другой тип виртуальных цепей - коммутируемые виртуальные цепи (SVC). Протокол ISDN предложен в качестве средства сообщения между DTE и DCE для динамичной организации, завершения и управления цепями SVC. Подробная информацию о ISDN дана в Главе 11 "ISDN". Как T1S1, так и CCITT ведут работу по включению SVС в стандарты Frame Relay.

Дополнения LMI

Помимо базовых функций передачи данных протокола Frame Relay, спецификация консорциума Frame Relay включает дополнения LMI, которые делают задачу поддержания крупных межсетей более легкой. Некоторые из дополнений LMI называют "общими"; считается, что они могут быть реализованы всеми, кто взял на вооружение эту спецификацию. Другие функции LMI называют "факультативными". Ниже приводится следующая краткая сводка о дополнениях LMI:

Сообщения о состоянии виртуальных цепей (общее дополнение).
Обеспечивает связь и синхронизацию между сетью и устройством пользователя, периодически сообщая о существовании новых PVC и ликвидации уже существующих PVC, и в большинстве случаев обеспечивая информацию о целостности PVC. Сообщения о состоянии виртуальных цепей предотвращают отправку информации в"черные дыры", т.е. через PVC, которые больше не существуют.
Многопунктовая адресация (факультативное).
Позволяет отправителю передавать один блок данных, но доставлять его через сеть нескольким получателям. Таким образом, многопунктовая адресация обеспечивает эффективную транспортировку сообщений протокола маршрутизации и процедур резолюции адреса, которые обычно должны быть отосланы одновременно во многие пункты назначения.
Глобальная адресация (факультативное).
Наделяет идентификаторы связи глобальным, а не локальным значением, позволяя их использование для идентификации определенного интерфейса с сетью Frame Relay. Глобальная адресация делает сеть Frame Relay похожей на LAN в терминах адресации; следовательно, протоколы резолюции адреса действуют в Frame Relay точно также, как они работают в LAN.
Простое управление потоком данных (факультативное).
Обеспечивает механизм управления потоком XON/XOFF, который применим ко всему интерфейсу Frame Relay. Он предназначен для тех устройств, высшие уровни которых не могут использовать биты уведомления о перегрузке и которые нуждаются в определенном уровне управления потоком данных.

Форматы блока данных

Формат блока данных изображен на Рис. 14-1. Флаги ( flags ) ограничивают начало и конец блока данных. За открывающими флагами следуют два байта адресной ( address) информации. 10 битов из этих двух байтов составляют идентификацию (ID) фактической цепи (называемую сокращенно DLCI от "data link connection identifier").

Центром заголовка Frame Relay является 10-битовое значение DLCI. Оно идентифицирует ту логическую связь, которая мультиплексируется в физический канал. В базовом режиме адресации (т.е. не расширенном дополнениями LMI), DLCI имеет логическое значение; это означает, что конечные усторойства на двух противоположных концах связи могут использовать различные DLCI для обращения к одной и той же связи. На рис. 14-2 представлен пример использования DLCI при адресации в соответствии с нерасширенным Frame Relay.

Рис. 14-2 предполагает наличие двух цепей PVC: одна между Aтлантой и Лос-Анджелесом, и вторая между Сан Хосе и Питтсбургом. Лос Анджелес может обращаться к своей PVC с Атлантой, используя DLCI=12, в то время как Атланта обращается к этой же самой PVC, используя DLCI=82. Аналогично, Сан Хосе может обращаться к своей PVC с Питтсбургом, используя DLCI=62. Сеть использует внутренние патентованные механизмы поддержания двух логически значимых идентификаторов PVC различными.

В конце каждого байта DLCI находится бит расширенного адреса (ЕА). Если этот бит единица, то текущий байт является последним байтом DLCI. В настоящее время все реализации используют двубайтовый DLCI, но присутствие битов ЕА означает, что может быть достигнуто соглашение об использовании в будущем более длинных DLCI.

Бит C/R, следующий за самым значащим байтом DLCI, в настоящее время не используется.

И наконец, три бита в двубайтовом DLCI являются полями, связанными с управлением перегрузкой. Бит "Уведомления о явно выраженной перегрузке в прямом направлении" (FECN) устанавливается сетью Frame Relay в блоке данных для того, чтобы сообщить DTE, принимающему этот блок данных, что на тракте от источника до места назначения имела место перегрузка. Бит "Уведомления о явно выраженной прегрузке в обратном направлении" (BECN) устанавливается сетью Frame Relay в блоках данных, перемещающихся в направлении, противоположном тому, в котором перемещаются блоки данных, встретившие перегруженный тракт. Суть этих битов заключается в том, что показания FECN или BECN могут быть продвинуты в какой-нибудь протокол высшего уровня, который может предпринять соответствующие действия по управлению потоком. (Биты FECN полезны для протоколов высших уровней, которые используют управление потоком, контролируемым пользователем, в то время как биты BECN являются значащими для тех протоколов, которые зависят от управления потоком, контролируемым источником ("emitter-controlled").

Бит "приемлемости отбрасывания" (DE) устанавливается DTE, чтобы сообщить сети Frame Relay о том, что какой-нибудь блок данных имеет более низшее значение, чем другие блоки данных и должен быть отвергнут раньше других блоков данных в том случае, если сеть начинает испытывать недостаток в ресурсах. Т.е. он представляет собой очень простой механизм приоритетов. Этот бит обычно устанавливается только в том случае, когда сеть перегружена.

Формат сообщений LMI

В предыдущем разделе описан базовый формат протокола Frame Relay для переноса блоков данных пользователя. Разработанная консорциумом спецификация Frame Relay также включает процедуры LMI. Сообщения LMI отправляются в блоках данных, которые характеризуются DLCI, специфичным для LMI (определенным в спецификации консорциума как DLCI=1023). Формат сообщений LMI представлен на Рис. 14-3.

В сообщениях LMI заголовок базового протокола такой же, как в обычных блоках данных. Фактическое сообщение LMI начинается с четырех мандатных байтов, за которыми следует переменное число информационных элементов (IE). Формат и кодирование сообщений LMI базируются на стандарте ANSI T1S1.

Первый из мандатных байтов (unnumbered information indicator-индикатор непронумерованной информации) имеет тот же самый формат, что и индикатор блока непронумерованной информации LAPB (UI) с битом P/F, установленным на нуль. Подробная информация о LAPB дается в разделе "Уровень 2" Главы 13 "Х.25". Следующий байт называют "дискриминатор протокола" (protocol discriminator); он установлен на величину, которая указывает на "LMI". Третий мандатный байт (call reference-ссылка на обращение) всегда заполнен нулями.

Последний мандатный байт является полем "типа сообщения" (message type). Определены два типа сообщений. Сообщения "запрос о состоянии" (status enquiry) позволяют устройствам пользователя делать запросы о состоянии сети. Сообщения "состояние" (status) являются ответом на сообщения-запросы о состоянии. Сообщения "продолжайте работать" (keepalives) (посылаемые через линию связи для подтверждения того, что обе стороны должны продолжать считать связь действующей) и сообщения о состоянии PVC являются примерами таких сообщений; это общие свойства LMI, которые должны быть частью любой реализации, соответствующей спецификации консорциума.

Сообщения о состоянии и запросы о состоянии совместно обеспечивают проверку целостности логического и физического каналов. Эта информация является критичной для окружений маршрутизации, т.к. алгоритмы маршрутизации принимают решения, которые базируются на целостности канала.

За полем типа сообщений следуют несколько IЕ. Каждое IЕ состоит из одно-байтового идентификатора IЕ, поля длины IЕ и одного или более байтов, содержащих фактическую информацию.

Глобальная адресация

В дополнение к общим характеристикам LMI существуют несколько факультативных дополнений LMI, которые чрезвычайно полезны в окружении межсетевого об'единения. Первым важным факультативным дополнением LMI является глобольная адресация. Как уже отмечалось раньше, базовая (недополненная) спецификация Frame Relay обеспечивает только значения поля DLCI, которые идентифицируют цепи PVC с локальным значением. В этом случае отсутствуют адреса, которые идентифицируют сетевые интерфейсы или узлы, подсоединенные к этим интерфейсам. Т.к. эти адреса не существуют, они не могут быть обнаружены с помощью традиционной техники обнаружения и резолюции адреса. Это означает, что при нормальной адресации Frame Relay должны быть составлены статистические карты, чтобы сообщать маршрутизаторам, какие DLCI использовать для обнаружения отдаленного устройства и связанного с ним межсетевого адреса.

Дополнение в виде глобальной адресации позволяет использовать идентификаторы узлов. При использовании этого дополнения значения, вставленные в поле DLCI блока данных, являются глобально значимыми адресами индивидуальных устройств конечного пользователя (например, маршрутизаторов). Реализация данного принципа представлена на Рис.14-4.

Необходимо отметить, что каждый интерфейс, изображенный на Рис.14-4, имеет свой собственный идентификатор. Предположим, что Питтсбург должен отправить блок данных в Сан Хосе. Идентификатором Сан Хосе является число 12, поэтому Питттсбург помещает величину "12" в поле DLCI и отправляет блок данных в сеть Frame Relay. В точке выхода из сети содержимое поля DLSI изменяется сетью на 13, чтобы отразить узел источника блока данных. Т.К. интерфейс каждого маршрутизатора имеет индивидуальную величину, как у идентификатора его узла, отдельные устройства могут быть различимы. Это обеспечивает адаптируемую маршрутизацию в сложных окружениях.

Глобальная адресация обеспечивает значительные преимущества в крупных комплексных об'единенных сетях, т.к. в этом случае маршрутизаторы воспринимают сеть Frame Relay на ее периферии как обычную LAN. Нет никакой необходимости изменять протоколы высших уровней для того, чтобы использовать все преимущества, обеспечиваемые их возможностями.

Групповая адресация (multicusting)

Другой ценной факультативной характеристикой LMI является многопунктовая адресация. Группы многопунктовой адресации обозначаются последовательностью из четырех зарезервированных значений DLCI (от 1019 до 1022). Блоки данных, отправляемые каким-либо устройством, использующим один из этих зарезервированных DLCI, тиражирутся сетью и отправляются во все выходные точки группы с данным обозначением. Дополнение о многопунктовой адресации определяет также сообщения LMI, которые уведомляют устройства пользователя о дополнении, ликвидации и наличиии групп с многопунктовой адресацией.

В сетях, использующих преимущества динамической маршрутизации, маршрутная информация должна обмениваться между большим числом маршрутизаторов. Маршрутные сообщения могут быть эффективно отправлены путем использования блоков данных с DLCI многопунктовой адресации. Это обеспечивает отправку сообщений в конкретные группы маршрутизаторов.

Реализация сети

Frame Relay может быть использована в качестве интерфейса к услугам либо общедоступной сети со своей несущей, либо сети с оборудованием, находящимся в частном владении. Обычным способом реализации частной сети является дополнение традиционных мультиплексоров Т1 интерфейсами Frame Relay для информационных устройств, а также интерфейсами (не являющимися специализированными интерфейсами Frame Relay) для других прикладных задач, таких как передача голоса и проведение видео-телеконференций. На Рис. 14-5 "Гибридная сеть Frame Relay" представлена такая конфигурация сети.

Обслуживание общедоступной сетью Frame Relay разворачивается путем размещения коммутирующего оборудования Frame Relay в центральных офисах (CO) телекоммуникационной линии. В этом случае пользователи могут реализовать экономические выгоды от тарифов начислений за пользование услугами, чувствительных к трафику, и освобождены от работы по администрированию, поддержанию и обслуживанию оборудования сети.

Для любого типа сети линии, подключающие устройства пользователя к оборудованию сети, могут работать на скорости, выбранной из широкого диапазона скоростей передачи информации. Типичными являются скорости в диапазоне от 56 Kb/сек до 2 Mb/сек, хотя технология Frame Relay может обеспечивать также и более низкие и более высокие скорости. Ожидается, что в скором времени будут доступны реализации, способные оперировать каналами связи с пропускной способностью свыше 45 Mb/сек (DS3).

Как в общедоступной, так и в частной сети факт обеспечения устройств пользователя интерфейсами Frame Relay не является обязательным условием того, что между сетевыми устройствами используется протокол Frame Relay. В настоящее время не существует стандартов на оборудование межсоединений внутри сети Frame Relay. Таким образом, могут быть использованы традиционные технологии коммутации цепей, коммутации пакетов, или гибридные методы, комбинирующие эти технологии.


Глава 15. SMDS.

  • Основы технологии
  • Адресация
  • Классы доступа
  • Протокол интерфейса SMDS (SIP)
    • Конфигурация CPE
    • Уровни SIP
  • Реализация сети

Библиографическая справка

Switched Multimegabit Data Service (SMDS) (Служба коммутации данных мультимегабитного диапазона) является службой дейтаграмм с коммутацией пакетов, предназначенной для высокоскоростных информационных сообщений глобальных сетей. Обеспечивая пропускную способность , которая первоначально будет находиться в диапазоне от 1 до 34 Mg/сек, SMDS в настоящее время начинает повсеместно использоваться в общедоступных сетях передачи данных коммерческими сетями связи в результате реакции на две тенденции. Первая из них-это пролиферация обработки распределенных данных и других прикладных задач, для реализации которых необходимы высокопроизводительные об'единенные сети. Второй тенденцией является уменьшающаюся стоимость и высокий потенциал полосы пропускания волоконно-оптического носителя, обеспечивающие жизнеспосособность таких прикладных задач при их использовании в глобальных сетях.

SMDS описана в серии спецификаций, выпущенных Bell Communications Reseach (Bellcore) и принятых поставщиками оборудования для телекоммуникаций и коммерческими сетями связи. Одна из этих спецификаций описывает SMDS Interface Protocol (SIP) (Протокол интерфейса SMDS), который является протоколом согласования между устройством пользователя (называемым также customer premises equipment- CPE - оборудованием в помещении заказчика) и оборудованием сети SMDS. SIP базируется на стандартном протоколе IEEE для сетей крупных городов (MAN), т.е. на стандарте IEEE 802.6 Distribuited Queue Dual bus (DQDB) (Дублированная шина очередей к распределенной базе данных). При применении этого протокола устройства CPE, такие как роутеры, могут быть подключены к сети SMDS и пользоваться обслуживанием SMDS для высокоскоростных об'единенных сетей.

Основы технологии

На рис.15-1 изображен сценарий межсетевого об'единения с использованием SMDS. Как показано на рисунке, доступ к SMDS обеспечивается либо через средства передачи с пропускной способностью 1.544-Mgps (DS-1 или Digital Signal 1), либо через средства передачи с пропускной способностью 44.736-Mgps (DS-3 или Digital Signal 3). Несмотря на то, что SMDS обычно описывается как обслуживание, базирующееся на волоконно-оптических носителях, доступ DS-1 может быть обеспечен либо через волоконно-оптический, либо через базирующийся на меди носитель с достаточно хорошими показателями характеристики погрешностей. Пункт разграничения между сетью SMDS частной компании- владельца сети связи и оборудованием клиента называется интерфейсом абонент/сеть (SNI).

Единицы данных SMDS могут содержать в себе до 9,188 восьмибитовых байтов информации пользователя. Следовательно, SMDS способен формировать все пакеты данных IEEE 802.3, IEEE 802.4, IEEE 802.5 и FDDI. Большой размер пакета согласуется с задачами высокоскоростного обслуживания.

Адресация

Как и у других дейтаграммных протоколов, единицы данных SMDS несут адрес как источника, так и пункта назначения. Получатель единицы данных может использовать адрес источника для возврата данных отправителю и для выполнения таких функций, как разрешение адреса (отыскание соответствия между адресами высших уровней и адресами SMDS). Адреса SMDS являются 10-значными адресами, напоминающими обычные телефонные номера.

Кроме того, SMDS обеспечивает групповые адреса, которые позволяют отправлять одну информационную единицу, которая затем доставляется сетью нескольким получателям. Групповая адресация аналогична многопунктовой адресации в локальных сетях и является ценной характеристикой для прикладных задач об'единенных сетей, где она широко используется для маршрутизации, разрешения адреса и динамического нахождения ресурсов сети (таких, как служебные файловые процессоры).

SMDS обеспечивает несколько других характеристик адресации. Адреса источников подтверждаются сетью для проверки законности назначения рассматриваемого адреса тому SNI, который является его источником. Таким образом пользователи защищаются от обманного присвоения адреса (address spoofing), когда какой-нибудь отправитель выдает себя за другого отправителя. Возможна также отбраковка (экранирование) адресов источника и пункта назначения. Отбраковка адресов источника производится в тот момент, когда информационнные единицы уходят из сети, в то время как отбраковка адресов пункта назначения производится в момент входа информационных единиц в сеть. Если адреса не являются разрешенными адресами, то доставка информационной единицы не производится. При наличии адресного экранирования абонент может организовать собственную виртуальную цепь, которая исключает ненужный трафик. Это обеспечивает абоненту экран для защиты исходных данных и способствует повышению эффективности, т.к. устройствам, подключенным к SMDS, не обязательно тратить ресурсы на обработку ненужного трафика.

Классы доступа

Чтобы приспособиться к широкому диапазону требований трафика и возможностей оборудования, SMDS обеспечивает ряд классов доступа. Различные классы доступа определяют различные максимальные поддерживаемые скорости передачи информации, а также допустимую степень разбивки при отправке пакетов в сеть SMDS.

В интерфейсах скоростей DS-3 классы доступа реализуются через алгоритмы управления разрешением на передачу очередного пакета данных. Эти алгоритмы отслеживают равновесие разрешений на передачу очередного пакета данных для каждого интерфейса заказчика. Разрешения даются на основе принципа периодичности, вплоть до определенного максимума. Затем баланс разрешений декрементируется по мере отсылки пакетов в сеть.

Работа схемы управления разрешением на передачу очередного пакета в значительной степени ограничивает работу оборудования заказчика до некоторой поддерживаемой, или средней скорости передачи информации. Эта средняя скорость передачи меньше пропускной способности устройства доступа DS-3 при полной информационной загрузке. Для интерфейса доступа DS-3 обеспечиваются 5 классов доступа, соответствующих средним скоростям передачи информации 4, 10, 16, 25 и 34 Mb/сек. Схема управления разрешением на передачу непригодна для интерфейсов доступа со скоростями DS-1.

Протокол интерфейса SMDS (SIP)

Доступ к сети SMDS осуществляется через SIP. SIP базируется на протоколе DQDB, определяемом стандартом IEEE 802.6 MAN. Протокол DQDB определяет схему управления доступом к носителю, которая позволяет об'единять между собой множество систем через две однонаправленные логические шины.

В соответствии с IEEE 802.6, стандарт DQDB может быть использован для построения частных, базирующихся на волоконно-оптических носителях сетей MAN, поддерживающих различные прикладные задачи, в том числе передачу данных, голоса и видеосигналов. Этот протокол был выбран в качестве базиса для SIP по той причине, что это был открытый стандарт, который мог обеспечить все характеристики обслуживания SMDS и совместимость со стандартами передачи для коммерческих линий связи, а также с новыми стандартами для Broadband ISDN (BISDN). По мере совершенствования и распространения технологии BISDN, коммерческие линии связи собираются обеспечить не только SMDN, но также и широкополосное видео и речевое обслуживание.

Для сопряжения с сетями SMDS необходима только часть протокола IEEE 802.6, касающаяся передачи данных без установления соединения. Поэтому SIP не определяет поддержку применений, связанных с передачей голоса или видеосигналов.

Если протокол DQDB используется для получения доступа к сети SMDS, то результатом его работы является "доступ DQDB" (access DQDB). Термин "доступ DQDB" отличает работу протокола DQDB в интерфейсе SNI от его работы в других окружениях (таких, как внутри сети SMDS). Один переключатель в сети SMDS воздействует на доступ DQDB как одна станция, в то время как оборудование заказчика воздействует на доступ DQDB как одна или более станций.

Т.к. протокол DQDB предназначался для поддержки информационных и неинформационных систем, а также потому, что это протокол управления коллективным доступом к среде, он является относительно сложным протоколом. Он состоит из двух частей:

  • Синтаксиса протокола
  • Алгоритма распределенного доступа с организацией очереди, который назначает управление коллективным доступом к носителю

Конфигурация CPE

Существуют две возможные конфигурации оборудования СРЕ для получения доступа DQDB к сети SMDS (смотри рис.15-2). При конфигурации с одним СРЕ доступ DQDB просто соединяет переключатель в коммерческой сети и одну станцию, принадлежащую абоненту (СРЕ). Для конфигурации с большим числом СРЕ, доступ DQDB состоит из переключателя в сети и множества об'единенных СРЕ в местоположении абонента. Для второй конфигурации, все СРЕ должны принадлежать одному и тому же абоненту.

Для случая с одним СРЕ, доступ DQDB фактически представляет собой просто подсеть DQDB из двух узлов. Каждый из этих узлов (переключатель и СРЕ) передают данные другому через однонаправленную логическую шину. Конкуренция на получение этой шины отсутствует, т.к. других станций нет. Поэтому нет необходимости использовать алгоритм распределенного доступа с организацией очереди. При отсутствии той сложности, которую создает применение алгоритма распределенного доступа с организацией очереди, SIP для конфигурации с одним СРЕ намного проще, чем SIP для конфигурации с большим числом СРЕ.

Уровни SIP

SIP может быть логически разделен на 3 уровня, как это показано на Рис. 15-3 "Формирование пакета данных пользователя уровнями SIP".

Уровень 3

Задачи, выполняемые уровнем 3 SIP, включают в себя формирование пакета "единиц данных обслуживания SMDS" (service data units(SDU)) в заголовке и концевике уровня 3. Затем "eдиницы данных протокола" (protocol data units (PDU)) разбиваются на PDU уровня 2 таким образом, чтобы соответствовать спецификациям уровня 2.

PDU уровня 3 SIP достаточно сложна. Она изображена на Рис. 15-4.

Поля на рисунке, помеченные знаком Х+, не используются средствами SMDS; они присутствуют в протоколе для того, чтобы обеспечить выравнивание формата SIP с форматом протокола DQDB. Значения, помещенные в этих полях оборудованием CPE, должны быть доставлены сетью в неизмененном виде.

Два резервных поля (reserved) должны быть заполнены нулями. Два поля BEtag содержат идентичные значения и используются для формирования связи между первым и последним сегментами, или "единицами данных протокола" (PDU) уровня 2 одной из PDU уровня 3 SIP. Эти поля могут быть использованы для определения условия, при котором как последний сегмент одной PDU уровня 3, так и первый сегмент следующей PDU уровня 3 потеряны, что приводит к приему неисправной PDU уровня 3.

Адреса пункта назначения (destination) и источника (source) состоят из двух частей: типа адреса (address type) и адреса (address). Тип адреса для обоих случаев занимает четыре наиболее значимых бита данного поля. Если адрес является адресом пункта назначения, то тип адреса может представлять собой либо "1100", либо "1110". Первое значение обозначает 60-битовый индивидуальный адрес, в то время как второе значение обозначает 60-битовый групповой адрес. Если адрес является адресом истрочника, то поле типа адреса может означать только индивидуальный адрес.

Bellcore Technical Advisories (Техническое Консультативное Заключение Bellcore) определяет, каким образом у адресов, формат которых согласуется с North American Numbering Plan(NANP), должны быть закодированы адресные поля источника и места назначения. В этом случае четыре наиболее значащих бита каждого из подполей адреса источника и пункта назначения содержат значение "0001", которое является международным кодом страны для Северной Америки. Следующие 40 битов содержат значения 10-значных адресов SMDS, закодированных в двоично-десятичных числах (BCD) и выровненных в соответствии с NANP. Последние 16 битов (наименее значащих) заполнены незначащей информацией (единицами).

Поле "идентификатора протокола высшего уровня" (higher-layer protocol identifier) указывает, какой тип протокола заключен в информационном поле. Это значение является важным для систем, использующим сеть SMDS (таких, как роутеры Cisco), но онo не обрабатывается и не изменяется сетью SMDS.

Поле "длины расширения заголовка" (header extesion length (HEL)) указывает на число 32-битовых слов в поле расширения заголовка. В настоящее время установлен размер этого поля для SMDS, равный 12 байтам. Следовательно, значение HEL всегда "0011".

Поле расширения заголовка (header extension (HE)) в настоящее время определяется как имеющее два назначения. Одно из них - содержать номер версии SMDS, который используется для определения версии протокола. Второе - сообщать о "значении для выбора несущей" (carrier selection value), которое обеспечивает возможность выбирать конкретную несущую межобмена для того, чтобы переносить трафик SMDS из одной локальной коммерческой сети связи в другую. При необходимости в будущем может быть определена другая информация, о которой будет сообщаться в поле расширения заголовка.

Уровень 2

PDU уровня 3 сегментируются на PDU уровня 2 с одинаковым размером (53-восьмибитовых байта), которые часто называют "слотами" (slots) или "секциями" (cells). Формат PDU уровня 2 SIP представлен на Рис. 15-5.

Поле "управления доступом" (access control) PDU уровня 2 SIP содержит различные значения, зависящие от направления информационного потока. Если слот отправлен из переключателя в CPE, то важным является только указание о том, содержит или нет данное PDU информацию. Если слот отправлен из СРЕ в переключатель, и при этом конфигурация представляет собой конфигурацию с несколькими СРЕ, то это поле может также содержать биты запроса, которые обозначают запросы шины для этих слотов, соединяющей переключатель и СРЕ. Дальнейшие подробности об использовании этих битов запроса для реализации управления распределенным доступом к среде с организацией очереди могут быть получены из стандарта IEEE 802.6.

Поле "информации управления сетью" (network control information) может содержать только два возможных значения. Одна из двух конкретных структур битов включается в том случае, если PDU содержит информацию; другая используется , когда она отсутствует.

Поле "типа сегмента" (segment type) указывает, является ли данная PDU уровня 2 начальным, последним или каким-нибудь слотом из середины PDU уровня 3. Значения типов сегмента представлены на Рис. 15-6.

Value | Meaning
00 | Continuation of message (COM)
01 | End of message (EOM)
10 | Beginning of message (BOM)
11 | Single segment message (SSM)

Figure 15-6 Segment Type Values

Поле "идентификатора (ID) сообщения" (message ID) обеспечивает связь PDU уровня 2 с каким-либо PDU уровня 3. ID сообщения одинаково для всех сегментов данного PDU уровня 3. Для доступа DQDB с множеством СРЕ, PDU, выходящие из разных СРЕ, должны иметь разные ID сообщения. Это позволяет сети SMDS, принимающей чередующиеся слоты от различных PDU уровня 3, ассоциировать каждый PDU уровня 2 с соответствующим PDU уровня 3. Следующие друг за другом PDU уровня 3 из одного и того же СРЕ могут иметь идентичные ID сообщения. Это не вносит никакой неопределенности, т.к. любой отдельный СРЕ должен отправить все PDU уровня 2, входящие в какой- либо PDU уровня 3, прежде чем он приступит к отправке PDU уровня 2, принадлежащих к другому PDU уровня 3.

Поле "единицы сегментации" (segmentation unit) является информационной частью PDU. В том случае, когда PDU уровня 2 незаполнена, это поле заполняется нулями.

Поле "длины полезной нагрузки" (payload length) указывает, какое число байтов PDU уровня 3 фактически содержится в поле единицы сегментации. Если данная PDU уровня 2 незаполнена, то это поле также заполняется нулями.

И наконец, поле "CRC полезной нагрузки" (payload CRC) содержит 10-битовое значение "проверки при помощи циклического избыточного кода" (cyclic redundancy check (CRC)), используемое для обнаружения неисправностей в полях типа сегмента, ID сообщений, единицы сегментации, длины полезной нагрузки и CRC полезной нагрузки. Данная проверка CRC не охватывает поля информации управления доступом или управления сетью.

Уровень 1

Уровень 1 SIP обеспечивает протокол физического канала, который действует при скоростях DS-3 или DS-1 между СРЕ и сетью. Уровень 1 SIP разделен на 2 части: подуровень системы передачи (transmission system) и Протокол конвергенции физического уровня (Physical Layer Convergence Protocol (PLCP)). Первая часть определяет характеристики и метод подключения к каналу передачи, т.е. DS-3 или DS-1. Вторая часть определяет, каким образом должны быть организованы PDU уровня 2 или слоты в зависимости от блока данных DS-3 или DS-1, a также часть информации управления.

Т.к. SIP базируется на IEEE 802.6, у него есть преимущество- совместимость с будущими интерфейсами BISDN, которые обеспечат применения, связанные не только с передачей данных, но также и видеосигналов и голоса. Однако ценой обеспечения этой совместимости стали некоторые непроизводительные затраты протокола, которые необходимо учитывать при подсчете общей пропускной способности, которую можно получить при использовании SIP. Общая полоса пропускания через доступ DQDB DS-3, доступная для данных пользователя PDU уровня 3, составляет примерно 34 Mb/сек. Через доступ DS-1 может быть перенесено примерно 1.2 Mb/сек информации пользователя.

Использование протокола "управления доступом к носителю" (МАС) IEEE 802.6 МАN в качестве базиса для SMDS SIP означает, что возможна локальная связь между СРЕ, совместно использующих один и тот же доступ DQDB. Часть этой локальной связи будет видимой для переключателя, обслуживающего SNI, а часть нет. Поэтому переключатель должен использовать адрес пункта назначения единицы данных, чтобы дифференцировать информационные единицы, предназначенные для передач SMDS, и информационные единицы, предназначенные для локальной передачи между несколькими СРЕ, совместно использующими один доступ DQDB.

Реализация сети

Внутри коммерческой сети возможность коммутации пакетов на большой скорости, которая необходима для SMDS, может быть обеспечена применением нескольких различных технологий. В настоящее время в ряд сетей вводятся переключатели, базирующиеся на технологии MAN, например, на стандарте DQDB. Ряд Technical Advisories (Технических консультативных заключений), выпущенных Bellcore, определяют требования стандарта на сетевое оборудование для таких функций, как:

  • Сетевые операции
  • Измерение частоты использования сети для пред'явления счета
  • Интерфейс между локальной коммерческой сетью и отдаленной коммерческой сетью
  • Интерфейс между двумя переключателями в пределах одной и той же коммерческой сети.
  • Управление клиентами сети

Как уже отмечалось, протокол IEEE 802.6 и SIP были специально разработаны так, чтобы соответствовать основному протоколу BISDN, называемому "Режим асинхронной передачи" (АТМ). АТМ и IEEE 802.6 принадлежат к классу протоколов, часто называемых протоколами "быстрой коммутации пакетов" или "реле сегментов" (cell relay). Эти протоколы организуют информацию в небольшие, с фиксированными размерами сегменты (в соответствии с терминологией SIP, это PDU уровня 2). Сегменты с фиксированными размерами могут обрабатываться и коммутироваться в аппаратуре на очень высоких скоростях. Это накладывает жесткие ограничения на характеристики задержки, делая протоколы реле сегментов пригодными для применений, связанных с голосом и видеосигналами. После того, как станет доступным коммутирующее оборудование, базирующееся на АТМ, эта технология также будет внедрена в сети, обеспечивающие SMDS.


Глава 16. AppleTalk.

  • Основы технологии
  • Доступ к среде
  • Сетевой уровень
    • Назначения адреса протокола
    • Сетевые объекты
    • Протокол доставки дейтаграмм (DDP)
    • Протокол поддепжки маршрутной таблицы (RTMP)
  • Транспортный уровень
    • Протокол транзакций AppleTalk (ATP)
    • Протокол потока данных AppleTalk (ADSP)
  • Протоколы высших уровней

Библиографическая справка

В начале 1980 гг. Apple Computer готовилась к выпуску компьютера Macintosh. Инженеры компании знали, что в скором времени сети станут насущной необходимостью, а не просто интересной новинкой. Они хотели также добиться того, чтобы базирующаяся на компьютерах Macintosh сеть была бесшовным расширением интерфейса пользователя Macintosh, совершившим подлинную революцию в этой области. Имея в виду эти два фактора, Apple решила встроить сетевой интерфейс в каждый Macintosh и интегрировать этот интерфейс в окружение настольной вычислительной машины. Новая сетевая архитектура Apple получила название Apple Talk.

Хотя Apple Talk является патентованной сетью, Apple опубликовала характеристики Apple Talk, пытаясь поощрить разработку при участии третьей стороны. В настоящее время большое число компаний успешно сбывают на рынке базирующиеся на Apple Talk изделия; в их числе Novell, Inc. и Мicrosoft Corparation.

Оригинальную реализацию Apple Talk, разработанную для локальных рабочих групп, в настоящее время обычно называют Apple Talk Phase I. Однако после установки свыше 1.5 мил. компьютеров Macintosh в течение первых пяти лет существования этого изделия, Apple обнаружила, что некоторые крупные корпорации превышают встроенные возможности Apple Talk Phase I, поэтому протокол был модернизирован. Расширенные протоколы стали известнны под названием Apple Talk Phase II. Oни расширили возможности маршрутизации Apple Talk, обеспечив их успешное применение в более крупных сетях.

Основы технологии

Apple Talk была разработана как система распределенной сети клиент- сервер. Другими словами, пользователи совместно пользуются сетевыми ресурсами (такими, как файлы и принтеры). Компьютеры, обеспечивающие эти ресурсы, называются служебными устройствами (servers); компьютеры, использующие сетевые ресурсы служебных устройств, называются клиентами (clients). Взаимодействие со служебными устройствами в значительной степени является прозрачным для пользователя, т.к. сам компьютер определяет местоположение запрашиваемого материала и обращается к нему без получения дальнейшей информации от пользователя. В дополнение к простоте использования, распределенные системы также имеют экономические преимущества по сравнению с системами, где все равны, т.к.важные материалы могут быть помещены в нескольких, а не во многих местоположениях.

Apple Talk относительно хорошо согласуется с эталонной моделью OSI. На Рис. 16-1 "Apple Talk и эталонная модель OSI" представлены протоколы Apple Talk, смежные с теми уровнями OSI, с которыми у них установлено соответствие. Этот рисунок отличается от других изображений связи пакета протоколов Apple Talk с моделью OSI тем, что на нем NBP, ZIP и RTMP размещены на Уровне 3, а АЕР-на Уровне 7. По мнению Cisco, NBP, ZIP и RТМP по своим функциональным возможностям стоят в ряду ближе к Уровню 3 модели OSI, хотя они и пользуются услугами DDP, другого протокола Уровня 3. Аналогично, Cisco полагает, что АРЕ следует включить в перечень протоколов прикладного уровня, т.к. он обычно используется для обеспечения функциональных возможностей прикладного уровня. В частности, АЕР помогает определить возможность отдаленных узлов принимать следующие соединения.

Доступ к среде

Apple разработала AppleTalk таким образом, чтобы он был независимым от канального уровня. Другими словами, теоретически он может работать в дополнение к любой реализации канального уровня. Apple обеспечивает различные реализации канального уровня, включая Ethernet, Token Ring, FDDI и LocalTalk. Apple ссылается на AppleTalk, работающий в Ethernet, как нa EtherTalk, в Тоkеn Ring-кaк на TokenTalk и в FDDI-как на FDDITalk. Информация о технических характеристиках Ethernet, TokenRing и FDDI приведена соответственно в главе 5 "Ethernet/IEEE 802.3", главе 6 "Token Ring/IEEE 802.5" и главе 7 "FDDI".

LocalTalk - это запатентованная компанией Apple система доступа к носителю. Он базируется на конкуренции на получение доступа, топологии об'единения с помощью шины и передаче сигналов базовой полосы (baseband signaling) и работает на носителе, представляющим собой экранированную витую пару, со скоростью 230.4 Kb/сек. Физическим интерфейсом является RS-422; это сбалансированный интерфейс для передачи электрических сигналов, поддерживаемый интерфейсом RS-449. Сегменты LocalTalk могут переноситься на расстояния до 300 метров и обеспечивать до 32 узлов.

Сетевой уровень

В данном разделе описываются концепции, принятые для сетевого уровня AppleTalk, и протоколы для этого уровня. В нем рассматриваются назначение адреса протокола, сетевые об'екты и протоколы AppleTalk, которые обеспечивают функциональные возможности Уровня 3 эталонной модели OSI.

Назначения адреса протокола

Для обеспечения минимальных затрат, связанных с работой администратора сети, aдреса узлов AppleTalk назначаются динамично. Когда Macintosh, прогоняющий AppleTalk, начинает работать, он выбирает какой-нибудь адрес протокола (сетевого уровня) и проверяет его, чтобы убедиться, что этот адрес используется в данный момент. Если это не так, то этот новый узел успешно присваивает себе какой-нибудь адрес. Если этот адрес используется в данный момент, то узел с конфликтным адресом отправляет сообщение, указывающее на наличие проблемы, а новый узел выбирает другой адрес и повторяет этот процесс. На Рис. 16-2 представлен процесс выбора адреса AppleTalk.

Фактические механизмы выбора адреса AppleTalk зависят от носителя. Для установления связи адресов AppleTalk с конкретными адресами носителя используется протокoл разрешения адреса AppleTalk (AARP). AARP также устанавливает связи между адресами других протоколов и аппаратными адресами. Если пакет протоколов AppleTalk или любого другой пакет протоколов должен отправить пакет данных в другой сетевой узел, то адрес протокола передается в AARP. AARP сначала проверяет адресный кэш, чтобы определить, является ли уже установленной связь между адресом этого протокола и аппаратным адресом. Если это так, то эта связь передается в запрашивающий пакет протоколов. Если это не так, то AARP инициирует широковещательное или многопунктовое сообщение, запрашивающее об аппаратном адресе данного протокольного адреса. Если широковещательное сообщение доходит до узла с этим протокольным адресом, то этот узел в ответном сообщении указывает свой аппаратный адрес. Эта информация передается в запрашивающий пакет протоколов, который использует этот аппаратный адрес для связи с этим узлом.

Сетевые объекты

AppleTalk идентифицирует несколько сетевых об'ектов. Самым простым является узел (node), который является просто любым устройством, соединенным с сетью AppleTalk. Наиболее распространенными узлами являются компьютеры Macintosh и лазерные принтеры, однако многие другие компьютеры также способны осуществлять связь AppleTalk, в том числе компьютеры IBM PC, Digital Equipment Corparation VAX и различные АРМ. Следующим об'ектом, определяемым AppleTalk, является сеть. Сеть AppleTalk представляет собой просто отдельный логический кабель. Хотя этот логический кабель часто является отдельным физическим кабелем, некоторые вычислительные центры используют мосты для об'единения нескольких физических кабелей. И наконец, зона (zone) АppleTalk является логической группой из нескольких сетей (возможно находящихся далеко друг от друга). Об'екты AppleTalk изображены на Рис. 16-3.

Протокол доставки дейтаграмм (DDP)

Основным протоколом сетевого уровня AppleTalk является протокол DDP. DDP обеспечивает обслуживание без установления соединения между сетевыми гнездами. Гнезда могут назначаться либо статистически, либо динамически. Адреса AppleTalk, назначаемые DDP, состоят из 2 компонентов: 16-битового номера сети (network number) и 8-битового номера узла (node number). Эти два компонента обычно записываются в виде десятичных номеров, разделенных точкой (например, 10.1 означает сеть 10, узел 1). Если номер сети и номер узла дополнены 8-битовым гнездом (socket), обозначающим какой-нибудь особый процесс, то это означает, что в сети задан какой-нибудь уникальный процесс.

AppleTalk Phase II делает различие между нерасширенными (nоnextended) и расширенными (extended) сетями. В нерасширенных сетях, таких как LocalTalk, номер каждого узла AppleTalk уникален. Нерасширенные сети были единственным типом сети, определенным в AppleTalk Phase I. В расширенных сетях, таких как EtherTalk и TokenTalk, уникальной является комбинация номер каждой сети/номер узла.

Зоны определяются управляющим сети AppleTalk в процессе конфигурации роутера. Каждый узел AppleTalk принадлежит к отдельной конкретной зоне. Расширенные сети могут иметь несколько зон, которые ассоциируются с ними. Узлы в расширенных сетях могут принадлежать к любой отдельной зоне, которая ассоциируется с этой расширенной сетью.

Протокол поддепжки маршрутной таблицы (RTMP)

Протокол, который организует и поддерживает маршрутные таблицы AppleTalk, называется Протоколом поддержки маршрутной таблицы (RTMP). Маршрутные таблицы RTMP содержат данные о каждой сети, до которой может дойти дейтаграмма. В эти данные входит порт роутера, который ведет к сети пункта назначения, ID узла следующего роутера, который принимает данный пакет, расстояние до сети назначения, выраженное числом пересылок, и текущее состояние этих данных (хорошее, подозрительное или плохое). Периодический обмен маршрутными таблицами позволяет роутерам об'единенных сетей гарантировать обеспечение непротиворечивой текущей информацией. На Рис. 16-4 представлен образец таблицы RTMP и соответствующая архитектура сети.

Протокол привязки по именам AppleTalk (Name Binding Protocol - NBP) устанавливает связь имен AppleTalk (которые выражаются как об'екты, видимые для сети - network-visible entities, или NVE) с адресами. NVE является адресуемой сетью AppleTalk услугой, такой как гнездо. NVE ассоциируются с более, чем одним именем об'ектов и перечнем атрибутов. Имена об'ектов представляют собой последовательность символов, например такую: printer@net1, в то время как перечень атрибутов определяет характеристики NVE.

Связь между NVE с присвоенными именами и сетевыми адресами устанавливается через процесс привязки имени. Привязка имени может быть произведена в момент запуска узла или динамично, непосредственно перед первым использованием. NBP управляет процессом привязки имени, в который входят регистрация имени, подтверждение имени, стирание имени и поиск имени.

Зоны позволяют проводить поиск имени в группе логически связанных узлов. Чтобы произвести поиск имен в пределах какой-нибудь зоны, отправляется запрос о поиске в местный роутер, который рассылает широковещательный запрос во все сети, которые имеют узлы, принадлежащие заданной зоне. Протокол информации зоны (Zone Information Protocol - ZIP) координирует эти действия.

ZIP поддерживает соответствие номер сети/номер зоны в информационных таблицах зоны (zone information tables-ZIT). ZIT хранятся в роутерах, которые являются основными пользователями ZIP, однако конечные узлы используют ZIP в процессе запуска для выбора своих зон и получения межсетевой информации о зонах. ZIP использует маршрутные таблицы RTMP для отслеживания изменений в топологии сети. Если ZIP находит данные о маршрутной таблице, которох нет в данной ZIT, она образует запись данных о новой ZIT. На Рис. 16-5 представлен образец ZIT.

Network number | Zone
1 | My
2 | Your
3 | Marketing
4 | Documentation
5-5 | Sales

Figure 16-5

Транспортный уровень

Транспортный уровень AppleTalk реализуется двумя основными протоколами AppleTalk: AppleTalk Transaction Protocol (ATP) (Протокол транзакций AppleTalk) и AppleTalk Data Stream Protocol (ADSP) (Протокол потока данных АppleTalk). АТР является транзакционно-ориентированным, в то время как ADSP является ориентированным по потоку данных.

Протокол транзакций AppleTalk (ATP)

ATP является одним из протоколов транспортного уровня Appletalk. АТР пригоден для применений, базирующихся на транзакциях, которые можно встретить в банках или магазинах розничной торговли.

В транзакции АТР входят запросы (от клиентов) (requests) и ответы (от служебных устройств) (replies). Каждая пара запрос/ответ имеет отдельный ID транзакции. Транзакции имеют место между двумя гнездами клиентов. АТР использует транзакции "точно-один раз" (exactly once - XO) и "по крайней мере один раз" (at-least-once - ALO), Транзакции ХО требуются в тех ситуациях, когда случайное выполнение транзакции более одного раза неприемлемо. Банковские транзакциии являются примером таких неидемпотентных (nonidempotent) ситуаций (ситуаций, когда повторение какой-нибудь транзакции вызывает проблемы, что достигается тем, что делаются недействительными данные, участвующие в данной транзакции).

АТР способен выполнять наиболее важные функции транспортного уровня, в том числе подтверждение о приеме данных и повторную передачу, установление последовательности пакетов, а также фрагментирование и повторную сборку. АТР ограничивает сегментирование сообщений до 8 пакетов; пакеты АТР не могут содержать более 578 информационных байтов.

Протокол потока данных AppleTalk (ADSP)

ADSP является другим важным протоколом транспортного уровня Apple Talk. Как видно из его названия, ADSP является ориентированным по потоку данных, а не по транзакциям. Он организует и поддерживает полностью дублированный поток данных между двумя гнездами в об'единенной сети AppleTalk.

ADSP является надежным протоколом в том плане, что он гарантирует доставку байтов в том же порядке, в каком они были отправлены, а также то, что они не будут дублированы. ADSP нумерует каждый байт, чтобы отслеживать отдельные элементы потока данных.

ADSP также определяет механизм управления потоком. Пункт назначения может в значительной степени замедлять передачи источника путем сокращения размера об'явленного окна на прием.

ADSP также обеспечивает механизм сообщений управления "выхода из полосы" (out-of-band) между двумя об'ектами AppleTalk. В качестве средства для перемещения сообщений управления выхода из полосы между двумя об'ектами AppleTalk используются пакеты "внимания" (attention packets).Эти пакеты используют отдельный поток номеров последовательностей, чтобы можно было отличать их от обычных пакетов данных ADSP.

Протоколы высших уровней

AppleTalk обеспечивает несколько протоколов высшего уровня. Протокол сеансов AppleTalk ( AppleTalk Session Protocol - ASP) организует и поддерживает сеансы (логические диалоги) между клиентом AppleTalk и служебным устройством. Протокол доступа к принтеру ( Printer Access Protocol- РАР) AppleTalk является ориентированным по связи протоколом, который организует и поддерживает связи между клиентами и служебными устройствами (использование термина printer в заголовке этого протокола является просто исторической традицией). Эхо-протокол AppleTalk (AppleTalk Echo Protocol- AEP) является очень простым протоколом, генерирующим пакеты, которые могут быть использованы для проверки способности различных узлов сети создавать повторное эхо. И наконец, Протокол ведения картотеки AppleTalk (AppleTalk Filing Protocol - AFP) помогает клиентам коллективно использовать служебные файлы в сети.


Глава 17. DECnet.

  • Архитектура цифровой сети (DNA)
  • Доступ к среде
  • Сетевой уровень
    • Формат длока данных маршрутизации DECnet Phase IV
    • Адресация
    • Уровни маршрутизации
  • Транспортный уровень

Библиографическая справка

Digital Equipment Corporation (Digital) разработала семейство протоколов DECnet с целью обеспечения своих компьютеров рациональным способом сообщения друг с другом. Выпущенная в 1975 г. первая версия DECnet обеспечивала возможность сообщения двух напрямую подключенных миникомпьютеров PDP-11. В последние годы Digital включила подддержку для непатентованных протоколов, однако DECnet попрежнему остается наиболее важным из сетевых изделий, предлагаемых Digital.

В настоящее время выпущена пятая версия основного изделия DECnet ( которую иногда называют Phase V, a в литературе компании Digital - DECnet/OSI). DECnet Phase V представляет собой надлежащим образом расширенный набор комплекта протоколов OSI, поддерживающий все протоколы OSI, а также несколько других патентованных и стандартных протоколов, которые поддерживались предыдущими версиями DECnet. Что касается ранее внесенных изменений в протокол, DECnet Phase V совместим с предыдущей версией (т.е. Phase IV).

Архитектура цифровой сети (DNA)

В противоположность бытующему мнению, DECnet вовсе не является архитектурой сети, а представляет собой ряд изделий, соответсвующих Архитектуре Цифровой сети ( Digital Network Architecture - DNA) компании Digital. Как и большинство других сложных сетевых архитектур, поставляемых крупными поставщиками систем, DNA поддерживает большой набор как патентованных, так и стандартных протоколов. Перечень технологий, которые поддерживает DNA, постоянно растет по мере того, как Digital реализует новые протоколы. Рис. 17-1 иллюстрирует неполную картину DNA и связь некоторых ее компонентов с эталонной моделью OSI.

Доступ к среде

Как видно из Рис. 17-1, DNA поддерживает различные реализации физического и канального уровней. Среди них такие известные стандарты, как Ethernet, Token Ring, Fiber Distributed Data Interface (FDDI), IEEE 802..2 и Х.25. Подробная информация об этих протоколах дается в Главе 5 "Ethernet/IEEE 802.3", Главе 6 "Token Ring/IEEE 802.5", Главе 7 "FDDI", Главе 12 "SDLC и его производные" и Главе 13 "X.25". DNA также предлагает протокол канального уровня для традиционного двухточечного соединения, который называется Digital Data Communications Message Protocol (DDCMP) (Протокол сообщений цифровой связи) и шину с пропускной способностью 70 Mb/sek , используемую для группы абонентов VAX, которая называется Computer-room Interconnect bus (CI bus) (шина межсоединений машинного зала).

Сетевой уровень

DECnet поддерживает сетевые уровни как без установления соединения, так и с установлением соединения. Оба сетевых уровня реализуются протоколами OSI. Реализации без установления соединения используют Connectionless Network Protocol(CLNP) (Протокол сети без установления соединения) и Connectionless Network Service(CLNS) (Услуги сети без установления соединения). Сетевой уровень с установлением соединения использует X.25 Packet-Level Protocol (PLP) (Протокол пакетного уровня), который также известен как X.25 level 3(Уровень 3 Х.25), и Connection-Mode Network Protocol(CMNP) (Протокол сети с установлением соединения). Более подробно эти протоколы OSI описываются в Главе 20 "Протоколы OSI".

Хотя в DECnet Phase V значительная часть DNA была приведена в соответствие с OSI, уже в DECnet Phase IV маршрутизация была очень схожа с маршрутизацией OSI. Маршрутизация DNA Phase V включает в себя маршрутизацию OSI (ES-IS и IS-IS) и постоянную поддержку протокола маршрутизации DECnet Phase IV. ЕS-IS и IS-IS описаны в Главе 28 "Маршрутизация OSI".

Формат длока данных маршрутизации DECnet Phase IV

Протокол маршрутизации DECnet Phase IV имеет несколько отличий от IS-IS. Одно из них-это разница в заголовках протоколов. Заголовок слоя маршрутизации DNA Phase IV приведен на Рис. 17-2; форматы пакетов IS-IS даны в Главе 28 "Маршрутизация OSI".

Первое поле в заголовке маршрутизации DNA Phase IV-это поле флагов маршрутизации (routing flags), которое состоит из:

return-to-sender
бит возврата получателю, если он задан, то указывает, что данный пакет возвращается в источник.
return-to-sender request
бит запроса о возврате получателю, если он задан, то указывает на то, что запрашиваемые пакеты должны быть возвращены в источник, если они не могут быть доставлены в пункт назначения.
intraLAN
бит intraLAN, который устанавливается по умолчанию. Если роутер обнаружит, что две сообщающиеся конечные системы не принадлежат одной и той же подсети, он исключает этот бит.
другие биты, которые обозначают формат заголовка, указывают, применялась ли набивка, и выполняют другие функции.

За полем флагов маршрутизации идут поля узла пункта назначения (destination node) и узла источника (source node), которые обозначают сетевые адреса узлов пункта назначения и узла источника.

Последнее поле в заголовке маршрутизации DNA Phase IV-поле траверсированных узлов ( nodes traversed), которое показывает число узлов, которые пересек пакет на пути к пункту назначения. Это поле обеспечивает реализацию подсчета максимального числа пересылок для того, чтобы можно было удалить из сети вышедшие из употребления пакеты.

DECnet различает два типа узлов: конечные узлы и узлы маршрутизации. Как конечные узлы, так и узлы маршрутизации могут отправлять и принимать информацию, но обеспечивать услуги маршрутизации для других узлов DECnet могут только узлы маршрутизации.

Маршрутные решения DECnet базируются на затратах (cost)-арбитражном показателе, назначаемом администратором сети для использования при сравнении различных путей через среду об'единенной сети. Затраты обычно базируются на числе пересылок, ширине полосы носителя и других показателях. Чем меньше затраты, тем лучше данный тракт. Если в сети имеют место неисправности, то протокол маршрутизации DECnet Phase IV использует значения затрат для повторного вычисления наилучшего мааршрута к каждому пункту назначения. Рис. 17-3 иллюстрирует расчет затрат в среде маршрутизации DECnet Phase IV.

Адресация

Адреса DECnet не связаны с физическими сетями, к которым подключены узлы. Вместо этого DECnet размещает главные вычислительные машины, используя пары адресов область/узел (area/node address). В диапазон значений адресов области входят значения от 1 до 63 (включительно). Адрес узла может иметь значение от 1 до 1023 (включительно). Следовательно, каждая область может иметь 1023 узла, а в сети DECnet адресация может быть произведена примерно к 65,000 узлам. Области могут перекрывать несколько роутеров, и отдельный кабель может обеспечивать несколько областей. Следовательно, если какой-нибудь узел имеет несколько сетевых интерфейсов, то он использует один и тот же адрес область/узел для каждого интерфейса. На Рис. 17-4 "Адреса DECnet" изображен пример сети DECnet с несколькими адресуемыми об'ектами.

Главные вычислительные машины DECnet не используют адреса уровня МАС (Media Access Control - Управлениe доступом к носителю), назначаемые производителем. Вместо этого адреса сетевого уровня встраиваются в адреса уровня МАС в соответствии с алгоритмом, который перемножает номер области на 1024 и прибавляет к результату номер узла. Результирующий 16-битовый десятичный адрес преобразуется в шестнадцатеричное число и добавляется к адресу АА00.0400 таким образом, что байты оказываются переставленными, так что наименее значимый байт оказывается первым. Например, адрес 12.75 DECnet становится числом 12363 (основание 10), которое равняется числу 304В (основание 16). После этого адрес с переставленными байтами добавляется к ставндартному префиксу адреса МАС DECnet; результирующим адресом является выражение АА00.0400.4В30.

Уровни маршрутизации

Узлы маршрутизации DECnet называются либо роутерами Уровня 1, либо роутерами Уровня 2. Роутер Уровня 1 сообщается с конечными узлами и с другими роутерами Уровня 1 в отдельной конкретной области. Роутеры Уровня 2 сообщаются с роутерами Уровня 1 той же самой области и роутерами Уровня 2 других областей. Таким образом, роутеры Уровня 1 и Уровня 2 вместе формируют иерархическую схему маршрутизации. Рассмотренные взаимоотношения иллюстрируются на Рис. 17-5.

Конечные системы отправляют запросы о маршрутах в назначенный роутер Уровня 1. На роль назначенного роутера выбирается роутер Уровня 1 с наивысшим приоритетом. Если два роутера имеют одинаковый приоритет, то назначенным роутером становится тот, который имеет большее число узлов. Конфигурацию приоритета любого роутера можно вибирать ручным способом, вынуждая его на роль назначенного роутера.

Как показано на Рис.17-5, в любой области может быть несколько роутеров Уровня 2. Если роутеру Уровня 1 необходимо отправить пакет за пределы своей области, он направляет этот пакет какому-нибудь роутеру Уровня 2 в этой же области. В некоторых случаях этот роутер Уровня 2 может не иметь оптимального маршрута к пункту назначения, однако конфигурация узловой сети обеспечивает такую степень устойчивости к ошибкам, которая не может быть обеспечена при назначении только одного роутера Уровня 2 на область.

Транспортный уровень

Транспортный уровень DNA реализуется различными протоколами транспортного уровня, как патентованными, так и стандартными. Поддерживаются следующие протоколы транспортного уровня OSI: ТР0, ТР2 и ТР4. Подробное описание этих протоколов дается в Главе 20 "Протоколы OSI".

Принадлежащий Digital Протокол услуг сети ( Network services protocol - NSP) по функциональным возможностям похож на ТР4 тем, что он обеспечивает ориентированное на соединение, с контролируемым потоком обслуживание, с фрагментацией и повторной сборкой сообщений . Обеспечиваются два подканала - один для нормальных данных, второй для срочных данных и информации управления потоком. Обеспечивается два типа управления потоком - простой механизм старт/стоп, при котором получатель сообщает отправителю, когда следует завершать и возобновлять передачу данных, и более сложная техника управления потоком, при которой получатель сообщает отправителю, сколько сообщений он может принять. NSP может также реагировать на уведомления о перегрузке, поступающие из сетевого уровня, путем уменьшения числа невыполненных сообщений, которое он может допустить.


Глава 18. Протоколы Internet

Internetworking Technology Overview.

Глава 18. Протоколы Internet.

  • Библиографическая справка
  • Сетевой уровень
    • Адресация
    • Маршрутизация Internet
    • ICMP
  • Транспортный уровень
    • Протокол управления передачей (TCP)
    • Протокол дейтаграмм пользователя (UDP)
  • Протоколы высших уровней

Библиографическая справка

В середине 1970 гг. Агентство по Внедрению Научно-исследовательских Проектов Передовой технологии при Министерстве обороны (DARPA) заинтересовалось организацией сети с коммутацией пакетов для обеспечения связи между научно-исследовательскими институтами в США. DARPA и другие правительственные организации понимали, какие потенциальные возможности скрыты в технологии сети с коммутацией пакетов; они только что начали сталкиваться с проблемой, с которой сейчас приходится иметь дело практически всем компаниям, а именно с проблемой связи между различными компьютерными системами.

Поставив задачу добиться связности гетерогенных систем, DARPA финансировала исследования, проводимые Стэнфордским университетом и компаниями Bolt, Beranek и Newman (BBN) с целью создания ряда протоколов связи. Результатом этих работ по разработке, завершенных в конце 1970 гг., был комплект протоколов Internet, из которых наиболее известными являются Transmission Control Protocol (TCP) и Internet Protocol (IP).

Протоколы Internet можно использовать для передачи сообщений через любой набор об'единенных между собой сетей. Они в равной мере пригодны для связи как в локальных, так и в глобальных сетях. Комплект протоколов Internet включает в себя не только спецификации низших уровней (такие, как ТСР и IP), но также спецификации для таких общих применений, как почта, эмуляция терминалов и передача файлов. На Рис. 18-1 представлены некоторые из наиболее важных протоколов Internet и их связь с эталонной моделью OSI.

Процесс разработки и выдачи документации протоколов Internet скорее напоминает академический исследовательский проект, чем что-либо другое. Протоколы определяются в документах, называемых Requests for Comments (RFC) (Запросы для Комментария). RFC публикуются, а затем рецензируются и анализируются специалистами по Internet. Уточнения к протоколам публикуются в новых RFC. Взятые вместе, RFC обеспечивают красочную историю людей, компаний и направлений, которые формировали разработку компекта протоколов для открытой системы, который сегодня является самым популярным в мире.

Сетевой уровень

IP является основным протоколом Уровня 3 в комплекте протоколов Internet. В дополнение к маршрутизации в об'единенных сетях, IР обеспечивает фрагментацию и повторную сборку дейтаграмм, а также сообщения об ощибках. Наряду с ТСР, IP представляет основу комплекта протоколов Internet. Формат пакета IP представлен на Рис. 18-2.

Заголовок IР начинается с номера версии (version number), который указывает номер используемой версии IP.

Поле длины заголовка (IHL) обозначает длину заголовка дейтаграммы в 32-битовых словах.

Поле типа услуги (type-of-service) указывает, каким образом должна быть обработана текущая дейтаграмма в соответствии с указаниями конкретного протокола высшего уровня. С помощью этого поля дейтаграммам могут быть назначены различные уровни значимости.

Поле общая длина (total length) определяет длину всего пакета IP в байтах, включая данные и заголовок.

Поле идентификации (identification) содержит целое число, обозначающее текущую дейтаграмму. Это поле используется для соединения фрагментов дейтаграммы.

Поле флагов (flags) (содержащее бит DF, бит MF и сдвиг фрагмента) определяет, может ли быть фрагментирована данная дейтаграмма и является ли текущий фрагмент последним.

Поле срок жизни (time-to-live) поддерживает счетчик, значение которого постепенно уменьшается до нуля; в этот момент дейтаграмма отвергается. Это препятствует зацикливанию пакетов.

Поле протокола (protocol) указывает, какой протокол высшего уровня примет входящие пакеты после завершения обработки IP.

Поле контрольной суммы заголовка (header checksum) помогает обеспечивать целостность заголовка ID.

Поля адресов источника и пункта назначения (source and destination address) oбoзначают отправляющий и принимающий узлы.

Поле опции (options) позволяет IP обеспечивать факультативные возможности, такие, как защита данных.

Поле данных (data) содержит информацию высших уровней.

Адресация

Как и у других протоколов сетевого уровня, схема адресации IP является интегральной по отношению к процессу маршрутизации дейтаграмм IP через об'единенную сеть. Длина адреса IP составляет 32 бита, разделенных на две или три части. Первая часть обозначает адрес сети, вторая (если она имеется) - адрес подсети, и третья - адрес главной вычислительной машины. Адреса подсети присутствуют только в том случае, если администратор сети принял решение о разделении сети на подсети. Длина полей адреса сети, подсети и главной вычислительной машины являются переменными величинами.

Адресация IP обеспечивает пять различных классов сети. Самые крайние левые биты обозначают класс сети.

Class A
Сети класса А предназначены главным образом для использования с несколькими очень крупными сетями, т.к. они обеспечивают всего 7 битов для поля адреса сети.
Class B
Сети класса В выделяют 14 битов для поля адреса сети и 16 битов для поля адреса главной вычислительной машины. Этот класс адреса обеспечивает хороший компромисс между адресным пространством сети и главной вычислительной машины.
Class C
Сети класса С выделяют 22 бита для поля адреса сети. Однако сети класса С обеспечивают только 8 битов для поля адреса главной вычислительной машины, поэтому число главных вычислительных машин, приходящихся на сеть, может стать ограничивающим фактором.
Class D
Адреса класса D резервируются для групп с многопунктовой адресацией (в соответствии с официальным документом RFC 1112). В адресах класса D четыре бита наивысшего порядка устанавливаются на значения 1,1,1 и 0.
Class E
Адреса класса Е также определены IP, но зарезервированы для использования в будущем. В адресах класса Е все четыре бита наивысшего порядка устанавливаются на 1.

Адреса IP записываются в формате десятичного числа с проставленными точками, например, 34.0.0.1. На рис. 18-3 представлены форматы адресов для сетей IP классов А, В и С.

Сети IP могут также быть разделены на более мелкие единицы, называемые подсетями (subnets). Подсети обеспечивают дополнительную гибкость для администратора сети. Например, предположим, что какой-то сети назначен адрес класса В , и что все узлы в сети в данный момент соответствуют формату адреса класса В. Далее предположим, что представлением адреса этой сети в виде десятичного числа с точками является 128.10.0.0. (наличие одних нулей в поле адреса главной вычислительной машины обозначает всю сеть). Вместо того, чтобы изменять все адреса на какой-то другой базовый сетевой номер, администратор может подразделить сеть, воспользовавшись организацией подсетей. Это выполняется путем заимствования битов из части адреса, принадлежащей главной вычислительной машине, и их использования в качестве поля адреса подсети, как показано на Рис. 18-4.

Если администратор сети решил использовать восемь битов для организации подсети, то третья восьмерка адреса IP класса В обеспечивает номер этой подсети. В нашем примере адрес 128.10.0. относится к сети 128.10, подсети 1; адрес 128.10.2.0. относится к сети 128.10, подсети 2, и т.д.

Число битов, занимаемых для адреса подсети, является переменной величиной. Для задания числа используемых битов IP обеспечивает маску подсети. Маски подсети используют тот же формат и технику представления адреса, что и адреса IP. Маски подсети содержат единицы во всех битах, кроме тех, которые определяют поле главной вычислительной машины. Например, маска подсети, которая назначает 8 битов организации подсети для адреса 34.0.0.0. класса А, представляет собой выражение 255.255.0.0. Маска подсети, которая определяет 16 битов организации подсети для адреса 34.0.0.0. класса А, представляется выражением 255.255.255.0. Обе эти маски изображены на Рис. 18-5.

Для некоторых носителей (таких как локальные сети IEEE 802), адреса носителя и адреса IP определяются динамически путем использования двух других составляющих комплекта протоколов Internet: Address Resolution Protocol (ARP) (Протокол разрешения адреса) иReverse Address Resolution Protocol (RARP)(Протокол разрешения обратного адреса). ARP использует широковещательные сообщения для определения аппаратного адреса (уровень МАС), соответствующего конкретному межсетевому адресу. ARP обладает достаточной степенью универсальности, чтобы позволить использование IP с практически любым типом механизма, лежащего в основе доступа к носителю. RARP использует широковещательные сообщения для определения адреса об'единенной сети, связанного с конкретным аппаратным адресом. RARP особенно важен для узлов, не имеющих диска, которые могут не знать своего межсетевого адреса, когда они выполняют начальную загрузку.

Маршрутизация Internet

Устройства маршрутизации в сети Internet традиционно называются шлюзами (gateway), что является очень неудачнным термином, т.к. повсеместно в индустрии сетей этот термин применяют для обозначения устройства с несколько иными функциональными возможностями. Шлюзы (которые мы с этого момента будем называть роутерами) в сети Internet организованы в соответствии с иерархическим принципом. Некоторые роутеры исползуются для перемещения информации через одну конкретную группу сетей, находящихся под одним и тем же административным началом и управлением (такой об'ект называется автономной системой - autonomous system). Роутеры, используемые для обмена информацией в пределах автономных систем, называются внутренними роутерами (interior routers); они используют различные протоколы для внутренних роутеров (interior gateway protocol - IGP) для выполнения этой задачи. Роутеры, которые перемещают информацию между автономными системами, называются внешними роутерами (exterior routers); для этого они используют протоколы для внешних роутеров. Архитектура Internet представлена на Рис. 18-6.

Протоколы маршрутизации IP-это динамичные протоколы. При динамичной маршрутизации (dynamic routing) запросы о маршрутах должны рассчитываться программным обеспечением устройств маршрутизации через определенные интервалы времени. Этот процесс противоположен статической маршрутизации (static routing), при которой маршруты устанавливаются администратором сети и не меняются до тех пор, пока администратор сети не поменяет их. Таблица маршрутизации IP состоит из пар "адрес назначения/следующая пересылка". Образец записи данных, показанный на Рис. 18-7, интерпретируется как имеющий значение "добраться до сети 34.1.0.0. (подсеть 1 сети 34), следующей остановкой является узел с адресом 54.34.23.12."

Маршрутизация IP определяет характер перемещения дейтаграмм IP через об'единенные сети (по одной пересылке за раз). В начале путешествия весь маршрут не известен. Вместо этого на каждой остановке вычисляется следующий пункт назначения путем сопоставления адреса пункта назначения, содержащегося в дейтаграмме, с записью данных в маршрутной таблице текущего узла. Участие каждого узла в процессе маршрутизации состоит только из продвижения пакетов, базируясь только на внутренней информации, вне зависимости от того, насколько успешным будет процесс и достигнет или нет пакет конечного пункта назначения. Другими словами, IP не обеспечивает отправку в источник сообщений о неисправностях, когда имеют место аномалии маршрутизации. Выполнение этой задачи предоставлено другому протоколу Internet, а именно Протоколу управляющих сообщений Internet (Internet Control Message Protocol - ICMP).

ICMP

ICMP выполняет ряд задач в пределах об'единенной сети IP. В дополнение к основной задаче, для выполнения которой он был создан (сообщение источнику об отказах маршрутизации), ICMP обеспечивает также метод проверки способности узлов образовывать повторное эхо в об'единенной сети (сообщения Echoи Reply ICMP), метод стимулирования более эффективной маршрутизации (сообщение Redirect ICMP - переадресация ICMP), метод информирования источника о том, что какая-то дейтаграмма превысила назначенное ей время существования в пределах данной об'единенной сети (сообщение Time Exceeded ICMP - "время превыщено") и другие полезные сообщения. Сделанное недавно дополнение к IСМР обеспечивает для новых узлов возможность нахождения маски подсети, используемой в межсети в данный момент. В целом, ICMP является интегральной частью любых реализаций IP, особенно таких, которые используются в роутерах.

Конкретные протоколы маршрутизации IP рассматриваются в других главах данной книги. Например, RIP рассматривается в Главе 23 "RIP", IGRP - в Главе 24 "IGRP", OSPF - в Главе 25 "OSPF", EGP - в главе 26 "EGP" и BGP - в Главе 27 "BGP". IS-IS также является официальным протоколом маршрутизации IP; он рассматривается в Главе 28 "OSI Routing".

Транспортный уровень

Транспортный уровень Internet реализуется ТСР и Протоколом Дейтаграмм Пользователя (User Datagram Protocol - UDP). ТСР обеспечивает транспортировку данных с установлением соединения, в то время как UDP работает без установления соединения.

Протокол управления передачей (TCP)

Transmission Control Protocol (TCP) обеспечивает полностью дублированные, с подтверждением и управлением потоком данных, услуги для протоколов высших уровней. Он перемещает данные в непрерывном неструктурированном потоке, в котором байты идентифицируются по номерам последовательностей. ТСР может также поддерживать многочисленные одновременные диалоги высших уровней. Формат пакета ТСР представлен на Рис. 18-8.

Поле "порт источника" (source port) обозначает точку, в которой конкретный процесс высшего уровня источника принимает услуги ТСР; поле "порт пункта назначения" (destination port) обозначает порт процесса высшего уровня пункта назначения для услуг ТСР.

Поле "номер последовательности" (sequence number) обычно обозначает номер, присвоенный первому байту данных в текущем сообщении. В некоторых случаях оно может также использоваться для обозначения номера исходной последовательности, который должен использоваться в предстоящей передаче.

Поле "номер подтверждения" (acknowledgement number) содержит номер последовательности следующего байта данных, которую отправитель пакета ожидает для приема.

Поле "сдвиг данных" (data offset) обозначает число 32-битовых слов в заголовке ТСР.

Поле "резерв" (reserved) зарезервировано для использования разработчиками протокола в будущем.

Поле "флаги" (flags) содержит различную управляющую информацию.

Поле "окно" (window) обозначает размер окна приема отправителя (буферный об'ем, доступный для поступающих данных).

Поле "контрольная сумма" (checksum) указывает, был ли заголовок поврежден при транзите.

Поле "указатель срочности" (urgent pointer) указывает на первый байт срочных данных в пакете.

Поле "опции" (options) обозначает различные факультативные возможности ТСР.

Протокол дейтаграмм пользователя (UDP)

Протокол UDP намного проще, чем ТСР; он полезен в ситуациях, когда мощные механизмы обеспечения надежности протокола ТСР не обязательны. Заголовок UDP имеет всего четыре поля: поле порта источника (source port), поле порта пункта назначения (destination port), поле длины (length) и поле контрольной суммы UDP (checksum UDP). Поля порта источника и порта назначения выполняют те же функции, что и в заголовке ТСР. Поле длины обозначает длину заголовка UDP и данных; поле контрольной суммы обеспечивает проверку целостности пакета. Контрольная сумма UDP является факультативной возможностью.

Протоколы высших уровней

Комплект протоколов Internet включает в себя большое число протоколов высших уровней, представляющих самые разнообразные применения, в том числе управление сети, передача файлов, распределенные услуги пользования файлами, эмуляция терминалов и электронная почта. На Рис. 18-9 показана связь между наиболее известными протоколами высших уровней Internet и применениями, которые они поддерживают.

Протокол передачи файлов (File Transfer Protocol - FTP) обеспечивает способ перемещения файлов между компьютерными системами. Telnetобеспечивает виртуальную терминальную эмуляцию. Протокол управления простой сетью (Simle network management protocol - SNMP) является протоколом управления сетью, используемым для сообщения об аномальных условиях в сети и установления значений допустимых порогов в сети. X Windows является популярным протоколом, который позволяет терминалу с интеллектом связываться с отдаленными компьютерами таким образом, как если бы они были непосредственно подключенными мониторами. Комбинация протоколов Network File System (NFS) (Система сетевых файлов), External Data Representation (XDP) (Представление внешней информации) и Remote Procedure Call (RPC) (Вызов процедуры обращений к отдаленной сети) обеспечивает прозрачный доступ к ресурсам отдаленной сети. Простой протокол передачи почты (Simple Mail Transfer Protocol - SMTP) обеспечивает механизм передачи электронной почты. Эти и другие применения используют услуги ТСР/IP и других протоколов Internet низших уровней, чтобы обеспечить пользователей базовыми сетевыми услугами.


Глава 19. Протоколы NetWare.

  • Основы технологии
  • Доступ к среде
  • Сетевой уровень
  • Транспортный уровень
  • Протоколы высших уровней

Библиографическая справка

NetWare является операционной системой сети (network operating system - NOS) и связанной с ней средой обеспечения услуг, разработанной Novell, Inc. и представленной на рынок в начале 1980 гг. В то время сети были небольшими и преимущественно гомогенными, связь рабочих групп с помощью локальных сетей была еще новым явлением, а идея о персональном компьютере еще только начала завоевывать популярность.

Большая часть технологии организации сетей NetWare была заимствована из Xerox Network Systems (XNS)- системы организации сетей, разработанной Xerox Corporation в конце 1970 гг. Подробная информация о XNS приведена в Главе 22 "XNS".

K началу 1990 гг. доля в рынке NOS NetWare возросла до 50-75 % (данные зависят от исследовательских групп, занимавшихся изучением рынка). Установив свыше 500,000 сетей NetWare по всему миру и ускорив продвижение по пути об'единения сетей с другими сетями, NetWare и подддерживающие ее протоколы часто сосуществуют на одном и том же физическом канале с многими другими популярными протоколами, в том числе ТСР/IP, DECnet и AppleTalk.

Основы технологии

В качестве среды NOS, NetWare определяет пять высших уровней эталонной модели OSI. Она обеспечивает совместное пользование файлами и принтером, поддержку различных прикладных задач, таких как передача электронной почты и доступ к базе данных, и другие услуги. Также, как и другие NOS, такие как Network File System (NFS)компании Sun Microsystems, Inc. и LAN Managerкомпании Microsoft Corporation, NetWare базируется на архитектуре клиент-сервер (slient-server architecture). В таких архитектурах клиенты (иногда называемые рабочими станциями) запрашивают у серверов определенные услуги, такие как доступ к файлам и принтеру.

Первоначально клиентами NetWare были небольшие РС, в то время как серверами были ненамного более мощные РС. После того, как NetWare стала более популярной, она была перенесена на другие компьютерные платформы. В настоящее время клиенты и сервера могут быть представлены практически любым видом компьютерной системы, от РС до универсальных вычислительных машин.

Основная характеристика системы клиент-сервер заключается в том, что доступ к отдаленной сети является прозрачным для пользователя. Это достигается с помощью удаленного вызовова процедур (remote procedure calls) - такого процесса, когда программа местного компьютера, работающая на оборудовании клиента, отправляет вызов в удаленный сервер. Этот сервер выполняет указанную процедуру и возвращает запрошенную информацию клиенту местного компьютера.

Рис. 19-1 иллюстрирует в упрощенном виде известные протоколы NetWare и их связь с эталонной моделью OSI. При наличии соответствующих драйверов, NetWare может работать с любым протоколом доступа к носителю. На рисунке перечислены те протоколы доступа к носителю, которые в настоящее время обеспечиваются драйверами NetWare.

Доступ к среде

NetWare работает с Ethenet/IEEE 802.3, Token Ring/IEEE 802.5, Fiber Distributed Data Interface (FDDI) и ARCnet. Информация о Ethernet/IEEE 802.3 дается в Главе 5 "Ethernet/IEEE 802.3", о Token Ring/IEEE 802.5 - в Главе 6 "Token Ring/IEEE 802.5", o FDDI - в Главе 7 "FDDI". NetWare также работает в синхронных каналах глобальных сетей, использующих Point-to-Point Protocol(PPP) (Протокол непосредственных соединений). РРР подробно рассматривается в Главе 10 "РРР".

ARСnet представляет собой систему простой сети, которая поддерживает все три основных носителя (скрученную пару, коаксиальный кабель и волоконно-оптический кабель) и две топологии (шина и звезда). Она была разработана корпорацией Datapoint Corporation и выпущена в 1977. Хотя ARCnet не приобрела такую популярность, какой пользуются Ethernet и Token Ring, ее гибкость и низкая стоимость завоевали много верных сторонников.

Сетевой уровень

Internet Packet Exchange (IPX) является оригинальным протоколом сетевого уровня Novell. Если устройство, с которым необходимо установить связь, находится в другой сети, IPX прокладывает маршрут для прохождения информации через любые промежуточные сети, которые могут находиться на пути к пункту назначения. На Рис. 19-2 представлен формат пакета IPX.

Пакет IPX начинается с 16-битового поля контрольной суммы (checksum), которое устанавливается на единицы.

16-битовое поле длины (length) определяет длину полной дейтаграммы IPX в байтах. Пакеты IPX могут быть любой длины, вплоть до размеров максимальной единицы передачи носителя (MTU). Фрагментация пакетов не применяется.

За полем длины идет 8-битовое поле управления транспортировкой (transport control), которое обозначает число роутеров, через которые прошел пакет. Когда значение этого поля доходит до 15, пакет отвергается исходя из предположения, что могла иметь место маршрутная петля.

8-битовое поле типа пакета (packet type) определяет протокол высшего уровня для приема информации пакета. Двумя общими значениями этого поля являются 5, которое определяет Sequenced Packet Exchange (SPX)(Упорядоченный обмен пакетами) и 17, которое определяет NetWare Core Protocol (NCP) (Основной протокол NetWare).

Информация адреса пункта назначения (destination address) занимает следующие три поля. Эти поля определяют сеть, главную вычислительную машину и гнездо (процесс) пункта назначения.

Следом идут три поля адреса источника (source address), определяющих сеть, главную вычислительную машину и гнездо источника.

За полями пункта назначения и источника следует поле данных (data). Оно содержит информацию для процессов высших уровней.

Хотя IPX и является производной XNS, он имеет несколько уникальных характеристик. С точки зрения маршрутизации , наиболее важное различие заключается в механизмах формирования пакетов данных этих двух протоколов. Формирование пакета данных - это процесс упаковки информации протокола высшего уровня и данных в блок данных. Блоки данных являются логическими группами информации, очень похожими на слова телефонного разговора. XNS использует стандартное формирование блока данных Ethernet, в то время как пакеты IPX формируются в блоки данных Ethernet Version 2.0 или IEEE 802.3 без информации IEEE 802.2, которая обычно сопровождает эти блоки данных. Рис.19-3 иллюстрирует формирование пакета данных Ethernet, стандарта IEEE 802.3 и IPX.
Примечание: NetWare 4.0 обеспечивает формирование пакетов IPX в блоки данных IEEE 802.3.

Для маршрутизации пакетов в об'единенных сетях IPX использует протокол динамической маршрутизации, называемый Routing Information Protocol (RIP) (Протокол маршрутной информации). Также, как и XNS, RIP получен в результате усилий компании Xerox по разработке семейства протоколов XNS. В настоящее время RIP является наиболее часто используемым протоколом для внутренних роутеров (interior gateway protocol-IGP) в сообществе Internet-среде международной сети, обеспечивающей связность практически со всеми университетами и исследовательскими институтами и большим числом коммерческих организаций в США, а также со многими иностранными организациями. Подробная информация о RIP приведена в Главе 23 "RIP".

В дополнение к разнице в механизмах формирования пакетов, Novell также дополнительно включила в свое семейство протоколов IPX протокол, называемый Service Adverticement Protocol (SAP) (Протокол об'явлений об услугах). SAP позволяет узлам, обеспечивающим услуги, об'являть о своих адресах и услугах, которые они обеспечивают.

Novell также поддерживает "Блок адресуемой сети" LU 6.2 компании IBM (LU 6.2 network addressable unit - NAU). LU 6.2 обеспечивает связность по принципу равноправных систем через среду сообщений IBM. Используя возможности LU 6.2, которые имеются у NetWare, узлы NetWare могут обмениваться информацией через сеть IBM. Пакеты NetWare формируются в пределах пакетов LU 6.2 для передачи через сеть IBM.

Транспортный уровень

Sequenced Packet Exchange (SPX)(Упорядоченный обмен пакетами) является наиболее часто используемым протоколом транспортного уровня NetWare. Novell получила этот протокол в результате доработки Sequenced Packet Protocol (SPP) системы XNS. Как и протокол ТСР (Transmission Control Protocol) и многие другие протоколы транспортного уровня, SPX является надежным, с установлением соединения протоколом, который дополняет услуги дейтаграмм, обеспечиваемые протоколами Уровня 3.

Novell также предлагает поддержку протокола Internet Protocol (IP) в виде формирования протоколом User Datagram Protocol(UDP)/IP других пакетов Novell, таких как пакеты SPX/IPX. Для транспортировки через об'единенные сети, базирующиеся на IP, дейтаграммы IPX формируются внутри заголовков UDP/IP. Общая информация о протоколах UPD и Internet дается в Главе 18 "Протоколы Internet".

Протоколы высших уровней

NetWare поддерживает большое разнообразие протоколов высших уровней; некоторые из них несколько более популярны, чем другие. NetWare shell (командный процессор) работает в оборудовании клиентов (которое часто называется рабочими станциями среди специалистов по NetWare) и перехватывает обращения прикладных задач к устройству Ввод/Вывод, чтобы определить, требуют ли они доступ к сети для удовлетворения запроса. Если это так, то NetWare shell организует пакеты запросов и отправляет их в программное обеспечение низшего уровня для обработки и передачи по сети. Если это не так, то они просто передаются в ресурсы местного устройства Ввода/Вывода. Прикладные задачи клиента не осведомлены о каких-либо доступах к сети, необходимых для выполнения обращений прикладных задач. NetWare Remote Procedure Call (Netware RPC) (Вызов процедуры обращения к отдаленной сети) является еще одним более общим механизмом переадресации, поддерживаемым Novell.

Netware Core Protocol (NCP) (Основной протокол NetWare) представляет собой ряд программ для сервера, предназначенных для удовлетворения запросов прикладных задач, приходящих, например, из NetWare shell. Услуги, предоставляемые NCP, включают доступ к файлам, доступ к принтеру, управление именами, учет использования ресурсов, защиту данных и синхронизацию файлов.

NetWare также поддерживает спецификацию интерфейса сеансового уровня Network Basic I/O System (NetBIOS) компаний IBM и Microsoft. Программа эмуляции NetBIOS, обеспечиваемая NetWare, позволяет программам, написанным для промышленного стандартного интерфейса NetBIOS, работать в пределах системы NetWare.

Услуги прикладного уровня NetWare включают NetWare Message Handling Service (NetWare MHS) (Услуги по обработке сообщений), Btrieve, NetWare Loadable Modules (NLM) (Загружаемые модули NetWare) и различные характеристики связности IBM. NetWare MHS является системой доставки сообщений, которая обеспечивает транспортировку электронной почты. Btrieve представляет собой реализацию механизма доступа к базе данных двоичного дерева (btree) Novell. NLM реализуются как дополнительные модули, которые подключаются к системе NetWare. В настоящее время компания Novell и третьи участвующие стороны предоставляют NLM для чередующихся комплектов протоколов (alternate protocol stacks), услуги связи, услуги доступа к базе данных и много других услуг.


Глава 20. Протоколы OSI.

  • Основы технологии
  • Доступ к среде
  • Сетевой уровень
    • Услуги без установления соединения
    • Услуги с установлением соединения
    • Адресация
  • Транспортный уровень
  • Протоколы высших уровней
    • Сеансовый уровень
    • Представительный уровень
    • Прикладной уровень

Библиографическая справка

В первые годы появления межкомпьютерной связи программное обеспечение организации сетей создавалось бессистемно, для каждого отдельного случая. После того, как сети приобрели достаточную популярность, некоторые из разработчиков признали необходимость стандартизации сопутствующих изделий программного обеспечения и разработки аппаратного обеспечения. Считалось, что стандартизация позволит поставщикам разработать системы аппаратного и программного обеспечения, которые смогут сообщаться друг с другом даже в том случае, если в их основе лежат различные архитектуры. Поставив перед собой эту цель, ISO начала разработку эталонной модели Open Systems Interconnections (OSI) (Взаимодействие открытых систем). Эталонная модель OSI была завершена и выпущена в 1984 г.

В настоящее время эталонная модель OSI (подробно рассмотренная в Главе 1 "Введение в об'единенные сети" ) является самой выдающейся в мире моделью архитектуры об'единенных сетей. Она также является самым популярным средством приобретения знаний о сетях. С другой стороны, у протоколов OSI был длинный период созревания. И хотя известно о некоторых реализациях OSI, протоколы OSI все еще не завоевали той популярности, которой пользуются многие патентованные протоколы (например, DECnet и АppleTalk) и действующие стандарты (например, протоколы Internet).

Основы технологии

Об'единение сетей OSI использует уникальную терминологию.

End system (ES)
Термин "конечная система" относится к любому устройству сети, не занимающемуся маршрутизацией.
Intermediate system (IS)
Термин "промежуточная система" относится к роутеру.
Area
"Область" обозначает группу смежных сетей и подключенных к ним хостов; область назначается администратором сети или другим аналогичным лицом.
Domain
"Домен" представляет собой набор соединенных областей. Домены маршрутизации обеспечивают полную связность со всеми конечными системами, находящимися в их пределах.

Доступ к среде

Также, как и некоторые другие современные 7-уровневые комплекты протоколов, комплект OSI включает в себя многие популярные сегодня протоколы доступа к носителю. Это позволяет другим комплектам протоколов существовать наряду с OSI в одном и том же носителе. В OSI входят IEEE 802.2, IEEE 802.3, IEEE 802.5, FDDI, X.21, V.35, X.25 и другие. Большинство из этих протоколов доступа к носителю OSI уже рассматривались в данной книге.

Сетевой уровень

OSI предлагает услуги сетевого уровня как без установления соединения, так и ориентированные на установления логического соединения. Услуги без установления соединения описаны в ISO 8473 (обычно называемом Connectionless Network Protocol - CLNP - Протокол сети без установления соединения). Обслуживание, ориентированное на установление логического соединения (иногда называемое Connection-Oriented Network Service - CONS) описывается в ISO 8208 (X.25 Packet-Level Protocol - Протокол пакетного уровня X.25, иногда называемый Connection-Mode Network Protocol - CMNP) и ISO 8878 (в котором описывается, как пользоваться ISO 8208, чтобы обеспечить ориентированные на установление логического соединения услуги OSI). Дополнительный документ ISO 8881 описывает, как обеспечить работу Протокола пакетного уровня X.25 в локальных сетях IEEE 802. OSI также определяет несколько протоколов маршрутизации, которые рассмотрены в Главе 28 "Маршрутизация OSI". X.25 рассмотрен в Главе 13 "Х.25".

В дополнение к уже упоминавшимся спецификациям протоколов и услуг, имеются другие документы, связанные с сетевым уровнем OSI, в число которых входят:

ISO 8648
На этот документ обычно ссылаются как на "внутреннюю организацию сетевого уровня" (internal organization of the network level - IONL). Он описывает, каким образом можно разбить сетевой уровень на три отдельных различимых друг от друга подуровня, чтобы обеспечить поддержку для различных типов подсетей.
ISO 8348
Этот документ обычно называют "определение услуг сети" (network service definition). Он описывает ориентированные на установление логического соединения услуги и услуги без установления соединения, которые обеспечивает сетевой уровень OSI. Адресация сетевого уровня также определена в этом документе. Определение услуг в режиме без установления соединения и определение адресации раньше были опубликованы отдельным дополнением к ISO 8348; однако вариант ISO 8348 1993 года об'единяет все дополнения в отдельный документ.
ISO TR 9575
Этот документ описывает структуру, концепции и терминологию, использованную в протоколах маршрутизации OSI.
ISO TR 9577
Этот документ описывает, как отличать друг от друга большое число протоколов сетевого уровня, работающих в одной и той же среде. Это необходимо потому, что в отличие от других протоколов, протоколы сетевого уровня OSI не различаются с помощью какого-либо идентификатора (ID) протокола или аналогичного поля канального уровня.

Услуги без установления соединения
Как видно из названия, CLNP является протоколом дейтаграмм без установления соединения, который используется для переноса данных и указателей неисправности. По своим функциональным возможностям он похож на Internet Protocol (IP), описанный в Главе 18 "Протоколы Internet". Он не содержит средств обнаружения ошибок и их коррекции, полагаясь на способность транспортного уровня обеспечить соответствующим образом эти услуги. Он содержит только одну фазу, которая называется "передача информации" (data transfer). Каждый вызов какого-либо примитива услуг не зависит от всех других вызовов, для чего необходимо, чтобы вся адресная информация полностью содержалась в составе примитива.

В то время как CLNP определяет действующий протокол, выполняющий типичные функции сетевого уровня, CLNS (Обслуживание сети без установления соединения) описывает услуги, предоставляемые транспортному уровню, в котором запрос о передаче информации реализуется доставкой, выполненной с наименьшими затратами (best effort). Такая доставка не гарантирует, что данные не будут потеряны, испорчены, что в них не будет нарушен порядок, или что они не будут скопированы. Обслуживание без установления соединения предполагает, что при необходимости все эти проблемы будут устранены в транспортном уровне. CLNS не обеспечивает никаких видов информации о соединении или состоянии, и не выполняет настройку соединения. Т.к. CLNS обеспечивает транспортные уровни интерфейсом услуг, сопрягающим с CLNP, протоколы CNLS и CLNP часто рассматриваются вместе.

Услуги с установлением соединения
Услуги сети OSI с установлением соединения определяются ISO 8208 и ISO 8878. OSI использует X.25 Racket-Level Protocol для перемещения данных и указателей ошибок с установлением соединения. Для об'ектов транспортного уровня предусмотрено 6 услуг (одна для установления соединения, другая для раз'единения соединения, и четыре для передачи данных). Услуги вызываются определенной комбинацией из 4 примитив: запрос (request), указатель (indication), ответ (response) и подтверждение (confirmation). Взаимодействие этих четырех примитив показано на Рис. 20-1.

В момент времени t1 транспортный уровень ES 1 отправляет примитив- запрос в сетевой уровень ES 1. Этот запрос помещается в подсеть ES 1 протоколами подсети низших уровней и в конечном итоге принимается ES 2, который отправляет информацию вверх в сетевой уровень. В мотент времени t2 сетевой уровень ES 2 отправляет примитив-указатель в свой транспортный уровень. После завершения необходимой обработки пакета в высших уровнях, ES 2 инициирует ответ в ES 1, используя примитив-ответ, отправленный из транспортного уровня в сетевой уровень. Отправленный в момень времени t3 ответ возвращается в ES 1, который отправляет информацию вверх в сетевой уровень, где генерируется примитив-подтверждение, отправляемый в транспортный уровень в момент t3.

Адресация
Услуги сети OSI предоставляются транспортному уровню через концептуальную точку на границе сетевого и транспортного уровней, известную под названием "точки доступа к услугам сети" (network service access point - NSAP). Для каждого об'екта транспортного уровня имеется одна NSAP.

Каждая NSAP может быть индивидуально адресована в об'единенной глобальной сети с помощью адреса NSAP (в обиходе существует неточное название - просто NSAP). Таким образом, любая конечная система OSI имеет, как правило, множество адресов NSAP. Эти адреса обычно отличаются только последним байтом, называемом n-selector.

Возможны случаи, когда полезно адресовать сообщение сетевому уровня системы в целом, не связывая его с конкретным об'ектом транспортного уровня, например, когда система участвует в протоколах маршрутизации или при адресации к какой-нибудь промежуточной системе (к роутеру). Подобная адресация выполняется через специальный адрес сети, известный под названием network entity title (NET) (титул об'екта сети). Структурно NET идентичен адресу NSAP, но он использует специальное значение n-selector "00". Большинство конечных и промежуточных систем имеют только один NET, в отличие от роутеров IP, которые обычно имеют по одному адресу на каждый интерфейс. Однако промежуточная система, участвующая в нескольких областях или доменах, имеет право выборa на обладание несколькими NET.

Адреса NET и NSAP являются иерархическими адресами. Адресация к иерархическим системам облегчает как управление (путем обеспечения нескольких уровней управления), так и маршрутизацию (путем кодирования информации о топологии сети). Адрес NSAP сначала разделяется на две части: исходная часть домена (initial domain part - IDP) и специфичнaя часть домена (domain specific part - DSP). IDP далее делится на идентификатор формата и полномочий (authority and format identifier - AFI) и идентификатор исходного домена (initial domain identifier - IDI).

AFI обеспечивает информацию о структуре и содержании полей IDI и DSP, в том числе информацию о том, является ли IDI идентификатором переменной длины и использует ли DSP десятичную или двоичную систему счислений. IDI определяет об'ект, который может назначать различные значения части DSP адреса.

DSP далее подразделяется полномочным лицом, ответственным за ее управление. Как правило, далее следует идентификатор другого управляющего авторитета, чем обеспечивается дальнейшее делегирование управления адресом в подорганы управления. Далее идет информация, используемая для маршрутизации, такая, как домены маршрутизации, область (area) с доменом маршрутизации, идентификатор (ID) станции в пределах этой области и селектор (selector) в пределах этой станции. Рис. 20-2 иллюстрирует формат адреса OSI.

Транспортный уровень

Как обычно для сетевого уровня OSI, oбеспечиваются услуги как без установления соединения, так и с установлением соединения. Фактически имеется 5 протоколов транспортного уровня OSI с установлением соединения: ТР0, ТР1, ТР2, ТР3 и ТР4. Все они, кроме ТР4, работают только с услугами сети OSI с установлением соединения. ТР4 работает с услугами сети как с установлением соединения, так и без установления соединения.

ТР0 является самым простым протоколом транспортного уровня OSI, ориентированным на установления логического соединения. Из набора классических функций протокола транспортного уровня он выполняет только сегментацию и повторную сборку. Это означает, что ТР0 обратит внимание на протокольную информационную единицу (protocol data unit - PDU) с самым маленьким максимальным размером, который поддерживается лежащими в основе подсетями, и разобьет пакет транспортного уровня на менее крупные части, которые не будут слишком велики для передачи по сети.

В дополнение к сегментации и повторной сборке ТР1 обеспечивает устранение базовых ошибок. Он нумерует все PDU и повторно отправляет те, которые не были подтверждены. ТР1 может также повторно инициировать соединение в том случае, если имеет место превышение допустимого числа неподтвержденных РDU.

ТР2 может мультиплексировать и демультиплексировать потоки данных через отдельную виртуальную цепь. Эта способность делает ТР2 особенно полезной в общедоступных информационных сетях (PDN), где каждая виртуальная цепь подвергается отдельной загрузке. Подобно ТР0 и ТР1, ТР2 также сегментирует и вновь собирает PDU.

ТР3 комбинирует в себе характеристики ТР1 и ТР2.

ТР4 является самым популярным протоколом транспортного уровня OSI. ТР4 похож на протокол ТСР из комплекта протоколов Internet; фактически, он базировался на ТСР. В дополнение к характеристикам ТР3, ТР4 обеспечивает надежные услуги по транспортировке. Его применение предполагает сеть, в которой проблемы не выявляются.

Протоколы высших уровней

Основные протоколы высших уровней OSI представлены на Рис. 20-3.

Сеансовый уровень
Протоколы сеансового уровня OSI преобразуют в сеансы потоки данных, поставляемых четырьмя низшими уровнями, путем реализации различных управляющих механизмов. В число этих механизмов входит ведение учета, управление диалогом (т.е. определение, кто и когда может говорить) и согласование параметров сеанса.

Управление диалогом сеанса реализуется путем использования маркера (token), обладание которым обеспечивает право на связь. Маркер можно запрашивать, и конечным системам ES могут быть присвоены приоритеты, обеспечивающие неравноправное пользование маркером.

Представительный уровень
Представительный уровень OSI, как правило, является просто проходным протоколом для информации из соседних уровней. Хотя многие считают, что Abstract Syntax Notation 1 (ASN.1)(Абстрактное представление синтаксиса) является протоколом представительного уровня OSI, ASN.1 используется для выражения форматов данных в независимом от машины формате. Это позволяет осуществлять связь между прикладными задачами различных компьютерных систем способом, прозрачным для этих прикладных задач.

Прикладной уровень
Прикладной уровень ОSI включает действующие протоколы прикладного уровня, а также элементы услуг прикладного уровня (application service elements - ASE). ASE обеспечивают легкую связь протоколов прикладного уровня с низшими уровнями. Тремя наиболее важными ASE являются Элемент услуг управления ассоциацией (Association Control Service Element - ACSE), Элемент услуг получения доступа к операциям отдаленного устройства (Remote Operations Service Element - ROSE) и Элемент услуг надежной передачи (Reliable Transfer Service Element - RTSE). При подготовке к связи между двумя протоколами прикладного уровня ACSE об'единяет их имена друг с другом. ROSE реализует родовой (generic) механизм "запрос/ответ", который разрешает доступ к операциям отдаленного устройства способом, похожим на вызовы процедуры обращений к отделенной сети (remote procedure calls - RPC). RTSE способствует надежной доставке, делая конструктивные элементы сеансового уровня легкими для использования. Наибольшего внимания заслуживают следующие пять протоколов прикладного уровня OSI:

Common Management Information Protocol (CMIP)
Протокол общей информации управления - протокол управления сети OSI Также, как и SNMP (смотри Главу 32 "SNMP") и Net View (смотри Главу 33 "Управление сети IBM"), он обеспечивает обмен управляющей информацией между ES и станциями управления (которые также являются ES).
Directory Services (DS)
Услуги каталогов. Разработанная на основе спецификации Х.500 CITT, эта услуга предоставляет возможности распределенной базы анных, которые полезны для идентификации и адресации узлов высших ровней.
File Transfer,Access, and Management (FTAM)
Передача, доступ и управление файлами - услуги по передаче файлов. В дополнение к классической передаче файлов, для которой FTAM обеспечивает многочисленные опции, FTAM также обеспечивает средста доступа к распределенным файлам таким же образом, как это делает NetWare компании Novell, Inc или Network File System (NFS) компании Sun Microsystems, Inc.
Massage Handling Systems (MHS)
Системы обработки сообщений - обеспечивает механизм, лежащий в основе транспортировки данных для прикладных задач передачи сообщений по электронной почте и других задач, требующих услуг по хранению и продвижению данных. Хотя они и выполняют аналогичные задачи, MHS не следует путать с NetWare MHS компании Novell (смотри Главу 19 "Протоколы NetWare)".
Virtual Terminal Protocol (VTP)
Протокол виртуальных терминалов - обеспечивает эмуляцию терминалов. Другими словами, он позволяет компьютерной системе для отдаленной ES казаться непосредственно подключенным терминалом. С помощью VTP пользователь может, например, выполнять дистанционные работы на универсальных вычислительных машинах.


Глава 21. Banyan VINES.

  • Основы технологии
  • Доступ к среде
  • Сетевой уровень
    • Протокол межсетевого обмена VINES (VIP)
    • Протокол корректировки маршрутизации (RTR)
    • Протокол разрешения адреса (ARP)
    • Протокол управления объединеной сетью (ICP)
  • Транспортный уровень
  • Протоколы высших уровней

Библиографическая справка

Компания Banyan Virtual Network System (VINES) реализовала систему распределенной сети, базирующуюся на семействе патентованных протоколов, разработанных на основе протоколов Xerox Network Systems (XNS)компании XEROX (смотри главу 22 "XNS"). Среда распределенной системы обеспечивает прозрачный для пользователя обмен информации между клиентами (компьютерами пользователя) и служебными устройствами (компьютерами специального назначения, которые обеспечивают услуги, такие, как файловое и принтерное обслуживание). Наряду с NetWareкомпании Novell, LAN Server компании IBM и LAN Manager компании Microsoft, VINES является одной из самых популярных сред распределенной системы для сетей, базирующихся на микрокомпьютерах.

Основы технологии

Комплект протоколов VINES представлен на Рис. 21-1.

Доступ к среде

Два низших уровня комплекта протоколов VINES реализованы с помощью различных общеизвестных механизмов доступа к носителю, включая Управление информационным каналом высшего уровня (HDLC) (смотри Главу 12 "SDLC и его производные"), Х.25 (смотри Главу 13 "Х.25"), Ethernet (смотри Главу 5 "Ethernet/IEEE 802.3") и Тоken Ring (смотри Главу 6 "Token Ring/IEEE 802.5").

Сетевой уровень

Для выполнения функций Уровня 3 (в том числе маршрутизации в об'единенной сети) VINES использует Протокол межсетевого обмена VINES (VINES Internetwork Protocol - VIP). VINES также обеспечивает собственный Протокол разрешения адреса (ARP), собственную версию Протокола информации маршрутизации (Routing Information Protocol - RIP), которая называется Протоколом корректировки маршрутизации (Routing Update Protocol - RTP) и Протокол управления Internet (ICP), который обеспечивает обработку исключительных состояний и специальной информации о затратах маршрутизации. Пакеты ICP, RTP и ARP формируются в заголовке VIP.

Протокол межсетевого обмена VINES (VIP)
Адреса сетевого уровня VINES являются 48-битовыми об'ектами, подразделенными на сетевую (32 бита) и подсетевую (16 битов) части. Сетевой номер можно описать как номер какого-нибудь служебного устройства, т.к. он получается непосредственно из ключа (key) служебного устройства (аппаратного модуля, который обозначает уникальный номер и программные опции для данного служебного устройства). Подсетевая часть адреса VINES лучше всего описывается как номер хоста, т.к. он используется для обозначения хоста в сетех VINES. Рис. 21-2 иллюстрирует формат адреса VINES.

Сетевой номер обозначает логическую сеть VINES, которая представлена в виде двухуровневого дерева, корень которого находится в узле обслуживания (service node). Узлы обслуживания, которыми обычно являются служебные устройства, обеспечивают услуги резрешения адреса и услуги маршрутизации клиентам (client), которые являются листьями этого дерева. Узел обслуживания назначает адреса VIP клиентам.

Когда какой-нибудь клиент включает питание, он направляет широковещательный запрос служебным устройствам. Все служебные устройства, которые получают этот запрос, посылают ответ. Клиент выбирает первый ответ и запрашивает у данного служебного устройства адрес подсети (хоста). Служебное устройство отвечает адресом, состоящим из его собственного сетевого адреса (полученного из его ключа), об'единенного с адресом подсети (хоста), который он выбрал сам. Адреса подсети клиента обычно назначаются последовательно, начиная с 8001H. Адреса подсети служебного устройства всегда 1. Процесс выбора адреса VINES показан на Рис. 21-3.

Динамичное назначение адреса не является уникальным явлением в индустрии сетей (AppleTalk также использует этот процесс); однако этот процесс определенно не является таким обычным процессом, как статическое назначение адреса. Т.к. адреса выбираются исключительно каким-нибудь одним конкретным служебным устройством (чей адрес является уникальным вследствие уникальности аппаратного ключа), вероятность дублирования адреса (что является потенциально опасной проблемой для сети Internet Protocol (IP) и других сетей) очень мала.

В схеме сети VINES все служебные устройства с несколькими интерфейсами в основном являются роутерами. Клиенты всегда выбирают свое собственное служебное устройство в качестве роутера для первой пересылки, даже если другое служебное устройство, подключенное к этому же кабелю, обеспечивает лучший маршрут к конечному пункту назначения. Клиенты могут узнать о других роутерах, получая переадресованные сообщения от своего служебного устройства. Т.К. клиенты полагаются на свои служебные устройства при первой пересылке маршрутизации, служебные устройства VINES поддерживают маршрутные таблицы, которые помогают им находить отдаленные узлы.

Маршрутные таблицы VINES состоят из пар "хост/затраты", гдe хост соответствует сетевому узлу, до которого можно дойти, а затраты - временной задержке в миллисекундах, необходимой для достижения этого узла. RTP помогает служебным устройствам VINES находить соседних клиентов, служебные устройства и роутеры.

Все клиенты периодически об'являют как о своих адресах сетевого уровня, так и о адресах МАС-уровня с помощью пакета, эквивалентого пакету "hello" (приветственное сообщение). Пакеты "hello" означают, что данный клиент все еще работает и сеть готова. Сами служебные устройства периодически отправляют в другие служебные устройства маршрутные корректировки. Маршрутные корректировки извещают другие роутеры об изменениях адресов узлов и топологии сети.

Когда какое-нибудь служебное устройство VINES принимает пакет, оно проверяет его, чтобы узнать, для чего он предназначается - для другого служебного устройства или для широкого вещания. Если пунктом назначения является данное служебное устройство, то это служебное устройство соответствующим образом обрабатывает этот запрос. Если пунктом назначения является другое служебное устройство, то данное служебное устройство либо непосредственно продвигает этот пакет (если это служебное устройство является его соседом), либо направляет его в служебное устройство/роутер, которые являются следующими в очереди. Если данный пакет является широковещательным, то данное служебное устройство проверяет его, чтобы узнать, пришел ли этот пакет с маршрута с наименьшими затратами. Если это не так, то пакет отвергается. Если же это так, то пакет продвигается на всех интерфейсах, за исключением того, на котором этот пакет был принят. Такой метод помогает уменьшить число широковещательных возмущений, которые являются обычной проблемой в других сетевых окружениях. Aлгоритм маршрутизации VINES представлен на Рис. 21-4.

Формат пакета VIP представлен на Рис. 21-5.

Пакет VIP начинается с поля контрольной суммы (checksum), используемой для обнаружения искажений в пакете.

За полем контрольной суммы идет поле длины пакета (packet length), которое обозначает длину всего пакета VIP.

Следующим полем является поле управления транспортировкой (transport control), которое состоит из нескольких подполей. Если пакет является широковещательным, то предусматривается два подполя: подполе класса (class) (с 1 по 3 биты) и подполе числа пересылок (hop-count) (с 4 по 7 биты). Если пакет не является широковещательным пакетом, то предусматривается 4 подполя: подполе ошибки (error), подполе показателя (metric), подполе переадресации (redirect), и подполе числа пересылок (hop count). Подполе класса определяет тип узла, который должен принимать широковещательное сообщение. С этой целью узлы разделяются на несколько различных категорий, зависящих от типа узла и типа канала, к которому принадлежит узел. Определяя тип узлов, которые должны принимать широковещательные сообщения, подполе класса уменьшает вероятность срывов в работе, вызываемых широковещательными сообщениями. Подполе числа пересылок представляет собой число пересылок (число пересеченных роутеров), через которые прошел пакет. Подполе ошибок определяет, надо ли протоколу ICP отправлять пакет уведомления об исключительной ситуации в источник пакета, если пакет окажется немаршрутизируемым. Подполе показателя устанавливается в 1 транспортным об'ектом, когда ему необходимо узнать затраты маршрутизации при перемещения пакетов между каким-нибудь узлом обслуживания и одним из соседей. Подполе переадресации определяет, должен ли роутер генерировать сигнал переадресации (при соответствующих обстоятельствах).

Далее идет поле типа протокола (protocol type), указывающее на протокол сетевого или транспортного уровня, для которого предназначен пакет показателя или пакет уведомления об исключении.

За полем типа протокола следуют адресные поля VIP. За полями номера сети назначения (destination network number) и номера подсети назначения (destination subnetwork number) идут поля номера сети источника (sourсe network number) и номера подсети источника (source subnetwork number).

Протокол корректировки маршрутизации (RTR)
RTR распределяет информацию о топологии сети. Пакеты корректировки маршрутизации периодически пересылаются широкой рассылкой как клиентом, так и узлами обслуживания. Эти пакеты информируют соседей о существовании какого-нибудь узла, а также указывают, является ли этот узел клиентом или узлом обслуживания. В каждый пакет корректировки маршрутизации узла обслуживания также включается перечень всех известных сетей и коэффициенты затрат, связанные с достижением этих сетей.

Поддерживаются две маршрутные таблицы: таблица всех известных сетей и таблица соседей. Для узлов обслуживания таблица всех известных сетей содержит запись данных о каждой известной сети, за исключением собственной сети узла обслуживания. Каждая запись содержит номер сети, показатель маршрутизации и указатель на запись данных следующей пересылки на пути к данной сети в таблице соседей. Таблица соседей содержит запись данных каждого узла обслуживания соседа и узла клиента. Записи включают в себя номер сети, номер подсети, протокол доступа к носителю (например, Ethernent), который использовался для достижения этого узла, адрес локальной сети (если средой, соединяющей с соседом, является локальная сеть) и показатель соседа.

RTR определяет 4 типа пакетов:

  • Пакеты корректировки маршрутизации.
    Периодически выпускаются для уведомления соседей о существовании какого-нибудь об'екта.
  • Пакеты запроса о маршрутизации.
    Об'екты обмениваются ими, когда им необходимо быстро узнать о топологии сети.
  • Пакеты ответа на запрос о маршрутизации.
    Содержат топологическую информацию и используются узлами обслуживания для ответа на пакеты запроса о маршрутизации.
  • Пакеты переадресации маршрутизации.
    Обеспечивают отправку информации о лучших маршрутах в узлы, использующие неэффективные тракты.

Пакеты RTR имеют 4-байтовый заголовок, состоящий из однобайтового поля типа операций (operation type), однобайтового поля типа узла (node type), однобайтового поля типа контроллера (controller type) и однобайтового поля типа машины (machine type). Поле типа операций указывает на тип пакета. Поле типа узла указывает, пришел пакет из узла обслуживания или из необслуживающего узла. Поле типа контроллера указывает, содержит ли контроллер узла, передающего пакет RTR, многобуферный контроллер. Это поле используется для облегчения регулирования информационного потока между сетевыми узлами. И наконец, поле типа машины указывает, является ли процессор отправителя RTR быстодействующим или нет. Как и поле типа контроллера, поле типа машины также используется для регулирования скорости передачи.

Протокол разрешения адреса (ARP)
Об'екты протокола ARP классифицируются либо как клиенты разрешения адреса (address resolution clients), либо как услуги разрешения адреса (address resolution services). Клиенты разрешения адреса обычно реализуются в узлах клиентов, в то время как услуги разрешения адреса обычно обеспечиваются узлами обслуживания.

Пакеты ARP имеют 8-байтовый заголовок, состоящий из 2-байтового типа пакета (packet type), 4-байтового номера сети (network number) и 2-байтового номера подсети (subnet number). Имеется 4 типа пакетов: запрос-заявка (query request), который является запросом какой-либо услуги ARP; ответ об услуге (service response), который является ответом на запрос-заявку, запрос о присваивании адреса (assignment request), который отправляется какой-нибудь услуге ARP для запроса адреса об'единенной сети VINES, и ответ о присваивании адреса (assignment response), который отправляется данной услугой ARP в качестве ответа на запрос о присваивании адреса. Поля номера сети и номера подсети имеют значение только в пакете ответа о присваивании адреса.

Когда какой-нибудь клиент приступает к работе, клиенты и услуги ARP реализуют следующий алгоритм. Сначала данный клиент отправляет широкой рассылкой пакеты запросов-заявок. Затем каждая услуга, которая является соседом данного клиента, отвечает пакетом ответа об услуге. Далее данный клиент выдает пакет запроса о присваивании адреса в первую услугу, которая ответила на его пакет запроса-заявки. Услуга отвечает пакетом ответа о присваивании адреса, содержащем присвоенный адрес об'единенной сети.

Протокол управления объединеной сетью (ICP)
ICP определяет пакеты уведомления об исключительных ситуациях (exception notification) и уведомления о показателе (metric notification). Пакеты уведомления об исключительных ситуациях обеспечивают информацию об исключительных ситуациях сетевого уровня; пакеты уведомления о показателе содержат информацию о последней передаче, которая была использована для достижения узла клиента.

Уведомления об исключительной ситуации отправляются в том случае, когда какой-нибудь пакет VIP не может быть соответствующим образом маршрутизирован, и устанавливается подполе ошибки в поле управления транспортировкой заголовка VIP. Эти пакеты также содержат поле, идентифицирующее конкретную исключительную ситуацию по коду ошибки, соответствующему этой ситуации.

Об'екты ICP в узлах обслуживания генерируют сообщения уведомления о показателе в том случае, когда устанавливается подполе показателя в поле управления транспортировкой заголовка VIP, и адрес пункта назначения в пакете узла обслуживания определяет одного из соседей этого узла обслуживания.

Транспортный уровень

VINES обеспечивает три услуги транспортного уровня:

  • Unreliable datagram service.
    Услуги ненадежных дейтаграмм. Отправляет пакеты, которые маршрутизируются на основе принципа "наименьших затрат" (best-effort basis), но не подтверждаются сообщением о приеме в пункте назначения.
  • reliable datagram service.
    Услуги надежных дейтаграмм. Услуга виртуальной цепи, которая обеспечивает надежную упорядоченную доставку сообщений между узлами сети с подтверждением о приеме. Надежное сообщение может быть передано с максимальным числом пакетов, равным 4.
  • data stream service.
    Услуга потока данных. Поддерживает контролируемый поток данных между двумя процессами. Услуга потока данных является услугой виртуальной цепи с подтверждением о приеме, которая обеспечивает передачу сообщений неограниченных размеров.

Протоколы высших уровней

Являясь распределенной сетью, VINES использует модель вызова процедуры обращений к отдаленной сети (remote procedure call - RPC) для связи между клиентами и служебными устройствами. RCP является основой сред распределенных услуг. Протокол NetRPC (Уровни 5 и 6) обеспечивает язык программирования высшего уровня, который позволяет осуществлять доступ к отдаленным услугам способом, прозрачным как для пользователя, так и для прикладной программы.

На Уровне 7 VINES обеспечивает протоколы файловых услуг и услуг принтера, а также протокол услуг "StreetTalk name/directory". StreetTalk, один из протоколов с торговым знаком компании VINES, обеспечивает службу постоянных имен в глобальном масштабе для всей об'единенной сети.

VINES также обеспечивает среду разработки интегрированных применений при наличии нескольких операционных систем, включая DOS и UNIX. Taкая среда разработки позволяет третьей участвующей стороне осуществлять разработку как клиентов, так и услуг, действующих в среде VINES.


Глава 22. Xerox Network Systems (XNS).

  • Основы технологии
  • Доступ к среде
  • Сетевой уровень
  • Транспортный уровень
  • Протоколы высших уровней

Библиографическая справка

Протоколы Xerox Network Systems (XNS) разработаны корпорацией Xerox в конце 1970-начале 1980 гг. Они предназначены для использования в разнообразных средах передачи, процессорах и прикладных задачах офиса. Несколько протоколов XNS похожи на Протокол Internet (IP) и Протокол управления передачей (TCP), разработанных агентством DARPA для Министерства обороны США (DoD). Информация по этим и связанным с ними протоколам дается в Главе 18 "Протоколы Internet". Все протоколы XNS соответствуют основным целям проектирования эталонной модели OSI.

Благодаря своей доступности и раннему появлению на рынке, XNS был принят большинством компаний, использовавших локальные сети с момента их появления, в том числе компаниями Novell, Inc., Ungermann-Bass, Inc. (которая теперь является частью Tandem Computers) и 3Com Corporation. За время,прошедшее с тех пор, каждая из этих компаний внесла различные изменения в протоколы XNS. Novell дополнила их Протоколом доступа к услугам (Service access protocol - SAP), чтобы обеспечить об'явление о ресурсах, и модифицировала протоколы Уровня 3 OSI (которые Novell переименовала в Internetwork Packet Exchange - IPX - Oбмен межсетевыми пакетами) для работы в сетях IEEE 802.3, а не в сетях Ethernet. Ungermann-Bass модифицировала RIP для поддержания задержки, а также числа пересылок. Были также внесены другие незначительные изменения. С течением времени реализации XNS для об'единенных в сети РС стали более популярными, чем XNS в том виде, в котором они были первоначально разработаны компанией Xerox.

Основы технологии

Несмотря на то, что они имеют общие цели проектирования, концепция XNS о иерархии протоколов несколько отличается от той концепции, которую предлагает эталонная модель OSI. На Рис. 22-1 показано приблизительное сравнение XNS и эталонной модели OSI.

Как видно из Рис. 22-1, Xerox обеспечивает 5-уровневую модель передачи пакетов. Уровень 0, который отвечает за доступ к каналу и манипуляцию потока битов, примерно соответствует Уровням 1 и 2 OSI. Уровень 1 примерно соответствует той части Уровня 3 OSI, которая относится к сетевому трафику. Уровень 2 примерно соответствует части Уровня 3, которая связана с маршрутизацией в об'единенной сети, и Уровню 4 OSI, который занимается связью внутри отдельных процессов. Уровни 3 и 4 примерно соответствуют двум верхним уровням модели OSI, которые заняты структурированием данных, взаимодействием между отдельными процессами и прикладными задачами. XNS не имеет протокола, соответствующего Уровню 5 OSI (сеансовый уровень).

Доступ к среде

Несмотря на то, что в документации XNS упоминаются X.25, Ethernet и HDLC, XNS не дает четкого определения того, что она называет протоколом уровня 0. Также, как и многие другие комплекты протоколов, XNS оставляет вопрос о протоколе доступа к носителю открытым, косвенным образом позволяя любому такому протоколу выполнять главную роль в транспортировке пакетов XNS через физический носитель.

Сетевой уровень

Протокол сетевого уровня XNS называется Протоколом дейтаграмм Internet (Internet Datagram Protocol - IDP). IDP выполняет стандартные функции Уровня 3, в число которых входят логическая адресация и сквозная доставка дейтаграмм через об'единенную сеть. Формат пакета IDP представлен на Рис. 22-2.

Первым полем в пакете IDP является 16-битовое поле контрольной суммы (checksum), которое помогает проверить целостность пакета после его прохождения через об'единенную сеть.

За полем контрольной суммы следует 16-битовое поле длины (length), которое содержит информацию о полной длине (включая контрольную сумму) текущей дейтаграммы.

За полем длины идет 8-битовое поле управления транспортировкой (transport control) и 8-битовое поле типа пакета (packet type). Поле управления транспортировкой состоит из подполей числа пересылок (hop count) и максимального времени существования пакета (maximum packet lifetime - MPL). Значение подполя числа пересылок устанавливается источником в исходное состояние 0 и инкрементируется на 1 при прохождении данной дейтаграммы через один роутер. Когда значение поля числа пересылок доходит до 16, дейтаграмма отвергается на основании допущения, что имеет место петля маршрутизации. Подполе MPL содержит максимальное время (в секундах), в течение которого пакет может оставаться в об'единенной сети.

За полем управления транспортировкой следует 8-битовое поле типа пакета (packet type). Это поле определяет формат поля данных.

Каждый из адресов сети источника и назначения имеют три поля: 32- битовый номер сети (network number), который уникальным образом обозначает сеть в об'единенной сети, 48-битовый номер хоста (host number), который является уникальным для всех когда-либо выпущенных хостов, и 16-битовый номер гнезда (socket number), который уникальным образом идентифицирует гнездо (процесс) в пределах конкретнго хоста. Адреса IEEE 802 эквивалентны номерам хостов, поэтому хосты, подключенные более чем к одной сети IEEE 802, имеют тот же самый адрес в каждом сегменте. Это делает сетевые номера избыточными, но тем не менее полезными для маршрутизации. Некоторые номера гнезд являются хорошо известными (well-known); это означает, что услуга, выполняемая программным обеспечением с использованием этих номеров гнезд, является статически определенной. Все другие номера гнезд допускают многократное использование.

XNS поддерживает пакеты с однопунктовой (из одного пункта в другой пункт), многопунктовой и широковещательной адресацией. Многопунктовые и широковещательные адреса далее делятся на 2 типа: прямые (directed) и глобальные (global). Прямые многопунктовые адреса доставляют пакеты членам группы многопунктовой адресации данной сети, заданной в адресе сети назначения с многопунктовой адресацией. Прямые широковещательные адреса доставляют пакеты всем членам заданной сети. Глобальные многопунктовые адреса доставляют пакеты всем членам данной группы в пределах всей об'единенной сети, в то время как глобальные широковещательные адреса доставляют пакеты во все адреса об'единенной сети. Один бит в номере хоста обозначает отдельный адрес в противовес многопунктовому адресу. Все единицы в поле хоста обозначают широковещательный адрес.

Для маршрутизации пакетов в об'единенной сети XNS использует схему динамической маршрутизации, называемую Протоколом информации маршрутизации (RIP). В настоящее время RIP является наиболее широко используемым Протоколом внутренних роутеров (interior gateway protocol - IGP) в сообществе Internet-среде международной сети, обеспечивющей связность практически со всеми университетами и научно- исследовательскими институтами, а также многими коммерческими организациями в США. Подробная информация о RIP дается в Главе 23 "RIP".

Транспортный уровень

Функции транспортного уровня OSI реализуются несколькими протоколами. Каждый из перечисленных ниже протоколов описан в спецификации ХNS как протокол уровня два.

Протокол упорядоченной передачи пакетов (Sequenced Packet Protocol - SPP) обеспечивает надежную, с установлением соединения и управлением потока, передачу пакетов от лица процессов клиента. По выполняемым функциям он похож на протокол TСР из комплекта протоколов Internet и на протокол ТР4 из комплекта протоколов OSI (смотри соответственно Главу 18 "Протоколы Internet" и Главу "Протоколы OSI" 20).

Каждый пакет SPP включает в себя номер последовательности (sequence number), который используется для упорядочивания пакетов и определения тех из них, которые были скопированы или потеряны. Пакеты SPP также содержат два 16-битовых идентификатора соединения (connection identifier). Каждый конец соединения определяет один идентификатор соединения. Оба идентификатора соединения вместе уникальным образом идентифицируют логическое соединение между процессами клиента.

Длина пакетов SPP не может быть больше 576 байтов. Процессы клиента могут согласовывать использование различных размеров пакетов во время организации соединения, однако SPP не определяет характер такого согласования.

Протокол обмена пакетами (Packet Exchange Protocol - PEP) является протоколом типа запрос-ответ, предназначенным обеспечивать надежность, которая больше надежности простых услуг дейтаграмм (например, таких, которые обеспечивает IDP), но меньше надежности SPP. По своим функциональным возможностям РЕР аналогичен Протоколу дейтаграмм пользователя (UDP) из комплекта протоколов Internet (смотри Главу 18 "Протоколы Internet"). PEP базируется на принципе одного пакета, обеспечивая повторные передачи, но не обеспечивая выявление дублированных пакетов. Он полезен для прикладных задач, в которых транзакции запрос-ответ являются идемпотентными (повторяемыми без повреждения контекста), или в которых надежная передача выполняется на другом уровне.

Протокол неисправностей (Error Protocol - EP) может быть использован любым процессом клиента для уведомления другого процесса клиента о том, что в сети имеет место ошибка. Например, этот протокол используется в ситуациях, когда какая-нибудь реализация SPP распознала дублированный пакет.

Протоколы высших уровней

XNS предлагает несколько протоколов высших уровней. Протокол "Печатание" (Printing) обеспечивает услуги принтера. Протокол "Ведение картотеки" (Filing) обеспечивает услуги доступа к файлам. Протокол "Очистка9 (Сlearinghouse) обеспечивает услуги, связанные с присвоением имени. Каждый из этих протоколов работает в дополнение к протоколу "Курьер" (Сourier), который обеспечивает соглашения для структурирования данных и взаимодействия процессов.

XNS также определяет протоколы уровня четыре. Это протоколы прикладного уровня, но поскольку они имеют мало общего с фактическими функциями связи, в спецификации XNS нет каких-либо определений по существу.

И наконец, протокол "Эхо" (Echo Protocol) используется для тестирования надежности узлов сети XNS. Он используется для поддержки таких функций, как функции, обеспечиваемые командой ping, которую можно встретить в Unix и других средах. Спецификация XNS описывает протокол "Эхо" как протокол уровня два.


Глава 23. RIP.

  • Формат таблицы маршрутизации
  • Формат пакета (Реализация IP)
  • Характеристики стабильности
    • Ограничение числа пересылок
    • Временные удерживания изменений
    • Расщепленные горизонты
    • Корректировки отмены маршрута

Библиографическая справка

Протокол Информации Маршрутизации (RIP) является протоколом маршрутизации, который был первоначально разработан для Универсального протокола PARC Xerox (где он назывался GWINFO) и использовался в комплекте протоколов ХNS. RIP начали связывать как с UNIX, так и с TCP/IP в 1982 г., когда версию UNIX, называемую Berkeley Standard Distribution (BSD), начали отгружать с одной из реализацией RIP, крторую называли "трассируемой" (routed) (слово произносится "route dee"). Протокол RIP, который все еще является очень популярным протоколом маршрутизации в сообществе Internet, формально определен в публикации "Протоколы транспортировки Internet" XNS (XNS Internet Transport Protocols) (1981 г.) и в Запросах для комментария (Request for Comments - RFC) 1058 (1988 г.).

RIP был повсеместно принят производителями персональных компьютеров (РС) для использования в их изделиях передачи данных по сети. Например, протокол маршрутизации AppleTalk (Протокол поддержания таблицы маршрутизации - RTMP) является модернизированной версией RIP. RIP также явился базисом для протоколов Novell, 3Com, Ungermann-Bass и Banyan. RIP компаний Novell и 3Com в основном представляет собой стандартный RIP компании Xerox. Ungermann-Bass и Banyan внесли незначительные изменения в RIP для удовлетворения своих нужд.

Формат таблицы маршрутизации

Каждая запись данных в таблице маршрутизации RIP обеспечивает разнообразную информацию, включая конечный пункт назначения, следующую пересылку на пути к этому пункту назначения и показатель (metric). Показатель обозначает расстояние до пункта назначения, выраженное числом пересылок до него. В таблице маршрутизации может находиться также и другая информация, в том числе различные таймеры, связанные с данным маршрутом. Типичная таблица маршрутизации RIP показана на Рис. 23-1.

Destination | Next hop | Distance | Timers | Flags
Network A | Router 1 | 3 | t1, t2, t3 | x,y
Network B | Router 2 | 5 | t1, t2, t3 | x,y
Network C | Router 1 | 2 | t1, t2, t3 | x,y
. . . | . . . | . . . | . . . | . . .

Figure 23-1

RIP поддерживает только самые лучшие маршруты к пункту назначения. Если новая информация обеспечивает лучший маршрут, то эта информация заменяет старую маршрутную информацию. Изменения в топологии сети могут вызывать изменения в маршрутах, приводя к тому, например, что какой-нибудь новый маршрут становится лучшим маршрутом до конкретного пункта назначения. Когда имеют место изменения в топологии сети, то эти изменения отражаются в сообщениях о корректировке маршрутизации. Например, когда какой-нибудь роутер обнаруживает отказ одного из каналов или другого роутера, он повторно вычисляет свои маршруты и отправляет сообщения о корректировке маршрутизации. Каждый роутер, принимающий сообщение об обновлении маршрутизации, в котором содержится изменение, корректирует свои таблицы и распространяет это изменение.

Формат пакета (Реализация IP)

На Рис. 23-2 изображен формат пакета RIP для реализаций IP так, как он определен в RFC 1058.

ПРИМЕЧАНИЕ: На Рис. 23-2 представлен формат RIP, используемый для сетей IP в Internet. В некоторые другие варианты RIP внесены незначительные изменения формата и (или) имен файлов, которые здесь перечислены, но функциональные возможности базового алгоритма маршрутизации те же самые.

Первое поле в пакете RIP-это поле команд (command). Это поле содержит целое число, обозначающее либо запрос, либо ответ. Команда "запрос" запрашивает отвечающую систему об отправке всей таблицы маршрутизации или ее части. Пункты назначения, для которых запрашивается ответ, перечисляются далее в данном пакете. Ответная команда представляет собой ответ на запрос или чаще всего какую-нибудь незатребованную регулярную корректировку маршрутизации. Отвечающая система включает всю таблицу маршрутизации или ее часть в ответный пакет. Регулярные сообщения о корректировке маршрутизации включают в себя всю таблицу мааршрутизации.

Поле версии (version) определяет реализуемую версию RIP. Т.к. в об'единенной сети возможны многие реализации RIP, это поле может быть использовано для сигнализирования о различных потенциально несовместимых реализациях.

За 16-битовым полем, состоящим из одних нулей, идет поле идентификатора семейства адресов (аddress family identifier). Это поле определяет конкретное используемое семейство адресов. В сети Internet (крупной международной сети, об'единяющей научно-исследовательские институты, правительственные учреждения, университеты и частные предприятия) этим адресным семейством обычно является IP (значение=2), но могут быть также представлены другие типы сетей.

Следом за еще одним 16-битовым полем, состоящим из одних нулей, идет 32-битовое поле адреса (address). В реализациях RIP Internet это поле обычно содержит какой-нибудь адрес IP.

За еще двумя 32-битовыми полями из нулей идет поле показателя RIP (metric). Этот показатель представляет собой число пересылок (hop count). Он указывает, сколько должно быть пересечено транзитных участков (роутеров) об'единенной сети, прежде чем можно добраться до пункта назначения.

В каждом отдельном пакете RIP IP допускается появление дo 25 вхождений идентификатора семейства адреса, обеспечиваемых полями показателя. Другими словами, в каждом отдельном пакете RIP может быть перечислено до 25 пунктов назначения. Для передачи информации из более крупных маршрутных таблиц используется множество пакетов RIP.

Как и другие протоколы маршрутизации, RIP использует определенные таймеры для регулирования своей работы. Таймер корректировки маршрутизации RIP (routing update timer) обычно устанавливается на 30 сек., что гарантирует отправку каждым роутером полной копии своей маршрутной таблицы всем своим соседям каждые 30 секунд. Таймер недействующих маршрутов (route invalid timer) определяет, сколько должно пройти времени без получения сообщений о каком-нибудь конкретном маршруте, прежде чем он будет признан недействительным. Если какой- нибудь маршрут признан недействительным, то соседи уведомяются об этом факте. Такое уведомление должно иметь место до истечения времени таймера отключения маршрута (route flush timer). Когда заданное время таймера отключения маршрута истекает, этот маршрут удаляется из таблицы маршрутизации. Типичные исходные значения для этих таймеров- 90 секунд для таймера недействующего маршрута и 270 секунд для таймера отключения маршрута.

Характеристики стабильности

RIP определяет ряд характеристик, предназначенных для более стабильной работы в условиях быстро изменяющейся топологии сети. В их число входит ограничение числа пересылок, временные удерживания изменений (hold-downs), расщепленные горизонты (split-horizons) и корректировки отмены (poison reverse updates).

Ограничение числа пересылок
RIP разрешает максимальное число пересылок, равное 15. Любому пункту назначения, который находится дальше, чем на расстоянии 15 пересылок, присваивается ярлык "недосягаемого". Максимальное число пересылок RIP в значительной мере ограничивает его применение в крупных об'единенных сетях, однако способствует предотвращению появления проблемы, называемой счетом до бесконечности (count to infinity), приводящей к зацикливанию маршрутов в сети. Проблема счета до бесконечности представлена на Рис. 23-3.

Рассмотрим, что случится, если на Рис. 23-3 канал Роутера 1 (R1) (канал а), связывающий его с сетью А, откажет. R1 проверяет свою информацию и обнаруживает, что Роутер 2 (R2) связан с сетью А каналом длиной в одну пересылку. Т.к. R1 знает, что он напрямую соединен с R2, то он об'являет о маршруте из двух пересылок до сети А и начинает направлять весь трафик в сеть А через R2. Это приводит к образованию маршрутной петли. Когда R2 обнаруживает, что R1 может теперь достичь сеть А за две пересылки, он изменяет запись своих собственных данных в таблице маршрутизации, чтобы показать, что он имеет тракт длиной в 3 пересылки до сети А. Эта проблема, а также данная маршрутная петля будут продолжаться бесконечно, или до тех пор, пока не будет навязано какое-нибудь внешнее граничное условие. Этим граничным условием является максимальное число пересылок RIP. Когда число пересылок превысит 15, данный маршрут маркируется как недосягаемый. Через некоторое время этот маршрут удаляется из таблицы.

Временные удерживания изменений
Временные удерживания изменений используются для того, чтобы помешать регулярным сообщениям о корректировке незаконно восстановить в правах маршрут, который оказался испорченным. Когда какой-нибудь маршрут отказывает, соседние роутеры обнаруживают это. Затем они вычисляют новые маршруты и отправляют сообщения об обновлении маршрутизации, чтобы информировать своих соседей об изменениях в маршруте. Эта деятельность приводит к появлению целой волны коррекций маршрутизации, которые фильтруются через сеть.

Приведенные в действие корректировки неодновременно прибывают во все устройства сети. Поэтому возможно, что какое-нибудь устройство, которое еще не получило информацию о каком-нибудь отказе в сети, может отправить регулярное сообщение о корректировке (в котором маршрут, который только что отказал, все еще числится исправным) в другое устройство, которое только что получило уведомление об этом отказе в сети. В этом случае это другое устройство теперь будет иметь (и возможно, рекламировать) неправильную маршрутную информацию.

Команды о временном удерживании указывают роутерам, чтобы они на некоторое время придержали любые изменения, которые могут оказать влияние на только что удаленные маршруты. Этот период удерживания обычно рассчитывается таким образом, чтобы он был больше периода времени, необходимого для внесения кокого-либо изменения о маршрутизации во всю сеть. Удерживание изменений предотвращает появление проблемы счета до бесконечности.

Расщепленные горизонты
Расщепленные горизонты используют преимущество того факта, что никогда не бывает полезным отправлять информацию о каком-нибудь маршруте обратно в том направлении, из которого пришла эта информация. Для иллюстрации этого положения рассмотрим Рис. 23-4.

Pоутер 1 (R1) первоначально об'являет, что он располагает каким- то маршрутом до Сети А. Pоутеру 2 (R2) нет оснований включать этот маршрут в свою корректировку, отсылаемую обратно роутеру R1, т.к. R1 ближе к Сети А. Правило расщепленного горизонта гласит, что R2 должен исключить (попасть на) этот маршрут при любых корректировках, которые он отправляет в R1.

Правило расщепленного горизонта помогает предотвратить маршрутные петли между двумя узлами. Например, рассмотрим случай, когда отказывает интерфейс R1 с Сетью А. При отсутствии расщепленных горизонтов R2 продолжает информировать R1 о том, что он может попасть в Сеть А через R1. Если R1 не располагает достаточным интеллектом, то он действительно может выбрать маршрут, предлагаемый R2, в качестве альтернативы для своей отказавшей прямой связи, что приводит к образованию петли маршрутизации. И хотя временное удерживание изменений должно предотвращать это, применение расщепленного горизонта обеспечивает дополнительную стабильность алгоритма.

Корректировки отмены маршрута
В то время как задачей расщепленных горизонтов является предотвращение образования маршрутных петель между соседними роутерами, корректировки отмены преданазначены для устранения более крупных маршрутных петель. В основе их действия лежит положение о том, что увеличение значения показателей маршрутизации обычно указывает на наличие маршрутных петель. В этом случае отправляются корректировки отмены для удаления данного маршрута и помещения его в состояние временного удерживания.


Глава 24. IGRP.

  • Технология
  • Формат пакета
  • Характеристики стабильности
    • Временные удерживания изменений
    • Расщепленные горизонты
    • Корректировки отмены маршрута
    • Таймеры

Библиографическая справка

Протокол маршрутизации внутренних роутеров (Interior Gateway Routing Protokol-IGRP) является протоколом маршрутизации, разработанным в середине 1980 гг. компанией Cisco Systems, Inc. Главной целью, которую преследовала Cisco при разработке IGRP, было обеспечение живучего протокола для маршрутизации в пределах автономной системы (AS), имеющей произвольно сложную топологию и включающую в себя носитель с разнообразными характеристиками ширины полосы и задержки. AS является набором сетей, которые находятся под единым управлением и совместно используют общую стратегию маршрутизации. Обычно AS присваивается уникальный 16-битовый номер, который назначается Центром Сетевой Информации (Network Information Center - NIC) Сети Министерства Обороны (Defence Data Network - DDN).

В середине 1980 гг. самым популярным протоколом маршрутизации внутри AS был Протокол Информации Маршрутизации (RIP). Хотя RIP был вполне пригоден для маршрутизации в пределах относительно однородных об'единенных сетей небольшого или среднего размера, его ограничения сдерживали рост сетей. В частности, небольшая допустимая величина числа пересылок (15) RIP ограничивала размер об'единенной сети, а его единственный показатель (число пересылок) не обеспечивал достаточную гибкость в сложных средах (смотри Главу 23 "RIP"). Популярность роутеров Cisco и живучесть IGRP побудили многие организации, которые имели крупные об'единенные сети, заменить RIP на IGRP.

Первоначальная реализация IGRP компании Cisco работала в сетях IP. Однако IGRP был предназначен для работы в любой сетевой среде, и вскоре Cisco распространила его для работы в сетях использующих Протокол Сет без Установления Соединения (Connectionless Network Protocol - CLNP) OSI.

Технология

IGRP является протоколом внутренних роутеров (IGP) с вектором расстояния. Протоколы маршрутизации с вектором расстояния требуют от каждого роутера отправления через определенные интервалы времени всем соседним роутерам всей или части своей маршрутной таблицы в сообщениях о корректировке маршрута. По мере того, как маршрутная информация распространяется по сети, роутеры могут вычислять расстояния до всех узлов об'единенной сети.

Протоколы маршрутизации с вектором расстояния часто противопоставляют протоколам маршрутизации с указанием состояния канала, которые отправляют информацию о локальном соединении во все узлы об'единенной сети. Рассмотрение двух популярных протоколов, использующих алгоритм маршрутизации с указанием состояния канала, "Открытый протокол с алгоритмом поиска наикратчайшего пути" (Open Shortest Path First) и "Промежуточная система-Промежуточная система" (Intermediate System to Intermediate System (IS-IS)), дается соответственно в Главе 25 "OSPF" и Главе 28 "Маршрутизация OSI".

IGRP использует комбинацию (вектор) показателей. Задержка об'единенной сети (internetwork delay), ширина полосы (bandwidth), надежность (reliability) и нагрузка (load) - все эти показатели учитываются в виде коэффициентов при принятии маршрутного решения. Администраторы сети могут устанавливать факторы весомости для каждого из этих показателей. IGRP использует либо установленные администратором, либо устанавливаемые по умолчанию весомости для автоматического расчета оптимальных маршрутов.

IGRP предусматривает широкий диапазон значений для своих показателей. Например, надежность и нагрузка могут принимать любое значение в интервале от 1 до 255, ширина полосы может принимать значения, отражающие скорости пропускания от 1200 до 10 гигабит в секунду, в то время как задержка может принимать любое значение от 1-2 до 24-го порядка. Широкие диапазоны значений показателей позволяют производить удовлетворительную регулировку показателя в об'единенной сети с большим диапазоном изменения характеристик производительности. Самым важным является то, что компоненты показателей об'единяются по алгоритму, который определяет пользователь. В результате администраторы сети могут оказывать влияние на выбор маршрута, полагаясь на свою интуицию.

Для обеспечения дополнительной гибкости IGRP разрешает многотрактовую маршрутизацию. Дублированные линии с одинаковой шириной полосы могут пропускать отдельный поток трафика циклическим способом с автоматическим переключением на вторую линию, если первая линия выходит из строя. Несколько трактов могут также использоваться даже в том случае, если показатели этих трактов различны. Например, если один тракт в три раза лучше другого благодаря тому, что его показатели в три раза ниже, то лучший тракт будет использоваться в три раза чаще. Только маршруты с показателями, которые находятся в пределах определенного диапазона показателей наилучшего маршрута, используются для многотрактовой маршрутизации.

Формат пакета

Первое поле пакета IGRP содержит номер версии (version number). Этот номер версии указывает на используемую версию IGRP и сигнализирует о различных, потенциально несовместимых реализациях.

За полем версии идет поле операционного кода (opcode). Это поле обозначает тип пакета. Операционный код, равный 1, обозначает пакет корректировки; равный 2-пакет запроса. Пакеты запроса используются источником для запроса маршрутной таблицы из другого роутера. Эти пакеты состоят только из заголовка, содержащего версию, операционный код и поля номера AS. Пакеты корректировки содержат заголовок, за которым сразу же идут записи данных маршрутной таблицы. На записи данных маршрутной таблицы не накладывается никаких ограничений, за исключением того, что пакет не может превышать 1500 байтов, вместе с заголовком IP. Если этого недостаточно для того, чтобы охватить весь об'ем маршрутной таблицы, то используются несколько пакетов.

За полем операционного кода идет поле выпуска (edition). Это поле содержит последовательный номер, который инкрементируется, когда маршрутная таблица каким-либо образом изменяется. Это значение номера выпуска используется для того, чтобы позволить роутерам избежать обработки корректировок, содержащих информацию, которую они уже видели.

За полем выпуска идет поле, содержащее номер AS (AS number). Это поле необходимо по той причине, что роутеры Cisco могут перекрывать несколько AS. Несколько AS (или процессов IGRP) в одном роутере хранят информацию маршрутизации AS отдельно.

Следующие три поля обозначают номер подсетей, номер главных сетей и номер внешних сетей в пакете корректировки. Эти поля присутствуют потому, что сообщения корректировки IGRP состоят из трех частей: внутренней для данной подсети, внутренней для текущей AS и внешней для текущей AS. Сюда включаются только подсети сети, связанной с тем адресом, в который отправляется данная корректировка. Главные сети (т.е. не подсети) помещаются во "внутреннюю для текущей AS" часть пакета, если только они не помечены четко как внешние. Сети помечаются как внешние, если информация о них поступает во внешней части сообщения из другого роутера.

Последним полем в заголовке IGRP является поле контрольной суммы (checksum). Это поле содержит какую-нибудь контрольную сумму для заголовка IGRP и любую информацию корректировки, содержащуюся в данном пакете. Вычисление контрольной суммы позволяет принимающему роутеру проверять достоверность входящего пакета.

Сообщения о корректировке содержат последовательность из семи полей данных для каждой записи данных маршрутной таблицы. Первое из этих полей содержит три значащих байта адреса (address) (в случае адреса IP). Следующие пять полей содержат значения показателей. Первое из них обозначает задержку (delay), выраженную в десятках микросекунд. Диапазон перекрывает значения от 10 мксек. до 167 сек. За полем задержки следует поле ширины полосы (bandwidth). Ширина полосы выражена в единицах 1 Кбит/сек и перекрывает диапазон от линии с шириной полосы 1200 бит/сек до 10 Гбит/сек. Затем идет поле MTU, которое обеспечивет размер MTU в байтах. За полем MTU идет поле надежности (reliability), указывающее процент успешно переданных и принятых пакетов. Далее идет поле нагрузки (load), которое обозначает занятую часть канала в процентном отношении. Последним полем в каждой записи данных маршрутизации является поле числа пересылок (hop count). И хотя использование числа пересылок не явно выражено при определении показателя, тем не менее это поле содержится в пакете IGRP и инкрементируется после обработки пакета, обеспечивая использование подсчета пересылок для предотвращения петель.

Характеристики стабильности

IGRP обладает рядом характеристик, предназначенных для повышения своей стабильности. В их число входят временное удерживание изменений, расщепленные горизонты и корректировки отмены.

Временные удерживания изменений
Временное удерживание изменений используется для того, чтобы помешать регулярным сообщениям о коррректировке незаконно восстановить в правах маршрут, который возможно был испорчен. Когда какой-нибудь роутер выходит из строя, соседние роутеры обнаруживают это через отсутствие регурярного поступления запланированных сообщений. Далее эти роутеры вычисляют новые маршруты и отправляют сообщения о корректировке маршрутизации, чтобы информировать своих соседей о данном изменении маршрута. Результатом этой деятельности является запуск целой волны корректировок, которые фильтруются через сеть.

Приведенные в действие корректировки поступают в каждое сетевое устройство не одновременно. Поэтому возможно, что какое-нибудь устройство, которое еще не было оповещено о неисправности в сети, может отправить регулярное сообщение о корректировке (указывающее, что какой-нибудь маршрут, который только что отказал, все еще считается исправным) в другое устройство, которое только что получило уведомление о данной неисправности в сети. В этом случае последнее устройство будет теперь содержать (и возможно, рекламировать) неправильную информацию о маршрутизации.

Команды о временном удерживании изменений предписывают роутерам удерживать в течение некоторого периода времени любые изменения, которые могут повлиять на маршруты. Период удерживания изменений обычно рассчитывается так, чтобы он был больше периода времени, необходимого для корректировки всей сети в соответствии с каким-либо изменением маршрутизации.

Расщепленные горизонты
Понятие о расщепленных горизонтах проистекает из того факта, что никогда не бывает полезным отправлять информацию о каком-нибудь маршруте обратно в том направлении, из которого она пришла. Для иллюстрации этого положения рассмотрим Рис. 24-2.

Роутер 1 (R1) первоначально об'являет, что у него есть какой-то маршрут до Сети А. Роутеру 2 (R2) нет оснований включать этот маршрут в свою корректировку, отправляемую в R1, т.к. R1 ближе к Сети А. В правиле о расщепленных горизонтах говорится, что R2 должен исключить этот маршрут независимо от того, какие корректировки он отправляет в R1.

Правило о расщепленных горизонтах помогает предотвращать зацикливание маршрутов. Например, рассмотрим случай, когда интерфейс R1 с Сетью А отказывает. Без расщепленных горизонтов R2 продолжал бы информировать R1, что он может попасть в Сеть А (через R1!). Если R1 не располагает достаточным интеллектом, он действительно может выбрать маршрут, предлагаемый R2, в качестве альтернативы своему отказавшему прямому соединению, что приводит к образованию маршрутной петли. И хотя удерживание изменений должно помешать этому, в IGRP реализованы также расщепленные горизонты, т.к. они обеспечивают дополнительную стабильность алгоритма.

Корректировки отмены маршрута
В то время как расщепленные горизонты должны препятствовать зацикливанию маршрутов между соседними роутерами, корректировки отмены маршрута предназначены для борьбы с более крупными маршрутными петлями. Увеличение значений показателей маршрутизации обычно указывает на появление маршрутных петель. В этом случае посылаются корректировки отмены, чтобы удалить этот маршрут и перевести его в состояние удерживания. В реализации IGRP компании Cisco корректировки отмены отправляются в том случае, если показатель маршрута увеличивается на коэффициент 1.1 или более.

Таймеры
IGRP обеспечивает ряд таймеров и переменных, содержащих временные интервалы. Сюда входят таймер корректировки, таймер недействующих маршрутов, период времени удерживания изменений и таймер отключения. Таймер корректировки определяет, как часто должны отправляться сообщения о корректировке маршрутов. Для IGRP значение этой переменной, устанавливаемое по умолчанию, равно 90 сек. Таймер недействующих маршрутов определяет, сколько времени должен ожидать роутер при отсутствии сообщений о корректировке какого-нибудь конкретного маршрута, прежде чем об'явить этот маршрут недействующим. Время по умолчанию IGRP для этой переменной в три раза превышает период корректировки. Переменная величина времени удерживания определяет промежуток времени удерживания. Время по умолчанию IGRP для этой переменной в три раза больше периода таймера корректировки, плюс 10 сек. И наконец, таймер отключения указывает, сколько времени должно пройти прежде, чем какой-нибудь роутер должен быть исключен из маршрутной таблицы. Время по умолчанию IGRP для этой величины в семь раз превышает период корректировки маршрутизации.


Глава 24. OSPF.

  • Основы технологии
  • Иерархия маршрутизации
  • Алгоритм SPF
  • Формат пакета
  • Дополнительные характеристики OSPF

Библиографическая справка

Открытый протокол, базирующийся на алгоритме поиска наикратчайшего пути (Open Shortest Path Fisrt - OSPF) является протоколом маршрутизации, разработанным для сетей IP рабочей группой Internet Engineering Task Force (IETF), занимающейся разработкой протоколов для внутрисистемных роутеров (interior gateway protocol - IGP). Рабочая группа была образована в 1988 г. для разработки протокола IGP, базирующегося на алгоритме "поиска наикратчайшего пути" (shortest path first - SPF), с целью его использования в Internet, крупной международной сети, об'единяющей научно-исследовательские институты, правительственные учреждения, университеты и частные предприятия. Как и протокол IGRP (смотри Главу 24 "IGRP"), OSPF был разработан по той причине, что к середине 1980 гг. непригодность RIP для обслуживания крупных гетерогенных об'единенных систем стала все более очевидна (смотри Главу 23 "RIP").

ОSPF явился результатом научных исследований по нескольким направлениям, включающим:

Алгоритм SPF компании Bolt, Beranek и Newman (BBN), разработанный для Arpanet (программы с коммутацией пакетов, разработанной BBN в начале 1970 гг., которая явилась поворотным пунктом в истории разработки сетей) в 1978 г.
Исследования Koмпании Radia Perlman по отказоустойчивости широкой рассылки маршрутной информации (1988).
Исследования BBN по маршрутизации в отдельной области (1986).
Одна из первых версий протокола маршрутизации IS-IS OSI

(Информация о IS-IS дается в Главе 28 "Maршрутизация OSI").

Как видно из его названия, OSPF имеет две основных характеристики. Первая из них-это то, что протокол является открытым, т.е. его спецификация является общественным достоянием. Спецификация OSPF опубликована в форме Запроса для Комментария (RFC) 1247. Второй его главной характеристикой является то, что он базируется на алгоритме SPF. Алгоритм SPF иногда называют алгоритмом Dijkstra по имени автора, который его разработал.

Основы технологии

OSPF является протоколом маршрутизации с об'явлением состояния о канале (link-state). Это значит, что он требует отправки об'явлений о состоянии канала (link-state advertisement - LSA) во все роутеры, которые находятся в пределах одной и тойже иерархической области. В oб'явления LSA протокола OSPF включается информация о подключенных интерфейсах, об использованных показателях и о других переменных. По мере накопления роутерами OSPF информации о состоянии канала, они используют алгоритм SPF для расчета наикратчайшего пути к каждому узлу.

Являясь алгоритмом с об'явлением состояния канала, OSPF отличается от RIP и IGRP, которые являются протоколами маршрутизации с вектором расстояния. Роутеры, использующие алгоритм вектора расстояния, отправляют всю или часть своей таблицы маршрутизации в сообщения о корректировке маршрутизации, но только своим соседям.

Иерархия маршрутизации

В отличие от RIP, OSPF может работать в пределах некоторой иерархической системы. Самым крупным об'ектом в этой иерархии является автономная система (Autonomous System - AS) AS является набором сетей, которые находятся под единым управлением и совместно используют общую стратегию маршрутизации. OSPF является протоколом маршрутизации внутри AS, хотя он и способен принимать маршруты из других AS и отправлять маршруты в другие AS.

Любая AS может быть разделена на ряд областей (area). Область - это группа смежных сетей и подключенных к ним хостов. Роутеры, имеющие несколько интерфейсов, могут участвовать в нескольких областях. Такие роутеры, которые называются роутерами границы областей (area border routers), поддерживают отдельные топологические базы данных для каждой области.

Топологическая база (topological database) данных фактически представляет собой общую картину сети по отношению к роутерам. Топологическая база данных содержит набор LSA, полученных от всех роутеров, находящихся в одной области. Т.к. роутеры одной области коллективно пользуются одной и той же информацией, они имеют идентичные топологические базы данных.

Термин "домен" (domain) исользуется для описания части сети, в которой все роутери имеют идентичную топологическую базу данных. Термин "домен" часто используется вместо AS.

Топология области является невидимой для об'ектов, находящихся вне этой области. Путем хранения топологий областей отдельно, OSPF добивается меньшего трафика маршрутизации, чем трафик для случая, когда AS не разделена на области.

Разделение на области приводит к образованию двух различных типов маршрутизации OSPF, которые зависят от того, находятся ли источник и пункт назначения в одной и той же или разных областях. Маршрутизация внутри области имеет место в том случае, когда источник и пункт назначения находятся в одной области; маршрутизация между областями - когда они находятся в разных областях.

Стержневая часть OSPF (backbone) отвечает за распределение маршрутной информации между областями. Она включает в себя все роутеры границы области, сети, которые не принадлежат полностью како-либо из областей, и подключенные к ним роутеры. На Рис. 25-1 представлен пример об'единенной сети с несколькими областями.

На этом рисунке роутеры 4, 5, 6, 10, 11 и 12 образуют стержень. Если хост Н1 Области 3 захочет отправить пакет хосту Н2 Области 2, то пакет отправляется в роутер 13, который продвигает его в роутер 12, который в свою очередь отправляет его в роутер 11. Роутер 11 продвигает пакет вдоль стержня к роутеру 10 границы области, который отправляет пакет через два внутренних роутера этой области (роутеры 9 и 7) до тех пор, пока он не будет продвинут к хосту Н2.

Сам стержень представляет собой одну из областей OSPF, поэтому все стержневые роутеры используют те же процедуры и алгоритмы поддержания маршрутной информации в пределах стержневой области, которые используются любым другим роутером. Топология стержневой части невидима для всех внутренних роутеров точно также, как топологии отдельных областей невидимы для стержневой части.

Область может быть определена таким образом, что стержневая часть не будет смежной с ней. В этом случае связность стержневой части должна быть восстановлена через виртуальные соединения. Виртуальные соединения формируются между любыми роутерами стержневой области, которые совместно используют какую-либо связь с любой из нестержневых областей; они функционируют так, как если бы они были непосредственными связями.

Граничные роутеры AS, использующие OSPF, узнают о внешних роутерах через протоколы внешних роутеров (EGPs), таких, как Exterior Gateway Protocol (EGP) или Border Gateway Protocol (BGP), или через информацию о конфигурации (информация об этих протоколах дается соответственно в Главе 26 "EGP" и Главе 27 "BGP").

Алгоритм SPF

Алгоритм маршрутизации SPF является основой для операций OSPF. Когда на какой-нибудь роутер SPF подается питание, он инициилизирует свои структуры данных о протоколе маршрутизации, а затем ожидает индикации от протоколов низшего уровня о том, что его интерфейсфы работоспособны.

После получения подтверждения о работоспособности своих интерфейсов роутер использует приветственный протокол (hello protocol) OSPF, чтобы приобрести соседей (neighbor). Соседи - это роутеры с интерфейсами с общей сетью. Описываемый роутер отправляет своим соседям приветственные пакеты и получает от них такие же пакеты. Помимо оказания помощи в приобретении соседей, приветственные пакеты также действуют как подтверждение дееспособности, позволяя другим роутерам узнавать о том, что другие роутери все еще функционируют.

В сетях с множественным доступом (multi-access networks) (сетях, поддержиающих более одного роутера), протокол Hello выбирает назначенный роутер (designated router) и дублирующий назначенный роутер. Назначеный роутер, помимо других функций, отвечает за генерацию LSA для всей сети с множественным доступом. Назначенные роутеры позволяют уменьшить сетевой трафик и об'ем топологической базы данных.

Если базы данных о состоянии канала двух роутеров являются синхронными, то говорят, что эти роутеры смежные (adjacent). В сетях с множественным доступом назначенные роутеры определяют, какие роутеры должны стать смежными. Топологические базы данных синхронизируются между парами смежных роутеров. Смежности управляют распределением пакетов протокола маршрутизации. Эти пакеты отправляются и принимаются только на смежности.

Каждый роутер периодическив отправляет какое-нибудь LSA. LSA также отправляются в том случае, когда изменяется состояние какого- нибудь роутера. LSA включает в себя информацию о смежностях роутера. При сравнении установленных смежностей с состоянием канала быстро обнаруживаются отказавшие роутеры, и топология сети изменяется сооответствующим образом. Из топологической базы данных, генерируемых LSA, каждый роутер рассчитывает дерево наикратчайшего пути, корнем которого является он сам. В свою очередь дерево наикратчайшего пути выдает маршрутную таблицу.

Формат пакета

Все пакеты OSPF начинаются с 24-байтового заголовка, как показано на Рис. 25-2.

Первое поле в заголовке OSPF - это номер версии OSPF (version number). Номер версии обозначает конкретную используемую реализацию OSPF.

За номером версии идет поле типа (type). Существует 5 типов пакета OSPF:

Hello.
Отправляется через регулярные интервалы времени для установления и поддержания соседских взаимоотношений.
Database Description.
Описание базы данных. Описывает содержимое базы данных; обмен этими пакетами производится при инициализации смежности.
Link-State Request
Запрос о состоянии канала. Запрашивает части топологической базы данных соседа. Обмен этими пакетами производится после того, как какой-нибудь роутер обнаруживает, (путем проверки пакетов описания базы данных), что часть его топологической базы данных устарела.
Link-State Update
Корректировка состояния канала. Отвечает на пакеты запроса о состоянии канала. Эти пакеты также используются для регулярного распределения LSA. В одном пакете могут быть включены несколько LSA.
Link-State Acknowledgement
Подтверждение состояния канала. Подтверждает пакеты корректировки состояния канала. Пакеты корректировки состояния канала должны быть четко подтверждены, что является гарантией надежности процесса лавинной адресации пакетов корректировки состояния канала через какую-нибудь область.

Каждое LSA в пакете корректировки состояния канала содержит тип поля. Существуют 4 типа LSA:

Router links advertisements (RLA)
Об'явления о каналах роутера. Описывают собранные данные о состоянии каналов роутера, связывающих его с конкретной областью. Любой роутер отправляет RLA для каждой области, к которой он принадлежит. RLA направляются лавинной адресацией через всю область, но они не отправляются за ее пределы.
Network links advertisements (NLA)
Об'явления о сетевых каналах. Отправляются назначенными роутерами. Они описывают все роутеры, которые подключены к сети с множественным доступом, и отправляются лавинной адресацией через область, содержащую данную сеть с множественным доступом.
Summary links advertisements (SLA)
Суммарные об'явления о каналах. Суммирует маршруты к пунктам назначения, находящимся вне какой-либо области, но в пределах данной AS. Они генерируются роутерами границы области, и отправляются лавинной адресацией через данную область. В стержневую область посылаются об'явления только о внутриобластных роутерах. В других областях рекламируются как внутриобластные, так и межобластные маршруты.
AS external links advertisements
Об'явления о внешних каналах AS. Описывают какой-либо маршрут к одному из пунктов назначения, который является внешним для данного AS. Об'явления о внешних каналах AS вырабатываются граничными роутерами AS. Этот тип об'явлений является единственным типом об'явлений, которые продвигаются во всех направлениях данной AS; все другие об'явления продвигаются только в пределах конкретных областей.

За полем типа заголовка пакета OSPF идет поле длины пакета (packet length). Это поле обеспечивает длину пакета вместе с заголовком OSPF в байтах.

Поле идентификатора роутера (router ID) идентифицирует источник пакета.

Поле идентификатора области (area ID) идентифицирует область, к которой принадлежит данный пакет. Все пакеты OSPF связаны с одной отдельной областью.

Стандартное поле контрольной суммы IP (checksum) проверяет содержимое всего пакета для выявления потенциальных повреждений, имевших место при транзите.

За полем контрольной суммы идет поле типа удостоверения (authentication type). Примером типа удостоверения является "простой пароль". Все обмены протокола OSPF проводятся с установлением достоверности. Тип удостоверения устанавливается по принципу "отдельный для каждой области".

За полем типа удостоверения идет поле удостоверения (authentication). Это поле длиной 64 бита и содержит информацию удостоверения.

Дополнительные характеристики OSPF

В числе дополнительных характеристик OSRF - равные затраты, многотрактовая маршрутизация (multipath routing) и маршрутизация, базирующаяся на запросах типа услуг высшего уровня (type of service - TOS). Базирующаяся на TOS маршрутизация поддерживает те протоколы высшего уровня, которые могут назначать конкретные типы услуг. Например, какая-нибудь прикладная программа может включить требование о том, что определенная информация является срочной. Если OSPF имеет в своем распоряжении каналы с высоким приоритетом, то они могут быть использованы для транспортировки срочных дейтаграмм.

OSPF обеспечивает один или более показателей. Если используется только один показатель, то он считается произвольным, и TOS не обеспечивается. Если используется более одного показателя, то TOS обеспечивается факультативно путем использования отдельного показателя (и следовательно, отдельной маршрутной таблицы) для каждой из 8 комбинаций, образованной тремя битами IP TOS: битом задержки (delay), производительности (throughput) и надежности (reliability). Например, если биты IP TOS задают небольшую задержку, низкую производительность и высокую надежность, то OSPF вычисляет маршруты во все пункты назначения, базируясь на этом обозначении TOS.

Маски подсети IP включаются в каждый об'явленный пункт назначения, что позволяет использовать маски подсети переменной длины (variable-length subnet masks). С помощью масок подсети переменной длины сеть IP может быть разбита на несколько подсетей разной величины. Это обеспечивает администраторам сетей дополнительную гибкость при выборе конфигурации сети.


Глава 26. EGP.

  • Основы технологии
  • Формат пакета
  • Типы сообщений
    • Приобретение соседа
    • Досягаемость соседа
    • Опрос
    • Корректиравка маршрутизации
    • Сообщения о неисправностях

Библиографическая справка

Протокол внешних роутеров (Exterior Gateway Protocol-EGP) является протоколом междоменной досягаемости, который применяется в Internet - международной сети, об'единяющей университеты, правительственные учреждения, научно-исследовательские организации и частные коммерческие концерны. EGP документально оформлен в Запросах для Комментария (RFC) 904, опубликованных в апреле 1984 г.

Являясь первым протоколом внешних роутеров, который получил широкое признание в Internet, EGP сыграл важную роль. К сожалению, недостатки EGP стали более очевидными после того, как Internet стала более крупной и совершенной сетью. Из-за этих недостатков EGP в настоящее время не отвечает всем требованиям Internet и заменяется другими протоколами внешних роутеров, такими, как Протокол граничных роутеров (Border Gateway Protocol - BGP) и Протокол междоменной маршрутизации (Inter-Domain Routing Protocol - IDRP) (смотри Главу 27 "BGP" и Главу 28 "Маршрутизация OSI").

Основы технологии

EGP первоначально предназначался для передачи информации о досягаемости в стержневые роутеры ARPANET и получения ее от них. Информация передавалась из отдельных узлов источника, находящихся в различных административных доменах, называемых автономными системами (AS), вверх в стержневые роутеры, которые передавали эту информацию через стержневую область до тех пор, пока ее можно было передать вниз к сети пункта назначения, находящейся в пределах другой AS. Эти взаимоотношения между EGP и другими компонентами ARPANET показаны на Рис. 26-1.

Несмотря на то, что EGP является динамическим протоколом маршрутизации, он использует очень простую схему. Он не использует показатели, и следовательно, не может принимать по настоящему интеллектуальных решений о маршрутизации. Корректировки маршрутизации EGP содержат информацию о досягаемости сетей. Другими словами, они указывают, что в определенные сети попадают через определенные роутеры.

EGP имеет три основных функции. Во-первых, роутеры, работающие с EGP, организуют для себя определенный набор соседей. Соседи - это просто другие роутеры, с которыми какой-нибудь роутер хочет коллективно пользоваться информацией о досягаемости сетей; какие-либо указания о географическом соседстве не включаются. Во-вторых, роутеры EGP опрашивают своих соседей для того, чтобы убедиться в их работоспособности. В-третьих, роутеры EGP oтправляют сообщения о корректировках, содержащих информацию о досягаемости сетей в пределах своих AS.

Формат пакета

Пакет EGPпредставлен на Рис. 26-2.

Первым полем в заголовке пакета EGP является поле номера версии EGP (EGP version number). Это поле обозначает текущую версию EGP и проверяется приемными устройствами для определения соответствия между номерами версий отправителя и получателя.

Следующим полем является поле типа (type), которое обозначает тип сообщения. EGP выделяет 5 отдельных типов сообщения.

Table 26-1 : EGP Message Types

Message | Function
Neighbor acquisition | Establishes/de-establishes neighbors
Neighbor reachability | Determines if neighbors are alive
Poll | Determines reachability of a particular network
Routing update | Provides routing updates
Error | Indicates error conditions

За полем типа следует поле кода (code). Это поле определяет различие между подтипами сообщений.

Следующее поле - поле состояния (status), которое содержит информацию о состоянии, зависящую от сообщения. В число кодов состояния входят коды недостатка ресурсов (insufficient resources), неисправных параметров (parameter problem), нарушений протокола (protocol violation), и другие.

За полем состояния идет поле контрольной суммы (checksum). Контрольная сумма используется для обнаружения возможных проблем, которые могли появиться в пакете в результате транспортировки.

За полем контрольной суммы идет поле номера автономной системы (autonomous system number). Оно обозначает AS, к которой принадлежит роутер-отправитель.

Последним полем заголовка пакета EGP является поле номера последовательности (sequence number). Это поле позволяет двум роутерам EGP, которые oбмениваются сообщениями, согласовывать запросы с ответами. Когда определен какой-нибудь новый сосед, номер последовательности устанавливается в исходное нулевое значение и инкрементируется на единицу с каждой новой транзакцией запрос-ответ.

За заголовком EGP идут дополнительные поля. Содержимое этих полей различается в зависимости от типа сообщения (определяемого полем типа).

Типы сообщений

За заголовком EGP идут дополнительные поля. Содержимое этих полей различается в зависимости от типа сообщения (определяемого полем типа).

Приобретение соседа
Сообщение "приобретение соседа" включает в себя интервал приветствия (hello interval) и интервал опроса (poll interval). Поле интервала приветствия определяет период интервала проверки работоспособности соседей. Поле интервала опроса определяет частоту корректировки маршрутизации.

Досягаемость соседа
Сообщения о досягаемости соседа не имеют отдельных полей в числе полей, идущих за заголовком EGP. Эти сообщения используют поле кода для указания различия между приветственным сообщением и ответом на приветственное сообщение. Выделение функции оценки досягаемости из функции корректировки маршрутизации уменьшает сетевой трафик, т.к. изменения о досягаемости сетей обычно появляются чаще, чем изменения параметров маршрутизации. Любой узел EGP заявляет об отказе одного из своих соседей только после того, как от него не был получен определенный процент сообщений о досягаемости.

Опрос
Чтобы обеспечить правильную маршрутизацию между AS, ЕGP должен знать об относительном местоположении отдаленных хостов. Сообщение опроса позволяет роутерам EGP получать информацию о досягаемости сетей, в которых находятся эти машины. Такие сообщения имеют только одно поле помимо обычного заголовка - поле сети источника IP (source network). Это поле определяет сеть, которая должна использоваться в качестве контрольной точки для запроса.

Корректиравка маршрутизации
Сообщения о корректировке маршрутизации дают роутерам EGP возможность указывать местоположение различных сетей в пределах своих AS. В дополнение к обычному заголовку эти сообщения включают несколько дополнительных полей. Поле числа внутренних роутеров (number of interior gateways) указывает на число внутренних роутеров, появляющихся в сообщении. Поле числа внешних роутеров (number of exterior gateways) указывает на число внешних роутеров, появляющихся в сообщении. Поле сети источника IP (IP source network) обеспечивает адрес IP той сети, от которой измерена досягаемость. За этим полем идет последовательность блоков роутеров (gateway blocks). Каждый блок роутеров обеспечивает адрес IP какого-нибудь роутера и перечень сетей, а также расстояний, связанных с достижением этих сетей.

В пределах одного блока роутера EGP перечисляет сети по расстояниям. Например, на расстоянии три может быть четыре сети. Эти сети перечислены по адресам. Следующей группой сетей могут быть сети, находящиеся на расстоянии 4, и т.д.

ЕGP не расшифровывает показатели расстояния, содержащиеся в сообщениях о корректировке маршрутов. EGP фактически использует поле расстояния для указания существования какого-либо маршрута; значение расстояния может быть использовано только для сравнения трактов, если эти тракты полностью находятся в пределах одного конкретного AS. По этой причине EGP является скорее протоколом досягаемости, чем протоколом маршрутизации. Это ограничение приводит также к ограничениям в структуре Internet. Характерно, что любая часть EGP сети Internet должна представлять собой структуру дерева, у которого стержневой роутер является корнем, и в пределах которого отсутствуют петли между другими AS. Это ограничение является основным ограничением EGP; оно стало причиной его постепенного вытеснения другими, более совершенными протоколами внешних роутеров.

Сообщения о неисправностях
Сообщения о неисправностях указывают на различные сбойные ситуации. В дополнение к общему заголовку EGP сообщения о неисправностях обеспечивают поле причины (reason), за которым следует заголовок сообщения о неисправности (message header). В число типичных неисправностей (причин) EGP входят неисправный формат заголовка EGP (bad EGP header format), неисправный формат поля данных EGP (bad EGP data field format), чрезмерная скорость опроса (excessive polling rate) и невозможность достижения информации (unavailability of reachability information). Заголовок сообщения о неисправности состоит из первых трех 32-битовых слов заголовка EGP.


Глава 27. BGP.

  • Основы технологии
  • Формат пакета
  • Сообщения
    • Открывающее сообщение
    • Сообщения о корректировках
    • Сообщения keepalive
    • Уведомления

Библиографическая справка

Протоколы внешних роутеров предназначены для маршрутизации между доменами маршрутизации. В терминологии Internet (международной сети, об'единяющей университеты, правительственные учреждения, научно-исследовательские организации и частные коммерческие концерны) доменом маршрутизации называется автономная система (AS). Первым протоколом внешних роутеров, получившим широкое признание в Internet, был протокол EGP (Смотри Главу 26 "ЕGP"). Хотя технология EGP пригодна для сетей, он имеет ряд недостатков, в том числе тот факт, что это скорее протокол досягаемости, а не маршрутизации.

Протокол Граничных роутеров (Border Gateway Protocol - BGP) является попыткой решить самую серьезную проблему EGP. BGP является протоколом маршрутизации между AS, созданным для применения в Internet. В отличие от EGP, BGP предназначен для обнаружения маршрутных петель. BGP можно назвать следующим поколением EGP. И действительно, BGP и другие протоколы маршрутизации между AS постепенно вытесняют EGP из Internet. Версия 3 BGP определена в Запросах для Комментария (RFC) 1163.

Основы технологии

Хотя BGP разработан как протокол маршрутизации между AS, он может использоваться для маршрутизации как в пределах, так и между AS. Два соседа BGP, сообщающихся из различных AS, должны находиться в одной и той же физической сети. Роутеры BGP, находящиеся в пределах одной и той же AS, сообщаются друг с другом, чтобы обеспечить согласующееся представление о данной AS и определить, какой из роутеров BGP данной AS будет служить в качестве точки соединения при передаче сообщений в определенные внешние AS и при их приеме.

Некоторые AS являются просто каналами для прохождения через них сетевого трафика. Другими словами, некоторые AS переносят трафик, источник которого не находится в их пределах и который не предназначен для них. BGP должен взаимодействовать с любыми протоколами маршрутизации внутри AS, которые существуют в пределах этих проходных AS.

Сообщения о корректировках BGP состоят из пар "сетевой номер/тракт AS". Тракт AS содержит последовательность из AS, через которые может быть достигнута указанная сеть. Эти сообщения о корректировке отправляются с помощью механизма транспортировки TCP для обеспечения надежной доставки.

Обмен исходной информацией между двумя роутерами является содержанием всей маршрутной таблицы BGP. С изменением маршрутной таблицы отправляются инкрементные корректировки. В отличие от некоторых других протоколов маршрутизации BGP не требует периодического обновления всей маршрутной таблицы. Вместо этого роутеры BGP хранят новейшую версию маршрутной таблицы каждого равноправного члена. Хотя BGP поддерживает маршрутную таблицу всех возможных трактов к какой-нибудь конкретной сети, в своих сообщениях о корректировке он об'являет только об основных (оптимальных) маршрутах.

Показатель BGP представляет собой произвольное число единиц, характеризующее степень предпочтения какого-нибудь конкретного маршрута. Эти показатели обычно устанавливаются администратором сети с помощью конфигурационных файлов. Степень предпочтения может базироваться на любом числе критериев, включая число AS (тракты с меньшим числом AS как правило лучше), тип канала (стабильность, быстродействие и надежность канала) и другие факторы.

Формат пакета

Формат пакета представлен на Рис. 27-1.

Пакеты BGP имеют общий 19-байтовый заголовок, состоящий их трех полей.

Поле маркера (marker) имеет длину 16 байтов и содержит величину, которую получатель сообщения может предсказывать. Это поле используется для установки подлинности.

Поле длины (length) содержит полную длину сообщения в байтах.

Поле типа (type) определяет тип сообщения.

Сообщения

RFC 1163 определяет 4 типа сообщений:

Открывающие сообщения
Сообщения о корректировке
Уведомления
Сообщения keepalive (продолжай действовать)

После того, как соединение протокола транспортного уровня организовано, первым сообщением, отправляемым каждой стороной, является открывающее сообщение. Если открывающее сообщение приемлемо для получателя, то отправителю отсылается сообщение keepalive, подтверждающее получение открывающего сообщения. После успешного подтверждения принятия открывающего сообщения может быть произведен обмен корректировками, сообщениями keepalive и уведомлениями.

Открывающие сообщения
В дополнение к обычному заголовку пакета BGP в открывающих сообщениях выделяют несколько полей. Поле версии (version) обеспечивает номер версии BGP и дает возможность получателю проверять, совпадает ли его версия с версией отправителя. Поле автономной системы (autonomous system) обеспечивает номер AS отправителя. Поле времени удерживания (hold time) указывает максимальное число секунд, которые могут пройти без получения какого-либо сообщения от передающего устройства, прежде чем считать его отказавшим. Поле кода удостоверения (authentication code) указывает на используемый код удостоверения (если он имеется). Поле данных удостоверения (autentication data) содержит фактические данные удостоверения (при их наличии).

Сообщения о корректировке
Сообщения о корректировках BGP обеспечивают корректировки маршрутизации для других систем BGP. Информация этих сообщений используется для построения графика, описывающего взаимоотношения между различными AS. В дополнение к обычному заголовку BGP сообщения о корректировках имеют несколько дополнительных полей. Эти поля обеспечивают маршрутную информацию путем перечисления атрибутов трактов, соответствующих каждой сети. В настоящее время BGP определяет 5 атрибутов: OriginИсточник. Может иметь одно из трех значений: IGP, EGP и incomplete(незавершенный). Атрибут IGP означает, что данная сеть является частью данной AS. Атрибут EGP означает, что первоначальные сведения о данной информации получены от протокола EGP. Реализации BGP склонны oтдавать предпочтение маршрутам IGP перед маршрутами EGP, т.к. маршрут EGP отказывает при наличии маршрутных петель. Атрибут incomplete используется для указания того, что о данной сети известно через какие-то другие средства. AS path Путь AS. Обеспечивает фактический перечень AS на пути к пункту назначения. Next hop Следующая пересылка. Обеспечивает адрес IP роутера, который должен быть использован в качестве следующей пересылки к сетям, перечисленным в сообщении о корректировке. UnreachableНедосягаемый. Указывает (при его наличии), что какой-нибудь маршрут больше не является досягаемым. Inter-AS metric Показатель сообщения между AS. Обеспечивает для какого-нибудь роутера BGP возможность рекламировать свои затраты на маршруты к пунктам назначения, находящимся в пределах его AS. Эта информация может быть использована роутерами, которые являются внешними по отношению к AS рекламодателя, для выбора оптимального маршрута к конкретному пункту назначения, находящемуся в пределах данной AS.

Сообщения keepalive (продолжай действовать)
Сообщения keepalive не содержат каких-либо дополнительных полей помимо тех, которые содержатся в заголовке BGP. Эти сообщения отправляются довольно часто для того, чтобы препятствовать истечению периода времени удерживания таймера.

Уведомления
Уведомления отправляются в том случае, если была обнаружена сбойная ситуация, и один роутер хочет сообщить другому, почему он закрывает соединение между ними. Помимо обычного заголовка BGP уведомления содержат поле кода ошибки (error code), поле подкода ошибки (error subcode) и данные ошибки (error data). Поле кода ошибки указывает тип ошибки, который может быть одним из перечисленных ниже:

Message header error
Ошибка в заголовке сообщения. Указывает на проблему в заголовке сообщения, такую, как неприемлемая длина сообщения, неприемлемое значение поля маркера или неприемлемый тип сообщения.
Open message error
Ошибка в открывающем сообщении. Указывает на наличие проблемы в открывающем сообщении, такой, как необеспечиваемый номер версии, неприемлемый номер AS или адрес IP и необеспечиваемый код удостоверения.
Update message error
Ошибка в сообщении о корректировке. Указывает на наличие проблемы в сообщении о корректировке. Примерами таких проблем могут быть неправильно сформированный перечень атрибутов, ошибка в перечне атрибутов и недействительный атрибут следующей пересылки.
Hold time expired
Время удерживания истекло. Указывает на истечение периода времени удерживания, после чего узел BGP будет об'явлен недействующим.


Глава 28. Маршрутизация OSI.

  • Терминология
  • ES-IS
  • IS-IS
    • Иерархия маршрутизации
    • Сообщение между ES
    • Показатели (метрики)
    • Формат пакета
  • Интегрированный IS-IS
  • Протокол междоменной маршрутизации (IDRP)

Библиографическая справка

При содействии Международной Организации по Стандартизации (ISO) уже разработаны или разрабатываются в настоящее время несколько протоколов маршрутизации. ISO ссылается на Протокол Обмена Внутридоменной Маршрутизации Промежуточных Систем (Intermediate System to Intermediate System Intra-Domain Routing Exchange Protocol (IS-IS)) как на ISO 10589. Двигательной силой стандартизации ISO документа IS-IS был комитет Х.3S3.3 Американского Национального Института Стандартов (ANSI), занимающийся сетевым и транспортным уровнями. В числе других протоколов ISO, связанных с маршрутизацией, протоколы ISO 9542 (End System to Intermediate System, или ES-IS - Конечная система-Промежуточная Система) и ISO 10747 (IS-IS Inter-Domain Routing Protocol, или IDRP- Протокол междоменной маршрутизации промежуточных систем). Об этих протоколах будет вкратце упомянуто в данной главе, однако oсновное внимание уделено внутридоменной версии IS-IS.

IS-IS базируется на работе, которая была впервые выполнена Digital Equipment Corporation при разработке Phase V DECnet. Хотя IS-IS предназначался для маршрутизации в сетях протокола CLNP ISO, со временем была разработана одна из его версий для поддержки как сетей CLNP, так и сетей IP. На эту версию IS-IS обычно ссылаются как на Integrated IS-IS (интегрированный); ее также называют Dual IS-IS (двойственный). Integrated IS-IS также рассматривается вкратце.

Терминология

Об'единенные сети OSI используют уникальную терминологию. Термин "конечная система" (end system - ES) относится к любому узлу сети, который не занимается маршрутизацией; термин "промежуточная система" (intermediate system-IS) относится к роутеру. На этих терминах базируются протоколы OSI ES-IS (который позволяет ES и IS находить друг друга) и IS-IS (который обеспечивает маршрутизацию между IS). Ниже дается определение некоторых других важных терминов об'единенных сетей OSI:

Area
Область. Группа смежных сетей и подключенных к ним хостов, которые определяются как область администратором сети или другим аналогичным лицом.
Domain
Домен. Набор соединенных областей. Домены маршрутизации обеспечивают полную связность со всеми конечными системами, находящимися в их пределах.
Level 1 routing
Маршрутизация в пределах области Уровня 1.
Level 2 routing
Maршрутизация между областями Уровня 1.

На Рис. 28-1 "Иерархия об'единенных сетей OSI" показана взаимосвязь между этими терминами.

С чисто технологической точки зрения IS-IS почти аналогичен протоколу маршрутизации OSPF (смотри Главу 25 "OSPF"). Оба протокола являются протоколами с указанием состояния канала. Оба они обеспечивают различные характеристики, которые не обеспечивает RIP, в том числе иерархии маршрутизации (routing hierachies), дробление путей (path splitting), обеспечение типа услуги (type-of-service - TOS), удостоверение (authentication), поддержка нескольких протоколов сетевого уровня и поддержка (совместно с протоколом Integrated IS-IS) масок подсети переменной длины.

ES-IS

ES-IS в большей мере является протоколом обнаружения, чем протоколом маршрутизации. Через ES-IS системы ES и IS узнают друг о друге. Этот процесс известен как конфигурация (configuration). Т.к. конфигурация должна иметь место прежде, чем может начаться маршрутизация между ES, протокол ES-IS рассматривается в первую очередь.

ES-IS различает три разных типа подсетей:

Point-to-point subnetworks
Двухточечные подсети. Обеспечивают непосредственное соединение между двумя системами. Большинство последовательных каналов глобальной сети являются двухточечными сетями.
Broadcast subnetworks
Широковещательные подсети. Направляют отдельное физическое сообщение во все узлы данной подсети. Примерами широковещательных подсетей являются Ethernet и IEEE 802.3 (смотри Главу 5 "Ethernet/IEEE 802.3").
General-topology subnetworks
Подсети с общей топологией. Поддерживают произвольное число систем. Однако в отличие от широковещательных подсетей, величина затрат на передачу по какому-нибудь маршруту n непосредственно связана с размерами данной подсети в подсети с общей топологией. Примером подсети с общей топологией является Х.25 (смотри Главу 13 "Х.25").

Информация конфигурации передается через определенные интервалы времени с помощью сообщений двух типов. Приветственные сообщения ES (Es hello messages - ESHs) генерируются ES и отправляются в каждую IS данной подсети. Приветственные сообщения IS (IS hello messages - ISH) генерируются IS и отправляются всем ES данной подсети. Эти приветственные сообщения в основном предназначены для переноса адресов подсетей и адресов сетевого уровня тех систем, которые генерируют их.

При возможности ES-IS пытается отправить информацию конфигурации одновременно в несколько систем. В широковещательных подсетях приветственные сообщения ES-IS отправляются во все IS с помощью специальной многопунктовой адресации. IS отправляют приветственные сообщения по специальному адресу многопунктовой адресации, определенного для всех конечных систем. При работе в подсети с общей топологией ES-IS обычно не передает информацию конфигурации из-за больших затрат на передачи многопунктовой адресации.

ES-IS переносит как адреса сетевого уровня, так и адреса подсетей. Адреса сетевого уровня OSI идентифицируют либо точку доступа к услугам сети (NSAP), которая представляет собой интерфейс между Уровнями 3 и 4, либо титул об'екта сети (NET), который является об'ектом сетевого уровня в OSI IS. Адреса подсетей OSI (иногда называемые адресами точки подключения подсети - subnetwork point of attachment - SNPA) являются точками, в которых ES или IS физически подключена к какой-нибудь подсети. Адрес SNPA уникальным образом идентифицирует каждую систему, подключенную к данной подсети. В сети Ethernet, например, SNPA является 48-битовым адресом управления доступом к носителю (МАС). Часть информации конфигурации, которую передает ES-IS, представляет собой отображение соответствия между NSAP и SNPA или между NET и SNPA.

На Рис. 28-2 представлены форматы пакетов ESH и ISH.

IS-IS

IS-IS является протоколом маршрутизации с указанием состояния канала. В этом роли он передает по сети лавинной адресацией информацию о состоянии канала для построения полной, последовательной картины топологии сети.

Иерархия маршрутизации
Для упрощения схемы и работы роутера IS-IS различает IS уровней 1 и 2. IS уровня 1 могут сообщаться с другими IS уровня 1, находящимися в той же области. IS уровня 2 могут сообщаться с IS других областей. Т.е. IS уровня 1 формируют области уровня 1; IS уровня 2 осуществляют маршрутизацию между областями уровня 1.

IS уровня 2 формируют стержень внутридоменной маршрутизации. Другими словами, IS уровня 2 могут попасть в другие IS уровня 2 путем пересечения только IS уровня 2. Наличие такого стержня упрощает схему, т.к. в этом случае IS уровня 1 нужно уметь только попадать в ближайший IS уровня 2. Протокол стержневой маршрутизации может также вносить изменения, не оказывая влияния на протокол внутриобластной маршрутизации.

Сообщение между ES
Маршрутизация OSI выполняется следующим образом. Каждая ES принадлежит конкретной области. ES обнаруживают ближайшую IS путем прослушивания пакетов ISH. Если какая-нибудь ES захочет отправить пакет в другую ES, она направляет пакет в одну из IS сети, к которой она непосредственно подключена. Роутер просматривает адрес пункта назначения и продвигает пакет по наилучшему маршруту. Если ES пункта назначения находится в той же подсети, то местная IS узнает об этом в результате прослушивания ESH и соответствующим образом продвинет пакет. В этом случае IS может также обеспечить отправку сообщения о переадресации (redirect - RD) в источник пакета, чтобы сообщить о доступности более прямого пути. Если адресом пункта назначения является какая-нибудь ES другой подсети той же области, то IS узнает о точном маршруте и соответствующим образом продвинет пакет. Если адресом пункта назначения является какая-нибудь ES другой области, то IS уровня 1 отправляет этот пакет в в ближайшую IS уровня 2. Продвижение пакета через IS уровня 2 продолжается до тех пор, пока он не достигнет IS уровня 2 в области пункта назначения. В пределах области пункта назначения IS продвигают пакет по наилучшему маршруту, пока не будет достигнутa ES пункта назначения.

Каждая IS генерирует корректировку, определяющую ES и IS, с которыми она соединена, а также связанные с ней показатели. Эта корректировка отправляется во все соседние IS, которые продвигают ее своим соседям, и т.д. (лавинная адресация). Номера последовательностей прекращают лавинную адресацию и отличают старые корректировки от новых. Т.к. каждая IS получает корректировки о состоянии канала от всех других IS, то каждая IS может построить полную базу данных всей топологии сети. При изменении топологии отправляются новые корректировки.

Показатели (метрики)
IS-IS использует один обязательный, устанавливаемый по умолчанию показатель с максимальным значением пути 1024. Этот показатель является произвольным и обычно назначается администратором сети. Любой отдельный канал может иметь максимальное значение 64. Длина путей вычисляется путем суммирования значений каналов. Максимальные значения каналов установлены на этих уровнях для обеспечения степени детализации, чтобы поддерживать различные типы каналов, одновременно обеспечивая достаточную эффективность алгоритма поиска наикратчайшего пути, используемого для расчета маршрута.

IS-IS также определяет три дополнительных показателя (затраты) в качестве опций для тех администраторов, которые испытывают в них необходимость. Затраты задержки (delay) отражают величину задержки в канале. Затраты на издержки (expense) отражают коммуникационные затраты, связанные с использованием данного канала. Затраты на ошибки (error) отражают коэффициент ошибок данного канала.

IS-IS обеспечивает соответствие этих четырех показателей опции качества обслуживания (quality-of-service- QOS) в заголовке пакета CLNP. Пользуясь этим соответствием, IS-IS может вычислять маршруты через об'единенную сеть.

Формат пакета
IS-IS использует три базовых формата пакета:

IS-IS hello packets - приветственные пакеты IS-IS
Link state packets (LSPs) - пакеты состояния канала
Sequence numbers packets (SNPs) - пакеты номеров последовательностей

Каждый из этих трех пакетов IS-IS имеет сложный формат с тремя различными логическими частями. Первой частью является 8-байтовый фиксированный заголовок, общий для всех трех типов пакетов. Второй частью является специфичная для данного типа пакета часть с фиксированным форматом. Третья логическая часть также является специфичной для типа пакета, но имеет переменную длину. Логический формат пакетов IS-IS представлен на Рис. 28-3.

Common header Packet-type-specific, fixed header Packet-type-specific, variable-length header

Figure 28-3

Каждый из трех типов пакета имеет общий заголовок, как это показано на Рис. 28-4.

Первым полем в общем заголовке IS-IS является идентификатор протокола (protocol identifier), который идентифицирует протокол IS-IS. Это поле содержит константу (131).

Следующим полем общего заголовка является поле длины заголовка (header length). Это поле содержит фиксированную длину заголовка. Эта длина всегда равняется 8 байтам, но она включена таким образом, чтобы пакеты IS-IS незначительно отличались от пакетов CLNP.

За полем длины следует поле версии (version), которое равняется единице в текущей спецификации IS-IS.

За полем версии идет поле длины ID, которое определяет размеры части ID (идентификатора) NSAP, если eго значение лежит в пределах от 1 до 8 (включительно). Если поле содержит нуль, то часть ID равняется 6 байтам. Если поле содержит 255 (одни единицы), то часть ID равна 0 байтов.

Следующим полем является поле типа пакета (packet type), которое определяет тип пакета IS-IS (hello, LSP или SNP).

За полем типа пакета повторно следует поле версии.

За вторым полем версии идет поле резерва (reserved), которое равно нулю и которое игнорируется получателем.

Последним полем общего заголовка является поле максимума адресов области. Это поле определяет число адресов, разрешeнных для этой области.

За общим заголовком идет дополнительная фиксированная часть, разная для каждого типа пакета, за которой следует переменная часть.

Интегрированный IS-IS

Интегрированный IS-IS является одной из версий IS-IS, которая использует один алгоритм маршрутизации для поддержки нескольких протоколов сетевого уровня, а не только одного протокола CLNP. Интегрированный IS-IS иногда называют Двойственным IS-IS (Dual IS-IS), по имени одной из версий, предназначенных для сетей IP и CLNP.

Пакеты IS-IS дополнены несколькими полями, что позволяет IS-IS поддерживать дополнительные сетевые уровни. Эти поля сообщают роутерам следующую информацию:

Досягаемость сетевых адресов из других комплектов протоколов
Какие протоколы поддерживаются и какими роутерами
Другую информацию, необходимую для какого-нибудь конкретного комплекта протоколов

Интегрированный IS-IS представляет один из двух способов поддержки в роутере нескольких протоколов сетевого уровня; другим способом является применение метода "корабли ночью" (ships in the night). Этот метод пропагандирует использование совершенно отдельного и отличного от других протокола маршрутизации для каждого сетевого протокола сети так, чтобы несколько протоколов маршрутизации фактически существовали независимо друг от друга (с разными типами маршрутной информации, проходящей подобно кораблям ночью). Возможность направлять по определенным маршрутам несколько протоколов сетевого уровня с помощью таблиц, рассчитанных одним протоколом маршрутизации, экономит ресурсы роутеров.

Протокол междоменной маршрутизации (IDRP)

IDRP является протоколом OSI, предназначенным для перемещения информации между доменами маршрутизации. Он предназначен для бесшовной работы с CLNP, ES-IS и IS-IS. IDRP базируется на Протоколе граничных роутеров (BGP), который является протоколом междоменной маршрутизации, впервые появившемся в сообществе IP (смотри Главу 27 "BGP").

IDRP вводит несколько новых терминов, в том числе следующие:

Border intermediate system (BIS)
Граничная промежуточная система. Это IS, участвующая в междоменной маршрутизации. Для этого она использует IDRP.
Routing domain (RD)
Домен маршрутизации. Это группа ES и IS, работающих согласно общим административным правилам, включающим коллективное пользование общим маршрутным планом.
Routing domain identifier (RDI)
Идентификатор домена маршрутизации. Уникальный идентификатор домена маршрутизации (RD).
Routing information base (RIB)
Информационная база маршрутизации. Это база данных маршрутизации, используемая IDRP. Каждая BIS строит свою RIB из информации, полученной от систем данного RD и из других BIS. Любая RIB содержит набор маршрутов, выбранных для использования какой-нибудь конкретной BIS.
Confederation
Конфедерация. Это группа доменов маршрутизации (RD). RD, не принадлежащие к данной конфедерации, воспринимают ее как один RD. Топология конфедерации невидима для RD, не принадлещащих к ней. Конфедерации помогают сократить сетевой трафик, выступая в об'единенной сети в качестве непреодолимой преграды; они могут быть вложены одна в другую.

Маршрут IDRP представляет собой последовательность RDI. Некоторые из этих RDI могут быть конфедерациями. При конфигурации каждой BIS она знает о RD и конфедерациях, к которым она принадлежит, а также узнает о других BIS, RD и конфедерациях из информации, которой она обменивается с каждым соседом. Как и для маршрутизации с вектором расстояния, маршруты в какой-нибудь конкретный пункт назначения накапливаются вне данного пункта назначения. Только маршруты, которые удовлетворяют требованиям местной политики какой-нибудь BIS и были выбраны для использования, будут переданы в другие BIS. Пересчет маршрутов носит частичный характер и имеет место при наличии одного их следующих трех событий: получена инкрементная корректировка маршрутизации с новыми маршрутами, отказывает какая-нибудь соседняя BIS или появляется новая соседняя BIS.

В число характеристик IDRP входят следующие:

Поддержка CLNP QOS
Устранение петель путем ослеживания всех RD, пересекаемых роутером
Сокращение об'ема маршрутной информации и ее обработки путем использования конфедераций, компрессии информации путей RD и других средств
Обеспечение надежности путем использования встроенных надежных средств транспортировки
Обеспечение защиты данных путем использования криптографической сигнатуры для каждого пакета
Наличие узлов обслуживания маршрута
Регенерирующие пакеты RIB


Глава 29. Прозрачное объединение сетей с помощью мостов.

  • Основы технологии
  • Петли в сетях, объединенных с помощью мостов
  • Алгоритм связующего дерева (Spanning-Tree Algoritm) (STA)
  • Формат блока данных (фрэйма)

Библиографическая справка

Прозрачные мосты (TB) были впервые разработаны Digital Equipment Corporation в начале 1980 гг. Digital представила свою работу в IEEE, который включил ее в стандарт IEEE 802.1. TB очень популярны в сетях Ethernet/IEEE 802.3.

Основы технологии

ТВ названы так потому, что их присутствие и работа являются прозрачными для хостов сети. После подачи питания на ТВ, они узнают о топологии сети путем анализа адреса источника блоков данных, приходящих из всех других подключенных сетей. Например, если мост видит, что какой-нибудь блок данных поступил на линию 1 из Хоста А, он делает вывод, что до Хоста А можно добраться через сеть, подключенную к линии 1. С помощью этого процесса ТВ строят таблицу, приведенную на Рис. 29-1.

Host address | Network number
15 | 1
17 | 1
12 | 2
13 | 2
18 | 1
9 | 1
14 | 3
. . . | . . .

Figure 29-1

Мост использует свою таблицу в качестве базиса для продвижения трафика. Когда на один из интерфейсов моста принят блок данных, мост ищет адрес пункта назначения этого блока данных в своей внутренней таблице. Если таблица содержит взаимосвязь между адресом пункта назначения и любым из портов этого моста, за исключением того, в которой был принят этот блок данных, то блок данных продвигается из указанного порта. Если не найдено никакой взаимосвязи, то блок данных отправляется лавинной адресацией во все порты, кроме порта вхождения блока данных. Широковещательные сообщения и сообщения многопунктовой адресации также отправляются лавинной адресацией таким же образом.

ТВ успешно изолирует внутрисегментный трафик, тем самым сокращая трафик, видимый в каждом отдельном сегменте. Это обычно улучшает время реакции сети, видимое пользователю. Степень сокращения трафика и улучшения времени реакции зависят от об'ема межсегментного трафика относительно общего трафика, а также от об'ема широковещательного и многопунктового трафика.

Петли в сетях, объединенных с помощью мостов

Без протокола взаимодействия между мостами алгоритм ТВ отказывает, когда между двумя любыми LAN об'единенной сети имеется несколько трактов, включающих в себя мосты и локальные сети. Образование петли при об'единении с помощью мостов показано на Рис. 29-2 "Неправильное продвижение пакетов и узнавание информации в средах прозрачного об'единения".

Предположим, что Хост А отправляет блок данных в Хост В. Оба моста принимают этот блок данных и и делают правильный вывод о том, что машина А находится в сети 2. К сожалению, после того, как машина В примет два экземпляра блока данных машины А, оба моста снова получают этот же блок данных на свои интерфейсы с Сетью 1, т.к. все хосты принимают все сообщения широковещательных LAN. В некоторых случаях мосты затем изменяют свои внутренние таблицы, чтобы указать, что машина А находится в Сети 1. В этом случае при ответе машины В на блок данных машины А оба моста примут, а затем проигнорируют эти ответы, т.к. их таблицы укажут, что данный пункт назначения (машина А) находится в том же сегменте сети, что и источник этого блока данных.

Помимо основных проблем связности, подобных описанной выше, потенциально серьезной проблемой является размножение широковещательных сообщений в сетях с петлями. Обратившись снова к Рис. 29-2, предположим, что первоначальный блок данных машины А является широковещательным. Оба моста будут бесконечно продвигать этот блок данных, используя всю доступную ширину полосы сети и блокируя передачу других пакетов в обоих сегментах.

Топология с петлями, подобными изображенной на Рис. 29-2, может быть полезной, но также и потенциально вредной. Петля подразумевает существование нескольких трактов через об'единеннную сеть. В сети с несколькими трактами от источника до пункта назначения общая помехоустойчивость может увеличиться благодаря улучшенной топологической гибкости.

Алгоритм связующего дерева (Spanning-Tree Algoritm) (STA)

Алгоритм был разработан для того, чтобы сохранить преимущества петель, устранив их проблемы. Первоначально алгоритм был документирован корпорацией Digital - основным поставщиком Ethernet. Новый алгоритм, разработанный Digital, был впоследствии пересмотрен комитетом IEEE 802 и опубликован в спецификации IEE 802. 1d в качестве алгоритма STA.

STA предусматривает свободное от петель подмножество топологии сети путем размещения таких мостов, которые, если они включены, то образуют петли в резервном (блокирующем) состоянии. Порты блокирующего моста могут быть активированы в случае отказа основного канала, обеспечивая новый тракт через об'единенную сеть.

STA пользуются выводом из теории графов в качестве базиса для построения свободного от петель подмножества топологии сети. Теория графов утверждает следующее:

Для любого подсоединенного графа, состоящего из узлов и ребер, соединяющих пары узлов, существует связующее дерево из ребер, которое поддерживает связность данного графа, но не содержит петель.

Рис. 29-3 поясняет, каким образом STA устраняет петли. STA требует, чтобы каждому мосту был назначен уникальный идентификатор. Обычно этот идентификатор является одним из адресов МАС данного моста, который дополнен приоритетом. Каждому порту во всех мостах также назначается уникальный (в пределах этого моста) идентификатор (как правило, его собственный адрес МАС). И наконец, каждый порт моста взаимосвязан с затратами какого-нибудь тракта. Затраты тракта представляют собой затраты на передачу какого-нибудь блока данных в одну из локальных сетей через этот порт. На Рис. 29-3 "Сеть ТВ до прогона STA" затраты трактов отмечены на линиях, исходящих из каждого моста. Затраты трактов обычно устaнaвливаются по умолчанию, но могут быть назначены вручную администраторами сети.

Первым шагом при вычислении связующего дерева является выбор корневого моста (root bridge), который представляет собой мост с наименьшим значением идентификатора моста. На Рис. 29-3 корневым мостом является Мост 1. Далее определяется корневой порт (root port) во всех остальных мостах. Корневой порт моста - это порт, через который можно попасть в корневой мост с наименьшими комбинированными затратами тракта. Эта величина (т.е. наименьшие комбинированные затраты тракта до корневого моста) называется затратами корневого тракта (root path cost).

И наконец, определяются назначенные мосты (designated bridges) и их назначенные порты (designated ports). Назначенный мост - это тот мост каждой локальной сети, который обеспечивает минимальные затраты корневого тракта. Назначенный мост локальной сети является единственным мостом, который позволяет продвигать блоки данных в ту локальную сеть (и из нее), для которой этот мост является назначенным. Назначенный порт локальной сети - это тот порт, который соединяет ее с назначенным мостом.

В некоторых случаях два или более мостов могут иметь одинаковые затраты корневого тракта. Например, на Рис. 29-3 как Мост 4, так и Мост 5 могут достичь Мост 1 (корневой мост) с затратами тракта 10. В этом случае снова используются идентификаторы моста, на этот раз для определения назначеных мостов. При выборе предпочтение отдано порту LAN V Моста 4 перед портом LAN V Моста 5.

При использовании этого процесса устраняются все мосты, непосредственно соединенные с каждой LAN, кроме одного; таким образом, удаляются все петли между двумя LAN. STA также устраняет петли, включающие более двух LAN, в то же время сохраняя связность. На Рис. 29-4 "Сеть ТВ после прогона STA" показаны результаты действия STA в сети, изображенной на Рис. 29-3. На Рис. 29-4 более четко показана топология дерева. Сравнение этого рисунка с рисунком сети до прогона STA показывает, что STA перевел в режим резерва как порты Моста 3 в LAN V, так и порты Moста 5 в LAN V.

Расчет связующего дерева имеет место при подаче питания на мост и во всех случаях обнаружения изменения топологии. Для расчета необходима связь между мостами связующего дерева, которая осуществляется через сообщения конфигурации (иногда называемые протокольными информационными единицами моста - bridge protocol data units, или BPDU). Сообщения конфигурации содержат информацию, идентифицирующую тот мост, который считается корневым (т.е. идентификатор корневого моста), и расстояние от моста-отправителя до корневого моста (затраты корневого тракта). Сообщения конфигурации также содержат идентификаторы моста и порта моста-отправителя, а также возраст информации, содержащейся в сообщении конфигурации.

Мосты обмениваются сообщениями конфигурации через регулярные интервалы времени (обычно 1-4 сек.). Если какой-нибудь мост отказывает (вызывая изменение в топологии), то соседние мосты вскоре обнаруживают отсутствие сообщений конфигурации и инициируют пересчет связующего дерева.

Все решения, связанные с топологией ТВ, принимаются логически. Обмен сообщениями конфигурации производится между соседними мостами. Центральные полномочия или администрация управления сетевой топологией отсутствуют.

Формат блока данных (фрэйма)

Мосты ТВ обмениваются сообщениями конфигурации (configuration messages) и сообщениями об изменении в топологии (topology change). Мосты обмениваются сообщениями конфигурации для установления топологии сети. Сообщения об изменении топологии отправляются после обнаружения какого-нибудь изменения в топологии для указания того, что должен быть произведен повторный прогон STA.

Формат сообщения конфигурации IEEE 802.1d представлен на Рис. 29-5.

Первым полем сообщения конфигурации ТВ является поле идентификатора протокола (protocol identifier), которое содержит нулевое значение.

Вторым полем в сообщении конфигурации ТВ является поле версии (version), которое содержит нулевое значение.

Третьим полем в сообщении ТВ является поле типа сообщения (message type), которое содержит нулевое значение.

Четвертым полем в сообщении конфигурации ТВ является однобайтовое поле флагов (flags). Бит ТС сигнализирует об изменении в топологии. Бит ТСА устанавливается для подтверждения приема сообщения конфигурации с установленным битом ТС. Другие шесть битов этого байта не используются.

Следующим полем в сообщении конфигурации ТВ является поле идентификатора корневого моста (root ID). Это 8-байтовое поле идентифицирует корневой мост путем перечисления его 2-байтового приоритета, за которым следует его 6-байтовый ID.

За полем ID корневого моста идет поле затрат корневого тракта (root path cost), которое содержит затраты тракта от моста, который отправляет конфигурационное сообщение, до корневого моста.

Далее идет поле идентификатора моста (bridge ID), которое идентифицирует приоритет и ID моста, отправляющего сообщение.

Поле идентификатора порта (port ID) идентифицирует порт, из которого отправлено конфигурационное сообщшение. Это поле позволяет обнаруживать и устранять петли, образованные несколькими подключенными мостами.

Поле возраста сообщения (message age) определяет промежуток времени, прошедшего с момента отправки корневым мостом конфигурационного сообщения, на котором базируется текущее конфигурационное сообщение.

Поле максимального возраста (maximum age) указывает, когда текущее конфигурационное сообщение должно быть стерто.

Поле времени приветствия (hello time) обеспечивает период времени между конфигурационными сообщениями корневого моста.

И наконец, поле задержки продвижения (forward delay) обеспечивает промежуток времени, в течение которого мосты должны выжидать, прежде чем перейти в новое состояние после изменения в топологии. Если переходы какого-нибудь моста происходят слишком быстро, то не все каналы сети могут оказаться готовыми для изменения их состояний, в результате чего могут появиться петли.

Сообщения о топологических изменениях состоят всего из 4 байтов. Они включают в себя поле идентификатора протокола (protocol identifier), которое содержит нулевое значение, поле версии (version), которое содержит нулевое значение и поле типа сообщения (message type), которое содержит значение 128.


Глава 30. Объединение сетей с помощью мостов "Источник-Маршрут".

  • Алгоритм SRB
  • Формат блока данных (фрэйма)

Библиографическая справка

Алгоритм Source-Route Bridging (SRB) (об'единение с помощью мостов "источник-маршрут") был разработан IBM и предложен комитету IEEE 802.1 в качестве средства об'единения локальных сетей с помощью мостов. После того, как комитет предпочел другой конкурирующий стандарт (смотри Главу 29 "Прозрачное об'единение с помощью мостов" о стандарте ТВ), сторонники SRB предложили его комитету IEEE 802.5, который впоследствии включил его в спецификацию локальной сети IEEE 802.5/Token Ring.

За первым предложением IBM последовало предложение нового стандарта об'единения с помощью мостов в комитет IEEE 802: Source-Route Transparent (SRT) (Прозрачное об'единение "источник-маршрут") Подробная информация о SRT дается в Главе 31 "Mixed-Media Bridging". SRT полностью устраняет мосты "источник-маршрут" (SRB), предлагая взамен два типа мостов LAN-TB и SRT. Несмотря на то, что SRT получил одобрение, мосты SRB попрежнему широко применяются в сетях.

Алгоритм SRB

Свое название мосты SRB получили потому, что они предполагают размещение полного маршрута от источника до пункта назначения во всех межсетевых (LAN) блоках данных, отправляемых источником. SRB хранят и продвигают эти блоки данных в соответствии с указаниями о маршруте, содержащимися в соответствующем поле блока данных. На Рис. 30-1 представлен образец сети SRB.

Предположим, что Хост Х на Рис. 30-1 решила отправить блок данных в Хост Y. Вначале машина Х не знает, где находится машина Y-в той же или в другой LAN. Чтобы определить это, она отправляет тестовый блок данных. Если этот блок данных возвращается к ней без положительного указания о том, что машина Y видела его, то она должна предположить, что машина Y находится в отдаленном сегменте.

Чтобы точно определить местоположение отдаленной машины Y, машина Х отправляет блок данных разведчика (explorer). Каждый мост, получающий этот блок данных (в нашем примере это Мосты 1 и 2), копирует его во все порты отправки сообщений. По мере продвижения блоков данных-разведчиков через об'единенную сеть они дополняются маршрутной информацией. Когда блоки данных-разведчики машины Х доходят до машины Y, то машина Y отвечает каждому отдельно, используя накопленную маршрутную информацию. После получения всех ответных блоков данных машина Х может выбрать маршрут, базирующийся на заранее установленном критерии.

В примере, приведенном на Рис. 30-1, результатом этого процесса будут два маршрута:

LAN 1 - Bridge 1 - LAN 3 - Bridge 3 - LAN 2
LAN 1 - Bridge 2 - LAN 4 - Bridge 4 - LAN 2

Машина Х должна выбрать один из этих двух маршрутов. Спецификация IEEE 802.5 не назначает критерий, который машина Х должна использовать для выбора маршрута; однако в ней имеется несколько предложений, которые перечислены ниже:

Первый принятый блок данных
Ответ с минимальным числом пересылок
Ответ с самым большим разрешенным размером блока данных
Различные комбинации перечисленных выше критериев

В большинстве случаев выбирается тракт, содержащийся в первом полученном блоке данных.

После того, как маршрут выбран, он включается в блоки данных, предназначенных для машины Y, в форме поля маршрутной информации (routing information field - RIF). RIF включается только в блоки данных, предназначенных для других LAN. Наличие маршрутной информации в блоке данных указывается путем установки самого значащего бита, называемого битом индикатора маршрутной информации (routing information indicator - RII), в поле адреса источника.

Формат блока данных (фрэйма)

Структура IEEE 802.5 RIF представлена на Рис. 30-2.

Подполе типа (type) в RIF указывает на количество узлов, в которые должен быть отправлен данный блок данных: в один узел, в группу узлов, включающих в себя связующее дерево данной об'единенной сети, или во все узлы. Первый тип называется "специально направленным" (specifically routed) блоком данных, второй тип - "разведчиком связующего дерева" (spanning-tree explorer), а третий тип - "разведчиком всех трактов" (all-paths explorer). Разведчик связующего дерева может быть использован в качестве транзитного механизма для блоков данных с многопунктовой адресацией. Он может быть также использован в качестве замены разведчика всех трактов в запросах об исходящих маршрутах. В этом случае пункт назначения в ответ присылает разведчика всех трактов.

Подполе длины (length) обозначает общую длину RIF в байтах.

Бит D указывает направление движения блока данных (прямое или обратное).

Поле "самый большой" (largest) обозначает самый большой блок данных, который может быть обработан вдоль всего этого маршрута.

Полей описателя маршрута (route descriptor) может быть несколько. Каждое из них содержит пару "номер кольца/номер моста", которая определяет какую-нибудь часть маршрута. Таким образом, маршруты представляют собой просто чередующиеся последовательности номеров LAN и мостов, которые начинаются и заканчиваются номерами LAN.


Глава 31. Объединение смешанных носителей с помощью мостов .

  • Основы технологии
    • Трудности трансляции
  • Трансляционное объединение с помощью мостов (TLB)
  • Прозрачное объединение с помощью мостов "Источник-Маршрут" (SRT)

Библиографическая справка

Прозрачные мосты (transparent bridges - TB) в основном встечаются в сетях Ethernet (смотри Главу 29 "Transparent Bridging"), в то время как мосты SRB встечаются почти исключительно в сетях Token Ring (смотри Главу 30 "Source-Route Bridging"). Оба метода об'единения сетей с помощью мостов (ТВ и SRB) популярны, поэтому естественно возникает вопрос о существовании какого-нибудь метода, который позволил бы об'единить их. Этот основной вопрос иллюстрируется Рис. 31-1 "Об'единение с помощью моста доменов ТВ и SRB".

Основы технологии

Трансляционное об'единение с помощью мостов (Translational bridging - TLB) обеспечивает относительно недорогое решение некоторых из многочисленных проблем, связанных с об'единением с помощью моста доменов ТВ и SRB. TLB впервые появился в середине-конце 1980 гг., но ни одна из организаций по стандартам не стала заниматься им. В результате многие аспекты TLB предоставлены для решения тому, кто реализует его.

В 1990 г. IBM устранила некоторые из недостатков TLB путем введения "Прозрачного об'единения с помощью моста "источник-маршрут" (Source-Route Transparent-SRT). SRT может продвигать трафик из конечных узлов сети как с прозрачным об'единением, так и с об'единением "источник-маршрут", и образовывать общее связующее дерево с мостами TB, позволяя тем самым конечным станциям каждого типа сообщаться с конечными станциями такого же типа в сети с произвольной топологией.

В конечном итоге, целью об'единения доменов ТВ и SRB является возможность сообщения между конечными станциями ТВ и SRB. В данной главе описываются технические проблемы, которые должны быть решены алгоритмами, пытающимися сделать это, а также представлены два возможных решения: TLB и SRT.

Трудности трансляции
Существует ряд трудностей, связанных с обеспечением связи между конечными станциями домена Ethernet/TB и конечными станциями домена SRB/Token Ring, которые перечислены ниже:

Несовместимый порядок организации битов. Хотя и Ethernet, и Тoken Ring поддерживают 48-битовые адреса МАС, внутреннее аппаратное представление этих адресов различно. Token Ring считает битом высшего порядка какого-нибудь байта первый бит, встречаемый в последовательном потоке битов, представляющим адрес. В Ethernet же, напротив, первый встреченный бит считается битом низшего порядка.
Адреса встроенного управления доступом к носителю (МАС). В некоторых случаях адреса МАС фактически содержатся в информационной части блока данных. Например, Протокол разрешения адреса (ARP), который является популярным протоколом в сетях ТСР/IP, размещает аппаратные адреса в информационной части блока данных канального уровня. Преобразование адресов, которые могут находиться в информационной части блока данных или их может не быть там, является нелегкой задачей, т.к. они должны обрабатываться индивидуально в каждом отдельном случае.
Несовместимые максимальные размеры единиц передачи (MTU). Token Ring и Ethernet oбеспечивают разные максимальные размеры блоков данных. MTU Ethernet равен примерно 1500 байтам, в то время как блоки данных Token Ring могут быть значительно больше. Т.к. мосты не могут выполнять фрагментацию и повторную сборку пакетов, то пакеты, превышающие MTU сети, должны быть отброшены.
Обработка операций бита состояния блока данных. Блоки данных Token Ring содержат три бита состояния блока данных: А, С и Е. Назначение этих битов - сообщить источнику блока данных, видел ли пункт назначения этот блок данных (задан бит А), скопировал ли его (задан бит С) и (или) обнаружил ли ошибки в этом блоке данных (задан бит Е). Т.к. Ethernet не обеспечивает этих битов, то изготовителям моста Ethernet/Token Ring предоставлено самим решать проблему этих битов.
Обработка эксклюзивных функций Token Ring. Некоторые биты Token Ring не имеют следствия в Ethernet. Например, Ethernet не имеет механизма приоритетов, в то время как Token Ring имеет его. В числе других битов Token Ring, которые должны быть отброшены при преобразовании блока данных Token Ring в блок данных Ethernet, бит маркера, бит монитора и бит резервирования.
Обработка ТВ блоков данных разведчика. В мостах ТВ не предусмотрен механизм обработки блоков данных разведчика маршрута SRB. ТВ узнают о топологии сети путем анализа адреса источника входящих блоков данных. Они не имеют понятия о процессе поиска маршрутов SRB.
Обработка ТВ информации поля маршрутной информации (RIF), содержащейся в блоках данных Token Ring. Алгоритм SRB размещает мааршрутную информацию в поле RIF. Алгоритм ТВ не имеет эквивалента RIF, и для ТВ чуждо понятие о размещении маршрутной информации в блоке данных.
Несовместимость алгоритмов связующего дерева. Как ТВ, так и SRB используют алгоритм связующего дерева для предотвращения петель, однако конкретные алгоритмы, используемые этими двумя способами об'единения сетей с помощью мостов, несовместимы.
Обработка SRB блоков данных без маршрутной информации. Мосты SRB предполагают наличие маршрутной информации во всех блоках данных обмена между LAN. Если в мост SRB поступают блоки данных без поля RIF (в их числе конфигурационные сообщения и сообщения о топологических изменениях, а также блоки данных МАС, отправляемые из домена ТВ), они просто игнорируются.

Трансляционное объединение с помощью мостов (TLB)

Поскольку порядок связи между двумя типами носителя не был по-настоящему стандартизован, нет ни одной реализации TLB, которую можно назвать точной. Ниже дается описание нескольких популярных методов реализации TLB.

При трансляции между Ethernet и Token Ring протокол TLB переупорядочивает биты адреса источника и пункта назначения. Проблема встроенных адресов МАС может быть решена путем программирования моста таким образом, чтобы он проверял адреса МАС разных типов; однако это техническое решение должно адаптироваться к каждому новому типу встроенных адресов МАС. В некоторых решениях TLB просто проверяются наиболее популярные встроенные адреса МАС. Если программное обеспечение TLB работает в роутере с несколькими протоколами, то этот роутер может успешно назначать тракты для этих протоколов и полностью решить эту проблему.

Поле RIF имеет подполе, которое указывает размер самого большого блока данных, который может быть принят конкретной реализацией SRB. TLB, отправляющие блоки данных из домена ТВ в домен SRB, обычно устанавливают значение поля размера MTU равным 1500 для того, чтобы ограничить размер блоков данных Token Ring, входящих в домен ТВ. Некоторые хосты не могут точно обрабатывать это поле; в этом случае TLB вынуждены просто игнорировать те блоки данных, которые превышают размер MTU Еthernet.

Биты, представляющие функции Token Ring, не имеющие следствия в Ethernet, обычно отбрасываются протоколами TLB. Например, отбрасываются биты приоритета, резервирования и монитора Token Ring. Что касается битов состояния блоков данных Token Ring, то они обрабатываются по-разному в зависимости от изготовителя TLB. Некоторые изготовители TLB просто игнорируют эти биты. Другие обеспечивают установку в мостах бита С, но не обеспечивают бит А. В первом случае узел источника Token Ring не имеет возможности установить, потерян или нет отправленный им блок данных. Сторонники этого метода считают, что механизмы надежности, такие, как отслеживание потерянных блоков данных, лучше реализовать в уровне 4 модели ОSI. Защитники "метода установки бита С" утверждают, что этот бит должен быть задан для отслеживания потерянных блоков данных, но бит А не может быть установлен, т.к. мост не является конечным пунктом назначения.

TLB могут образовывать программный мост между двумя доменами. Для конечных станций SRB мост TLB выглядит как стандартный SRB, т.к. он имеет номер кольца и номер моста, связанного с ним. В этом случае номер кольца фактически отражает весь домен ТВ. Для домена ТВ, TLB является просто еще одним ТВ.

При об'единении с помощью моста доменов SRB и ТВ информация SRB удаляется. RIF обычно сохраняются в кэш для использования последующим возвратным трафиком. При об'единении с помощью моста доменов ТВ и SRB, TLB может проверить блок данных, чтобы узнать, имеет ли он назначение многопунктовой адресации. Если блок данных имеет многопунктовое или широковещательное назначение, он отправляется в домен SRB в качестве разведчика связующего дерева. Если блок данных имеет однопунктовый адрес, то TLB ищет пункт назначения в кэш RIF. Если тракт найден, то он будет использован, а информация RIF включается в блок данных; в противном случае этот блок данных отправляется в качестве разведчика связующего дерева. Т.к. две этих реализации связующего дерева несовместимы, то, как правило, не разрешаются несколько трактов между доменами SRB и ТВ.

Прозрачное объединение с помощью мостов "Источник-Маршрут" (SRT)

SRT комбинируют реализации алгоритмов ТВ и SRB. SRT используют бит индикатора маршрутной информации (routing information indicator - RII), чтобы отличать блоки данных, использующих SRB, от блоков данных, использующих ТВ. Если бит RII равен 1, то RIF присутствует в блоке данных, и данный мост использует алгоритм SRB. Если RII равен 0, то RIF oтсутствует, и данный мост использует ТВ.

Как и мосты TLB, мосты SRT не являются техническим решением, совершенным с точки зрения решения проблем об'единения с помощью мостов смешанных носителей. SRT также должны иметь дело с описанными выше несовместимостями Ethernet/Token Ring. Скорее всего, SRT потребует расширения аппаратных возможностей SRB, чтобы они могли справляться с дополнительной нагрузкой, связанной с анализом каждого пакета. Может потребоваться также программное наращивание SRB. Кроме того, в окружениях смешанных SRT, TB и SRB, выбранные маршруты источника должны пересекать любые доступные SRT и SRB. Результирующие тракты могут быть потенциально значительно хуже маршрутов связующего дерева, образованных мостами ТВ. И наконец, смешанные сети SRB/SRT теряют преимущества SRT, поэтому пользователи поймут, что они вынуждены осуществить полный переход к SRT, требующий значительных расходов. Однако SRT позволяет сосуществование двух несовместимых сред и обеспечивает связь между конечными узлами SRB и ТВ.


Глава 32. SNMP.

  • Основы технологии
    • Модель управления
    • Типы команд
    • Различия в представлениии информации
    • Базы данных управления
    • Операции
  • Формат сообщений

Библиографическая справка

В создание протокола SNMP внесли свой вклад разработки по трем направлениям:

High-level Entity Management System (HEMS)
Система управления об'ектами высшего уровня. Определяет систему управления с рядом интересных технических характеристик. К сожалению, HEMS использовалась только в местах ее разработки, что в конечном итоге привело к прекращению ее действия.
Simple Gateway Monitoring Protocol (SGMP)
Протокол управления простым роутером. Разработка была начата группой сетевых инженеров для решения проблем, связанных с управлением быстрорастущей Internet; результатом их усилий стал протокол, предназначенный для управления роутерами Internet. SGMP был реализован во многих региональных ветвях Internet.
CMIP over TCP (CMOT)
CMIP над ТСР. Пропагандирует сетевое управление, базирующееся на OSI, в частности, применение Common Management Information Protocol (CMIP) (Протокол информации общего управления) для облегчения управления об'единенных сетей, базирующихся на ТСР.

Достоинства и недостатки этих трех методов (HEMS, SGMP и CMOT) часто и горячо обсуждались в течение второй половины 1987 г. В начале 1988 г. был образован комитет Internet Activities Board - IAB (IAB - это группа, ответственная за техническую разработку протоколов Internet) для разрешения дебатов по поводу протокола сетевого управления. В конечном итоге комитет IAB пришел к соглашению, что улучшенная версия SGMP, которая должна была называться SNMP, должна стать временным решением; для долгосрочного применения должна быть проанализирована одна из технологий, базирующихся на OSI (либо СМОТ, либо сам СMIP). Для обеспечения легкого пути наращивания была разработана общая структура сетевого управления (которая теперь называется стандартной Структурой Управления Сети - Network Management Framework).

Сегодня SNMP является самым популярным протоколом управления различными коммерческими, университетскими и исследовательскими об'единенными сетями. Деятельность по стандартизации, связанная с SNMP, продолжается по мере того, как поставщики разрабатывают и выпускают современные прикладные программы управления, базирующиеся на SNMP. SNMP относительно простой протокол, однако набор его характеристик является достаточно мощным для решения трудных проблем, возникающих при управлении гетерогенных сетей.

Основы технологии

SNMP является протоколом прикладного уровня, предназначенным для облегчения обмена информацией управления между сетевыми устройствами. Пользуясь информацией SNMP (такой, как показатель числа пакетов в секунду и коэффициент сетевых ошибок), сетевые администраторы могут более просто управлять производительностью сети и обнаруживать и решать сетевые проблемы.

Модель управления
Агентами в SNMP являются программные модули, которые работают в управляемых устройствах. Агенты собирают информацию об управляемых устройствах, в которых они работают, и делают эту информацию доступной для систем управления сетями (network management systems - NMS) с помощью протокола SNMP. Эта модель представлена графически на Рис. 32-1.

Управляемое устройство может быть узлом любого типа, находящимся в какой-нибудь сети: это хосты, служебные устройства связи, принтеры, роутеры, мосты и концентраторы. Т.к. некоторые из этих систем могут иметь ограниченные способности управления программным обеспечением (например, они могут иметь центральные процессоры с относительно малым быстродействием или ограниченный об'ем памяти), программное обеспечение управления должно сделать допущение о наименьшем общем знаменателе. Другими словами, программы управления должны быть построены таким образом, чтобы минимизировать воздействие своей производительности на управляемое устройство.

Т.к. управляемые устройства содержат наименьший общий знаменатель программного обеспечения управления, тяжесть управления ложится на NMS. Поэтому NMS обычно являются компьютерами калибра АРМ проектировщика, которые имеют быстродействующие центральные процессоры, мегапиксельные цветные устройства отображения, значительный об'ем памяти и достаточный об'ем диска. В любой управляемой сети может иметься одна или более NMS. NMS прогоняют прикладные программы сетевого управления, которые представляют информацию управления пользователям. Интерфейс пользователя обычно базируется на стандартизированном графическом интерфейсе пользователя (graphical user interface - GUI).

Сообщение между управляемыми устройствами и NMS регулируется протоколом сетевого управления. Стандартный протокол сети Internet, Network Management Framework, предполагает парадигму дистанционной отладки, когда управляемые устройства поддерживают значения ряда переменных и сообщают их по требованию в NMS. Например, управляемое устройство может отслеживать следующие параметры:

Число и состояние своих виртуальных цепей
Число определенных видов полученных сообщений о неисправности
Число байтов и пакетов, входящих и исходящих из данного устройства
Максимальная длина очереди на выходе (для роутеров и других устройств об'единения сетей)
Отправленные и принятые широковещательные сообщения
Отказавшие и вновь появившиеся сетевые интерфейсы

Типы команд
Если NMS хочет проконтролировать какое-либо из управляемых устройств, она делает это путем отправки ему сообщения с указанием об изменении значения одной из его переменных. В целом управляемые устройства отвечают на четыре типа команд (или инициируют их):

Reads
Для контролирования управляемых устройств NMS считывают переменные, поддерживаемые этими устройствами.
Writes
Для контролирования управляемых устройств NMS записывают переменные, накопленные в управляемых устройствах
Traversal operations
NMS используют операции прослеживания, чтобы определить, какие переменные поддерживает управляемое устройство, а затем собрать информацию в таблицы переменных (такие, как таблица маршрутизации IP)
Traps
Управляемые устройства используют ловушки для асинхронных сообщений в NMS о некоторых событиях.

Различия в представлениии информации
Обмен информацией в управляемой сети находится потенциально под угрозой срыва из-за различий в технике представления данных, используемой управляемыми устройствами. Другими словами, компьютеры представляют информацию по-разному; эту несовместимость необходимо рационализировать, чтобы обеспечить сообщение между различными системами. Эту функцию выполняет абстрактный синтаксис. SNMP использует для этой цели подмножество абстрактного синтаксиса, созданного для OSI - Abstract Syntax Notation One (ASN.1) (Система обозначений для описания абстрактного синтаксиса). ASN.1 определяет как форматы пакетов, так и управляемые об'екты. Управляемый об'ект-это просто характеристика чего-либо, которой можно управлять. Управляемый об'ект отличается от переменной, которая является конкретной реализацией об'екта. Управляемые об'екты могут быть скалярными (определяя отдельную реализацию) или табулярными величинами (определяя несколько связанных друг с другом реализаций).

Базы данных управления
Все управляемые об'екты содержатся в Информационной базе управления (Management Information Base - MIB), которая фактически является базой данных об'ектов. Логически MIB можно изобразить в виде абстрактного дерева, листьями которого являются отдельные информационные элементы. Идентификаторы об'ектов уникальным образом идентифицируют об'екты MIB этого дерева. Идентификаторы об'ектов похожи на телефонные номера тем, что они организованы иерархически и их отдельные части назначаются различными организациями. Например, международные телефонные номера состоят из кода страны (назначаемого международной организацией) и телефонного номера в том виде, в каком он определен в данной стране. Телефонные номера в США далее делятся на код области, номер центральной телефонной станции (СО) и номер станции, связанной с этой СО. Аналогично, идентификаторы об'ектов высшего уровня MIB назначаются Международной Электротехнической Комиссией ISO (ISO IEC). ID об'ектов низшего уровня назначаются относящимися к ним организациями. На Рис. 32-2 изображены корневая и несколько наиболее крупных ветвей дерева MIB.

Дерево MIB расширяемо благодаря экспериментальным и частным ветвям. Например, поставщики могут определять свои собственные ветви для включения реализаций своих изделий. В настоящее время вся работа по стандартизации ведется на экспериментальной ветви.

Структуру MIB определяет документ, называемый Структура Информации Управления (Structure of Management Information - SMI). SMI определяет следующие типы информации:

Network addresses (Сетевые адреса)
Предсталяют какой-нибудь адрес из конкретного семейства протоколов. В настоящее время единственным примером сетевых адресов являются 32-битовые адреса IP.
Counters (Счетчики)
Неотрицательные целые числа, которые монотонно увеличиваются до тех пор, пока не достигнут максимального значения, после чего они сбрасываются до нуля. Примером счетчика является общее число байтов, принятых интерфейсом.
Gauges (Измерительный прибор, мера, размер)
Неотрицательные целые числа, которые могут увеличиваться или уменьшаться, но запираются при максимальном значении. Примером измерительного прибора является длина очереди, состоящей из выходных пакетов (в пакетах).
Ticks (Тики)
Сотые доли секунды, прошедшие после какого-нибудь события. Примером tick является время, прошедшее после вхождения интерфейса в свое текущее состояние.
Opaque (Мутный)
Произвольное кодирование. Используется для передачи произвольных информационных последовательностей, находящихся вне пределов точного печатания данных, которое использует SMI.

Операции
SNMP является простым протоколом запроса/ответа. Узлы могут отправлять множество запросов, не получая ответа. Определены следующие 4 операции SNMP:

Get (достань).
Извлекает какую-нибудь реализацию об'екта из агента.
Get-next (достань следующий).
Операция прослеживания, которая извлекает следущую реализацию об'екта из таблицы или перечня, находящихся в каком-нибудь агенте.
Set (установи).
Устанавливает реализации об'екта в пределах какого-нибудь агента.
Trap (ловушка).
Используется агентом для асинхронного информирования NMS о каком-нибудь событии.

Формат сообщений

Сообщения SNMP состоят из 2 частей: имени сообщества (community name) и данных (data). Имя сообщества назначает среду доступа для набора NMS, которые используют это имя. Можно сказать, что NMS, принадлежащие одному сообществу, находятся под одним и тем же административным началом. Т.к. устройства, которые не знают правильного имени сообщества, исключаются из операций SNMP, управляющие сетей также используют имя сообщества в качестве слабой формы опознавания.

Информационная часть сообщения содержит специфичную операцию SNMP (get, set, и т.д.) и связанные с ней операнды. Операнды обозначают реализации об'екта, которые включены в данную транзакцию SNMP.

Сообщения SNMP официально называются протокольными единицами данных (protocol data units - PDU). На Рис. 32-3 изображен формат пакета SNMP.

PDU операций get и set SNMP состоят из следующих частей:

Request-ID (идентификатор запроса).
Устанавливает связь между командами и ответами.
Error-status (состояние сбоя).
Указывает ошибку и ее тип.
Error-index (индекс ошибки).
Устанавливвает связь между ошибкой и конкретной реализацией об'екта.
Variable bindings (переменные привязки).
Состоят из данных SNMP PDU. Пепеменные привязки устанавливают связь между конкретными переменными и их текущими значениями.

PDU ловушки несколько отличаются от PDU других операций. Они состоят из следующих частей:

Enterprise (предметная область).
Идентифицирует тип об'екта, генерирующего данную ловушку.
Agent address (адрес агента).
Обеспечивает адрес об'екта, генерирующего данную ловушку.
Generic trap type (групповой тип ловушки).
Обеспечивает групповой тип ловушки.
Specific trap code (специфичный код ловушки).
Обеспечивет специфичный код ловушки.
Time stamp (временной ярлык).
Обеспечивает величину времени, прошедшего между последней повторной инициализацией сети и генерацией данной ловушки.
Variable bindings (переменные привязки).
Обеспечивает перечень переменных, содержащих интересную информацию о ловушке.


Глава 33. Управление сетями IBM.

  • Функциональные области управления
    • Управление конфигурацией
    • Управление производительностью и учетом сетевых ресурсов
    • Управление проблемами
    • Управление операциями
    • Управление изменениями
  • Основные архитектуры и платформы управления
    • Структура управления открытой сети (ONA)
    • System View
    • NetView
    • Управляющий сети LAN
    • SNMP

Библиографическая справка

IBM была одной из первых компаний, которые признали важность полной интегрированной стратегии управления сетями. В 1986 г. IBM предложила Open Network Management (ONA)(Управление открытыми сетями) - структуру, описывающую обобщенную архитектуру управления сетями. NetView, самое первое изделие сетевого управления для универсальной вычислительной машины IBM, фактически является компонентом ONA. NetView обеспечивает связный набор услуг централизованного управления сетями, который дает возможность пользователям контролировать, управлять и перестраивать конфигурацию своих сетей SNA (Systems Network Architecture - Aрхитектура Системной Сети).

За время, прошедшее с момента появления ONA и NetView, IBM постоянно совершенствовала, расширяла и и вносила другие изменения в технологическую базу управления сетями. В настоящее время сетевое управление IBM является всеоб'емлющим и чрезвычайно сложным. В последующих разделах дается описание наиболее важных основ некоторых из компонентов сетевого управления IBM.

Функциональные области управления

IBM делит сетевое управление на 5 функций, ориентированных на пользователя:

Configuration management (управление конфигурацией).
Идентифицирует ресурсы физических и логических систем и обеспечивает управление их взаимоотношениями.
Perfomance and accounting management (управление производительностью и учетом использования ресурсов).
Обеспечивает квалификацию, измерение, сообщение и управление реакцией, доступностью, утилизацией и использованием компонентов сети.
Problem management (управление проблемами).
Обеспечивает обнаружение, диагностику, решение, а также средства отслеживания и управления проблемой.
Operations management (Управление операциями).
Обеспечивает средства для запроса и управления распределенными сетевыми ресурсами из центрального пункта.
Change management (Управление изменениями).
Обеспечивает планирование, управление и применение дополнений, исключений и модификаций в аппаратном обеспечении, микрокодировании и программном обеспечении системы.

Эти функции сетевого управления не совсем точно коррелируются с функциями, предложенными ISO в модели OSI. Сравнение функций сетевого управления OSI и IBM приведено на Рис. 33-1.

OSI | IBM
Configuration management | Configuration management
Performance management | Performance and accounting management
Accounting management
Fault management | Problem management
Security management | -
- | Operations management
- | Change management

Figure 33-1

Управление конфигурацией
Конфигурационное управление управляет информацией, описывающей как физические, так и логические ресурсы информационных систем и их взаимоотношения друг с другом. Эта информация обычно состоит из названий ресурсов, адресов, местоположений, контактов и телефонных номеров. Функция управления конфигурацией IBM очень близко соответствует концепции OSI об управлении конфигурацией.

С помощью средств управления конфигурацией пользователи могут поддерживать ведомость сетевых ресурсов. Управление конфигурацией помогает гарантировать быстроту и точность отражения изменений сетевой конфигурации в базе данных конфигурационного управления. Информация управления конфигурацией используется системами управления проблемами для сравнения различий в версиях и для локализации, идентификации и проверки характеристик сетевых ресурсов. Системы управления изменениями могут использовать данные управления конфигурацией для анализа эффекта, произведенного изменениями, и для составления графика внесения изменений в моменты минимального сетевого воздействия.

Услуга управления SNA, называемая "идентификация изделия запроса" (query product identification), извлекает программную и аппаратную физическую информацию из базы данных управления конфигурацией. Извлеченная информация иногда называется "данными жизненноважного изделия" (vital product data).

Управление производительностью и учетом сетевых ресурсов
Эта функция управления SNA обеспечивает информацию о производительности сетевых ресурсов. Путем анализа данных управления производительностью и учетом ресурсов, пользователи могут определять, будут ли удовлетворены задачи производительности сети.

Управление производительностью и учетом включает в себя учет ресурсов, контролирование времени реакции, доступности, утилизации и компонентной задержки, а также регулировку, отслеживание и управление производительностью. Информация от работы каждой из этих функций может привести к инициированию процедуры определения проблемы, если уровни производительности не отвечают требуемым.

Управление проблемами
Услуги управления SNA определяют проблему (problem) как сбойную ситуацию, которая приводит к потере пользователем всех функциональных свойств ресурсов системы. SNA делит управление проблемами на несколько областей:

Problem determination (Определение проблемы).
Выявляет проблему и выполняет шаги, необходимые для начала диагностики проблемы. Назначение этой области - изолировать проблему в конкретной подсистеме, например, в каком-нибудь аппаратном устройстве, программном изделии, компоненте микрокода или сегменте носителя.
Problem diagnosis (Диагноз проблемы).
Определяет точную причину проблемы и воздействие, необходимое для решения этой проблемы. Если диагноз проблемы выполняется вручную, то он следует за определением проблемы. Если он выполняется автоматически, то это обычно делается одновременно с определением проблемы, чтобы можно было выдать результаты вместе.
Problem bypass and recovery (Обход проблемы и восстановление).
Попытки обойти проблему либо частично, либо полностью. Обычно эта операция является временной, причем подразумевается, что далее последует полное решение проблемы; однако обход проблемы может быть перманентным, если она не просто решается.
Problem resolution (Решение проблемы).
Включает усилия, необходимые для устранения проблемы. Решение проблемы обычно начинается после установления ее диагноза и часто включает в себя корректирующее воздействие, которое должно быть занесено в график; например, это может быть замена отказавшего дисковода.
Problem tracking and control (Отслеживание и управление проблемой).
Отслеживет проблему до ее полного решения. В частности, если для решения проблемы необходимо внешнее воздействие, то жизненноважная информация, описывающая эту проблему (такая, как информация контролирования состояния и отчеты о состоянии проблемы), включается в запись управления проблемой, которая вводится в базу данных этой проблемы.

Управление операциями
Управление операциями включает в себя управление распределенными сетевыми ресурсами из центрального пункта. Оно предусматривает два набора функций: услуги общих операций (common operations service) и услуги управления операциями (operations management services).

Услуги общих операций обеспечивают управление ресурсами, которыми другие категории SNA занимаются в неявно выраженном виде, путем обеспечения специализированной связи с этими ресурсами с помощью новых, более производительных прикладных программ. Двумя очень важными услугами, которые обеспечивают эту производительность, являются команда execute (выполняй) и услуга управления ресурсами. Команда executeобеспечивает стандартизированные средства выполнения какой-нибудь дистанционной команды. Услуги управления ресурсами обеспечивают возможность транспортировки информации независимым от контекста способом.

Услуги управления операциями обеспечивают возможность управления дистанционными ресурсами путем активации и дезактивации ресурсов, отмены команды и установки часов сетевых ресурсов. Услуги управления операциями могут быть инициированы автоматически в результате продвижения уведомления о системной проблеме, тем самым позволяя автоматическую обработку дистанционных проблем.

Управление изменениями
Управлениие изменениями помогает пользователям управлять сетевыми или системными изменениями путем обеспечения отправки, извлечения, установки и удаления файлов изменений в отдаленных узлах. Кроме того, управление изменениями обеспечивает активацию узла. Изменения имеют место либо из-за изменений в требованиях пользователя, либо из-за необходимости обойти проблему.

Хотя наличие проблем приводит к изменению, изменение также может вызвать проблемы. Управление изменением пытается минимизировать проблемы, вызванные изменением, путем поощрения упорядоченного изменения и отслеживания изменений.

Основные архитектуры и платформы управления

IBM предлагает несколько архитектур управления и важных платформ управления.

Структура управления открытой сети (ONA)
Базовая структура ONA представлена на Рис. 33-2.

Фокусы (focal points) обеспечивают поддержку операций централизованного сетевого управления. Это те об'екты управления, которые уже были названы ранее в описанной общей модели. Фокусы отвечают на предупреждения конечных станций, поддерживают базы данных управления и обеспечивают интерфейс пользователя с оператором управления сети.

Существуют два вида фокусов: первичный (primary) и вторичный (secondary). Первичные фокусы соответствуют описанным выше. Вторичные фокусы обеспечивают резерв для первичных фокусов и используются при отказе первичных фокусов.

Вложенные фокусы (nested focal points) обеспечивают поддержку распределенного управления для частей крупных сетей. Они продвигают критичную информацию в другие глобальные фокусы.

Точки сбора (collection points) передают инфрмацию из автономных подсетей SNA в фокусы. Точки сбора обычно используются для продвижения данных из сети IBM с равноправными узлами в иерархию ONA.

Точки ввода (entry points) являются устройствами SNA, которые могут реализовать ONA для себя и для других устройств. Большинство стандартных устройств SNA могут быть точками ввода.

Точки обслуживания (service points) являются системами, которые обеспечивают доступ в ONA для устройств, не являющихся устройствами SNA. Toчки обслуживания способны отправлять в фокусы информацию сетевого управления о системах, не являющихся системами SNA, а также принимать команды из фокусов, транслируя их в формат, приемлемый для устройств, не являющихся устройствами SNA, и продвигать их в эти устройства для выполнения. Точки обслуживания фактически являются сетевыми интерфейсами с ONA.

System View
IBM об'явила о System View в 1990 г. System View является программой для разработки прикладных задач управления, способных управлять информационными системами от нескольких поставщиков. В частности, System View описывает, как будут выглядеть и работать прикладные программы, управляющие гетерогенными сетями, а также как они будут кооперировать с другими системами управления. System View является официальной стратегией управления системами SAA (Systems Application Architecture - Архитектура системных прикладных программ).

NetView
NetView является самой всеоб'емлющей платформой управления сети предметной области. Она содержит следующие основные части:

Command control facility (средства управления командами).
Обеспечивает ваозможность управления сети с помощью базового оператора и команд файлового доступа к прикладным программам, контроллерам, операционным системам и интерфейсу NetView/PC (интерфейс между NetView и устройствами, не являющимися устройствами SNA) VTAM (Virtual Telecommcnications Access Method - Метод Обеспечения Доступа к Виртуальной Сети Связи).
Hardware monitor (монитор аппаратного обеспечения).
Контролирует сеть и автоматически выдает предупреждения оператору сети, если имеет место неисправность в аппаратуре.
Session monitor (монитор сеанса).
Действует как монитор производительности VTAM. Монитор сеанса обеспечивает определение проблем в программном обеспечении и управление конфигурацией.
Help function (функция оказания помощи).
Обеспечивает помощь пользователям услуг управления NetView. Эта функция включает в себя средства просмотра файлов, пульт функции помощи и библиотеку наиболее часто встечающихся ситуаций при работе сети.
Status monitor (монитор состояния).
Обобщает и представляет информацию о состоянии сети.
Performance monitor (монитор производительности).
Koнтролирует производительность контроллеров связи (communications controllers), которые также называются процессорами предварительной обработки данных (front-end processors - FEPs), Программу управления сетью (Network Control Program - NCP) и прикрепленными ресурсами.
Distribution manager (управляющий распределением).
Планирует, составляет график и отслеживает распределение информации, программного обеспечения и микрокода 3174 в среде SNA.

Управляющий сети LAN
Изделие IBM "Управляющий сети LAN" (LAN Network Manager - LNM) представляет собой прикладную программу управления сети, базирующуюся на OS/2 Extended Edition (расширенный вариант), которая позволяет управлять локальными сетями Token Ring из центрального пункта поддержки. Для NetView деятельность LNМ может быть видимой (например, аварийные сигналы). LNM сообщается с программным обеспечением LAN, называемым LAN Station Manager (LSM) (Управляющий станций LAN), которое реализует агентов управления в отдельных конечных станциях LAN. Сообщение между LNM и LSM осуществляется путем использования Протокола CMIS/CMIP (OSI Common Management Information Services/Common Management Information Protocol - Информационные услуги общего управления OSI/ Протокол информации общего управления), который управляет работой протокола LLC (Logical Link Control - Протокол управления логическим каналом без установления соединения).

SNMP
IBM недавно включила поддержку протокола SNMP (смотри Главу 32 "SNMP").


CISCO Internetworking Technology Overview
Содержание

Часть I. Основы построения объединенных сетей.

  • Глава 1. Введение в объединенные сети.
    Введение, Эталонная модель OSI, Иерархическая связь, Форматы информации, Проблемы совместимости, Уровни OSI, Важнейшие термины и концепции, Адресация, Блоки данных (фрэймы), пакеты и сообщения, Основные организации.
  • Глава 2. Основы маршрутизации.
    Компоненты маршрутизации, Определение маршрута, Коммутация, Алгоритмы маршрутизации, Цели разработки алгоритмов маршрутизации, Типы алгоритмов, Показатели алгоритмов (метрики), Сопоставление терминов "Routed Protocol" и "Routing Protocol".
  • Глава 3. Основы объединения сетей с помощью мостов.
    Сравнение устройств для объединения сетей, Основы технологии объединения сетей, Типы мостов Глава 4. Основы управления сетями.
    Архитектура управления сети, Модель управления сети ISO, Управление эффективностью, Управление конфигурацией, Управление учетом использования ресурсов, Управление неисправностями, Управление защитой данных

Часть II. Технология доступа к среде.

  • Глава 5. Ethernet и IEEE 802.3.
    Сравнение Ethernet и IEEE 802.3, Физические соединения, Форматы блока данных
  • Глава 6. Token Ring и IEEE 802.5.
    Сравнение Token Ring и IEEE 802.5, Передача маркера, Физические соединения, Система приоритетов, Механизмы управления неисправостями, Формат блока данных
  • Глава 7. FDDI
    Основы технологии, Технические условия FDDI, Физические соединения, Типы трафика, Особенности отказоустойчивости, Формат блока данных
  • Глава 8. UltraNet
    Основы технологии, Компоненты UltraNet, Концентратор (hub) UltraNet, Программное обеспечение главной вычислительной машины UltraNet, Управляющий сети UltraNet, Сетевые процессоры, Адаптеры каналов связи
  • Глава 9. HSSI
    Основы технологии
  • Глава 10. PPP
    Компоненты PPP, Основные принципы работы, Требования, определяемые физическим уровнем, Канальный уровень PPP, Протокол управления канала связи PPP (LCP)
  • Глава 11. ISDN
    Компоненты ISDN, Усдуги ISDN, Уровень 1, Уровень 2, Уровень 3

Часть III.

  • Глава 12. SDLC и его производные.
    Основы технологии, Форматы блока данных, Производные протоколы, HDLC, LAPB, IEEE802.2
  • Глава 13. X25.
    Основы технологии, Формат блока данных, Уровень 3, Уровень 2, Уровень 1
  • Глава 14. Frame Relay.
    Основы технологии, Дополнения LMI, Форматы блока данных, Формат сообщений LMI, Глобальная адресация, Групповая адресация (multicusting), Реализация сети
  • Глава 15. SMDS.
    Основы технологии, Адресация, Классы доступа, Протокол интерфейса SMDS (SIP), Конфигурация CPE, Уровни SIP, Реализация сети

Часть IV.

  • Глава 16. Apple Talk
    Основы технологии, Доступ к среде, Сетевой уровень, Назначения адреса протокола, Сетевые объекты, Протокол доставки дейтаграмм (DDP), Протокол поддепжки маршрутной таблицы (RTMP), Транспортный уровень, Протокол транзакций AppleTalk (ATP), Протокол потока данных AppleTalk (ADSP), Протоколы высших уровней
  • Глава 17. DECnet
    Архитектура цифровой сети (DNA), Доступ к среде, Сетевой уровень, Формат длока данных маршрутизации DECnet Phase IV, Адресация, Уровни маршрутизации, Транспортный уровень, Протоколы высших уровней
  • Глава 18. Протоколы Internet.
    Сетевой уровень, Адресация, Маршрутизация Internet, ICMP, Транспортный уровень, Протокол управления передачей (TCP), Протокол дейтаграмм пользователя (UDP), Протоколы высших уровней
  • Глава 19. Протоколы NetWare.
    Основы технологии, Доступ к среде, Сетевой уровень, Транспортный уровень, Протоколы высших уровней
  • Глава 20. Протоколы OSI.
    Основы технологии, Доступ к среде, Сетевой уровень, Услуги без установления соединения, Услуги с установлением соединения, Адресация, Транспортный уровень, Протоколы высших уровней, Сеансовый уровень, Представительный уровень, Прикладной уровень
  • Глава 21. Banyan VINES.
    Основы технологии, Доступ к среде, Сетевой уровень, Протокол межсетевого обмена VINES (VIP), Протокол корректировки маршрутизации (RTR), Протокол разрешения адреса (ARP), Протокол управления объединеной сетью (ICP), Транспортный уровень, Протоколы высших уровней
  • Глава 22. XNS.
    Основы технологии, Доступ к среде, Сетевой уровень, Транспортный уровень, Протоколы высших уровней

Часть V. Протоколы Маршрутизации.

  • Глава 23. RIP.
    Формат таблицы маршрутизации, Формат пакета (Реализация IP), Характеристики стабильности, Ограничение числа пересылок, Временные удерживания изменений, Расщепленные горизонты, Корректировки отмены маршрута
  • Глава 24. IGRP.
    Технология, Формат пакета, Характеристики стабильности, Временные удерживания изменений, Расщепленные горизонты, Корректировки отмены маршрута, Таймеры
  • Глава 25. OSPF.
    Основы технологии, Иерархия маршрутизации, Алгоритм OSPF, Формат пакета, Дополнительные характеристики OSPF
  • Глава 26. EGP.
    Основы технологии, Формат пакета, Типы сообщений, Приобретение соседа, Досягаемость соседа, Опрос, Корректиравка маршрутизации, Сообщения о неисправностях
  • Глава 27. BGP.
    Основы технологии, Формат пакета, Сообщения, Открывающее сообщение, Сообщения о корректировках, Сообщения keepalive, Уведомления
  • Глава 28. Маршрутизация OSI.
    Терминология, ES-IS, IS-IS, Иерархия маршрутизации, Сообщение между ES, Показатели (метрики), Формат пакета, Интегрированный IS-IS, Протокол междоменной маршрутизации (IDRP)

Часть VI. Технология мостов.

  • Глава 29. Прозрачное объединение сетей с помощью мостов.
    Основы технологии, Петли в сетях, объединенных с помощью мостов, Алгоритм связующего дерева (Spanning-Tree Algoritm) (STA), Формат блока данных (фрэйма)
  • Глава 30. Объединение сетей с помощью мостов "Источник-Маршрут".
    Алгоритм SRB, Формат блока данных (фрэйма)
  • Глава 31. Объединение смешанных носителей с помощью мостов.
    Основы технологии, Трудности трансляции, Трансляционное объединение с помощью мостов (TLB), Прозрачное объединение с помощью мостов "Источник-Маршрут" (SRT)

Часть VII. Управление Сетью.

  • Глава 32. SNMP.
    Основы технологии, Модель управления, Типы команд, Различия в представлениии информации, Базы данных управления, Операции, Формат сообщений
  • Глава 33. Управление сетями IBM.
    Функциональные области управления, Управление конфигурацией, Управление производительностью и учетом сетевых ресурсов, Управление проблемами, Управление операциями, Управление изменениями, Основные архитектуры и платформы управления, Структура управления открытой сети (ONA), System View, NetView, Управляющий сети LAN, SNMP


Концепции построения сети

Copyright (C) Cisco Systems, Inc., (С) PLUS Communications, 1998

Цифровая сеть передачи данных

с интеграцией услуг

Cодержание

Предисловие

Назначение документа

Состояние рынка телекоммуникаций стран СНГ и тенденции его развития

Пути внедрения

Краткий анализ технологий передачи данных

ATM и PDH (ИКМ)

ATM и SDH

Построение региональных ВОЛС на базе оборудования SDH

Построение региональных ВОЛС коммутации ячеек/пакетов ATM/FR

Передача голоса по сетям АТМ

Раздел 1. Почему Cisco?

Cisco IOS™

Раздел 2. Решения CISCO SYSTEMS для поставщиков услуг

Сети поставщиков услуг 21 века

Что приводит к изменениям в глобальном сетевом взаимодействии?

Консолидация индустрии

Конвергенция технологий

Интеллектуальные IP сети будущего

Мультисервисные решения

Раздел 3. Решения CISCO SYSTEMS для сети с интеграцией услуг

Общая структура сети

Основные характеристики широкополосной АТМ-сети

Уровень ядра сети

Роль ядра сети: обслуживание пограничной сети

Оборудование и технологии для построения магистральной сети

Уровень распределения сети

Роль пограничной сети: обслуживание потребителя

Оборудование для построения пограничной сети

Стандартные функции

Управление АТМ-сетями CISCO

Уровень доступа сети

Назначение

Модель взаимодействия end-to-end

Технологии и их применение

Технология ADSL и оборудование уровня доступа

История развития технологии xDSL

Различные типы xDSL и как они работают

Асимметричная цифровая абонентская линия (ADSL)

Адаптивная по скорости цифровая абонентская линия (R-ADSL)

xDSL - широкополосный доступ по медным проводам

Бизнес - возможности сетей ADSL

Услуги связи с Internet

Услуги связи с филиалами

Услуги телекоммуникации

Услуги бизнес-бизнес

Услуги предоставления информации

Требования к услугам end-to-end

Конфигурации доступа

Internet

Корпоративные сети

Локальная информация

Равноправная связь

Функциональные требования для сети ADSL

Легкость миграции от существующей инфраструктуры доступа ISP

Одновременная связь: Internet и корпоративная сеть

Многопротокольная поддержка

Защита

Многоадресная передача

Поддержка нескольких классов услуг

Поддержка качества обслуживания

Оборудование для построения ADSL-сети

Доступ по коммутируемым линиям и оборудование уровня доступа

Реализация узла доступа в Интернет сети оператора связи/поставщика услуг

Функциональные возможности серверов AS5x00 с операционной системой Cisco IOS

Cisco IOS – основа AS5х00

Безопасный доступ (Secure Dial Access)

Сервисы WAN

Оптимизация использования ресурсов (WAN-оптимизация)

Качество сервиса (QoS)

Маршрутизация IP

Поддержка Virtual Private Network

Обеспечение и учет VPN

Управление

Универсальные серверы доступа CISCO AS5200/5300

Примеры мультисервисных сетей Cisco StrataCom

Заключение

Сети СISCO следующего поколения

Факторы развития

Пограничная сеть следующего поколения

Ядро следующего поколения

Итоги финансового года CISCO SYSTEMS

Предисловие

Назначение документа

Настоящий документ носит ознакомительный характер и его целью является представление концепций, технологий и оборудования для построения широкополосной цифровой мультисервисной сети оператора связи, обеспечивающей предоставление своим абонентам услуг телефонной связи, доступа к информационным ресурсам частных распределенных сетей и сетей общего пользования (Интернет).

Создание высокоэффективной телекоммуникационной среды является важнейшей национальной проблемой. Без ее решения невозможно построение информационного сообщества и внедрение новейших информационных технологий в сферы производства, бизнеса, науки, образования, медицины и т.д. Именно информация становится стратегическим ресурсом, а наибольший экономический и социальный успех сопутствует тем, активно использует и предлагает современные средства и услуги информационных и телекоммуникационных технологий.

В большинстве случаев территориально-распределенная сеть поставщика услуг существует для того, чтобы обеспечить возможность удобного и низкостоимостного взаимодействия отдельных пользователей или групп между собой. Поставщики услуг используют оборудование, программное обеспечение, человеческие ресурсы для того, чтобы максимально использовать свои сети с одновременным уменьшением стоимости расходов на эксплуатацию оборудования и на общее содержание сети. Оптимальное использование сети зависит от услуг, которые она предоставляет: насколько хорошо каждая услуга разрешает проблемы потребителя, насколько быстро услуга может быть доставлена потребителю и насколько надежно функционирует эта услуга. Стоимость сети (и расходы на ее содержание) зависит от инфраструктуры, развернутой для ее поддержания: общей стоимости требуемого оборудования, стоимости поддержки информационных систем, расходов на содержание обслуживающего персонала, ширины полосы пропускания, потребляемой услугами и т.д. Очевидно, что наиболее рентабельные поставщики услуг - это те, которые могут развернуть свои сети с приносящими доход услугами с наименьшими для себя затратами.

Состояние рынка телекоммуникаций стран СНГ и тенденции его развития

Существующие телекоммуникационные сети обладают целом рядом недостатков, из которых следует отметить их узкую специализацию, отсутствие гибкости и адаптации к изменению требований пользователей, а также низкую эффективность использования сетевых ресурсов.

В настоящее время телекоммуникации на всей территории бывшего союза - отрасль, находящаяся на подъеме. Доходность возросла, особенно для крупнейших компаний. В ситуации, когда спрос резко подскочил, а затраты снижаются быстрее, чем цены, эти компании в полной мере пользуются своим монопольным положением. В этом состоит главная причина, почему даже некомпетентно управляемые фирмы могут получать высокие прибыли.

Потребителям приходилось принимать любое качество обслуживания и радоваться ему. Но теперь такому состоянию дел приходит конец: на рынок активно выходят новые конкуренты, а клиенты из мира бизнеса требуют нового качества услуг и не согласны мириться с ситуацией, при которой, например, обрывается почти 50% телефонных переговоров, или с длинными очередями на подключение телефона.

Конкуренция возрастает и идет по многим направлениям. Как пример, можно привести ситуацию, когда правительство России поддерживает нарастание конкуренции с сфере телекоммуникаций и выступает за устранение диктата Ростелекома (национальной монополии) на внутреннем рынке.

Новейшие технологии разбивают монополистический контроль над телекоммуникациями и приводят в эту область новых конкурентов. Теперь конкурируют не только различные телефонные фирмы, но и компании кабельного телевидения (которые также передают данные по своим линиям), поставщики услуг Интернет, производители программного обеспечения (предлагающие услуги связи через компьютерные сети), банки (которые предлагают услуги специализированных систем передачи финансовой информации). Данная ситуация способствует превращению телекоммуникаций из индустрии, которая занята строительством и поддержанием систем связи, в индустрию, предлагающую связь лишь как часть широкого спектра услуг. Поскольку новые технологии снижают затраты, связанные с вхождением в бизнес, конкуренция распространяется все шире. Правительство РФ начинает осознавать, что конкуренция - лучшая гарантия, что прогресс технологии найдет полное выражение в виде более качественных, доступных и дешевых услуг.

Министерства, как и местные компании и банки, осознали, наконец, необходимость круглосуточного, беспрепятственного потока информации и денежных переводов и ненадежность существующих линий связи. Крупные частные заказчики (по некоторым сообщениям, одни лишь российские банковские гиганты - Инкомбанк, Онэксимбанк и Мост-банк - потратили в 1997 году $78 млн. на оборудование для систем связи), которые хотят иметь больший выбор и более высокое качество услуг, также давят на правительство, стремясь заставить его реформировать телекоммуникации.

Международный опыт указывает на несколько моментов, которые должны иметь в виду страны с переходной экономикой:

  • "Либерализация" телекоммуникаций состоит из трех частей: подсоединение оборудования клиента (типа компьютера или факса) к телефонной сети, перепродажа телефонных линий, арендованных у телефонного ведомства и полностью независимая конкурентоспособная сеть;
  • Конкуренция в целом ведет к снижению, а не к повышению тарифов (хотя цена некоторых субсидируемых услуг может повыситься);
  • Все крупные компании телекоммуникаций имеют большие скрытые возможности, которые они используют против конкурентов;
  • В таких огромных организациях, как государственные монополии, установить, имеет ли место субсидирование одних услуг за счет других (как и факт ценовой политики, направленной против конкурентов), практически невозможно;
  • Как показал опыт США, Великобритании и ряда других стран, приватизация и децентрализация может дать эффект - но только если для контроля будет создан сложный регулирующий аппарат, включая целый корпус юристов, специализирующихся на вопросах телекоммуникаций.

Есть и другая причина, по которой следует признать необходимость либерализации телекоммуникаций. Эта отрасль вместе с остальными отраслями услуг и инфраструктуры, такими, как банки, страхование и транспорт, принадлежит к областям, которые делают современную экономику динамичной. Если телефонную систему страны можно заставить работать хорошо, и при этом дешевле, выгоды от этого для всей экономики в целом просто нельзя переоценить.

Пути внедрения

Мировая практика развития сетей связи показывает, что основными этапами перехода от не интегрированных аналоговых сетей к цифровым сетям с интеграцией служб являются:

  • Развертывание цифровой сети;
  • Создание цифровой сети интегрального обслуживания с коммутацией каналов для служб телефонии на базе единого цифрового канала 64Кбит/с;
  • Создание широкополосной цифровой сети интегрального обслуживания (B-ISDN) на технологиях АТМ/FrameRelay с объединением всех унаследованных служб и информационных сетей.

Данным документом охватывается именно третий, заключительный, этап развития цифровых сетей, предполагающий построение высокоскоростного ядра цифровой сети с поэтапной интеграцией с существующей инфраструктурой низкоскоростных цифровых сетей и организацией абонентского доступа на базе аналоговых телефонных сетей.

При этом, анализ развития отрасли показывает существование двух ярко выраженных тенденций создания широкополосных цифровых сетей:

  1. Построение региональных ВОЛС на базе оборудования SDH.
  2. Построение региональных ВОЛС коммутации ячеек и пакетов ATM/FR с интеграцией услуг.

Компания PLUS Communications предлагает законченные решения (end-to-end) для построения мультисервисных цифровых сетей с использованием оборудования и технологических решений компании Cisco Systems, Inc.

Краткий анализ технологий передачи данных

ATM и PDH (ИКМ)

Тенденции развития технологий передачи данных для территориально-распределенных сетей можно проследить на примере технологий PDH (плезиохронная цифровая иерархия) и АТМ (асинхронный режим передачи).

  • 1980-1990 – широкое распространение TDM-оборудования, как основы для построения сетей PDH;
  • 1991-1995 – развитие Frame Relay и АТМ;
  • 1996-1997 – принятие концепции мультисервисных сетей АТМ;
  • 1998-2002 – широкое распространение АТМ.

Отсюда становятся очевидными два направления:

  1. Продолжать развитие сетей на базе TDM-оборудования и отвечать на современные требования по предоставлению телекоммуникационных услуг путем инсталляции дополнительного магистрального оборудования (“технологических заплат”) и, как следствие, создание наложенных сетей.
  2. Используя полную совместимость сетей АТМ с TDM осуществлять переход на современные технологии мультисервисных сетей с постепенным вытеснением TDM по мере амортизации устаревшего оборудования, выигрывая время на подготовку к взрывному росту спроса на услуги мультисервисных сетей в обозримом будущем.

Первый путь подразумевает продление жизни устаревающей технологии и соответствует оптимальному решению для конца 80-х – начала 90-х годов. Тем не менее, такое решение не исключает перехода на АТМ-сети, а лишь оттягивает этот переход на более позднее время, накапливая на балансе неперспективное оборудование и откладывая переоснащение сети на период массового спроса на услуги мультисервисных сетей АТМ, чем предопределяются еще большие затраты на будущие.

Второй путь соответствует современному технологическому уровню.

Принято разделять инвестиции на экстенсивные и интенсивные. Первый термин относится к инвестициям в такое оборудование, которое лишь расширит существующую систему, не меняя существенно её структуры и оставаясь на том же технологическом уровне, как и в момент принятия решения на построение существующей системы. Второй означает создание систем на принципиально новой основе с более высокой эффективностью использования всех видов ресурсов и подразумевает качественный скачок в развитии.
image1.gif (16289 bytes)

Рисунок 1. Использование полосы пропускания технологиями TDM и ATM

Сети TDM по своему назначению предусматривают использование мультиплексоров для предоставления фиксированной полосы пропускания для независимых услуг. Основным же достоинством технологии ATM является предоставляемая ею возможность объединять различные типы трафика в единый поток с помощью механизма статистического мультиплексирования, позволяющего более эффективно использовать полосу пропускания

К недостатку синхронных методов передачи, таких как TDM, относится то, что они не позволяют смещать блоки данных по времени для заполнения “пустот” в канале. Это приводит к неэффективному использованию полосы пропускания. Любой же статистический мультиплексор способен “по своему усмотрению” буферизовать данные так, чтобы уплотнить трафик разных пользователей в один общий поток (см. рис 2). Это позволяет избежать незаполненных участков и обеспечить максимально эффективное использование каналов.

На рис. 2 показано, как статистический мультиплексор ATM заполняет трафиком полосу пропускания, которая при использовании мультиплексора TDM осталась бы незадействованной. Еще раз подчеркнем, что мультиплексор ATM не резервирует тайм-слоты для входящих потоков. Потоки могут иметь лишь различные уровни приоритета на использование полосы пропускания; эти уровни определяются параметрами качества обслуживания. Отсутствие резервирования тайм-слотов означает, что данные не могут мгновенно вводиться в тракт передачи и вынуждены проводить некоторое время в буферах, ожидая появления свободного “окна”.

image2.gif (20494 bytes)

Рисунок 2. Уплотнение трафика с помощью мультиплексоров АТМ и традиционного TDM

Другое узкое место технологии PDH/TDM – слабые возможности в организации служебных потоков для целей контроля и управления потоком в сети и практически полное отсутствие средств маршрутизации низовых мультиплексированных потоков, что крайне важно для использования в сетях передачи данных. В связи с отсутствием специальных средств маршрутизации, при формировании PDH-фреймов и мультифреймов увеличивается (при мультиплексировании и переключении потоков) возможность ошибки в отслеживании истории текущего переключения, а значит, увеличивается возможность потерять сведения о его истории в целом, что приводит к нарушению схемы маршрутизации всего трафика.

В настоящее время широко используется наложенная телефонная сеть общего пользования на основе телефонных коммутаторов (АТС). Создание публичной сети ATM /Frame Relay требует инсталляции соответствующих коммутаторов поверх первичной сети передачи данных и не решает проблемы межсетевого взаимодействия (internetworking), создавая ряд независимых наложенных сетей со своим управлением и мониторингом.

Установка "промежуточных" систем (раздельных вычислительных и телефонных сетей) в действительности оказываются дороже, чем переход на АТМ. Переход на АТМ не только позволяет сэкономить средства за счет объединения ресурсов магистрального оборудования первичной сети и уменьшения расходов на дальнейшую модификацию, но и приносит непосредственный экономический эффект благодаря возможности предоставлять широкий спектр услуг.

Очевидно, что телефонные сети развиваются в направлении распределенной коммутации с помощью технологии ATM. Об этом же говорит и встречная тенденция развития самих АТС - появление интерфейсов ATM у станций ряда ведущих производителей.

ATM и SDH

Построение региональных ВОЛС на базе оборудования SDH

С начала 90-х годов в странах СНГ (Россия, Украина, Казахстан и др.) развернуты и полномасштабно функционируют десятки крупных сетей SDH. Технология SDH активно продвигается а регионы. На ее основе происходит крупномасштабное переоборудование старой аналоговой сети связи в цифровую взаимоувязанную сеть. С течением времени под влиянием новых требований пользователей (Интернет, создание частных виртуальных сетей, удаленный доступ и т. д.) компании связи, развернувшие в регионе цифровую сеть SDH для транспорта коммутируемых телефонных каналов, осознают необходимость своего участия на данном рынке услуг и получения новых источников доходов. И, таким образом, наметился переход многих региональных операторов связи от предоставления транспорта телефонии к предоставлению полномасштабных (или частичных) сервисных услуг с гарантированным качеством. Именно в этот момент возникает необходимость построения АТМ/FR-сети.

image3.gif (12116 bytes)

Рисунок 3. Тенденции развития интеллектуальных услуг в корпоративных сетях

Сети SDH и ATM обеспечивает работу приложений, чувствительных к времени задержки передачи сигналов. Однако, сеть SDH не может сама коммутировать цифровые голосовые каналы – коммутацию осуществляет АТС и таким образом увеличивается время коммутации, т.к. вызов абонента может проходить через несколько последовательных АТС. Принятие стандартов сети АТМ, позволяющих ей самой коммутировать виртуальный голосовой канал по набранному номеру цифровой сети, в два раза сокращает число интерфейсов подключения на АТС, а значит снижает их стоимость.

В этой связи, сети SDH целесообразно использовать в качестве транспортных сетей для технологии АТМ, которая становится связующим звеном между локальными компьютерными сетями и глобальными транспортными сетями SDH. АТМ-трафик наиболее подходит для транспортирования в средах SDH, учитывая, что виртуальные контейнеры VC-n могут нести в упакованном виде поток АТМ ячеек в качестве полезной нагрузки.

Достаточно гибкая процедура перехода на магистральную сеть АТМ позволяет защитить инвестиции в уже созданных сегментах первичной сети SDH. Такой подход соответствует принципу преемственности, суть которого сводится к тому, что каждый последующий состав оборудования не должен ухудшать характеристик существующей сети.

Построение региональных ВОЛС коммутации ячеек/пакетов ATM/FR

Переход на технологию АТМ на новых оптических участках позволяет исключить дополнительные затраты на создание первичной сети передачи данных SDH с низким уровнем сервисных услуг и наложенных сетей, как “технологических заплат” под дополнительные телекоммуникационные услуги. Важным преимуществом АТМ является мультисервисность и оптимизация использования магистральных каналов за счет динамического выделения пропускной способности различным видам трафика.

Пример, изображенный на рисунке 4, иллюстрирует принципиальное отличие и преимущества интеллектуальной АТМ–сети перед сетью SDH.

image4.gif (24703 bytes)

Рисунок 4. Оптимизация магистральных каналов в сетях ATM/FR для организации высококачественных телефонных соединений

Из представленного примера при расчете трафика только по телефонной сети, становится очевидным, что для соединения одной АТС с 3-мя АТС в других городах по сети SDH требуется, как минимум 3 транковых порта T1/Е1 на исходящей АТС. В то же время, количество каналов 64К в каждом транке может быть меньше максимального, что влечет необоснованную избыточность транковых портов на АТС, трибных интерфейсов на мультиплексорах SDH и излишние затраты на расширение магистральных каналов.

В сети АТМ на оборудовании Cisco Systems этого можно избежать путем установления виртуальных соединений (VC) для требуемого количества телефонных каналов из одного транкового порта между соответствующими АТС. Основным преимуществом коммутируемых виртуальных соединений является освобождение пропускной способности магистрального канала при отсутствии телефонных вызовов. Телефонные каналы транка Е1 одной телефонной станции маршрутизируются в соответствующие транки Е1 других АТС исходя из расчета межстанционных соединительных линий. Разделение канала Т1/Е1 на DS0 выполняет коммутатор АТМ узла, к которому эта станция подключена.

Комитет Voice and Telephony Over ATM (VTOA) Форума АТМ выпустил ряд документов, посвященных способам передачи цифровых потоков, кратных основному цифровому голосовому каналу DS0, в ячейках АТМ (CES - служба эмуляции выделенных каналов) и преобразования систем сигнализации телефонии и протоколов АТМ (IWF - межсетевая функция). В соответствии с рекомендациями Форума АТМ межсетевая функция (IWF) осуществляет преобразование системы сигнализации, принятой на телефонных сетях в протоколы сигнализации АТМ Служба CES позволяет создавать цифровые каналы связи через сеть АТМ между двумя точками, так же, как это делается в сетях SDH, но, в отличие от SDH, полоса пропускания такого канала в АТМ может быть любой, от 8 Кб/с до емкости линии связи. Это делает возможным использование АТМ в качестве транспортной среды для телефонии.

Функция преобразования протоколов сигнализации реализуется в коммутаторе АТМ, подключение АТС к коммутатору АТМ осуществляется цифровыми потоками 2 Мб/с в соответствии с рекомендациями МСЭ-Т G.703/G.704. В этом случае сеть АТМ представляется для других устройств как цифровая АТС с поддержкой всех соответствующих функций. Вследствие этого каждая АТС, подключаемая к АТМ коммутатору через межсетевую функцию, обрабатывает вызовы только тех абонентов, которые подключены к этой АТС, тогда как канал между станциями устанавливается средствами коммутаторов АТМ и проходит только через них, без использования станций как транзитных. Это не только позволяет снизить требования, предъявляемые к производительности АТС и уменьшить количество соединительных цифровых интерфейсов в них, но и повышает надежность всей сети в целом, так как установленные в сети АТМ каналы могут перекоммутироваться автоматически и устанавливаться в зависимости от текущей загрузки линий связи и их состояния. Кроме того, такие каналы существуют только во время установленного соединения и освобождают полосу пропускания после его разрыва, что позволяет снизить требования к полосе пропускания линий связи или использовать свободную емкость для передачи других видов трафика, например, данных.

В случае обрыва магистрального канала перемаршрутизация установленных соединений происходит автоматически по оптимальному маршруту. Архитектура программного обеспечения магистральных коммутаторов Cisco предусматривает сохранение в энергонезависимой памяти каждого АТМ-коммутатора всей топологии сети, что обеспечивает восстановление соединений в реальном времени и вне зависимости от наличия соединения с центральной станцией управления. Такая архитектура является самодостаточной для обеспечения надежности соединений до 99,99% без вмешательства обслуживающего персонала. Отсюда очевидно, что с увеличением сети растет число обходных каналов и увеличивается надежность соединений.

Таким образом, достигается надежное соединение АТС по принципу “каждый с каждым” с поддержкой всех протоколов сигнализации в существующей телефонной сети (SS-7, QSIG, DPNSS, ISDN, CAS, MFP-U1, MFP-U2, MFS, 2ВСК и др.) и экономия транковых портов на АТС. Суммарная задержка при передаче телефонного трафика по такому типу соединений не превышает 0,2 сек., увеличение пропускной способности сети и увеличение точек подключения осуществляется без изменения существующей конфигурации соединений. В сети SDH все выглядит иначе, с ростом сети увеличиваются затраты на обслуживание и уменьшается общая надежность соединений.

Передача голоса по сетям АТМ

Применение фирменной технологии Voice Network Switching (VNS) в сетях Cisco позволяет использовать не только постоянные каналы связи (PVC), но и предоставляет механизмы, позволяющие автоматически устанавливать коммутируемые виртуальные каналы (SVC) между вызывающей телефонной станцией и станцией абонента. Два важнейших примера таких механизмов - это наличие собственной системы адресов устройств АТМ и протоколов сигнализации. В результате, сеть АТМ обладает теми же функциональными возможностями по коммутации каналов, что и цифровые телефонные сети, например ISDN, и может использоваться как часть корпоративной телефонной сети. Использование службы переменной скорости передачи битов (Variable Bit Rate, VBR) - один из основных подходов к передаче голоса по ATM, прорабатываемых Форумом ATM. Его реализации позволяют всю мощь АТМ по эффективному использованию полосы пропускания и управлению трафиком, которая прежде применялась лишь для передачи данных, задействовать и для передачи голоса.

При установлении каждого нового телефонного соединения сеть ATM вычисляет оптимальный в данный момент времени маршрут с учетом топологии сети, доступной полосы пропускания на разных участках, ожидаемых значений задержки и ее вариации, стоимости соединений по различным маршрутам. В результате устанавливается соединение с характеристиками, необходимыми для качественной передачи голоса. По окончании разговора полоса пропускания высвобождается для других приложений. При использовании технологии VNS сеть ATM “ведет себя” по отношению к периферийным АТС как центральный транзитный узел, а значит, структура телефонной сети заметно упрощается. Теперь не нужно соединять АТС между собой множеством линий связи, число которых зависит не только от объема трафика, но и от структуры телефонной сети и требуемого уровня отказоустойчивости (организация дополнительных линий связи для резервирования). Достаточно соединить АТС только с ближайшим пограничным коммутатором ATM, причем число используемых для этого линий связи зависит лишь от объема трафика. Установление соединений между АТС будет осуществляться на основе получаемой от них сигнализации.

В такой ситуации можно уменьшить число цифровых интерфейсов АТС и не устанавливать чисто транзитные АТС, а следовательно, снизить стоимость телефонного оборудования. Кроме того, упрощаются создание и поддержание единого плана нумерации, поскольку отпадает необходимость содержать в базах данных периферийных АТС сведения обо всех абонентах телефонной сети.

Еще один важный аргумент в пользу применения технологии АТМ для передачи голоса - упрощение расширяемости сети. Предположим, необходимо добавить новый узел или модернизировать старый (увеличить число пользователей, расширить спектр предоставляемых услуг). Традиционный подход потребует перепроектирования межстанционных соединений, причем может понадобиться изменение их структуры или замена магистрали на более производительную из-за отсутствия необходимой емкости на каком-либо ее участке.

В сетях ATM, где используется VNS, ситуация значительно упрощается. В них все АТС являются логически смежными узлами, а значит, расширение телефонной сети сводится к соединению АТС с ближайшим пограничным коммутатором и внесению соответствующей записи в сетевую базу данных. Даже отсутствие свободной полосы пропускания на магистрали ATM не является препятствием к расширению сети. В этом случае можно отложить модернизацию магистрали до лучших времен и просто немного увеличить степень сжатия голоса.

Важно отметить следующее: построение сети ATM для передачи голоса позволяет легко организовать передачу данных и видеоинформации, а использование для разных типов трафика единой системы управления облегчает и удешевляет управление сетью.

image5.gif (70634 bytes)

Рисунок 5. Методы голосовой компрессии в соответствии с ITU-T Recommendation

Наличие “интеллекта” в коммутаторах АТМ/FR от Cisco подразумевает программно-аппаратную реализацию алгоритмов компрессии телефонных каналов 32-, 24-Kbps ADPCM (ITU-T G.726, G.723) или 8-Kbps CS-ACELP (ITU-T G.729a) и функцию подавления пауз, что позволяет одновременно организовать до 240 телефонных каналов при 8-Kbps компрессии на одном транковом потоке Е1 и эффективно использовать отведенную полосу пропускания в магистральном канале. Функция подавления пауз VAD (Voice Activity Detection) использует технологию DSP (digital-signal processing) для переключения между состояниями разговор/пауза в телефонном канале, освобождая полосу пропускания телефонного канала во время паузы в телефонном разговоре. Это позволяет оптимизировать (высвобождение до 50% полосы пропускания) пропускную способность магистрального канала даже при выключенной компрессии телефонных каналов.

image6.gif (5418 bytes)

Рисунок 6. Распределение расходов при эксплуатации магистральных сетей

источник: Data Communications

Обеспечение динамического распределения полосы пропускания транкового канала позволяет перераспределять ширину полосы пропускания для каждого типа трафика в зависимости от загрузки и административно определенной политики качества предоставления услуг (Quality of Service). Таким образом, применение описанных механизмов позволяет говорить об оптимизации и увеличении номинальной пропускной способности магистральных каналов в 3-4 раза.

Построение и эксплуатация интеллектуальных сетей ATM/FR позволяет операторам связи увеличивать доходность за счет новых видов телекоммуникационных услуг, предоставляемых мультисервисной сетью и значительно снизить затраты на использование магистральных каналов связи (при владении этими каналами рассматривается себестоимость 1Kbps) и обслуживание сети. В действительности, стоимость магистральных каналов составляет от 80% до 90% стоимости эксплуатации сети. Так же среди этих затрат можно назвать закупочную стоимость оборудования и программного обеспечения, обучение технического персонала, обслуживание сети и уровень технической поддержки производителя оборудования (Рисунок 5).

Несмотря на то, что АТМ-оборудование дороже оборудования для сети SDH, при использовании для построения магистральной сети SDH-коммутаторов резко возрастает стоимость периферийного оборудования – АТС, маршрутизаторов, мультиплексоров доступа и т.д. Поэтому, общую стоимость систем, реализованных на коммутаторах АТМ и SDH, можно считать сравнимой.

Раздел 1. Почему Cisco?

Компания Cisco Systems является мировым лидером в обеспечении сетевого взаимодействия для Internet. Сегодня каждое виртуальное сообщение, отправленное через Internet, проходит через оборудование компании Cisco Systems. Компания прочно занимает позиции лидера на рынке маршрутизаторов (по разным данным от 60 до 80% в секторе рынка), а после присоединения ряда фирм, специализировавшихся на технологиях Cell-Relay (ATM) и LAN Switching, Cisco Systems вышла в лидеры также и по этим направлениям: 70% рынка магистральных коммутаторов Frame Relay принадлежит именно Cisco (источник:Dataquest).

Основы решений Cisco лежат в понимании важности сети потребителя, как стратегического элемента его бизнеса.
Компания выпускает изделия с оптимальным характером взаимодействия всех уровней сетевой модели OSI, предоставляя при этом пользователю не рекламный, а реальный показатель качества сетевого обслуживания.

market.gif (9124 bytes)

Рисунок 7. Распределение поставок портов ATM для локальных и глобальных сетей
(источник Cisco/Dell'Oro Group)

Аналогично тому, как сети прошли развитие от средств для внутренних взаимодействий до стратегических корпоративных решений для поддержки важнейших приложений, происходит и развитие Cisco. Доступ в Internet, ATM, frame relay, или другие сервисы, - для любого из этих направлений Cisco располагает уникальным оборудованием, заставляющим Internet работать.
Решения Cisco направлены на обеспечение высокой надежности и производительности, защиты и возможности управления всей сетью и отличаются законченностью, что называется end-to-end решениями, позволяющими масштабировать размеры сети от локальной до глобальной.
Cisco имеет свою собственную глобальную сеть Intranet, что позволяет персоналу Cisco по всему миру оперативно разрешать вопросы бизнеса и оказывать необходимую помощь потребителям. Линии связи к стратегическим поставщикам и потребителям позволяют Cisco сотрудничать с ними наиболее эффективно. Сеть Intranet компании позволяет также показать обоснованность новых технологий и продуктов Cisco, которые, будучи внедренными в работающую сеть, позволяют гарантировать их готовность к применению у пользователей. Наличие огромного опыта Cisco в области Internet и Intranet является бесценным ресурсом при дизайне, планировании и построении глобальных сетей. Cisco знает, как применять сетевые технологии для того, чтобы сделать бизнес наиболее конкурентноспособным и наиболее прибыльным.

Cisco IOS™

Спектр изделий, предлагаемых Cisco, занимает весь диапазон аппаратных устройств, в той или иной мере являющимися узлами каких-либо сетей, от простейших, по цене менее 1000 долл., до коммутаторов ценой более 100 тыс. долл. Изделия эти работают со всеми разработанными на сегодняшний день протоколами.

iosstar.gif (2460 bytes)

Именно IOS обеспечивает работу всех изделий фирмы Cisco Systems, гарантируя их полную совместимость между собой независимо от класса изделия и назначения.

Сегодня весь спектр оборудования Cisco, от небольших маршрутизаторов для решения локальных проблем до крупных кампусных или магистральных коммутаторов, поддерживается программным обеспечением Cisco IOS™, которое является платформой для доставки сетевых услуг и функционирования таких сетевых приложений, как интегрированные данные/голос/видео, качество обслуживания (QoS), мультимедиа, а также услуг для взаимодействия с IBM.

Cisco Systems - пока единственный в мире поставщик столь широкого спектра оборудования, работающего под управлением единой операционной системы, вследствие чего достигается:

  • во-первых, гарантированно хорошее взаимодействие на всех уровнях;
  • во-вторых, обеспечивается унификация и, следовательно, упрощение администрирования сложных сетей;
  • в-третьих, появляется возможность применения перспективных, но пока не стандартизованных технологий.

Cisco Systems является активным участником организаций, таких, как ATM Forum, IETF, Frame Relay Forum, занимающихся определением стратегии развития сетевых технологий, выработкой и принятием соответствующих стандартов, и уже множество отработанных фирмой решений оформлены в виде документов, описывающих стандарты в таких областях, как протоколы маршрутизации, сетевое управление и т. д. В последнее время фирма все чаще начала представлять на рынок изделия с реализацией новейших технологий, ни в каких других продуктах больше не представленных, таким образом прочно утверждая себя в качестве бесспорного и сильного лидера и становясь законодателем стандартов де-факто.

На сегодняшний день компания Cisco Systems уверена в том, что она имеет лучшие в своей индустрии платформы для обеспечения требований, предъявляемых к сетям Internet/Intranet, - как сегодняшних, так и будущих.

Раздел 2. Решения CISCO SYSTEMS для поставщиков услуг

Сети поставщиков услуг 21 века

Сетевая индустрия ожидает высоко интеллектуальных глобальных сетей для поддержки приложений, основанных на последних достижениях науки и техники. Cisco предлагает форсировать реализацию глобального сетевого взаимодействия, обеспечивая дополнительные доходы как для корпоративных пользователей, так и для поставщиков услуг. Например, при помощи новаторских партнерских программ Cisco связывает сеть предприятия с поставщиком услуг для создания благоприятных возможностей получения новых источников дохода. Приложения, работающие на предприятии, требуют таких новейших сетевых услуг, как видеоконференции и возможность проведения дистанционного обучения, что требует защиты и поддержки качества сервиса (QoS) от общедоступого Internet.

earth.gif (79917 bytes)

Cisco видит будущее глобального сетевого взаимодействия в предоставлении высокоинтеллектуальных сетевых услуг. Как результат, поставщики услуг Internet будут в возрастающем размере играть важнейшую роль в предоставлении дополнительных услуг, кроме предоставления непосредственно доступа в Internet. Для того, чтобы это обеспечить, необходимо обновить имеющиеся возможности общедоступного Internet так, чтобы сделать сопоставимыми услуги, предоставляемые Internet и услуги, возможные в частных Intranet.

Что приводит к изменениям в глобальном сетевом взаимодействии?

Консолидация индустрии

Сокращение вмешательства государства в экономику стимулировало изменения в индустрии глобального сетевого взаимодействия. Следствием этого явилась консолидация индустрии. Все новые и новые участники каждый день предлагают новые и новые услуги, таким образом разгорается глобальная конкуренция. Для успешного конкурирования поставщики услуг стремяться уменьшить стоимость, одновременно добавляя новые источники дополнительных доходов.

Упавшие цены на персональные компьютеры и цифровые процессоры дали финансовую возможность реализовать новые интерактивные, чувствительные к ширине полосы пропускания LAN приложения и довести их до рабочего места конечного пользователя.

Конвергенция технологий

По мере консолидации индустрии, различные технологии тоже сходятся, комбинируя множественные сервисы в общую инфраструктуру. Одной из крупнейших проблем является интеграция услуг для передачи данных и услуг для передачи голоса по единой сетевой инфраструктуре. Телекоммуникационные поставщики, которые объединяют технологии, могут в значительной степени сократить стоимость их функционирования. Подобно этому, поставщики услуг Internet могут получить дополнительный доход, предоставляя услуги передачи голоса поверх сетей передачи данных. Более того, развитие Internet показывает, как будут выглядеть глобальные сети завтра. Для коммерческой деятельности требуется функционирование приложений по всему миру; следовательно, глобальные сети должны быть достаточно интеллектуальными для того, чтобы поддерживать тот уровень обслуживания, который сейчас удовлетворяет коммерческие требования в частных сетях. Поставщики услуг владеют общедоступными сетями и предприятия ждут от них обеспечения консолидированных, глобальных IP сетей, которые будут поддерживать новейшие услуги между любыми конечными точками в сети по всему миру.

Интеллектуальные IP сети будущего

Internet развивается, высвобождая части сетей в связующую общедоступную инфраструктуру IP. World Wide Web становится удобным средством для доступа к содержимому и доставки информации. Новый Internet будет хорошо управляемой, высокоинтеллектуальной платформой, которой на сегодняшний день нет. Из доступных интеллектуальных услуг Заказчик сможет выбирать нужные для своего бизнеса с целью увеличения дохода и долговременного успеха. Cisco Systems уверена в том, что поставщики телекоммуникационных услуг и поставщики услуг Internet в будущем будут предоставлять не только сетевой транспорт - они будут коммуникационными партнерами для предприятий.

ipplatf.gif (8878 bytes)

В 1998 году во всемирной паутине World Wide Web ожидается свыше 100 миллионов пользователей. К 2000 году доход от рынка Internet составит $92 миллиарда.

Переход к рынку со специализированными услугами сулит благоприятные возможности для получения огромных доходов. В прошлом, поставщики телекоммуникационных услуг получали новый источник доходов, добавляя к общедоступной коммутируемой телефонной сети (PSTN) интеллектуальные услуги для голоса, такие, как ожидание звонка, организация голосовых конференций, перенаправление звонка. Аналогично, добавление интеллектуальных услуг к хорошо управляемому в будущем Internet, позволит поставщикам услуг предлагать новые услуги и охватывать новые рынки. Для достижения этой цели поставщики услуг должны добавить интеллект в сеть и интегрировать услуги для устранения путаницы в помещении потребителя. Потребитель должен получить возможность удовлетворения всех своих требований к сети в одном месте.

Мультисервисные решения

Cisco интегрирует голос и данные "сквозь" сетевую архитектуру с организацией взаимодействия IP и ATM. Для совмещения технологий IP и ATM на основе Cisco IOS™ созданы интегрированные устройства, снабженные стандартными средствами администрирования. Такие решения обеспечивают сходимость инфраструктур от сетевых пограничных устройств через ядро сети или магистраль, а также позволяют существенно снизить затраты на построение коммуникационных систем благодаря возможности комбинировать разнородные сервисы в единых высокоскоростных сетях.

  • Объединение локальных вычислительных сетей

Коммутация и маршрутизация трафика данных через магистраль провайдера
  • Сервис голосовых сообщений

Коммутация голосовых каналов и объединение телефонных станций

  • Видеоконференц-связь

Организация видеоконференций с гарантированным качеством изображения
  • Подключение и объединение сетей с унаследованной архитектурой

Сети IBM SNA, сети пакетной коммутации X.25, асинхронные каналы данных
  • TDM-миграция

Предоставление транспортной среды для мультиплексоров с временным разделением

image8.gif (79896 bytes)

Рисунок 8. Интеграция услуг в широкополосных цифровых сетях Cisco Systems

Сегодня большинство предприятий-потребителей строит свои собственные сети и основной услугой для них являются выделенные линии. Многие потребители приобретают услуги по мере поступления надобности в каждой из них и при минимальном инвестировании. Также они желают получить новые приложения, использующие услуги для коммерческой, издательской деятельности, а также в области развлечений. Если поставщики услуг смогут обеспечить и коммуникации и вычислительную инфраструктуру для предприятий и, особенно, для предприятий малого и среднего бизнеса, их внутриведомственные потребности могут быть значительно сокращены или даже полностью исключены. Положение поставщика транспорта является рискованным, потому что выиграть могут только некоторые из таких поставщиков. Таким образом, наличие платформы интеллектуальных услуг обеспечивает благоприятные возможности для получения прибыли, так как потребители воспринимают эти услуги как весьма значимые.

Cisco предлагает сотрудничество с поставщиками услуг для построения сетей, основанных на коммутации пакетов и ячеек с выходом к существующим инфраструктурам PSTN.

Раздел 3. Решения CISCO SYSTEMS для сети с интеграцией услуг

Общая структура сети

Являясь основой для предоставления интеллектуальных сетевых услуг, сетевая архитектура должна поддерживать взаимодействие для всех унаследованных сетей, основанных на коммутации пакетов, ячеек или кадров, распространяя применение элементов услуг на пограничных устройствах через высокоскоростное магистральное ядро. Расширение спектра предоставляемых объединениями Электросвязей услуг на основе мультисервисной сети передачи данных с сохранением существующей телефонной услуги в качестве базовой и приоритетной на сегодняшний день представляет собой главную задачу, комплексное решение которой предлагается полным спектром оборудования Cisco Systems от оконечных пользовательских устройств до магистральных коммутаторов.

Cisco предлагает законченную (end-to-end) архитектуру, позволяя поставщику услуг предоставлять интеллектуальные услуги. Для мультисервисной сети подобные услуги должны обеспечить:

  • Оптимальное использование существующих транспортных (SDH) и коммутационных телефонных систем сети общего пользования (ТфОП) и прозрачность для различных протоколов телефонной сигнализации ОП SS-7, CCS, CAS, MFP-U1, MFP-U2, MFS, 2ВСК и др;
  • Передачу трафика данных и трафика телефонной сети общего пользования (ТфОП) с суммарной задержкой при передаче телефонного трафика не более 0,2 сек.;
  • Возможность предоставления всем категориям пользователей гарантированного качества обслуживания (QoS) в части предоставления голосового сервиса, мультимедиа и сервиса типа video-on-demand (видео по заказу);
  • Предоставление конечным абонентам сети (домашним пользователям) и корпоративным клиентам высокоскоростного доступа к ресурсам частных информационных сетей и ресурсам Internet с обеспечением сохранения телефонной услуги на абонентской линии;
  • Возможность создания на основе сети поставщика услуг (оператора связи) виртуальных корпоративных частных сетей с предоставлением полного спектра услуг по объединению разнородных сетевых систем.

Основные характеристики широкополосной АТМ-сети

  • Масштабируемость. Подразумевает возможность наращивания пропускной способности сети и количества подключений конечных абонентов сети без внесения существенных изменений в логическую структуру сетевой системы и с наименьшими затратами на дополнительное сетевое оборудование;
  • Мультисервисность. Эта характеристика сети означает, что создаваемая сеть имеет полный набор услуг доступа к информационным ресурсам, включая передачу цифрового и голосового трафика, данных мультимедиа (видеотрансляции и видеоконференции), а также поддержку всех применяемых сетевых протоколов передачи данных;
  • Отказоустойчивость. Отказоустойчивость сети обеспечивается за счет резервирования основных узлов и блоков активного сетевого оборудования, создания резервных линий связи и применения современных протоколов управления потоками данных.
  • Перспективность. Имеется в виду наличие стратегических перспектив использования и наращивания сети за счет предоставления абонентам телефонных сетей услуг доступа к сетям передачи данных через имеющиеся каналы и линии связи;
  • Преемственность (сохранение инвестиций). Предоставление дополнительных услуг абонентам сети не должно повлечь за собой существенных изменений в составе имеющегося телефонного оборудования и линий связи, а также не должно сказываться на качестве телефонных услуг.

Для того, чтобы оптимизировать доходные (услуги) и расходные (содержание сети) части Cisco в своих решениях построения крупных распределенных сетей рекомендует многоуровневую логическую модель, включающую два основных уровня: пограничная сеть и ядро.

Пограничная сеть используется для предоставления приносящих доход услуг. Ядро используется для оптимизации расходов, для чего применяются эффективные транспорт и ширина полосы пропускания для генерируемого пограничными сетями трафика. В общей форме можно сказать, что "Пограничная сеть" - это максимизация доходов, а "Ядро" - это минимизация затрат. И это важно для понимания важного различия между функциями двух платформ - пограничных сетей и ядра.

В последующих разделах описывается роль, которую играют обе платформы в территориально распределенных сетях, указаны факторы, которые влияют на обе платформы, а также представлено видение компанией Cisco Systems требований к пограничным сетям и ядру следующего поколения. И наконец, обсуждаются обе платформы, предлагаемые компанией Cisco, с указанием деталей, специфичных для оборудования.

  • уровень ядра сети (Core Drive);
  • уровень распределения или пограничная сеть (Edge Drive).

image9.gif (20281 bytes)

Рисунок 9. Пограничная сеть обеспечивает доступ и предоставляет услуги потребителям.

Ядро оптимизирует транспорт для трафика, производимого пограничными сетями.

Уровень ядра сети

Роль ядра сети: обслуживание пограничной сети

Ядро прежде всего отвечает за консолидацию потоков низкоскоростного трафика, поступающего от пограничных устройств в высокоскоростные транки, упрощая сетевую топологию и достигая эффективного использования полосы пропускания через транспортную инфраструктуру.

image10.gif (4945 bytes)

Рисунок 10. Пограничная сеть обслуживает потребителя, ядро обслуживает пограничную сеть.

Узлы ядра должны транспортировать большое количество трафика и обеспечить очень высокую коммутационную емкость. Работоспособность и постоянная доступность ядра также является ключевым моментом, так как должна быть гарантия того, что в случае сбоя в ядре качество обслуживания не пострадает. И наконец, так как конечный пользователь не напрямую подсоединяется к платформе ядра, здесь отсутствует необходимость в применении разнообразных интерфейсов, как в случае пограничного коммутатора. Следовательно, сетевые элементы ядра нуждаются только в высокоскоростных интерфейсах для агрегирования трафика от пограничных сетей (обычно это OC-3/STM-1 и выше) и еще более скоростных транковых интерфесах (OC-12/STM-4 и выше).

Магистральные сети должны использовать преимущества скоростных оптических технологий и стать функционально прозрачными для доставленных услуг пограничных сетей. Магистральные сети предназначена для обслуживания пограничных сетей. Ключевая функция ядра состоит в предоставлении высокоскоростного, высокоплотного транспорта для трафика. Для удовлетворения требований к полосе пропускания в ядре сети предлагается использовать устройства SDH/Synchronous Optical Network (SONET) а, в будущем, оборудование dens wave-division multiplexing (DWDM) – спектральное мультиплексирование по длине волны. Учитывая влияние нескольких планов управления, Cisco готова предоставить "бесшовное" взаимодействие между ними через технологию открытых интерфесов, позволяя Asynchronous Transfer Mode (ATM) получать информацию от различных планов управления (например, Signaling System 7 [SS7], Private Network-to-Network Interface [PNNI], или Multi-Protocol Label Switching [MPLS]).

Ядро сети должно обеспечивать гибкий транспорт для более, чем одной пограничной сети. В свою очередь эти пограничные сети могут включать сетевые элементы от более, чем одного поставщика услуг, Заказчиков или индивидуальных пользователей.

Таким образом:

  • Ядро сети должно предоставить экономически эффективный транспорт для IP и ATM трафика; следовательно должно поддерживать основанные на стандартах, гибкие протоколы маршрутизации.
  • Ядро сети должно иметь возможность наращивания емкости, полностью прозрачного для пограничных сетей - другими словами, ядро никогда не должно быть источником риска для качества услуги.
  • Ядро сети должно быть готово к принятию оптических технологий.

Категорическим требованием, которое Cisco неуклонно выполняет, является основанное на стандартах ядро, что позволяет поддерживать гетерогенные пограничные сети.

image11a.gif (14486 bytes)

Рисунок 11. Пример построения ядра магистральной сети

Оборудование и технологии для построения магистральной сети

Технология Tag Switching - является реализацией компании Cisco стандарта Multiprotocol Label Switching (MPLS, многопротокольная маршрутизация с использованием меток), разрабатываемого группой IETF (Internet Engineering Task Force), который уже поддерживается рядом производителей оборудования для глобальных сетей.

Сегодня, в условиях повсеместного распространения протокола IP, все чаще возникает проблема передачи IP-пакетов по сетям других типов. Она оказывается особенно актуальной, когда в качестве базовой транспортной инфраструктуры используются магистрали ATM: бурное развитие технологии асинхронной передачи привело к выпуску разнообразного серийного оборудования и к появлению множества реально работающих сетей на ее основе. Интеграция этих двух технологий позволила бы объединить такие достоинства сетей ATM, как поддержка требуемых уровней информационной защиты и возможность задания гарантированного качества сервиса (QoS), с универсальными возможностями связи, демонстрируемыми средой IP. В результате провайдеры могли бы комбинировать предоставление услуг IP и услуг ATM в одной сетевой среде, разделяя между ними полосу пропускания в динамическом режиме. В целях достижения подобной интеграции к настоящему времени предложено несколько решений: так, в рамках консорциума ATM Forum была разработана специальная технология IP over ATM, а позднее - в июле 1997 г.- принята спецификация MultiProtocol over ATM (MPOA), Cisco Systems предложила метод коммутации с использованием тегов Tag Switching, который в итоге лег в основу технологии MPLS.

MPLS предусматривает использование специальных "меток" в пакетах данных, позволяющих создавать выделенные высокоскоростные коммутируемые потоки информации. В данном случае (в отличие от современных маршрутизируемых инфраструктур Internet) это достигается за счет недопустимости прохождения многочисленных сетевых узлов. Выполнение спецификаций MPLS упрощает создание виртуальных частных сетей (VPN), передачу голоса и видео средствами IP, позволяет более эффективно управлять "сквозным" качеством сервиса.
tgx.gif (5418 bytes)

Cisco TGX™ 8750 - платформа Cisco для ядра IP+ATM, оптический коммутатор TGX 8750 поддерживает технологию Tag Switching, иерархический интерфейс связи между частными сетями (IPNNI), автоматическую защищенную коммутацию с защитой данных (Automatic Protection Switching) в среде SONET/SDH, работу в сетевой среде DS3/E3, OC-3/STM-1, OC-12/STM-4, OC-48c/STM-16 (2,4 Гбит/с). TGX 8750 может обслуживать разнообразные пограничные сети, включая коммутацию ATM/Frame Relay, маршрутизацию IP или сети xDSL.
В качестве лидера в области платформ для ядра с иерархическим PNNI и MPLS /TagSwitching, TGX 8750 поддерживает сети

больших масштабов и предоставляет транспорт с минимальной стоимостью передачи на один бит.
Ядро сети ATM с коммутаторами TGX 8750, построенной на базе интерфейса IPNNI, можно расширить до нескольких тысяч узлов, поддерживающих коммутируемые (SVC) и программируемые постоянные (PVC) виртуальные каналы, а также виртуальные каналы, связывающие один узел с несколькими. Чтобы полностью контролировать приоритеты при передаче голосового трафика и данных, коммутатор применяет алгоритм организации очередей по виртуальным каналам, а средства контроля доступной скорости передачи (ABR), основанные на ее явном указании, позволяют в полном объеме использовать сетевые ресурсы при минимальном ухудшении характеристик сервиса.

Коммутатор усилен рядом средств, повышающих устойчивость его работы. Помимо поддержки надежных масштабируемых протоколов маршрутизации (PNNI, OSPF, IS-IS), сюда относятся наличие задублированных коммутационных матриц, процессорных плат, источников питания и интерфейсных карт, допускающих горячую замену. Поддержка резервных интерфейсных карт для портов OC-3c, OC-12c, OC-48 и OC-48c обеспечивается средствами автоматической коммутации с защитой данных (SONET 1+1 Automatic Protection Switching), гарантирующими быстрое восстановление работоспособности сетевых служб.

Cisco 12000 Series Gigabit Switch Router – семейство гигабитных маршрутизирующих АТМ-коммутаторов, ориентированных на использование в магистральных сетях провайдеров SDH/SONET, имеющих масштабируемую коммутирующую матрицу 5-60Гбит. Устройство предоставляет возможность организации высокоскоростной транспортной оптической среды на скоростях OC-3/SMT-1, OC-12/STM-4, OC-48/STM-16 с предоставлением гарантированного качества обслуживания – Quality of Service (QOS).

gsr12k.gif (32929 bytes)

Модульные маршрутизаторы Cisco 7500 – представляют универсальную высокопроизводительную серию устройств фирмы Cisco Systems. Они удовлетворяют самым высоким требованиям, предъявляемым к современным сетям передачи данных. Модульная архитектура Cisco 7500 позволяет создавать оптимальные решения для конкретных проектов.

c7500.gif (5455 bytes)

Серия Cisco 7500 состоит из трех моделей: Cisco 7505, Cisco 7507 и Cisco 7513. Cisco 7505 имеет пять слотов: один для Route/Switch-процессора (RSP) и четыре слота для интерфейсных адаптеров, один блок питания и общую пропускную способность 1 Гбит/с.

Cisco 7507 имеет 7 слотов, a Cisco 7513 - 13 слотов (2 для RSP и 5 или 11 слотов соответственно для интерфейсных адаптеров). Модели Cisco 7507 и Cisco 7513 обеспечивают пропускную способность более 2 Гбит/с и могут быть укомплектованы двумя RSP и двумя входами питания.

Cisco StrataCom BPX 8600 Service Node - Устройство BPX Service Node представляет собой мощный транспортный коммутатор ATM, объединяющий в себе функции высокоскоростной коммутации трафика ATM и функции интеграции разнородного трафика для передачи его по магистралям ATM. Архитектура коммутатора состоит из двух основных компонентов:

  • Высокоскоростной шины BPX, обеспечивающей работу магистральных интерфейсных модулей со скоростями передачи до 622 Мбит/с.
  • Низкоскоростной шины MGX-8220, поддерживающей интерфейсные модули, занимающиеся интеграцией трафиков голосовой связи, видео, Frame Relay, низкоскоростных сетей ATM, LAN, X.25, SNA.

Коммутатор предназначен для создания высокопроизводительных территориально распределенных магистральных сетей ATM масштаба города, области, государства.

Одним из основных достоинств коммутаторов BPX Service Node является способность динамического использования каналов. Между абонентами системы создаются виртуальные соединения типа “точка-точка”. При отсутствии трафика между конечными точками системы ресурсы канала динамически освобождаются и передаются другим виртуальным соединениям. Эта функция коммутаторов позволяет наиболее полно использовать пропускную способность магистралей.

Коммутатор BPX Service Node обладает общей производительностью 20 Гбит/с и обеспечивает одновременное функционирование в одном шасси до 20 высокоскоростных портов с пропускной способностью 622 Мбит/с и до 80 портов с пропускной способностью 155 Мбит/с. Для менее мощных приложений BPX может работать на каналах E3, поддерживает работу с портами Frame Relay и прозрачную передачу потоков E1. BPX обеспечивает все виды сервиса ATM: CBR, rt-VBR, nrt-VBR, ABR, UBR, а также 2 типа сервиса Network Interworking.

BPX Service Node предоставляет производительность в 800/1600 Мбит/с для каждого из 12 имеющихся разъемов расширения (слотов), позволяя таким образом увеличивать емкость узла при сохранении наивысшей производительности. Низкоскоростные интерфейсы располагаются в отдельном шасси, что обеспечивает наиболее полное использование возможностей BPX Service Node, и не оказывает сколько-нибудь существенного влияния на высокоскоростные магистральные интерфейсы.

BPX Service Node предоставляет следующий набор сетевых сервисов:

  • Internet/intranet

BPX Service Node объединяет трафики Интернет и интрасетей, поддерживает полный набор функций доступа и масштабирует предоставление пользовательских услуг, что позволяет обеспечивать от сотен до тысяч абонентских подключений на одном узле. Расширенные функции управления трафиком предоставляют возможность наиболее эффективно использовать пропускную способность соединений без риска потери пакетов в этих соединениях.

  • ATM

BPX Service Node поддерживает широкий набор интерфейсов передачи данных, включая ATM, Frame Relay, SMDS, LAN, SNA, X.25 и видео высокого разрешения.

  • Switched interworking (объединение коммутируемых сетей)

BPX Service Node – надежная платформа для создания прозрачных высокоскоростных соединений типа "LAN-to-LAN" для топологий Ethernet, Fast Ethernet, Token Ring и FDDI. Трафик передается по частной или глобальной ATM-магистрали.

  • Frame Relay

BPX Service Node предоставляет возможность прозрачной миграции от сетей Frame Relay к сетям ATM и высокоскоростные магистрали с полным набором сервисов для объединения сетей.

  • Voice (передача голоса)

BPX Service Node обеспечивает расширенные функции управления трафиком и классы сервисов (class-of-service, CoS), гарантирующие необходимые условия для работы голосовых приложений реального времени.

  • Video

BPX Service Node обеспечивает необходимое качество сервиса (quality-of-service, QoS) для передачи видеоинформации через линии ATM, включая такие приложения, как "видео по требованию" (video-on-demand), видеоконференции и видеотелефонию.

  • Wireless (беспроводная связь)

Коммутаторы поддерживают функции передачи аналоговой и цифровой беспроводной связи, передачу данных по беспроводным каналам, а также расширенные функции передачи мобильной радиосвязи (enhanced specialized mobile radio, ESMR) в одном шасси BPX Service Node.

В основе BPX Service Node лежит использование технологии Stratm, базирующейся на специализированных наборах микросхем (application-specific integrated circuits, ASIC). Технология Stratm включена в высокоскоростные коммутирующие модули (broadband switch modules, BXM). Функции включают в себя управление трафиком, очередность каждого виртуального соединения (per-virtual-circuit queuing), управление классами сервисов (class of service, COS), поддержку SVC и многоадресной рассылки на каждой карте BXM.

Технология Stratm предоставляет дополнительные функции коммутации ATM для всех коммутирующих модулей, обеспечивает высокую плотность портов и поддерживает сотни тысяч подключений.

Технология Stratm в коммутаторах BPX Service Node расширяет функции обработки SVC, обеспечивая обработку до 4000 вызовов в секунду и 384 000 активных соединений на один узел. Технология Stratm обеспечивает самые низкие в отрасли затраты на обслуживание каждого конечного пользователя и поддерживает наивысшую плотность портов и соединений на каждый слот. BPX с технологией Stratm полностью соответствует определению virtual source/virtual destination (VS/VD) документа ATM Forum Traffic Management Specification Version 4.0.

Уровень распределения сети

Роль пограничной сети: обслуживание потребителя

Пограничная сеть (или сети) ответственна за доставку и обработку услуг от оборудования доступа. Пограничные устройства (Edge Device) существует для обслуживания потребителей и предоставляют необходимые интерфейсы для подключения оборудования уровня доступа. Ключевые функции пограничной сети включают создание и доставку услуг на различных физических интерфейсах, а также обеспечение качества обслуживания и установление различий. Например, при использовании пограничных сетей появляется возможность выбора для предоставления услуг Frame Relay, миграции SNA, виртуальных частных сетей IP, управляемой услуги голос/данные, и т.д. При помощи пограничных сетей можно обеспечить эмуляцию каналов для большой ширины полосы пропускания, тем самым обеспечив замену частных линий связи. Пограничная сеть является тем местом, где создание и дифференциация имеют наибольшее воздействие и где гибкость коммутаторов наиболее критична. Доставка ресурсов Internet, масштабирование intranet, управление данными, голосом и услуги видео для потребителя - все это происходит на пограничных узлах сети и "бесшовным" образом связывается с сетевым окружением в целом.

Для удовлетворения требований бизнеса роли пограничных и магистральных сетей WAN должны эволюционировать и в нынешних условиях четкие грани различий между устройствами Carrier-Class и Edge постепенно исчезают. Первоначальная обработка услуг, чувствительных к скорости обработки и ширине полосы пропускания на пограничных устройствах позволяет освободить магистральное ядро для выполнения функций оптимизированного, высокоскоростного транспорта.

Проведенный аналитиками Сisco анализ данных из независимых источников показал, что поставщики услуг тратят в 7-10 раз больше средств на пограничные сети, чем на ядро сети.

image12.gif (21582 bytes)

Рисунок 12. Пример построения пограничной сети

Оборудование для построения пограничной сети

bpx.gif (11354 bytes)

Универсальные пограничные платформы Cisco - BPX® 8680 и MGXTM 8800 - пограничные WAN коммутаторы, обеспечивающие как предоставление услуг, так и масштабирование и ориентированные на поддержку IP-услуг нового поколения на основе методики Tag Switching. Cisco BPX 8600 IP+ATM Wide-Area Edge Switch – серия динамических коммутаторов трафика IP в сетях ATM с 20Гбит неблокируемой коммутирующей матрицей, предназначенных для базовых сетей провайдеров сетевых услуг, использующий технологию Tag Switching.Функции интеллектуального управления качества обслуживания (QoS), гарантирующие для пользователя запрашиваемый класс сервиса (CoS – всего до 16 классов), поддержка протоколов групповой рассылки (IP Multicast) предоставляет пользователям услуги организации многоточечных видеоконференций, видеотелефонии, видео по заказу.

Cisco MGX 8800 Series Wide-Area Edge Switch -граничный коммутатор MGX 8800 обеспечивает доступ к глобальным сетям средствами VPN, extranet, Frame Relay, а также других типов сервисов, включая IBM SNA. Он способен поддерживать широкий набор узкополосных и широкополосных интерфейсов и обеспечивает диапазон скоростей от DS0 до OC-48c/STM-16 при пропускной способности коммутационной матрицы 45 Гбит/с. Используя коммутатор MGX 8800, провайдеры смогут предложить своим клиентам богатый ассортимент сервисов глобальной сети, включая виртуальные частные сети, IP-телефонию, ретрансляцию кадров, экстра- и интрасети, управляемые службы передачи голоса и данных, передачу трафика SNA по другим сетям и поддержку смешанного трафика (данные/голос/видео).

mgx.gif (6485 bytes)
MGX 8800 и BPX 8680 включают программное обеспечение Cisco IOS®, гарантирующее богатейшую реализацию возможностей IP.
igx.gif (18101 bytes)

Cisco StrataCom IGX – самый распространенный в опорных сетях операторов связи масштабируемый ATM/FR-коммутатор применяется в качестве пограничного устройства при построении территориально распределенных ATM/FR-магистралей. Устройство доступно в 3 моделях: 8-, 16- и 32-слотовые версии. Семейство продуктов IGX интегрируются с другими продуктами фирмы Cisco Systems семейства StrataCom, общее управление которыми осуществляется при помощи программного обеспечения сетевого управления StrataSphere.

Устройства серии IGX поддерживают широкий набор низкоскоростных и высокоскоростных приложений, свойственных как корпоративным частным сетям, так и сетям поставщиков услуг. В условиях сети с неоднородным трафиком серия продуктов IGX позволяет быстро и эффективно добавлять в систему поддержку новых сетевых сервисов и увеличивать плотность портов системы по мере необходимости. Например, в результате развития передающих технологий требуется все большая пропускная способность коммутирующих устройств. Серия продуктов IGX предоставляет возможность быстрого наращивания коммуникационных узлов и миграции на новые, высокоскоростные технологии передачи данных. Продукты IGX и BPX Service Node предоставляют Заказчикам многие сходные возможности и расширенные сетевые функции, включая следующие:

  • Классы сервисных функций OptiClass;
  • Система управления трафиком и избежания перегрузок ForeSight;
  • Система очередности виртуальных соединений (per-virtual-circuit queuing) и распределения нагрузки FairShare;
  • Система управления соединениями AutoRoute;
  • E - LMI 1;
  • FR - ATM service internetworking.

Продукты IGX позволяют производить миграцию с низкоскоростных технологий передачи на высокоскоростные технологии ATM за счет наличия поддержки низкоскоростных интерфейсов.

Стандартные функции

Аппаратное и программное обеспечение коммутатора разработано с учетом требований по максимальной досягаемости портов устройства. Все модели устройств объединяют следующие конструкторские решения:

  • 100% избыточность компонентов устройства;
  • Обширная фоновая диагностика;
  • Возможность "горячей" замены модулей;
  • Ускоренное обнаружение сбоев питания;
  • Обновление программного кода в фоновом режиме;
  • Обновление программного кода с удаленной консоли управления;
  • Сертификация компонентов по спецификации Class B EMI;
  • Аппаратная и программная индикация неисправностей, функция автонабора телефонного номера (требуется дополнительный модем);
  • Минимальное количество кабелей внутри системы (монтажного шкафа).

Благодаря широкому спектру интерфейсных и управляющих модулей коммутаторы IGX обеспечивают передачу через сети ATM следующих типов трафика:

  • Собственно данные. Показатели скорости передачи варьируются от 1200 бит/с до 2.048 Мбит/с (для асинхронных соединений от 1.2 Кбит/с до 19.2 Кбит/с). Используемые интерфейсы: EIA/TIA-232, V.35, X.21, T1/E1. Коммутаторы IGX поддерживают оба типа соединений – dedicated port и channelized circuit emulation.
  • Передача голосовых сообщений. Канальные (Channelized voice module, CVM) и универсальные (universal voice module, UVM) для коммутаторов серии IGX поддерживают интерфейсы E1/T1. Функция определения активности голосового канала, обеспечивающая подавление пауз, также реализована на этих интерфейсах. Функция коммутации звонков является дополнительной. CVM обеспечивают ADPCM-сжатие 32K, 24K и 16K. UVM обеспечивают сжатие ADPCM 32K, 24K, LD-CELP-сжатие 16K и CS-ACELP-сжатие 8К.
  • Поддержка передачи факсимильных сообщений и модемной связи между абонентами узлов. Сервисные голосовые функции IGX обеспечивают прозрачную передачу факсимильных сообщений и организацию модемной связи между абонентами. Это достигается за счет отключения сжатия голосовых данных.
  • Передача видео трафика позволяет организовывать на основе коммутаторов IGX систему видеоконференций между абонентами узлов.
  • Коммутация сетей Frame Relay и ATM.

Шины коммутации устройства расположены таким образом, что все управляющие модули располагаются на передней панели устройства, а все интерфейсные модули – на задней панели коммутатора. Это позволяет производить большую часть работ по обслуживанию коммутатора без отключения интерфейсных кабелей.

Помимо представленного оборудования для построения пограничных сетей Cisco располагает широким спектром устройств с интерфейсами, необходимыми для подключения к широкополосной сети услуг операторов связи сетей X.25/ISDN/FR/SNA.

Таким образом, пограничная сеть от Cisco обеспечит следующие преимущества:

  • гибкость обслуживания потребителя;
  • увеличение дохода без увеличения капиталовложений (возврат инвестиций) при использовании одной пограничной сети для предоставления нескольких услуг;
  • улучшение времени выхода новой услуги на рынок и доведения ее до потребителя;
  • надежная реализация IP для обеспечения лучшей поддержки будущих высокоприбыльных услуг;
  • доступность высокоскоростных оптических интерфейсов OC-48c/STM-16.

Пример построения широкополосной мультисервисной цифровой сети передачи данных, реализованной на базе оборудования и решений Cisco, приводится на
Рисунке 13.

image13.gif (26816 bytes)

Рисунок 13. АТМ-сеть с интеграцией услуг от Cisco Systems

Управление АТМ-сетями CISCO

Cisco понимает, что представление Internet как платформы для интеллектуальных услуг безоговорочно требует лучших в своем классе инструментов управления для обеспечения, учета и управления новыми услугами. Cisco разрабатывает всеобъемлющие решения для управления всей сетью по единой законченной схеме. В этой области Cisco взаимодействует с Microsoft при разработке Active Directory. Cisco переносит эти разработки на UNIX, обеспечивая тем самым универсальную среду для управления, сбора информации об инфраструктурах и услугах, а также управление на уровне обслуживания через Cisco интерфейсы прикладного программирования (API). Cisco планирует выпустить комплект для разработки программного обеспечения для специфического окружения.

Как отмечалось раннее все продукты Cisco работают под управлением операционной системы Cisco IOS. Кроме того, они снабжены специальными средствами администрирования сетевых служб. Возможности Cisco IOS позволяют реализовать в ATM-сети оператора поддержку качества сервиса IP, масштабируемость, функции защиты данных и администрирования, не прибегая для этого к помощи специфических протоколов.

Провайдеру, развертывающему решения IP+ATM от Cisco, гарантируется полное взаимодействие с сетями корпоративных клиентов, уже использующих ПО Cisco IOS. Предлагаемый пакет средств администрирования Cisco Service Management поможет проводить планирование работы служб IP+ATM, управлять их функционированием и осуществлять тарификацию услуг. Все возможности PNNI и Tag Switching отныне интегрированы в программное обеспечение Cisco IOS. Распространяя действие функционального диапазона своей ОС как на ядро, так и на периферию коммуникационной среды, Cisco предлагает своим клиентам сквозную поддержку приложений по всей сети.

Подробное описание состава и функциональностей программного обеспечения Cisco для управления мультисервисными WAN-сетями не входит в состав данного материала.

Уровень доступа сети

Назначение

Уровень доступа сети предназначен для обеспечения конечных подключений абонентов и пользователей сети поставщика услуг. Этот уровень состоит из оборудования, образующего конечные порты отдельных пользователей, порты оборудования, установленного в помещении корпоративных Заказчиков и линий связи, обеспечивающих подключение конечного пользовательского оборудования к этим портам.

Линии связи представляют собой медные пары, проведенные от АТС в жилые дома и учреждения для подключения оконечного оборудования.

Модель взаимодействия end-to-end

Как отмечалось в Разделе “концепции CISCO…”, данная модель сетевого взаимодействия является парадигмой деятельности Cisco Systems и охватывает все решения, которые предлагаются Cisco.

В этой главе дается описание двух сетевых технологий доступа: Dial-Up - самый распространенный вид доступа по коммутируемой линии и ADSL – технология высокоскоростного доступа по существующим медным парам “последней мили”, привлекающая на свою сторону все больше сторонников среди пользователей и поставщиков услуг.

Технологии и их применение

Рассуждения о том, какой технологии удаленного доступа суждено развиваться, а какой - нет, должны быть основаны на понимании необходимости их сосуществования. Технологии, подобные аналоговому dial-up, Frame Relay, и ISDN прекрасно сосуществуют на рынке, основанном на различных требованиях к видам услуг и на их способности обеспечивать доход, обслуживая различные бизнес - приложения. Факторами, которые будут определять успех технологии, являются надежность, стоимость внедрения, простота установки и использования, а также соответствие требованиям приложений пользователя. Ниже приведены краткие описания конкурирующих технологий.

Tаблица 1. Технологии доступа и их применение
Технология | Скорость | Дистанция (24AWG провод) | Приложения
Аналоговые модемы 56 Kbps | 56 Kbps (downstream) 28.8 или 33.6 Kbps (upstream) | Не ограничивается | Электронная почта, удаленный доступ к LAN и сетям Internet/intranet
ISDN | До 128 Kbps (без сжатия) Полный дуплекс | 6 км (для увеличения требуется дополнительное оборудование) | Удаленный доступ к сетям Internet/intranet, LAN access, видеоконференции, резервные линии связи для сетей Frame Relay и выделенных линий
Кабельные модемы | От 10 до 30 Mbps поток downstream, от 128 Kbps до 10 Mbps поток upstream (разделяемая полоса пропускания) | 35 – 40 км по коаксиальному кабелю (при использовании дополнительного оборудования дистанция может быть увеличена до 250 км) | Доступ в Internet
ADSL/ R-ADSL | От 1.5 до 8 Mbps поток downstream, от 16 до 640 Kbps поток upstream | 6 км (4 км рекомендуется для достижения наибольшей скорости передачи) | Доступ к Internet/intranet, видео – по – требованию, удаленный доступ к LAN, совместная обработка данных (только R-ADSL)
HDSL | 1.544 Mbps (full duplex T1) 2.048 Mbps (full duplex E1) (используют-ся 2-3 пары проводов) | 5 км | Локальное продолжение каналов T1/E1, объединение АТС, сбор трафика Frame Relay, расширение LAN
SDSL | 1.544 Mbps (full duplex T1) 2.048 Mbps (full duplex E1)(используется пара проводов) | 3 км | Локальное продолжение каналов T1/E1, совместная обработка данных, расширение LAN
VDSL | От 13 до 52 Mbps поток downstream. От 1.5 до 2.3 Mbps поток upstream | От 0,3 до 1,5 км (в зависимости от скорости передачи) | Телевидение высокого разрешения, мультимедийный доступ к Internet

image14.gif (33838 bytes)

Рисунок 14. Разнообразие технологий абонентского доступа

Технология ADSL и оборудование уровня доступа

Для построения уровня доступа в сетях поставщиков услуг на базе технологий и оборудования xDSL (Digital Subscriber Line) Cisco Systems применяет оборудование Cisco NetSpeed.

xDSL технологии позиционируются для приложений передачи данных, голоса и видео, а также для объединения учрежденческих телефонных станций по телефонным медным проводам.

В следующие несколько лет xDSL технология потенциально может начать использоваться для доставки ATM в жилые помещения и по существующей инфраструктуре медного кабеля. Разработка стандартов для этого зависит от комитетов ANSI, ETSI, ADSL Forum, ATM Forum, Digital Audio-Visual Council (DAVIC). Как указывается в документах консорциума ADSL Forum, технология ADSL изначально была предназначена для передачи постоянного трафика, а не пакетов данных. Тем не менее, эта организация включила в число своих задач обеспечение полной совместимости технологии ADSL с протоколами пакетной передачи данных, поскольку она идеально подходит для доступа к сетям с коммутацией пакетов.

История развития технологии xDSL

Первая xDSL технология была специфицирована в 1987 Bell Communications Research (Bellcore) - консорциумом региональных операторских компаний Bell (RBOC). В то время xDSL была разработана для предоставления услуг видео по требованию и интерактивных телевизионных приложений с использованием витой пары. Однако, в связи с распадом альянса компаний Bell и кабельных компаний, технология оказалась невостребованной.

Интерес к xDSL возобновился после того, как выяснилось, что использование волоконно-оптических линий в качестве маршрута от конечного пользователя до первого активного устройства поставщика услуг слишком дорого и трудоемко. Другим толчком послужила возможность конкурировать на смежных рынках услуг телефонным компаниям, кабельным компаниям, радио/телевизионным станциям, поставщикам услуг доступа в Internet и постоянного подключения, а также производителям телекоммуникационного оборудования. Телефонные компании видят в xDSL возможность удовлетворения резко возросшего интереса к Internet и требований потребителей к высокоскоростному доступу к данным.

В декабре 1996 г. консорциум принял решение разработать совместно с другими органами стандартизации общие методы сквозной передачи популярных пакетно-ориентированных протоколов по линиям ADSL. Начать решено с ATM, а именно с адаптации ADSL-устройствами потока 53-байтных ATM-ячеек, поступающего со статистического мультиплексора.

Различные типы xDSL и как они работают

Начальная буква "x" в аббревиатуре xDSL обозначает различные виды технологий цифровой абонентской линии, включая ADSL, R-ADSL, HDSL, SDSL и VDSL. Для полного понимания значения этих технологий и определения области приложения каждой из них требуется знать, чем они отличаются.

Ключевыми моментами являются зависимости между дистанцией, на которую передается сигнал и скоростью передачи, а также различия в симметрии трафика upstream (к поставщику услуг) и downstream (к пользователю). В Таблице 1 приведено сравнение различных типов технологий xDSL с конкурирующими технологиями, включая 56 Кбит/с аналоговый dial-up, кабельные модемы и цифровую сеть с интеграцией услуг (ISDN).

Асимметричная цифровая абонентская линия (ADSL)

ADSL технология - это новая платформа для доставки широкополосных услуг в жилые помещения и к небольшим офисам. ADSL может поддерживать широкий набор приложений, требующих высокой полосы пропускания, таких как высокоскоростной доступ к Internet, телеконференциям, виртуальным частным сетям и потокам мультимедиа. Существующими технологиями доставки данных по коммутируемым линиям такие услуги до сих пор или не поддерживались вовсе или поддержка осуществлялась недостаточно эффективно. В настоящее время многие поставщики услуг объявили о своих планах по продвижению решений ADSL.

Ключевым фактором успешного развития и внедрения ADSL является ее двухсторонняя способность к взаимодействию. Благодаря этому качеству появляется возможность использовать оборудование различных производителей и быть уверенным в их совместимости. Значительный прогресс сделан в установке способности к взаимодействию на физическом уровне ADSL. Число моделей ADSL увеличивается по мере развития и адаптации тестовых версий к особенностям рынка и техническим условиям.

Такое решение удовлетворяет следующим ключевым требованиям обслуживания:

  • Доступ к Internet, корпоративной сети, локально предоставляемой информации и равноправные соединения;
  • Легкость миграции от существующей инфраструктуры ISP;
  • Одновременный доступ к нескольким услугам;
  • Мультипротокольная поддержка;
  • Защита;
  • Поддержка многоадресной рассылки;
  • Поддержка нескольких классов обслуживания;
  • Поддержка качества обслуживания (QoS).

ADSL технология асимметрична: она позволяет установить большую величину ширины полосы пропускания от центрального офиса поставщика услуг к узлу потребителя (downstream), чем от узла потребителя к поставщику услуг(upstream). Эта способность делает ADSL идеальной для доступа к Internet/intranet приложениям, видео-по-требованию и удаленного доступа к LAN, так как пользователи этих приложений обычно получают гораздо больше информации, чем отправляют сами. На downstream, ADSL поддерживает скорости между 1.5 и 7 Mbps; на upstream - между 16 и 640 Кбит (Рис. 15). Оптимальные скорости от 6 до 7 Mbps могут быть достигнуты на расстоянии от 3 до 4 км.

Адаптивная по скорости цифровая абонентская линия (R-ADSL)

R-АDSL работает с теми же скоростями, что и ADSL, но динамически настраивается на длину и качество линии. При использовании R-ADSL возможно подключение по разным линиям с различными скоростями. Скорость соединения может быть выбрана при установке синхронизации линии, во время соединения или в результате получения сигнала от центрального офиса.

image15.gif (8259 bytes)

Рисунок 15. Основные элементы ADSL соединения

xDSL - широкополосный доступ по медным проводам

Самым замечательным в технологиях хDSL является их способность передавать большие объемы информации по существующим медным телефонным линиям. Это возможно благодаря тому, что xDSL модемы используют технику обработки сигналов, позволяющую внедрять и вычленять больше цифровых данных при работе с аналоговой линией. Ключевой является модуляция -процесс, при котором один сигнал модифицирует свойство другого.
sinus.gif (1632 bytes) В случае с цифровой абонентской линией модулируемый сигнал от посылающего модема преобразуется в высокочастотный, формируя модулируемую волну (См. рис. слева). Благодаря тому, что этот высокочастотный сигнал может быть модифицирован, большие объемы цифровых данных передаются в этой модулируемой волне на большие дистанции, чем по обычной медной паре.

Когда передаваемые данные достигают назначения, принимающий модем производит демодуляцию.

Бизнес - возможности сетей ADSL

Высокоскоростная связь, предоставляемая домашним, небольшим и удаленным офисам технологией ADSL, открывает большие возможности для провайдеров услуг. Ниже мы обсуждаем несколько таких возможностей для иллюстрации широты услуг, возможных при использовании ADSL.

Услуги связи с Internet

Вспышка интереса к Internet создала возможности для предоставления высокоскоростного доступа к Internet из домашних или небольших офисов. ADSL может обеспечить не только высокую скорость, но также и всегда доступную услугу ("always on") -, услугу, не вызывающую блокирование телефонной сети. Провайдеры могут также предоставлять услугу "Web hosting" для поставщиков информации и потребителей, нуждающихся в создании и управлении Web страницами.

Услуги связи с филиалами

ADSL предлагается для связи филиалов, эффективно заменяя выделенные линии. Большинство бизнес приложений для персональных компьютеров (доступ к файлам, электронная почта, эмуляция терминала и т.д.), используют асимметричную связь, делая ADSL подходящей технологией для подключения удаленных офисов к предприятию.

Услуги телекоммуникации

Телекоммуникации - другая возможность для применения ADSL технологии. Используя способность высокоскоростной доставки информации к помещениям сотрудников, сетевой оператор может предложить "виртуальный офис" для потребителей телекоммуникационных услуг. Такая возможность очень привлекательна, так как все большее количество корпораций выбирает телекоммуникации как средство снижения расходов. Это увеличивает их готовность вкладывать инвестиции в услуги ADSL сети. Дополнительно, сетевой оператор может предоставлять доступ к бизнес сетям в своей стране или даже по всему миру, либо через Internet, либо через широкополосные сети.

Услуги бизнес-бизнес

Сегодняшнее информационное объединение создает новые типы бизнес отношений и предоставляет новые возможности в традиционном бизнес контексте. Приложения бизнес - процессов, связанные между собой, могут иметь потребность в разделении инфраструктуры частных сетей. Сетевые операторы могут организовать виртуальную частную сеть, используя ADSL в содружестве с существующими магистральными сетями для объединения таких бизнес-приложений. Бизнес - приложения, находящиеся вне области услуг оператора, могут быть подключены через Internet, используя такие протоколы туннелирования, как PPTP, L2F или L2TP.

Услуги предоставления информации

Хотя высокоскоростное подключение к сети само по себе очень привлекательно для потребителей, оно дает возможность расширить качество и количество доступной информации. Информация может иметь различные формы: каталоги товаров, справочные материалы, списки недвижимости, транспортные услуги, игры, музыка, видео и т.д. Комбинация высокоскоростных сетей с богатым набором информации является весьма интересным предложением как для бизнеса, так и для рядового потребителя. Операторы сетей также будут иметь возможность локально предоставлять такие услуги, в дополнение к услугам провайдеров информации.

Требования к услугам end-to-end

Для получения доступа к вышеперечисленным услугам существуют требования, которые могут быть классифицированы в двух категориях: конфигурации доступа и функциональные требования. Конфигурация доступа определяет типы пунктов назначения, с которыми сеть обеспечивает связь. Функциональные требования определяют возможности, предоставляемые сетью для поддержки приложений.

Конфигурации доступа

Для успешного функционирования ADSL, оператор общедоступной сети должен обеспечить поддержку комбинации следующих четырех конфигураций доступа: Internet, корпоративные сети, локальный провайдер информации и равноправная связь.

Конфигурации доступа

Рисунок 16. Конфигурации доступа: Internet, корпоративные сети,
локальный провайдер информации и равноправная связь

Internet

Обеспечение высокоскоростного доступа в Internet имеет ключевое значение как для пользователей, работающих дома, так и для небольших офисов. Доступ к Internet осуществляется через одного или нескольких провайдеров доступа в Internet (ISP), присоединенных высокоскоростными каналами к центральным офисам (СО) телефонных компаний (telco). Эти высокоскоростные каналы являются частью региональной сети телефонной компании, которая может быть скомбинирована с SONET, ATM и Frame Relay.

Корпоративные сети

Существует два способа доступа к корпоративной сети. Один из них заключается в использовании механизма туннелирования IP через Internet (используя протоколы PPTP, L2F или L2TP). Такой способ подходит для корпораций с dial-up модемами, когда Internet является как бы частью частной виртуальной сети. При этом, правда, скорость будет зависеть от полосы пропускания Internet. Второй способ заключается в использовании собственной региональной широкополосной сети сетевого оператора, как показано на рисунке, для предоставления прямого высокоскоростного доступа к корпоративной сети. При этом имеется выигрыш в скорости и повышении защищенности.

Локальная информация

Локально представленная информация может быть доставлена с высокой скоростью пользователю, минуя Internet. Такого рода информация может храниться в точках присутствия POP (point of presence) провайдеров доступа в Internet, у провайдеров информации, а также в центральных офисах (CO) и региональных операторских центрах (ROC) телефонных компаний. Такое хранилище информации может быть создано и локально (например, услуги по торговой деятельности), или сгенерировано удаленно (содержимое Web из Internet кэшируется на локальные серверы).

Равноправная связь

Возможность высокоскоростного объединения потребителей позволяет выполнять такие чувствительные к скорости приложения, как видео телефония или интерактивные игры, предполагающие наличие двух равноправных устройств. Требования к такого рода приложениям появляются медленнее, чем к перечисленным выше, однако их сдерживает агрессивная ценовая политика. Появление ADSL позволяет устранить этот недостаток.

Функциональные требования для сети ADSL

Следующие семь функциональных требований должны быть выполнены для внедрения ADSL:

Легкость миграции от существующей инфраструктуры доступа ISP

Поскольку на местах уже имеется инфраструктура для поддержки dial-up доступа, основанного на PPP, любые новые решения широкополосного доступа к Internet должны принимать во внимание эту инфраструктуру. В идеале, модель для достижения услуг ISP может быть повторно использована большинством сетевых, управленческих и административных инфраструктур (таких, как администрирование IP адресов или структуры имен доменов), не затрагивая при этом самой структуры поставщика услуги.

Одновременная связь: Internet и корпоративная сеть

Потребители телекоммуникационных услуг, работающие дома, могут иметь потребность доступа к Internet одновременно с текущей связью со своей корпоративной сетью. Существует два способа обеспечить такую связь. Один способ заключается в доступе к Internet через шлюз своей корпоративной сети. Другой способ состоит в одновременной, но раздельной поддержке доступа к корпоративной сети и к Internet. В большинстве случаев, второй путь предпочтительнее. Он позволяет пользователю иметь прямой доступ к Internet без использования ресурсов своей корпоративной сети (например, при необходимости отвлечься от работы играми). Однако, некоторым корпорациям такая возможность не подойдет, так как компьютер пользователя будет служить открытой дверью в корпоративную сеть со стороны Internet.

Многопротокольная поддержка

Так как не все корпорации используют исключительно IP протокол, обеспечение корпоративной связуемости требует объединения не - IP сетей по ADSL. Такая связь преодолевает протокольные разногласия и назначение адресов.

Защита

Потребители телекоммуникационных услуг и небольшие офисы должны иметь возможность связи со своей корпоративной сетью, используя поддержку аутентификации, авторизации и прав доступа. Защита также важна в случае связи с Internet, так как ISP уже определил все права доступа для пользователя. ISP должен идентифицировать пользователя и предоставить ему права соответственно оговоренному уровню услуг.

Многоадресная передача

Сейчас наблюдается вспышка интереса к услуге многоадресной передачи IP. Многоадресная передача является предпочтительным механизмом доставки. Первоочередным требованием к сети доступа ADSL является доставка услуги многоадресной передачи IP к домашним или небольшим офисам.

Поддержка нескольких классов услуг

Становится ясно, что многие услуги, включая доступ в Internet, не могут зависеть исключительно от парадигмы "один для всех". Для удовлетворения различных потребностей используются различные классы услуг. Так, например, пользователь с большими правами отличается от случайного пользователя. Различия в классах услуг могут основываться на нескольких атрибутах, как, например, максимальное, среднее или минимальное значение ширины полосы пропускания.

Поддержка качества обслуживания

Приложения аудио и видео в режиме реального времени приобретают большую популярность, особенно по Internet. Эти приложения, также как все приложения реального времени, требуют качества обслуживания (QoS), гарантирующего их достоверность и реальность. Качество обслуживания также подразумевает предохранение сети от использования ее ресурсов агрессивными или нечестными пользователями, а также от разрушения достижений других пользователей.

image17.gif (12443 bytes)

Рисунок 17. Элементы сети xDSL

Оборудование для построения ADSL-сети

Cisco 6200 Series Advanced DSL Access Multiplexer (DSLAM) - 14-ти слотовый мультиплексор для абонентского доступа с поддержкой до 80-ти абонентских линий ADSL на скорости до 7Мбит/с. Наличие двух транковых оптических интерфейсов OC3/STM-1 позволит подключить устройство непосредственно к пограничной сети поставщика услуг по каналам АТМ.Для трафика каждой арендованной линии обеспечивается выделенный буфер памяти; поддерживается режим “горячей” замены плат и избыточность основных компонентов.
 c6200.gif (6931 bytes)

Наличие программного обеспечения Cisco IOSO гарантирует полную сквозную совместимость с оборудованием Cisco всей сети и управляемость.

Помимо оборудования, устанавливаемого на телефонных узлах, Cisco располагает оборудованием, которое устанавливается непосредственно в помещении потребителей:

The 605 Personal PCI ADSL Modem - внутренний модем PPP/ATM для установки в PCI-слот компьютера, не требующий установки POTS-сплиттера, позволяет пользователю принимать информацию от узла провайдера на скорости до 7Мбит/с.

Cisco 626 ATM25 ADSL Modem – внешний модем в комплекте с сетевой картой АТМ25.

Cisco 675 SOHO/Telecommuter ADSL Router, Cisco 1401 Small Office ADSL Router – маршрутизаторы для одновременного абонентского доступа сотрудников организаций. Устройства подключаются к сети пользователя через порт 10/100Base-T Ethernet и не требует частотного разделителя.

image18.gif (35523 bytes)

Рисунок 18. Архитектура абонентского доступа ADSL/Dial-Up от Cisco Systems

Доступ по коммутируемым линиям и оборудование уровня доступа

Подавляющее большинство (около 90%) клиентов всех российских провайдеров подключены к Internet через телефонную сеть в сеансовом режиме.

Являясь основой для предоставления коммутируемых услуг доступа, предлагаемое оборудование Cisco Systems сети доступа обеспечивает:

  • Всем категориям пользователей гарантированное качество обслуживания в части предоставления сервиса по коммутируемым линиям на скоростях в соответствии со стандартами ITU V.90 56K, ITU-T V.34 Annex 12 at 33600/31200 bps, ITU-T V.34.
  • Предоставление конечным абонентам сети (домашним пользователям) и корпоративным клиентам доступа к ресурсам частных информационных сетей и ресурсам Internet с обеспечением сохранения телефонной услуги на абонентской линии;
  • Возможность организации защищенных коммутируемых виртуальных соединений с использованием механизмов авторизации/аутентификации и ведением листов доступа.

Реализация узла доступа в Интернет сети оператора связи/поставщика услуг

На рисунке 19 приведена схема организации узла доступа, построенного на оборудовании Cisco Systems. На примере данной схемы показано, что набор устройств Cisco Systems охватывает все задачи, свойственные поставщику услуг, от небольших организаций до первичных поставщиков. Использование продуктов Cisco для организации узлов удаленного доступа разных уровней позволяет наилучшим образом обеспечить сохранение инвестиций в оборудование этих узлов.

При организации узла доступа по коммутируемым аналоговым/цифровым линиям связи основным функциональным элементом является сервер удаленного доступа Cisco Systems модели AS 5200/5300, основанным на архитектуре DASA (Dial Access Stacking Architecture). Архитектура DASA и возможности операционной системы Cisco IOS предоставляют увеличение плотности конечных портов и производительности в системах удаленного доступа.

Благодаря тому, что архитектура DASA является архитектурой распределенной обработки вызовов, решения на ее основе являются гибкими и готовыми к внедрению новых перспективных технологий по организации узлов удаленного доступа и увеличению количества конечных пользовательских портов в одном устройстве. Еще одним преимуществом этой архитектуры является то, что устройства, основанные на ее применении, могут быть установлены в стек.

image19.gif (13402 bytes)

Рисунок 19. Пример реализации узла доступа по коммутируемым линиям на оборудовании Cisco Systems

Функциональные возможности серверов AS5x00 с операционной системой Cisco IOS

Операционная система Cisco IOS Feature Set, под управлением которой работают серверы AS5x00, обеспечивает поставщикам услуг возможность предоставлять конечным пользователям дополнительные сервисы поверх базовой услуги доступа в Internet по Dial-Up. Этот набор дополнительных сервисов включает в себя организацию частных виртуальных сетей, предоставление нескольких уровней классов сервисов, многопротокольные сервисы, сервисы управления и учета звонков. Кроме того, данная версия IOS разработана учетом готовности к 2000 году.

Cisco IOS – основа AS5х00

Достаточно долгое время Cisco Systems занимает лидирующую позицию на рынке продуктов, поддерживающих большое число промышленных протоколов маршрутизации и маршрутизируемых протоколов. Большинство систем поставщиков услуг предоставляет функции доступа к сетям IP. В связи с этим в состав Cisco IOS IP Plus для AS5х00 включены расширенные функции по управлению именно трафиком IP. Сюда можно отнести масштабируемость при использовании большого числа конечных пользовательских подключений, функции оптимизации WAN, поддержку протокола IP и сопутствующих протоколов маршрутизации, управление, безопасность, поддержку мультимедиа, различные сервисы virtual private network (VPN), специальные функции ведения журнала событий (syslog messaging), поддержку Management Information Base (MIB), поддержку нескольких типов коммутации (включая спецификации Q.931, в том числе EuroISDN).

Безопасный доступ (Secure Dial Access)

Операционная система Cisco IOS IP Plus включает в себя полный набор функций по организации авторизованного доступа пользователей к ресурсам системы поставщика услуг и предотвращения несанкционированного доступа нарушителей к этим ресурсам. Некоторые из этих функций обеспечивают несколько уровней защиты паролей пользователей, включая: списки доступа и расширенные списки доступа, безопасность доступа, Lock and key, MAC security for hubs, авторизация и аутентификация маршрутизации MD5, процедуры аутентификации пользователей, функции протоколов PAP (Password Authentication Protocol) и CHAP (Challenge Handshake Authentication Protocol), функции сетевой безопасности (firewall), шифрование передаваемых данных, функции поддержки RADIUS и TACACS+.

Сервисы WAN

Combinet Packet Protocol (CPP), Dialer profiles, Frame Relay, Frame Relay traffic shaping, Half bridge/Half router for CPP and PPP, HDLC, ISDN, Multichassis Multilink PPP (MMP), PPP (включая поддержку протоколов LAN, авторизацию PAP и CHAP и PPP компрессию), SMDS, Switched 56, VPDN (Virtual Private Dialup Network), X.25 (включая X.25 switching и компрессию по каждому виртуальному соединению).

Оптимизация использования ресурсов (WAN-оптимизация)

В состав операционной системы Cisco IOS для AS5х00 включены дополнительные функции оптимизации использования ресурсов сервера доступа. К этим функциям относятся фильтрация протоколов передачи (spoofing), приоритетные очереди, резервирование по телефонному каналу (dial backup), дозвон по требованию (dial-on-demand), компрессия заголовков и канала (header and link compression), изменение пропускной способности по требованию (bandwidth on demand, BOD).

Качество сервиса (QoS)

В порядке предоставления нескольких уровней классов сервисов поставщикам услуг предоставляется набор функций по управлению качеством сервиса, такие как общее формирование трафика (Generic traffic shaping), Random Early Detection (RED), Resource Reservation Protocol (RSVP) и Weighted Fair Queuing (WFQ).

Маршрутизация IP

BGP, BGP4, EGP, EIGRP, EIGRP optimizations, IGRP, Named IP Access Control List, Network Address Translation (NAT), On Demand Routing (ODR), OSPF, OSPF NSSA, OSPF On Demand Circuit, Protocol Independent Multicast (PIM), Policy-based routing, RIP, RIP Version 2.

Поддержка Virtual Private Network

Благодаря поддержке VPN, реализованной в операционной системе Cisco IOS, поставщики услуг могут обеспечивать удаленный доступ к локальным ресурсам пользователям распределенных частных глобальных сетей. Имея возможность реализации виртуального удаленного доступа, поставщики услуг могут предоставлять удаленным пользователям весь набор функций доступа к локальным ресурсам. Локальные звонки могут обеспечиваться функциями доступа к ресурсам распределенной сети предприятия. Доступ удаленных пользователей может осуществляться по протоколу L2F или L2TP (в конце 98 года).

Обеспечение и учет VPN

Значительным требованием к поставщикам услуг сетей VPN является потребность заказчиков в обеспечении необходимого количества подключений, а также в учете сеансов доступа к ресурсам. Новая организация сеансов доступа virtual private dialup network (VPDN) позволяет обеспечивать необходимое количество подключений AS5x00 к локальному пользовательскому шлюзу. Эта возможность реализована в версии операционной системы Cisco IOS IP Plus 11.2.14, функционирующей на серверах доступа AS5х00. Она позволяет собирать статистическую и управляющую информацию о виртуальных соединениях, производимых абонентами узла.

Управление

AutoInstall, автоматическое конфигурирование и управление модемами, сервер HTTP, полный RMON, SNMP, Telnet.

Универсальные серверы доступа CISCO AS5200/5300

as5200.gif (9009 bytes) | Универсальные серверы доступа серий AS5200 и AS5300 представляют собой многоцелевые платформы, обеспечивающие функции сервера доступа, маршрутизатора и пула цифровых модемов на едином шасси. Эти устройства предназначены для операторов Интернет, телекоммуникационных компаний, а также для организаций, обеспечивающих доступ к корпоративным сетям удаленным и мобильным пользователям.
Сервер доступа AS5300 представляет новое поколение универсальных серверов доступа. В нем впервые применены устройства MICA (Modem ISDN Channel Aggregation), обеспечивающие одновременную поддержку модемов и устройств ISDN | as5300.gif (7011 bytes)

и объединяющие преимущества обеих технологий. Сейчас модемы MICA также устанавливаются на серверах серии AS5200. AS5300 поддерживает сигнализацию R2, являющуюся одной из основных применяющихся телефонных сигнализаций. Высокая производительность сервера доступа AS5300 обеспечивается 150 MHz RISC процессором.

AS5200 и AS5300 имеет модульную архитектуру и могут быть укомплектованы различными интерфейсными модулями со встроенными модемами, что позволяет создавать конфигурации, точно соответствующие требованиям пользователя. Кроме того, это позволяет динамически наращивать конфигурацию по мере необходимости путем добавления требуемых модулей. Серверы являются полностью управляемыми платформами через программное обеспечение SNMP и включают программный агент для RMON-контроля. SNMP обеспечивает сбор информации относительно каждого процессора и интерфейса, который может быть опрошен через любую SNMP-совместимую систему управления сети. К примеру, используя параметры и пороги, задаваемые с помощью MIB RMON-группы Alarm, появляется возможность обнаружения перегрузок и анализа состояния системы в реальном времени при возникновении событий, превышающих установленные правила.

Примеры мультисервисных сетей Cisco StrataCom

Наибольший интерес представляют крупные Российские компании – операторы связи, которые приняли решение по выбору магистрального оборудования Cisco StrataCom в текущем 1998 году. Среди них, в первую очередь, можно назвать таких операторов связи, где компания Plus Communications выиграла тендер на построение региональной мультисервисной сети общего доступа.

ОАО “Электросвязь Приморского края”. Первая очередь реализации проекта региональной мультисервисной сети общего доступа предусматривает поставку шести коммутаторов Cisco StrataCom IGX 8410, которые составят ядро территориально-распределенной сети, объединяющей крупнейшие города Приморского края: Владивосток, Уссурийск и Находку. ATM-коммутаторы IGX соединены в общую инфраструктуру через оптоволоконные каналы ОС-3/STM-1 с помощью четырехпортовых UXM-модулей, что позволит обеспечить скорость передачи данных до 155 Мбит/с. Клиентам сети будут предложены услуги Frame Relay, синхронной передачи данных (High-speed synchronous data module) и телефонии (Universal Voice module). Кроме того, в некоторых узлах сети планируется подключение локальных вычислительных сетей через пограничные коммутаторы Cisco Systems по интерфейсу АТМ (UNI).

ОАО “Удмурттелеком”. Республиканская мультисервисная сеть предусматривает поставку на первом этапе трех коммутаторов Cisco StrataCom IGX 8410, которые составят ядро опорной сети в г. Ижевск с пропускной способностью до 155 Мбит/с. В дальнейшем, по мере ввода в эксплуатацию волоконно-оптических каналов связи запланировано расширение опорной сети на коммутаторах IGX по республике на каналах Е1. Этот проект представляет интерес, как полностью интегрированное решение мультисервисной сети на оборудовании Cisco Systems от опорной сети до уровня доступа, т.е. реализован принцип “End-to-End” на оборудовании одного производителя. Альтернативные решения на разнородном оборудовании могли бы добавить проблем со сквозной совместимостью и эксплуатационными трудностями.

Другим российским оператором связи - “МТУ-Информ” был сделан выбор в пользу дальнейшей модернизации сети АТМ на коммутаторах Cisco IGX 8400 против аналогичного оборудования фирмы NewBridge, на котором была построена их сеть SDH/АТМ. На первом этапе установлены IGX 8410 для организации дальних магистральных каналов, в том числе с поставщиком услуг Интернет – MCI (США). Примечателен тот факт, что установка коммутатора Cisco IGX 8400 на магистральных и межзоновых каналах становится тенденцией у крупных операторов связи.

Из числа зарубежных компаний показательными являются:

China National Financial Data Communications Backbone Network (Китай), которая заключила контракт на построение национальной мультисервисной сети на АТМ коммутаторах Cisco IGX 8400. Весь проект предусматривает установку 200 коммутаторов IGX, которые будут объединять главные национальные банки и финансовые институты Китая.

Deutsche Post AG (Германия) выбрала в качестве базовой платформы Cisco IGX 8400 для объединения голосового трафика и потоков данных на базе АТМ технологии. Проект предусматривает поставку, инсталляцию и сервисное сопровождение свыше 200 коммутаторов Cisco IGX 8400 и 15 систем Cisco Voice Network Switch (VNS) для динамической коммутации телефонных каналов, Frame Relay и АТМ трафика через мультисервисную опорную сеть АТМ. В качестве магистральных используются совмещенные каналы Е1. Масштабируемое устройство коммутации VNS установлено из расчета на обслуживание до 30 телефонных коммутаторов с дальнейшим наращиванием по мере роста телефонного трафика. Предусмотрена компрессия телефонных каналов по стандартным алгоритмам 32-Kbps ADPCM (ITU-T G.726) и 8-Kbps CS-ACELP (ITU-T G.729a) и использование функции подавления пауз VAD. Данный проект отличается тем, что до принятия решения специалистами Deutsche Post AG было проведено тестирование различных, основанных на технологии Time Division Multiplexing (TDM), систем построения сети SDH.

Compugraf Network Services (Бразилия), являясь крупнейшим национальным оператором связи, после проведенного тестирования АТМ коммутаторов от Nortel, Newbridge, Cascade и Cisco Systems сделала свой выбор в пользу Cisco IGX 8400. Первоначально было установлено два коммутатора IGX. Сейчас сеть АТМ Compugraf Network Services включает 16 коммутаторов IGX и предоставляет следующие услуги: соединение локальных вычислительных сетей, видеоконференции, соединение АТС по схеме “каждый с каждым”, частные ISDN сети, доступ к Интернет, доступ к мэйнфреймам (SNA) IBM и виртуальные частные сети поверх маршрутизаторов Cisco Systems и сети Frame Relay. В ближайшие планы Compugraf входит инсталляция мультисервисных концентраторов Cisco MC3800 в качестве недорогих удаленных узлов доступа к АТМ сети с сохранением всех вышеперечисленных услуг.

Fleet Financial Group (США) построила корпоративную территориально-распределенную сеть АТМ на коммутаторах Cisco IGX 8400, т.к. считает одним из основных требованием к своей корпоративной сети передачи данных – надежность и доступность всех видов телекоммуникационных услуг 24 часа в сутки 7 дней в неделю и такое же сервисное обслуживание от производителя оборудования. Кратковременный сбой сети передачи данных влечет за собой большие убытки компании. Этого не обеспечивала существующая сеть SDH на базе технологии TDM, т.к. при неисправности магистрального канала восстановление работоспособности сети осуществлялось соответствующими действиями обслуживающего персонала, на что требовалось время. Корпоративная сеть, включавшая 4 коммутатора IGX, в настоящее время расширяется до 70 коммутаторов IGX 8400 и обеспечивает практически все банковские сервисы: доступ к мэйнфреймам (SNA) IBM, телефония, услуги операционных отделов банка, банкоматы (доступ в реальном времени) и финансовые информационные системы.

AvMed (США), крупнейшая медицинская компания во Флориде, использует в качестве АТМ коммутаторов корпоративной опорной сети IGX 8400. Такое решение было обосновано, кроме всего, наличием большого количества инсталлированного оборудования Cisco Systems: магистральных маршрутизаторов Cisco7500 и Cisco4500, коммутаторов Catalyst5500 в локальных сетях и различного оборудования доступа в многочисленных филиалах. Большой опыт работы технического персонала с этим оборудованием и единая программная платформа Cisco IOS на всем оборудовании Cisco обеспечили переход на АТМ сеть на базе коммутаторов IGX без дополнительных расходов на подготовку технических специалистов.

Заключение

Сети СISCO следующего поколения

Факторы развития

Изменение - это одна нескольких постоянных величин в телекоммуникационной индустрии конца 20 века. Роль телекоммуникационных сетей несомненно изменяются благодаря влиянию различных факторов. Наиболее важные из них:

Потребности. Потребители постоянно запрашивают новые типы услуг для разрешения специфичных проблем; поставщики услуг расширяют пакеты услуг для дифференциации их предложений. В обозримом будущем эта тенденция к наращивания услуг продолжится. Поставщики услуг добавляют виртуальные частные IP сети, голос поверх IP, обеспечивающий интегрированную компьютерную телефонию и другие услуги. Быстрое увеличение услуг вызывает также необходимость в увеличении полосы пропускания, по мере того, как все большее количество пользователей подключается к общедоступным сетям и все большее количество приложений становится более чувствительным к ширине полосы пропускания.

Доставка необработанной полосы пропускания. Недавние разработки в технологии DWDM позволили существенно снизить предельно высокую себестоимость сетевой полосы пропускания на интерфейсах OC-48/STM-16 и выше. DWDM системы, которые обеспечивают спектральное мультиплексирование и позволяют переносить несколько потоков (каждый из которых поддерживает высокоскоростную линию связи) по одному оптоволоконному кабелю, перевернули экономику глобальных сетей и полосы пропускания, в частности. В действительности, те поставщики транспорта, которые применили DWDM, увеличили емкость их уже имеющихся волоконных кабелей в 16-80 раз, в зависимости от системы. При этом стоимость получилась ниже, чем стоимость укладки новых кабелей.

Давление конкуренции. Появление новых участников на рынке поставщиков услуг с их конкурирующими предложениями привело к снижению цен на существующие WAN услуги. Для того, чтобы удержать сегодняшние границы цен, поставщики услуг должны предоставить дополнительные высокозначимые услуги (такие как виртуальные частные сети IP). В связи с тем, что большинство быстрорастущих приложений для предприятий основано на IP, дополнительный услугой будет являться виртуальная частная сеть IP. Увеличение конкуренции заставляет поставщиков услуг пересмотреть отношение к скорости предоставления услуг и дифференцированно подойти к этому вопросу. Для поставщика услуг важно не только то, что он первым вышел на рынок с определенной услугой. Большое значение имеет факт приведения этой услуги в действие за меньшее время, чем его конкуренты. В борьбе за приобретение потребителя WAN-услуги выиграет тот поставщик услуги, который доставит ее быстрее, чем остальные поставщики.

Cisco Systems, являясь одним из бесспорных лидеров на рынке телекоммуникаций, готова предоставить новейшие технологии и оборудование, способное учесть данные факторы, предлагает реализовывать телекоммуникационные сети нового поколения.

image20.gif (6342 bytes)

Рисунок 20. Cisco и мировой рынок оборудования ATM/FR для WAN сетей
емкость рынка: $2.8 млрд.
Источник: Vertical Systems, ATM and Frame Relay Industry Update, 1997

Сравнительно недавно компания обнародовала свою стратегию разработки высокоскоростных технологий взаимодействия оптических сетей, состоящую из пяти этапов. Выпуск устройств типа TGX 8750 и GSR 12000 соответствует ее второму этапу, направленному на создание коммутаторов и маршрутизаторов, сопрягаемых непосредственно с уровнем оптической сети, что позволило бы избежать лишних расходов и ограничений на полосу пропускания, обусловленных применением технологий мультиплексирования с временным разделением каналов (TDM) и SDH.

Пограничная сеть следующего поколения

В новом мире повышенных требований к услугам и ширине полосы пропускания, с необходимостью быстрейшей доставки и появления этих услуг у пользователя, положение пограничной сети понятно: наиболее рентабельной будет сеть с максимально гибкими услугами. Другими словами, пограничная сеть должна иметь возможность предоставить услугу высокого качества с высокой скоростью. Те поставщики услуг, которые сейчас имеют пограничную платформу, позволяющую предоставить только одну услугу, будут вынуждены разворачивать дополнительно новую, параллельную пограничную платформу для поддержки новых услуг, которые будут требоваться в будущем. В результате эти поставщики услуг понесут значительные убытки по сравнению с теми конкурирующими поставщиками, которые изначально имеют достаточно гибкие пограничные сети, имеющие возможность предоставлять более, чем одну услугу. Гибкость обслуживания в пограничной сети имеет отношение и к проблеме скорости появления услуги у потребителя.

IP играет ключевую роль в этом требовании гибкости обслуживания. Для того, чтобы увеличить общую рентабельность сети, поставщики должны предоставить услуги, основанные на IP или способные "понимать" IP, так как большинство приложений, требующих предоставления WAN услуг, используют IP. И, поскольку потребители продолжают запрашивать от своих поставщиков услуг предоставления дополнительных функциональностей, поставщики должны постоянно искать все новые и новые услуги, которые смогут дополнить и усилить приложения потребителей. Невозможно предсказать точно, какие из этих будущих услуг станут невозможными, но можно с уверенностью говорить о том, что они должны быть основанными на IP.

Поэтому Cisco уверена в том, что надежная поддерка IP на пограничных сетях будет ключевой для тех поставщиков услуг, которые желают успешно конкурировать в следующем веке.

Пограничная сеть с возможностью гибкого предоставления высокозначимых услуг имеет хорошую проблему: она быстро заполняется приносящим доход трафиком. Следовательно, пограничная платформа следующего поколения должна иметь больше коммутирующей/маршрутизирующей емкости и высокоскоростных интерфейсов, чем это требовалось для платформы, предоставляющей одну услугу.

Появление оборудования DWDM играет удачную роль. Так как технология DWDM снизила себестоимость 2.5 гигабитной полосы пропускания, и поставщик сети может заполнить эту полосу приносящим доход трафиком, появляется благоприятная возможность использовать интерфейсы OC-48c/STM-16 на сетевых элементах пограничной сети. Даже в отличных от глобальной сетях, где экономическая выгода от применения DWDM в настоящее время еще не доказана, транки OC-48c/STM-16 потребуются для соединения с высокоскоростными коммутаторами ядра.

Ядро следующего поколения

Изменение сетей ядра должно происходить несколькими ключевыми путями:

Во-первых, чтобы поддержка транспорта для трафика, предоставляемого пограничными сетями, была экономически эффективной, ядро сети должно обеспечить поддержку различных типов услуг. Само по себе ядро не вносит долю доходов, так как оно не предоставляет непосредственно услуги. Следовательно, для удовлетворения цели поставщика услуг вернуть инвестиции ядро должно быть способным транспортировать трафик IP и ATM для тех поставщиков, которые предоставляют и IP и ATM услуги. Это требует гораздо большей гибкости от платформы ядра, чем она имела в прошлом, обеспечивая транспорт для одного типа трафика. Также требуется применение дополнительного набора основанных на стандартах гибких протоколов маршрутизации, таких как Private Network-Network Interface (PNNI) для ATM-трафика и Multiprotocol Label Switching (MPLS) для трафика IP.

Во-вторых, увеличившаяся ширина полосы пропускания, используемая в пограничных сетях, вынуждает обеспечить в ядре прозрачное наращивание емкости. Категорическим является требование, по которому все изменения, связанные с эволюцией ядра (включая наращивание емкости, обслуживание, замену оборудования) не должны оказывать воздействия на доставку трафика, а значит и услуг. Потребители WAN-услуг не должны ничего знать об инфраструктуре ядра - кроме того, что оно полностью поддерживает те услуги, за которые они, потребители, платят деньги.

В-третьих, телекоммуникационная индустрия быстро движется в сторону применения оптических технологий. Cisco уверена в том, что сети ядра в 21 веке будут существенно отличаться от традиционных сетей сегодняшнего дня, частично из-за интеграции таких оптических технологий, как DWDM в платформу ядра. Имея преимущество от снижения стоимости, позволяемого такой интеграцией, поставщики услуг должны гарантировать, что их сети ядра готовы для развития, в часности, обеспечат прозрачную доставку услуг.

Итоги финансового года CISCO SYSTEMS

Источник:Телеком-Форум/Cisco Systems:

13 августа Московское представительство Cisco Systems подвело итоги 1998 финансового года, который завершился 25 июля. Собственно говоря, журналистам были сообщены лишь финансовые итоги материнской компании. Ее доход за прошедший финансовый год составил 8 456 млн дол, что на 31% превышает достижения 1997 финансового года. Прибыль достигла 1 879 млн дол. и превысила на 33% показатели прошлого года. Темпы роста как доходов, так и прибыли Cisco постепенно снижаются, что в определенной степени объясняется значительным увеличением масштабов компании за 11 лет ее существования. Стоит отметить, что по абсолютным объемам прибыли Cisco нет равных ни среди сетевых компаний, ни среди представителей пока еще более крупных компаний, действующих на рынке производства оборудования для телекоммуникационных (телефонных) операторов.

Таблица 2
Компания | Доход за II кв. 1998 г., млн дол. | Доход за II кв. 1997 г., млн дол. | При- рост, % | Прибыль за II кв. 1998 г., млн дол. | Прибыль за II кв. 1997 г., млн дол. | При- рост, %
Cisco Systems | 2390 | 1765 | 35 | 523 | 383 | 36
Lucent | 7220 | 6340 | 14 | -233 | 215 |
Nortel | 4160 | 3714 | 12 | -69 |  |
Источник: ИАЦ "Телекоммуникации" по данным Cisco и Network World
Во втором квартале 1998 г. все три компании прикупали или рассчитывались за прошлые приобретения. Тем не менее Cisco удалось положить в копилку дополнительных полмиллиарда, а ее будущим конкурентам пришлось залезать в долги.

Вот уже больше года отрасль телекоммуникаций бредит идеей объединения всех видов трафика в одной сети. Большинство аналитиков склоняются ко мнению, что коммутироваться в этой сети будут пакеты, а не каналы и базовым протоколом будет IP. Практически нерешенным остался только один вопрос: кто будет править балом на поприще обеспечения нового телекоммуникационного мира? Старые господа (поставщики АТС и каналообразующего оборудования для телефонных компаний) или какие-нибудь выскочки из производителей сетевого оборудования? Судя по иностранной печати (в России этот вопрос мало кого интересует - не до жиру, быть бы живу), большинство отдает предпочтение первым. Производители оборудования для телефонных компаний пользуются большим авторитетом за их огромный опыт по обеспечению круглосуточной работоспособности своего оборудования, да и в финансовом отношении они значительно мощнее сетевиков. То что телекоммуникационщики ничего не смыслят в IP и вообще в коммутации пакетов, особых опасений не вызывает, считается, что они спокойно могут прикупить себе специалистов из первой лиги, к которой относят поставщиков сетевого оборудования. Опыт последних месяцев, кажется подтверждает эту точку зрения: Nortel готов заплатить за Bay Networks 9,1 млрд дол. при рыночной стоимости последней на 3 млрд меньше, а Lucent предпочитает покупать поменьше, но чаще - за прошедший год поглощены Octel, Livingston, Prominet, Yurie и LANNET (подразделение компании Madge).

В свою очередь президент Cisco Джон Чамберс заявил, что он исключает любую возможность слияния с кем-нибудь из ведущих поставщиков сложных телефонных систем. Что же касается некрупных новаторов в области телефонии, то к их скупке Cisco приступила еще в декабре прошлого года, поглотив Lightspeed International, разработки которой позволят оборудованию Cisco поддерживать систему сигнализации N7. Последней по времени "жертвой" стала компания Summa Four, выпускающая программируемые телефонные коммутаторы (они используются в системах голосовой почты, голосового набора номера, а также для поддержки телефонных карточек). Как считают в Cisco, эти коммутаторы облегчат телефонным операторам переход на пакетную транспортировку речи по протоколу IP. "Мы приближаемся к порогу за которым доминирующим видом трафика становятся данные," - сказал в интервью журналу tele.com Ларри Ланг, вице-президент Cisco по работе с сервис-провайдерами. – "Самое время присмотреться к сетям передачи данных и подумать, как организовать в них телефонную связь". Джон Чамберс считает, что объединение телефонии и передачи данных знаменует собой "третий большой скачок" в сетевых технологиях. Lucent и иже с ней пытаются конкурировать в нарождающемся новом мире связи, не понимая того, что они пережитки прошлого. В отличие от них Cisco встречает наступление новой эры во всеоружии. Что же касается недостатка опыта в чистой телефонии, то он будет восполнен приобретением соответствующих специалистов. Cisco объявила, что половина ее покупок в текущем году будет напрямую связана с конвергенцией телефонных сетей и СПД.

Итак, Cisco отправляется в одиночное плавание, не слушая предостережений о том, что даже в союзе с крупным телекоммуникационным поставщиком ей было бы трудно завоевать доверие у операторов магистральных каналов связи. "Эти компании скептически относятся к большинству поставщиков оборудования передачи данных", - утверждает аналитик из Dataquest Джон Кунс.

А что думают о Cisco крупные российские операторы? Виктор Гришкевич (Ростелеком): "Однозначно сказать, что Cisco не сможет обеспечить на телефонных сетях страны ту надежность, которая предусмотрена нормативными документами, по-моему, никто не может. У нас еще нет достаточно масштабного внедрения оборудования этой компании, чтобы делать какие-то аналитические выводы. Мы работаем со всеми поставщиками: Ericsson, Siemens, NEC, Nortel и Cisco в том числе. Все познается в сравнении".

Plus Networking Academy

Россия, Москва, 1-й Хвостов переулок 11А
Tel: +7 (095) 238-3711, -3777, -3977, -5343
+7 (095) 777-0-111, 777-0-222
Fax: +7 (095) 238-3989
E-mail: info@pluscom.ru

© 1996-2000 Plus Communications


Концепции построения сети

Цифровая сеть передачи данных с интеграцией услуг

Cодержание

Предисловие

Назначение документа

Состояние рынка телекоммуникаций стран СНГ и тенденции его развития

Пути внедрения

Краткий анализ технологий передачи данных

ATM и PDH (ИКМ)

ATM и SDH

Построение региональных ВОЛС на базе оборудования SDH

Построение региональных ВОЛС коммутации ячеек/пакетов ATM/FR

Передача голоса по сетям АТМ

Раздел 1. Почему Cisco?

Cisco IOS™

Раздел 2. Решения CISCO SYSTEMS для поставщиков услуг

Сети поставщиков услуг 21 века

Что приводит к изменениям в глобальном сетевом взаимодействии?

Консолидация индустрии

Конвергенция технологий

Интеллектуальные IP сети будущего

Мультисервисные решения

Раздел 3. Решения CISCO SYSTEMS для сети с интеграцией услуг

Общая структура сети

Основные характеристики широкополосной АТМ-сети

Уровень ядра сети

Роль ядра сети: обслуживание пограничной сети

Оборудование и технологии для построения магистральной сети

Уровень распределения сети

Роль пограничной сети: обслуживание потребителя

Оборудование для построения пограничной сети

Стандартные функции

Управление АТМ-сетями CISCO

Уровень доступа сети

Назначение

Модель взаимодействия end-to-end

Технологии и их применение

Технология ADSL и оборудование уровня доступа

История развития технологии xDSL

Различные типы xDSL и как они работают

Асимметричная цифровая абонентская линия (ADSL)

Адаптивная по скорости цифровая абонентская линия (R-ADSL)

xDSL - широкополосный доступ по медным проводам

Бизнес - возможности сетей ADSL

Услуги связи с Internet

Услуги связи с филиалами

Услуги телекоммуникации

Услуги бизнес-бизнес

Услуги предоставления информации

Требования к услугам end-to-end

Конфигурации доступа

Internet

Корпоративные сети

Локальная информация

Равноправная связь

Функциональные требования для сети ADSL

Легкость миграции от существующей инфраструктуры доступа ISP

Одновременная связь: Internet и корпоративная сеть

Многопротокольная поддержка

Защита

Многоадресная передача

Поддержка нескольких классов услуг

Поддержка качества обслуживания

Оборудование для построения ADSL-сети

Доступ по коммутируемым линиям и оборудование уровня доступа

Реализация узла доступа в Интернет сети оператора связи/поставщика услуг

Функциональные возможности серверов AS5x00 с операционной системой Cisco IOS

Cisco IOS – основа AS5х00

Безопасный доступ (Secure Dial Access)

Сервисы WAN

Оптимизация использования ресурсов (WAN-оптимизация)

Качество сервиса (QoS)

Маршрутизация IP

Поддержка Virtual Private Network

Обеспечение и учет VPN

Управление

Универсальные серверы доступа CISCO AS5200/5300

Примеры мультисервисных сетей Cisco StrataCom

Заключение

Сети СISCO следующего поколения

Факторы развития

Пограничная сеть следующего поколения

Ядро следующего поколения

Итоги финансового года CISCO SYSTEMS

Предисловие

Назначение документа

Настоящий документ носит ознакомительный характер и его целью является представление концепций, технологий и оборудования для построения широкополосной цифровой мультисервисной сети оператора связи, обеспечивающей предоставление своим абонентам услуг телефонной связи, доступа к информационным ресурсам частных распределенных сетей и сетей общего пользования (Интернет).

Создание высокоэффективной телекоммуникационной среды является важнейшей национальной проблемой. Без ее решения невозможно построение информационного сообщества и внедрение новейших информационных технологий в сферы производства, бизнеса, науки, образования, медицины и т.д. Именно информация становится стратегическим ресурсом, а наибольший экономический и социальный успех сопутствует тем, активно использует и предлагает современные средства и услуги информационных и телекоммуникационных технологий.

В большинстве случаев территориально-распределенная сеть поставщика услуг существует для того, чтобы обеспечить возможность удобного и низкостоимостного взаимодействия отдельных пользователей или групп между собой. Поставщики услуг используют оборудование, программное обеспечение, человеческие ресурсы для того, чтобы максимально использовать свои сети с одновременным уменьшением стоимости расходов на эксплуатацию оборудования и на общее содержание сети. Оптимальное использование сети зависит от услуг, которые она предоставляет: насколько хорошо каждая услуга разрешает проблемы потребителя, насколько быстро услуга может быть доставлена потребителю и насколько надежно функционирует эта услуга. Стоимость сети (и расходы на ее содержание) зависит от инфраструктуры, развернутой для ее поддержания: общей стоимости требуемого оборудования, стоимости поддержки информационных систем, расходов на содержание обслуживающего персонала, ширины полосы пропускания, потребляемой услугами и т.д. Очевидно, что наиболее рентабельные поставщики услуг - это те, которые могут развернуть свои сети с приносящими доход услугами с наименьшими для себя затратами.

Состояние рынка телекоммуникаций стран СНГ и тенденции его развития

Существующие телекоммуникационные сети обладают целом рядом недостатков, из которых следует отметить их узкую специализацию, отсутствие гибкости и адаптации к изменению требований пользователей, а также низкую эффективность использования сетевых ресурсов.

В настоящее время телекоммуникации на всей территории бывшего союза - отрасль, находящаяся на подъеме. Доходность возросла, особенно для крупнейших компаний. В ситуации, когда спрос резко подскочил, а затраты снижаются быстрее, чем цены, эти компании в полной мере пользуются своим монопольным положением. В этом состоит главная причина, почему даже некомпетентно управляемые фирмы могут получать высокие прибыли.

Потребителям приходилось принимать любое качество обслуживания и радоваться ему. Но теперь такому состоянию дел приходит конец: на рынок активно выходят новые конкуренты, а клиенты из мира бизнеса требуют нового качества услуг и не согласны мириться с ситуацией, при которой, например, обрывается почти 50% телефонных переговоров, или с длинными очередями на подключение телефона.

Конкуренция возрастает и идет по многим направлениям. Как пример, можно привести ситуацию, когда правительство России поддерживает нарастание конкуренции с сфере телекоммуникаций и выступает за устранение диктата Ростелекома (национальной монополии) на внутреннем рынке.

Новейшие технологии разбивают монополистический контроль над телекоммуникациями и приводят в эту область новых конкурентов. Теперь конкурируют не только различные телефонные фирмы, но и компании кабельного телевидения (которые также передают данные по своим линиям), поставщики услуг Интернет, производители программного обеспечения (предлагающие услуги связи через компьютерные сети), банки (которые предлагают услуги специализированных систем передачи финансовой информации). Данная ситуация способствует превращению телекоммуникаций из индустрии, которая занята строительством и поддержанием систем связи, в индустрию, предлагающую связь лишь как часть широкого спектра услуг. Поскольку новые технологии снижают затраты, связанные с вхождением в бизнес, конкуренция распространяется все шире. Правительство РФ начинает осознавать, что конкуренция - лучшая гарантия, что прогресс технологии найдет полное выражение в виде более качественных, доступных и дешевых услуг.

Министерства, как и местные компании и банки, осознали, наконец, необходимость круглосуточного, беспрепятственного потока информации и денежных переводов и ненадежность существующих линий связи. Крупные частные заказчики (по некоторым сообщениям, одни лишь российские банковские гиганты - Инкомбанк, Онэксимбанк и Мост-банк - потратили в 1997 году $78 млн. на оборудование для систем связи), которые хотят иметь больший выбор и более высокое качество услуг, также давят на правительство, стремясь заставить его реформировать телекоммуникации.

Международный опыт указывает на несколько моментов, которые должны иметь в виду страны с переходной экономикой:

  • "Либерализация" телекоммуникаций состоит из трех частей: подсоединение оборудования клиента (типа компьютера или факса) к телефонной сети, перепродажа телефонных линий, арендованных у телефонного ведомства и полностью независимая конкурентоспособная сеть;
  • Конкуренция в целом ведет к снижению, а не к повышению тарифов (хотя цена некоторых субсидируемых услуг может повыситься);
  • Все крупные компании телекоммуникаций имеют большие скрытые возможности, которые они используют против конкурентов;
  • В таких огромных организациях, как государственные монополии, установить, имеет ли место субсидирование одних услуг за счет других (как и факт ценовой политики, направленной против конкурентов), практически невозможно;
  • Как показал опыт США, Великобритании и ряда других стран, приватизация и децентрализация может дать эффект - но только если для контроля будет создан сложный регулирующий аппарат, включая целый корпус юристов, специализирующихся на вопросах телекоммуникаций.

Есть и другая причина, по которой следует признать необходимость либерализации телекоммуникаций. Эта отрасль вместе с остальными отраслями услуг и инфраструктуры, такими, как банки, страхование и транспорт, принадлежит к областям, которые делают современную экономику динамичной. Если телефонную систему страны можно заставить работать хорошо, и при этом дешевле, выгоды от этого для всей экономики в целом просто нельзя переоценить.

Пути внедрения

Мировая практика развития сетей связи показывает, что основными этапами перехода от не интегрированных аналоговых сетей к цифровым сетям с интеграцией служб являются:

  • Развертывание цифровой сети;
  • Создание цифровой сети интегрального обслуживания с коммутацией каналов для служб телефонии на базе единого цифрового канала 64Кбит/с;
  • Создание широкополосной цифровой сети интегрального обслуживания (B-ISDN) на технологиях АТМ/FrameRelay с объединением всех унаследованных служб и информационных сетей.

Данным документом охватывается именно третий, заключительный, этап развития цифровых сетей, предполагающий построение высокоскоростного ядра цифровой сети с поэтапной интеграцией с существующей инфраструктурой низкоскоростных цифровых сетей и организацией абонентского доступа на базе аналоговых телефонных сетей.

При этом, анализ развития отрасли показывает существование двух ярко выраженных тенденций создания широкополосных цифровых сетей:

  1. Построение региональных ВОЛС на базе оборудования SDH.
  2. Построение региональных ВОЛС коммутации ячеек и пакетов ATM/FR с интеграцией услуг.

Компания PLUS Communications предлагает законченные решения (end-to-end) для построения мультисервисных цифровых сетей с использованием оборудования и технологических решений компании Cisco Systems, Inc.

Краткий анализ технологий передачи данных

ATM и PDH (ИКМ)

Тенденции развития технологий передачи данных для территориально-распределенных сетей можно проследить на примере технологий PDH (плезиохронная цифровая иерархия) и АТМ (асинхронный режим передачи).

  • 1980-1990 – широкое распространение TDM-оборудования, как основы для построения сетей PDH;
  • 1991-1995 – развитие Frame Relay и АТМ;
  • 1996-1997 – принятие концепции мультисервисных сетей АТМ;
  • 1998-2002 – широкое распространение АТМ.

Отсюда становятся очевидными два направления:

  1. Продолжать развитие сетей на базе TDM-оборудования и отвечать на современные требования по предоставлению телекоммуникационных услуг путем инсталляции дополнительного магистрального оборудования (“технологических заплат”) и, как следствие, создание наложенных сетей.
  2. Используя полную совместимость сетей АТМ с TDM осуществлять переход на современные технологии мультисервисных сетей с постепенным вытеснением TDM по мере амортизации устаревшего оборудования, выигрывая время на подготовку к взрывному росту спроса на услуги мультисервисных сетей в обозримом будущем.

Первый путь подразумевает продление жизни устаревающей технологии и соответствует оптимальному решению для конца 80-х – начала 90-х годов. Тем не менее, такое решение не исключает перехода на АТМ-сети, а лишь оттягивает этот переход на более позднее время, накапливая на балансе неперспективное оборудование и откладывая переоснащение сети на период массового спроса на услуги мультисервисных сетей АТМ, чем предопределяются еще большие затраты на будущие.

Второй путь соответствует современному технологическому уровню.

Принято разделять инвестиции на экстенсивные и интенсивные. Первый термин относится к инвестициям в такое оборудование, которое лишь расширит существующую систему, не меняя существенно её структуры и оставаясь на том же технологическом уровне, как и в момент принятия решения на построение существующей системы. Второй означает создание систем на принципиально новой основе с более высокой эффективностью использования всех видов ресурсов и подразумевает качественный скачок в развитии.

image1.gif (16289 bytes)

Рисунок 1. Использование полосы пропускания технологиями TDM и ATM

Сети TDM по своему назначению предусматривают использование мультиплексоров для предоставления фиксированной полосы пропускания для независимых услуг. Основным же достоинством технологии ATM является предоставляемая ею возможность объединять различные типы трафика в единый поток с помощью механизма статистического мультиплексирования, позволяющего более эффективно использовать полосу пропускания

К недостатку синхронных методов передачи, таких как TDM, относится то, что они не позволяют смещать блоки данных по времени для заполнения “пустот” в канале. Это приводит к неэффективному использованию полосы пропускания. Любой же статистический мультиплексор способен “по своему усмотрению” буферизовать данные так, чтобы уплотнить трафик разных пользователей в один общий поток (см. рис 2). Это позволяет избежать незаполненных участков и обеспечить максимально эффективное использование каналов.

На рис. 2 показано, как статистический мультиплексор ATM заполняет трафиком полосу пропускания, которая при использовании мультиплексора TDM осталась бы незадействованной. Еще раз подчеркнем, что мультиплексор ATM не резервирует тайм-слоты для входящих потоков. Потоки могут иметь лишь различные уровни приоритета на использование полосы пропускания; эти уровни определяются параметрами качества обслуживания. Отсутствие резервирования тайм-слотов означает, что данные не могут мгновенно вводиться в тракт передачи и вынуждены проводить некоторое время в буферах, ожидая появления свободного “окна”.

image2.gif (20494 bytes)

Рисунок 2. Уплотнение трафика с помощью мультиплексоров АТМ и традиционного TDM

Другое узкое место технологии PDH/TDM – слабые возможности в организации служебных потоков для целей контроля и управления потоком в сети и практически полное отсутствие средств маршрутизации низовых мультиплексированных потоков, что крайне важно для использования в сетях передачи данных. В связи с отсутствием специальных средств маршрутизации, при формировании PDH-фреймов и мультифреймов увеличивается (при мультиплексировании и переключении потоков) возможность ошибки в отслеживании истории текущего переключения, а значит, увеличивается возможность потерять сведения о его истории в целом, что приводит к нарушению схемы маршрутизации всего трафика.

В настоящее время широко используется наложенная телефонная сеть общего пользования на основе телефонных коммутаторов (АТС). Создание публичной сети ATM /Frame Relay требует инсталляции соответствующих коммутаторов поверх первичной сети передачи данных и не решает проблемы межсетевого взаимодействия (internetworking), создавая ряд независимых наложенных сетей со своим управлением и мониторингом.

Установка "промежуточных" систем (раздельных вычислительных и телефонных сетей) в действительности оказываются дороже, чем переход на АТМ. Переход на АТМ не только позволяет сэкономить средства за счет объединения ресурсов магистрального оборудования первичной сети и уменьшения расходов на дальнейшую модификацию, но и приносит непосредственный экономический эффект благодаря возможности предоставлять широкий спектр услуг.

Очевидно, что телефонные сети развиваются в направлении распределенной коммутации с помощью технологии ATM. Об этом же говорит и встречная тенденция развития самих АТС - появление интерфейсов ATM у станций ряда ведущих производителей.

ATM и SDH

Построение региональных ВОЛС на базе оборудования SDH

С начала 90-х годов в странах СНГ (Россия, Украина, Казахстан и др.) развернуты и полномасштабно функционируют десятки крупных сетей SDH. Технология SDH активно продвигается а регионы. На ее основе происходит крупномасштабное переоборудование старой аналоговой сети связи в цифровую взаимоувязанную сеть. С течением времени под влиянием новых требований пользователей (Интернет, создание частных виртуальных сетей, удаленный доступ и т. д.) компании связи, развернувшие в регионе цифровую сеть SDH для транспорта коммутируемых телефонных каналов, осознают необходимость своего участия на данном рынке услуг и получения новых источников доходов. И, таким образом, наметился переход многих региональных операторов связи от предоставления транспорта телефонии к предоставлению полномасштабных (или частичных) сервисных услуг с гарантированным качеством. Именно в этот момент возникает необходимость построения АТМ/FR-сети.

image3.gif (12116 bytes)

Рисунок 3. Тенденции развития интеллектуальных услуг в корпоративных сетях

Сети SDH и ATM обеспечивает работу приложений, чувствительных к времени задержки передачи сигналов. Однако, сеть SDH не может сама коммутировать цифровые голосовые каналы – коммутацию осуществляет АТС и таким образом увеличивается время коммутации, т.к. вызов абонента может проходить через несколько последовательных АТС. Принятие стандартов сети АТМ, позволяющих ей самой коммутировать виртуальный голосовой канал по набранному номеру цифровой сети, в два раза сокращает число интерфейсов подключения на АТС, а значит снижает их стоимость.

В этой связи, сети SDH целесообразно использовать в качестве транспортных сетей для технологии АТМ, которая становится связующим звеном между локальными компьютерными сетями и глобальными транспортными сетями SDH. АТМ-трафик наиболее подходит для транспортирования в средах SDH, учитывая, что виртуальные контейнеры VC-n могут нести в упакованном виде поток АТМ ячеек в качестве полезной нагрузки.

Достаточно гибкая процедура перехода на магистральную сеть АТМ позволяет защитить инвестиции в уже созданных сегментах первичной сети SDH. Такой подход соответствует принципу преемственности, суть которого сводится к тому, что каждый последующий состав оборудования не должен ухудшать характеристик существующей сети.

Построение региональных ВОЛС коммутации ячеек/пакетов ATM/FR

Переход на технологию АТМ на новых оптических участках позволяет исключить дополнительные затраты на создание первичной сети передачи данных SDH с низким уровнем сервисных услуг и наложенных сетей, как “технологических заплат” под дополнительные телекоммуникационные услуги. Важным преимуществом АТМ является мультисервисность и оптимизация использования магистральных каналов за счет динамического выделения пропускной способности различным видам трафика.

Пример, изображенный на рисунке 4, иллюстрирует принципиальное отличие и преимущества интеллектуальной АТМ–сети перед сетью SDH.

image4.gif (24703 bytes)

Рисунок 4. Оптимизация магистральных каналов в сетях ATM/FR для организации высококачественных телефонных соединений

Из представленного примера при расчете трафика только по телефонной сети, становится очевидным, что для соединения одной АТС с 3-мя АТС в других городах по сети SDH требуется, как минимум 3 транковых порта T1/Е1 на исходящей АТС. В то же время, количество каналов 64К в каждом транке может быть меньше максимального, что влечет необоснованную избыточность транковых портов на АТС, трибных интерфейсов на мультиплексорах SDH и излишние затраты на расширение магистральных каналов.

В сети АТМ на оборудовании Cisco Systems этого можно избежать путем установления виртуальных соединений (VC) для требуемого количества телефонных каналов из одного транкового порта между соответствующими АТС. Основным преимуществом коммутируемых виртуальных соединений является освобождение пропускной способности магистрального канала при отсутствии телефонных вызовов. Телефонные каналы транка Е1 одной телефонной станции маршрутизируются в соответствующие транки Е1 других АТС исходя из расчета межстанционных соединительных линий. Разделение канала Т1/Е1 на DS0 выполняет коммутатор АТМ узла, к которому эта станция подключена.

Комитет Voice and Telephony Over ATM (VTOA) Форума АТМ выпустил ряд документов, посвященных способам передачи цифровых потоков, кратных основному цифровому голосовому каналу DS0, в ячейках АТМ (CES - служба эмуляции выделенных каналов) и преобразования систем сигнализации телефонии и протоколов АТМ (IWF - межсетевая функция). В соответствии с рекомендациями Форума АТМ межсетевая функция (IWF) осуществляет преобразование системы сигнализации, принятой на телефонных сетях в протоколы сигнализации АТМ Служба CES позволяет создавать цифровые каналы связи через сеть АТМ между двумя точками, так же, как это делается в сетях SDH, но, в отличие от SDH, полоса пропускания такого канала в АТМ может быть любой, от 8 Кб/с до емкости линии связи. Это делает возможным использование АТМ в качестве транспортной среды для телефонии.

Функция преобразования протоколов сигнализации реализуется в коммутаторе АТМ, подключение АТС к коммутатору АТМ осуществляется цифровыми потоками 2 Мб/с в соответствии с рекомендациями МСЭ-Т G.703/G.704. В этом случае сеть АТМ представляется для других устройств как цифровая АТС с поддержкой всех соответствующих функций. Вследствие этого каждая АТС, подключаемая к АТМ коммутатору через межсетевую функцию, обрабатывает вызовы только тех абонентов, которые подключены к этой АТС, тогда как канал между станциями устанавливается средствами коммутаторов АТМ и проходит только через них, без использования станций как транзитных. Это не только позволяет снизить требования, предъявляемые к производительности АТС и уменьшить количество соединительных цифровых интерфейсов в них, но и повышает надежность всей сети в целом, так как установленные в сети АТМ каналы могут перекоммутироваться автоматически и устанавливаться в зависимости от текущей загрузки линий связи и их состояния. Кроме того, такие каналы существуют только во время установленного соединения и освобождают полосу пропускания после его разрыва, что позволяет снизить требования к полосе пропускания линий связи или использовать свободную емкость для передачи других видов трафика, например, данных.

В случае обрыва магистрального канала перемаршрутизация установленных соединений происходит автоматически по оптимальному маршруту. Архитектура программного обеспечения магистральных коммутаторов Cisco предусматривает сохранение в энергонезависимой памяти каждого АТМ-коммутатора всей топологии сети, что обеспечивает восстановление соединений в реальном времени и вне зависимости от наличия соединения с центральной станцией управления. Такая архитектура является самодостаточной для обеспечения надежности соединений до 99,99% без вмешательства обслуживающего персонала. Отсюда очевидно, что с увеличением сети растет число обходных каналов и увеличивается надежность соединений.

Таким образом, достигается надежное соединение АТС по принципу “каждый с каждым” с поддержкой всех протоколов сигнализации в существующей телефонной сети (SS-7, QSIG, DPNSS, ISDN, CAS, MFP-U1, MFP-U2, MFS, 2ВСК и др.) и экономия транковых портов на АТС. Суммарная задержка при передаче телефонного трафика по такому типу соединений не превышает 0,2 сек., увеличение пропускной способности сети и увеличение точек подключения осуществляется без изменения существующей конфигурации соединений. В сети SDH все выглядит иначе, с ростом сети увеличиваются затраты на обслуживание и уменьшается общая надежность соединений.

Передача голоса по сетям АТМ

Применение фирменной технологии Voice Network Switching (VNS) в сетях Cisco позволяет использовать не только постоянные каналы связи (PVC), но и предоставляет механизмы, позволяющие автоматически устанавливать коммутируемые виртуальные каналы (SVC) между вызывающей телефонной станцией и станцией абонента. Два важнейших примера таких механизмов - это наличие собственной системы адресов устройств АТМ и протоколов сигнализации. В результате, сеть АТМ обладает теми же функциональными возможностями по коммутации каналов, что и цифровые телефонные сети, например ISDN, и может использоваться как часть корпоративной телефонной сети. Использование службы переменной скорости передачи битов (Variable Bit Rate, VBR) - один из основных подходов к передаче голоса по ATM, прорабатываемых Форумом ATM. Его реализации позволяют всю мощь АТМ по эффективному использованию полосы пропускания и управлению трафиком, которая прежде применялась лишь для передачи данных, задействовать и для передачи голоса.

При установлении каждого нового телефонного соединения сеть ATM вычисляет оптимальный в данный момент времени маршрут с учетом топологии сети, доступной полосы пропускания на разных участках, ожидаемых значений задержки и ее вариации, стоимости соединений по различным маршрутам. В результате устанавливается соединение с характеристиками, необходимыми для качественной передачи голоса. По окончании разговора полоса пропускания высвобождается для других приложений. При использовании технологии VNS сеть ATM “ведет себя” по отношению к периферийным АТС как центральный транзитный узел, а значит, структура телефонной сети заметно упрощается. Теперь не нужно соединять АТС между собой множеством линий связи, число которых зависит не только от объема трафика, но и от структуры телефонной сети и требуемого уровня отказоустойчивости (организация дополнительных линий связи для резервирования). Достаточно соединить АТС только с ближайшим пограничным коммутатором ATM, причем число используемых для этого линий связи зависит лишь от объема трафика. Установление соединений между АТС будет осуществляться на основе получаемой от них сигнализации.

В такой ситуации можно уменьшить число цифровых интерфейсов АТС и не устанавливать чисто транзитные АТС, а следовательно, снизить стоимость телефонного оборудования. Кроме того, упрощаются создание и поддержание единого плана нумерации, поскольку отпадает необходимость содержать в базах данных периферийных АТС сведения обо всех абонентах телефонной сети.

Еще один важный аргумент в пользу применения технологии АТМ для передачи голоса - упрощение расширяемости сети. Предположим, необходимо добавить новый узел или модернизировать старый (увеличить число пользователей, расширить спектр предоставляемых услуг). Традиционный подход потребует перепроектирования межстанционных соединений, причем может понадобиться изменение их структуры или замена магистрали на более производительную из-за отсутствия необходимой емкости на каком-либо ее участке.

В сетях ATM, где используется VNS, ситуация значительно упрощается. В них все АТС являются логически смежными узлами, а значит, расширение телефонной сети сводится к соединению АТС с ближайшим пограничным коммутатором и внесению соответствующей записи в сетевую базу данных. Даже отсутствие свободной полосы пропускания на магистрали ATM не является препятствием к расширению сети. В этом случае можно отложить модернизацию магистрали до лучших времен и просто немного увеличить степень сжатия голоса.

Важно отметить следующее: построение сети ATM для передачи голоса позволяет легко организовать передачу данных и видеоинформации, а использование для разных типов трафика единой системы управления облегчает и удешевляет управление сетью.

image5.gif (70634 bytes)

Рисунок 5. Методы голосовой компрессии в соответствии с ITU-T Recommendation

Наличие “интеллекта” в коммутаторах АТМ/FR от Cisco подразумевает программно-аппаратную реализацию алгоритмов компрессии телефонных каналов 32-, 24-Kbps ADPCM (ITU-T G.726, G.723) или 8-Kbps CS-ACELP (ITU-T G.729a) и функцию подавления пауз, что позволяет одновременно организовать до 240 телефонных каналов при 8-Kbps компрессии на одном транковом потоке Е1 и эффективно использовать отведенную полосу пропускания в магистральном канале. Функция подавления пауз VAD (Voice Activity Detection) использует технологию DSP (digital-signal processing) для переключения между состояниями разговор/пауза в телефонном канале, освобождая полосу пропускания телефонного канала во время паузы в телефонном разговоре. Это позволяет оптимизировать (высвобождение до 50% полосы пропускания) пропускную способность магистрального канала даже при выключенной компрессии телефонных каналов.

image6.gif (5418 bytes)

Рисунок 6. Распределение расходов при эксплуатации магистральных сетей

источник: Data Communications

Обеспечение динамического распределения полосы пропускания транкового канала позволяет перераспределять ширину полосы пропускания для каждого типа трафика в зависимости от загрузки и административно определенной политики качества предоставления услуг (Quality of Service). Таким образом, применение описанных механизмов позволяет говорить об оптимизации и увеличении номинальной пропускной способности магистральных каналов в 3-4 раза.

Построение и эксплуатация интеллектуальных сетей ATM/FR позволяет операторам связи увеличивать доходность за счет новых видов телекоммуникационных услуг, предоставляемых мультисервисной сетью и значительно снизить затраты на использование магистральных каналов связи (при владении этими каналами рассматривается себестоимость 1Kbps) и обслуживание сети. В действительности, стоимость магистральных каналов составляет от 80% до 90% стоимости эксплуатации сети. Так же среди этих затрат можно назвать закупочную стоимость оборудования и программного обеспечения, обучение технического персонала, обслуживание сети и уровень технической поддержки производителя оборудования (Рисунок 5).

Несмотря на то, что АТМ-оборудование дороже оборудования для сети SDH, при использовании для построения магистральной сети SDH-коммутаторов резко возрастает стоимость периферийного оборудования – АТС, маршрутизаторов, мультиплексоров доступа и т.д. Поэтому, общую стоимость систем, реализованных на коммутаторах АТМ и SDH, можно считать сравнимой.

Раздел 1. Почему Cisco?

Компания Cisco Systems является мировым лидером в обеспечении сетевого взаимодействия для Internet. Сегодня каждое виртуальное сообщение, отправленное через Internet, проходит через оборудование компании Cisco Systems. Компания прочно занимает позиции лидера на рынке маршрутизаторов (по разным данным от 60 до 80% в секторе рынка), а после присоединения ряда фирм, специализировавшихся на технологиях Cell-Relay (ATM) и LAN Switching, Cisco Systems вышла в лидеры также и по этим направлениям: 70% рынка магистральных коммутаторов Frame Relay принадлежит именно Cisco (источник:Dataquest).

Основы решений Cisco лежат в понимании важности сети потребителя, как стратегического элемента его бизнеса.
Компания выпускает изделия с оптимальным характером взаимодействия всех уровней сетевой модели OSI, предоставляя при этом пользователю не рекламный, а реальный показатель качества сетевого обслуживания.

market.gif (9124 bytes)

Рисунок 7. Распределение поставок портов ATM для локальных и глобальных сетей
(источник Cisco/Dell'Oro Group)

Аналогично тому, как сети прошли развитие от средств для внутренних взаимодействий до стратегических корпоративных решений для поддержки важнейших приложений, происходит и развитие Cisco. Доступ в Internet, ATM, frame relay, или другие сервисы, - для любого из этих направлений Cisco располагает уникальным оборудованием, заставляющим Internet работать.
Решения Cisco направлены на обеспечение высокой надежности и производительности, защиты и возможности управления всей сетью и отличаются законченностью, что называется end-to-end решениями, позволяющими масштабировать размеры сети от локальной до глобальной.
Cisco имеет свою собственную глобальную сеть Intranet, что позволяет персоналу Cisco по всему миру оперативно разрешать вопросы бизнеса и оказывать необходимую помощь потребителям. Линии связи к стратегическим поставщикам и потребителям позволяют Cisco сотрудничать с ними наиболее эффективно. Сеть Intranet компании позволяет также показать обоснованность новых технологий и продуктов Cisco, которые, будучи внедренными в работающую сеть, позволяют гарантировать их готовность к применению у пользователей. Наличие огромного опыта Cisco в области Internet и Intranet является бесценным ресурсом при дизайне, планировании и построении глобальных сетей. Cisco знает, как применять сетевые технологии для того, чтобы сделать бизнес наиболее конкурентноспособным и наиболее прибыльным.

Cisco IOS™

Спектр изделий, предлагаемых Cisco, занимает весь диапазон аппаратных устройств, в той или иной мере являющимися узлами каких-либо сетей, от простейших, по цене менее 1000 долл., до коммутаторов ценой более 100 тыс. долл. Изделия эти работают со всеми разработанными на сегодняшний день протоколами.

iosstar.gif (2460 bytes)

Именно IOS обеспечивает работу всех изделий фирмы Cisco Systems, гарантируя их полную совместимость между собой независимо от класса изделия и назначения.

Сегодня весь спектр оборудования Cisco, от небольших маршрутизаторов для решения локальных проблем до крупных кампусных или магистральных коммутаторов, поддерживается программным обеспечением Cisco IOS™, которое является платформой для доставки сетевых услуг и функционирования таких сетевых приложений, как интегрированные данные/голос/видео, качество обслуживания (QoS), мультимедиа, а также услуг для взаимодействия с IBM.

Cisco Systems - пока единственный в мире поставщик столь широкого спектра оборудования, работающего под управлением единой операционной системы, вследствие чего достигается:

  • во-первых, гарантированно хорошее взаимодействие на всех уровнях;
  • во-вторых, обеспечивается унификация и, следовательно, упрощение администрирования сложных сетей;
  • в-третьих, появляется возможность применения перспективных, но пока не стандартизованных технологий.

Cisco Systems является активным участником организаций, таких, как ATM Forum, IETF, Frame Relay Forum, занимающихся определением стратегии развития сетевых технологий, выработкой и принятием соответствующих стандартов, и уже множество отработанных фирмой решений оформлены в виде документов, описывающих стандарты в таких областях, как протоколы маршрутизации, сетевое управление и т. д. В последнее время фирма все чаще начала представлять на рынок изделия с реализацией новейших технологий, ни в каких других продуктах больше не представленных, таким образом прочно утверждая себя в качестве бесспорного и сильного лидера и становясь законодателем стандартов де-факто.

На сегодняшний день компания Cisco Systems уверена в том, что она имеет лучшие в своей индустрии платформы для обеспечения требований, предъявляемых к сетям Internet/Intranet, - как сегодняшних, так и будущих.

Раздел 2. Решения CISCO SYSTEMS для поставщиков услуг

Сети поставщиков услуг 21 века

Сетевая индустрия ожидает высоко интеллектуальных глобальных сетей для поддержки приложений, основанных на последних достижениях науки и техники. Cisco предлагает форсировать реализацию глобального сетевого взаимодействия, обеспечивая дополнительные доходы как для корпоративных пользователей, так и для поставщиков услуг. Например, при помощи новаторских партнерских программ Cisco связывает сеть предприятия с поставщиком услуг для создания благоприятных возможностей получения новых источников дохода. Приложения, работающие на предприятии, требуют таких новейших сетевых услуг, как видеоконференции и возможность проведения дистанционного обучения, что требует защиты и поддержки качества сервиса (QoS) от общедоступого Internet.

earth.gif (79917 bytes)

Cisco видит будущее глобального сетевого взаимодействия в предоставлении высокоинтеллектуальных сетевых услуг. Как результат, поставщики услуг Internet будут в возрастающем размере играть важнейшую роль в предоставлении дополнительных услуг, кроме предоставления непосредственно доступа в Internet. Для того, чтобы это обеспечить, необходимо обновить имеющиеся возможности общедоступного Internet так, чтобы сделать сопоставимыми услуги, предоставляемые Internet и услуги, возможные в частных Intranet.

Что приводит к изменениям в глобальном сетевом взаимодействии?

Консолидация индустрии

Сокращение вмешательства государства в экономику стимулировало изменения в индустрии глобального сетевого взаимодействия. Следствием этого явилась консолидация индустрии. Все новые и новые участники каждый день предлагают новые и новые услуги, таким образом разгорается глобальная конкуренция. Для успешного конкурирования поставщики услуг стремяться уменьшить стоимость, одновременно добавляя новые источники дополнительных доходов.

Упавшие цены на персональные компьютеры и цифровые процессоры дали финансовую возможность реализовать новые интерактивные, чувствительные к ширине полосы пропускания LAN приложения и довести их до рабочего места конечного пользователя.

Конвергенция технологий

По мере консолидации индустрии, различные технологии тоже сходятся, комбинируя множественные сервисы в общую инфраструктуру. Одной из крупнейших проблем является интеграция услуг для передачи данных и услуг для передачи голоса по единой сетевой инфраструктуре. Телекоммуникационные поставщики, которые объединяют технологии, могут в значительной степени сократить стоимость их функционирования. Подобно этому, поставщики услуг Internet могут получить дополнительный доход, предоставляя услуги передачи голоса поверх сетей передачи данных. Более того, развитие Internet показывает, как будут выглядеть глобальные сети завтра. Для коммерческой деятельности требуется функционирование приложений по всему миру; следовательно, глобальные сети должны быть достаточно интеллектуальными для того, чтобы поддерживать тот уровень обслуживания, который сейчас удовлетворяет коммерческие требования в частных сетях. Поставщики услуг владеют общедоступными сетями и предприятия ждут от них обеспечения консолидированных, глобальных IP сетей, которые будут поддерживать новейшие услуги между любыми конечными точками в сети по всему миру.

Интеллектуальные IP сети будущего

Internet развивается, высвобождая части сетей в связующую общедоступную инфраструктуру IP. World Wide Web становится удобным средством для доступа к содержимому и доставки информации. Новый Internet будет хорошо управляемой, высокоинтеллектуальной платформой, которой на сегодняшний день нет. Из доступных интеллектуальных услуг Заказчик сможет выбирать нужные для своего бизнеса с целью увеличения дохода и долговременного успеха. Cisco Systems уверена в том, что поставщики телекоммуникационных услуг и поставщики услуг Internet в будущем будут предоставлять не только сетевой транспорт - они будут коммуникационными партнерами для предприятий.

ipplatf.gif (8878 bytes)

В 1998 году во всемирной паутине World Wide Web ожидается свыше 100 миллионов пользователей. К 2000 году доход от рынка Internet составит $92 миллиарда.

Переход к рынку со специализированными услугами сулит благоприятные возможности для получения огромных доходов. В прошлом, поставщики телекоммуникационных услуг получали новый источник доходов, добавляя к общедоступной коммутируемой телефонной сети (PSTN) интеллектуальные услуги для голоса, такие, как ожидание звонка, организация голосовых конференций, перенаправление звонка. Аналогично, добавление интеллектуальных услуг к хорошо управляемому в будущем Internet, позволит поставщикам услуг предлагать новые услуги и охватывать новые рынки. Для достижения этой цели поставщики услуг должны добавить интеллект в сеть и интегрировать услуги для устранения путаницы в помещении потребителя. Потребитель должен получить возможность удовлетворения всех своих требований к сети в одном месте.

Мультисервисные решения

Cisco интегрирует голос и данные "сквозь" сетевую архитектуру с организацией взаимодействия IP и ATM. Для совмещения технологий IP и ATM на основе Cisco IOS™ созданы интегрированные устройства, снабженные стандартными средствами администрирования. Такие решения обеспечивают сходимость инфраструктур от сетевых пограничных устройств через ядро сети или магистраль, а также позволяют существенно снизить затраты на построение коммуникационных систем благодаря возможности комбинировать разнородные сервисы в единых высокоскоростных сетях.

  • Объединение локальных вычислительных сетей

Коммутация и маршрутизация трафика данных через магистраль провайдера
  • Сервис голосовых сообщений

Коммутация голосовых каналов и объединение телефонных станций

  • Видеоконференц-связь

Организация видеоконференций с гарантированным качеством изображения
  • Подключение и объединение сетей с унаследованной архитектурой

Сети IBM SNA, сети пакетной коммутации X.25, асинхронные каналы данных
  • TDM-миграция

Предоставление транспортной среды для мультиплексоров с временным разделением

image8.gif (79896 bytes)

Рисунок 8. Интеграция услуг в широкополосных цифровых сетях Cisco Systems

Сегодня большинство предприятий-потребителей строит свои собственные сети и основной услугой для них являются выделенные линии. Многие потребители приобретают услуги по мере поступления надобности в каждой из них и при минимальном инвестировании. Также они желают получить новые приложения, использующие услуги для коммерческой, издательской деятельности, а также в области развлечений. Если поставщики услуг смогут обеспечить и коммуникации и вычислительную инфраструктуру для предприятий и, особенно, для предприятий малого и среднего бизнеса, их внутриведомственные потребности могут быть значительно сокращены или даже полностью исключены. Положение поставщика транспорта является рискованным, потому что выиграть могут только некоторые из таких поставщиков. Таким образом, наличие платформы интеллектуальных услуг обеспечивает благоприятные возможности для получения прибыли, так как потребители воспринимают эти услуги как весьма значимые.

Cisco предлагает сотрудничество с поставщиками услуг для построения сетей, основанных на коммутации пакетов и ячеек с выходом к существующим инфраструктурам PSTN.

Раздел 3. Решения CISCO SYSTEMS для сети с интеграцией услуг

Общая структура сети

Являясь основой для предоставления интеллектуальных сетевых услуг, сетевая архитектура должна поддерживать взаимодействие для всех унаследованных сетей, основанных на коммутации пакетов, ячеек или кадров, распространяя применение элементов услуг на пограничных устройствах через высокоскоростное магистральное ядро. Расширение спектра предоставляемых объединениями Электросвязей услуг на основе мультисервисной сети передачи данных с сохранением существующей телефонной услуги в качестве базовой и приоритетной на сегодняшний день представляет собой главную задачу, комплексное решение которой предлагается полным спектром оборудования Cisco Systems от оконечных пользовательских устройств до магистральных коммутаторов.

Cisco предлагает законченную (end-to-end) архитектуру, позволяя поставщику услуг предоставлять интеллектуальные услуги. Для мультисервисной сети подобные услуги должны обеспечить:

  • Оптимальное использование существующих транспортных (SDH) и коммутационных телефонных систем сети общего пользования (ТфОП) и прозрачность для различных протоколов телефонной сигнализации ОП SS-7, CCS, CAS, MFP-U1, MFP-U2, MFS, 2ВСК и др;
  • Передачу трафика данных и трафика телефонной сети общего пользования (ТфОП) с суммарной задержкой при передаче телефонного трафика не более 0,2 сек.;
  • Возможность предоставления всем категориям пользователей гарантированного качества обслуживания (QoS) в части предоставления голосового сервиса, мультимедиа и сервиса типа video-on-demand (видео по заказу);
  • Предоставление конечным абонентам сети (домашним пользователям) и корпоративным клиентам высокоскоростного доступа к ресурсам частных информационных сетей и ресурсам Internet с обеспечением сохранения телефонной услуги на абонентской линии;
  • Возможность создания на основе сети поставщика услуг (оператора связи) виртуальных корпоративных частных сетей с предоставлением полного спектра услуг по объединению разнородных сетевых систем.

Основные характеристики широкополосной АТМ-сети

  • Масштабируемость. Подразумевает возможность наращивания пропускной способности сети и количества подключений конечных абонентов сети без внесения существенных изменений в логическую структуру сетевой системы и с наименьшими затратами на дополнительное сетевое оборудование;
  • Мультисервисность. Эта характеристика сети означает, что создаваемая сеть имеет полный набор услуг доступа к информационным ресурсам, включая передачу цифрового и голосового трафика, данных мультимедиа (видеотрансляции и видеоконференции), а также поддержку всех применяемых сетевых протоколов передачи данных;
  • Отказоустойчивость. Отказоустойчивость сети обеспечивается за счет резервирования основных узлов и блоков активного сетевого оборудования, создания резервных линий связи и применения современных протоколов управления потоками данных.
  • Перспективность. Имеется в виду наличие стратегических перспектив использования и наращивания сети за счет предоставления абонентам телефонных сетей услуг доступа к сетям передачи данных через имеющиеся каналы и линии связи;
  • Преемственность (сохранение инвестиций). Предоставление дополнительных услуг абонентам сети не должно повлечь за собой существенных изменений в составе имеющегося телефонного оборудования и линий связи, а также не должно сказываться на качестве телефонных услуг.

Для того, чтобы оптимизировать доходные (услуги) и расходные (содержание сети) части Cisco в своих решениях построения крупных распределенных сетей рекомендует многоуровневую логическую модель, включающую два основных уровня: пограничная сеть и ядро.

Пограничная сеть используется для предоставления приносящих доход услуг. Ядро используется для оптимизации расходов, для чего применяются эффективные транспорт и ширина полосы пропускания для генерируемого пограничными сетями трафика. В общей форме можно сказать, что "Пограничная сеть" - это максимизация доходов, а "Ядро" - это минимизация затрат. И это важно для понимания важного различия между функциями двух платформ - пограничных сетей и ядра.

В последующих разделах описывается роль, которую играют обе платформы в территориально распределенных сетях, указаны факторы, которые влияют на обе платформы, а также представлено видение компанией Cisco Systems требований к пограничным сетям и ядру следующего поколения. И наконец, обсуждаются обе платформы, предлагаемые компанией Cisco, с указанием деталей, специфичных для оборудования.

  • уровень ядра сети (Core Drive);
  • уровень распределения или пограничная сеть (Edge Drive).

image9.gif (20281 bytes)

Рисунок 9. Пограничная сеть обеспечивает доступ и предоставляет услуги потребителям.

Ядро оптимизирует транспорт для трафика, производимого пограничными сетями.

Уровень ядра сети

Роль ядра сети: обслуживание пограничной сети

Ядро прежде всего отвечает за консолидацию потоков низкоскоростного трафика, поступающего от пограничных устройств в высокоскоростные транки, упрощая сетевую топологию и достигая эффективного использования полосы пропускания через транспортную инфраструктуру.

image10.gif (4945 bytes)

Рисунок 10. Пограничная сеть обслуживает потребителя, ядро обслуживает пограничную сеть.

Узлы ядра должны транспортировать большое количество трафика и обеспечить очень высокую коммутационную емкость. Работоспособность и постоянная доступность ядра также является ключевым моментом, так как должна быть гарантия того, что в случае сбоя в ядре качество обслуживания не пострадает. И наконец, так как конечный пользователь не напрямую подсоединяется к платформе ядра, здесь отсутствует необходимость в применении разнообразных интерфейсов, как в случае пограничного коммутатора. Следовательно, сетевые элементы ядра нуждаются только в высокоскоростных интерфейсах для агрегирования трафика от пограничных сетей (обычно это OC-3/STM-1 и выше) и еще более скоростных транковых интерфесах (OC-12/STM-4 и выше).

Магистральные сети должны использовать преимущества скоростных оптических технологий и стать функционально прозрачными для доставленных услуг пограничных сетей. Магистральные сети предназначена для обслуживания пограничных сетей. Ключевая функция ядра состоит в предоставлении высокоскоростного, высокоплотного транспорта для трафика. Для удовлетворения требований к полосе пропускания в ядре сети предлагается использовать устройства SDH/Synchronous Optical Network (SONET) а, в будущем, оборудование dens wave-division multiplexing (DWDM) – спектральное мультиплексирование по длине волны. Учитывая влияние нескольких планов управления, Cisco готова предоставить "бесшовное" взаимодействие между ними через технологию открытых интерфесов, позволяя Asynchronous Transfer Mode (ATM) получать информацию от различных планов управления (например, Signaling System 7 [SS7], Private Network-to-Network Interface [PNNI], или Multi-Protocol Label Switching [MPLS]).

Ядро сети должно обеспечивать гибкий транспорт для более, чем одной пограничной сети. В свою очередь эти пограничные сети могут включать сетевые элементы от более, чем одного поставщика услуг, Заказчиков или индивидуальных пользователей.

Таким образом:

  • Ядро сети должно предоставить экономически эффективный транспорт для IP и ATM трафика; следовательно должно поддерживать основанные на стандартах, гибкие протоколы маршрутизации.
  • Ядро сети должно иметь возможность наращивания емкости, полностью прозрачного для пограничных сетей - другими словами, ядро никогда не должно быть источником риска для качества услуги.
  • Ядро сети должно быть готово к принятию оптических технологий.

Категорическим требованием, которое Cisco неуклонно выполняет, является основанное на стандартах ядро, что позволяет поддерживать гетерогенные пограничные сети.

image11a.gif (14486 bytes)

Рисунок 11. Пример построения ядра магистральной сети

Оборудование и технологии для построения магистральной сети

Технология Tag Switching - является реализацией компании Cisco стандарта Multiprotocol Label Switching (MPLS, многопротокольная маршрутизация с использованием меток), разрабатываемого группой IETF (Internet Engineering Task Force), который уже поддерживается рядом производителей оборудования для глобальных сетей.

Сегодня, в условиях повсеместного распространения протокола IP, все чаще возникает проблема передачи IP-пакетов по сетям других типов. Она оказывается особенно актуальной, когда в качестве базовой транспортной инфраструктуры используются магистрали ATM: бурное развитие технологии асинхронной передачи привело к выпуску разнообразного серийного оборудования и к появлению множества реально работающих сетей на ее основе. Интеграция этих двух технологий позволила бы объединить такие достоинства сетей ATM, как поддержка требуемых уровней информационной защиты и возможность задания гарантированного качества сервиса (QoS), с универсальными возможностями связи, демонстрируемыми средой IP. В результате провайдеры могли бы комбинировать предоставление услуг IP и услуг ATM в одной сетевой среде, разделяя между ними полосу пропускания в динамическом режиме. В целях достижения подобной интеграции к настоящему времени предложено несколько решений: так, в рамках консорциума ATM Forum была разработана специальная технология IP over ATM, а позднее - в июле 1997 г.- принята спецификация MultiProtocol over ATM (MPOA), Cisco Systems предложила метод коммутации с использованием тегов Tag Switching, который в итоге лег в основу технологии MPLS.

MPLS предусматривает использование специальных "меток" в пакетах данных, позволяющих создавать выделенные высокоскоростные коммутируемые потоки информации. В данном случае (в отличие от современных маршрутизируемых инфраструктур Internet) это достигается за счет недопустимости прохождения многочисленных сетевых узлов. Выполнение спецификаций MPLS упрощает создание виртуальных частных сетей (VPN), передачу голоса и видео средствами IP, позволяет более эффективно управлять "сквозным" качеством сервиса.

tgx.gif (5418 bytes)

Cisco TGX™ 8750 - платформа Cisco для ядра IP+ATM, оптический коммутатор TGX 8750 поддерживает технологию Tag Switching, иерархический интерфейс связи между частными сетями (IPNNI), автоматическую защищенную коммутацию с защитой данных (Automatic Protection Switching) в среде SONET/SDH, работу в сетевой среде DS3/E3, OC-3/STM-1, OC-12/STM-4, OC-48c/STM-16 (2,4 Гбит/с). TGX 8750 может обслуживать разнообразные пограничные сети, включая коммутацию ATM/Frame Relay, маршрутизацию IP или сети xDSL.
В качестве лидера в области платформ для ядра с иерархическим PNNI и MPLS /TagSwitching, TGX 8750 поддерживает сети

больших масштабов и предоставляет транспорт с минимальной стоимостью передачи на один бит.
Ядро сети ATM с коммутаторами TGX 8750, построенной на базе интерфейса IPNNI, можно расширить до нескольких тысяч узлов, поддерживающих коммутируемые (SVC) и программируемые постоянные (PVC) виртуальные каналы, а также виртуальные каналы, связывающие один узел с несколькими. Чтобы полностью контролировать приоритеты при передаче голосового трафика и данных, коммутатор применяет алгоритм организации очередей по виртуальным каналам, а средства контроля доступной скорости передачи (ABR), основанные на ее явном указании, позволяют в полном объеме использовать сетевые ресурсы при минимальном ухудшении характеристик сервиса.

Коммутатор усилен рядом средств, повышающих устойчивость его работы. Помимо поддержки надежных масштабируемых протоколов маршрутизации (PNNI, OSPF, IS-IS), сюда относятся наличие задублированных коммутационных матриц, процессорных плат, источников питания и интерфейсных карт, допускающих горячую замену. Поддержка резервных интерфейсных карт для портов OC-3c, OC-12c, OC-48 и OC-48c обеспечивается средствами автоматической коммутации с защитой данных (SONET 1+1 Automatic Protection Switching), гарантирующими быстрое восстановление работоспособности сетевых служб.

Cisco 12000 Series Gigabit Switch Router – семейство гигабитных маршрутизирующих АТМ-коммутаторов, ориентированных на использование в магистральных сетях провайдеров SDH/SONET, имеющих масштабируемую коммутирующую матрицу 5-60Гбит. Устройство предоставляет возможность организации высокоскоростной транспортной оптической среды на скоростях OC-3/SMT-1, OC-12/STM-4, OC-48/STM-16 с предоставлением гарантированного качества обслуживания – Quality of Service (QOS).

gsr12k.gif (32929 bytes)

Модульные маршрутизаторы Cisco 7500 – представляют универсальную высокопроизводительную серию устройств фирмы Cisco Systems. Они удовлетворяют самым высоким требованиям, предъявляемым к современным сетям передачи данных. Модульная архитектура Cisco 7500 позволяет создавать оптимальные решения для конкретных проектов.

c7500.gif (5455 bytes)

Серия Cisco 7500 состоит из трех моделей: Cisco 7505, Cisco 7507 и Cisco 7513. Cisco 7505 имеет пять слотов: один для Route/Switch-процессора (RSP) и четыре слота для интерфейсных адаптеров, один блок питания и общую пропускную способность 1 Гбит/с.

Cisco 7507 имеет 7 слотов, a Cisco 7513 - 13 слотов (2 для RSP и 5 или 11 слотов соответственно для интерфейсных адаптеров). Модели Cisco 7507 и Cisco 7513 обеспечивают пропускную способность более 2 Гбит/с и могут быть укомплектованы двумя RSP и двумя входами питания.

Cisco StrataCom BPX 8600 Service Node - Устройство BPX Service Node представляет собой мощный транспортный коммутатор ATM, объединяющий в себе функции высокоскоростной коммутации трафика ATM и функции интеграции разнородного трафика для передачи его по магистралям ATM. Архитектура коммутатора состоит из двух основных компонентов:

  • Высокоскоростной шины BPX, обеспечивающей работу магистральных интерфейсных модулей со скоростями передачи до 622 Мбит/с.
  • Низкоскоростной шины MGX-8220, поддерживающей интерфейсные модули, занимающиеся интеграцией трафиков голосовой связи, видео, Frame Relay, низкоскоростных сетей ATM, LAN, X.25, SNA.

Коммутатор предназначен для создания высокопроизводительных территориально распределенных магистральных сетей ATM масштаба города, области, государства.

Одним из основных достоинств коммутаторов BPX Service Node является способность динамического использования каналов. Между абонентами системы создаются виртуальные соединения типа “точка-точка”. При отсутствии трафика между конечными точками системы ресурсы канала динамически освобождаются и передаются другим виртуальным соединениям. Эта функция коммутаторов позволяет наиболее полно использовать пропускную способность магистралей.

Коммутатор BPX Service Node обладает общей производительностью 20 Гбит/с и обеспечивает одновременное функционирование в одном шасси до 20 высокоскоростных портов с пропускной способностью 622 Мбит/с и до 80 портов с пропускной способностью 155 Мбит/с. Для менее мощных приложений BPX может работать на каналах E3, поддерживает работу с портами Frame Relay и прозрачную передачу потоков E1. BPX обеспечивает все виды сервиса ATM: CBR, rt-VBR, nrt-VBR, ABR, UBR, а также 2 типа сервиса Network Interworking.

BPX Service Node предоставляет производительность в 800/1600 Мбит/с для каждого из 12 имеющихся разъемов расширения (слотов), позволяя таким образом увеличивать емкость узла при сохранении наивысшей производительности. Низкоскоростные интерфейсы располагаются в отдельном шасси, что обеспечивает наиболее полное использование возможностей BPX Service Node, и не оказывает сколько-нибудь существенного влияния на высокоскоростные магистральные интерфейсы.

BPX Service Node предоставляет следующий набор сетевых сервисов:

  • Internet/intranet

BPX Service Node объединяет трафики Интернет и интрасетей, поддерживает полный набор функций доступа и масштабирует предоставление пользовательских услуг, что позволяет обеспечивать от сотен до тысяч абонентских подключений на одном узле. Расширенные функции управления трафиком предоставляют возможность наиболее эффективно использовать пропускную способность соединений без риска потери пакетов в этих соединениях.

  • ATM

BPX Service Node поддерживает широкий набор интерфейсов передачи данных, включая ATM, Frame Relay, SMDS, LAN, SNA, X.25 и видео высокого разрешения.

  • Switched interworking (объединение коммутируемых сетей)

BPX Service Node – надежная платформа для создания прозрачных высокоскоростных соединений типа "LAN-to-LAN" для топологий Ethernet, Fast Ethernet, Token Ring и FDDI. Трафик передается по частной или глобальной ATM-магистрали.

  • Frame Relay

BPX Service Node предоставляет возможность прозрачной миграции от сетей Frame Relay к сетям ATM и высокоскоростные магистрали с полным набором сервисов для объединения сетей.

  • Voice (передача голоса)

BPX Service Node обеспечивает расширенные функции управления трафиком и классы сервисов (class-of-service, CoS), гарантирующие необходимые условия для работы голосовых приложений реального времени.

  • Video

BPX Service Node обеспечивает необходимое качество сервиса (quality-of-service, QoS) для передачи видеоинформации через линии ATM, включая такие приложения, как "видео по требованию" (video-on-demand), видеоконференции и видеотелефонию.

  • Wireless (беспроводная связь)

Коммутаторы поддерживают функции передачи аналоговой и цифровой беспроводной связи, передачу данных по беспроводным каналам, а также расширенные функции передачи мобильной радиосвязи (enhanced specialized mobile radio, ESMR) в одном шасси BPX Service Node.

В основе BPX Service Node лежит использование технологии Stratm, базирующейся на специализированных наборах микросхем (application-specific integrated circuits, ASIC). Технология Stratm включена в высокоскоростные коммутирующие модули (broadband switch modules, BXM). Функции включают в себя управление трафиком, очередность каждого виртуального соединения (per-virtual-circuit queuing), управление классами сервисов (class of service, COS), поддержку SVC и многоадресной рассылки на каждой карте BXM.

Технология Stratm предоставляет дополнительные функции коммутации ATM для всех коммутирующих модулей, обеспечивает высокую плотность портов и поддерживает сотни тысяч подключений.

Технология Stratm в коммутаторах BPX Service Node расширяет функции обработки SVC, обеспечивая обработку до 4000 вызовов в секунду и 384 000 активных соединений на один узел. Технология Stratm обеспечивает самые низкие в отрасли затраты на обслуживание каждого конечного пользователя и поддерживает наивысшую плотность портов и соединений на каждый слот. BPX с технологией Stratm полностью соответствует определению virtual source/virtual destination (VS/VD) документа ATM Forum Traffic Management Specification Version 4.0.

Уровень распределения сети

Роль пограничной сети: обслуживание потребителя

Пограничная сеть (или сети) ответственна за доставку и обработку услуг от оборудования доступа. Пограничные устройства (Edge Device) существует для обслуживания потребителей и предоставляют необходимые интерфейсы для подключения оборудования уровня доступа. Ключевые функции пограничной сети включают создание и доставку услуг на различных физических интерфейсах, а также обеспечение качества обслуживания и установление различий. Например, при использовании пограничных сетей появляется возможность выбора для предоставления услуг Frame Relay, миграции SNA, виртуальных частных сетей IP, управляемой услуги голос/данные, и т.д. При помощи пограничных сетей можно обеспечить эмуляцию каналов для большой ширины полосы пропускания, тем самым обеспечив замену частных линий связи. Пограничная сеть является тем местом, где создание и дифференциация имеют наибольшее воздействие и где гибкость коммутаторов наиболее критична. Доставка ресурсов Internet, масштабирование intranet, управление данными, голосом и услуги видео для потребителя - все это происходит на пограничных узлах сети и "бесшовным" образом связывается с сетевым окружением в целом.

Для удовлетворения требований бизнеса роли пограничных и магистральных сетей WAN должны эволюционировать и в нынешних условиях четкие грани различий между устройствами Carrier-Class и Edge постепенно исчезают. Первоначальная обработка услуг, чувствительных к скорости обработки и ширине полосы пропускания на пограничных устройствах позволяет освободить магистральное ядро для выполнения функций оптимизированного, высокоскоростного транспорта.

Проведенный аналитиками Сisco анализ данных из независимых источников показал, что поставщики услуг тратят в 7-10 раз больше средств на пограничные сети, чем на ядро сети.

image12.gif (21582 bytes)

Рисунок 12. Пример построения пограничной сети

Оборудование для построения пограничной сети

bpx.gif (11354 bytes)

Универсальные пограничные платформы Cisco - BPX® 8680 и MGXTM 8800 - пограничные WAN коммутаторы, обеспечивающие как предоставление услуг, так и масштабирование и ориентированные на поддержку IP-услуг нового поколения на основе методики Tag Switching. Cisco BPX 8600 IP+ATM Wide-Area Edge Switch – серия динамических коммутаторов трафика IP в сетях ATM с 20Гбит неблокируемой коммутирующей матрицей, предназначенных для базовых сетей провайдеров сетевых услуг, использующий технологию Tag Switching.Функции интеллектуального управления качества обслуживания (QoS), гарантирующие для пользователя запрашиваемый класс сервиса (CoS – всего до 16 классов), поддержка протоколов групповой рассылки (IP Multicast) предоставляет пользователям услуги организации многоточечных видеоконференций, видеотелефонии, видео по заказу.

Cisco MGX 8800 Series Wide-Area Edge Switch -граничный коммутатор MGX 8800 обеспечивает доступ к глобальным сетям средствами VPN, extranet, Frame Relay, а также других типов сервисов, включая IBM SNA. Он способен поддерживать широкий набор узкополосных и широкополосных интерфейсов и обеспечивает диапазон скоростей от DS0 до OC-48c/STM-16 при пропускной способности коммутационной матрицы 45 Гбит/с. Используя коммутатор MGX 8800, провайдеры смогут предложить своим клиентам богатый ассортимент сервисов глобальной сети, включая виртуальные частные сети, IP-телефонию, ретрансляцию кадров, экстра- и интрасети, управляемые службы передачи голоса и данных, передачу трафика SNA по другим сетям и поддержку смешанного трафика (данные/голос/видео).

mgx.gif (6485 bytes)
MGX 8800 и BPX 8680 включают программное обеспечение Cisco IOS®, гарантирующее богатейшую реализацию возможностей IP.
igx.gif (18101 bytes)

Cisco StrataCom IGX – самый распространенный в опорных сетях операторов связи масштабируемый ATM/FR-коммутатор применяется в качестве пограничного устройства при построении территориально распределенных ATM/FR-магистралей. Устройство доступно в 3 моделях: 8-, 16- и 32-слотовые версии. Семейство продуктов IGX интегрируются с другими продуктами фирмы Cisco Systems семейства StrataCom, общее управление которыми осуществляется при помощи программного обеспечения сетевого управления StrataSphere.

Устройства серии IGX поддерживают широкий набор низкоскоростных и высокоскоростных приложений, свойственных как корпоративным частным сетям, так и сетям поставщиков услуг. В условиях сети с неоднородным трафиком серия продуктов IGX позволяет быстро и эффективно добавлять в систему поддержку новых сетевых сервисов и увеличивать плотность портов системы по мере необходимости. Например, в результате развития передающих технологий требуется все большая пропускная способность коммутирующих устройств. Серия продуктов IGX предоставляет возможность быстрого наращивания коммуникационных узлов и миграции на новые, высокоскоростные технологии передачи данных. Продукты IGX и BPX Service Node предоставляют Заказчикам многие сходные возможности и расширенные сетевые функции, включая следующие:

  • Классы сервисных функций OptiClass;
  • Система управления трафиком и избежания перегрузок ForeSight;
  • Система очередности виртуальных соединений (per-virtual-circuit queuing) и распределения нагрузки FairShare;
  • Система управления соединениями AutoRoute;
  • E - LMI 1;
  • FR - ATM service internetworking.

Продукты IGX позволяют производить миграцию с низкоскоростных технологий передачи на высокоскоростные технологии ATM за счет наличия поддержки низкоскоростных интерфейсов.

Стандартные функции

Аппаратное и программное обеспечение коммутатора разработано с учетом требований по максимальной досягаемости портов устройства. Все модели устройств объединяют следующие конструкторские решения:

  • 100% избыточность компонентов устройства;
  • Обширная фоновая диагностика;
  • Возможность "горячей" замены модулей;
  • Ускоренное обнаружение сбоев питания;
  • Обновление программного кода в фоновом режиме;
  • Обновление программного кода с удаленной консоли управления;
  • Сертификация компонентов по спецификации Class B EMI;
  • Аппаратная и программная индикация неисправностей, функция автонабора телефонного номера (требуется дополнительный модем);
  • Минимальное количество кабелей внутри системы (монтажного шкафа).

Благодаря широкому спектру интерфейсных и управляющих модулей коммутаторы IGX обеспечивают передачу через сети ATM следующих типов трафика:

  • Собственно данные. Показатели скорости передачи варьируются от 1200 бит/с до 2.048 Мбит/с (для асинхронных соединений от 1.2 Кбит/с до 19.2 Кбит/с). Используемые интерфейсы: EIA/TIA-232, V.35, X.21, T1/E1. Коммутаторы IGX поддерживают оба типа соединений – dedicated port и channelized circuit emulation.
  • Передача голосовых сообщений. Канальные (Channelized voice module, CVM) и универсальные (universal voice module, UVM) для коммутаторов серии IGX поддерживают интерфейсы E1/T1. Функция определения активности голосового канала, обеспечивающая подавление пауз, также реализована на этих интерфейсах. Функция коммутации звонков является дополнительной. CVM обеспечивают ADPCM-сжатие 32K, 24K и 16K. UVM обеспечивают сжатие ADPCM 32K, 24K, LD-CELP-сжатие 16K и CS-ACELP-сжатие 8К.
  • Поддержка передачи факсимильных сообщений и модемной связи между абонентами узлов. Сервисные голосовые функции IGX обеспечивают прозрачную передачу факсимильных сообщений и организацию модемной связи между абонентами. Это достигается за счет отключения сжатия голосовых данных.
  • Передача видео трафика позволяет организовывать на основе коммутаторов IGX систему видеоконференций между абонентами узлов.
  • Коммутация сетей Frame Relay и ATM.

Шины коммутации устройства расположены таким образом, что все управляющие модули располагаются на передней панели устройства, а все интерфейсные модули – на задней панели коммутатора. Это позволяет производить большую часть работ по обслуживанию коммутатора без отключения интерфейсных кабелей.

Помимо представленного оборудования для построения пограничных сетей Cisco располагает широким спектром устройств с интерфейсами, необходимыми для подключения к широкополосной сети услуг операторов связи сетей X.25/ISDN/FR/SNA.

Таким образом, пограничная сеть от Cisco обеспечит следующие преимущества:

  • гибкость обслуживания потребителя;
  • увеличение дохода без увеличения капиталовложений (возврат инвестиций) при использовании одной пограничной сети для предоставления нескольких услуг;
  • улучшение времени выхода новой услуги на рынок и доведения ее до потребителя;
  • надежная реализация IP для обеспечения лучшей поддержки будущих высокоприбыльных услуг;
  • доступность высокоскоростных оптических интерфейсов OC-48c/STM-16.

Пример построения широкополосной мультисервисной цифровой сети передачи данных, реализованной на базе оборудования и решений Cisco, приводится на
Рисунке 13.

image13.gif (26816 bytes)

Рисунок 13. АТМ-сеть с интеграцией услуг от Cisco Systems

Управление АТМ-сетями CISCO

Cisco понимает, что представление Internet как платформы для интеллектуальных услуг безоговорочно требует лучших в своем классе инструментов управления для обеспечения, учета и управления новыми услугами. Cisco разрабатывает всеобъемлющие решения для управления всей сетью по единой законченной схеме. В этой области Cisco взаимодействует с Microsoft при разработке Active Directory. Cisco переносит эти разработки на UNIX, обеспечивая тем самым универсальную среду для управления, сбора информации об инфраструктурах и услугах, а также управление на уровне обслуживания через Cisco интерфейсы прикладного программирования (API). Cisco планирует выпустить комплект для разработки программного обеспечения для специфического окружения.

Как отмечалось раннее все продукты Cisco работают под управлением операционной системы Cisco IOS. Кроме того, они снабжены специальными средствами администрирования сетевых служб. Возможности Cisco IOS позволяют реализовать в ATM-сети оператора поддержку качества сервиса IP, масштабируемость, функции защиты данных и администрирования, не прибегая для этого к помощи специфических протоколов.

Провайдеру, развертывающему решения IP+ATM от Cisco, гарантируется полное взаимодействие с сетями корпоративных клиентов, уже использующих ПО Cisco IOS. Предлагаемый пакет средств администрирования Cisco Service Management поможет проводить планирование работы служб IP+ATM, управлять их функционированием и осуществлять тарификацию услуг. Все возможности PNNI и Tag Switching отныне интегрированы в программное обеспечение Cisco IOS. Распространяя действие функционального диапазона своей ОС как на ядро, так и на периферию коммуникационной среды, Cisco предлагает своим клиентам сквозную поддержку приложений по всей сети.

Подробное описание состава и функциональностей программного обеспечения Cisco для управления мультисервисными WAN-сетями не входит в состав данного материала.

Уровень доступа сети

Назначение

Уровень доступа сети предназначен для обеспечения конечных подключений абонентов и пользователей сети поставщика услуг. Этот уровень состоит из оборудования, образующего конечные порты отдельных пользователей, порты оборудования, установленного в помещении корпоративных Заказчиков и линий связи, обеспечивающих подключение конечного пользовательского оборудования к этим портам.

Линии связи представляют собой медные пары, проведенные от АТС в жилые дома и учреждения для подключения оконечного оборудования.

Модель взаимодействия end-to-end

Как отмечалось в Разделе “концепции CISCO…”, данная модель сетевого взаимодействия является парадигмой деятельности Cisco Systems и охватывает все решения, которые предлагаются Cisco.

В этой главе дается описание двух сетевых технологий доступа: Dial-Up - самый распространенный вид доступа по коммутируемой линии и ADSL – технология высокоскоростного доступа по существующим медным парам “последней мили”, привлекающая на свою сторону все больше сторонников среди пользователей и поставщиков услуг.

Технологии и их применение

Рассуждения о том, какой технологии удаленного доступа суждено развиваться, а какой - нет, должны быть основаны на понимании необходимости их сосуществования. Технологии, подобные аналоговому dial-up, Frame Relay, и ISDN прекрасно сосуществуют на рынке, основанном на различных требованиях к видам услуг и на их способности обеспечивать доход, обслуживая различные бизнес - приложения. Факторами, которые будут определять успех технологии, являются надежность, стоимость внедрения, простота установки и использования, а также соответствие требованиям приложений пользователя. Ниже приведены краткие описания конкурирующих технологий.

Tаблица 1. Технологии доступа и их применение
Технология | Скорость | Дистанция (24AWG провод) | Приложения
Аналоговые модемы 56 Kbps | 56 Kbps (downstream) 28.8 или 33.6 Kbps (upstream) | Не ограничивается | Электронная почта, удаленный доступ к LAN и сетям Internet/intranet
ISDN | До 128 Kbps (без сжатия) Полный дуплекс | 6 км (для увеличения требуется дополнительное оборудование) | Удаленный доступ к сетям Internet/intranet, LAN access, видеоконференции, резервные линии связи для сетей Frame Relay и выделенных линий
Кабельные модемы | От 10 до 30 Mbps поток downstream, от 128 Kbps до 10 Mbps поток upstream (разделяемая полоса пропускания) | 35 – 40 км по коаксиальному кабелю (при использовании дополнительного оборудования дистанция может быть увеличена до 250 км) | Доступ в Internet
ADSL/ R-ADSL | От 1.5 до 8 Mbps поток downstream, от 16 до 640 Kbps поток upstream | 6 км (4 км рекомендуется для достижения наибольшей скорости передачи) | Доступ к Internet/intranet, видео – по – требованию, удаленный доступ к LAN, совместная обработка данных (только R-ADSL)
HDSL | 1.544 Mbps (full duplex T1) 2.048 Mbps (full duplex E1) (используют-ся 2-3 пары проводов) | 5 км | Локальное продолжение каналов T1/E1, объединение АТС, сбор трафика Frame Relay, расширение LAN
SDSL | 1.544 Mbps (full duplex T1) 2.048 Mbps (full duplex E1)(используется пара проводов) | 3 км | Локальное продолжение каналов T1/E1, совместная обработка данных, расширение LAN
VDSL | От 13 до 52 Mbps поток downstream. От 1.5 до 2.3 Mbps поток upstream | От 0,3 до 1,5 км (в зависимости от скорости передачи) | Телевидение высокого разрешения, мультимедийный доступ к Internet

image14.gif (33838 bytes)

Рисунок 14. Разнообразие технологий абонентского доступа

Технология ADSL и оборудование уровня доступа

Для построения уровня доступа в сетях поставщиков услуг на базе технологий и оборудования xDSL (Digital Subscriber Line) Cisco Systems применяет оборудование Cisco NetSpeed.

xDSL технологии позиционируются для приложений передачи данных, голоса и видео, а также для объединения учрежденческих телефонных станций по телефонным медным проводам.

В следующие несколько лет xDSL технология потенциально может начать использоваться для доставки ATM в жилые помещения и по существующей инфраструктуре медного кабеля. Разработка стандартов для этого зависит от комитетов ANSI, ETSI, ADSL Forum, ATM Forum, Digital Audio-Visual Council (DAVIC). Как указывается в документах консорциума ADSL Forum, технология ADSL изначально была предназначена для передачи постоянного трафика, а не пакетов данных. Тем не менее, эта организация включила в число своих задач обеспечение полной совместимости технологии ADSL с протоколами пакетной передачи данных, поскольку она идеально подходит для доступа к сетям с коммутацией пакетов.

История развития технологии xDSL

Первая xDSL технология была специфицирована в 1987 Bell Communications Research (Bellcore) - консорциумом региональных операторских компаний Bell (RBOC). В то время xDSL была разработана для предоставления услуг видео по требованию и интерактивных телевизионных приложений с использованием витой пары. Однако, в связи с распадом альянса компаний Bell и кабельных компаний, технология оказалась невостребованной.

Интерес к xDSL возобновился после того, как выяснилось, что использование волоконно-оптических линий в качестве маршрута от конечного пользователя до первого активного устройства поставщика услуг слишком дорого и трудоемко. Другим толчком послужила возможность конкурировать на смежных рынках услуг телефонным компаниям, кабельным компаниям, радио/телевизионным станциям, поставщикам услуг доступа в Internet и постоянного подключения, а также производителям телекоммуникационного оборудования. Телефонные компании видят в xDSL возможность удовлетворения резко возросшего интереса к Internet и требований потребителей к высокоскоростному доступу к данным.

В декабре 1996 г. консорциум принял решение разработать совместно с другими органами стандартизации общие методы сквозной передачи популярных пакетно-ориентированных протоколов по линиям ADSL. Начать решено с ATM, а именно с адаптации ADSL-устройствами потока 53-байтных ATM-ячеек, поступающего со статистического мультиплексора.

Различные типы xDSL и как они работают

Начальная буква "x" в аббревиатуре xDSL обозначает различные виды технологий цифровой абонентской линии, включая ADSL, R-ADSL, HDSL, SDSL и VDSL. Для полного понимания значения этих технологий и определения области приложения каждой из них требуется знать, чем они отличаются.

Ключевыми моментами являются зависимости между дистанцией, на которую передается сигнал и скоростью передачи, а также различия в симметрии трафика upstream (к поставщику услуг) и downstream (к пользователю). В Таблице 1 приведено сравнение различных типов технологий xDSL с конкурирующими технологиями, включая 56 Кбит/с аналоговый dial-up, кабельные модемы и цифровую сеть с интеграцией услуг (ISDN).

Асимметричная цифровая абонентская линия (ADSL)

ADSL технология - это новая платформа для доставки широкополосных услуг в жилые помещения и к небольшим офисам. ADSL может поддерживать широкий набор приложений, требующих высокой полосы пропускания, таких как высокоскоростной доступ к Internet, телеконференциям, виртуальным частным сетям и потокам мультимедиа. Существующими технологиями доставки данных по коммутируемым линиям такие услуги до сих пор или не поддерживались вовсе или поддержка осуществлялась недостаточно эффективно. В настоящее время многие поставщики услуг объявили о своих планах по продвижению решений ADSL.

Ключевым фактором успешного развития и внедрения ADSL является ее двухсторонняя способность к взаимодействию. Благодаря этому качеству появляется возможность использовать оборудование различных производителей и быть уверенным в их совместимости. Значительный прогресс сделан в установке способности к взаимодействию на физическом уровне ADSL. Число моделей ADSL увеличивается по мере развития и адаптации тестовых версий к особенностям рынка и техническим условиям.

Такое решение удовлетворяет следующим ключевым требованиям обслуживания:

  • Доступ к Internet, корпоративной сети, локально предоставляемой информации и равноправные соединения;
  • Легкость миграции от существующей инфраструктуры ISP;
  • Одновременный доступ к нескольким услугам;
  • Мультипротокольная поддержка;
  • Защита;
  • Поддержка многоадресной рассылки;
  • Поддержка нескольких классов обслуживания;
  • Поддержка качества обслуживания (QoS).

ADSL технология асимметрична: она позволяет установить большую величину ширины полосы пропускания от центрального офиса поставщика услуг к узлу потребителя (downstream), чем от узла потребителя к поставщику услуг(upstream). Эта способность делает ADSL идеальной для доступа к Internet/intranet приложениям, видео-по-требованию и удаленного доступа к LAN, так как пользователи этих приложений обычно получают гораздо больше информации, чем отправляют сами. На downstream, ADSL поддерживает скорости между 1.5 и 7 Mbps; на upstream - между 16 и 640 Кбит (Рис. 15). Оптимальные скорости от 6 до 7 Mbps могут быть достигнуты на расстоянии от 3 до 4 км.

Адаптивная по скорости цифровая абонентская линия (R-ADSL)

R-АDSL работает с теми же скоростями, что и ADSL, но динамически настраивается на длину и качество линии. При использовании R-ADSL возможно подключение по разным линиям с различными скоростями. Скорость соединения может быть выбрана при установке синхронизации линии, во время соединения или в результате получения сигнала от центрального офиса.

image15.gif (8259 bytes)

Рисунок 15. Основные элементы ADSL соединения

xDSL - широкополосный доступ по медным проводам

Самым замечательным в технологиях хDSL является их способность передавать большие объемы информации по существующим медным телефонным линиям. Это возможно благодаря тому, что xDSL модемы используют технику обработки сигналов, позволяющую внедрять и вычленять больше цифровых данных при работе с аналоговой линией. Ключевой является модуляция -процесс, при котором один сигнал модифицирует свойство другого.

sinus.gif (1632 bytes) В случае с цифровой абонентской линией модулируемый сигнал от посылающего модема преобразуется в высокочастотный, формируя модулируемую волну (См. рис. слева). Благодаря тому, что этот высокочастотный сигнал может быть модифицирован, большие объемы цифровых данных передаются в этой модулируемой волне на большие дистанции, чем по обычной медной паре.

Когда передаваемые данные достигают назначения, принимающий модем производит демодуляцию.

Бизнес - возможности сетей ADSL

Высокоскоростная связь, предоставляемая домашним, небольшим и удаленным офисам технологией ADSL, открывает большие возможности для провайдеров услуг. Ниже мы обсуждаем несколько таких возможностей для иллюстрации широты услуг, возможных при использовании ADSL.

Услуги связи с Internet

Вспышка интереса к Internet создала возможности для предоставления высокоскоростного доступа к Internet из домашних или небольших офисов. ADSL может обеспечить не только высокую скорость, но также и всегда доступную услугу ("always on") -, услугу, не вызывающую блокирование телефонной сети. Провайдеры могут также предоставлять услугу "Web hosting" для поставщиков информации и потребителей, нуждающихся в создании и управлении Web страницами.

Услуги связи с филиалами

ADSL предлагается для связи филиалов, эффективно заменяя выделенные линии. Большинство бизнес приложений для персональных компьютеров (доступ к файлам, электронная почта, эмуляция терминала и т.д.), используют асимметричную связь, делая ADSL подходящей технологией для подключения удаленных офисов к предприятию.

Услуги телекоммуникации

Телекоммуникации - другая возможность для применения ADSL технологии. Используя способность высокоскоростной доставки информации к помещениям сотрудников, сетевой оператор может предложить "виртуальный офис" для потребителей телекоммуникационных услуг. Такая возможность очень привлекательна, так как все большее количество корпораций выбирает телекоммуникации как средство снижения расходов. Это увеличивает их готовность вкладывать инвестиции в услуги ADSL сети. Дополнительно, сетевой оператор может предоставлять доступ к бизнес сетям в своей стране или даже по всему миру, либо через Internet, либо через широкополосные сети.

Услуги бизнес-бизнес

Сегодняшнее информационное объединение создает новые типы бизнес отношений и предоставляет новые возможности в традиционном бизнес контексте. Приложения бизнес - процессов, связанные между собой, могут иметь потребность в разделении инфраструктуры частных сетей. Сетевые операторы могут организовать виртуальную частную сеть, используя ADSL в содружестве с существующими магистральными сетями для объединения таких бизнес-приложений. Бизнес - приложения, находящиеся вне области услуг оператора, могут быть подключены через Internet, используя такие протоколы туннелирования, как PPTP, L2F или L2TP.

Услуги предоставления информации

Хотя высокоскоростное подключение к сети само по себе очень привлекательно для потребителей, оно дает возможность расширить качество и количество доступной информации. Информация может иметь различные формы: каталоги товаров, справочные материалы, списки недвижимости, транспортные услуги, игры, музыка, видео и т.д. Комбинация высокоскоростных сетей с богатым набором информации является весьма интересным предложением как для бизнеса, так и для рядового потребителя. Операторы сетей также будут иметь возможность локально предоставлять такие услуги, в дополнение к услугам провайдеров информации.

Требования к услугам end-to-end

Для получения доступа к вышеперечисленным услугам существуют требования, которые могут быть классифицированы в двух категориях: конфигурации доступа и функциональные требования. Конфигурация доступа определяет типы пунктов назначения, с которыми сеть обеспечивает связь. Функциональные требования определяют возможности, предоставляемые сетью для поддержки приложений.

Конфигурации доступа

Для успешного функционирования ADSL, оператор общедоступной сети должен обеспечить поддержку комбинации следующих четырех конфигураций доступа: Internet, корпоративные сети, локальный провайдер информации и равноправная связь.

Конфигурации доступа

Рисунок 16. Конфигурации доступа: Internet, корпоративные сети,
локальный провайдер информации и равноправная связь

Internet

Обеспечение высокоскоростного доступа в Internet имеет ключевое значение как для пользователей, работающих дома, так и для небольших офисов. Доступ к Internet осуществляется через одного или нескольких провайдеров доступа в Internet (ISP), присоединенных высокоскоростными каналами к центральным офисам (СО) телефонных компаний (telco). Эти высокоскоростные каналы являются частью региональной сети телефонной компании, которая может быть скомбинирована с SONET, ATM и Frame Relay.

Корпоративные сети

Существует два способа доступа к корпоративной сети. Один из них заключается в использовании механизма туннелирования IP через Internet (используя протоколы PPTP, L2F или L2TP). Такой способ подходит для корпораций с dial-up модемами, когда Internet является как бы частью частной виртуальной сети. При этом, правда, скорость будет зависеть от полосы пропускания Internet. Второй способ заключается в использовании собственной региональной широкополосной сети сетевого оператора, как показано на рисунке, для предоставления прямого высокоскоростного доступа к корпоративной сети. При этом имеется выигрыш в скорости и повышении защищенности.

Локальная информация

Локально представленная информация может быть доставлена с высокой скоростью пользователю, минуя Internet. Такого рода информация может храниться в точках присутствия POP (point of presence) провайдеров доступа в Internet, у провайдеров информации, а также в центральных офисах (CO) и региональных операторских центрах (ROC) телефонных компаний. Такое хранилище информации может быть создано и локально (например, услуги по торговой деятельности), или сгенерировано удаленно (содержимое Web из Internet кэшируется на локальные серверы).

Равноправная связь

Возможность высокоскоростного объединения потребителей позволяет выполнять такие чувствительные к скорости приложения, как видео телефония или интерактивные игры, предполагающие наличие двух равноправных устройств. Требования к такого рода приложениям появляются медленнее, чем к перечисленным выше, однако их сдерживает агрессивная ценовая политика. Появление ADSL позволяет устранить этот недостаток.

Функциональные требования для сети ADSL

Следующие семь функциональных требований должны быть выполнены для внедрения ADSL:

Легкость миграции от существующей инфраструктуры доступа ISP

Поскольку на местах уже имеется инфраструктура для поддержки dial-up доступа, основанного на PPP, любые новые решения широкополосного доступа к Internet должны принимать во внимание эту инфраструктуру. В идеале, модель для достижения услуг ISP может быть повторно использована большинством сетевых, управленческих и административных инфраструктур (таких, как администрирование IP адресов или структуры имен доменов), не затрагивая при этом самой структуры поставщика услуги.

Одновременная связь: Internet и корпоративная сеть

Потребители телекоммуникационных услуг, работающие дома, могут иметь потребность доступа к Internet одновременно с текущей связью со своей корпоративной сетью. Существует два способа обеспечить такую связь. Один способ заключается в доступе к Internet через шлюз своей корпоративной сети. Другой способ состоит в одновременной, но раздельной поддержке доступа к корпоративной сети и к Internet. В большинстве случаев, второй путь предпочтительнее. Он позволяет пользователю иметь прямой доступ к Internet без использования ресурсов своей корпоративной сети (например, при необходимости отвлечься от работы играми). Однако, некоторым корпорациям такая возможность не подойдет, так как компьютер пользователя будет служить открытой дверью в корпоративную сеть со стороны Internet.

Многопротокольная поддержка

Так как не все корпорации используют исключительно IP протокол, обеспечение корпоративной связуемости требует объединения не - IP сетей по ADSL. Такая связь преодолевает протокольные разногласия и назначение адресов.

Защита

Потребители телекоммуникационных услуг и небольшие офисы должны иметь возможность связи со своей корпоративной сетью, используя поддержку аутентификации, авторизации и прав доступа. Защита также важна в случае связи с Internet, так как ISP уже определил все права доступа для пользователя. ISP должен идентифицировать пользователя и предоставить ему права соответственно оговоренному уровню услуг.

Многоадресная передача

Сейчас наблюдается вспышка интереса к услуге многоадресной передачи IP. Многоадресная передача является предпочтительным механизмом доставки. Первоочередным требованием к сети доступа ADSL является доставка услуги многоадресной передачи IP к домашним или небольшим офисам.

Поддержка нескольких классов услуг

Становится ясно, что многие услуги, включая доступ в Internet, не могут зависеть исключительно от парадигмы "один для всех". Для удовлетворения различных потребностей используются различные классы услуг. Так, например, пользователь с большими правами отличается от случайного пользователя. Различия в классах услуг могут основываться на нескольких атрибутах, как, например, максимальное, среднее или минимальное значение ширины полосы пропускания.

Поддержка качества обслуживания

Приложения аудио и видео в режиме реального времени приобретают большую популярность, особенно по Internet. Эти приложения, также как все приложения реального времени, требуют качества обслуживания (QoS), гарантирующего их достоверность и реальность. Качество обслуживания также подразумевает предохранение сети от использования ее ресурсов агрессивными или нечестными пользователями, а также от разрушения достижений других пользователей.

image17.gif (12443 bytes)

Рисунок 17. Элементы сети xDSL

Оборудование для построения ADSL-сети

Cisco 6200 Series Advanced DSL Access Multiplexer (DSLAM) - 14-ти слотовый мультиплексор для абонентского доступа с поддержкой до 80-ти абонентских линий ADSL на скорости до 7Мбит/с. Наличие двух транковых оптических интерфейсов OC3/STM-1 позволит подключить устройство непосредственно к пограничной сети поставщика услуг по каналам АТМ.Для трафика каждой арендованной линии обеспечивается выделенный буфер памяти; поддерживается режим “горячей” замены плат и избыточность основных компонентов.
         c6200.gif (6931 bytes)

Наличие программного обеспечения Cisco IOSO гарантирует полную сквозную совместимость с оборудованием Cisco всей сети и управляемость.

Помимо оборудования, устанавливаемого на телефонных узлах, Cisco располагает оборудованием, которое устанавливается непосредственно в помещении потребителей:

The 605 Personal PCI ADSL Modem - внутренний модем PPP/ATM для установки в PCI-слот компьютера, не требующий установки POTS-сплиттера, позволяет пользователю принимать информацию от узла провайдера на скорости до 7Мбит/с.

Cisco 626 ATM25 ADSL Modem – внешний модем в комплекте с сетевой картой АТМ25.

Cisco 675 SOHO/Telecommuter ADSL Router, Cisco 1401 Small Office ADSL Router – маршрутизаторы для одновременного абонентского доступа сотрудников организаций. Устройства подключаются к сети пользователя через порт 10/100Base-T Ethernet и не требует частотного разделителя.

image18.gif (35523 bytes)

Рисунок 18. Архитектура абонентского доступа ADSL/Dial-Up от Cisco Systems

Доступ по коммутируемым линиям и оборудование уровня доступа

Подавляющее большинство (около 90%) клиентов всех российских провайдеров подключены к Internet через телефонную сеть в сеансовом режиме.

Являясь основой для предоставления коммутируемых услуг доступа, предлагаемое оборудование Cisco Systems сети доступа обеспечивает:

  • Всем категориям пользователей гарантированное качество обслуживания в части предоставления сервиса по коммутируемым линиям на скоростях в соответствии со стандартами ITU V.90 56K, ITU-T V.34 Annex 12 at 33600/31200 bps, ITU-T V.34.
  • Предоставление конечным абонентам сети (домашним пользователям) и корпоративным клиентам доступа к ресурсам частных информационных сетей и ресурсам Internet с обеспечением сохранения телефонной услуги на абонентской линии;
  • Возможность организации защищенных коммутируемых виртуальных соединений с использованием механизмов авторизации/аутентификации и ведением листов доступа.

Реализация узла доступа в Интернет сети оператора связи/поставщика услуг

На рисунке 19 приведена схема организации узла доступа, построенного на оборудовании Cisco Systems. На примере данной схемы показано, что набор устройств Cisco Systems охватывает все задачи, свойственные поставщику услуг, от небольших организаций до первичных поставщиков. Использование продуктов Cisco для организации узлов удаленного доступа разных уровней позволяет наилучшим образом обеспечить сохранение инвестиций в оборудование этих узлов.

При организации узла доступа по коммутируемым аналоговым/цифровым линиям связи основным функциональным элементом является сервер удаленного доступа Cisco Systems модели AS 5200/5300, основанным на архитектуре DASA (Dial Access Stacking Architecture). Архитектура DASA и возможности операционной системы Cisco IOS предоставляют увеличение плотности конечных портов и производительности в системах удаленного доступа.

Благодаря тому, что архитектура DASA является архитектурой распределенной обработки вызовов, решения на ее основе являются гибкими и готовыми к внедрению новых перспективных технологий по организации узлов удаленного доступа и увеличению количества конечных пользовательских портов в одном устройстве. Еще одним преимуществом этой архитектуры является то, что устройства, основанные на ее применении, могут быть установлены в стек.

image19.gif (13402 bytes)

Рисунок 19. Пример реализации узла доступа по коммутируемым линиям на оборудовании Cisco Systems

Функциональные возможности серверов AS5x00 с операционной системой Cisco IOS

Операционная система Cisco IOS Feature Set, под управлением которой работают серверы AS5x00, обеспечивает поставщикам услуг возможность предоставлять конечным пользователям дополнительные сервисы поверх базовой услуги доступа в Internet по Dial-Up. Этот набор дополнительных сервисов включает в себя организацию частных виртуальных сетей, предоставление нескольких уровней классов сервисов, многопротокольные сервисы, сервисы управления и учета звонков. Кроме того, данная версия IOS разработана учетом готовности к 2000 году.

Cisco IOS – основа AS5х00

Достаточно долгое время Cisco Systems занимает лидирующую позицию на рынке продуктов, поддерживающих большое число промышленных протоколов маршрутизации и маршрутизируемых протоколов. Большинство систем поставщиков услуг предоставляет функции доступа к сетям IP. В связи с этим в состав Cisco IOS IP Plus для AS5х00 включены расширенные функции по управлению именно трафиком IP. Сюда можно отнести масштабируемость при использовании большого числа конечных пользовательских подключений, функции оптимизации WAN, поддержку протокола IP и сопутствующих протоколов маршрутизации, управление, безопасность, поддержку мультимедиа, различные сервисы virtual private network (VPN), специальные функции ведения журнала событий (syslog messaging), поддержку Management Information Base (MIB), поддержку нескольких типов коммутации (включая спецификации Q.931, в том числе EuroISDN).

Безопасный доступ (Secure Dial Access)

Операционная система Cisco IOS IP Plus включает в себя полный набор функций по организации авторизованного доступа пользователей к ресурсам системы поставщика услуг и предотвращения несанкционированного доступа нарушителей к этим ресурсам. Некоторые из этих функций обеспечивают несколько уровней защиты паролей пользователей, включая: списки доступа и расширенные списки доступа, безопасность доступа, Lock and key, MAC security for hubs, авторизация и аутентификация маршрутизации MD5, процедуры аутентификации пользователей, функции протоколов PAP (Password Authentication Protocol) и CHAP (Challenge Handshake Authentication Protocol), функции сетевой безопасности (firewall), шифрование передаваемых данных, функции поддержки RADIUS и TACACS+.

Сервисы WAN

Combinet Packet Protocol (CPP), Dialer profiles, Frame Relay, Frame Relay traffic shaping, Half bridge/Half router for CPP and PPP, HDLC, ISDN, Multichassis Multilink PPP (MMP), PPP (включая поддержку протоколов LAN, авторизацию PAP и CHAP и PPP компрессию), SMDS, Switched 56, VPDN (Virtual Private Dialup Network), X.25 (включая X.25 switching и компрессию по каждому виртуальному соединению).

Оптимизация использования ресурсов (WAN-оптимизация)

В состав операционной системы Cisco IOS для AS5х00 включены дополнительные функции оптимизации использования ресурсов сервера доступа. К этим функциям относятся фильтрация протоколов передачи (spoofing), приоритетные очереди, резервирование по телефонному каналу (dial backup), дозвон по требованию (dial-on-demand), компрессия заголовков и канала (header and link compression), изменение пропускной способности по требованию (bandwidth on demand, BOD).

Качество сервиса (QoS)

В порядке предоставления нескольких уровней классов сервисов поставщикам услуг предоставляется набор функций по управлению качеством сервиса, такие как общее формирование трафика (Generic traffic shaping), Random Early Detection (RED), Resource Reservation Protocol (RSVP) и Weighted Fair Queuing (WFQ).

Маршрутизация IP

BGP, BGP4, EGP, EIGRP, EIGRP optimizations, IGRP, Named IP Access Control List, Network Address Translation (NAT), On Demand Routing (ODR), OSPF, OSPF NSSA, OSPF On Demand Circuit, Protocol Independent Multicast (PIM), Policy-based routing, RIP, RIP Version 2.

Поддержка Virtual Private Network

Благодаря поддержке VPN, реализованной в операционной системе Cisco IOS, поставщики услуг могут обеспечивать удаленный доступ к локальным ресурсам пользователям распределенных частных глобальных сетей. Имея возможность реализации виртуального удаленного доступа, поставщики услуг могут предоставлять удаленным пользователям весь набор функций доступа к локальным ресурсам. Локальные звонки могут обеспечиваться функциями доступа к ресурсам распределенной сети предприятия. Доступ удаленных пользователей может осуществляться по протоколу L2F или L2TP (в конце 98 года).

Обеспечение и учет VPN

Значительным требованием к поставщикам услуг сетей VPN является потребность заказчиков в обеспечении необходимого количества подключений, а также в учете сеансов доступа к ресурсам. Новая организация сеансов доступа virtual private dialup network (VPDN) позволяет обеспечивать необходимое количество подключений AS5x00 к локальному пользовательскому шлюзу. Эта возможность реализована в версии операционной системы Cisco IOS IP Plus 11.2.14, функционирующей на серверах доступа AS5х00. Она позволяет собирать статистическую и управляющую информацию о виртуальных соединениях, производимых абонентами узла.

Управление

AutoInstall, автоматическое конфигурирование и управление модемами, сервер HTTP, полный RMON, SNMP, Telnet.

Универсальные серверы доступа CISCO AS5200/5300

as5200.gif (9009 bytes) | Универсальные серверы доступа серий AS5200 и AS5300 представляют собой многоцелевые платформы, обеспечивающие функции сервера доступа, маршрутизатора и пула цифровых модемов на едином шасси. Эти устройства предназначены для операторов Интернет, телекоммуникационных компаний, а также для организаций, обеспечивающих доступ к корпоративным сетям удаленным и мобильным пользователям.
Сервер доступа AS5300 представляет новое поколение универсальных серверов доступа. В нем впервые применены устройства MICA (Modem ISDN Channel Aggregation), обеспечивающие одновременную поддержку модемов и устройств ISDN | as5300.gif (7011 bytes)

и объединяющие преимущества обеих технологий. Сейчас модемы MICA также устанавливаются на серверах серии AS5200. AS5300 поддерживает сигнализацию R2, являющуюся одной из основных применяющихся телефонных сигнализаций. Высокая производительность сервера доступа AS5300 обеспечивается 150 MHz RISC процессором.

AS5200 и AS5300 имеет модульную архитектуру и могут быть укомплектованы различными интерфейсными модулями со встроенными модемами, что позволяет создавать конфигурации, точно соответствующие требованиям пользователя. Кроме того, это позволяет динамически наращивать конфигурацию по мере необходимости путем добавления требуемых модулей. Серверы являются полностью управляемыми платформами через программное обеспечение SNMP и включают программный агент для RMON-контроля. SNMP обеспечивает сбор информации относительно каждого процессора и интерфейса, который может быть опрошен через любую SNMP-совместимую систему управления сети. К примеру, используя параметры и пороги, задаваемые с помощью MIB RMON-группы Alarm, появляется возможность обнаружения перегрузок и анализа состояния системы в реальном времени при возникновении событий, превышающих установленные правила.

Примеры мультисервисных сетей Cisco StrataCom

Наибольший интерес представляют крупные Российские компании – операторы связи, которые приняли решение по выбору магистрального оборудования Cisco StrataCom в текущем 1998 году. Среди них, в первую очередь, можно назвать таких операторов связи, где компания Plus Communications выиграла тендер на построение региональной мультисервисной сети общего доступа.

ОАО “Электросвязь Приморского края”. Первая очередь реализации проекта региональной мультисервисной сети общего доступа предусматривает поставку шести коммутаторов Cisco StrataCom IGX 8410, которые составят ядро территориально-распределенной сети, объединяющей крупнейшие города Приморского края: Владивосток, Уссурийск и Находку. ATM-коммутаторы IGX соединены в общую инфраструктуру через оптоволоконные каналы ОС-3/STM-1 с помощью четырехпортовых UXM-модулей, что позволит обеспечить скорость передачи данных до 155 Мбит/с. Клиентам сети будут предложены услуги Frame Relay, синхронной передачи данных (High-speed synchronous data module) и телефонии (Universal Voice module). Кроме того, в некоторых узлах сети планируется подключение локальных вычислительных сетей через пограничные коммутаторы Cisco Systems по интерфейсу АТМ (UNI).

ОАО “Удмурттелеком”. Республиканская мультисервисная сеть предусматривает поставку на первом этапе трех коммутаторов Cisco StrataCom IGX 8410, которые составят ядро опорной сети в г. Ижевск с пропускной способностью до 155 Мбит/с. В дальнейшем, по мере ввода в эксплуатацию волоконно-оптических каналов связи запланировано расширение опорной сети на коммутаторах IGX по республике на каналах Е1. Этот проект представляет интерес, как полностью интегрированное решение мультисервисной сети на оборудовании Cisco Systems от опорной сети до уровня доступа, т.е. реализован принцип “End-to-End” на оборудовании одного производителя. Альтернативные решения на разнородном оборудовании могли бы добавить проблем со сквозной совместимостью и эксплуатационными трудностями.

Другим российским оператором связи - “МТУ-Информ” был сделан выбор в пользу дальнейшей модернизации сети АТМ на коммутаторах Cisco IGX 8400 против аналогичного оборудования фирмы NewBridge, на котором была построена их сеть SDH/АТМ. На первом этапе установлены IGX 8410 для организации дальних магистральных каналов, в том числе с поставщиком услуг Интернет – MCI (США). Примечателен тот факт, что установка коммутатора Cisco IGX 8400 на магистральных и межзоновых каналах становится тенденцией у крупных операторов связи.

Из числа зарубежных компаний показательными являются:

China National Financial Data Communications Backbone Network (Китай), которая заключила контракт на построение национальной мультисервисной сети на АТМ коммутаторах Cisco IGX 8400. Весь проект предусматривает установку 200 коммутаторов IGX, которые будут объединять главные национальные банки и финансовые институты Китая.

Deutsche Post AG (Германия) выбрала в качестве базовой платформы Cisco IGX 8400 для объединения голосового трафика и потоков данных на базе АТМ технологии. Проект предусматривает поставку, инсталляцию и сервисное сопровождение свыше 200 коммутаторов Cisco IGX 8400 и 15 систем Cisco Voice Network Switch (VNS) для динамической коммутации телефонных каналов, Frame Relay и АТМ трафика через мультисервисную опорную сеть АТМ. В качестве магистральных используются совмещенные каналы Е1. Масштабируемое устройство коммутации VNS установлено из расчета на обслуживание до 30 телефонных коммутаторов с дальнейшим наращиванием по мере роста телефонного трафика. Предусмотрена компрессия телефонных каналов по стандартным алгоритмам 32-Kbps ADPCM (ITU-T G.726) и 8-Kbps CS-ACELP (ITU-T G.729a) и использование функции подавления пауз VAD. Данный проект отличается тем, что до принятия решения специалистами Deutsche Post AG было проведено тестирование различных, основанных на технологии Time Division Multiplexing (TDM), систем построения сети SDH.

Compugraf Network Services (Бразилия), являясь крупнейшим национальным оператором связи, после проведенного тестирования АТМ коммутаторов от Nortel, Newbridge, Cascade и Cisco Systems сделала свой выбор в пользу Cisco IGX 8400. Первоначально было установлено два коммутатора IGX. Сейчас сеть АТМ Compugraf Network Services включает 16 коммутаторов IGX и предоставляет следующие услуги: соединение локальных вычислительных сетей, видеоконференции, соединение АТС по схеме “каждый с каждым”, частные ISDN сети, доступ к Интернет, доступ к мэйнфреймам (SNA) IBM и виртуальные частные сети поверх маршрутизаторов Cisco Systems и сети Frame Relay. В ближайшие планы Compugraf входит инсталляция мультисервисных концентраторов Cisco MC3800 в качестве недорогих удаленных узлов доступа к АТМ сети с сохранением всех вышеперечисленных услуг.

Fleet Financial Group (США) построила корпоративную территориально-распределенную сеть АТМ на коммутаторах Cisco IGX 8400, т.к. считает одним из основных требованием к своей корпоративной сети передачи данных – надежность и доступность всех видов телекоммуникационных услуг 24 часа в сутки 7 дней в неделю и такое же сервисное обслуживание от производителя оборудования. Кратковременный сбой сети передачи данных влечет за собой большие убытки компании. Этого не обеспечивала существующая сеть SDH на базе технологии TDM, т.к. при неисправности магистрального канала восстановление работоспособности сети осуществлялось соответствующими действиями обслуживающего персонала, на что требовалось время. Корпоративная сеть, включавшая 4 коммутатора IGX, в настоящее время расширяется до 70 коммутаторов IGX 8400 и обеспечивает практически все банковские сервисы: доступ к мэйнфреймам (SNA) IBM, телефония, услуги операционных отделов банка, банкоматы (доступ в реальном времени) и финансовые информационные системы.

AvMed (США), крупнейшая медицинская компания во Флориде, использует в качестве АТМ коммутаторов корпоративной опорной сети IGX 8400. Такое решение было обосновано, кроме всего, наличием большого количества инсталлированного оборудования Cisco Systems: магистральных маршрутизаторов Cisco7500 и Cisco4500, коммутаторов Catalyst5500 в локальных сетях и различного оборудования доступа в многочисленных филиалах. Большой опыт работы технического персонала с этим оборудованием и единая программная платформа Cisco IOS на всем оборудовании Cisco обеспечили переход на АТМ сеть на базе коммутаторов IGX без дополнительных расходов на подготовку технических специалистов.

Заключение

Сети СISCO следующего поколения

Факторы развития

Изменение - это одна нескольких постоянных величин в телекоммуникационной индустрии конца 20 века. Роль телекоммуникационных сетей несомненно изменяются благодаря влиянию различных факторов. Наиболее важные из них:

Потребности. Потребители постоянно запрашивают новые типы услуг для разрешения специфичных проблем; поставщики услуг расширяют пакеты услуг для дифференциации их предложений. В обозримом будущем эта тенденция к наращивания услуг продолжится. Поставщики услуг добавляют виртуальные частные IP сети, голос поверх IP, обеспечивающий интегрированную компьютерную телефонию и другие услуги. Быстрое увеличение услуг вызывает также необходимость в увеличении полосы пропускания, по мере того, как все большее количество пользователей подключается к общедоступным сетям и все большее количество приложений становится более чувствительным к ширине полосы пропускания.

Доставка необработанной полосы пропускания. Недавние разработки в технологии DWDM позволили существенно снизить предельно высокую себестоимость сетевой полосы пропускания на интерфейсах OC-48/STM-16 и выше. DWDM системы, которые обеспечивают спектральное мультиплексирование и позволяют переносить несколько потоков (каждый из которых поддерживает высокоскоростную линию связи) по одному оптоволоконному кабелю, перевернули экономику глобальных сетей и полосы пропускания, в частности. В действительности, те поставщики транспорта, которые применили DWDM, увеличили емкость их уже имеющихся волоконных кабелей в 16-80 раз, в зависимости от системы. При этом стоимость получилась ниже, чем стоимость укладки новых кабелей.

Давление конкуренции. Появление новых участников на рынке поставщиков услуг с их конкурирующими предложениями привело к снижению цен на существующие WAN услуги. Для того, чтобы удержать сегодняшние границы цен, поставщики услуг должны предоставить дополнительные высокозначимые услуги (такие как виртуальные частные сети IP). В связи с тем, что большинство быстрорастущих приложений для предприятий основано на IP, дополнительный услугой будет являться виртуальная частная сеть IP. Увеличение конкуренции заставляет поставщиков услуг пересмотреть отношение к скорости предоставления услуг и дифференцированно подойти к этому вопросу. Для поставщика услуг важно не только то, что он первым вышел на рынок с определенной услугой. Большое значение имеет факт приведения этой услуги в действие за меньшее время, чем его конкуренты. В борьбе за приобретение потребителя WAN-услуги выиграет тот поставщик услуги, который доставит ее быстрее, чем остальные поставщики.

Cisco Systems, являясь одним из бесспорных лидеров на рынке телекоммуникаций, готова предоставить новейшие технологии и оборудование, способное учесть данные факторы, предлагает реализовывать телекоммуникационные сети нового поколения.

image20.gif (6342 bytes)

Рисунок 20. Cisco и мировой рынок оборудования ATM/FR для WAN сетей
емкость рынка: $2.8 млрд.
Источник: Vertical Systems, ATM and Frame Relay Industry Update, 1997

Сравнительно недавно компания обнародовала свою стратегию разработки высокоскоростных технологий взаимодействия оптических сетей, состоящую из пяти этапов. Выпуск устройств типа TGX 8750 и GSR 12000 соответствует ее второму этапу, направленному на создание коммутаторов и маршрутизаторов, сопрягаемых непосредственно с уровнем оптической сети, что позволило бы избежать лишних расходов и ограничений на полосу пропускания, обусловленных применением технологий мультиплексирования с временным разделением каналов (TDM) и SDH.

Пограничная сеть следующего поколения

В новом мире повышенных требований к услугам и ширине полосы пропускания, с необходимостью быстрейшей доставки и появления этих услуг у пользователя, положение пограничной сети понятно: наиболее рентабельной будет сеть с максимально гибкими услугами. Другими словами, пограничная сеть должна иметь возможность предоставить услугу высокого качества с высокой скоростью. Те поставщики услуг, которые сейчас имеют пограничную платформу, позволяющую предоставить только одну услугу, будут вынуждены разворачивать дополнительно новую, параллельную пограничную платформу для поддержки новых услуг, которые будут требоваться в будущем. В результате эти поставщики услуг понесут значительные убытки по сравнению с теми конкурирующими поставщиками, которые изначально имеют достаточно гибкие пограничные сети, имеющие возможность предоставлять более, чем одну услугу. Гибкость обслуживания в пограничной сети имеет отношение и к проблеме скорости появления услуги у потребителя.

IP играет ключевую роль в этом требовании гибкости обслуживания. Для того, чтобы увеличить общую рентабельность сети, поставщики должны предоставить услуги, основанные на IP или способные "понимать" IP, так как большинство приложений, требующих предоставления WAN услуг, используют IP. И, поскольку потребители продолжают запрашивать от своих поставщиков услуг предоставления дополнительных функциональностей, поставщики должны постоянно искать все новые и новые услуги, которые смогут дополнить и усилить приложения потребителей. Невозможно предсказать точно, какие из этих будущих услуг станут невозможными, но можно с уверенностью говорить о том, что они должны быть основанными на IP.

Поэтому Cisco уверена в том, что надежная поддерка IP на пограничных сетях будет ключевой для тех поставщиков услуг, которые желают успешно конкурировать в следующем веке.

Пограничная сеть с возможностью гибкого предоставления высокозначимых услуг имеет хорошую проблему: она быстро заполняется приносящим доход трафиком. Следовательно, пограничная платформа следующего поколения должна иметь больше коммутирующей/маршрутизирующей емкости и высокоскоростных интерфейсов, чем это требовалось для платформы, предоставляющей одну услугу.

Появление оборудования DWDM играет удачную роль. Так как технология DWDM снизила себестоимость 2.5 гигабитной полосы пропускания, и поставщик сети может заполнить эту полосу приносящим доход трафиком, появляется благоприятная возможность использовать интерфейсы OC-48c/STM-16 на сетевых элементах пограничной сети. Даже в отличных от глобальной сетях, где экономическая выгода от применения DWDM в настоящее время еще не доказана, транки OC-48c/STM-16 потребуются для соединения с высокоскоростными коммутаторами ядра.

Ядро следующего поколения

Изменение сетей ядра должно происходить несколькими ключевыми путями:

Во-первых, чтобы поддержка транспорта для трафика, предоставляемого пограничными сетями, была экономически эффективной, ядро сети должно обеспечить поддержку различных типов услуг. Само по себе ядро не вносит долю доходов, так как оно не предоставляет непосредственно услуги. Следовательно, для удовлетворения цели поставщика услуг вернуть инвестиции ядро должно быть способным транспортировать трафик IP и ATM для тех поставщиков, которые предоставляют и IP и ATM услуги. Это требует гораздо большей гибкости от платформы ядра, чем она имела в прошлом, обеспечивая транспорт для одного типа трафика. Также требуется применение дополнительного набора основанных на стандартах гибких протоколов маршрутизации, таких как Private Network-Network Interface (PNNI) для ATM-трафика и Multiprotocol Label Switching (MPLS) для трафика IP.

Во-вторых, увеличившаяся ширина полосы пропускания, используемая в пограничных сетях, вынуждает обеспечить в ядре прозрачное наращивание емкости. Категорическим является требование, по которому все изменения, связанные с эволюцией ядра (включая наращивание емкости, обслуживание, замену оборудования) не должны оказывать воздействия на доставку трафика, а значит и услуг. Потребители WAN-услуг не должны ничего знать об инфраструктуре ядра - кроме того, что оно полностью поддерживает те услуги, за которые они, потребители, платят деньги.

В-третьих, телекоммуникационная индустрия быстро движется в сторону применения оптических технологий. Cisco уверена в том, что сети ядра в 21 веке будут существенно отличаться от традиционных сетей сегодняшнего дня, частично из-за интеграции таких оптических технологий, как DWDM в платформу ядра. Имея преимущество от снижения стоимости, позволяемого такой интеграцией, поставщики услуг должны гарантировать, что их сети ядра готовы для развития, в часности, обеспечат прозрачную доставку услуг.

Итоги финансового года CISCO SYSTEMS

Источник:Телеком-Форум/Cisco Systems:

13 августа Московское представительство Cisco Systems подвело итоги 1998 финансового года, который завершился 25 июля. Собственно говоря, журналистам были сообщены лишь финансовые итоги материнской компании. Ее доход за прошедший финансовый год составил 8 456 млн дол, что на 31% превышает достижения 1997 финансового года. Прибыль достигла 1 879 млн дол. и превысила на 33% показатели прошлого года. Темпы роста как доходов, так и прибыли Cisco постепенно снижаются, что в определенной степени объясняется значительным увеличением масштабов компании за 11 лет ее существования. Стоит отметить, что по абсолютным объемам прибыли Cisco нет равных ни среди сетевых компаний, ни среди представителей пока еще более крупных компаний, действующих на рынке производства оборудования для телекоммуникационных (телефонных) операторов.

Таблица 2
Компания | Доход за II кв. 1998 г., млн дол. | Доход за II кв. 1997 г., млн дол. | При- рост, % | Прибыль за II кв. 1998 г., млн дол. | Прибыль за II кв. 1997 г., млн дол. | При- рост, %
Cisco Systems | 2390 | 1765 | 35 | 523 | 383 | 36
Lucent | 7220 | 6340 | 14 | -233 | 215 |
Nortel | 4160 | 3714 | 12 | -69 |  |
Источник: ИАЦ "Телекоммуникации" по данным Cisco и Network World
Во втором квартале 1998 г. все три компании прикупали или рассчитывались за прошлые приобретения. Тем не менее Cisco удалось положить в копилку дополнительных полмиллиарда, а ее будущим конкурентам пришлось залезать в долги.

Вот уже больше года отрасль телекоммуникаций бредит идеей объединения всех видов трафика в одной сети. Большинство аналитиков склоняются ко мнению, что коммутироваться в этой сети будут пакеты, а не каналы и базовым протоколом будет IP. Практически нерешенным остался только один вопрос: кто будет править балом на поприще обеспечения нового телекоммуникационного мира? Старые господа (поставщики АТС и каналообразующего оборудования для телефонных компаний) или какие-нибудь выскочки из производителей сетевого оборудования? Судя по иностранной печати (в России этот вопрос мало кого интересует - не до жиру, быть бы живу), большинство отдает предпочтение первым. Производители оборудования для телефонных компаний пользуются большим авторитетом за их огромный опыт по обеспечению круглосуточной работоспособности своего оборудования, да и в финансовом отношении они значительно мощнее сетевиков. То что телекоммуникационщики ничего не смыслят в IP и вообще в коммутации пакетов, особых опасений не вызывает, считается, что они спокойно могут прикупить себе специалистов из первой лиги, к которой относят поставщиков сетевого оборудования. Опыт последних месяцев, кажется подтверждает эту точку зрения: Nortel готов заплатить за Bay Networks 9,1 млрд дол. при рыночной стоимости последней на 3 млрд меньше, а Lucent предпочитает покупать поменьше, но чаще - за прошедший год поглощены Octel, Livingston, Prominet, Yurie и LANNET (подразделение компании Madge).

В свою очередь президент Cisco Джон Чамберс заявил, что он исключает любую возможность слияния с кем-нибудь из ведущих поставщиков сложных телефонных систем. Что же касается некрупных новаторов в области телефонии, то к их скупке Cisco приступила еще в декабре прошлого года, поглотив Lightspeed International, разработки которой позволят оборудованию Cisco поддерживать систему сигнализации N7. Последней по времени "жертвой" стала компания Summa Four, выпускающая программируемые телефонные коммутаторы (они используются в системах голосовой почты, голосового набора номера, а также для поддержки телефонных карточек). Как считают в Cisco, эти коммутаторы облегчат телефонным операторам переход на пакетную транспортировку речи по протоколу IP. "Мы приближаемся к порогу за которым доминирующим видом трафика становятся данные," - сказал в интервью журналу tele.com Ларри Ланг, вице-президент Cisco по работе с сервис-провайдерами. – "Самое время присмотреться к сетям передачи данных и подумать, как организовать в них телефонную связь". Джон Чамберс считает, что объединение телефонии и передачи данных знаменует собой "третий большой скачок" в сетевых технологиях. Lucent и иже с ней пытаются конкурировать в нарождающемся новом мире связи, не понимая того, что они пережитки прошлого. В отличие от них Cisco встречает наступление новой эры во всеоружии. Что же касается недостатка опыта в чистой телефонии, то он будет восполнен приобретением соответствующих специалистов. Cisco объявила, что половина ее покупок в текущем году будет напрямую связана с конвергенцией телефонных сетей и СПД.

Итак, Cisco отправляется в одиночное плавание, не слушая предостережений о том, что даже в союзе с крупным телекоммуникационным поставщиком ей было бы трудно завоевать доверие у операторов магистральных каналов связи. "Эти компании скептически относятся к большинству поставщиков оборудования передачи данных", - утверждает аналитик из Dataquest Джон Кунс.

А что думают о Cisco крупные российские операторы? Виктор Гришкевич (Ростелеком): "Однозначно сказать, что Cisco не сможет обеспечить на телефонных сетях страны ту надежность, которая предусмотрена нормативными документами, по-моему, никто не может. У нас еще нет достаточно масштабного внедрения оборудования этой компании, чтобы делать какие-то аналитические выводы. Мы работаем со всеми поставщиками: Ericsson, Siemens, NEC, Nortel и Cisco в том числе. Все познается в сравнении".


Решения Cisco IOS для сетей Novell Netware

Содержание

Предисловие

Введение

Введение в Novell Netware

Поддержка доступа к среде (Сетевые связи)

Протокол IPX (Internetwork Packet Exchange)

Протокол SAP и Novell Directory Services

Другие протоколы Netware

Решения Cisco IOS

Услуги связи (Connectivity)

Различные типы инкапсуляций LAN

Коммутируемые и виртуальные локальные сети

Соединения WAN

Интерфейс NASI (Netware Asynchronous Services Interface)

Шлюз IPX/IP Gateway

Функции обеспечения безопасности

Списки доступа IPX (IPX Access Lists)

Фильтры RIP, SAP и NetBIOS

Протоколирование нарушений списков доступа

Дополнительные функции использования списков доступа

Сервисы масштабирования

Routing Information Protocol

Протокол EIGRP (Enhanced Interior Gateway Routing Protocol)

Протокол NLSP и агрегирование маршрутов

Распространение маршрутов (Redistribution)

Конфигурирование времени обновления
и размера пакетов протоколов RIP и SAP

Направленные широковещательные пакеты NetBIOS

Протокол RSUP (Reliable SAP Update Protocol)

Туннели IPX

Сети, не содержащие серверов, и фильтрация запросов GNS

Виртуальные интерфейсы

Сервисы, повышающие эффективность использования
объединенных сетей Netware

Принцип DDR (Dial-on-Demand Routing)

Принцип Snapshot Routing (Моментальный снимок)

Плавающие статические маршруты (Floating static routes)

Механизмы IPX Watchdog и SPX Keepalive Spoofing

Сжатие заголовков IPX и данных

Протокол NHRP (Next Hop Resolution Protocol)

Производительность

Быстрая коммутация (Fast Switching)

Разделение нагрузки (Load Sharing)

Система очередей и приоритетов трафика

Функции управления

Протокол SNMP (Simple Network Management Protocol)

Просмотр содержимого SAP по имени

Поддержка Inverse ARP для сетей Frame Relay

Система учета IPX (IPX Accounting)

Утилита IPX Ping

Средства отладки

Заключение

Предисловие

Сетевая операционная система Novell Netware является одной из наиболее распространенных систем в сетях, обеспечивающих взаимодействие персональных компьютеров и других клиентов с серверами, работающими под управлением этой операционной системы. Серверы Netware предоставляют своим клиентам широкий набор сетевых услуг, включая совместное использование файлов, принтеров, управление каталогами (Directory Services), а также услуги доступа к сети Интернет. Большое количество таких серверов используются в качестве серверов приложений, обрабатывающих совместные базы данных, а также в качестве серверов Интернет и интрасетей. Общее число установленных сетей и клиентов Novell во всем мире составляет 5 и 50 миллионов соответственно.

Введение

Компания Cisco Systems занимает лидирующее положение в отрасли сетевой индустрии и является одним из основных партнеров фирмы Novell. В настоящее время пользователи корпоративных сетей нуждаются в необходимости совместной обработки информации как внутри корпорации, так и в масштабах целого государства или всего мира. Объединение территориально удаленных сетей Novell через частные и публичные сети связи, а также возможность обеспечения доступа клиентов этих сетей к ресурсам Интернет во многом определяет успех в деятельности государственных и коммерческих организаций.

Компании Cisco Systems и Novell сотрудничают между собой уже на протяжении многих лет. За это время было проведено большое количество совместных разработок в области создания и внедрения корпоративных сетей разного масштаба, основанных на ОС Netware. И хотя большинство протоколов Netware изначально разрабатывалось для небольших локальных сетей, усилия Cisco Systems в этой области позволили добавить некоторые функциональные возможности, обеспечивающие возможность функционирования этих протоколов в условиях крупных распределенных сетей.

Сетевое оборудование Cisco, включая маршрутизаторы, коммутаторы и серверы доступа, обеспечивают едва ли не наилучшие конечные решения по объединению сетей Netware. Оборудование Cisco поддерживает широкий спектр локальных связей, включая Ethernet, Fast Ethernet, Token Ring и FDDI (Fiber Distributed Data Interface). Локальные сети Netware могут объединяться между собой либо непосредственно напрямую, либо через высокоскоростные синхронные соединения (до скоростей T3/OC-1), а также через системы поставщиков сетевых услуг, основанные на X.25, Frame Relay, ISDN (Integrated Services Digital Network), ATM (Asynchronous Transfer Mode) и SMDS (Switched Multimegabit Data Service).

Устройства и решения Cisco Systems поддерживают множество уникальных функций и особенностей оригинальных протоколов Netware. Эта поддержка является частью ОС Cisco IOS™ (Internetwork Operating System) – единой программной платформы для всех устройств и сервисов компании, обеспечивающей функционирование сетевых приложений.

Cisco IOS функционирует на маршрутизаторах, коммутаторах, серверах доступа и прочих устройствах компании. Применительно к ОС Novell Netware Cisco IOS предоставляет:

  • Услуги связи
  • Ethernet, Fast Ethernet, Token Ring, FDDI, ATM
  • Несколько типов инкапсуляции пакетов для Ethernet, Token Ring и FDDI
  • Коммутируемые и виртуальные локальные сети (VLAN)
  • Поддержка связей WAN (IPXWAN 1.0, 2.0 и IPXCP)
  • Поддержка NASI (Netware Asynchronous Services Interface™)
  • Поддержка IPX/IP gateway (IPeXchange)
  • Функции безопасности и защиты данных
  • Списки доступа (Access List) для протокола IPX (Internetwork Packet Exchange)
  • Фильтры протоколов RIP (Routing Information Protocol), SAP (Service Advertising Protocol) и NetBIOS (Network Basic Input/Output System)
  • Ведение протоколов нарушений списков доступа
  • Простота использования списков доступа
  • Средства масштабирования
  • Поддержка современные протоколов маршрутизации, включая Enhanced IGRP® (Enhanced Interior Gateway Routing Protocol) и NLSP (Netware Link Services Protocol)
  • Агрегирование маршрутов NLSP (NLSP 1.1)
  • Распространение маршрутных таблиц между протоколами Enhanced IGRP, NLSP и RIP/SAP
  • Конфигурация таймеров обновлений маршрутных таблиц RIP и SAP и размеров пакетов
  • Направленное распространение широковещательных пакетов NetBIOS
  • Поддержка протокола RSUP (Reliable SAP Update Protocol)
  • Туннелирование IPX
  • Поддержка подсетей, не содержащих собственных серверов и фильтрация пакетов GNS (Get Nearest Server)
  • Поддержка виртуальных интерфейсов для соединений WAN
  • Сервисы для снижения стоимости эксплуатации
  • Маршрутизация по требованию (DDR, Dial-on-Demand Routing)
  • Маршрутизация на основе “моментального снимка” сети (Snapshot Routing)
  • Поддержка статических маршрутов
  • Поддержка протокола SPX (Sequenced Packet Exchange) и поддержка групповой передачи пакетов IPX
  • Сжатие заголовков и полей данных пакетов IPX
  • Поддержка протокола NHRP (Next Hop Resolution Protocol)
  • Обеспечение высокого уровня производительности
  • Быстрая коммутация пакетов (Fast Switching)
  • Разделение нагрузки, включая разделение нагрузки каждого узла (Per-Host Load Balancing)
  • Обработка очередей и поддержка различных приоритетов трафика
  • Функции управления
  • Поддержка протокола SNMP (Simple Network Management Protocol)
  • Поддержка индикации SAP по имени
  • Поддержка Inverse ARP (Address Resolution Protocol) для сетей Frame Relay
  • Поддержка IPX accounting
  • Наличие утилиты IPX Ping
  • Средства отладки

Следующий раздел статьи содержит некоторые базовые сведения о протоколах Novell Netware, а также описывает каждое из технологических решений, заложенных в ОС Cisco IOS.

Введение в Novell Netware

Компания Novell, Inc. разработала и представила ОС Netware в начале 80-х годов. Происхождение этой системы связано с набором сетевых протоколов XNS (Xerox Network Systems), представленных корпорацией Xerox в конце 70-х годов.

ОС Netware использует архитектуру “клиент-сервер”. Клиенты (иногда называемые рабочими станциями) запрашивают у серверов определенные услуги, такие как доступ к файлам или принтерам. Клиент-серверная архитектура Netware использует систему вызовов удаленных процедур, которые обеспечивают удаленный доступ к ресурсам, прозрачный для пользователей.

На рис. 1 показана структура протоколов Netware, протоколы доступа к среде, поддерживаемые Netware и Cisco, а также взаимосвязь между протоколами Netware и сетевой моделью OSI (Open Systems Interconnection).

image1.gif (11522 bytes)

Рис. 1. Протоколы Netware и модель OSI

Поддержка доступа к среде (Сетевые связи)

Одним из нововведений, появившихся в ОС Netware, явилась поддержка большого числа коммуникационных стандартов и протоколов доступа к среде передачи (также называемых протоколами уровня 2). В настоящее время Netware поддерживает такие стандарты, как Ethernet/802.3, Token Ring/802.5, Fast Ethernet, FDDI, ATM и PPP (Point-to-Point Protocol).

Как показано на рис. 2, Netware обеспечивает поддержку нескольких типов инкапсуляции (форматов кадров) для протоколов семейства Ethernet. В терминах ПО Cisco IOS эти типы инкапсуляции обозначаются следующим образом:

  • Novell-ether (также известный, как Novell Ethernet_802.3, 802.3 raw и Novell proprietary). Кадр включает в себя поле length, предусмотренное стандартом IEEE 802.3 (Institute of Electrical and Electronic Engineers), однако, в нем отсутствует заголовок IEEE 802.2 LLC (Logical Link Control). Этот тип инкапсуляции используется в ОС Netware версий 2.х и 3.х.
  • Sap (также известный, как Novell Ethernet_802.2). Это есть ничто иное, как стандартный формат кадров IEEE, включающий в себя заголовок 802.2 LLC. В ОС Netware 3.12 и 4.х этот тип инкапсуляции представлен как новый стандарт Novell.
  • Arpa (также известный, как Novell Ethernet_II или Ethernet версии 2), использует стандартный заголовок Ethernet 2.
  • Snap (также известный, как Novell Ethernet_SNAP) расширяет заголовок IEEE 802.2 добавлением заголовка протокола SNAP (Subnetwork Access Protocol), который обеспечивает передачу кода "encapsulation type" также, как определено в спецификации Ethernet версии 2.

image2.gif (7642 bytes)

Рис. 2. Типы инкапсуляции семейства протоколов Ethernet/802.3 в Netware

Протокол IPX (Internetwork Packet Exchange)

Протокол IPX (Internetwork Packet Exchange) является протоколом уровня 3, используемым в Novell Netware для маршрутизации пакетов в объединенных сетях. Протокол IPX характеризуется не ориентированными на соединение дейтаграммами, сходными с пакетами протокола TCP/IP (Transmission Control Protocol/Internet Protocol).

Сетевые адреса протокола IPX состоят из двух частей: адреса сети и адреса узла. Адрес (или номер) сети IPX задается администратором сети, адресом же узла обычно является MAC-адрес (Media Access Control address) сетевого интерфейса конечного узла.

Обмен таблицами маршрутизации в сетях IPX происходит по протоколу RIP, который является динамическим протоколом, работающим по алгоритму Distance Vector. Версии Netware 3.12 и 4.х используют дополнительный маршрутизирующий протокол NLSP, основанный на текущем состоянии сетевых соединений.

Протокол IPX RIP рассылает обновления маршрутных таблиц каждые 60 секунд. RIP использует сетевую задержку и количество промежуточных узлов для определения метрики маршрута и имеет ограничение на максимально допустимый маршрут – не более 16 промежуточных узлов (Hops). Несмотря на схожесть протокола Novell RIP с другими его реализациями, этот протокол не совместим с похожими протоколами других сетей, таких как TCP/IP.

ОС Netware также использует в качестве транспорта протокол TCP/IP. Для этого разработан специальный модуль операционной системы, известный как Netware/IP. В условиях Netware/IP дейтаграммы протокола IPX инкапсулируются внутрь заголовков протокола UDP (User Datagram Protocol) и в таком виде передаются по сети TCP/IP. Все аппаратные и программные средства Cisco поддерживают расширения TCP/IP, позволяющие передавать трафик Netware, инкапсулированный в пакеты IP. Целью этой статьи является раскрытие вопросов, касающихся использования ОС Netware протокола IPX на сетевом уровне.

Протокол SAP и Novell Directory Services

Протокол Netware SAP (Service Advertising Protocol) позволяет сетевым ресурсам, включая файловые серверы и серверы печати, рекламировать свои услуги в сетях Netware. Пакет SAP содержит специальный код, идентифицирующий тип услуги, предоставляемой сервером (например, код 4 соответствует файловому сервису, а код 7 – сервису печати), и сетевой адрес самого сервера. Пакеты SAP рассылаются каждым сервером сети каждые 60 секунд.

Промежуточные сетевые устройства, такие как маршрутизаторы, “слушают” пакеты протокола SAP и на основе их информации строят таблицы, содержащие сведения обо всех сетевых ресурсах. В том случае, когда клиент Novell запрашивает некий сетевой сервис, маршрутизатор посылает ответный пакет, содержащий адрес сервера, предоставляющего этот сервис. После этого клиент может взаимодействовать с сервером напрямую.

Начиная с версии Netware 4.x, компания Novell представила сервис управления каталогами NDS (Netware Directory Services), который снижает необходимость использования протокола SAP. Однако протокол SAP все же используется клиентами Netware 4.x при их начальной загрузке для определения адреса сервера NDS.

Другие протоколы Netware

Протокол SPX (Sequenced Packet Exchange) является общим для всех реализаций Netware транспортным протоколом уровня 4. Надежный, ориентированный на соединение протокол SPX (сходный с TCP) расширяет возможности протокола IPX по передаче дейтаграмм. SPX представляет собой надстройку IPX.

Клиентские оболочки Netware работают на широком спектре клиентского оборудования, включая IBM PC, Apple Macintosh и рабочие станции UNIX. Эти оболочки перехватывают запросы ввода-вывода пользовательских приложений и определяют необходимость выполнения сетевых операций для обработки этих запросов. Если необходим доступ к сети, то клиентская оболочка Netware производит преобразование запроса в сетевые пакеты и передает их протоколу IPX, который осуществляет их трансляцию по сети. В противном случае клиентская оболочка передает запрос к локальной системе ввода-вывода.

Протокол NCP (Netware Core Protocol) представляет собой набор функциональных модулей, призванных удовлетворить запросы приложений, поступающие от клиентских оболочек Netware и других удаленных клиентских процессов. Услуги, предоставляемые протоколом NCP, включают в себя доступ к файлам, принтерам, управление именами, систему учета и безопасности, а также файловую синхронизацию.

ОС Netware также поддерживает протокол сеансового уровня NetBIOS, определенный компаниями IBM и Microsoft для сетей IBM PC. Эмуляция NetBIOS позволяет приложениям IBM PC использовать интерфейс NetBIOS в сетях Netware. Пакеты NetBIOS инкапсулируются в пакеты IPX.

Решения Cisco IOS

Услуги связи (Connectivity)

Первым шагом при построении объединенных сетей является рассмотрение возможности связи между индивидуальными локальными сетями (LAN) через глобальные сети (WAN). Аппаратное обеспечение Cisco и программное обеспечение Cisco IOS обеспечивает такую возможность для всех протоколов LAN, поддерживаемых ОС Netware, включая Ethernet, Fast Ethernet, Token Ring, FDDI и ATM. Cisco также поддерживает полный набор связей WAN, включая высокоскоростные выделенные линии, PPP, X.25, Frame Relay, ISDN, ATM и SMDS.

Различные типы инкапсуляций LAN

Аппаратное и программное обеспечение Cisco поддерживает все типы инкапсуляций Ethernet/802.3, используемые ОС Netware. Оборудование Cisco может различать разные типы пакетов, маршрутизировать и коммутировать трафик IPX независимо от типа инкапсуляции.

Различные типы инкапсуляции, поддерживаемые в условиях одной сети, позволяют старым и новым версиям узлов Netware сосуществовать и взаимодействовать между собой на одном сегменте сети. Поддержка различных типов инкапсуляции позволяет снизить расходы на оборудование, уменьшить количество процедур конфигурирования и облегчить миграцию от одного типа инкапсуляции к другому.

В условиях сетей FDDI Cisco IOS обеспечивает поддержку двух стандартных типов инкапсуляции FDDI (FDDI_SNAP и FDDI_802.2). Вместе с тем, необходимо упомянуть о поддержке такой инкапсуляции IPX, как FDDI_RAW. FDDI_RAW используется такими устройствами, как мосты и коммутаторы, для объединения сетей Netware при помощи внутрифирменного протокола Novell через сети, основанные на FDDI. Пакеты FDDI_RAW могут маршрутизироваться в другие LAN или WAN или возвращаться в сети FDDI в оригинальном формате Novell.

Инкапсуляция FDDI_RAW не является официально поддерживаемым стандартом Novell, однако это можно не учитывать при проектировании коммутируемых сетей. Поддержка FDDI_RAW означает необходимость в трансляции инкапсуляции Ethernet на серверах и клиентах сети при использовании для объединения сетей магистралей FDDI.

Коммутируемые и виртуальные локальные сети

Cisco предлагает полное семейство коммутаторов локальных сетей (для пакетов Ethernet, Token Ring и Fast Ethernet) и коммутаторов ATM (для ячеек ATM), которые обеспечивают высокопроизводительные линии связи для объединения сетей Novell.

В добавление к сказанному о производительности коммутаторов необходимо отметить, что все коммутаторы обладают способностью создавать виртуальные локальные сети (VLAN). Технология VLAN позволяет сетевым администраторам логически разбивать множество конечных портов на сегменты, представляющие собой автономные виртуальные рабочие группы. Перемещения, удаления и добавления конечных пользователей автоматически отслеживаются коммутаторами, что значительно облегчает конфигурирование и поддержку сети. Логическая сегментация также предоставляет дополнительные преимущества при администрировании сетевых адресов и стратегии защиты данных и в управлении широковещательной активностью во всей сети.

Для обеспечения масштабируемости внутри крупных инфраструктур, естественно, необходимо обеспечить коммуникации между отдельными VLAN через так называемые “транковые” соединения между коммутаторами. Программное обеспечение Cisco IOS может инкапсулировать трафик IPX и другие типы трафика Netware в единые соединения с использованием протокола IEEE 802.10 или ISL (Inter-Switch Link), разработанного Cisco Systems. Использование этих протоколов позволяет создать между коммутаторами и маршрутизаторами высокоскоростных соединений, несущих в себе трафики нескольких VLAN. Необходимо отметить, что на текущий момент поддержка IPX ограничивается только инкапсуляцией novell-ether.

Соединения WAN

Компания Novell для обеспечения передачи пакетов IPX через соединения WAN с использованием PPP представляет протокол IPXWAN. Этот протокол описывает процедуры установления соединений и в некоторых случаях позволяет определить тип того или иного соединения. Кроме того, этот протокол содержит методы, позволяющие осуществлять динамическое присвоение сетевых адресов и определять метрики маршрутов для каждого интерфейса. Протокол IPXWAN необходим для обеспечения работы программного модуля Novell MPR (Netware Multiprotocol Router).

ПО Cisco IOS поддерживает обе версии протокола IPXWAN – версию 1 (RFC-1362) и версию 2 (RFC-1634). Протокол IPXWAN 2.0 содержит поддержку сетей X.25 (коммутируемые и постоянные виртуальные соединения) и сетей Frame Relay (постоянные виртуальные соединения), в отличие от протокола IPXWAN 1.0, который поддерживает только синхронные линии связи. Кроме того, IPXWAN 2.0 позволяет использовать NLSP в качестве маршрутизирующего протокола и поддерживает использование ненумерованных (unnumbered) соединений IPX.

Использование ненумерованных соединений делает конфигурирование связей WAN более простым и позволяет администраторам сетей сократить использование сетевых адресов IPX. Использование NLSP на соединениях WAN уменьшает стоимость эксплуатации этих соединений за счет исключения передачи ненужной маршрутной информации, передаваемой в противном случае через всю сеть.

ПО Cisco IOS также поддерживает протокол IPX через соединения PPP с использованием стандартного протокола IPXCP (PPP Control Protocol, RFC-1552). Протокол IPXCP позволяет соединять сети IPX через любые линии связи WAN, поддерживающие PPP, включая X.25, Frame Relay, ISDN, ATM, SDMS и высокоскоростные синхронные линии.

Интерфейс NASI (Netware Asynchronous Services Interface)

Как показано на рис. 3, сервер NASI позволяет клиентам Netware использовать асинхронные ресурсы сети, такие как модемы, без необходимости наличия этих ресурсов на самом клиентском рабочем месте.

image3.gif (8062 bytes)

Рис. 3. Использование сервера доступа Cisco в качестве сервера NASI

Сервер доступа Cisco, на котором работает ПО Cisco IOS, может выполнять функции сервера NASI для 16-битных клиентов Novell. Необходимо отметить, что работа 32-битных клиентов не поддерживается.

Благодаря поддержке NASI сетевые администраторы получают возможность централизованно управлять такими ресурсами сети, как модемные пулы, что позволит расширить сферу расположения клиентов сети и увеличить эффективность работы распределенных клиентов Netware, использующих эти ресурсы.

Шлюз IPX/IP Gateway

Шлюз IPX/IP, известный как IPeXchange и разработанный Cisco Systems, дает пользователям сетей Netware осуществлять защищенный доступ к сети Интернет, а также запускать приложения, работающие по протоколу TCP/IP, такие как программы просмотра Web (Web Browsers), Telnet и FTP (File Transfer Protocol). При использовании IPeXchange сети на основе IPX подключаются к сетям IP (например, к Интернет) задействуя всего один IP-адрес для всей локальной сети Netware. IPeXchange исключает необходимость конфигурирования и поддержки всего стека протокола TCP/IP на каждом рабочем месте и запуска маршрутизирующих протоколов IPX на уровне ядра корпоративной сети.

Возможности IPeXchange могут быть применимы как к выделенным, отдельно стоящим устройствам, так и к некоторым (по выбору администратора) серверам доступа, работающим под управлением Cisco IOS.

Функции обеспечения безопасности

По мере роста сетей Novell и их подключения к другим сетям, как частного, так и общего пользования, предотвращение неавторизованного доступа пользователей к ресурсам и конфиденциальным данным этих сетей становится все более важным.

Например, показанный на рис. 4 маршрутизатор соединяет инженерный и финансовый департаменты сети и позволяет инженерам и бухгалтерам компании обмениваться необходимой информацией. Однако следует учесть, что это соединение также позволяет рабочим станциям инженерного департамента получать доступ к конфиденциальным финансовым данным.

image4.gif (6917 bytes)

Рис. 4. Объединение различных сетей и организационной информации

Несмотря на то, что парольная защита и шифрование данных безусловно способствуют решению проблем защиты данных, ПО Cisco IOS обеспечивает некоторое количество дополнительных функций ограничения и контроля доступа на сетевом уровне. Эти дополнительные меры обеспечения защиты особенно важны в тех ситуациях, когда имеются подключения к внешним сетям или потенциальными нарушителями используются программные анализаторы, осуществляющие дешифрацию паролей и другой конфиденциальной информации, передаваемой через сеть.

Списки доступа IPX (IPX Access Lists)

ПО Cisco IOS обеспечивает сетевым администраторам возможность определения списков доступа, также известных как ACL (Access Control List). Списки доступа разрешают или запрещают обмен информацией между различными элементами сети на основе сетевых адресов отправителя и получателя, порта или протокола. Списки доступа физически предотвращают прохождение пакетов между некоторыми сетями, Устанавливая препятствия между определенными клиентами и серверами.

Списки доступа в ПО Cisco IOS для пакетов IPX могут назначаться в обоих направлениях для каждого интерфейса. Выходные списки доступа предотвращают выход трафика Netware за пределы определенного сегмента сети или запрещают его передачу другим сетям.

Входные списки доступа обеспечивают дополнительную гибкость при создании защищенных сетей IPX. Они могут использоваться для определения информации пользователя на краях сетей и построения более сложных систем firewall. Входные списки доступа также снижают загрузку на процессор за счет запрещения прохождения определенных пакетов до их обработки маршрутизатором и обеспечивают фильтрацию трафика при использовании туннельных сетей на основе инкапсуляции GRE (Generic Routing Encapsulation). Более подробно о сетях такого типа см. раздел “Туннели IPX".

Фильтры RIP, SAP и NetBIOS

Кроме управления трафиком IPX при помощи списков доступа, программное обеспечение Cisco IOS обеспечивает фильтрацию пакетов RIP, SAP и NetBIOS. Фильтрация возможна также в обоих направлениях на каждом из интерфейсов.

Фильтрация пакетов RIP обеспечивает несколько преимуществ:

  • Фильтрация некоторых маршрутов обеспечивает изоляцию некоторых сетей по выбору администратора
  • Фильтрация обеспечивает “видимость” определенных участков сети только из указанных областей сетевой системы
  • Фильтрация позволяет создать логически параллельные сетевые связи без необходимости физической изоляции сетевых соединений и участков

Фильтрация также может применяться для увеличения производительности сети за счет предотвращения попадания в соединения с ограниченной полосой пропускания неавторизованного трафика.

Трафик SAP может быть разделен по типам рекламируемых сервисов, номеру сети и по другим полям пакета SAP. ПО Cisco IOS также может фильтровать трафик NetBIOS, который инкапсулируется в пакеты IPX. Сетевой трафик может быть отфильтрован либо по именам узлов NetBIOS, либо по любой двоичной маске, накладываемой на каждый пакет NetBIOS. Сетевые администраторы могут использовать гибкие механизмы фильтрации для уменьшения размеров таблиц SAP, а также для ограничения доступа к ресурсам серверов Netware для пользователей из неавторизованных областей сети.

Протоколирование нарушений списков доступа

Программное обеспечение Cisco IOS позволяет использовать стандартные механизмы протоколирования нарушений списков доступа IPX. Нарушение протоколируется при получении первого пакета с параметрами, совпадающими с записями в списке доступа. Обновление записей производится через временные интервалы, соответствующие примерно 5 минутам.

Эта способность программного обеспечения позволяет сохранять информацию об адресах получателя и отправителя, типах протоколов (пакетов) и произведенных действиях (доступ запрещен/разрешен). Использование системы протоколирования нарушений списков доступа позволяет сетевому администратору установить в сети единую систему учета и контроля за соблюдением прав доступа с возможностью раннего оповещения о неавторизованном доступе к ресурсам сети.

Дополнительные функции использования списков доступа

ПО Cisco IOS обладает некоторыми функциями, позволяющими облегчить использование списков доступа. В списках доступа можно использовать маски сетей, что позволяет в одной записи указать сразу целый диапазон сетей, в отношении которых необходимо производить указанные санкции. Эта функция облегчает администрирование крупной сетевой системы, в которой используется иерархический подход к определению сетевых адресов. Кстати отметим, что само по себе использование такого подхода позволяет создать более наглядное представление о распределенной сетевой системе.

Общепринятые идентификационные номера протоколов используются в расширенных списках доступа. Кроме того, в таких списках доступа можно использовать имена узлов. Эта функция снижает количество процедур настройки и значительно облегчает фильтрацию пакетов IPX, RIP, SAP, NCP и NetBIOS.

Сервисы масштабирования

Объединение существующих сетей Novell в единую сетевую систему и поддержка большого числа клиентов и серверов Netware вызвали необходимость в разработке специальных механизмов, обеспечивающих масштабируемость таких сетей. ПО Cisco IOS содержит ряд специальных функций, делающих возможным создание больших объединенных сетей Novell.

Routing Information Protocol

Программное обеспечение Cisco IOS поддерживает протокол RIP, который предоставляет базовое решение по объединению сетей Netware в единую сетевую систему. Однако, достаточно частые пакеты обновлений для таблиц маршрутизации, низкий уровень сходимости при изменениях топологии сети и ограничение на 16 промежуточных узлов делает этот выбор этого решения не совсем удачным для сетевых систем, использующих каналы WAN.

Протокол EIGRP (Enhanced Interior Gateway Routing Protocol)

Одним из наиболее сильных шагов Cisco Systems в решении проблемы объединения сетей Netware явилась разработка собственной версии протокола IGRP® (Interior Gateway Routing Protocol). Кроме сетей TCP/IP протокол EIGRP обеспечивает поддержку сетей Netware и AppleTalk.

EIGRP использует алгоритм Distance Vector, однако, несмотря на это, его быстрая сходимость при изменениях сетевой топологии сравнима с протоколами, работающими по алгоритму link-state. Протокол EIGRP рассылает обновления маршрутов только в случае изменений топологии, передает только информацию об изменениях и его распространение ограничивается числом промежуточных узлов, задаваемым по желанию сетевого администратора. В результате EIGRP обеспечивает низкий уровень нагрузки на сетевые соединения, низкий уровень утилизации процессоров маршрутизаторов и умеренные требования к памяти.

В отличие от протоколов link-state EIGRP не требует наличия в сети строгой иерархической организации сетевых адресов, что позволяет сетевым администраторам более гибко объединять и расширять существующие сети. EIGRP также обеспечивает наличие у каждого маршрута нескольких метрик (задержка, полоса пропускания, надежность и текущая загрузка), что обеспечивает более точное представление о топологии сети и позволяет наиболее эффективно использовать суммарную полосу пропускания.

Использование EIGRP в больших сетях Netware может снизить общий трафик в основных магистральных соединениях на 40-50%. Многие большие публичные и частные сети Netware используют EIGRP на основных магистральных соединениях благодаря его высокой масштабируемости и производительности.

Протокол NLSP и агрегирование маршрутов

Для преодоления ограничений протокола RIP компания Novell включила в состав ОС Netware версий 3.12 и 4.х поддержку нового маршрутизирующего протокола NLSP (Netware Link Services Protocol). Протокол NLSP основан на маршрутизирующем протоколе сетей TCP/IP, известном как OSPF (Open Shortest Path First), однако происхождение этого протокола связано с протоколом IS-IS (OSI Intermediate System-to-Intermediate System).

Как любой маршрутизирующий протокол, использующий алгоритм link-state, протокол NLSP обладает низким временем сходимости. Изменения топологии сети вызывают передачу широковещательных пакетов с обновлениями маршрутной информации только один раз. NLSP требует сравнительно небольшой пропускной способности линий связи, однако его успешная работа во многом зависит от производительности маршрутизатора и может вызывать повышенные требования к памяти.

Программное обеспечение Cisco IOS поддерживает протокол NLSP, что было успешно протестировано при внедрении сетей Novell. Именно Cisco IOS является первым программным обеспечением, поддерживающим дополнительные функции этого протокола, описанные в спецификации NLSP 1.1, известными также, как агрегирование маршрутов.

Эти дополнительные функциональные возможности протокола NLSP предоставляют некоторые преимущества пользователям больших сетей IPX. Первым из них является возможность разделения сетей IPX на множество независимых областей NLSP. Ранее протокол NLSP предназначался для работы в сети, представляющей собой единую маршрутную область, что означало, что для взаимодействия маршрутных таблиц разных областей NLSP было необходимо использовать протокол RIP.

Протокол NLSP, в том виде, как его представляет Cisco Systems, позволяет на одном маршрутизаторе запускать несколько областей протокола с обеспечением обмена или “протекания” маршрутной информации между этими областями. Это позволяет создавать большие объединенные сети, используя протокол NLSP даже при помощи всего лишь одного маршрутизатора.

Как показано на рис. 5, при правильном дизайне сети и при иерархической системе распределения сетевых адресов, использование агрегирования маршрутов протокола NLSP более эффективно.

image5.gif (8805 bytes)

Рис. 5. Агрегирование маршрутов NLSP

По возможности диапазоны сетевых адресов могут быть агрегированы в одну маршрутную запись, что существенно снижает размеры маршрутных таблиц и объемы трафика, содержащего маршрутные обновления. Такой подход обеспечивает более эффективную маршрутизацию.

Распространение маршрутов (Redistribution)

Программное обеспечение Cisco IOS также обеспечивает распространение маршрутной информации между различными маршрутизирующими протоколами, такими как EIGRP, NLSP и RIP в условиях сетей Netware. Это свойство предоставляет дополнительную гибкость пользователям и администраторам сетей Novell. Распространение маршрутной информации позволяет создавать большие сети Novell с использованием сложных маршрутизирующих протоколов на уровне основных магистральных соединений и без необходимости поддержки или использования этих протоколов на пограничных устройствах сети.

Ранее, когда сети IPX дорастали до такого состояния, что протоколы RIP и SAP уже не могли их адекватно обслуживать, пользователям таких сетей приходилось выбирать между EIGRP и NLSP, учитывая те или иные преимущества каждого из этих протоколов в условиях конкретных требований. Теперь, благодаря возможности распространения маршрутов, пользователи могут выбирать маршрутизирующий протокол или их комбинацию, наиболее удовлетворяющую всем требованиям. Например, сеть IPX может быть построена с применением комбинации протоколов RIP и NLSP на уровне серверов Netware и с использованием EIGRP в качестве единого маршрутизирующего протокола на уровне соединений ядра сети.

Конфигурирование времени обновления и размера пакетов протоколов RIP и SAP

Клиенты и серверы Netware при определении доступных сервисов полагаются на пакеты обновлений протоколов RIP и SAP. Один раз в минуту протоколы RIP и SAP генерируют широковещательные пакеты, учитываемые во внутренних таблицах маршрутизации и доступных сервисов каждого узла сети. Эти пакеты обновлений вызывают некоторое снижение производительности сети, которое в случае большой сети может вызвать серьезную нагрузку на соединения уровня ядра, что в свою очередь приведет к существенному снижению производительности всей сети в целом.

ПО Cisco IOS поддерживает возможность конфигурирования временных интервалов между рассылкой таких пакетов. При соответствующей конфигурации таймеров RIP и SAP сетевые администраторы могут контролировать объем трафика, вызываемого этими протоколами и, соответственно, оказывать влияние на уровень нагрузки на соединения. Эта возможность позволяет оптимальным образом использовать суммарную полосу пропускания сети.

Кроме того, Cisco IOS позволяет изменять размеры пакетов протоколов RIP и SAP вплоть до размеров MTU (Maximum Transmission Unit). При увеличении размеров пакетов RIP и SAP общее их число снижается, что также оказывает благотворное влияние на использование полосы пропускания соединений.

Направленные широковещательные пакеты NetBIOS

Программное обеспечение Cisco IOS помогает решить проблему управления трафиком NetBIOS, инкапсулированным в пакеты IPX. Сервис имен NetBIOS основан на использовании широковещательных пакетов, которые занимают значительную часть полосы пропускания в крупных сетях. Cisco IOS обеспечивает алгоритм “all nets broadcasting”, который позволяет осуществлять эффективное распространение широковещательного трафика без образования замкнутых петель, вызывающих широковещательные штормы.

Протокол RSUP (Reliable SAP Update Protocol)

Даже при увеличении временного интервала в рассылке обновлений SAP эти пакеты продолжают оказывать существенное влияние на использование полосы пропускания соединений, в особенности это касается соединений WAN или крупных сетей Novell. Это утверждение особенно актуально в том случае, если наложенные сервисы, предоставляемые различными серверами Netware не подвержены частым изменениям.

Для решения подобной проблемы компания Cisco Systems разработала протокол RSUP (Reliable SAP Update Protocol). Использование протокола RSUP позволяет маршрутизаторам и другим устройствам, работающим под управлением Cisco IOS, поддерживать таблицы текущего состояния сетевых сервисов рассылая только те пакеты SAP, которые действительно содержат сведения об изменениях сетевых сервисов с момента последнего обновления. Протокол RSUP может работать как сам по себе, так и во взаимодействии с протоколом EIGRP.

Туннели IPX

Другой функциональной составляющей ПО Cisco IOS, разработанной с целью оптимизации клиент/серверного взаимодействия является туннелирование IPX. Туннелирование – это стандартный термин, обозначающий способ взаимодействия двух родственных сетевых сред через третью инородную среду. Туннелирование обеспечивает услуги связи для сетей Netware через частные и публичные сети, включая Интернет, даже если эти сети вообще не поддерживают протокол IPX.

ПО Cisco IOS поддерживает функции туннелирования, используя при этом инкапсуляцию GRE (Generic Routing Encapsulation, RFC-1701). Инкапсуляция GRE позволяет мультиплексировать несколько типов протоколов в единый туннель.

Пример туннелирования показан на рис. 6.

image6.gif (6553 bytes)

Рис. 6. Туннелирование с использованием GRE

Две локальные сети, использующие протокол IPX, разделены некоторой сетью, работающей по протоколу IP. При использовании GRE маршрутизаторы Cisco, находящиеся на краях этой сети (назовем ее IP WAN) могут инкапсулировать дейтаграммы IPX в пакеты IP для передачи первых через сеть IP.

Внутри туннелированных сетей сетевые устройства могут реализовывать различные протоколы маршрутизации IP и другие технологические решения, обеспечивающие управление, оптимизацию трафика IP. При этом время выбора маршрута и сходимость протоколов маршрутизации сокращается.

Добавим, что хотя трафик туннеля может проходить через большое число маршрутизаторов Cisco внутри IP WAN, протоколы маршрутизации IPX рассматривают весь туннель как одно прямое соединение между двумя маршрутизаторами. Такое решение обеспечивает функции масштабирования при использовании протокола RIP, ограниченного числом промежуточных узлов. И, наконец, необходимо отметить, что процедуры конфигурации туннеля для практически не отличаются процедур конфигурации сетевого интерфейса, что означает, что на туннель можно устанавливать списки доступа и фильтры протоколов.

Отметим, что Cisco IOS обеспечивает создание туннелей IP для передачи протокола IPX только при использовании стандартной реализации GRE. Реализация, описанная в RFC-1234, не поддерживается.

Сети, не содержащие серверов, и фильтрация запросов GNS

Cisco IOS позволяет клиентам Netware располагаться в таких сетях, где нет ни одного сервера Netware. Когда клиент Netware пытается обнаружить сервер, он посылает в сеть широковещательный запрос, называемый GNS (Get Nearest Server). Маршрутизаторы Cisco “слушают” трафик Netware, находят подходящий сервер и перенаправляют запросы GNS непосредственно к нему. Благодаря наличию возможности фильтрации запросов GNS сетевые администраторы могут исключать некоторые серверы из поля видимости клиентов, реализуя таким образом функции защиты данных. Кроме того, эта возможность позволяет повысить уровень гибкости сети.

В ответах на запросы GNS программное обеспечение Cisco IOS также может распределять клиентов по всем имеющимся в наличии серверам. Например, клиент A направляется на сервер 1, а клиент В – на сервер 2, как показано на рис. 7.

image7.gif (4594 bytes)

Рис. 7. Разделение нагрузки при обработке GNS на сегментах, не содержащих серверов

Маршрутизатор Cisco посылает ответ GNS клиенту А, в котором говорится о том, что этому клиенту надлежит взаимодействовать с сервером 1. Клиенту же В предписывается работа с сервером 2. Благодаря поддержке сетевых сегментов, не содержащих серверов Netware, а также возможности по распределению клиентов по разным серверам, ПО Cisco IOS позволяет организовать сетевое разделение нагрузки, повышающее доступность сетевых приложений и снижающее необходимость в установке большого числа локальных серверов.

Виртуальные интерфейсы

Другой функциональной возможностью Cisco IOS является наличие поддержки виртуальных интерфейсов, позволяющих создавать виртуальные соединения в сетях X.25, Frame Relay или SMDS. Эти виртуальные интерфейсы конфигурируются так же, как если бы это были разные физические интерфейсы, включая поддержку списков доступа и фильтров протоколов, параметры маршрутизирующих протоколов (например, RIP на одном виртуальном соединении и EIGRP – на другом). Эта функциональная особенность позволяет существенно увеличить уровень гибкости сетевой структуры.

Сервисы, повышающие эффективность использования объединенных сетей Netware

Соединения WAN, как правило, имеют высокую эксплуатационную стоимость и имеют ограничения по пропускной способности. Использование сервисов, повышающих эффективность использования таких соединений, является ключевым аспектом в снижении стоимости эксплуатации распределенных объединенных сетей. Программное обеспечение Cisco IOS предлагает набор функциональных возможностей, уменьшающих стоимость эксплуатации сети и, вместе с тем, обеспечивающих эффективность в ее использовании. Основной концепцией этих возможностей является использование каналов WAN только в случае необходимости. Другими словами, каналы WAN целесообразно использовать только для передачи пользовательского трафика.

Принцип DDR (Dial-on-Demand Routing)

При увеличении зоны охвата сети Netware зачастую появляется необходимость в поддержке клиентов и серверов сети, расположенных в разных географических зонах и соединяющихся с центральной сетью через внешние каналы связи. Традиционно сети WAN строились с использованием частных выделенных линий, на которых устанавливались постоянные соединения, имеющие фиксированную эксплуатационную стоимость. Сказанное также относится к постоянным виртуальным соединениям.

В целях снижения стоимости эксплуатации дорогих каналов WAN Cisco IOS предлагает использовать коммутируемые соединения с использованием принципа DDR (Dial-on-Demand Routing). С использованием DDR заказчики могут применять модемы, терминальные адаптеры ISDN или интегрированное оборудование ISDN для установления периодических, коротких по времени соединений через публичные телефонные сети или сети с коммутацией каналов.

Примером использования DDR может служить сеть, состоящая их двух серверов Netware, соединенных через ISDN. Когда клиент в одной из частей такой сети начинает передавать пакеты, адресованные другой части сети, то маршрутизатор совершает звонок ISDN для достижения удаленного сетевого сегмента и передает эти пакеты по установленному соединению. Когда трафик прекращается и истекает время ожидания следующего пакета, то маршрутизатор обрывает соединение.

Сам по себе принцип DDR обеспечивает периодическую связь между удаленными офисами. Однако, протоколы Netware RIP и SAP не предназначены для работы в таких сетевых средах, где досягаемость тех или иных участков сети не является постоянной или пропускная способность сети достаточно не велика. При использовании DDR пакеты обновлений RIP и SAP будут постоянно активизировать и удерживать в рабочем состоянии все линии связи. Если не предпринимать дополнительных шагов в ходе миграции к сетям с использованием DDR, то передача трафика Netware через линии связи WAN не принесет ожидаемого экономического эффекта.

Программное обеспечение Cisco IOS предлагает ряд решений, способствующих снижению или устранению проблем, связанных с активизацией линий связи пакетами RIP и SAP. Для небольших сетей, имеющих небольшое число серверов, необходимость в пакетах обновления маршрутов и распределения сервисов устраняется путем конфигурирования статических маршрутов и статических таблиц SAP. Это однако означает, что изменения в топологии сети не будут автоматически отражаться на тех участках, которые используют это решение. Вся ответственность за правильное функционирование сети ложится в этом случае на администратора, который в случае каких-либо изменений должен будет произвести ручную настройку параметров устройств.

Как уже отмечалось выше, сетевой администратор может увеличить временные интервалы между пакетами обновлений RIP и SAP, что позволит снизить использование полосы пропускания и частоту активизации линий связи этим типом трафика. Кроме того, фильтрация пакетов RIP и SAP позволяет передавать информацию об изменениях в сети блоками, используя линии связи WAN для передачи только той информации, которая содержит сведения о реальных изменениях, произошедших в сети с момента последнего обновления. Вмешательство администратора в этом случае все равно необходимо при изменении конфигурации сети и при управлении доступностью тех или иных сетевых ресурсов.

Следующие разделы статьи описывают дополнительные функциональные возможности Cisco IOS, которые специально разработаны для решения проблем, связанных с использованием DDR.

Принцип Snapshot Routing (Моментальный снимок)

Этот принцип маршрутизации позволяет протоколам RIP и SAP изучать конфигурацию удаленных маршрутов и сервисов динамически, причем информация о них сохраняется в соответствующих таблицах до тех пор, пока не произойдет обмена пакетами обновлений. Этот принцип маршрутизации поддерживается Cisco IOS при использовании выделенных линий связи и каналов ISDN.

image8.gif (14252 bytes)

Рис. 8. Принцип маршрутизации Snapshot Routing

Принцип “моментального снимка” (см. рис. 8) заключается в том, что удаленный маршрутизатор получает информацию о маршрутах и сервисах то время, когда линия связи активна (интервал T1). Это состояние маршрутов и сервисов сохраняется на все время, в течение которого линия связи является неактивной (интервал T2). Затем снова наступает активный период, в течение которого происходит обмен информацией об изменениях конфигурации маршрутов и сервисов.

В том случае, если за время следующего активного периода маршрутизатор не получает ни одного пакета обновлений, то через заданный промежуток времени (интервал T3) он может активизировать линию связи с тем, чтобы убедиться в наличии маршрутизатора или другого устройства на другом конце линии связи. Например, такая ситуация возможна в том случае, если телефонный номер DDR или интерфейс был временно недоступен во время активного периода.

Принцип Snapshot Routing особенно подходит к использованию в сетях ISDN для снижения суммарной стоимости соединения.

Плавающие статические маршруты (Floating static routes)

В маршрутизаторах и серверах доступа сконфигурированные вручную статические маршруты имеют больший приоритет по сравнению с динамическими маршрутами, конфигурируемыми автоматически протоколами маршрутизации. ПО Cisco IOS поддерживает дополнительный тип маршрутов, конфигурируемых напрямую – плавающие статические маршруты. Плавающий статический маршрут представляет собой так называемый “путь последнего обращения”, используемый в качестве альтернативного пути по заданному направлению в том случае, если для передачи пакетов нет динамического маршрута. Эта функциональная особенность обеспечивает определенную гибкость при создании устойчивых топологий маршрутизации.

Одним из применений плавающих статических маршрутов является создание резервных путей следования трафика при использовании DDR. Такой случай показан на рис. 9.

image9.gif (4224 bytes)

Рис. 9. Резервный путь следования трафика, использующий плавающий статический маршрут

На этом рисунке основным путем из сети 1 в сеть 2 является выделенная линия между маршрутизаторами А и В. Однако, возможен и другой путь, проходящий через коммутируемое соединение. В случае обрыва выделенной линии маршрутизатор А перенаправит весь трафик на маршрутизатор С, а тот, в свою очередь, передаст его маршрутизатору B. При восстановлении работоспособности выделенной линии динамический маршрут перекроет плавающий статический маршрут, и путь следования трафика вновь станет таким, каким он было до обрыва.

Механизмы IPX Watchdog и SPX Keepalive Spoofing

ОС Netware включает в себя специальный контрольный протокол (IPX Watchdog), производящий периодический опрос неактивных соединений с рабочими станциями и передающий серверу сообщения о сбоях этих соединений или о доступности той или иной рабочей станции. Если отчет протокола IPX Watchdog на каком-то из соединений не доступен, то сервер закрывает это соединение.

Некоторые программы, входящие в состав ОС Netware, требующие гарантированного соединения и использующие для этого систему подтверждений правильности передачи пакетов (например, Netware Remote Console [RCONSOLE], Remote Printer [RPRINTER] и Netware for SAA), работают с протоколом SPX. Устройства, находящиеся на обоих концах соединения SPX периодически посылают друг другу диагностические запросы, сохраняющие активное соединение даже в том случае, если передачи полезных данных не происходит.

Как и пакеты обновления RIP и SAP, пакеты IPX Watchdog и SPX могут вызвать постоянную активность коммутируемых каналов WAN, делая их использование неоправданно дорогим. Интервалы в передаче этих пакетов могут быть увеличены – это несколько снизит уровень использования канала. В этом плане Cisco IOS имеет возможность эмулировать оба этих протокола, снижая таким образом общее количество трафика, передаваемого через каналы WAN и предотвращая попадание этих пакетов в соединения, использующие DDR.

Маршрутизаторы и серверы доступа, работающие под управлением Cisco IOS, могут напрямую отвечать серверам Netware на рассылаемые ими запросы IPX Watchdog. Эта функциональная особенность, также известная как IPX spoofing или NCP spoofing, позволяет производить локальное разрешение запросов. Что касается функции SPX spoofing, то устройства, работающие под Cisco IOS, могут отвечать на запросы keepalive, рассылая соответствующие пакеты, как клиентам, так и серверам, обеспечивая устойчивое соединение между ними. Использование этих функциональных возможностей обеспечивает отсутствие передачи ненужного трафика по дорогостоящим каналам WAN, что позволяет существенно снизить стоимость их эксплуатации в условиях крупных распределенных сетей Netware.

Сжатие заголовков IPX и данных

ПО Cisco IOS обеспечивает сжатие данных в пакетах IPX при их передаче через сети X.25, PPP и Frame Relay. Сжатие данных позволяет уменьшить размер поля payload внутри сетевого пакета.

Cisco IOS также поддерживает механизм сжатия заголовков IPX Header Compression (CIPX), что уменьшает размеры заголовков пакетов IPX при их передаче через соединения PPP. Такое сжатие обеспечивает уменьшение размера заголовка от 30 байт до одного.

CIPX работает на соединениях PPP, использующих коммуникационные протоколы IPXCP или IPXWAN. Применение или неприменение CIPX на соединениях IPXWAN определяется автоматически, что упрощает конфигурирование таких линий связи.

Оба способа сжатия уменьшают эксплуатационную стоимость сети и повышают ее производительность за счет снижения требований к пропускной способности соединений WAN при передаче трафика Netware.

Протокол NHRP (Next Hop Resolution Protocol)

Протокол NHRP позволяет маршрутизаторам и серверам доступа динамически определять адреса уровня 2, соответствующие другим устройствам в облаке WAN. ПО Cisco IOS в настоящее время поддерживает протокол NHRP на соединениях IPX-over-ATM, SDMS и туннелях GRE.

В частично соединенных, нешироковещательных сетях с множественным доступом, таких как ATM и SDMS, множественные логические сети, организованные в облаке WAN, нуждаются в организации полного сетевого взаимодействия между собой. В таких сетевых конфигурациях пакеты могут проходить через большое число промежуточных устройств до тех пор, пока не достигнут своего назначения, а именно того маршрутизатора, который является ближайшим к сети назначения пакета.

Используя протокол NHRP, маршрутизаторы и серверы доступа получают возможность динамически узнавать адреса уровня 2 узлов, находящихся в разных частях сети. Маршрутизаторы и серверы доступа могут выбирать наиболее прямой путь следования пакетов данных в большой сети, исключая таким образом наличие ненужных промежуточных узлов на маршруте. Протокол NHRP облегчает путь перехода к распределенным коммутируемым сетям WAN и исключает необходимость во многих ручных процедурах конфигурирования устройств.

Производительность

Необходимость поддержки пиковой производительности в распределенных сетях вызвало определенные усилия разработчиков сетей в этой области. Cisco Systems предоставляет набор дополнительных функциональных возможностей аппаратного и программного обеспечения для достижения этой цели.

Быстрая коммутация (Fast Switching)

Cisco Systems внедряет высокопроизводительную аппаратуру коммутации для любого трафика, так или иначе связанного с ОС Netware. Технология Fast Switching позволяет значительно повысить скорость коммутации пакетов и снизить уровень задержек, вызываемых активным сетевым оборудованием.

Разделение нагрузки (Load Sharing)

Возможность разделения нагрузки особенно важна для сетей, передающих данные, критичные к уровню задержек. При разделении нагрузки суммарная пропускная способность сети используется более эффективно, снижается уровень задержек и возрастает скорость реакции на запросы.

Маршрутизаторы Cisco могут прозрачно использовать несколько путей следования данных между двумя узлами сети, что обеспечивает разделение нагрузки на линиях связи между двумя маршрутизаторами и узлами сети. Cisco IOS обеспечивает два подхода для организации разделения нагрузки между путями следования данных, имеющих одинаковую административную стоимость.

На рис. 10 показан пример разделения нагрузки между несколькими линиями связи.

image10.gif (2992 bytes)

Рис. 10. Разделение нагрузки между несколькими линиями связи

Два маршрутизатора соединены между собой двумя высокоскоростными выделенными линиями, что позволяет им разделять нагрузку, передавая пакеты сразу по обеим линиям связи. Если одно из соединений будет нарушено, то весь объем трафика автоматически переключится на оставшееся соединение. Таким образом, кроме более эффективного использования полосы пропускания, разделение нагрузки способствует лучшей отказоустойчивости сети.

На рис. 11 показано разделение нагрузки между несколькими путями следования трафика.

image11.gif (4091 bytes)

Рис. 11. Разделение нагрузки между несколькими путями следования трафика

Одним из возможных применений такого подхода к разделению нагрузки может служить использование алгоритма “round-robin”, при котором передача каждого следующего пакета производится по альтернативному пути, имеющему такую же административную стоимость. При этом такая передача пакетов совершенно прозрачно с точки зрения конечных узлов сети. Эта конфигурация позволяет эффективно использовать суммарную пропускную способность сети и снизить уровень задержек при передаче пакетов.

В некоторых случаях линии связи в распределенных сетях имеют сильно не одинаковые значения пропускной способности. В связи с этим традиционный подход к разделению нагрузки может привести к тому, что пакеты будут получены узлом назначения не в том порядке, в каком они были отправлены узлом-источником. В сетях IPX пакеты, полученные не в том порядке, обязательно должны быть переданы заново, что приводит к увеличению задержек при обработке запросов приложений и к увеличению суммарного трафика сети.

Для решения этой проблемы Cisco IOS предлагает механизм балансирования нагрузки по методу per-host для протокола IPX. При таком балансировании нагрузки последовательно передаваемые пакеты (или поток трафика), предназначенные для данного узла назначения, передаются по одному пути, даже если имеется альтернативный путь. Так как этот метод балансирования нагрузки посылает все пакеты, предназначенные данному узлу, по одному пути, то это гарантирует, что порядок следования пакетов не будет нарушен. Соблюдение очередности передачи пакетов значительно уменьшает количество повторных передач и, как следствие, сокращает вероятность возникновения перегрузок сети.

Балансирование нагрузки по методу per-host не гарантирует оптимально эффективное использование всех имеющихся в наличии соединений. Однако, использование разных путей для разных конечных узлов, находящихся в одном месте, позволяет достичь тех же преимуществ традиционного подхода к разделению нагрузки в плане эффективности использования соединений и повышения отказоустойчивости.

Система очередей и приоритетов трафика

Программное обеспечение Cisco IOS обеспечивает несколько методов для создания очередей для трафика IPX. Системы очередей позволяют гарантировать уровень сервиса путем создания приоритетов трафика и резервирования полосы пропускания.

Одним из методов организации очередей является приоритетная очередность (priority queuing). Этот метод основан на адресе узла IPX, сетевом адресе и идентификаторе сервиса (также называемом типом пакета или socket). Приоритетная очередность обеспечивает своевременную доставку пакетов специфического протокола или типа трафика, потому что трафик имеющий больший приоритет всегда передается в первую очередь, даже если для этого необходимо пожертвовать другим типом трафика. Приоритетная очередность используется для того, чтобы обеспечить гарантированную передачу некоторых типов трафика или всего трафика от некоторых систем, входящих в состав сети.

Другим методом организации очередей является так называемый custom queuing, который обеспечивает передачу трафика путем присвоения различных размеров очередей для разных типов сетевого трафика, причем эти очереди обслуживаются по методу round-robin. При использовании custom queuing каждому типу протокола, пользователю или приложению может быть присвоена своя особенная глубина очереди, однако ни один из типов трафика не сможет монополизировать всю доступную пропускную способность соединений. Метод custom queuing обычно применяется в тех случаях, когда необходимо обеспечить определенному типу трафика гарантированную полосу пропускания.

Третьим альтернативным методом организации очередей является weighted fair queuing, который обеспечивает наличие очередей, не требующих определенной полосы пропускания, и где имеется возможность предсказать поведение трафика. Потоки данных, характеризующиеся малой плотностью пакетов, получают предпочтение в сетевом сервисе, их доставка чаще всего осуществляется вовремя. В то же время, те потоки, которым характерна высокая плотность пакетов, используют оставшуюся емкость каналов связи, состоящую из эквивалентной или пропорциональной полосы пропускания. Метод Weighted fair queuing разделяет длинные цепочки пакетов, в которых пакеты следуют один за другим, и помещает сами пакеты в раздельные потоки, устраивая таким образом чередования потоков трафика. Метод Weighted fair queuing применяется в тех сетях, где всем узлам необходимо предоставить примерно одинаковый уровень сетевого сервиса, независимо от того, как часто тот или иной узел использует сетевые ресурсы.

Функции управления

Программное обеспечение Cisco IOS включает в себя набор инструментальных утилит, позволяющих осуществлять функции конфигурирования, мониторинга и управления сетями. Эти средства позволяют легко решать проблемы, связанные с объединением сетей Netware и могут быть жизненно важными при возникновении непредусмотренных ситуаций, возникающих при эксплуатации объединенной сети.

Протокол SNMP (Simple Network Management Protocol)

ПО Cisco IOS поддерживает соглашения Netware MIB (Management Information Base) для протокола SNMP, что позволяет администраторам сети производить следующие операции:

  • Ручное удаление соседнего маршрутизатора и всех его маршрутов из таблицы маршрутизации;
  • Просматривать все параметры интерфейсов, таки или иначе связанных с протоколом IPX, отслеживать состояние линейного оборудования, включать/выключать поддержку протокола IPX и отслеживать задержку передачи пакетов на разных участках сети;
  • Просматривать содержимое таблиц имен, соседних устройств и таблиц маршрутизации;
  • Просматривать статистическую информацию о трафике IPX, включая:
  • Общее число принятых пакетов IPX;
  • Общее количество и типы возникающих ошибок передачи;
  • Общее число принятых, отправленных и переданных широковещательных пакетов;
  • Количество отправленных и полученных эхо – пакетов;
  • Протоколирование важных операций протокола IPX, включая работу протоколов RIP, SAP, эхо – пакетов и активности маршрутизации.

Просмотр содержимого SAP по имени

Программное обеспечение Cisco IOS позволяет администраторам сети просматривать содержимое таблиц SAP по именам, что более предпочтительно, нежели просматривать идентификаторы сервисов. Благодаря тому, что обеспечивается представление конфигурации сети в более читабельном формате, упрощаются сами процедуры настройки и сопровождения сложных сетей.

Поддержка Inverse ARP для сетей Frame Relay

Cisco IOS обеспечивает поддержку запросов Inverse ARP для сетей Frame Relay. Поддержка этих запросов позволяет маршрутизаторам на сети Frame Relay автоматически определять номера DLCI (Data-Link Connection Identifier), которые обеспечат возможность определения сетевых адресов узлов сети Netware на другом конце каждого виртуального соединения. Эта функциональная возможность позволяет осуществлять автоматическое конфигурирование оборудования в сети, что значительно упрощает процедуры настройки благодаря исключению ручных операций.

Запросы Inverse ARP упрощают запуск, конфигурирование и управление в сетях Frame Relay. Ручная статическая конфигурация топологии облака Frame Relay может оказаться очень сложной для поддержки и настройки, особенно в сетях с большим количеством подключенных маршрутизаторов и коммутаторов.

Система учета IPX (IPX Accounting)

ПО Cisco IOS предоставляет возможности сбора сетевой статистики о работе протокола IPX. Система учета IPX генерирует статистические записи для каждого пакета IPX, куда включается информация об адресах отправителя и получателя, а также размер самого пакета.

Система учета IPX может применяться для организации системы оплаты сетевых соединений по количеству передаваемого трафика, а также использоваться в диагностических целях при поиске неисправностей в сети.

Утилита IPX Ping

Cisco IOS включает в себя IPX – версию известной команды ping, помогающей при поиске неисправностей в сети.

Эта команда позволяет администратору сети проверять работоспособность отдельных каналов и устройств путем посылки тому или иному узлу сетевых запросов и получения (или неполучения) ответов. Команда ping позволяет находить сбойные участки и узлы сети, вызвавшие проблемы в работоспособности всей сетевой системы. Утилита IPX ping поддерживает все стандартные соглашения Novell и может использоваться с любым сервером или клиентом Netware, а также с любым устройством как производства Cisco, так и другого производителя.

Средства отладки

В составе ПО Cisco IOS присутствует полнофункциональная команда debug, которая обеспечивает сетевым администраторам возможность отслеживания всех процессов, происходящих на маршрутизаторах, сетевых интерфейсах и в каналах связи. Поддержка средств отладки Cisco, значительно превосходящих аналоги любых конкурентов, позволяют осуществлять мониторинг, управление и поиск неисправностей в сетях Novell.

Заключение

Протоколы, используемые в ОС Novell Netware, так же, как и другие сетевые протоколы, могут транслироваться, маршрутизироваться и коммутироваться сетевым оборудованием Cisco Systems. Законченные решения Cisco для сетей Novell Netware основаны на многолетнем опыте компании, полученном при построении и управлении объединенными сетями. Многие из этих сетей занимают значительное географическое пространство, содержат тысячи серверов, клиентов, маршрутизаторов и коммутаторов, и продолжают расти.

Программное и аппаратное обеспечение Cisco обеспечивают большое количество уникальных функциональных возможностей и решений для сетей Novell Netware. Эти возможности могут использоваться как отдельно, так и в совокупности, обеспечивая создание мощных и эффективных сетевых инфраструктур, обладающих гибкостью при добавлении новых сервисов, функциональных возможностей и приложений, обеспечивающих возрастающие потребности развивающегося бизнеса.

Компания Cisco продолжает свое сотрудничество с компанией Novell и ее заказчиками с целью разработки новых современных решений, отвечающих потребностям сегодняшнего дня. Надежная поддержка компанией Cisco сетей Novell делает Cisco Systems одним из лучших стратегических партнеров для тех организаций, которые в условиях своих корпоративных сетей сделали ставку на ОС Netware.


Проектирование корпоративных сетей с многоуровневой коммутацией

Проектирование высокопроизводительных корпоративных сетей с многоуровневой коммутацией

Введение

Настоящий документ содержит краткое сравнение нескольких подходов к проектированию корпоративных внутренних сетей с многоуровневой коммутацией. Далее будет представлено более детальное описание иерархического подхода к проектированию, называемого многоуровневой коммутируемой корпоративной сетью. Многоуровневый подход к проектированию сетей обеспечивает оптимальное использование многоуровневой коммутации, что позволит создать масштабируемую, отказоустойчивую и управляемую сеть.

Независимо от того, по какой топологии построена корпоративная сеть – Ethernet или ATM (Asynchronous Transfer Mode) – применение многоуровневой модели имеет множество преимуществ. Многоуровневая кампусная сеть имеет строгое иерархическое разделение различных компонентов, что обеспечивает значительное упрощение процедур поиска и устранения неисправностей при масштабировании такой сети. Кроме того, многоуровневая модель проектирования предоставляет возможность модульности сети, что позволяет увеличивать общую производительность сети при добавлении дополнительных строительных блоков. “Интеллектуальные” службы уровня 3 обеспечивают блокировку передачи широковещательного трафика по магистралям сети (имеется в виду ядро системы). “Интеллектуальные” маршрутные протоколы уровня 3, такие как Open Shortest Path First (OSPF) и Enhanced Interior Gateway Routing Protocol (EIGRP), обеспечивают разделение потоков данных при передаче трафика по альтернативным путям и быстрое время сходимости маршрутных таблиц в ядре системы.

Благодаря тому, что многоуровневая модель проектирования подразумевает сохранение имеющейся системы внутренней адресации узлов, процесс миграции к новым технологиям и активному сетевому оборудованию максимально облегчается. Отказоустойчивость сети и быстрая сходимость маршрутных протоколов обеспечиваются за счет использования протоколов UplinkFast и Hot Standby Routing Protocol (HSRP). Масштабирование пропускной способности обеспечивается переходом с технологий Fast Ethernet и Gigabit Ethernet на технологии Fast EtherChannel и Gigabit EtherChannel соответственно. Эта модель обеспечивает поддержку всех общих кампусных протоколов.

Идеи, изложенные в настоящем документе, отражают богатый опыт, полученный при построении большого количества внутренних корпоративных сетей (интрасетей). Детализированные примеры конфигураций устройств, представленные в приложениях к настоящему документу, позволяют читателям более подробно вникнуть в суть применения многоуровневой коммутации в ядрах систем, построенных с применением технологий Ethernet или ATM LANE (LAN Emulation).

Содержание

Обсуждение вопросов проектирования кампусной сети

Плоские сети с применением мостов

Маршрутизация и масштабируемость

Коммутация уровня 2

Коммутация уровня 3

Коммутация уровня 4

Виртуальные (VLAN) и эмулированные (ELAN) локальные сети

Сравнение моделей проектирования кампусных сетей

Модель с маршрутизатором и концентратором

Модель с распространением VLAN по всему кампусу

Технология MPOA (Multiprotocol Over ATM)

Многоуровневая модель

Новое правило 80/20

Компоненты многоуровневой модели

Резервирование и разделение нагрузки

Масштабирование полосы пропускания

Управление правами доступа на уровне ядра

Расположение серверов

Ядро с применением ATM LANE

Поддержка IP Multicast

Обсуждение вопросов масштабирования

Стратегия миграции

Безопасность в многоуровневой модели

Бриджинг в многоуровневой модели

Преимущества многоуровневой модели

Приложение А. Внедрение многоуровневой модели

Ядро на основе Ethernet

Включение фермы серверов

Ядро ATM LANE

Обсуждение вопросов проектирования кампусной сети

Плоские сети с применением мостов

Первоначально кампусные сети представляли собой единую локальную вычислительную сеть (ЛВС, LAN, Local-Area Network), к которой по необходимости добавлялись новые пользователи. Эти ЛВС имели логический или физический кабель, к которому подключались все устройства сети. В случае с Ethernet имелась полоса пропускания в 10 Мбит/с, которая в равной мере использовалась всеми узлами сети. Такая ЛВС образовывала единый коллизионный домен, в котором все пакеты в равной степени обрабатывались всеми устройствами. В такой ЛВС использовался метод передачи, называемый “множественный доступ с контролем несущей и обнаружением коллизий” (Carrier Sense Multiaccess With Collision Detection, CSMA/CD). При таком подходе возникновение коллизий в таких ЛВС было обычным делом, что приводило к тому, что реальная скорость сети была значительно ниже расчетной.

При достижении максимального числа пользователей в одном коллизионном домене появлялась необходимость добавления в состав оборудования ЛВС устройств, называемых мостами (Bridge). Мост обеспечивал разделение всей ЛВС на несколько коллизионных доменов, что позволяло увеличить доступную полосу пропускания для каждого узла сети за счет сокращения количества этих самых узлов в одном коллизионном домене. Мост можно условно назвать коммутатором, работающим по принципу “store-and-forward”. Мост производит распространение широковещательных (broadcast), многоцелевых (multicast) и неизвестных одноцелевых (unknown unicast) пакетов по всем сегментам сети. Таким образом, можно сказать, что все сегменты такой сети образуют единый широковещательный домен.

Для предотвращения возникновения петель в такой сети был разработан протокол Spanning Tree Protocol (STP), обеспечивающий, кроме того, маршрутизацию потоков данных в обход сбойных элементов активного сетевого оборудования.

Ниже приведены основные характеристики широковещательного домена STP:

  • Резервные линии связи заблокированы и не несут в себе трафика данных;

  • Между различными точками сети имеются несколько альтернативных маршрутов;

  • Время сходимости протокола STP обычно составляет 40-50 секунд;

  • Широковещательный трафик уровня 2 обрабатывается каждым узлом сети;

  • Возникновение широковещательных “штормов” на уровне 2 сказывается на всем домене;

  • Локализация и устранение неисправностей требует больших затрат времени;

  • Степень защищенности данных на уровне 2 сильно ограничена.

Теоретически количество широковещательного трафика устанавливает практический предел размеров широковещательного домена. На практике же происходит так, что управление и поиск неисправностей в такой сети усложняются прямо пропорционально количеству подключенных пользователей. Одна неправильно настроенная рабочая станция может вывести из строя весь широковещательный домен на достаточно длительное время.

При проектировании сетей с использованием мостов каждый сегмент сети ставился в соответствие рабочей группе. Сервер рабочей группы располагался в том же сегменте, что и его клиенты, что обеспечивало ограничение трафика, передаваемого по всей сети. Здесь необходимо упомянуть о правиле 80/20, по которому строились такие ЛВС. Это правило гласит, что 80% трафика, генерируемого рабочей станцией, не должно выходить за пределы локального сегмента.

Маршрутизация и масштабируемость

Маршрутизатором называется пакетный коммутатор, обеспечивающий взаимодействие разных широковещательных доменов. Маршрутизаторы перенаправляют пакеты узлам сети ориентируясь на сетевые адреса, известные также как адреса доступа к среде (Media Access Control address, MAC-address). Сети с маршрутизаторами обладают лучшими возможностями по масштабированию по сравнению с сетями, построенными с использованием мостов. Это достигается за счет более интеллектуального управления трафиком. Маршрутизаторы используют маршрутные протоколы, такие как OSPF и EIGRP, которые позволяют маршрутизаторам обмениваться между собой информацией о достижимости тех или иных подсетей.

В сравнении с протоколом STP маршрутные протоколы обладают рядом преимуществ:

  • Разделение нагрузки между несколькими маршрутами с одинаковой административной стоимостью (применительно к оборудованию Cisco);

  • Обнаружение наилучшего маршрута между подсетями (имеются в виду административные установки и расчет количества метрик маршрута);

  • Меньшее время сходимости протокола при внесении изменений в топологию сети;

  • Сбор информации обо всех сетях, что обеспечивает улучшенные возможности по масштабированию.

В добавление необходимо отметить, что маршрутизаторы Cisco Systems обладают дополнительными функциями по контролю над широковещательным трафиком, что обеспечивает еще большую масштабируемость и управляемость кампусных сетей. Эти функции заложены в программное обеспечение Cisco IOS™, которое функционирует как на маршрутизаторах, так и на многоуровневых коммутаторах компании. Программное обеспечение IOS имеет наборы дополнительных функций для всех кампусных протоколов, включая:

  • TCP/IP;

  • AppleTalk;

  • DECnet;

  • Novell IPX;

  • IBM Systems Network Architecture (SNA), data-link switching (DLSw), Advanced Peer-to-Peer Networking (APPN).

В сети, использующей маршрутизаторы, вводится понятие диаметр, которое представляет собой количество промежуточных маршрутизаторов между крайними узлами сети. Как показывает практика, хорошим дизайном сети является тот, при котором это понятие является сбалансированным. На рис. 1 показана типичная иерархическая модель сети, объединяющей в себе маршрутизаторы и концентраторы-повторители (хабы). Диаметр такой сети в любом ее месте составляет 2 маршрутизатора. Расстояние от конечной станции до сервера на магистрали Fiber Distributed Data Interface (FDDI) составляет 1 маршрутизатор (хоп).

Рис. 1. Традиционная кампусная сеть с применением маршрутизаторов и концентраторов

Коммутация уровня 2

Коммутация уровня 2 представляет собой аппаратно реализованный бриджинг. В частности передача кадров осуществляется специализированным оборудованием, называемым Application-Specific Integrated Circuit (ASIC). Коммутаторы уровня 2 заменяют концентраторы-повторители в составе коммуникационных узлов кампусной сети.

Увеличение производительности систем, построенных на коммутации уровня 2, по сравнению с сетями на концентраторах, достаточно велико. Рассмотрим рабочую группу из 100 пользователей на подсети, использующей 1 разделяемый сегмент Ethernet. Средняя полоса пропускания для каждого пользователя вычисляется путем деления общей полосы пропускания на количество пользователей, т.е. 10 Мбит/с на 100 пользователей, что составляет всего 100 Кбит/с. Замена концентратора на полнодуплексный коммутатор Ethernet приведет к тому, что средняя полоса пропускания для каждого узла составит удвоенную полосу пропускания всей сети, т.е. 20 Мбит/с. Общая пропускная способность коммутируемой рабочей группы на 100 пользователей в 200 раз больше пропускной способности аналогичной разделяемой рабочей группы. Ограничивающим фактором, препятствующим достижения высокой скорости обмена данными в такой сети, является подключение сервера на скорости 10 Мбит/с. Порт коммутатора, к которому подключается сервер рабочей группы, является узким местом коммутируемой сети. Высокая производительность коммутируемых сетей может явиться достаточным требованием для тех заказчиков, которые просто хотят увеличить число рабочих мест в каждой отдельной подсети. Увеличение количества узлов в отдельных подсетях называется плоским дизайном с несколькими подсетями или логическими сетями в кампусной сетевой системе.

Однако, несмотря на все преимущества, коммутация уровня 2 имеет те же характеристики и ограничения, что и сеть с использованием мостов. Широковещательные домены по-прежнему имеют те же ограничения по масштабируемости и производительности, что и сети, основанные на бриджинге. Количество широковещательных пакетов в общем трафике увеличивается прямо пропорционально количеству конечных узлов, и все узлы сети получают и обрабатывают эти пакеты. Ограничения протокола STP по блокированным линиям связи и низкому времени сходимости также применимы к сетям с коммутацией уровня 2.

Коммутация уровня 3

Коммутация уровня 3 представляет собой аппаратную маршрутизацию. В частности, передачей пакетов занимаются специализированные устройства, т.е. ASIC. В зависимости от протоколов, интерфейсов и поддерживаемых функций коммутаторы уровня 3 могут использоваться в кампусных сетях вместо маршрутизаторов. Коммутаторы уровня 3, которые поддерживают стандартную перезапись заголовков пакетов и увеличение поля TTL (Time-To-Live) в этих заголовках мы будем называть пакетными коммутаторами уровня 3 (packet-by-packet Layer 3 switch).

Высокопроизводительная коммутация уровня 3 применяется в двух различных случаях. Коммутатор Cisco 12000 Gigabit Switch Router (GSR) применяется в целях создания сети с высокоскоростной коммутацией, ограниченной лишь способностями кабельной системы, на единой коммутирующей матрице. Семейство многоуровневых коммутаторов Catalyst® обеспечивают коммутацию уровня 3 вместе с аппаратурой ASIC, встроенной в управляющие модули Supervisor Engine. Пакетные коммутаторы Cisco соответствуют всем промышленным стандартам и могут применяться в качестве быстрых маршрутизаторов к внешним устройствам.

Коммутация уровня 3 в представлении Cisco Systems в семействе коммутаторов Catalyst объединяет в себе полную поддержку многопротокольной маршрутизации в программном обеспечении Cisco IOS и аппаратную коммутацию уровня 3. Управляющий модуль Route Switch Module (RSM) является маршрутизатором, базирующимся на ПО Cisco IOS, с таким же RISC (Reduced Instruction Set Computing) процессором, что и в функциональном модуле RSP2 в маршрутизаторах старшего класса Cisco 7500. Аппаратная коммутация уровня 3 обеспечивается аппаратурой ASIC, установленной на функциональном модуле NetFlow. Модуль NetFlow является дочерним модулем для устройства Supervisor Engine в коммутаторах Catalyst.

Коммутация уровня 4

Коммутация уровня 4 заключается в аппаратном анализе трафика, создаваемого различными типами пользовательских приложений. В потоках данных, создаваемых протоколами TCP (Transmission Control Protocol) и UDP (User Datagram Protocol), порт того или иного приложения содержится в заголовке каждого пакета. Маршрутизаторы Cisco имеют набор функций для анализа информации протоколов уровня 4, что при использовании списков доступа (Access List) позволяет управлять потоками данных. Управление потоками данных осуществляет функциональный модуль NetFlow.

Многоуровневые коммутаторы семейства Catalyst могут быть опционально сконфигурированы как коммутаторы уровня 3, так и как коммутаторы уровня 4. При работе в качестве коммутатора уровня 3 функциональный модуль NetFlow производит кэширование потоков данных исходя из адресов узлов-приемников (IP destination address), а при работе в качестве коммутатора уровня 4 кэширование базируется на адресах источника и приемника (source/destination address) и на номерах портов протокола уровня 4 (source/destination port). В связи с тем, что функциональный модуль NetFlow производит коммутацию пакетов аппаратно, то нет никакого отличия по скорости обработки данных при работе в том или ином режиме. В том случае, если соображения обеспечения безопасности и защищенности данных требуют раздельного подхода к номерам портов протоколов уровня 4 (а другими словами – есть необходимость фильтрации трафика, генерируемого разными приложениями), следует использовать коммутаторы в качестве коммутаторов уровня 4.

Виртуальные (VLAN) и эмулированные (ELAN) локальные сети

Одна из технологий, разработанных для обеспечения коммутации уровня 2 в кампусных сетях, называется технологией виртуальных локальных сетей (VLAN). Технология VLAN является одним из путей организации дополнительных логических сетей независимо от физической коммутации активного сетевого оборудования и конечных узлов. Каждая логическая сеть VLAN функционирует как отдельный широковещательный пакет и имеет характеристики, сходные с расширенной сетью с использованием мостов. Протокол STP нормально функционирует между коммутаторами, принадлежащими одной VLAN.

На рис. 2 показаны три VLAN, помеченные розовым, пурпурным и зеленым цветом. Каждое цветовое обозначение соответствует рабочей группе, каждая из которых соответствует определенной подсети:

  • Розовый (pink) – 131.108.2.0

  • Пурпурный (purple) – 131.108.3.0

  • Зеленый (green) – 131.108.4.0

Одной из технологий, обеспечивающей распространение одной VLAN по всему кампусу, называется VLAN Trunking. Каналы связи, реализующие эту технологию, называются VLAN trunk. Мы будем называть такие соединения магистральными соединениями VLAN.

Рис. 2. Технология виртуальных сетей (VLAN)

Магистральное соединение VLAN между двумя коммутаторами уровня 2 позволяет мультиплексировать трафик нескольких логических сетей в одном соединении. Магистральное соединение VLAN между коммутатором уровня 2 и маршрутизатором позволяет маршрутизатору быть подключенным сразу к нескольким логическим сетям через один физический интерфейс. На рис. 2 показано, что магистральное соединение VLAN (VLAN trunk) позволяет серверу X взаимодействовать со всеми VLAN одновременно. Линии связи, обозначенные желтым цветом на рис. 2 являются магистральными соединениями VLAN, использующими протокол ISL (Inter-Switch Link) и обеспечивающими передачу трафиков всех имеющихся VLAN (pink, purple и green).

Протоколы ISL, 802.10 и 802.1q являются описательными протоколами (tagging protocols), разработанными для обеспечения работы технологии VLAN Trunking. Здесь необходимо ввести понятие тэга VLAN. Тэг VLAN – это целое число, внедренное в заголовок кадров, передаваемых между двумя устройствами. Уникальное значение тэга при передаче трафиков разных VLAN позволяет мультиплексировать и демультиплексировать трафики этих VLAN при использовании одной физической линии.

Технология ATM LANE обеспечивает передачу трафиков нескольких логических сетей через единую коммутируемую инфраструктуру ATM. Эмулированные сети (ELAN) используют похожий принцип идентификации трафиков различных логических сетей, что и протоколы ISL, 802.10 и 802.1q и являются совместимыми с технологией Ethernet VLAN. На рис. 2 модули LANE в коммутаторах Catalyst B и C работают в качестве клиентов LANE (LEC) и обеспечивают прохождение VLAN pink, purple и green через магистраль ATM. Сервер D подключен непосредственно к ATM и является клиентом LANE для ELAN pink, purple и green. Таким образом, сервер D может напрямую взаимодействовать с узлами, входящими в состав VLAN pink, purple и green.

Технология ATM LANE эмулирует передачу широковещательного протокола Ethernet через линии ATM, ориентированные на соединение. На рис. 2 не показаны такие компоненты технологии, как LANE Configuration Server (LECS), LANE Server (LES) и Broadcast and Unknown Server (BUS), необходимые для обеспечения работы сети ATM как сети Ethernet. Функции LECS и LES/BUS поддерживаются программным обеспечением Cisco IOS, устанавливаемым на коммутаторы Cisco LightStream 1010 и Catalyst 5000 с модулем LANE, или на маршрутизатор с интерфейсом ATM.

Узлы, подключенные к Ethernet и относящиеся к разным VLAN, не могут взаимодействовать между собой. На рис. 2 клиент Z, относящийся к VLAN green, не может работать с сервером Y, относящимся к VLAN pink. Это происходит из-за того, что между VLAN pink и green нет ни одного маршрутизатора.

Сравнение моделей проектирования кампусных сетей

Модель с маршрутизатором и концентратором

На рис. 1 показана кампусная сеть, построенная по традиционной модели с маршрутизаторами и концентраторами. Устройствами уровня доступа такой сети являются концентраторы, которые представляют собой повторители уровня 1. Уровень распределения состоит из маршрутизаторов. Уровень ядра состоит из концентраторов FDDI или других концентраторов, функционирующих в качестве повторителей уровня 1. Маршрутизаторы на уровне распределения обеспечивают управление широковещательными пакетами и сегментирование сети. Каждый концентратор уровня доступа представляет собой логическую сеть или подсеть и имеет одно подключение к порту маршрутизатора. Также необходимо отметить, что несколько концентраторов уровня доступа могут каскадироваться между собой, образуя, таким образом, одну логическую сеть.

Такая модель сети обладает некоторыми возможностями масштабирования благодаря функциям маршрутных протоколов, таких как OSPF и EIGRP. Уровень распределения служит демаркационной линией между сетями уровня доступа и сетью уровня ядра. Маршрутизаторы уровня распределения обеспечивают сегментирование, что позволяет разделить как коллизионные, так и широковещательные домены. Эта модель сети достаточно разделена на составные части, чтобы обеспечить упрощение выполнения функций управления и поиска неисправностей. Эта модель также достаточно хорошо подходит для использования всех сетевых протоколов, таких как Novell IPX, AppleTalk, DECnet и TCP/IP.

Модель сети с маршрутизаторами и концентраторами конфигурируется и поддерживается напрямую благодаря ее модульности. Каждый маршрутизатор уровня распределения программируется с одинаковым набором функций. Общие элементы конфигурации могут без изменений переноситься с одного маршрутизатора на другой. Благодаря похожести конфигурации маршрутизаторов значительно упрощается выполнение функций поиска и устранения неисправностей. Пакетная коммутация уровня 3 использует набор служб, распределенных между всеми маршрутизаторами уровня распределения.

Традиционная модель кампусной сети с маршрутизаторами и концентраторами может наращиваться с целью увеличения производительности. Разделяемое пространство уровня доступа и ядра может быть переведено на коммутацию уровня 2, а уровень распределения может быть расширен для выполнения функций коммутации уровня 3 с элементами многоуровневой коммутации. Наращивание разделяемых областей сети с повторителей уровня 1 до коммутаторов уровня 2 не вызовет внесения изменений в схему адресации и логическую структуру сети, что обеспечит отсутствие необходимости внесения изменений в конфигурацию маршрутизаторов.

Модель с распространением VLAN по всему кампусу

На рис. 3 показана обыкновенная модель сети с распространением VLAN по всему кампусу.

Рис. 3. Традиционная модель сети с распространением VLAN по всему кампусу

Коммутация уровня 2 используется на уровнях доступа, распределения и ядра сети. Четыре рабочих группы, показанные на рис. 3 синим (blue), розовым (pink), пурпурным (purple) и зеленым (green) цветами распространяются между различными коммутаторами уровня доступа. Взаимодействие между рабочими группами обеспечивается маршрутизатором X, имеющим подключение ко всем четырем VLAN. Сервисы и коммутация уровня 3 сосредоточены в маршрутизаторе X. Корпоративные серверы, показанные ниже маршрутизатора, подключены раздельными логическими сетями, обозначенными черным цветом.

Физические соединения маршрутизатора X к разным VLAN заменяются одним магистральным соединением ISL (ISL trunk). Маршрутизатор X в таком варианте подключения принято называть “маршрутизатором на палочке” (router on a stick) или “одноруким маршрутизатором (one-armed router). Для разделения нагрузки можно использовать несколько маршрутизаторов, подключенных к нескольким или ко всем VLAN. Трафик между рабочими группами проходит следующий путь: сначала данные от исходящей VLAN проходят через кампус к маршрутизатору, а затем возвращаются обратно к VLAN, которой они предназначены.

На рис. 4 показан обновленный вариант сети с распространением VLAN по всему кампусу, предоставляющий преимущества многоуровневой коммутации. Коммутатор X представляет собой устройство семейства Catalyst 5000. Однорукий маршрутизатор заменен модулем RSM, а аппаратная коммутация уровня 3 выполняется функциональным модулем NetFlow.

Рис. 4. Сеть с распространением VLAN по всему кампусу с функциями многоуровневой коммутации

Корпоративные серверы в серверной ферме (server farm) могут быть подключены по технологии Fast Ethernet с пропускной способностью в 100 Мбит/с или по технологии Fast EtherChannel для увеличения полосы пропускания до 200 или 400 Мбит/с.

Эффективность работы сети, построенной по такой модели, в большой степени зависит от выполнения правила 80/20. Если 80% общего трафика сосредоточено внутри рабочих групп, то 80% пакетов коммутируются на уровне 2 от клиента к серверу. Однако, если 90% трафика следует к серверной ферме, то 90% пакетов коммутируются одноруким маршрутизатором. Масштабируемость и производительность сети, построенной по модели VLAN, ограничиваются характеристиками протокола STP, Каждая VLAN эквивалентна плоской сети с применением мостов.

Модель сети с распространением VLAN по всему кампусу обеспечивает гибкость при перемещении статически сконфигурированных конечных станций между этажами и корпусами кампусного здания. Это возможно благодаря таким решениям Cisco Systems, как VLAN Membership Policy Server (VMPS) и протоколу VTP (VLAN Trunking Protocol). Мобильные пользователи могут подключать свои мобильные компьютеры к любой конечной розетке сети в любом корпусе или на любом этаже кампусного здания. Локальный коммутатор Catalyst при подключении пользователя посылает запрос серверу VMPS для определения прав доступа этого пользователя и его принадлежности той или иной VLAN. После получения ответа сервера коммутатор Catalyst закрепляет данный порт за нужной VLAN.

Технология MPOA (Multiprotocol Over ATM)

Технология MPOA добавляет в технологию ATM LANE функции прозрачной коммутации уровня 3. При этом используется та же инфраструктура ATM, что и в случае с ATM LANE. Компоненты LECS и LES/BUS для каждой ELAN конфигурируются обычным образом. На рис. 5 показан пример небольшой кампусной сети с применением технологии MPOA.

Рис. 5. Кампусная сеть с применением MPOA

Применение технологии MPOA добавляет в инфраструктуру ATM два дополнительных компонента:

  • MPS (Multiprotocol Server) – дополнительные функции, встроенные в программное обеспечение маршрутизатора X;

  • MPC (Multiprotocol Client) – набор аппаратного и программного обеспечения на коммутаторах доступа к MPS.

При взаимодействии клиента VLAN pink с сервером в составе серверной фермы первый пакет проходит путь от MPC к MPS с использованием технологии LANE. Сервер MPS перенаправляет пакет клиенту-приемнику MPC, также используя LANE. Затем MPS выдает указание двум клиентам MPC установить прямое коммутируемое виртуальное соединение (Direct Switched Virtual Circuit, Direct SVC) между подсетью pink и подсетью, к которой подключена серверная ферма.

При использовании MPOA одноцелевые пакеты IP (IP unicast) занимают прямое соединение SVC. Многоцелевые пакеты (multicast), тем не менее, передаются северу BUS для распространения по порождающей их ELAN. Затем маршрутизатор X копирует многоцелевые пакеты на серверы BUS для каждой из ELAN, которые должны эти пакеты получить. Это определяется конфигурацией маршрутизации многоцелевого трафика на маршрутизаторе X. Далее каждый сервер BUS распространяет эти пакеты по своей ELAN.

Пакеты протоколов отличных от IP также проходят связку “LANE-маршрутизатор-LANE”, однако в этом случае не происходит установления прямого SVC. Применение дизайна MPOA должно основываться на количестве общего трафика в отношении к производительности маршрутизатора. Технология MPOA в основном применяется в сетях, где доминируют одноцелевые пакеты IP (IP unicast) и имеются магистральные соединения ATM к коммутаторам уровня доступа.

Многоуровневая модель

Новое правило 80/20

Обычное правило 80/20 лежит в основе традиционных моделей кампусных сетей, обсуждение которых представлено в предыдущих разделах документа. При использовании модели с распространением VLAN по всему кампусу локальные рабочие группы распределены по всей сети, однако, 80% трафика сети все так же сосредоточено внутри VLAN. Оставшиеся 20% трафика передаются в общую сеть или другие подсети через маршрутизатор.

Традиционная модель трафика 80/20 появилась в связи с тем, что каждый департамент или рабочая группа имела свой локальный сервер. Локальные серверы использовались в качестве файловых серверов, серверов авторизации пользователей и серверов приложений в рамках одной рабочей группы. Модель трафика 80/20 резким образом изменилась при появлении корпоративных интрасетей и приложений, опирающихся на распределенные сервисы IP.

Многие новые и существующие приложения переходят на распределенную технологию хранения и поиска данных WWW (World Wide Web). Распределение трафика в кампусных сетях приняло обратные значения, и теперь все чаще происходит ссылка на правило 20/80. При использовании правила 20/80 лишь 20% трафика концентрируются в сети рабочей группы, а остальные 80% трафика передаются в кампусную сеть.

Компоненты многоуровневой модели

Производительность многоуровневой коммутации соответствует требованиям новой модели распределения трафика 20/80. В составе коммутаторов семейства Catalyst 5000 присутствуют два компонента многоуровневой коммутации – управляющий модуль RSM и функциональный модуль NetFlow. RSM представляет собой многопротокольный маршрутизатор, работающий под управлением операционной системы Cisco IOS и выполненный в виде модуля к коммутатору. Производительность и набор функций модуля аналогичны маршрутизаторам серии Cisco 7500. NetFlow выполнен в виде дочернего модуля для управляющего модуля Supervisor Engine. NetFlow обеспечивает функции коммутации как уровня 3, так и уровня 2, обеспечивая специализированное оборудование ASIC. Необходимо отметить, что нет никаких особых преимуществ по производительности у коммутации уровня 3 перед коммутацией уровня 2 с использованием модуля NetFlow.

На рис. 6 показана простая кампусная многоуровневая сеть.

Рис. 6. Кампусная многоуровневая сеть

Здание кампуса состоит из трех корпусов – A, B и C, - соединенных между собой магистралью, называемой ядром (Core). Уровень распределения состоит из многоуровневых коммутаторов семейства Catalyst 5000. Многоуровневый дизайн сети использует преимущества коммутации уровня 2 на уровнях доступа и ядра, а на уровне распределения применяется многоуровневая коммутация. Многоуровневая модель сети позволяет сохранить существующую структуру адресации и логических сетей аналогично традиционной сети с маршрутизаторами и концентраторами. Подсети уровня доступа не выходят дальше уровня распределения. С другой стороны, подсети уровня ядра также заканчиваются на уровне распределения. Несмотря на то, что многоуровневая модель не распространяет VLAN по всему кампусу, она позволяет достичь всех преимуществ магистральных соединений VLAN. Далее мы рассмотрим, как это происходит.

В связи с тем, что коммутация уровня 3 используется на уровне распределения многоуровневой модели, здесь применимо большинство преимуществ маршрутизации. Уровень распределения формирует широковещательную границу, через которую широковещательный трафик не проходит из корпуса здания в магистраль или наоборот. Дополнительные функции Cisco IOS применимы на уровне распределения. Например, коммутаторы уровня распределения могут собирать информацию о существующих в общей сети серверах Novell Netware и отвечать на запросы GNS (Get Nearest Server), применяемые в сетях Netware. Другим примером может служить функция распространения сообщений протокола DHCP (Dynamic Host Configuration Protocol) от мобильных станций IP к серверам DHCP.

Другим набором функций Cisco IOS, включенным в состав программного обеспечения многоуровневых коммутаторов уровня распределения является LAM (Local Area Mobility). Технология LAM применяется в тех кампусных сетях, где не внедрены протокол и службы DHCP для того, чтобы позволить статически сконфигурированным конечным станциям перемещаться внутри кампуса. Суть работы LAM заключается в том, что адреса мобильных узлов включаются непосредственно в таблицы маршрутизации отдельными маршрутами.

Программное обеспечение Cisco IOS содержит множество вспомогательных функций по обеспечению стабильности, масштабируемости и управляемости корпоративных сетей. Эти функции применимы ко всем сетевым протоколам, встречающимся в кампусных сетях, включая DECnet, AppleTalk, IBM SNA, Novell IPX, TCP/IP и многие другие. Все эти функции можно охарактеризовать одним словом – внешние функции (out of the box). Внешние функции применяются для работы всей сети. Они являются противоположностью внутренних характеристик (inside the box), которые включают в себя производительность и плотность портов устройства. Внутренние характеристики применимы к отдельно взятым устройствам. Внутренние характеристики оказывают небольшое влияние на стабильность, масштабируемость и управляемость корпоративных сетей.

Устойчивость многоуровневой модели сети обуславливается ее иерархичностью и модульностью. Иерархичность модели заключается в том, что отдельные ее компоненты можно рассматривать и специализировать независимо от других. Модульность же определяется тем, что каждая часть модели внутри определенного уровня выполняет сходные логические функции. Отдельные преимущества, присущие различным технологиям, могут быть добавлены в состав сети, не оказывая влияния на логическую структуру модели. Например, топология Token Ring на отдельных участках сети может быть заменена топологией Ethernet. FDDI можно заменить на коммутируемый Fast Ethernet. Вместо концентраторов можно установить коммутаторы уровня 2. Вместо Fast Ethernet можно использовать ATM LANE в качестве магистральных и прочих соединений. ATM LANE можно представить в виде Gigabit Ethernet и т.д. Таким образом, можно утверждать, что модульность обеспечивает миграцию и интеграцию существующих технологий передачи настолько легко, насколько это возможно.

Другим ключевым преимуществом модульного дизайна сети является то, что каждое устройство внутри определенного уровня программируется аналогично другим устройствам того же уровня и выполняет сходные задачи, что, в свою очередь, значительно упрощает процесс конфигурации. Функции поиска и устранения неисправностей также в значительной мере облегчаются при использовании модульного дизайна сети.

На уровне доступа подсети соответствуют разным VLAN. VLAN могут ограничиваться одним коммутатором, а могут и быть представленными на нескольких устройствах. Если на уровне доступа используются коммутаторы семейства Catalyst 5000, то технология VLAN Trunking обеспечит все необходимые функции для гибкого распределения VLAN между несколькими коммутаторами. В примерах конфигураций, которые будут показаны далее, мы продемонстрируем коммутатор, относящийся к двум VLAN, и как этот факт обеспечивает разделение нагрузки и быстрое восстановление работоспособности после сбоев на этапе взаимодействия уровней распределения и доступа.

В самом простом случае уровень ядра сети можно рассматривать как одну логическую сеть или VLAN. В наших примерах мы рассмотрим уровень ядра как единую коммутируемую инфраструктуру уровня 2, не имеющую петель. Это обеспечит такое полезное свойство, как отсутствие необходимости использования протокола STP на уровне ядра сети. Вместо этого мы рассмотрим вопросы, касающиеся разделения нагрузки и быстрой сходимости маршрутных протоколов уровня 3, таких как OSPF и EIGRP, обеспечивающих быстрое определение оптимальных маршрутов и восстановление после сбоев в основной магистрали сети (backbone). Функции поиска оптимальных маршрутов и восстановления после сбоев в многоуровневой модели выполняются на уровне распределения.

Резервирование и разделение нагрузки

Коммутатор уровня распределения, показанный на рис. 6, демонстрирует точку сбоя в строительном блоке сети. Одна тысяча пользователей, расположенных в корпусе A, в случае сбоя электропитания потеряет соединение с основной магистралью сети. Если произойдет сбой соединения между коммутатором уровня распределения и уровня доступа, то соединение с основной магистралью сети потеряют 100 пользователей, расположенных на этажах корпуса. Рис. 7 показывает многоуровневый дизайн, позволяющий найти выход из такой ситуации.

Рис. 7. Избыточность в многоуровневой кампусной сети

Многоуровневые коммутаторы A и B обеспечивают резервирование соединений с доменом “North”. Дополнительные линии связи соединяют каждый коммутатор уровня доступа с коммутаторами A и B. Резервирование на уровне ядра сети обеспечивается установкой двух или более коммутаторов Catalyst. Резервные линии связи от уровня распределения обеспечивают отказоустойчивость и разделение нагрузки по параллельным маршрутам.

Резервные линии связи соединяют коммутаторы уровня доступа с парой коммутаторов уровня распределения. Быстрое восстановление после сбоя на уровне 3 обеспечивается протоколом HSRP (Hot Standby Router Protocol), разработанным фирмой Cisco Systems. Два коммутатора уровня распределения совместно реализуют функции основных маршрутизаторов HSRP для всех узлов IP в корпусе здания. Быстрое восстановление после сбоя на уровне 2 обеспечивается функцией UplinkFast, также являющейся разработкой Cisco Systems. Функция UplinkFast работает на основе быстросходящегося алгоритма, который обеспечивает переключение потока данных со сбойной линии связи на резервную в течение 3 секунд.

Разделение нагрузки внутри ядра системы обеспечивается “интеллектуальными” маршрутизирующими протоколами уровня 3, встроенными в ПО Cisco IOS. На рис. 7 показаны четыре возможных маршрута для связи между двумя любыми корпусами здания. Например, для связи между доменами North и West могут использоваться маршруты AXC, AXYD, BYD и BYXC. Эти четыре маршрута уровня 2 эквивалентны маршрутам уровня 3 благодаря маршрутизирующим протоколам. Следует отметить, что все пути от доменов North, West и South до основной магистрали сети проходят через один логический транзитный узел (single logical hop). ПО Cisco IOS обеспечивает разделение нагрузки по шести административно эквивалентным маршрутам для протокола IP и для большего количества маршрутов для других протоколов.

Рис. 8 иллюстрирует отказоустойчивую многоуровневую сеть, в которой присутствуют фермы корпоративных серверов (Enterprise Server Farm).

Рис. 8. Многоуровневая сеть с фермами корпоративных серверов

Ферма корпоративных серверов выделена в модульный строительный блок, использующий многоуровневую коммутацию. Магистральное соединение A (Gigabit Ethernet) обеспечивает передачу трафика между серверами. Магистральное соединение B (Fast EtherChannel) обеспечивает передачу трафика в ядре системы. Весь межсерверный трафик не выпускается в основную магистраль сети, что имеет свои преимущества в плане производительности и защищенности данных. Корпоративные серверы используют быстрые функции резервирования по протоколу HSRP между коммутаторами X и Y. Права доступа к серверной ферме могут контролироваться списками доступа (access list) на коммутаторах X и Y.

На рис. 8 для большей понятности коммутаторы уровня 2 V и W в ядре сети показаны отдельно от коммутаторов X и Y. Для сети такого размера коммутаторы V и W могут быть объединены с коммутаторами X и Y.

Помещение серверов в отдельную ферму также предотвращает проблемы, связанные с перенаправлением пакетов IP при выборе оптимального основного маршрутизатора, которые возникают при подключении серверов непосредственно к основной магистрали сети (рис. 7). В частности, протокол HSRP не применяется для корпоративных серверов в сетях, аналогичных сети на рис. 7; они используют протоколы ARP (Address Resolution Protocol), IRDP (Internet Router Discovery Protocol), GDP (Gateway Discovery Protocol) или RIP (Routing Information Protocol) для распространения маршрутных таблиц.

Рис. 9 иллюстрирует работу протокола HSRP между двумя коммутаторами уровня распределения. Конечные узлы сети подключены к портам коммутаторов уровня доступа.

Рис. 9. Резервирование по протоколу HSRP

Четные подсети соответствуют четным VLAN, нечетные подсети – нечетным VLAN. Основным HSRP коммутатором для четных подсетей является коммутатор X, и основным HSRP коммутатором для нечетных подсетей является коммутатор Y.

Соответственно, коммутатор X является резервным для нечетных подсетей, а коммутатор Y является резервным для четных подсетей. Договоримся, что маршрутизатор по умолчанию (параметр Default Gateway) для всех конечных узлов всегда имеет адрес узла 100, т.е. для подсети 15.0 адрес основного маршрутизатора будет 15.100. Если маршрутизатор 15.100 будет по какой-либо причине отключен, то коммутатор X примет адрес 15.100, а также MAC адрес HSRP в течение 2 секунд, как показано в примере конфигурации, представленной в приложении A.

Рис. 10 иллюстрирует разделение нагрузки между уровнями доступа и распределения при использовании протокола ISL VTP.

Рис. 10. Разделение нагрузки с использованием VTP Trunking

Мы имеем VLAN 10 и 11, расположенные на коммутатору A, и VLAN 12 и 13, расположенные на коммутаторе B. Каждый коммутатор уровня доступа имеет два магистральных соединения с уровнем распределения. Протокол STP блокирует резервные соединения. Эти соединения показаны на рисунке буквами B. Основные соединения будут передавать трафик. На рисунке они обозначены буквами F. Разделение нагрузки будет происходить за счет того, что одни соединения будут передавать трафик четных VLAN, а другие – нечетных.

На коммутаторе A левое соединение отмечено как F10, что означает, что по этому соединению передается трафик VLAN 10. Правое же соединение отмечено как F11, что, в свою очередь, означает, что по этому соединению передается трафик VLAN 11. Левое соединение также имеет пометку B11, что означает, что этот путь следования трафика VLAN 11 заблокирован. Такая же история с правым соединением. Такая конфигурация делает коммутатор X корневым мостом (STP root bridge) для четных VLAN, а коммутатор Y является корневым мостом для нечетных VLAN. Для рассмотрения команд конфигурации см. Приложение A. Рис. 11 иллюстрирует сеть, показанную на рис. 10, после сбоя соединения, обозначенного “крестом”.

Рис. 11. Технология VLAN Trunking с восстановлением UplinkFast

UplinkFast переключает состояние левого соединения: оно становится активным для передачи трафика VLAN 11. Трафик коммутируется при необходимости через соединение Z (Fast EtherChannel). Соединение Z является резервным путем следования пакетов уровня 2 для всех VLAN домена, а также по нему проходит некоторое количество трафика, возникающего при балансировании нагрузки между коммутаторами X и Y. При использовании обычного протокола STP время его сходимости составляет 40-50 секунд. При использовании UplinkFast переключение потока данных на резервное соединение происходит примерно за 3 секунды. Конфигурация устройств показана в приложении A.

Масштабирование полосы пропускания

Соединения Ethernet в сети, построенной на основе многоуровневой модели, могут масштабироваться несколькими путями. Ethernet может быть заменена на Fast Ethernet. Fast Ethernet может заменяться на Fast EtherChannel, Gigabit Ethernet или Gigabit EtherChannel. Коммутаторы уровня доступа могут входить в состав нескольких VLAN, будучи подключенными к ним несколькими линиями связи. Мультиплексирование VLAN по протоколу ISL может происходить не по одному, а по нескольким физическим соединениям.

Технология Fast EtherChannel объединяет две или четыре линии связи Fast Ethernet в один высокоскоростной канал. Технология Fast EtherChannel поддерживается маршрутизаторами семейства Cisco 7500 с ПО Cisco IOS, начиная с версии 11.1.14CA. Технология также поддерживается интерфейсными модулями Fast EtherChannel и управляющими модулями Supervisor Engine II и Supervisor Engine III для коммутаторов семейства Catalyst 5000. Технология анонсирована несколькими производителями оборудования, включая Adaptec, Auspex, Compaq, Hewlett-Packard, Intel, Sun Microsystems и Znyx. При помощи каналов Fast EtherChannel корпоративные серверы могут быть подключены к магистралям ядра сети на скоростях 400 и 800 Мбит/с.

Рис. 12 показывает три различных способа масштабирования пропускной способности между уровнями доступа и распределения.

Рис. 12. Способы масштабирования пропускной способности

В конфигурации, помеченной как “A - Best” все VLAN комбинируются в одном канале Fast EtherChannel, в котором функционирует протокол ISL. В конфигурации “B-Good” используется комбинация сегментированных магистральных соединений ISL. В конфигурации “C-OK” используется простая сегментация.

Везде, где это возможно, лучше использовать вариант A и потому, что технология Fast EtherChannel предоставляет наиболее эффективное использование полосы пропускания за счет мультиплексирования всех VLAN в одно логическое соединение. Если интерфейсные модули Fast EtherChannel отсутствуют в составе активного сетевого оборудования, то рекомендуется использовать вариант B. Если ни Fast EtherChannel, ни протокол ISL не поддерживаются аппаратным и программным обеспечением сети, то придется остановиться на варианте C. При использовании простой сегментации каждая VLAN использует отдельное соединение. Для достижения производительности, обеспечиваемой вариантами A и B, может возникнуть использования большего количества интерфейсных портов.

Увеличение пропускной способности магистралей ATM на уровне ядра возможно путем добавления дополнительных линий связи OC-3 или OC-12. “Интеллектуальную” маршрутизацию в этом случае будет обеспечивать протокол PNNI (Private Network-to-Network Interface), реализующий функции разделения нагрузки и восстановления после сбоев.

Управление правами доступа на уровне ядра

Благодаря коммутации уровня 3 на уровне ядра сети имеется возможность конфигурировать ядро системы либо как одну логическую подсеть, либо как несколько таких подсетей. Выбор того или иного варианта зависит от требований заказчика. Технология VLAN может использоваться для создания различных логических сетей, которые могут применяться для разных целей. Одно ядро IP создается на реализации функций управления сетью, а другое содержит в себе все корпоративные серверы. Для каждой логической подсети уровня ядра применяются разные правила разграничения прав доступа. Правила разграничения прав доступа задаются списками доступа (access list) на уровне распределения сети. В этом случае доступ к подсети, содержащей управляющий трафик, находится под постоянным контролем.

Другой причиной, вызывающей необходимость разделения ядра на логические части, является наличие более чем одного сетевого протокола. В части подключения корпоративных серверов создаются разные VLAN для протоколов IP, IPX, DECnet и т.д. Логическое разделение ядра сети может быть связано с требованиями по защите данных, когда для каждого протокола необходимо создать “физически” отдельную сеть. На рис. 13 показана сеть, физически разделенная при помощи двух коммутаторов.

Рис. 13. Логическое или физическое разделение ядра

VLAN 100 на коммутаторе V соответствует подсети IP с адресом 131.108.1.0, к которой подключена серверная ферма, обслуживающая службы WWW. VLAN 200 на коммутаторе W соответствует подсети IPX с адресом BEEF0001, к которой подключена серверная ферма, состоящая из серверов Novell Netware.

Естественно, что чем проще топология ядра системы, тем лучше это сказывается на всей сети в целом. В таком варианте необходимо минимальное количество VLAN и ELAN. Обсуждение вопросов масштабирования, связанных с установкой большого числа коммутаторов уровня 3, подключенных ко многим логическим подсетям, мы рассмотрим позднее в разделе “Обсуждение вопросов масштабирования” настоящего документа.

Расположение серверов

Наиболее общим решением этого вопроса в корпоративных сетях является централизация серверов. В некоторых случаях сетевые службы концентрируются на едином сервере. В других случаях все серверы устанавливаются в специальных серверных или аппаратных помещениях для обеспечения физической безопасности и простоты управления. В то же время все чаще рабочие группы или индивидуальные пользователи публикуют свои собственные страницы WWW локально и делают их доступными из всей сети.

При использовании централизованных серверов весь трафик “клиент-сервер” проходит через одно промежуточное устройство (hop) от подсети уровня доступа до подсети уровня ядра. Контроль за разграничением прав доступа ведется с помощью списков доступа (access list) на уровне распределения. На рис. 14 сервер W подключен к подсети уровня ядра по топологии Fast Ethernet.

Рис. 14. Подключение серверов в многоуровневой модели

Сервер X подключен к подсети уровня ядра с использованием технологии Fast EtherChannel. Как уже упоминалось, серверы, подключенные непосредственно к ядру системы, используют протоколы ARP, IRDP, GDP и RIP для распространения своих маршрутных таблиц. Протокол HSRP не используется в подсетях уровня ядра, потому что соединения всех путей следования трафика реализуются коммутаторами уровня распределения.

Корпоративные серверы Y и Z подключены в составе серверной фермы, представляющей собой строительный блок сети с многоуровневой коммутацией внутри. Сервер Y подключен по технологии Fast Ethernet, а сервер Z – по Fast EtherChannel. Контроль над разграничением прав доступа к этим серверами выполняется при помощи списков доступа на коммутаторах уровня ядра. Другим большим преимуществом распределения серверов является возможность реализации между ними протокола HSRP, обеспечивающего резервирование и восстановление после сбоев. Модель с распределением серверов также позволяет не выпускать межсерверный трафик в основные магистральные соединения ядра сети. Пример создания фермы серверов приведен в приложении A.

Сервер M подключен к рабочей группе D, представляющей собой одну VLAN. Этот сервер подключен к порту коммутатора уровня доступа по технологии Fast Ethernet. Это связано с тем, что большая часть трафика, связанная с этим сервером, является локальной для данной рабочей группы. Это следует из правила 80/20. При необходимости доступ к серверу M из общей сети может быть закрыт путем создания соответствующего списка доступа на коммутаторе H.

Сервер N подключается к коммутатору уровня распределения H. Этот сервер имеет соединения с клиентами VLAN A, B, C и D. Прямой коммутируемый путь уровня 2 между сервером N и клиентами VLAN A, B, C и D может быть установлен двумя способами:

  • Установка в сервер четырех сетевых адаптеров (NIC, Network Interface Card), непосредственно связанных с каждой VLAN;

  • Установка в сервер одного NIC, поддерживающего протокол ISL. При таком подключении сервер получит соединения со всеми четырьмя VLAN через магистральное соединение VLAN (VLAN Trunk).

Доступ к серверу N из общей сети по мере необходимости может быть запрещен или ограничен путем создания соответствующего списка доступа на коммутаторе H.

Ядро с применением ATM LANE

На рис. 15 показан вариант многоуровневой сети с ядром, построенным с применением технологии ATM LANE.

Рис. 15. Многоуровневая сеть с ядром ATM LANE

Сети ATM являются хорошей альтернативой для тех заказчиков, которым необходимо обеспечить в своих сетях гарантированное качество сервиса (QoS, Quality-of-Service). Голосовые и видео приложения могут использовать такие функции сетей ATM, как очередность по заполнению (Per-Flow Queuing), которые предоставляют возможность передачи данных реального времени без задержек.

Каждый многоуровневый коммутатор Catalyst 5000 на уровне распределения комплектуется интерфейсным модулем LANE. Этот модуль выполняет функции LEC, благодаря которым коммутаторы уровня распределения получают возможность подключения к ядру сети. Модули LANE имеют резервные интерфейсы OC-3, которые называются Dual-PHY. На рис. 15 сплошными линиями показаны основные линии связи, а пунктирными – линии, находящиеся в режиме “горячего” резервирования (hot-standby link).

В ядре ATM находятся два коммутатора LightStream 1010. Маршрутизаторы и серверы с “настоящими” (native) ATM-интерфейсами подключены непосредственно к портам ATM уровня ядра. Корпоративная ферма серверов подключена к многоуровневым коммутаторам Catalyst X и Y. Эти серверы могут иметь подключения либо по Fast Ethernet, либо по Fast EtherChannel. Эти коммутаторы Catalyst 5000 также комплектуются интерфейсными модулями LANE для обеспечения взаимодействия с серверами, подключенными по Ethernet, через ядро ATM ELAN.

В зависимости от требований заказчика магистральные соединения между коммутаторами LightStream 1010 выполняются либо линиями OC-3, либо линиями OC-12. Протокол PNNI на этих соединениях обеспечивает выполнение функций разделения нагрузки и “интеллектуальной” маршрутизации между коммутаторами ATM. Функции “интеллектуальной” маршрутизации необходимы для обеспечения масштабируемости при увеличении числа коммутаторов ATM. На уровне ядра не используется протокол STP. На уровне 3 функции “интеллектуальной” маршрутизации выполняются протоколами типа OSPF или EIGRP, которые занимаются вопросами обнаружения оптимальных маршрутов следования трафика и разделения нагрузки между коммутаторами уровня распределения.

Cisco Systems разработала протокол SSRP (Simple Server Redundancy Protocol) для обеспечения резервирования таких важных компонентов LANE, как LECS и LES/BUS. Протокол SSRP доступен в маршрутизаторах семейства Cisco 7500, коммутаторах семейства Catalyst 5000 и на коммутаторах LightStream 1010 и совместим LEC, поддерживающими спецификацию LANE 1.0.

Интерфейсные модули LANE для коммутаторов Catalyst 5000 являются достаточно эффективными серверами BUS с широковещательной производительностью в 120 тысяч пакетов в секунду. Это достаточный уровень производительности для больших кампусных сетей. В сети, показанной на рис. 15, мы расположили основной сервер LES/BUS на коммутаторе X, а резервный – на коммутаторе Y. В небольших сетях протокол SSRP обеспечивает переключение с основного LES/BUS на резервный в течение нескольких секунд. В крупных сетях эта процедура может занять значительное время – до нескольких минут. В крупных сетях зачастую на уровне основных магистралей используются двойные ELAN, что обеспечивает быструю сходимость маршрутизирующих протоколов при выходе из строя одного из серверов LES/BUS.

В нашем примере на уровне магистралей ядра сети созданы две ELAN – Red и Blue. Если сервер LES/BUS, обслуживающий ELAN Red по какой-либо причине будет недоступен, то трафик достаточно быстро переключится на ELAN Blue и будет проходить по ней до тех пор, пока работоспособность ELAN Red не будет восстановлена. После восстановления ELAN Red многоуровневые коммутаторы на уровне распределения восстановят соединения между собой через ELAN Red и заново запустят режим разделения нагрузки между ELAN Red и ELAN Blue. Этот процесс выполняется маршрутизирующими протоколами.

Благодаря тому, что коммутаторы LightStream 1010 занимают центральное положение в сети, то база данных LECS должна быть сконфигурирована именно на них. При стабильной работе ELAN на центральный процессор LECS не оказывается существенной нагрузки. Обращение к серверу LECS происходит только при подключении к ELAN нового клиента LEC. В связи с этим мы рассмотрим некоторые вопросы производительности относительно расположения основного и резервного сервера LECS. Хорошим выбором для основного сервера LECS является маршрутизатор серии Cisco 7500 с непосредственным подключением к ядру ATM, который не будет испытывать перегрузок при возникновении трафика, генерируемого при сбое серверов LES/BUS.

На рис. 16 показано альтернативное решение ядра LANE с применением коммутаторов Catalyst 5500.

Рис. 16. Сеть с ядром ATM LANE на основе коммутаторов Catalyst 5500

В этом примере коммутаторы Catalyst 5500 работают в качестве коммутаторов ATM. Это возможно благодаря управляющему модулю ASP (ATM Switch Processor). Они сконфигурированы как LEC с добавлением интерфейсных модулей OC-12 LANE/MPOA. Также они представляют собой коммутаторы кадров Ethernet с необходимым количеством интерфейсных модулей Ethernet и Fast Ethernet. Ферма серверов обладает дополнительной многоуровневой коммутацией. Коммутаторы Catalyst 5500 объединяют функциональные возможности коммутаторов LightStream 1010 и Catalyst 5000 в одном шасси. В приложении A показан пример конфигурации ядра ATM с применением коммутаторов Catalyst 5500.

Поддержка IP Multicast

Приложения, использующие IP Multicast, составляют пока небольшую, но постоянно растущую часть корпоративных интрасетей. Такие приложения как IP/TV, Microsoft NetShow и NetMeeting находятся на стадии испытаний и внедрения. Для обеспечения эффективной поддержки IP Multicast необходимо рассмотреть следующие аспекты:

  • Многоцелевая маршрутизация (Multicast Routing), протокол PIM (Protocol Independent Multicast) в режимах плотного и разреженного трафика (Dense Mode и Sparse Mode);

  • Подключение клиентов и серверов к группам многоцелевой рассылки по протоколу IGMP (Internet Group Management Protocol);

  • Ограничение многоцелевых деревьев (Multicast Tree) при помощи протокола CGMP (Cisco Group Management Protocol) или при распространении трафика протокола IGMP;

  • Производительность коммутаторов и маршрутизаторов при передаче трафика IP Multicast;

  • Вопросы разграничения доступа при работе с IP Multicast.

Основным протоколом маршрутизации трафика IP Multicast является протокол PIM. В режиме малой насыщенности (Sparse Mode) этот протокол описан в документе RFC-2117, в режиме же большой насыщенности (Dense Mode) этот протокол описан в стандартизующих документах. Протокол PIM нашел широкое применение как в сети Интернет, так и в корпоративных интрасетях. Как видно из названия, протокол PIM работает со многими маршрутизирующими одноцелевыми (unicast) протоколами типа OSPF или EIGRP. При необходимости маршрутизаторы протокола PIM могут взаимодействовать с протоколом DVMRP (Distance Vector Multicast Routing Protocol). Протокол DVMRP является маршрутизирующим протоколом, внедренным в свое время в магистрали MBONE (Internet Multicast Backbone). В настоящее время примерно 50% магистрали MBONE переведена на протокол PIM, окончательная замена протокола DVMRP протоколом PIM ожидается в ближайшее время.

Протокол PIM поддерживает работу в двух режимах – Dense и Sparse. Режим Dense используется при работе таких приложений, как IP/TV, при которых один сервер осуществляет рассылку сообщений большому числу клиентов по всему кампусу. Режим Sparse используется на уровне рабочих групп приложениями типа NetMeeting. В любом режиме протокол PIM обеспечивает построение эффективных деревьев IP multicast, которые способствуют минимизации общего количества трафика в сети. И это немаловажно при использовании приложений, требующих наличия высокоскоростной полосы пропускания, таких как видеотрансляции реального времени. В большинстве случаев протокол PIM сконфигурирован так, что режим его работы выбирается автоматически.

Протокол IGMP используется серверами и клиентами IP multicast для присоединения к группам рассылки или для распространения по сети информации об этих группах. Локальный основной маршрутизатор (Default Gateway Router) передает трафик IP Multicast в локальную подсеть только в том случае, если на этой подсети имеются активные клиенты IP Multicast. При их отсутствии передача этого типа трафика блокируется. Протокол CGMP обеспечивает еще более широкие возможности для управления таким трафиком на коммутаторах Catalyst. Маршрутизатор Cisco посылает по сети сообщение CGMP, содержащее все MAC-адреса узлов, принадлежащих группе рассылки IP Multicast. Коммутаторы Catalyst получают эти сообщения и начинают передавать многоцелевые пакеты только в те свои порты, к которым подключены указанные в сообщении CGMP узлы. Это блокирует передачу такого трафика тем коммутаторам, у которых на интерфейсных портах нет ни одного узла-клиента группы рассылки.

Архитектура коммутаторов Catalyst 5000 позволяет им передавать многоцелевой поток данных в один, несколько или во все интерфейсные порты без существенной разницы в нагрузке на центральный процессор коммутатора. Коммутаторы Catalyst обеспечивают поддержку сразу нескольких групп рассылки одновременно без снижения скорости передачи пакетов.

Одним из путей решения проблемы разграничения прав доступа при работе с трафиком IP Multicast является тот путь, при котором серверы IP Multicast располагаются за коммутатором Catalyst X, как показано на рис. 17.

Рис. 17. Разграничение прав доступа при работе с IP Multicast

Коммутатор X работает в качестве своеобразного брэндмауера (firewall) IP Multicast, который управляет скоростями передачи и контролирует доступ к многоцелевым потокам данных. Для обеспечения изоляции трафика IP Multicast рекомендуется создать отдельную VLAN или подсеть на уровне ядра сети, в которую будут входить клиенты групп рассылки. Эта VLAN может быть либо логической частью ядра сети, либо может обслуживаться своим коммутатором в том случае, если уровень трафика такого типа слишком высок. Коммутатор X является логическим местом расположения точки сбора протокола PIM. Понятие “точка сбора” означает корень дерева IP Multicast.

Обсуждение вопросов масштабирования

Многоуровневая модель сети изначально масштабируется. Масштабирование коммутации уровня 3 объясняется тем, что сама по себе коммутация является распределенной. Производительность ядра системы масштабируется при добавлении дополнительных линий связи или коммутаторов. Индивидуальные коммутируемые домены или сети в корпусах здания могут быть увеличены до 1000 рабочих мест с сохранением на уровне распределения двух коммутаторов, обеспечивающих функции резервирования. Дополнительные строительные блоки сети или блоки серверов могут быть добавлены без изменения самой модели сети. В связи с тем, что такая модель сети в значительной степени структурирована, то масштабируемость возможна еще и с точки зрения управления и администрирования такой сети.

На всем протяжении обсуждения многоуровневого дизайна кампусных сетей мы говорили о том, что на уровне ядра такой сети нет и не может быть петель протокола STP. Протокол STP обеспечивает время сходимости маршрутизирующих протоколов в 40-50 секунд и не обеспечивает разделения нагрузки между параллельными маршрутами. На сегментах Ethernet в нашем примере петель нет. На уровне соединений ATM функции разделения нагрузки выполняет протокол PNNI. В любых ситуациях “интеллектуальные” протоколы маршрутизации уровня 3, такие как OSPF и EIGRP, обеспечат выполнение функций поиска оптимального маршрута и разделения нагрузки по нескольким маршрутам на уровне ядра.

Объем трафика протокола OSPF возрастает линейно в зависимости от числа установленных коммутаторов уровня распределения. Это происходит из-за того, что протокол OSPF выбирает один основной и один резервный маршрутизатор (Designated Router) для работы со всеми коммутаторами уровня 3 на уровне распределения. Если на одном соединении находятся две VLAN или ELAN, то для каждой из них будет выбран основной и резервный маршрутизатор. В связи с этим уровень трафика протокола OSPF и нагрузка на центральные процессоры (CPU) устройств будут возрастать в зависимости от числа VLAN или ELAN. Для предотвращения чрезмерного увеличения трафика и нагрузки на CPU рекомендуется создавать на уровне ядра сети как можно меньше VLAN или ELAN. Для больших сетей ATM LANE рекомендуется создать две ELAN, как это описано ранее в разделе “Ядро с применением ATM LANE” настоящего документа.

Другим важным аспектом обсуждения масштабируемости OSPF является проблема большого размера маршрутных таблиц в крупных сетях и большое количество пакетов обновления этих таблиц (route update). Для крупных сетей подсети, входящие в состав корпуса здания, объединяются в области OSPF (OSPF Area), а коммутаторы уровня распределения конфигурируются на выполнение функций пограничных маршрутизаторов (Area Border Router, ABR). Эти маршрутизаторы собирают информацию обо всех подсетях внутри своей области, создают собственные таблицы маршрутов и посылают в общую сеть всего одно обновление. Это уменьшает количество служебной маршрутной информации в общей сети и увеличивает достоверность маршрутных таблиц. В случае с протоколом EIGRP следует поступать аналогичным образом.

Однако не все маршрутизирующие протоколы работают одинаково. Протоколы RTMP (AppleTalk Routing Table Maintenance Protocol), SAP (Novell Server Advertisement Protocol) и RIP (Novell Routing Information Protocol) могут создавать служебный трафик, уровень которого согласуется с количеством узлов. Например, скажем, что в сети установлены 12 коммутаторов уровня распределения, имеющих подключения к ядру сети и работающих с протоколом Novell SAP. Если во всем кампусе установлено 100 узлов, рассылающих анонсы SAP, то каждый коммутатор уровня распределения будет передавать 100/7 = 15 таких анонсов в ядро сети каждые 60 секунд. Все 12 коммутаторов, соответственно, будут отправлять 12 * 15 = 180 анонсов SAP каждые 60 секунд. Программное обеспечение Cisco IOS имеет такие встроенные функции, как фильтрация пакетов SAP, которые позволяют передавать анонс только в случае изменения конфигурации соответствующих серверов Novell, при их добавлении или выключении. Пусть 180 пакетов в минуту не такое уж большое число. Но представьте себе, что произойдет, если количество коммутаторов уровня распределения возрастет до 100, а количество узлов, предоставляющих какие-либо сервисы Novell до 1000? На рис. 18 показана структура ядра ATM большой кампусной сети.

Рис. 18. Ядро ATM большой кампусной сети

Ядро ATM, обозначенное областью B, состоит из восьми коммутаторов LightStream 1010, имеющих частичные (partial mesh) соединения между собой, выполненные линиями OC-12. Домен C содержит три пары коммутаторов LightStream 1010. Домен C может иметь такую систему адресов ATM, что сможет собирать сведения обо всех адресах ядра B. В данном случае ручная конфигурация таблицы адресов ATM будет малоэффективна. По умолчанию в ней будет всего лишь 26 маршрутов, соответствующих 26 коммутаторам, показанным на рис. 18. В домене A пары коммутаторов уровня распределения подключены к ATM линиями OC-3 LANE. Ферма серверов, находящаяся за коммутаторами Catalyst X и Y подключена непосредственно к ядру через интерфейсные модули OC-12 LANE/MPOA.

Стратегия миграции

Многоуровневая модель сетевого дизайна описывает логическую структуру кампуса. Структура адресации и дизайн уровня 3 не зависят от типа выбранной среды передачи. Логически нет никаких отличий при проектировании сетей Ethernet, Token Ring, FDDI или ATM. Это не всегда справедливо, в особенности, когда дело касается немаршрутизируемых протоколов типа NetBIOS и SNA, которые являются зависимыми от среды передачи. Для того чтобы кадры Token Ring, имеющие размер более 1500 байт, “засунуть” в сети Ethernet, необходимо приложить некоторые усилия, о которых пойдет речь дальше. На рис. 19 показана многоуровневая кампусная сеть с параллельными магистралями FDDI.

Рис. 19. Миграция от сетей Token Ring и FDDI

Магистраль FDDI может транслироваться в Fast Ethernet на уровне распределения. Альтернативным путем решения проблемы может являться конфигурирование магистрали FDDI как отдельной логической сети. Мы приведем несколько доводов в пользу того, чтобы имеющиеся магистрали FDDI включать в состав модернизируемых сетей. Топология FDDI поддерживает работу с кадрами, имеющими размер 4500 байт, в то время как топология Ethernet работает с кадрами размером в 1500 байт. Это может оказаться важным для немаршрутизируемых протоколов, работающих в локальных подсетях Token Ring, в которых конечные узлы также могут генерировать кадры размером в 4500 байт. Другим доводом в пользу имеющихся магистралей FDDI является наличие у заказчиков сетевых адаптеров FDDI.

Технология DLSw+ (Data-link Switching plus) является реализацией компанией Cisco стандартной технологии DLSw. Кадры SNA, генерируемые “настоящим” (native) клиентом SNA, обозначенным на рис. 19 буквой B, инкапсулируются маршрутизатором или коммутатором уровня распределения в пакеты протокола TCP/IP. Распределяющий коммутатор деинкапсулирует трафик SNA и передает его устройству FEP (Front-End Processor), подключенный по топологии Token Ring к центру обработки данных. Многоуровневые коммутаторы могут подключаться к сетям Token Ring благодаря управляющему модулю VIP (Versatile Interface Processor) и портовому адаптеру Token Ring.

Безопасность в многоуровневой модели

Поддержка контрольных списков доступа (Access Control List) обеспечивается многоуровневой коммутацией без уменьшения производительности. В связи с тем, что весь трафик сети проходит через уровень распределения, то именно этот уровень и есть наиболее подходящее место для установки списков доступа и средств обеспечения разграничения прав доступа. Эти списки доступа могут также использоваться для ограничения взаимодействия коммутаторов на разных уровнях сети. В добавление необходимо отметить, что в такой сети обеспечивается поддержка протоколов централизованного управления правами доступа, таких как TACACS+ и RADIUS. Программное обеспечение Cisco IOS также обеспечивает несколько уровней авторизации и шифрование паролей пользователей. Сетевым менеджерам может быть предоставлен определенный набор команд по управлению отдельными участками сети.

Использование коммутации уровня 2 на уровне доступа и в фермах серверов привносит в общую сеть дополнительные возможности по разграничению прав доступа. На разделяемой среде передачи все пакеты видны для всех пользователей логической подсети. Это может быть использовано при взломе систем защиты данных, т.к. имеется возможность отслеживать передачу файлов и паролей пользователей. В коммутируемой же сети при взаимодействии двух узлов пакеты видны только отправителю и получателю данных. А также если коммутация уровня 2 применяется в фермах серверов, то весь межсерверный трафик не выпускается в общую сеть.

Для обеспечения функций безопасности и защиты данных в условиях глобальных сетей (Wide-Area Network, WAN) используется концепция брэндмауеров (firewall). Firewall имеет в своем составе один или несколько маршрутизаторов и выступает в качестве бастиона, защищающего внутренние узлы сети от доступа из специальной зоны, называемой DMZ (Demilitarized Zone). Специализированные устройства кэширования содержимого серверов WWW и другие устройства Firewall могут быть подключены к DMZ.

Внутренние маршрутизаторы Firewall подключаются к ядру кампусной сети, что можно назвать уровнем распределения WAN. На рис. 20 показан строительный блок сети, представляющий собой уровень распределения WAN с элементами Firewall.

Рис. 20. Уровень распределения WAN, подключенный к Интернет

Бриджинг в многоуровневой модели

Бриджинг в многоуровневой модели кампусной сети может применяться для передачи трафика немаршрутизируемых протоколов. Эти функции при взаимодействии уровня распределения с уровнем ядра выполняют модули RSM. В связи с тем, что каждая VLAN уровня распределения использует протокол IEEE Spanning Tree, то нет необходимости в конфигурировании бриджинг-группы на модуле RSM. Эффект бриджинга достигается тем, что все деревья STP объединяются в единое дерево, STP корнем которого становится модуль RSM. Однако, например, конфигурация бриджинг-группы STP для протокола DEC позволяет сохранить все остальные деревья независимыми.

Для обеспечения резервирования конфигурации мостов как показано на рис. 7 необходимо использовать ПО Cisco IOS версии 11.2(13)P или выше на всех модулях RSM. Cisco IOS версии 11.2(13)P имеет специальный набор функций, которые обеспечивают передачу BPDU (Bridge Protocol Data Unit) протокола DEC между модулями RSM коммутаторов Catalyst 5000. С предыдущими версиями программного обеспечения мосты DEC не видели друг друга в сети и не имели возможности блокировать резервные линии связи в топологии сети. При использовании предыдущих версий Cisco IOS необходимо убедиться в том, что между двумя любыми подсетями имеется только один мост. Например, RSM A является мостом для четных VLAN, а RSM B – для нечетных.

Преимущества многоуровневой модели

Мы обсудили несколько вариантов многоуровневой модели дизайна кампусной сети. Независимо от того, используется ли ядро, основанное на коммутации кадров Ethernet или на коммутации ячеек ATM, такой подход к проектированию имеет ряд общих преимуществ. Все части модели в значительной степени структурированы, что позволяет облегчить выполнение функций управления и поиска неисправностей. Модульность каждого строительного блока сети обеспечивает хорошие возможности масштабирования при добавлении новых корпусов здания и серверных ферм. “Интеллектуальные” маршрутизирующие протоколы уровня 3, такие как OSPF и EIGRP, обеспечивают выполнение функций разделения нагрузки и восстановления после сбоев внутри основных магистралей уровня ядра. Сохраняется та же модель адресации и логическая структура сети, что и в случае применения модели с маршрутизаторами и концентраторами, что обеспечивает удобный путь миграции от существующих сетей. Множество дополнительных функций ПО Cisco IOS, таких как кэширование серверов, туннелирование и объединение маршрутных таблиц встроены в коммутаторы Catalyst на уровне распределения. Функции обеспечения защиты данных также встроены в устройства уровня распределения и в коммутаторы распределения серверов в виде списков доступа (access list).

Резервирование и быстрая сходимость алгоритмов поиска оптимальных маршрутов обеспечиваются такими функциями, как UplinkFast и HSRP. Масштабирование производительности путем замены линий связи Fast Ethernet на Fast EtherChannel или Gigabit Ethernet не требуют пересмотра стратегии организации защиты данных и разграничения прав доступа. Благодаря большому набору дополнительных функций ПО Cisco IOS обеспечивается поддержка всех общих сетевых протоколов, встречающихся в кампусных сетях, включая TCP/IP, AppleTalk, Novell IPX, DECnet, IBM SNA, NetBIOS и многие другие. Большое количество успешных проектов организации крупных кампусных сетей выполнено в применением многоуровневой модели проектирования. Это позволяет избежать проблем, связанных с масштабированием, которые обычно возникают в сетях с применением мостов. И, наконец, многоуровневая модель проектирования обеспечивает включение в состав сети коммутации уровня 3, причем это не вызывает уменьшения скорости обработки трафика по сравнению с применением коммутации уровня 2.

Приложение А. Внедрение многоуровневой модели

Ядро на основе Ethernet

Этот раздел содержит примеры конфигурации сети, построенной на основе многоуровневой модели, в ядре которой используется топология Ethernet. Рис. 21 иллюстрирует небольшую кампусную интрасеть.

Рис. 21. Многоуровневая модель в сетях, основанных на Ethernet

На рисунке показаны два здания, каждое из которых представляет собой домен VTP – North и South. Ядро сети представляет собой другой домен VTP – Backbone. Внутри каждого домена хотя бы один коммутатор должен выполнять функции сервера VTP. Основной задачей сервера VTP является отслеживание состояния всех VLAN, имеющих место в данном домене. Коммутатор d1a является сервером VTP для домена North. Коммутатор d2a является сервером VTP для домена South. Оба коммутатора ca и cb являются серверами VTP для домена Backbone, потому что трафик VLAN 1 не должен проходить на уровень ядра сети. Фактически в сети нет ни одного магистрального соединения ISL. Расположение сервера VTP на коммутаторе уровня доступа a1a не является хорошей идеей, потому что не все VLAN в домене North имеют доступ к этому коммутатору. Коммутаторы, которые не являются серверами VTP, сконфигурированы так, чтобы прозрачно пропускать через себя трафик VTP. Использование такого режима конфигурации коммутатора a1a позволяет распространить информацию обо всех VLAN, присутствующих на этом коммутаторе.

На рис. 22 VLAN 10 показана более подробно. Магистрали VLAN trunk, составляющие треугольник, несут на себе трафик VLAN 10. Коммутатор d1a, расположенный в нижнем левом углу, является корневым для VLAN 10. На коммутаторе a1a соединение 2/1 находится в активном состоянии и передает трафик VLAN 10, а соединение 2/2 является заблокированным. Заблокированные соединения выделены пурпурным цветом (purple). На коммутаторе a1a включены функции UplinkFast. В добавление скажем, что три соединения, три порта подключены к VLAN 10. Рабочая станция PC A имеет IP адрес 131.108.10.1 и подключена к порту 2/11 коммутатора a1a. Два модуля RSM r1a и r1b сконфигурированы так, что они имеют логическое подключение к VLAN. Модуль RSM r1a подключен к порту 3/1 коммутатора d1a, а модуль RSM r1b подключен к порту 3/1 коммутатора d1b. Модуль RSM r1a имеет IP адрес 131.108.10.151 на интерфейсе VLAN 10 , однако, функционирует как основной маршрутизатор HSRP с IP адресом 131.108.10.100.

Рис. 22. Логическая топология VLAN 10 внутри многоуровневой модели

Рис. 23 иллюстрирует VLAN 11 во всех подробностях.

Рис. 23. Логическая топология VLAN 11 внутри многоуровневой модели

Напомним, что коммутатор d1b является корневым для нечетных VLAN. На коммутаторе a1a соединение 2/1 заблокировано, а соединение 2/2 активно. Модуль RSM r1b функционирует в качестве основного маршрутизатора HSRP и имеет IP адрес 131.108.11.100 для VLAN 11. При этом резервным маршрутизатором является r1a.

Отметим, что в данном примере мы используем упрощенные имена узлов. Так, в частности, буква ‘а’ в имени коммутатора означает, что он относится к уровню доступа (Access Layer), буква ‘d’ – к уровню распределения (Distribution Layer), а буква ‘c’ – к уровню ядра сети (Core Layer). Первый модуль RSM в коммутаторе d1a имеет имя r1a. IP адреса, имеющие младшие значения в поле адреса узла, например, 131.108.10.1, относятся к конечным узлам, адреса 131.108.10.20x относятся к серверам, а адреса 131.108.10.10x относятся к маршрутизаторам HSRP. Для обеспечения других функций, кроме работы протокола HSRP, модули RSM имеют следующие адреса:

Модуль RSM | IP Адрес
r1a | x.x.x.151
r1b | x.x.x.152
r2a | x.x.x.153
r2b | x.x.x.154
rca | x.x.x.155
rcb | x.x.x.156
rwan | x.x.x.157 (Маршрутизатор Cisco 7500, подключенный к ядру)

В домене North находятся четыре подсети, имеющие IP адреса 131.108.10.0, 131.108.11.0, 131.108.12.0 и 131.108.13.0. Эти подсети относятся к VLAN 10, 11, 12 и 13 соответственно. В добавлении отметим, что подсеть для управления имеет адрес 131.108.1.0 и относится к VLAN 1 внутри домена. VLAN 1 не выходит за пределы уровня распределения. Внутри домена South также имеется VLAN 1, однако, это – другая подсеть. Порт управления SC0 на каждом коммутаторе принадлежит VLAN 1, адрес которой 131.108.1.0. Адреса управляющих интерфейсов распределены следующим образом:

Устройство | IP Адрес | IP адрес маршрутизатора по умолчанию (default gateway)
a1a | 131.108.1.1 | 131.108.1.100
a1b | 131.108.1.2 | 131.108.1.101
d1a | 131.108.1.3 | 131.108.1.100
d1b | 131.108.1.4 | 131.108.1.101
r1a | 131.108.1.151 | (Основной HSRP для 131.108.1.100)
r1b | 131.108.1.152 | (Резервный HSRP для 131.108.1.100)

В домене South находятся четыре подсети, имеющие IP адреса 131.108.20.0, 131.108.21.0, 131.108.22.0 и 131.108.23.0. Эти подсети относятся к VLAN 20, 21, 22 и 23 соответственно. В добавлении отметим, что подсеть для управления имеет адрес 131.108.2.0 и относится к VLAN 1 внутри домена. VLAN 1 не выходит за пределы уровня распределения. Внутри домена South также имеется VLAN 1, однако, это – другая подсеть. Порт управления SC0 на каждом коммутаторе принадлежит VLAN 1, адрес которой 131.108.2.0. Адреса управляющих интерфейсов распределены следующим образом:

Устройство | IP Адрес | IP адрес маршрутизатора по умолчанию (default gateway)
a2a | 131.108.2.1 | 131.108.2.100
a2b | 131.108.2.2 | 131.108.2.101
d2a | 131.108.2.3 | 131.108.2.100
d2b | 131.108.2.4 | 131.108.2.101
r2a | 131.108.2.151 | (Основной HSRP для 131.108.2.100)
r2b | 131.108.2.152 | (Резервный HSRP для 131.108.2.100)

Домен Backbone содержит подсеть 131.108.99.0, которая представляет собой VLAN 99. Протокол HSRP не сконфигурирован на подсети 99.0, т.к. состояние “standby" на интерфейсе VLAN отменяет рассылку пакетов протокола ICMP (Internet Control Message Protocol). Основной маршрутизатор для ca и cb сконфигурирован на их собственные адреса с маской подсети класса B, т.к. ca и cb для обращения к другим подсетям будут использовать запросы proxy ARP.

Устройство | IP Адрес | IP адрес маршрутизатора по умолчанию (default gateway)
ca | 131.108.99.1 | Proxy ARP, gateway 131.108.99.1
 |  | Mask 255.255.0.0
cb | 131.108.99.2 | Proxy ARP, 131.108.99.2
 |  | Mask 255.255.0.0
r1a | 131.108.99.151 | --
r1b | 131.108.99.152 | --
r2a | 131.108.99.153 | --
r2b | 131.108.99.154 | --

Конфигурация коммутатора a1a показана ниже. В слоте 2 установлен интерфейсный модуль 10/100, порты 2/1 и 2/2 используются для соединения с коммутаторами d1a и d1b соответственно. Последняя команда set spantree uplinkfast enable включает функцию восстановления после сбоя протокола STP.

set prompt a1a

set vtp mode transparent

set vtp domain North

set interface sc0 1 131.108.1.1 255.255.255.0

set ip route default 131.108.1.100 0

set trunk 2/1 on

set trunk 2/2 on

set vlan 10

set vlan 10 2/11 (assigns one host port in VLAN 10)

set vlan 11

set vlan 11 2/12 (assigns one host port in VLAN 11)

set spantree uplinkfast enable

Конфигурация коммутатора d1a следующая: в слоте 2 установлен модуль интерфейсный 10/100, порты 2/1, 2/2 и 2/3 используются для соединений с коммутаторами a1a, a1b и d1b соответственно. Этот коммутатор выполняет роль Root Bridge для VLAN 10 и 12. Мы удалим VLAN 12, 13 и 99 из магистрального соединения 2/1 с коммутатором a1a. Также мы удалим VLAN 10, 11 и 99 из магистрального соединения 2/2 с коммутатором a1b. Мы удалим VLAN 99 из соединения 2/3 с коммутатором d1b для предотвращения образования петель STP на уровне ядра сети. VLAN 1 не может быть удалена из соединений внутри домена VTP. Коммутатор d1a выполняет функции сервера VTP для домена North.

set prompt d1a

set vtp domain North

set vtp mode server

set interface sc0 1 131.108.1.3 255.255.255.0

set ip route default 131.108.1.100 0

set trunk 2/1 on

set trunk 2/2 on

set trunk 2/3 on

set vlan 10, 11, 12, 13, 99

set spantree root 10, 12

clear trunk 2/1 12,13,99

clear trunk 2/2 10,11,99

clear trunk 2/3 99

Ниже представлена конфигурация модуля RSM rla. Этот коммутатор функционирует как основной HSRP маршрутизатор для адреса 131.108.1.100. Этот коммутатор также является основным маршрутизатором по умолчанию для четных подсетей с адресами 131.108.10.0 и 131.108.12.0. В отношении нечетных подсетей 131.108.11.0 и 131.108.13.0 этот коммутатор является резервным маршрутизатором по умолчанию.

hostname r1a

interface vlan 1

ip address 131.108.1.151 255.255.255.0

standby 1 ip 131.108.1.100

standby 1 priority 100

standby 1 preempt

interface vlan 10

ip address 131.108.10.151 255.255.255.0

standby 1 ip 131.108.10.100

standby 1 priority 100

standby 1 preempt

interface vlan 11

ip address 131.108.11.151 255.255.255.0

standby 1 ip 131.108.11.100

standby 1 priority 50

interface vlan 12

ip address 131.108.12.151 255.255.255.0

standby 1 ip 131.108.12.100

standby 1 priority 100

standby 1 preempt

interface vlan 13

ip address 131.108.13.151 255.255.255.0

standby 1 ip 131.108.13.100

standby 1 priority 50

interface vlan 99

ip address 131.108.99.151 255.255.255.0

router ospf 777

network 131.108.0.0 0.0.255.255 area 0

Включение фермы серверов

На рис. 24 показана ферма корпоративных серверов, подключенная к VLAN 100.

Рис. 24. Создание фермы серверов

Мы добавили модули RSM rca и rcb в состав коммутаторов уровня ядра ca и cb. Модуль RSM rca выполняет функции основного HSRP маршрутизатора для адреса 131.108.100.100, а модуль RSM rcb является резервным для того же адреса. Модуль RSM rcb выполняет функции основного HSRP маршрутизатора для адреса 131.108.100.101, а модуль RSM rca является резервным для того же адреса. Корпоративный сервер 131.108.100.200 использует в качестве маршрутизатора по умолчанию адрес 131.108.100.100, а сервер 131.108.100.201 – адрес 131.108.100.101. Это обеспечивает распределение нагрузки для исходящих пакетов от фермы серверов до основных магистралей уровня ядра.

На рис. 25 коммутаторы уровня ядра ca и cb показаны более подробно.

Рис. 25. Ферма серверов

Магистральное соединение Fast EtherChannel, по которому передается трафик VLAN 100, соединяет коммутаторы ca и cb, обеспечивая функции коммутации уровня 2 между корпоративными серверами и основными и резервными маршрутизаторами HSRP. Это соединение также несет в себе межсерверный трафик.

Конфигурация коммутатора ca представлена ниже:

set prompt ca

set vtp domain Backbone

set vtp mode server

set interface sc0 99 131.108.99.1 255.255.255.0

set ip route default 131.108.99.100 0

set vlan 99 name 131.108.99.0

set vlan 100 name 131.108.100.0

set port channel 2/1-2 on (Fast EtherChannel VLAN 99)

set port channel 2/3-4 on (Fast EtherChannel VLAN 100)

set vlan 99 2/1-2

set vlan 100 2/12

set trunk 1/1 off

set trunk 1/2 off

set trunk 2/1 off (FEC is not an ISL trunk)

set trunk 2/3 off (FEC is not an ISL trunk)

Конфигурация модуля RSM rca:

hostname rca

interface vlan 99

ip address 131.108.99.155 255.255.255.0

interface vlan 100

ip address 131.108.100.155 255.255.255.0

standby 1 ip 131.108.100.100

Standby 1 priority 100

standby 1 preempt

standby 2 ip 131.108.100.101

standby 2 priority 50

router ospf 777

network 131.108.0.0 0.0.255.255. area 0

Ядро ATM LANE

На рис. 26 показана сеть, построенная на основе многоуровневой модели с применением на уровне ядра технологии ATM LANE.

Рис. 26. Сеть с ядром ATM LANE

Коммутаторы Catalyst 5500 ca и cb обеспечивают коммутацию ATM на уровне ядра сети и коммутацию Ethernet на уровне распределения серверов в составе серверной фермы. На всех коммутаторах уровней ядра и распределения интерфейсные модули LANE обеспечивают соединение VLAN 98 с ядром ATM ELAN. Модуль LANE в коммутаторе ca выполняет функции основного сервера LES/BUS, а модуль LANE в коммутаторе cb является резервным сервером LES/BUS. На уровне ядра сконфигурирована всего одна ELAN, которая соответствует подсети с адресом 131.108.98.0. Это упрощает логическую структуру ядра и уменьшает число требуемых виртуальных соединений. В крупных кампусных сетях ATM обычно используют две ELAN для обеспечения резервирования. На рис. 27 к ядру подключены девять клиентов LEC. Каждый интерфейсный модуль LANE на коммутаторах d1a, d1b, d2a, d2b, ca и cb имеет одного клиента LEC, ассоциируемого с VLAN 98. Каждый коммутатор ATM имеет LEC, ассоциируемого с управляющим портом. Маршрутизатор rwan имеет “настоящий” интерфейс ATM, который также является клиентом LEC.

Рис. 27. Управляющая подсеть в ATM LANE

Количество требуемых виртуальных соединений вычисляется по формуле:

6n < x < 6n + (n(n-1)/2),

где n – количество LEC в ядре ATM. При отсутствии трафика каждый LEC имеет 6 виртуальных соединений. Для сети ATM с девятью LEC мы получаем:

54 < x < 90

При отсутствии трафика в ядре ELAN будут иметь место 54 виртуальных соединения. Если любой LEC откроет соединение с любым другим LEC, то число виртуальных соединений возрастет до 90. Это достаточно малое число, чтобы перегрузить сервер LES/BUS.

В случае если основной сервер LES/BUS по какой-то причине будет отключен, то протокол SSRP произведет восстановление соединений через резервный сервер в течение нескольких секунд. Для определения количества открытых виртуальных соединений можно воспользоваться командой show atm vc.

Rwan#show atm vc

AAL / Peak Avg. Burst

Interface VCD VPI VCI Type Encapsulation Kbps

Kbps Cells Status

ATM0/0 1 0 5 PVC AAL5-SAAL 155000 155000 96 ACTIVE

ATM0/0 2 0 16 PVC AAL5-ILMI 155000 155000 96 ACTIVE

ATM0/0.2 4 0 33 SVC LANE-LEC 155000 155000 32 ACTIVE

ATM0/0.2 5 0 34 MSVC LANE-LEC 155000 155000 32 ACTIVE

ATM0/0.2 6 0 35 SVC LANE-LEC 155000 155000 32 ACTIVE

ATM0/0.2 7 0 36 MSVC LANE-LEC 155000 155000 32 ACTIVE

ATM0/0.2 79 0 127 SVC LANE-DATA 155000 155000 32 ACTIVE

Показанный вывод результатов команды фиксирует 6 виртуальных соединений по умолчанию (default VC) и одно соединение данных, которое открылось из-за текущей Telnet сессии на маршрутизатор rwan. Постоянное виртуальное соединение (Permanent Virtual Circuit, PVC) 0 5 обеспечивает передачу сигнализации SVC (Switched Virtual Circuit), а PVC 0 16 – передачу сигнализации ILMI (Interim Local Management Interface). Также имеются: одно отрытое соединение SVC и одно открытое соединение MSVC до сервера LES, и одно SVC и одно MSVC до сервера BUS.

Конфигурация устройств уровней доступа и распределения и модулей RSM в этом случае такая же, как и в случае с использованием Ethernet. До конфигурирования компонентов LANE необходимо рассмотреть некоторые соглашения с тем, чтобы соблюдался некоторый порядок в обсуждении и дальнейшем использовании таких сетей. Ниже приведены некоторые соглашения, используемые для модулей LANE и интерфейсов ATM:

Подинтерфейс | Ассоциация
n.0 | Резервируется для LECS при необходимости
n.1 | ELAN по умолчанию (Default) (Не используется в данном примере)
n.2 | ELAN в ядре ATM = VLAN 98 = подсеть 131.108.98.0
n.3 | Не используется

Также необходимо рассмотреть расположение IP адресов на управляющих интерфейсах VLAN 98. Здесь aspca – это имя LEC на управляющем порту 13/0/0.2 на модуле ASP в коммутаторе ca. Порт 13/0/0 представляет собой внутренний управляющий интерфейс коммутатора ATM.

Устройство | IP Адрес
r1a | 131.108.98.151
r1b | 131.108.98.152
r2a | 131.108.98.153
r2b | 131.108.98.154
rca | 131.108.98.155
rcb | 131.108.98.156
rwan | 131.108.98.157
aspca | 131.108.98.171 (активный LEC)
aspcb | 131.108.98.172 (резервный LEC)
са | 131.108.98.1
cb | 131.108.98.2
laneca | -- (активный LES/BUS)
lanecb | -- (резервный LES/BUS)

На модуле Supervisor Engine коммутатора ca конфигурируется Ethernet VLAN 98. Мы не будем использовать технологию VTP Trunking, поэтому VLAN 1 не используется.

set prompt ca

set vtp domain backbone

set vtp mode server

set vlan 1 name default

set vlan 98 name atmbackbone

set vlan 98 8/1-12 (attach servers and Ethernet13/0/0 from aspca)

set interface sc0 98 131.108.98.1 255.255.255.0

set ip route default 131.108.98.1 255.255.0.0 (use proxy ARP)

Для нахождения ATM адресов NSAP (Network Service Access Point) воспользуемся командой show lane default, чтобы определить адрес основного LES на laneca и резервного LES на lanecb. Интерфейс ATM на модуле LANE необходимо физически подключить к порту коммутатора ATM. Это необходимо для того, чтобы протокол ILMI смог определить 20-байтный адрес NSAP. Активный физический интерфейс PHY-A отражается в 13-байтном префиксе, полученном от коммутатора ATM. Интерфейс PHY-A модуля laneca подключается к aspca, а интерфейс PHY-A модуля lanecb – к aspcb.

laneca>show lane default

interface ATM0:

LANE Client: 47.0091810000000010F6737401.0010F6737020.**

LANE Server: 47.0091810000000010F6737401.0010F6737021.**

LANE Bus: 47.0091810000000010F6737401.0010F6737022.**

LANE Config Server: 47.0091810000000010F6737401.0010F6737023.00

note: ** is the subinterface number byte in hex

lanecb>show lane default

interface ATM0:

LANE Client: 47.0091810000000010F6756301.0010F6755F20.**

LANE Server: 47.0091810000000010F6756301.0010F6755F21.**

LANE Bus: 47.0091810000000010F6756301.0010F6755F22.**

LANE Config Server: 47.0091810000000010F6756301.0010F6755F23.00

note: ** is the subinterface number byte in hex

Для определения основного и резервного серверов LECS на модулях aspca и aspcb выполним команду show lane default.

aspca#show lane default

interface ATM13/0/0:

LANE Client: 47.0091810000000010F6737401.0010F6737402.**

LANE Server: 47.0091810000000010F6737401.0010F6737403.**

LANE Bus: 47.0091810000000010F6737401.0010F6737404.**

LANE Config Server: 47.0091810000000010F6737401.0010F6737405.00

note: ** is the subinterface number byte in hex

aspcb#show lane default

interface ATM13/0/0:

LANE Client: 47.0091810000000010F6756301.0010F6756302.**

LANE Server: 47.0091810000000010F6756301.0010F6756303.**

LANE Bus: 47.0091810000000010F6756301.0010F6756304.**

LANE Config Server: 47.0091810000000010F6756301.0010F6756305.00

note: ** is the subinterface number byte in hex

Конфигурируем aspca как основной LECS, а aspcb – как резервный. Модуль LANE в коммутаторе уровня ядра ca становится основным сервером LES/BUS для ядра ELAN. В связи с тем, что оба модуля – и laneca, и lanecb – имеют интерфейсы Dual-PHY, то выбираем активным интерфейсом первый из них (PHY-A).

Конфигурация базы данных LECS происходит в следующей последовательности:

1 | PHY-A для laneca | (активный физический интерфейс)
2 | PHY-A для lanecb | (активный физический интерфейс)
3 | PHY-B для lanecb | (резервный физический интерфейс)
4 | PHY-B для laneca | (резервный физический интерфейс)

В показанной конфигурации мы соединяем порт Ethernet 13/0/0 с портом, находящимся в составе VLAN 98 в качестве второго порта внеполосного (out-of-band) управления для испытательных целей. Постольку поскольку мы имеем дело с коммутатором, то ему необходим основной маршрутизатор. Т.к. на уровне ядра не используется протокол HSRP, мы будем использовать Proxy ARP. Основной маршрутизатор будет иметь адрес 131.108.98.171, который принадлежит управляющему интерфейсу коммутатора. Маска подсети будет 255.255.0.0.

LANE Client: 47.0091810000000010F6737401.0010F6737402.**

LANE Server: 47.0091810000000010F6737401.0010F6737403.**

LANE Bus: 47.0091810000000010F6737401.0010F6737404.**

LANE Config Server: 47.0091810000000010F6737401.0010F6737405.00

note: ** is the subinterface number byte in hex

aspcb#show lane default

interface ATM13/0/0:

LANE Client:

47.0091810000000010F6756301.0010F6756302.**

atm lecs-address-default 47.0091.8100.0000.0010.f673.7401.0010.f673.7405.00 1

atm lecs-address-default 47.0091.8100.0000.0010.f675.6301.0010.f675.6305.00 2

!

lane database atmbackbone

name atmbackbone server-atm-address 47.0091810000000010F6737401.0010F6737021.02

name atmbackbone server-atm-address 47.0091810000000010F6756301.0010F6755F21.02

name atmbackbone server-atm-address 47.0091810000000010F6737401.0010F6755F21.02

name atmbackbone server-atm-address 47.0091810000000010F6756301.0010F6737021.02

default-name atmbackbone

!

interface ATM13/0/0

no ip address

lane config auto-config-atm-address

lane config database atmbackbone

!

interface ATM13/0/0.2 multipoint

ip address 131.108.98.171 255.255.255.0

lane client ethernet atmbackbone

!

interface Ethernet13/0/0

ip address 131.108.98.181 255.255.255.0

!

ip default-gateway 131.108.98.171 255.255.0.0

Теперь конфигурируем интерфейсные модули LANE laneca и lanecb как LES/BUS для atmbackbone. Также конфигурируем LEC для привязки Ethernet VLAN 98 к ATM ELAN atmbackbone.

interface ATM0

atm preferred phy A

atm pvc 1 0 5 qsaal

atm pvc 2 0 16 ilmi

!

interface ATM0.2 multipoint

lane server-bus ethernet atmbackbone

lane client ethernet 98 atmbackbone

Теперь нужно конфигурировать интерфейсные модули LANE lane1a, lane1b, lane2a и lane2b. Это позволит привязать Ethernet VLAN 98 к ATM ELAN atmbackbone на каждом коммутаторе.

interface ATM0

atm preferred phy A

atm pvc 1 0 5 qsaal

atm pvc 2 0 16 ilmi

!

interface ATM0.2 multipoint

lane client ethernet 98 atmbackbone

На рис. 28 показаны физические подключения основных и резервных соединений ATM от каждого порта модуля LANE Dual-PHY к портам коммутаторов aspca и aspcb.

Рис. 28. Соединения ATM в ядре ATM LANE

Для того чтобы убедиться в правильности работы каждого LEC, можно воспользоваться командой show lane на каждом LEC.

Rwan#show lane

LE Client ATM0/0.2 ELAN name: atmbackbone

Admin: up State: operational

Client ID: 9 LEC up for 19 hours 16 minutes 16 seconds

Join Attempt: 2

HW Address: 0010.a64e.b800 Type: ethernet Max Frame Size: 1516

ATM Address: 47.0091810000000010F6756301.0010A64EB800.02

VCD rxFrames txFrames Type ATM Address 0 0 0 configure

47.0091810000000010F6737401.0010F6737023.00 4 1 290 direct

47.0091810000000010F6737401.0010F6737021.02 5 46581 0 distribute

47.0091810000000010F6737401.0010F6737021.02 6 0 16254 send

47.0091810000000010F6737401.0010F6737022.02 7 156271 0 forward

47.0091810000000010F6737401.0010F6737022.02

Если имеется параллельное ядро сети, основанное на Ethernet и предоставляющее возможности резервирования основного ядра, то необходимо для этого ядра использовать свой номер VLAN и свой адрес подсети. При использовании дублирующихся номеров подсетей на уровне ядра в части Ethernet и ATM LANE будут возникать петли, которые не лучшим образом скажутся на производительности сети.


Конфигурирование функций NAT

Cisco IOS
Конфигурирование функций
Network Address Translation

Введение

Двумя основными проблемами, стоящими сегодня перед глобальной сетью Интернет, является ограниченность адресного пространства протокола IP и масштабирование маршрутизации. Функции NAT (Network Address Translation), о которых пойдет речь в настоящей статье, появились в программном обеспечении Cisco IOS не случайно. Это было связано идеей предоставления организациям возможности использования внутри корпоративных и частных сетей адресного пространства, отличного от того, которого от них требуют поставщики услуг Интернет. Так, например, функции NAT позволяют организациям, использующим во внутренних корпоративных сетях маршрутизируемое частное адресное пространство (Private Subnets), получать доступ к узлам и ресурсам Интернет, имеющим “настоящие” адреса IP. Другой сферой применения NAT можно считать создание более гибкого решения по переадресации узлов для организаций, либо меняющих поставщика услуг Интернет, либо переадресующих блоки CIDR (Classless Interdomain Routing). Полное описание функций NAT можно найти в документе RFC 1631.

Содержание

Применение NAT в современных бизнес-сетях

Преимущества NAT

Терминология NAT

Действия, выполняемые при настройке NAT

Трансляция внутренних адресов Source

Конфигурация статической трансляции

Конфигурация динамической трансляции

Использование одного внутреннего глобального адреса

Трансляция перекрывающихся адресов

Конфигурирование статической трансляции

Конфигурирование динамической трансляции

Обеспечение распределения нагрузки TCP

Изменение тайм-аутов трансляции

Мониторинг и сопровождение NAT

Применение NAT в современных бизнес-сетях

Функции NAT для решения следующих проблем и задач:

  • При необходимости подключения к Интернет, когда количество внутренних узлов сети превышает выданное поставщиком услуг Интернет количество реальных адресов IP. NAT позволяет частным сетям IP, использующим незарегистрированные адреса, получать доступ к ресурсам Интернет. Функции NAT конфигурируются на пограничном маршрутизаторе, разграничивающем частную (внутреннюю) сеть и сеть общего пользования (например, Интернет). Далее сеть общего пользования мы будем называть внешней сетью, а частную сеть – внутренней сетью. Функции NAT перед отправкой пакетов во внешнюю сеть осуществляют трансляцию внутренних локальных адресов в уникальные внешние адреса IP.
  • При необходимости изменения внутренней системы адресов. Вместо того, чтобы производить полное изменение всех адресов всех узлов внутренней сети, что представляет собой достаточно трудоемкую процедуру, функции NAT позволят производить их трансляцию в соответствии с новым адресным планом.
  • При необходимости организации простого разделения трафика на основе портов TCP. Функции NAT предоставляют возможность установления соответствия (mapping) множества локальных адресов одному внешнему адресу, используя функции распределения нагрузки TCP.

Являясь решением проблем организации связи между различными узлами и подсетями (connectivity problems), на практике функции NAT в данный момент времени обслуживают работу лишь небольшого числа узлов во внутреннем домене. Это связано с тем, что ситуация, при которой всем узлам внутренней сети одновременно необходимо взаимодействовать с некоторыми внешними узлами, является маловероятной. Тогда в этом случае только сравнительно небольшое количество внутренних адресов по мере необходимости должны транслироваться во внешние адреса. В том случае, если какой-либо внешний адрес больше не используется каким-либо внутренним узлом, то он отдается в распоряжение другому внутреннему узлу.

Преимущества NAT

Одним из важнейших преимуществ NAT является то, что нет необходимости вносить изменения в конфигурацию конечных узлов и маршрутизаторов внутренней сети, за исключением тех устройств, на которых собственно и выполняются эти функции. Как уже отмечалось выше, функции NAT не имеют практического применения в тех сетях, где с внешней сетью одновременно работает большое количество внутренних узлов. К тому же некоторые приложения используют встроенные адреса IP, что ставит под вопрос использование NAT. Такие приложения либо не могут работать прозрачно в сетях с использованием NAT, либо их трафик вообще не будет проходить через устройства, реализующие функции NAT. Также отметим, что функции NAT скрывают внутреннее расположение узлов, что в зависимости от конкретных условий может быть как преимуществом, так и недостатком.

Маршрутизатор, выполняющий функции NAT, должен иметь, по крайней мере, один внутренний и один внешний интерфейсы. При обычном использовании NAT конфигурируется на выходном маршрутизаторе, разделяющем локальный домен и сеть общего пользования. Когда пакет покидает пределы локального домена, функции NAT транслируют содержимое поля Source (локальный адрес отправителя пакета) в значение уникального внешнего адреса. Когда же пакет входит в локальный домен, производится трансляция уникального внешнего адреса в локальный адрес. Если локальный домен имеет более одного выхода во внешнюю сеть, то все маршрутизаторы NAT должны иметь одинаковые таблицы соответствия внутренних и внешних адресов. Если программное обеспечение не в состоянии занять адрес для текущего пакета, то такой пакет будет уничтожен. Одновременно в обратном направлении будет отправлен пакет ICMP, содержащий извещение об уничтожении этого пакета (Host Unreachable).

Маршрутизатор, выполняющий функции NAT, не должен распространять во внешнюю сеть информацию о внутренних подсетях. Тем не менее, маршрутная информация, получаемая маршрутизатором NAT из внешней сети, обычно распространяется по внутренней сети.

Терминология NAT

Как уже рассматривалось выше, термин внутренняя сеть применяется для тех сетей, которые находятся внутри организаций и используют адреса, нуждающиеся в трансляции. Внутри такого сетевого домена узлы используют одно адресное пространство, в то время как снаружи они доступны по адресам из другого адресного пространства, определяемого настройками функций NAT. Первое адресное пространство принято называть локальным, а второе – глобальным адресным пространством.

Аналогичным образом термин внешняя сеть относится к тем сетям, к которым подключаются внутренние сетевые домены. Эти сети не находятся под контролем организаций. Как будет описано далее, узлы внешней сети также могут быть объектами трансляции. Они могут использовать как локальные, так и глобальные адреса.

Приведем список определений и терминов, используемых функциями NAT:

  • Внутренний локальный адрес (Inside local address). Это адреса IP, присвоенные узлам внутренней сети. Как правило, эти адреса не являются зарегистрированными NIC (Network Information Center) или поставщиком услуг.
  • Внутренний глобальный адрес (Inside global address). Этот адрес выдается организации центром NIC или поставщиком услуг Интернет. Он представляет один или более внутренних узлов во внешней сети.
  • Внешний локальный адрес (Outside local address). Это адрес IP, присвоенный внешнему узлу и означающий, что внешний узел принадлежит внутренней сети. Этот адрес не нуждается в регистрации. Этот адрес должен принадлежать такому адресному пространству, которое имеет возможность маршрутизироваться во внутреннюю сеть.
  • Внешний глобальный адрес (Outside global address). Это адрес IP, присвоенный узлу внешней сети владельцем данного узла. Этот адрес принадлежит глобальному адресному или сетевому пространству.

Действия, выполняемые при настройке NAT

Прежде, чем приступить к конфигурированию функций NAT, необходимо проанализировать имеющуюся информацию о локальных и глобальных внутренних адресах. Следующие разделы статьи будут посвящены обсуждению того, каким образом можно использовать NAT в зависимости от потребностей в каждом конкретном случае.

Трансляция внутренних адресов Source

Эта функция NAT позволяет транслировать имеющиеся внутренние адреса IP в уникальные адреса, принадлежащие глобальному адресному пространству, при необходимости обеспечения взаимодействия внутренней сети с внешней сетью. Имеется возможность использования статической или динамической трансляции:

  • Статическая трансляция устанавливает соответствие адресов по типу “один к одному”, т.е. один глобальный внутренний адрес соответствует одному локальному внутреннему адресу. Статическая трансляция применяется в тех случаях, когда некий внутренний узел должен быть доступен извне по постоянному адресу (например, сервер WWW).
  • Динамическая трансляция устанавливает соответствие между внутренним локальным адресом и пулом глобальных адресов.

На рис. 1 показан маршрутизатор, транслирующий адреса узлов, содержащихся в поле Source заголовков пакетов IP из внутренних во внешние.

Рис. 1. Трансляция внутренних адресов Source

Приведенный ниже процесс описывает трансляцию локальных адресов Source, показанную на рис. 1:

  1. Пользователь узла 1.1.1.1 открывает соединение с узлом В.
  2. Первый пакет, полученный маршрутизатором от узла 1.1.1.1 приводит к тому, что маршрутизатор начинает проверять таблицу NAT.
    • Если имеется статическая запись в таблице трансляции, то маршрутизатор переходит к пункту 3.
    • Если статической записи в таблице трансляции нет, то маршрутизатор определяет, что адрес узла-источника пакета (SA, Source Address) 1.1.1.1 должен транслироваться динамически. Далее маршрутизатор выбирает свободный глобальный адрес из пула адресов и создает в таблице запись о трансляции. Тип такой записи называется простая запись (Simple Entry).
  1. Маршрутизатор заменяет внутренний локальный адрес узла 1.1.1.1 на указанный в таблице трансляции глобальный адрес (2.2.2.2), а затем передает пакет во внешнюю сеть.
  2. Узел В получает пакет и отвечает узлу 1.1.1.1 используя внутренний глобальный адрес назначения (DA, Destination Address) 2.2.2.2.
  3. Когда маршрутизатор получает пакет с внутренним глобальным адресом, он сверяется с таблицей NAT, используя внутренний глобальный адрес в качестве ключа поиска. Далее происходит трансляция внутреннего глобального адреса во внутренний локальный адрес узла 1.1.1.1, и пакет передается узлу 1.1.1.1.
  4. Узел 1.1.1.1 получает этот пакет и продолжает взаимодействие с узлом В. Маршрутизатор осуществляет действия, описанные в пунктах 2 – 5, по отношению к каждому пакету.

Конфигурация статической трансляции

Для конфигурации статической трансляции необходимо выполнить следующие действия:

Действие | Команда
Установить режим статической трансляции между внутренним локальным адресом и внутренним глобальным адресом | ip nat inside source static <локальный адрес> <глобальный адрес>
Указать внутренний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети | ip nat inside
Указать внешний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети | ip nat outside

Показанный пример содержит лишь минимальные изменения в конфигурации маршрутизатора. При использовании нескольких внутренних и внешних интерфейсов необходимо аналогичные действия произвести и в отношении остальных интерфейсов.

Конфигурация динамической трансляции

Для конфигурации динамической трансляции необходимо выполнить следующие действия:

Действие | Команда
Определить пул глобальных адресов | ip nat pool <имя> <первый адрес> <последний адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить стандартный список доступа, регламентирующий адреса, подлежащие трансляции | access-list <номер> permit <адрес или блок адресов>
Установить динамическую трансляцию на основе списка доступа, определенного на предыдущем шаге | ip nat inside source list <номер списка доступа> pool <имя>
Указать внутренний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети | ip nat inside
Указать внешний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети | ip nat outside

Замечание. Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

Представленный ниже пример транслирует все адреса узлов-источников, определенных списком доступа 1 (разрешены адреса от 192.168.1.0/24), в пул адресов, названный net-208. Этот пул содержит адреса с 171.69.233.208 по 171.69.233.233.

ip nat pool net-208 171.69.233.208 171.69.233.233 netmask 255.255.255.240

ip nat inside source list 1 pool net-208

!

interface serial 0

ip address 171.69.232.182 255.255.255.240

ip nat outside

!

interface ethernet 0

ip address 192.168.1.94 255.255.255.0

ip nat inside

!

access-list 1 permit 192.168.1.0 0.0.0.255

Использование одного внутреннего глобального адреса

Существует возможность экономии пула внутренних глобальных адресов путем разрешения маршрутизатору использовать один глобальный адрес для трансляции нескольких локальных адресов. Если используется такой вариант конфигурации, то маршрутизатор использует информацию протоколов более высокого уровня (например, TCP и UDP) для обратной трансляции глобального адреса в корректные локальные адреса. При использовании соответствия нескольких локальных адресов одному глобальному адресу номера портов TCP или UDP каждого внутреннего узла указывают на локальные адреса этих узлов.

На рис. 2 показан принцип работы NAT, когда один внутренний глобальный адрес представляет несколько внутренних локальных адресов. Порты TCP используются в качестве критерия принадлежности пакетов тому или иному локальному адресу.

Рис. 2. Использование одного внутреннего глобального адреса

Ниже показан процесс, выполняемый маршрутизатором в сети на рис. 2. Узлы В и С обращаются к одному узлу 2.2.2.2. На самом же деле они общаются с разными узлами во внутренней сети. Разделителем адресов этих узлов служит номер порта TCP. Фактически получается, что довольно большое количество внутренних узлов могут разделять один внутренний глобальный адрес IP, используя для этого разные порты TCP.

  1. Пользователь узла 1.1.1.1 открывает соединение с узлом В.
  2. Первый пакет, получаемый маршрутизатором от узла 1.1.1.1 приводит к тому, что маршрутизатор начинает проверку таблицы NAT.

    3. Если в таблице нет записей о трансляции, то маршрутизатор определяет, что адрес 1.1.1.1 должен быть транслирован, и устанавливает трансляцию внутреннего локального адреса 1.1.1.1 в имеющийся глобальный адрес. Если включен режим использования одного внутреннего глобального адреса и в настоящий момент работает другая процедура трансляции, то маршрутизатор забирает у этой процедуры данный глобальный адрес, обеспечивая при этом сохранение всей необходимой для обратной трансляции информации. Такой тип записи называется расширенной записью (Extended Entry).

  3. Маршрутизатор заменяет внутренний локальный адрес 1.1.1.1 выбранным глобальным адресом и осуществляет передачу пакета во внешнюю сеть.
  4. Узел В получается этот пакет и отвечает узлу 1.1.1.1, используя внутренний глобальный адрес 2.2.2.2.
  5. При получении из внешней сети пакета с внутренним глобальным адресом 2.2.2.2 маршрутизатор производит просмотр таблицы NAT, используя тип протокола, внутренний глобальный адрес и порт, а также внешний адрес и порт в качестве ключа поиска. После этого производится обратная трансляция адреса в локальный адрес 1.1.1.1, и пакет передается узлу 1.1.1.1.
  6. Узел 1.1.1.1 получает этот пакет и продолжает взаимодействие. Маршрутизатор производит действия, описанные в пунктах 2 – 5 для каждого проходящего пакета.

Для конфигурирования режима использования одного внутреннего глобального адреса необходимо выполнить следующие шаги:

Действие | Команда
Определить пул глобальных адресов | ip nat pool <имя> <первый адрес> <последний адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить стандартный список доступа | access-list <номер> permit <внутренний адрес или блок адресов>
Установить режим динамической трансляции адресов, разрешенных в списке доступа, определенном на предыдущем шаге | ip nat inside source list <номер списка доступа> pool <имя> overload
Указать внутренний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети | ip nat inside
Указать внешний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети | ip nat outside

Замечание. Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

Приведенный ниже пример создает пул адресов, названный net-208. Данный пул содержит адреса с 171.69.233.208 по 171.69.233.233. Список доступа 1 разрешает пакеты, имеющие адрес отправителя с 192.168.1.0 по 192.168.1.255. Если в данный момент не производится процедур трансляции, то адреса в пакетах, соответствующих условиям списка доступа 1, транслируются в адрес из указанного пула. Маршрутизатор позволяет нескольким внутренним адресам (с 192.168.1.0 по 192.168.1.255) использовать один глобальный адрес. Для определения того или иного соединения маршрутизатор использует номера портов.

ip nat pool net-208 171.69.233.208 171.69.233.233 netmask 255.255.255.240

ip nat inside source list 1 pool net-208 overload

!

interface serial0

ip address 171.69.232.182 255.255.255.240

ip nat outside

!

interface ethernet0

ip address 192.168.1.94 255.255.255.0

ip nat inside

!

access-list 1 permit 192.168.1.0 0.0.0.255

Трансляция перекрывающихся адресов

В описании NAT говориться, что данные функции используются для трансляции адресов IP, которые не являются официально зарегистрированными или закрепленными за определенными узлами или подсетями. Однако, может сложиться такая ситуация, при которой внутри корпоративной сети будет использоваться пространство адресов, официально закрепленное за другой сетью. Ситуация, при которой один и тот же адрес используется как легальный и как нелегальный одновременно, называют перекрыванием (Overlapping). Функции NAT можно использовать с целью трансляции внутренних адресов, перекрывающихся с внешними адресами. Этот режим NAT используется в случаях, когда одна сеть использует адресное пространство другой, и в то же время необходимо организовать взаимодействие этих двух сетей.

На рис. 3 показана работа NAT в режиме трансляции перекрывающихся адресов.

Рис. 3. Трансляция перекрывающихся адресов

При таком режиме маршрутизатор выполняет действия, показанные ниже:

  1. Пользователь узла 1.1.1.1 открывает соединение с узлом С по имени, полученном от сервера DNS.
  2. Маршрутизатор перехватывает ответ сервера DNS и транслирует возвращаемый адрес, если имеет место перекрывание (это приводит к тому, что легальный адрес становится нелегальным во внутренней сети). Для обеспечения трансляции маршрутизатор создает простую запись трансляции, которая устанавливает соответствие между перекрывающимся адресом 1.1.1.3 и адресом из предварительно сконфигурированного пула внешних локальных адресов.

    3. Маршрутизатор отслеживает все ответы сервера DNS, обеспечивая таким образом отсутствие внешнего локального адреса во внутренней сети. Если такая ситуация имеет место быть, то маршрутизатор транслирует данный адрес.

  3. Узел 1.1.1.1 открывает соединение с узлом 3.3.3.3.
  4. Маршрутизатор настраивает соответствие внутренних локальных и глобальных адресов, а также внешних локальных и глобальных адресов.
  5. Маршрутизатор заменяет адрес источника на внутренний глобальный адрес и адрес получателя на внешний глобальный адрес.
  6. Узел С получает пакет и продолжает взаимодействие.
  7. Маршрутизатор производит определение и замену адреса получателя на внутренний локальный адрес и адреса отправителя на внешний локальный адрес.
  8. Узел 1.1.1.1 получает пакет и продолжает взаимодействие, используя процесс трансляции адресов.

Конфигурирование статической трансляции

Для конфигурирования статической трансляции внешних адресов узлов-отправителей, необходимо выполнить следующие шаги:

Действие | Команда
Установить статическую трансляцию между внешним локальным адресом и внешним глобальным адресом | ip nat outside source static <глобальный адрес> <локальный адрес>
Указать внутренний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети | ip nat inside
Указать внешний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети | ip nat outside

Конфигурирование динамической трансляции

Для конфигурирования динамической трансляции внешних адресов узлов-отправителей, необходимо выполнить следующие шаги:

Действие | Команда
Определить пул локальных адресов | ip nat pool <имя> <начальный адрес> <конечный адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить стандартный список доступа | access-list <номер> permit <локальный адрес или блок адресов>
Установить динамическую трансляцию внешних адресов узлов-отправителей, основанную на списке доступа, определенном на предыдущем шаге | ip nat outside source list <номер списка доступа> pool <имя>
Указать внутренний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети | ip nat inside
Указать внешний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети | ip nat outside

Замечание. Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

В приведенном ниже примере адреса в локальной сети используются кем-то еще в качестве легальных адресов Интернет. Во внешней сети необходимо производить дополнительную трансляцию. Пул net-10 является пулом внешних локальных адресов IP. Выражение ip nat outside source list 1 pool net-10 транслирует адреса узлов из внешней перекрывающейся сети в адреса данного пула.

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28

ip nat pool net-10 10.0.1.0 10.0.1.255 prefix-length 24

ip nat inside source list 1 pool net-208

ip nat outside source list 1 pool net-10

!

interface serial 0

ip address 171.69.232.192 255.255.255.240

ip nat outside

!

interface ethernet0

ip address 192.168.1.94 255.255.255.0

ip nat inside

access-list 1 permit 192.168.1.0 0.0.0.255

Обеспечение распределения нагрузки TCP

Другая сфера применения NAT не относится к использованию адресов Интернет. Допустим, что организация имеет множество узлов, которые должны подключаться к одному узлу, характеризующемуся высокой степенью загрузки запросами пользователей. Используя NAT можно организовать виртуальный узел во внутренней сети, который будет координировать разделение нагрузки между реальными узлами сети. Адреса узлов назначения, совпадающие с условиями списка доступа, заменяются на адреса из постоянно перебираемого пула. Выбор адреса осуществляется по механизму round-robin, причем такой выбор производится только при установлении нового соединения из внешней сети во внутреннюю. Трафик “не-ТСР” передается без изменений. Эта функция показана на рис. 4.

Рис. 4. Распределение нагрузки ТСР

Маршрутизатор выполняет следующие действия при переборе адресов:

  1. Пользователь узла В (9.6.7.3) открывает соединение с виртуальным узлом 1.1.1.127.
  2. Маршрутизатор получает пакет с запросом на подключение и создает новую запись трансляции, выбирая для нее новый реальный узел (1.1.1.1) в качестве внутреннего локального адреса IP.
  3. Маршрутизатор заменяет адрес назначения выбранным адресом реального узла и передает пакет.
  4. Узел 1.1.1.1 получает пакет и формирует ответ на него.
  5. Маршрутизатор получает ответный пакет и просматривает таблицу NAT, используя в качестве ключа поиска внутренний локальный адрес и номер порта. Маршрутизатор транслирует адрес источника в адрес виртуального узла и передает пакет по сети.

Следующий запрос на соединение вынуждает маршрутизатор выбирать адрес 1.1.1.2 в качестве внутреннего локального адреса.

Для конфигурирования этого режима использования функций NAT необходимо произвести приведенные ниже шаги. Эта функция NAT позволяет устанавливать соответствие между одним виртуальным узлом и множеством реальных узлов сети. Каждая новая сессия ТСР открывает новый виртуальный узел. Эта сессия будет транслироваться как сессия с другим реальным узлом.

Действие | Команда
Определить пул адресов, состоящий из адресов реальных узлов | ip nat pool <имя> <начальный адрес> <конечный адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить список доступа, разрешающий адрес виртуального узла | access-list <номер> permit <адрес назначения или группа адресов>
Установить динамическую внутреннюю трансляцию адресов назначения на основе вписка доступа, определенного на предыдущем шаге | ip nat inside destination list <номер списка доступа> pool <имя>
Указать внутренний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети | ip nat inside
Указать внешний интерфейс | interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети | ip nat outside

Замечание. Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

В приведенном ниже примере основной целью определения виртуального адреса является то, что все соединения распределяются между несколькими реальными узлами. Пул адресов определяет эти узлы. Список доступа определяет виртуальный адрес. Если в данный момент нет процедуры трансляции, то пакет ТСР с интерфейса Serial 0 (внешний интерфейс), адрес назначения которого удовлетворяет условиям списка доступа, транслируется в один из адресов адресного пула.

ip nat pool real-hosts 192.168.15.2 192.168.15.15 prefix-length 28 type rotary

ip nat inside destination list 2 pool real-hosts

!

interface serial 0

ip address 192.168.15.129 255.255.255.240

ip nat outside

!

interface ethernet 0

ip address 192.168.15.17 255.255.255.240

ip nat inside

!

access-list 2 permit 192.168.15.1

Изменение тайм-аутов трансляции

По умолчанию динамическая трансляция адресов периодически не используется. При необходимости можно изменить значение тайм-аута, после которого используемые адреса трансляции будут освобождаться для других нужд. Если не сконфигурирован режим использования одного глобального адреса для нескольких локальных адресов (overloading), то время действия простых записей трансляции составляет 24 часа. Для изменения значения тайм-аута необходимо выполнить следующие шаги:

Действие | Команда
Изменить значение тайм-аута для динамической трансляции адресов. Режим overloading не используется. | ip nat translation timeout <значение в секундах>

Если используется режим overloading, то управление тайм-аутами производится более тонко в связи с тем, что каждая запись трансляции определяет тип трафика, используемый указанными в записи узлами. Команды по изменению значений тайм-аутов выглядят следующим образом:

Действие | Команда
Изменение значения тайм-аута UDP (по умолчанию 5 минут) | ip nat translation udp-timeout <значение в секундах>
Изменение значения тайм-аута DNS (по умолчанию 1 минута) | ip nat translation dns-timeout <значение в секундах>
Изменение значения тайм-аута TCP (по умолчанию 24 часа) | ip nat translation tcp-timeout <значение в секундах>
Изменение значения тайм-аута Finish и Reset (по умолчанию 1 минута) | ip nat translation finrst-timeout <значение в секундах>

Мониторинг и сопровождение NAT

По умолчанию таблица динамической трансляции адресов со временем очищается автоматически. Однако, имеется возможность проведения работ по мониторингу и сопровождению NAT с консоли управления маршрутизатором:

Действие | Команда
Очистить все записи динамической трансляции адресов из таблицы NAT | clear ip nat translation *
Очистить простую запись динамической трансляции, содержащей информацию либо о внутренней трансляции, либо о внутренней и внешней трансляции | clear ip nat translation inside <глобальный адрес> <локальный адрес> [outside <локальный адрес> <глобальный адрес>]
Очистить простую запись динамической трансляции, содержащую информацию о внешней трансляции | clear ip nat translation outside <локальный адрес> <глобальный адрес>
Очистить расширенную запись динамической трансляции | clear ip nat translation <протокол> inside <глобальный адрес> <глобальный порт> <локальный адрес> <локальный порт> [outside <локальный адрес> <локальный порт> <глобальный адрес> <глобальный порт>]

Просмотреть текущее состояние NAT можно при помощи следующих команд:

Действие | Команда
Показать активные трансляции | show ip nat translations [verbose]
Показать статистику трансляций | show ip nat statistics

Plus Networking Academy

Россия, Москва, 1-й Хвостов переулок 11А
Tel: +7 (095) 238-3711, -3777, -3977, -5343
+7 (095) 777-0-111, 777-0-222
Fax: +7 (095) 238-3989
E-mail: info@pluscom.ru

© 1996-2000 Plus Communications